DoubleTake.Web.Models Namespace

Double-Take REST SDK 8.1.1
DoubleTake.Web.Models Namespace
Classes
 | Class | Description
Public class | AccessLevelModel | Data access model used to obtain the user's access level.
Public class | AceModel | ACE model.
Public class | ActionInputFlatModel | Represents input into a monitor action.
Public class | ActionInputModel | Represents input into a monitor action.
Public class | ActionResultFlatModel | Represents the result of a monitor action.
Public class | ActionResultModel | Represents the result of a monitor action.
Public class | ActivationAttributeModel | Activation attribute model.
Public class | ActivationCodeInfoModel | Activation code information on appliance for V2V push install
Public class | ActivationCodeModel | Activation code model.
Public class | ActivationParametersModel | Activation parameters query model.
Public class | ActivationStatusModel | Activation status model.
Public class | ActivityStatusModel | Activity status model.
Public class | ActivityTokenModel | Activity token model.
Public class | AddressPersistedStateModel | Address persisted state.
Public class | ApplicationOptionsModel | Application options model.
Public class | ArchiveCriteriaModel | Archive criteria model.
Public class | ArchiveScheduleModel | Archive schedule model.
Public class | BackConnectionResultsModel |
Public class | BandwidthEntryModel | Bandwidth entry model.
Public class | BandwidthLimitModel | Used for specifying the current or new bandwidth limit and/or mode.
Public class | BandwidthOptionsModel | Bandwidth options model.
Public class | BandwidthScheduleEntryModel | Bandwidth schedule entry model.
Public class | BandwidthScheduleModel | Bandwidth schedule model.
Public class | BandwidthSpecificationModel | Bandwidth specification model.
Public class | BooleanSettingModel | Boolean setting.
Public class | ChangedItemsModel | Changed items model.
Public class | CloudOptionsModel | Cloud options model.
Public class | ClusteredVirtualMachineModel | A clustered VM
Public class | ClusteredVirtualMachineResourceInfoModel | Clustered virtual machine resource information.
Public class | ClusteredVirtualMachinesInfoModel | Clustered VM Groups
Public class | ClusterFilesAndFoldersQualificationResultsModel | Cluster files and folders qualification results model.
Public class | ClusterGroupInfoModel | Cluster group information.
Public class | ClusterOptionsModel | Cluster options model.
Public class | ClusterResourceInfoModel | Cluster resource information.
Public class | CompositeActionInputModel | Represents the input to a Composite action agent.
Public class | CompositeActionResultModel | Represents the results of a composite action.
Public class | CompositeQueryInputModel | Represents the input to a Composite query agent.
Public class | CompositeQueryResultModel | Represents the results of a composite query.
Public class | CompressionLevelModel | Compression level model.
Public class | ConnectionConfigurationModel | Connection configuration model.
Public class | ConnectionInfoModel | Connection information.
Public class | ConnectionParametersModel | Connection parameters.
Public class | ConnectionQualificationResultModel | Connection qualification result.
Public class | ConnectionScheduleModel | Connection schedule model.
Public class | ConnectionStartParametersModel | Connection start parameters model.
Public class | ConnectionStatisticsModel | Connection statistics.
Public class | ConnectionStatusModel | The connection status model.
Public class | ControlledServerInfoModel | Represents information about a server managed by Controller Service
Public class | ControlledServerInfoSimpleModel | Represents information about a server managed by Controller Service
Public class | CoreClusterInfoModel | Data specific to the cluster. This is data that stays with the cluster during roll-over.
Public class | CoreConnectionDetailsModel | Core connection details model.
Public class | CoreConnectionOptionsModel | Core connection options model.
Public class | CoreConnectionPersistedStateModel | The core connection persisted state.
Public class | CoreMonitorDetailsModel | Core monitor details model.
Public class | CoreMonitorOptionsModel | Core monitor options model.
Public class | CoreQualificationResultsModel | Core qualification results model.
Public class | CreateConnectionModel | This class represents the parameters passed into the api/connections/create call
Public class | CreateDelegateWorkloadModel | Parameters used in the CreateFromWithDelegation call
Public class | CreateFromExistingJobModel | Contains the information needed to create a new job from and existing job.
Public class | CreateOptionsModel | Create options model.
Public class | CreateRepsetRequestModel | Create repset request.
Public class | CredentialModel | Credential model
Public class | CutoverDetailsModel | Cut over details model.
Public class | DeleteJobRequestModel | Delete job request model.
Public class | DeleteOptionsModel | Delete options.
Public class | DiagnosticsPersistedStateModel | Diagnostics persisted state.
Public class | DirectoryItemModel | Directory item model.
Public class | DiskLayoutInitializeModel | Disk layout initialize.
Public class | DiskLayoutModel | Describes how a disk is to be partitioned and formatted. The DiskIdentifier is used to identify the disk to be partition. The Partitioning Scheme identifies if the disk is to use GPT or MBR. The array of PartitionInitializationInfo structures identifies how many partitions, what size and format they should have and other things.
Public class | DiskLayoutResultModel | Disk layout extraction result from a source system state scrape.
Public class | DiskLayoutStatusResultModel | Disk layout status result.
Public class | DiskLayoutVerifyResultsModel | Results of disk layout verification.
Public class | DiskLayoutWithEnvironmentModel | Disk layout environment constraints.
Public class | DiskModel | Represents a disk for the server.
Public class | DiskOptionsModel | Represents a disk for the server.
Public class | DiskPartitionLayoutModel | Disk partition layout model.
Public class | DnsDomainDetailsModel | DNS domain details model.
Public class | DnsDomainDetailsPrototypeModel | DNS domain details prototype model.
Public class | DnsOptionsModel | DNS options model.
Public class | DnsRecordLockOptionsModel | DNS record lock options model.
Public class | DnsServerDetailModel | DNS server detail model.
Public class | DTAVPersistedStateModel | DTAV persisted state.
Public class | DTHVPersistedStateModel | DTHV persisted state.
Public class | DtInfoCollectionStatusModel | DTInfo collection status.
Public class | DtmuActivationStatusModel | DTMU activation status.
Public class | DtmuConfigurationModel | DTMU configuration model.
Public class | DtmuProductModel | DTMU product model.
Public class | DtscStatusQueryInputModel | Inputs for a DtscStatus monitor
Public class | DtscStatusQueryResultModel | Represents the results of a Dtsc status query.
Public class | DTTargetResourceQueryInputModel | The Input parameters to monitor a resource on a Target machine
Public class | DynamicServiceEndpointModel | Dynamic service endpoint model.
Public class | EmailNotificationSettingsModel | Email notification settings model
Public class | EmailNotificationTestParametersModel | Email notification test parameters.
Public class | EmailOptionsModel | Email options model.
Public class | EmailTestModel | Email test model.
Public class | EngineControlStatusModel | Engine control status model.
Public class | ErrorInfoModel | Represents job error properties.
Public class | ESXInfoModel | This class represents the general information about an ESX server.
Public class | EventLogModel | Event log model.
Public class | ExtendedLowLevelStateModel | Extended low level state model.
Public class | FailbackOptionsModel | Failback options model.
Public class | FailoverOptionsModel | Failover options model.
Public class | FailoverPersistedStateModel | Failover persisted state.
Public class | FailoverReport | Failover report information.
Public class | FailoverReportingModel | Failover reporting data model
Public class | FailoverReportMachineInfoModel | Data about the target machine
Public class | FailoverReportTimesModel | Time at various points of the failover.
Public class | FailoverScriptConfigurationModel | Failover script configuration model.
Public class | FeatureModel | Feature model.
Public class | FileItemModel | File item model.
Public class | FilesAndFoldersPersistedStateModel | Files and Folders persisted state.
Public class | FixJobOptionsRequestModel | Fix job options request model.
Public class | FixJobOptionsStatusModel | Fix job options model.
Public class | FixRecommendedJobOptionsRequestModel | Fix recommended job options request model.
Public class | FullServerFailoverOptionsModel | Full server failover options model.
Public class | FullServerJobDetailsModel | Full server job details.
Public class | FullServerNicMappingsModel | Full server NIC mappings model.
Public class | FullServerPersistedStateModel | Full server persisted state.
Public class | FullServerTestFailoverOptionsModel | Full server test failover options model.
Public class | HeartbeatPingQueryInputModel | Represents the input to a Double-Take heartbeat ping query agent.
Public class | HeartbeatPingQueryResultModel | Represents the results of a heartbeat ping query.
Public class | IcmpPingQueryInputModel | Represents the input to an ICMP ping query agent.
Public class | IcmpPingQueryResultModel | Represents the results of an ICMP ping query.
Public class | ImageDeleteInfoModel | Image delete info model.
Public class | ImageDeleteInfosModel | Image delete infos model.
Public class | ImageInfoModel | Image info model.
Public class | ImageProtectionJobDetailsModel | Image protection job details model.
Public class | ImageProtectionOptionsModel | Image protection options model.
Public class | ImageProtectionPersistedStateModel | Image protection persisted state.
Public class | ImageRecoveryJobDetailsModel | Image recovery job details model.
Public class | ImageRecoveryOptionsModel | Image recovery options model.
Public class | ImageRecoveryPersistedStateModel | Image recovery persisted state.
Public class | ImageVhdInfoModel | Image VHD info model.
Public class | IntegerSettingModel | Integer setting.
Public class | IPAddressModel | IP address.
Public class | JobActionModel | Job action model.
Public class | JobCredentialsModel | Job credentials model.
Public class | JobInfoModel | Job info model.
Public class | JobInfoPrivateModel | Used for storing the status information for a job. It tells you whether or not the job is started. If it is started, it provides the status information for each connection that is associated with this job.
Public class | JobOptionsModel | Job options model.
Public class | JobParametersModel | Job parameters.
Public class | JobQualificationResultsModel | Job qualification results model.
Public class | JobStateModel | Represents job state information.
Public class | JobStatisticsModel | Job statistics model.
Public class | JobStatusModel | Job status model.
Public class | JobUsageDataModel | Job usage data.
Public class | LinuxJobPersistedStateModel | Linux job persisted state.
Public class | LinuxJobStateFlagModel | String representation of a JobStateFlag, defined privately by the Linux job implementation
Public class | LinuxJobStateFlagStackLevelModel | Linux job state flag stack level.
Public class | LinuxJobStateFlagStackModel | A stack levels containing LinuxJobStateFlag values, as managed privately by the Linux job implementation. Each level in the stack is contains an array of one or more JobStateFlag values.
Public class | LogActionInputModel | Represents the input to a log action.
Public class | LogicalItemModel | Logical item model.
Public class | LogicalVolumeModel | Logical volume model.
Public class | LogMessageModel | Log message model.
Public class | LvmOptionsModel | Lvm options model.
Public class | MachineInfoClassModel | Data about the target machine
Public class | MachineInfoModel | Machine info model.
Public class | MirrorParametersModel | Mirror parameters model.
Public class | ModifyReplicationSetRulesRequestModel | Modify replication set rules request.
Public class | MonitorableAddressInfoModel | Used to specify a monitorable IP address that can be used to configure a failover monitor.
Public class | MonitorActionFlatModel | Represents an action that is run in the context of a monitor.
Public class | MonitorActionModel | Represents an action that is run in the context of a monitor.
Public class | MonitorConfigurationModel | Monitor configuration model.
Public class | MonitoredAddressConfigurationModel | Monitored address configuration model.
Public class | MonitoredAddressStatusModel | Monitored address status.
Public class | MonitorInfoModel | Monitor information.
Public class | MonitoringOptionsModel | Monitoring options model.
Public class | MonitorQualificationResultModel | An instance of this class is returned from a QualifyMonitor operation on the ICoreService service.
Public class | MonitorQueryFlatModel | Monitor query flat.
Public class | MonitorQueryModel | This class is part of the MonitorActivity class which contains both query and action.
Public class | MonitorStatusModel | Monitor status.
Public class | MultiStringSettingModel | Multi-string setting.
Public class | NamedSettingModel | Named setting.
Public class | NetworkAddressMapModel | Network address map model.
Public class | NetworkInterfaceInfoModel | Network interface info model.
Public class | NetworkInterfaceModel | Network interface model.
Public class | NicMappingsModel | NIC mapping.
Public class | OperatingSystemModel | Operating system model.
Public class | OperatingSystemVersionModel | Operating system version model.
Public class | OptionModel | Option model.
Public class | OptionRequestModel | Options request.
Public class | OptionValueModel | Options value.
Public class | OrphansScheduleModel | Orphans schedule model.
Public class | PartitionModel | Represents a partition info for a volume.
Public class | PathBlockingEntryModel | A path blocking entry.
Public class | PathTransformationModel | Path transformation model.
Public class | PerformanceCounterQueryInputModel | Represents the input to a performance counter query.
Public class | PerformanceCounterQueryResultModel | Represents the results of a Performance Counter Query
Public class | PhysicalItemFlatModel | Represents a physical storage item such as Volume, Directory, File
Public class | PhysicalItemModel | Physical item model.
Public class | PhysicalRuleModel | Physical rule model.
Public class | PhysicalRulesModel | Physical rules model
Public class | PhysicalVolumeModel | Physical volume model.
Public class | PITSnapshotRecordModel | PIT snapshot record.
Public class | ProductInfoModel | Product info model.
Public class | ProductVersionModel | Product version model.
Public class | PropertyModel | Represents an association between a name and another string
Public class | ProtectableItemModel | Protectable item model.
Public class | QueryInputFlatModel | Query input flat.
Public class | QueryInputModel | Represents arguments to a monitoring query.
Public class | QueryResultFlatModel | Represents the result of a monitoring query.
Public class | QueryResultModel | Represents the result of a monitoring query.
Public class | QueueTaskParametersModel | Queue task parameters.
Public class | RecommendedFailbackOptionsModel | Recommended failback options model.
Public class | RecommendedFailoverOptionsModel | Recommended failover options model.
Public class | RecommendedJobOptionsModel | Recommended job options model.
Public class | RecommendedJobOptionsRequestModel | Recommended job options request model.
Public class | RecommendedRestoreOptionsModel | Recommended restore options.
Public class | ReplicationSetInfoModel | Replication set information.
Public class | ReplicaVmInfoModel | Replica VM info model.
Public class | ResourceAndPassiveNodesModel | Resource and passive nodes.
Public class | RestoreOptionsModel | Restore options model.
Public class | RestoreParametersModel | Restore parameters model.
Public class | RunScriptRequestModel | Run script request model.
Public class | ScheduleItemModel | Schedule item model.
Public class | ScriptActionInputModel | Represents the input to execute a script
Public class | ScriptActionResultModel | Represents the results of a Script action.
Public class | ScriptPointModel | Script point model.
Public class | ScriptQueryInputModel | Defines the input into the script query.
Public class | ServerInfoModel | Server info model.
Public class | ServerQualificationResultsModel | Server qualification results model.
Public class | ServiceConnectionModel | Service connection model.
Public class | ServiceInfoModel | Service information.
Public class | ServiceInformationModel | Service information model.
Public class | ServiceMetadataModel | Service metadata.
Public class | ServiceMonitoringOptionsModel | Service monitoring options model.
Public class | ServiceOperationActionInputModel | The inputs for a Service operation
Public class | ServiceOperationActionResultModel | Represents the result of a service operation action.
Public class | ServiceStatusQueryInputModel | Represents the input to a service query
Public class | ServiceStatusQueryResultModel | Represents the results of a Service Status Query
Public class | ServicesToStopModel | Services to stop.
Public class | ShareModel | Share model.
Public class | ShareQueryInputModel | The inputs required for a share monitor
Public class | ShareQueryResultModel | Represents the results of a share query.
Public class | SimpleFailoverMonitorOptionsModel | Simple failover monitor options model.
Public class | SnapshotEntryModel | Snapshot entry model.
Public class | SnapshotScheduleModel | Snapshot schedule model.
Public class | SqlDatabasePersistedInfoModel | SQL database persisted information.
Public class | StorageInfoModel | Core.StorageInfo
Public class | StringSettingModel | String setting.
Public class | SwitchPortInfoModel | Switch port info.
Public class | SystemStateConfigurationModel | Holds the system state definitions for both the source and target
Public class | SystemStateCutoverStatusModel | System state cutover status.
Public class | SystemStateDefinitionModel | System state definition.
Public class | SystemStateDumpNonDiskSystemStateInfoStatusModel | System state dump non-disk system state information.
Public class | SystemStateOptionsModel | System state options model.
Public class | SystemStatePathModel | System state path.
Public class | SystemStatePropertyValueModel | System state property.
Public class | SystemStateVerificationResultModel | System state verification result.
Public class | SystemStateVerificationStepModel | System state verification step.
Public class | TargetFileServerQualificationResultsModel | Target file server qualification results model.
Public class | TargetServicesOptionsModel | Target services options model.
Public class | TargetServicesToStopModel | Target services to stop model.
Public class | TargetStateInfoModel | Target state info model.
Public class | TaskParametersModel | Specifies a script or executable to be run along with its corresponding command-line arguments.
Public class | TestFailoverOptionsModel | Test failover options model for VRA.
Public class | TestFailoverServerCredentialModel | Full server test failover options model.
Public class | TestScriptRequestModel | Test script request model
Public class | TimesClassModel | Time at various points of the failover.
Public class | TimeWindowModel | Time window model.
Public class | TransmissionScheduleModel | Transmission schedule model.
Public class | UnicastIPAddressModel | Unicast IP address model.
Public class | UnicastNetworkAddressInfoModel | Unicast network address info model.
Public class | UnmanagedConnectionOptionsModel | Unmanaged connection options model.
Public class | UpdateCredentialsModel | Information required to update the credentials for a job
Public class | UpdateRecommendedJobOptionsRequestModel | Update recommended job options request model.
Public class | UsageDataModel | Usage data.
Public class | UVRAPersistedStateModel | UVRA persisted state.
Public class | UVRAVolumePersistedStateModel | UVRA volume persisted state.
Public class | V2VVirtualMachineModel | Describes a virtual machine to be protected by the V2V feature.
Public class | VcdVappOptionsModel | Vcd vapp options model.
Public class | VerificationStatusModel | Verification status model.
Public class | VerificationStepModel | Verification step model.
Public class | VerifyJobOptionsRequestModel | Verify job options request model.
Public class | VerifyScheduleModel | Verify schedule model.
Public class | VHDMappingModel | Represents source and target VHD mappings
Public class | VirtualizationConnectionInfoModel | Virtualization connection information.
Public class | VirtualMachineResourceInfoModel | Virtual machine resource information.
Public class | VirtualNetworkInterfaceInfoModel | Virtual network interface info model.
Public class | VirtualSwitchConfigQueryInputModel | Inputs for a Virtual Switch monitor
Public class | VirtualSwitchConfigQueryResultModel | Represents the results of a Virtual Switch config query.
Public class | VirtualSwitchInfoModel | Virtual switch info model
Public class | VirtualSwitchMappingModel | Virtual switch mapping model.
Public class | VmCfgSimpleInfoModel | VM configuration simple information.
Public class | VmConfigQueryInputModel | Query inputs for monitoring a VmConfig
Public class | VmConfigQueryResultModel | Represents the results of a Vm config query
Public class | VmdkInfoModel | VMDK information.
Public class | VmHealthQueryInputModel | Query input for monitoring the health of a vm
Public class | VmHealthQueryResultModel | Represents the results of a Vm health query
Public class | VmInfoModel | Vm info model.
Public class | VolumeGroupModel | Volume group model.
Public class | VolumeModel | Volume model.
Public class | VolumeOptionsModel | Volume options model.
Public class | VolumeQualificationResultsModel | Volume qualification results model.
Public class | VRAInternalVirtualNetworkInterfaceInfoModel | VRA internal virtual network interface information.
Public class | VraOptionsModel | Vra options model.
Public class | VraQualificationResultsModel | Vra qualification results model.
Public class | VRAVolumePersistedStateModel | VRA volume persisted state.
Public class | VraWorkloadCustomizationOptionsModel | Vra workload customization options model.
Public class | WinServiceInfoModel | Service information.
Public class | WorkloadModel | Workload model.
Public class | WorkloadSupportSummaryModel | Workload support summary model.
Public class | WorkloadTypeModel | Workload type model.
Public class | WorkloadTypesActivationStatusModel | Contains information required to get the available workload types by using the activation status of the source and target
Enumerations
 | Enumeration | Description
Public enumeration | AccessLevel | Represents the resulting access level when credentials are provided to the engine service.
Public enumeration | AceFlags | ACE flags.
Public enumeration | ActionStatus | Action status.
Public enumeration | ActiveDirectoryFailoverOptions | ActiveDirectory failover options.
Public enumeration | ActivityCompletionStatus | Activity completion status.
Public enumeration | ArchiveRestoreOption | Archive restore option.
Public enumeration | BandwidthEntryType | Bandwidth entry type.
Public enumeration | BandwidthScheduleMode | Bandwidth schedule mode.
Public enumeration | BandwidthSpecificationType | Bandwidth specification type.
Public enumeration | ClusterResourceState | Cluster resource state.
Public enumeration | ComparisonOperationEnum | Represents the types of comparison operations.
Public enumeration | CompositeQueryOperationEnum | Defines how to evaluate a composite query.
Public enumeration | ConnectionModeEnum | Connectio nmode.
Public enumeration | ConnectionQualificationFailuresEnum | Connection qualification failures
Public enumeration | ControlOperationEnum | Control operation.
Public enumeration | CoreClusteredResourceStateEnum | Core clustered resource state
Public enumeration | DesktopInteractionMode | Desktop interaction mode.
Public enumeration | DiskConfigStrategy | Disk configuration strategy for the replica
Public enumeration | DriveTypeEnum | Drive type
Public enumeration | DtInfoCollectionProgressEnum | Double-Take information collection progress
Public enumeration | DtmuJobStatusEnum | DTMU job status
Public enumeration | EmailNotificationCategoriesEnum | Email notification categories
Public enumeration | EngineJobType | Engine job type.
Public enumeration | FailoverAddressesOption | Failover addresses option.
Public enumeration | FailoverDataAction | Failover data action.
Public enumeration | FailoverItems | Failover items.
Public enumeration | FailoverMode | Failover mode.
Public enumeration | FailoverProcessingOptions | Failover processing options.
Public enumeration | FailoverReplaceActions | Failover replace actions.
Public enumeration | FailoverReportTypeEnum | Type of failover being used.
Public enumeration | FailoverStyle | Type of failover being used.
Public enumeration | FailoverTrigger | Failover trigger.
Public enumeration | FailoverType | Failover type.
Public enumeration | FileSystemAttributes | File system attributes
Public enumeration | FullServerJobTypeEnum | This enum is used during System State verification as well as rule generation of all full server job types. It is basically a wrapper for the SSMCLI::JobType enum class. It tells system state which rules and transform paths to generate, and/or validators to run. This has been around forever so the names are a little funky and don't really equate to the current job names. I have included what the current jobs should be using. For additional information, see Ed or Louie. Validation: -Move Server Migration job should use MoveServerMigration -All others should use FullServerProtection Rules and transforms: -Any job that is using a snapshot for recovery/failover/failback should use SnapshotMirror -A Full Server Failover job that has a DR image repository server as it's source should use ImageRepositoryFailover -All others should use FullServerProtection
Public enumeration | Health | Health.
Public enumeration | HighAvailabilityState | High availability state.
Public enumeration | HighLevelState | High level state.
Public enumeration | ImageType | The image type.
Public enumeration | InclusionMode | Inclusion mode.
Public enumeration | LicenseType | License type.
Public enumeration | MirrorComparisonCriteria | Mirror comparison criteria.
Public enumeration | MirrorOperationOptions | Mirror operation options.
Public enumeration | MirrorState | Mirror state.
Public enumeration | MonitorResultEnum | Monitor result
Public enumeration | OperatingSystemArchitecture | Operating system architecture.
Public enumeration | OperatingSystemProductType | Operating system product type.
Public enumeration | PathBlockingModeEnum | This value represents if the path is blocked.
Public enumeration | PingMethods | Ping methods.
Public enumeration | QueueStateEnum | The operational state of a queue.
Public enumeration | RebootActionEnum | An enumeration specifying the desired reboot behavior after a cutover.
Public enumeration | RecursionMode | Recursion mode.
Public enumeration | ReMonitorActionEnum | Used to specify the action to take after a failback has completed.
Public enumeration | ReplicationSetUsageType | Replication set usage type.
Public enumeration | ReplicationState | Replication state.
Public enumeration | RestoreOptions | Restore options.
Public enumeration | RestoreStates | Restore states.
Public enumeration | RestoreStatus | Restore status.
Public enumeration | SaturationLevel | Saturation level.
Public enumeration | ScriptExecutionMode | Script execution mode.
Public enumeration | ScriptPointType | Script point type.
Public enumeration | ServiceOperationEnum | Represents the different types of Windows service operations.
Public enumeration | ServicesStartModeEnum | Represents the startup mode of a Windows service.
Public enumeration | ShortNameBehaviorSettingEnum | Defines values of the system short name behavior setting
Public enumeration | ShutdownOptionEnum | Shutdown option
Public enumeration | SmtpConnectionSecurity | SMTP connection security.
Public enumeration | SnapshotAge | Snapshot age.
Public enumeration | SnapshotCreationReason | Snapshot creation reason.
Public enumeration | SnapshotQuality | Snapshot quality.
Public enumeration | SsmRecoveryType | SSM recovery type
Public enumeration | TargetServiceStatus | Target service status.
Public enumeration | TargetStates | Target states.
Public enumeration | TransmissionMode | Transmission mode.
Public enumeration | VerificationStatus | Verification status.
Public enumeration | VhdDeleteActionType | VHD delete action type.
Public enumeration | VmHealthEnum | VM health
Public enumeration | Weekdays | The Weekdays.
Public enumeration | WinServiceStartModeEnum | Service start mode


AccessLevel Enumeration

AccessLevel Enumeration
Represents the resulting access level when credentials are provided to the engine service.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum AccessLevel
Public Enumeration AccessLevel
public enum class AccessLevel
type AccessLevel
Members
Member name | Value | Description
Unknown | -1 | The access level is unknown.
NoAccess | 0 | The credentials are not authenticated.
MonitorOnlyAccess | 1 | This access level is associated with membership in the Double-Take Monitors or dtmon security group.
FullAccess | 2 | This access level is associated with membership in the Double-Take Admin or dtadmin security group.
See Also

Reference

DoubleTake.Web.Models Namespace


AccessLevelModel Class

AccessLevelModel Class
Data access model used to obtain the user's access level.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsAccessLevelModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class AccessLevelModel
Public NotInheritable Class AccessLevelModel
public ref class AccessLevelModel sealed
[<SealedAttribute>]
type AccessLevelModel =  class end

The AccessLevelModel type exposes the following members.

Constructors
 | Name | Description
Public method | AccessLevelModel | Initializes a new instance of the AccessLevelModel class
Top
Properties
 | Name | Description
Public property | AccessLevel | Gets or sets the user's access level.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


AccessLevelModel Constructor

AccessLevelModel Constructor
Initializes a new instance of the AccessLevelModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public AccessLevelModel()
Public Sub New
public:
AccessLevelModel()
new : unit -> AccessLevelModel
See Also

Reference

AccessLevelModel Class


AccessLevelModel Properties

AccessLevelModel Properties

The AccessLevelModel type exposes the following members.

Properties
 | Name | Description
Public property | AccessLevel | Gets or sets the user's access level.
Top
See Also

Reference

AccessLevelModel Class


AccessLevelModel.AccessLevel Property

AccessLevelModelAccessLevel Property
Gets or sets the user's access level.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public AccessLevel AccessLevel { get; set; }
Public Property AccessLevel As AccessLevel
    Get
    Set
public:
property AccessLevel AccessLevel {
    AccessLevel get ();
    void set (AccessLevel value);
}
member AccessLevel : AccessLevel with get, set

Property Value

Type: AccessLevel
See Also

Reference

AccessLevelModel Class


AccessLevelModel Methods

AccessLevelModel Methods

The AccessLevelModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AccessLevelModel Class


AceFlags Enumeration

AceFlags Enumeration
ACE flags.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum AceFlags
<FlagsAttribute>
Public Enumeration AceFlags
[FlagsAttribute]
public enum class AceFlags
[<FlagsAttribute>]
type AceFlags
Members
Member name | Value | Description
ObjectInheritAce | 1 | The object inherit ace
ContainerInheritAce | 2 | The container inherit ace
NoPropogateInheritAce | 4 | The no propagate inherit ace
InheritOnlyAce | 8 | The inherit only ace
InheritedAce | 16 | The inherited ace
See Also

Reference

DoubleTake.Web.Models Namespace


AceModel Class

AceModel Class
ACE model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsAceModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class AceModel
Public NotInheritable Class AceModel
public ref class AceModel sealed
[<SealedAttribute>]
type AceModel =  class end

The AceModel type exposes the following members.

Constructors
 | Name | Description
Public method | AceModel | Initializes a new instance of the AceModel class
Top
Properties
 | Name | Description
Public property | AccessMask | Gets or sets the access mask.
Public property | AceFlags | Gets or sets the ace flags.
Public property | AceType | Gets or sets the type of the ace.
Public property | Domain | Gets or sets the domain.
Public property | Name | Gets or sets the name.
Public property | Sid | Gets or sets the sid.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


AceModel Constructor

AceModel Constructor
Initializes a new instance of the AceModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public AceModel()
Public Sub New
public:
AceModel()
new : unit -> AceModel
See Also

Reference

AceModel Class


AceModel Properties

AceModel Properties

The AceModel type exposes the following members.

Properties
 | Name | Description
Public property | AccessMask | Gets or sets the access mask.
Public property | AceFlags | Gets or sets the ace flags.
Public property | AceType | Gets or sets the type of the ace.
Public property | Domain | Gets or sets the domain.
Public property | Name | Gets or sets the name.
Public property | Sid | Gets or sets the sid.
Top
See Also

Reference

AceModel Class


AceModel.AccessMask Property

AceModelAccessMask Property
Gets or sets the access mask.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int AccessMask { get; set; }
Public Property AccessMask As Integer
    Get
    Set
public:
property int AccessMask {
    int get ();
    void set (int value);
}
member AccessMask : int with get, set

Property Value

Type: Int32
The access mask.
See Also

Reference

AceModel Class


AceModel.AceFlags Property

AceModelAceFlags Property
Gets or sets the ace flags.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public AceFlags AceFlags { get; set; }
Public Property AceFlags As AceFlags
    Get
    Set
public:
property AceFlags AceFlags {
    AceFlags get ();
    void set (AceFlags value);
}
member AceFlags : AceFlags with get, set

Property Value

Type: AceFlags
The ace flags.
See Also

Reference

AceModel Class


AceModel.AceType Property

AceModelAceType Property
Gets or sets the type of the ace.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public AceType AceType { get; set; }
Public Property AceType As AceType
    Get
    Set
public:
property AceType AceType {
    AceType get ();
    void set (AceType value);
}
member AceType : AceType with get, set

Property Value

Type: AceType
The type of the ace.
See Also

Reference

AceModel Class


AceModel.Domain Property

AceModelDomain Property
Gets or sets the domain.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Domain { get; set; }
Public Property Domain As String
    Get
    Set
public:
property String^ Domain {
    String^ get ();
    void set (String^ value);
}
member Domain : string with get, set

Property Value

Type: String
The domain.
See Also

Reference

AceModel Class


AceModel.Name Property

AceModelName Property
Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

AceModel Class


AceModel.Sid Property

AceModelSid Property
Gets or sets the sid.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] Sid { get; set; }
Public Property Sid As Byte()
    Get
    Set
public:
property array<unsigned char>^ Sid {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member Sid : byte[] with get, set

Property Value

Type: Byte
The sid.
See Also

Reference

AceModel Class


AceModel Methods

AceModel Methods

The AceModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AceModel Class


ActionInputFlatModel Class

ActionInputFlatModel Class
Represents input into a monitor action.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActionInputFlatModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class ActionInputFlatModel
Public Class ActionInputFlatModel
public ref class ActionInputFlatModel
type ActionInputFlatModel =  class end

The ActionInputFlatModel type exposes the following members.

Constructors
 | Name | Description
Public method | ActionInputFlatModel | Initializes a new instance of the ActionInputFlatModel class
Top
Properties
 | Name | Description
Public property | Actions | Gets or sets the enumerable collection of actions.
Public property | Arguments | Gets or sets the arguments to the script or executable.
Public property | ClassName | Gets or sets the name of the class.
Public property | Credentials | Gets or sets the credentials to be used by the action.
Public property | EventType | Gets or sets the type of the event.
Public property | FileName | Gets or sets the file name of the script or executable to run.
Public property | Message | Gets or sets the message.
Public property | MessageFormatParameters | Gets or sets the message format parameters.
Public property | ParallelExecution | Gets or sets a value indicating whether the actions are to be executed in parallel.
Public property | QueryResult | Gets or sets the query result.
Public property | RunAs | Gets or sets the key to the credentials of the user as which the process will be run.
Public property | ServiceName | Gets or sets the name of the service.
Public property | ServiceOperation | Gets or sets the service operation.
Public property | StartArguments | Gets or sets the arguments for the Start operation.
Public property | Timeout | Gets or sets the timeout for the wait operation.
Public property | WaitForCompletion | Gets or sets a value indicating whether to wait for completion.
Public property | WaitForCompletionTimeout | Gets or sets the wait for completion timeout.
Public property | WaitForStatus | Gets or sets a value indicating whether to wait for the service status to change as a result of the operation performed.
Public property | WorkingDirectory | Gets or sets the working directory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ActionInputFlatModel Constructor

ActionInputFlatModel Constructor
Initializes a new instance of the ActionInputFlatModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ActionInputFlatModel()
Public Sub New
public:
ActionInputFlatModel()
new : unit -> ActionInputFlatModel
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel Properties

ActionInputFlatModel Properties

The ActionInputFlatModel type exposes the following members.

Properties
 | Name | Description
Public property | Actions | Gets or sets the enumerable collection of actions.
Public property | Arguments | Gets or sets the arguments to the script or executable.
Public property | ClassName | Gets or sets the name of the class.
Public property | Credentials | Gets or sets the credentials to be used by the action.
Public property | EventType | Gets or sets the type of the event.
Public property | FileName | Gets or sets the file name of the script or executable to run.
Public property | Message | Gets or sets the message.
Public property | MessageFormatParameters | Gets or sets the message format parameters.
Public property | ParallelExecution | Gets or sets a value indicating whether the actions are to be executed in parallel.
Public property | QueryResult | Gets or sets the query result.
Public property | RunAs | Gets or sets the key to the credentials of the user as which the process will be run.
Public property | ServiceName | Gets or sets the name of the service.
Public property | ServiceOperation | Gets or sets the service operation.
Public property | StartArguments | Gets or sets the arguments for the Start operation.
Public property | Timeout | Gets or sets the timeout for the wait operation.
Public property | WaitForCompletion | Gets or sets a value indicating whether to wait for completion.
Public property | WaitForCompletionTimeout | Gets or sets the wait for completion timeout.
Public property | WaitForStatus | Gets or sets a value indicating whether to wait for the service status to change as a result of the operation performed.
Public property | WorkingDirectory | Gets or sets the working directory.
Top
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.Actions Property

ActionInputFlatModelActions Property
Gets or sets the enumerable collection of actions.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<MonitorActionFlatModel> Actions { get; set; }
Public Property Actions As IEnumerable(Of MonitorActionFlatModel)
    Get
    Set
public:
property IEnumerable<MonitorActionFlatModel^>^ Actions {
    IEnumerable<MonitorActionFlatModel^>^ get ();
    void set (IEnumerable<MonitorActionFlatModel^>^ value);
}
member Actions : IEnumerable<MonitorActionFlatModel> with get, set

Property Value

Type: IEnumerable MonitorActionFlatModel
The enumerable collection of actions.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.Arguments Property

ActionInputFlatModelArguments Property
Gets or sets the arguments to the script or executable.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
member Arguments : string with get, set

Property Value

Type: String
The arguments to the script or executable.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.ClassName Property

ActionInputFlatModelClassName Property
Gets or sets the name of the class.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ClassName { get; set; }
Public Property ClassName As String
    Get
    Set
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}
member ClassName : string with get, set

Property Value

Type: String
The name of the class.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.Credentials Property

ActionInputFlatModelCredentials Property
Gets or sets the credentials to be used by the action.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, CredentialModel> Credentials { get; set; }
Public Property Credentials As IDictionary(Of String, CredentialModel)
    Get
    Set
public:
property IDictionary<String^, CredentialModel^>^ Credentials {
    IDictionary<String^, CredentialModel^>^ get ();
    void set (IDictionary<String^, CredentialModel^>^ value);
}
member Credentials : IDictionary<string, CredentialModel> with get, set

Property Value

Type: IDictionary String, CredentialModel
The credentials.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.EventType Property

ActionInputFlatModelEventType Property
Gets or sets the type of the event.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public TraceEventType EventType { get; set; }
Public Property EventType As TraceEventType
    Get
    Set
public:
property TraceEventType EventType {
    TraceEventType get ();
    void set (TraceEventType value);
}
member EventType : TraceEventType with get, set

Property Value

Type: TraceEventType
The type of the event.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.FileName Property

ActionInputFlatModelFileName Property
Gets or sets the file name of the script or executable to run.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

Property Value

Type: String
The file name of the script or executable to run.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.Message Property

ActionInputFlatModelMessage Property
Gets or sets the message.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Property Value

Type: String
The message.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.MessageFormatParameters Property

ActionInputFlatModelMessageFormatParameters Property
Gets or sets the message format parameters.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string[] MessageFormatParameters { get; set; }
Public Property MessageFormatParameters As String()
    Get
    Set
public:
property array<String^>^ MessageFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member MessageFormatParameters : string[] with get, set

Property Value

Type: String
The message format parameters.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.ParallelExecution Property

ActionInputFlatModelParallelExecution Property
Gets or sets a value indicating whether the actions are to be executed in parallel.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool ParallelExecution { get; set; }
Public Property ParallelExecution As Boolean
    Get
    Set
public:
property bool ParallelExecution {
    bool get ();
    void set (bool value);
}
member ParallelExecution : bool with get, set

Property Value

Type: Boolean
if the actions are to be executed in parallel; otherwise, .
Remarks
If this property is set to , the actions are executed synchronously in the order they exist in the Actions property.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.QueryResult Property

ActionInputFlatModelQueryResult Property
Gets or sets the query result.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public QueryResultFlatModel QueryResult { get; set; }
Public Property QueryResult As QueryResultFlatModel
    Get
    Set
public:
property QueryResultFlatModel^ QueryResult {
    QueryResultFlatModel^ get ();
    void set (QueryResultFlatModel^ value);
}
member QueryResult : QueryResultFlatModel with get, set

Property Value

Type: QueryResultFlatModel
The query result.
Remarks
This property will be automatically populated in for all actions being executed as a CorrectiveAction for a MonitorActivity. It may be helpful for the action to have contextual information concerning why the query failed when performing the corrective action.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.RunAs Property

ActionInputFlatModelRunAs Property
Gets or sets the key to the credentials of the user as which the process will be run.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string RunAs { get; set; }
Public Property RunAs As String
    Get
    Set
public:
property String^ RunAs {
    String^ get ();
    void set (String^ value);
}
member RunAs : string with get, set

Property Value

Type: String
The key to the credentials of the user as which the process will be run.
Remarks
This value is the key into the Credentials dictionary under which the credentials are stored.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.ServiceName Property

ActionInputFlatModelServiceName Property
Gets or sets the name of the service.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
member ServiceName : string with get, set

Property Value

Type: String
The name of the service.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.ServiceOperation Property

ActionInputFlatModelServiceOperation Property
Gets or sets the service operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ServiceOperationEnum ServiceOperation { get; set; }
Public Property ServiceOperation As ServiceOperationEnum
    Get
    Set
public:
property ServiceOperationEnum ServiceOperation {
    ServiceOperationEnum get ();
    void set (ServiceOperationEnum value);
}
member ServiceOperation : ServiceOperationEnum with get, set

Property Value

Type: ServiceOperationEnum
The service operation.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.StartArguments Property

ActionInputFlatModelStartArguments Property
Gets or sets the arguments for the Start operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string[] StartArguments { get; set; }
Public Property StartArguments As String()
    Get
    Set
public:
property array<String^>^ StartArguments {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member StartArguments : string[] with get, set

Property Value

Type: String
The arguments for the Start operation.
Remarks
This property is ignored for all [F:ServiceOperation] values other than the Start operation.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.Timeout Property

ActionInputFlatModelTimeout Property
Gets or sets the timeout for the wait operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TimeSpan> Timeout { get; set; }
Public Property Timeout As Nullable(Of TimeSpan)
    Get
    Set
public:
property Nullable<TimeSpan> Timeout {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
member Timeout : Nullable<TimeSpan> with get, set

Property Value

Type: Nullable TimeSpan
The timeout for the wait operation.
Remarks
If this value is , the action agent will wait indefinitely for the status to change.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.WaitForCompletion Property

ActionInputFlatModelWaitForCompletion Property
Gets or sets a value indicating whether to wait for completion.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool WaitForCompletion { get; set; }
Public Property WaitForCompletion As Boolean
    Get
    Set
public:
property bool WaitForCompletion {
    bool get ();
    void set (bool value);
}
member WaitForCompletion : bool with get, set

Property Value

Type: Boolean
if the query should wait for completion; otherwise, .
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.WaitForCompletionTimeout Property

ActionInputFlatModelWaitForCompletionTimeout Property
Gets or sets the wait for completion timeout.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TimeSpan> WaitForCompletionTimeout { get; set; }
Public Property WaitForCompletionTimeout As Nullable(Of TimeSpan)
    Get
    Set
public:
property Nullable<TimeSpan> WaitForCompletionTimeout {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
member WaitForCompletionTimeout : Nullable<TimeSpan> with get, set

Property Value

Type: Nullable TimeSpan
The wait for completion timeout.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.WaitForStatus Property

ActionInputFlatModelWaitForStatus Property
Gets or sets a value indicating whether to wait for the service status to change as a result of the operation performed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool WaitForStatus { get; set; }
Public Property WaitForStatus As Boolean
    Get
    Set
public:
property bool WaitForStatus {
    bool get ();
    void set (bool value);
}
member WaitForStatus : bool with get, set

Property Value

Type: Boolean
to wait for the service status to change; otherwise, .
Remarks
There is a corresponding service status change for each operation. For instance, if you've requested the Start operation, this action will wait for the service status to change to Running.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel.WorkingDirectory Property

ActionInputFlatModelWorkingDirectory Property
Gets or sets the working directory.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string WorkingDirectory { get; set; }
Public Property WorkingDirectory As String
    Get
    Set
public:
property String^ WorkingDirectory {
    String^ get ();
    void set (String^ value);
}
member WorkingDirectory : string with get, set

Property Value

Type: String
The working directory.
See Also

Reference

ActionInputFlatModel Class


ActionInputFlatModel Methods

ActionInputFlatModel Methods

The ActionInputFlatModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActionInputFlatModel Class


ActionInputModel Class

ActionInputModel Class
Represents input into a monitor action.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActionInputModel
DoubleTake.Web.ModelsCompositeActionInputModel
DoubleTake.Web.ModelsLogActionInputModel
DoubleTake.Web.ModelsScriptActionInputModel
DoubleTake.Web.ModelsServiceOperationActionInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class ActionInputModel
Public Class ActionInputModel
public ref class ActionInputModel
type ActionInputModel =  class end

The ActionInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | ActionInputModel | Initializes a new instance of the ActionInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the action.
Public property | QueryResult | Gets or sets the query result.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ActionInputModel Constructor

ActionInputModel Constructor
Initializes a new instance of the ActionInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ActionInputModel()
Public Sub New
public:
ActionInputModel()
new : unit -> ActionInputModel
See Also

Reference

ActionInputModel Class


ActionInputModel Properties

ActionInputModel Properties

The ActionInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the action.
Public property | QueryResult | Gets or sets the query result.
Top
See Also

Reference

ActionInputModel Class


ActionInputModel.Credentials Property

ActionInputModelCredentials Property
Gets or sets the credentials to be used by the action.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, CredentialModel> Credentials { get; set; }
Public Property Credentials As IDictionary(Of String, CredentialModel)
    Get
    Set
public:
property IDictionary<String^, CredentialModel^>^ Credentials {
    IDictionary<String^, CredentialModel^>^ get ();
    void set (IDictionary<String^, CredentialModel^>^ value);
}
member Credentials : IDictionary<string, CredentialModel> with get, set

Property Value

Type: IDictionary String, CredentialModel
The credentials.
See Also

Reference

ActionInputModel Class


ActionInputModel.QueryResult Property

ActionInputModelQueryResult Property
Gets or sets the query result.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public QueryResultModel QueryResult { get; set; }
Public Property QueryResult As QueryResultModel
    Get
    Set
public:
property QueryResultModel^ QueryResult {
    QueryResultModel^ get ();
    void set (QueryResultModel^ value);
}
member QueryResult : QueryResultModel with get, set

Property Value

Type: QueryResultModel
The query result.
Remarks
This property will be automatically populated in for all actions being executed as a CorrectiveAction for a MonitorActivity. It may be helpful for the action to have contextual information concerning why the query failed when performing the corrective action.
See Also

Reference

ActionInputModel Class


ActionInputModel Methods

ActionInputModel Methods

The ActionInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActionInputModel Class


ActionResultFlatModel Class

ActionResultFlatModel Class
Represents the result of a monitor action.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActionResultFlatModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class ActionResultFlatModel
Public Class ActionResultFlatModel
public ref class ActionResultFlatModel
type ActionResultFlatModel =  class end

The ActionResultFlatModel type exposes the following members.

Constructors
 | Name | Description
Public method | ActionResultFlatModel | Initializes a new instance of the ActionResultFlatModel class
Top
Properties
 | Name | Description
Public property | ActionResults | Gets or sets the action results.
Public property | ClassName | Gets or sets the name of the class.
Public property | Exception | Gets or sets the action exception.
Public property | ExitCode | Gets or sets the exit code of the process.
Public property | ExitTime | Gets or sets the exit time.
Public property | ServiceStatus | Gets or sets the service status after the operation has been executed.
Public property | StartTime | Gets or sets the start time.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ActionResultFlatModel Constructor

ActionResultFlatModel Constructor
Initializes a new instance of the ActionResultFlatModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ActionResultFlatModel()
Public Sub New
public:
ActionResultFlatModel()
new : unit -> ActionResultFlatModel
See Also

Reference

ActionResultFlatModel Class


ActionResultFlatModel Properties

ActionResultFlatModel Properties

The ActionResultFlatModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionResults | Gets or sets the action results.
Public property | ClassName | Gets or sets the name of the class.
Public property | Exception | Gets or sets the action exception.
Public property | ExitCode | Gets or sets the exit code of the process.
Public property | ExitTime | Gets or sets the exit time.
Public property | ServiceStatus | Gets or sets the service status after the operation has been executed.
Public property | StartTime | Gets or sets the start time.
Top
See Also

Reference

ActionResultFlatModel Class


ActionResultFlatModel.ActionResults Property

ActionResultFlatModelActionResults Property
Gets or sets the action results.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<ActionResultFlatModel> ActionResults { get; set; }
Public Property ActionResults As IEnumerable(Of ActionResultFlatModel)
    Get
    Set
public:
property IEnumerable<ActionResultFlatModel^>^ ActionResults {
    IEnumerable<ActionResultFlatModel^>^ get ();
    void set (IEnumerable<ActionResultFlatModel^>^ value);
}
member ActionResults : IEnumerable<ActionResultFlatModel> with get, set

Property Value

Type: IEnumerable ActionResultFlatModel
The action results.
See Also

Reference

ActionResultFlatModel Class


ActionResultFlatModel.ClassName Property

ActionResultFlatModelClassName Property
Gets or sets the name of the class.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ClassName { get; set; }
Public Property ClassName As String
    Get
    Set
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}
member ClassName : string with get, set

Property Value

Type: String
The name of the class.
See Also

Reference

ActionResultFlatModel Class


ActionResultFlatModel.Exception Property

ActionResultFlatModelException Property
Gets or sets the action exception.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ExceptionDetailModel Exception { get; set; }
Public Property Exception As ExceptionDetailModel
    Get
    Set
public:
property ExceptionDetailModel^ Exception {
    ExceptionDetailModel^ get ();
    void set (ExceptionDetailModel^ value);
}
member Exception : ExceptionDetailModel with get, set

Property Value

Type: ExceptionDetailModel
The action exception.
See Also

Reference

ActionResultFlatModel Class


ActionResultFlatModel.ExitCode Property

ActionResultFlatModelExitCode Property
Gets or sets the exit code of the process.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> ExitCode { get; set; }
Public Property ExitCode As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> ExitCode {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member ExitCode : Nullable<int> with get, set

Property Value

Type: Nullable Int32
The exit code.
Remarks
This value will be if the user chose not to wait for completion.
See Also

Reference

ActionResultFlatModel Class


ActionResultFlatModel.ExitTime Property

ActionResultFlatModelExitTime Property
Gets or sets the exit time.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTimeOffset> ExitTime { get; set; }
Public Property ExitTime As Nullable(Of DateTimeOffset)
    Get
    Set
public:
property Nullable<DateTimeOffset> ExitTime {
    Nullable<DateTimeOffset> get ();
    void set (Nullable<DateTimeOffset> value);
}
member ExitTime : Nullable<DateTimeOffset> with get, set

Property Value

Type: Nullable DateTimeOffset
The exit time.
Remarks
This value will be if the user chose not to wait for completion.
See Also

Reference

ActionResultFlatModel Class


ActionResultFlatModel.ServiceStatus Property

ActionResultFlatModelServiceStatus Property
Gets or sets the service status after the operation has been executed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ServiceStatus { get; set; }
Public Property ServiceStatus As String
    Get
    Set
public:
property String^ ServiceStatus {
    String^ get ();
    void set (String^ value);
}
member ServiceStatus : string with get, set

Property Value

Type: String
The service status after the operation has been executed.
See Also

Reference

ActionResultFlatModel Class


ActionResultFlatModel.StartTime Property

ActionResultFlatModelStartTime Property
Gets or sets the start time.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset StartTime { get; set; }
Public Property StartTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset StartTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member StartTime : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
The start time.
See Also

Reference

ActionResultFlatModel Class


ActionResultFlatModel Methods

ActionResultFlatModel Methods

The ActionResultFlatModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActionResultFlatModel Class


ActionResultModel Class

ActionResultModel Class
Represents the result of a monitor action.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActionResultModel
DoubleTake.Web.ModelsCompositeActionResultModel
DoubleTake.Web.ModelsScriptActionResultModel
DoubleTake.Web.ModelsServiceOperationActionResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class ActionResultModel
Public Class ActionResultModel
public ref class ActionResultModel
type ActionResultModel =  class end

The ActionResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | ActionResultModel | Initializes a new instance of the ActionResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the action exception.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ActionResultModel Constructor

ActionResultModel Constructor
Initializes a new instance of the ActionResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ActionResultModel()
Public Sub New
public:
ActionResultModel()
new : unit -> ActionResultModel
See Also

Reference

ActionResultModel Class


ActionResultModel Properties

ActionResultModel Properties

The ActionResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the action exception.
Top
See Also

Reference

ActionResultModel Class


ActionResultModel.Exception Property

ActionResultModelException Property
Gets or sets the action exception.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ExceptionDetailModel Exception { get; set; }
Public Property Exception As ExceptionDetailModel
    Get
    Set
public:
property ExceptionDetailModel^ Exception {
    ExceptionDetailModel^ get ();
    void set (ExceptionDetailModel^ value);
}
member Exception : ExceptionDetailModel with get, set

Property Value

Type: ExceptionDetailModel
The action exception.
See Also

Reference

ActionResultModel Class


ActionResultModel Methods

ActionResultModel Methods

The ActionResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActionResultModel Class


ActionStatus Enumeration

ActionStatus Enumeration
Action status.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum ActionStatus
Public Enumeration ActionStatus
public enum class ActionStatus
type ActionStatus
Members
Member name | Value | Description
Pending | 0 | The pending
Running | 1 | The running
Completed | 2 | The completed
Cancelled | 3 | The canceled
Faulted | 4 | The faulted
See Also

Reference

DoubleTake.Web.Models Namespace


ActivationAttributeModel Class

ActivationAttributeModel Class
Activation attribute model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActivationAttributeModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ActivationAttributeModel
Public NotInheritable Class ActivationAttributeModel
public ref class ActivationAttributeModel sealed
[<SealedAttribute>]
type ActivationAttributeModel =  class end

The ActivationAttributeModel type exposes the following members.

Constructors
 | Name | Description
Public method | ActivationAttributeModel | Initializes a new instance of the ActivationAttributeModel class
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of this activation attribute.
Public property | Value | Gets or sets the value of this activation attribute.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ActivationAttributeModel Constructor

ActivationAttributeModel Constructor
Initializes a new instance of the ActivationAttributeModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ActivationAttributeModel()
Public Sub New
public:
ActivationAttributeModel()
new : unit -> ActivationAttributeModel
See Also

Reference

ActivationAttributeModel Class


ActivationAttributeModel Properties

ActivationAttributeModel Properties

The ActivationAttributeModel type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of this activation attribute.
Public property | Value | Gets or sets the value of this activation attribute.
Top
See Also

Reference

ActivationAttributeModel Class


ActivationAttributeModel.Name Property

ActivationAttributeModelName Property
Gets or sets the name of this activation attribute.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

ActivationAttributeModel Class


ActivationAttributeModel.Value Property

ActivationAttributeModelValue Property
Gets or sets the value of this activation attribute.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long Value { get; set; }
Public Property Value As Long
    Get
    Set
public:
property long long Value {
    long long get ();
    void set (long long value);
}
member Value : int64 with get, set

Property Value

Type: Int64
See Also

Reference

ActivationAttributeModel Class


ActivationAttributeModel Methods

ActivationAttributeModel Methods

The ActivationAttributeModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActivationAttributeModel Class


ActivationCodeInfoModel Class

ActivationCodeInfoModel Class
Activation code information on appliance for V2V push install
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActivationCodeInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class ActivationCodeInfoModel
Public Class ActivationCodeInfoModel
public ref class ActivationCodeInfoModel
type ActivationCodeInfoModel =  class end

The ActivationCodeInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ActivationCodeInfoModel | Initializes a new instance of the ActivationCodeInfoModel class
Top
Properties
 | Name | Description
Public property | ActivationCode | Gets or sets a 24 character, alpha-numeric key which applies the appropriate license to the server.
Public property | DaysToExpire | Gets or sets the number of days until the license expires.
Public property | IsEval | Gets or sets a value indicating whether the license key is an evaluation license.
Public property | IsNodeLocked | Gets or sets a value indicating whether the license key must be activated.
Public property | IsValid | Gets or sets a value indicating whether the license key is valid.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ActivationCodeInfoModel Constructor

ActivationCodeInfoModel Constructor
Initializes a new instance of the ActivationCodeInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ActivationCodeInfoModel()
Public Sub New
public:
ActivationCodeInfoModel()
new : unit -> ActivationCodeInfoModel
See Also

Reference

ActivationCodeInfoModel Class


ActivationCodeInfoModel Properties

ActivationCodeInfoModel Properties

The ActivationCodeInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | ActivationCode | Gets or sets a 24 character, alpha-numeric key which applies the appropriate license to the server.
Public property | DaysToExpire | Gets or sets the number of days until the license expires.
Public property | IsEval | Gets or sets a value indicating whether the license key is an evaluation license.
Public property | IsNodeLocked | Gets or sets a value indicating whether the license key must be activated.
Public property | IsValid | Gets or sets a value indicating whether the license key is valid.
Top
See Also

Reference

ActivationCodeInfoModel Class


ActivationCodeInfoModel.ActivationCode Property

ActivationCodeInfoModelActivationCode Property
Gets or sets a 24 character, alpha-numeric key which applies the appropriate license to the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ActivationCode { get; set; }
Public Property ActivationCode As String
    Get
    Set
public:
property String^ ActivationCode {
    String^ get ();
    void set (String^ value);
}
member ActivationCode : string with get, set

Property Value

Type: String
See Also

Reference

ActivationCodeInfoModel Class


ActivationCodeInfoModel.DaysToExpire Property

ActivationCodeInfoModelDaysToExpire Property
Gets or sets the number of days until the license expires.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int DaysToExpire { get; set; }
Public Property DaysToExpire As Integer
    Get
    Set
public:
property int DaysToExpire {
    int get ();
    void set (int value);
}
member DaysToExpire : int with get, set

Property Value

Type: Int32
See Also

Reference

ActivationCodeInfoModel Class


ActivationCodeInfoModel.IsEval Property

ActivationCodeInfoModelIsEval Property
Gets or sets a value indicating whether the license key is an evaluation license.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsEval { get; set; }
Public Property IsEval As Boolean
    Get
    Set
public:
property bool IsEval {
    bool get ();
    void set (bool value);
}
member IsEval : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ActivationCodeInfoModel Class


ActivationCodeInfoModel.IsNodeLocked Property

ActivationCodeInfoModelIsNodeLocked Property
Gets or sets a value indicating whether the license key must be activated.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsNodeLocked { get; set; }
Public Property IsNodeLocked As Boolean
    Get
    Set
public:
property bool IsNodeLocked {
    bool get ();
    void set (bool value);
}
member IsNodeLocked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ActivationCodeInfoModel Class


ActivationCodeInfoModel.IsValid Property

ActivationCodeInfoModelIsValid Property
Gets or sets a value indicating whether the license key is valid.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid { get; set; }
Public Property IsValid As Boolean
    Get
    Set
public:
property bool IsValid {
    bool get ();
    void set (bool value);
}
member IsValid : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ActivationCodeInfoModel Class


ActivationCodeInfoModel Methods

ActivationCodeInfoModel Methods

The ActivationCodeInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActivationCodeInfoModel Class


ActivationCodeModel Class

ActivationCodeModel Class
Activation code model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActivationCodeModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ActivationCodeModel
Public NotInheritable Class ActivationCodeModel
public ref class ActivationCodeModel sealed
[<SealedAttribute>]
type ActivationCodeModel =  class end

The ActivationCodeModel type exposes the following members.

Constructors
 | Name | Description
Public method | ActivationCodeModel | Initializes a new instance of the ActivationCodeModel class
Top
Properties
 | Name | Description
Public property | Attributes | Gets or sets the attributes of this activation code.
Public property | Code | Gets or sets the text of the activation code.
Public property | ExpirationDate | Gets or sets the expiration date of this activation code.
Public property | IsEvaluation | Gets or sets a value indicating whether this activation code represents an evaluation license.
Public property | IsExpired | Gets or sets a value indicating whether this activation code is expired.
Public property | IsNodeLocked | Gets or sets a value indicating whether or not this activation code represents a node-locked license.
Public property | IsValid | Gets or sets a value indicating whether or not this activation code is valid.
Public property | LicenseType | Gets or sets the type of the license this activation code entitles the user to.
Public property | MajorVersion | Gets or sets the major version of the release associated with this activation code.
Public property | MinorVersion | Gets or sets the minor version of the release associated with this activation code.
Public property | ProductCode | Gets or sets the product code associated with this activation code.
Public property | ProductName | Gets or sets the name of the product associated with this activation code.
Public property | SerialNumber | Gets or sets the serial number associated with this activation code.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ActivationCodeModel Constructor

ActivationCodeModel Constructor
Initializes a new instance of the ActivationCodeModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ActivationCodeModel()
Public Sub New
public:
ActivationCodeModel()
new : unit -> ActivationCodeModel
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel Properties

ActivationCodeModel Properties

The ActivationCodeModel type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets or sets the attributes of this activation code.
Public property | Code | Gets or sets the text of the activation code.
Public property | ExpirationDate | Gets or sets the expiration date of this activation code.
Public property | IsEvaluation | Gets or sets a value indicating whether this activation code represents an evaluation license.
Public property | IsExpired | Gets or sets a value indicating whether this activation code is expired.
Public property | IsNodeLocked | Gets or sets a value indicating whether or not this activation code represents a node-locked license.
Public property | IsValid | Gets or sets a value indicating whether or not this activation code is valid.
Public property | LicenseType | Gets or sets the type of the license this activation code entitles the user to.
Public property | MajorVersion | Gets or sets the major version of the release associated with this activation code.
Public property | MinorVersion | Gets or sets the minor version of the release associated with this activation code.
Public property | ProductCode | Gets or sets the product code associated with this activation code.
Public property | ProductName | Gets or sets the name of the product associated with this activation code.
Public property | SerialNumber | Gets or sets the serial number associated with this activation code.
Top
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.Attributes Property

ActivationCodeModelAttributes Property
Gets or sets the attributes of this activation code.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ActivationAttributeModel[] Attributes { get; set; }
Public Property Attributes As ActivationAttributeModel()
    Get
    Set
public:
property array<ActivationAttributeModel^>^ Attributes {
    array<ActivationAttributeModel^>^ get ();
    void set (array<ActivationAttributeModel^>^ value);
}
member Attributes : ActivationAttributeModel[] with get, set

Property Value

Type: ActivationAttributeModel
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.Code Property

ActivationCodeModelCode Property
Gets or sets the text of the activation code.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Code { get; set; }
Public Property Code As String
    Get
    Set
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}
member Code : string with get, set

Property Value

Type: String
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.ExpirationDate Property

ActivationCodeModelExpirationDate Property
Gets or sets the expiration date of this activation code.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime ExpirationDate { get; set; }
Public Property ExpirationDate As DateTime
    Get
    Set
public:
property DateTime ExpirationDate {
    DateTime get ();
    void set (DateTime value);
}
member ExpirationDate : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.IsEvaluation Property

ActivationCodeModelIsEvaluation Property
Gets or sets a value indicating whether this activation code represents an evaluation license.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEvaluation { get; set; }
Public Property IsEvaluation As Boolean
    Get
    Set
public:
property bool IsEvaluation {
    bool get ();
    void set (bool value);
}
member IsEvaluation : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.IsExpired Property

ActivationCodeModelIsExpired Property
Gets or sets a value indicating whether this activation code is expired.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsExpired { get; set; }
Public Property IsExpired As Boolean
    Get
    Set
public:
property bool IsExpired {
    bool get ();
    void set (bool value);
}
member IsExpired : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.IsNodeLocked Property

ActivationCodeModelIsNodeLocked Property
Gets or sets a value indicating whether or not this activation code represents a node-locked license.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsNodeLocked { get; set; }
Public Property IsNodeLocked As Boolean
    Get
    Set
public:
property bool IsNodeLocked {
    bool get ();
    void set (bool value);
}
member IsNodeLocked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.IsValid Property

ActivationCodeModelIsValid Property
Gets or sets a value indicating whether or not this activation code is valid.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid { get; set; }
Public Property IsValid As Boolean
    Get
    Set
public:
property bool IsValid {
    bool get ();
    void set (bool value);
}
member IsValid : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.LicenseType Property

ActivationCodeModelLicenseType Property
Gets or sets the type of the license this activation code entitles the user to.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public LicenseType LicenseType { get; set; }
Public Property LicenseType As LicenseType
    Get
    Set
public:
property LicenseType LicenseType {
    LicenseType get ();
    void set (LicenseType value);
}
member LicenseType : LicenseType with get, set

Property Value

Type: LicenseType
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.MajorVersion Property

ActivationCodeModelMajorVersion Property
Gets or sets the major version of the release associated with this activation code.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int MajorVersion { get; set; }
Public Property MajorVersion As Integer
    Get
    Set
public:
property int MajorVersion {
    int get ();
    void set (int value);
}
member MajorVersion : int with get, set

Property Value

Type: Int32
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.MinorVersion Property

ActivationCodeModelMinorVersion Property
Gets or sets the minor version of the release associated with this activation code.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int MinorVersion { get; set; }
Public Property MinorVersion As Integer
    Get
    Set
public:
property int MinorVersion {
    int get ();
    void set (int value);
}
member MinorVersion : int with get, set

Property Value

Type: Int32
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.ProductCode Property

ActivationCodeModelProductCode Property
Gets or sets the product code associated with this activation code.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int ProductCode { get; set; }
Public Property ProductCode As Integer
    Get
    Set
public:
property int ProductCode {
    int get ();
    void set (int value);
}
member ProductCode : int with get, set

Property Value

Type: Int32
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.ProductName Property

ActivationCodeModelProductName Property
Gets or sets the name of the product associated with this activation code.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ProductName { get; set; }
Public Property ProductName As String
    Get
    Set
public:
property String^ ProductName {
    String^ get ();
    void set (String^ value);
}
member ProductName : string with get, set

Property Value

Type: String
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel.SerialNumber Property

ActivationCodeModelSerialNumber Property
Gets or sets the serial number associated with this activation code.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int SerialNumber { get; set; }
Public Property SerialNumber As Integer
    Get
    Set
public:
property int SerialNumber {
    int get ();
    void set (int value);
}
member SerialNumber : int with get, set

Property Value

Type: Int32
See Also

Reference

ActivationCodeModel Class


ActivationCodeModel Methods

ActivationCodeModel Methods

The ActivationCodeModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActivationCodeModel Class


ActivationParametersModel Class

ActivationParametersModel Class
Activation parameters query model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActivationParametersModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ActivationParametersModel
Public NotInheritable Class ActivationParametersModel
public ref class ActivationParametersModel sealed
[<SealedAttribute>]
type ActivationParametersModel =  class end

The ActivationParametersModel type exposes the following members.

Constructors
 | Name | Description
Public method | ActivationParametersModel | Initializes a new instance of the ActivationParametersModel class
Top
Properties
 | Name | Description
Public property | ActivationCodes | Gets or sets the activation codes.
Public property | AdditionalCodes | Gets or sets the additional codes.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ActivationParametersModel Constructor

ActivationParametersModel Constructor
Initializes a new instance of the ActivationParametersModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ActivationParametersModel()
Public Sub New
public:
ActivationParametersModel()
new : unit -> ActivationParametersModel
See Also

Reference

ActivationParametersModel Class


ActivationParametersModel Properties

ActivationParametersModel Properties

The ActivationParametersModel type exposes the following members.

Properties
 | Name | Description
Public property | ActivationCodes | Gets or sets the activation codes.
Public property | AdditionalCodes | Gets or sets the additional codes.
Top
See Also

Reference

ActivationParametersModel Class


ActivationParametersModel.ActivationCodes Property

ActivationParametersModelActivationCodes Property
Gets or sets the activation codes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> ActivationCodes { get; set; }
Public Property ActivationCodes As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ ActivationCodes {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member ActivationCodes : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
See Also

Reference

ActivationParametersModel Class


ActivationParametersModel.AdditionalCodes Property

ActivationParametersModelAdditionalCodes Property
Gets or sets the additional codes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> AdditionalCodes { get; set; }
Public Property AdditionalCodes As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ AdditionalCodes {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member AdditionalCodes : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
See Also

Reference

ActivationParametersModel Class


ActivationParametersModel Methods

ActivationParametersModel Methods

The ActivationParametersModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActivationParametersModel Class


ActivationStatusModel Class

ActivationStatusModel Class
Activation status model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActivationStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ActivationStatusModel
Public NotInheritable Class ActivationStatusModel
public ref class ActivationStatusModel sealed
[<SealedAttribute>]
type ActivationStatusModel =  class end

The ActivationStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | ActivationStatusModel | Initializes a new instance of the ActivationStatusModel class
Top
Properties
 | Name | Description
Public property | AddOnCodes | Gets or sets the current add-on codes on this server.
Public property | Codes | Gets or sets the current activation codes on this server.
Public property | IsNodeLocked | Gets or sets a value indicating whether or not the license on this server is node locked.
Public property | IsValid | Gets or sets a value indicating whether the license on this server is valid.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ActivationStatusModel Constructor

ActivationStatusModel Constructor
Initializes a new instance of the ActivationStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ActivationStatusModel()
Public Sub New
public:
ActivationStatusModel()
new : unit -> ActivationStatusModel
See Also

Reference

ActivationStatusModel Class


ActivationStatusModel Properties

ActivationStatusModel Properties

The ActivationStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | AddOnCodes | Gets or sets the current add-on codes on this server.
Public property | Codes | Gets or sets the current activation codes on this server.
Public property | IsNodeLocked | Gets or sets a value indicating whether or not the license on this server is node locked.
Public property | IsValid | Gets or sets a value indicating whether the license on this server is valid.
Top
See Also

Reference

ActivationStatusModel Class


ActivationStatusModel.AddOnCodes Property

ActivationStatusModelAddOnCodes Property
Gets or sets the current add-on codes on this server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ActivationCodeModel[] AddOnCodes { get; set; }
Public Property AddOnCodes As ActivationCodeModel()
    Get
    Set
public:
property array<ActivationCodeModel^>^ AddOnCodes {
    array<ActivationCodeModel^>^ get ();
    void set (array<ActivationCodeModel^>^ value);
}
member AddOnCodes : ActivationCodeModel[] with get, set

Property Value

Type: ActivationCodeModel
See Also

Reference

ActivationStatusModel Class


ActivationStatusModel.Codes Property

ActivationStatusModelCodes Property
Gets or sets the current activation codes on this server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ActivationCodeModel[] Codes { get; set; }
Public Property Codes As ActivationCodeModel()
    Get
    Set
public:
property array<ActivationCodeModel^>^ Codes {
    array<ActivationCodeModel^>^ get ();
    void set (array<ActivationCodeModel^>^ value);
}
member Codes : ActivationCodeModel[] with get, set

Property Value

Type: ActivationCodeModel
See Also

Reference

ActivationStatusModel Class


ActivationStatusModel.IsNodeLocked Property

ActivationStatusModelIsNodeLocked Property
Gets or sets a value indicating whether or not the license on this server is node locked.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsNodeLocked { get; set; }
Public Property IsNodeLocked As Boolean
    Get
    Set
public:
property bool IsNodeLocked {
    bool get ();
    void set (bool value);
}
member IsNodeLocked : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ActivationStatusModel Class


ActivationStatusModel.IsValid Property

ActivationStatusModelIsValid Property
Gets or sets a value indicating whether the license on this server is valid.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid { get; set; }
Public Property IsValid As Boolean
    Get
    Set
public:
property bool IsValid {
    bool get ();
    void set (bool value);
}
member IsValid : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ActivationStatusModel Class


ActivationStatusModel Methods

ActivationStatusModel Methods

The ActivationStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActivationStatusModel Class


ActiveDirectoryFailoverOptions Enumeration

ActiveDirectoryFailoverOptions Enumeration
ActiveDirectory failover options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum ActiveDirectoryFailoverOptions
<FlagsAttribute>
Public Enumeration ActiveDirectoryFailoverOptions
[FlagsAttribute]
public enum class ActiveDirectoryFailoverOptions
[<FlagsAttribute>]
type ActiveDirectoryFailoverOptions
Members
Member name | Value | Description
None | 0 | The none
FailoverHostName | 1 | The failover host name
FailbackHostName | 2 | The failback host name
See Also

Reference

DoubleTake.Web.Models Namespace


ActivityCompletionStatus Enumeration

ActivityCompletionStatus Enumeration
Activity completion status.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum ActivityCompletionStatus
Public Enumeration ActivityCompletionStatus
public enum class ActivityCompletionStatus
type ActivityCompletionStatus
Members
Member name | Value | Description
Pending | 0 | pending
Running | 1 | running
Completed | 2 | completed
Canceled | 3 | canceled
Faulted | 4 | faulted
See Also

Reference

DoubleTake.Web.Models Namespace


ActivityStatusModel Class

ActivityStatusModel Class
Activity status model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActivityStatusModel
DoubleTake.Web.ModelsFixJobOptionsStatusModel
DoubleTake.Web.ModelsVerificationStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public class ActivityStatusModel
Public Class ActivityStatusModel
public ref class ActivityStatusModel
type ActivityStatusModel =  class end

The ActivityStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | ActivityStatusModel | Initializes a new instance of the ActivityStatusModel class
Top
Properties
 | Name | Description
Public property | Duration | Gets or sets a value the duration of the activity at the time this status was yielded.
Public property | MessageFormatParameters | Gets or sets the message format parameters.
Public property | MessageId | Gets or sets a value representing a message identifier.
Public property | RequesterUserName | Gets or sets the user that initiated the activity.
Public property | Status | Gets or sets the current status of the activity.
Public property | StatusUri | Gets or sets the URI to call to obtain further status information - missing if the status is 'completed', 'canceled' or 'faulted'.
Public property | TimeStamp | Gets or sets the server time when the activity yielded this status.
Public property | Token | Gets or sets a token that identifies the request that initiated the activity.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ActivityStatusModel Constructor

ActivityStatusModel Constructor
Initializes a new instance of the ActivityStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ActivityStatusModel()
Public Sub New
public:
ActivityStatusModel()
new : unit -> ActivityStatusModel
See Also

Reference

ActivityStatusModel Class


ActivityStatusModel Properties

ActivityStatusModel Properties

The ActivityStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | Duration | Gets or sets a value the duration of the activity at the time this status was yielded.
Public property | MessageFormatParameters | Gets or sets the message format parameters.
Public property | MessageId | Gets or sets a value representing a message identifier.
Public property | RequesterUserName | Gets or sets the user that initiated the activity.
Public property | Status | Gets or sets the current status of the activity.
Public property | StatusUri | Gets or sets the URI to call to obtain further status information - missing if the status is 'completed', 'canceled' or 'faulted'.
Public property | TimeStamp | Gets or sets the server time when the activity yielded this status.
Public property | Token | Gets or sets a token that identifies the request that initiated the activity.
Top
See Also

Reference

ActivityStatusModel Class


ActivityStatusModel.Duration Property

ActivityStatusModelDuration Property
Gets or sets a value the duration of the activity at the time this status was yielded.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Duration { get; set; }
Public Property Duration As TimeSpan
    Get
    Set
public:
property TimeSpan Duration {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Duration : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

ActivityStatusModel Class


ActivityStatusModel.MessageFormatParameters Property

ActivityStatusModelMessageFormatParameters Property
Gets or sets the message format parameters.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] MessageFormatParameters { get; set; }
Public Property MessageFormatParameters As String()
    Get
    Set
public:
property array<String^>^ MessageFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member MessageFormatParameters : string[] with get, set

Property Value

Type: String
See Also

Reference

ActivityStatusModel Class


ActivityStatusModel.MessageId Property

ActivityStatusModelMessageId Property
Gets or sets a value representing a message identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string MessageId { get; set; }
Public Property MessageId As String
    Get
    Set
public:
property String^ MessageId {
    String^ get ();
    void set (String^ value);
}
member MessageId : string with get, set

Property Value

Type: String
See Also

Reference

ActivityStatusModel Class


ActivityStatusModel.RequesterUserName Property

ActivityStatusModelRequesterUserName Property
Gets or sets the user that initiated the activity.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string RequesterUserName { get; set; }
Public Property RequesterUserName As String
    Get
    Set
public:
property String^ RequesterUserName {
    String^ get ();
    void set (String^ value);
}
member RequesterUserName : string with get, set

Property Value

Type: String
See Also

Reference

ActivityStatusModel Class


ActivityStatusModel.Status Property

ActivityStatusModelStatus Property
Gets or sets the current status of the activity.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ActivityCompletionStatus Status { get; set; }
Public Property Status As ActivityCompletionStatus
    Get
    Set
public:
property ActivityCompletionStatus Status {
    ActivityCompletionStatus get ();
    void set (ActivityCompletionStatus value);
}
member Status : ActivityCompletionStatus with get, set

Property Value

Type: ActivityCompletionStatus
See Also

Reference

ActivityStatusModel Class


ActivityStatusModel.StatusUri Property

ActivityStatusModelStatusUri Property
Gets or sets the URI to call to obtain further status information - missing if the status is 'completed', 'canceled' or 'faulted'.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string StatusUri { get; set; }
Public Property StatusUri As String
    Get
    Set
public:
property String^ StatusUri {
    String^ get ();
    void set (String^ value);
}
member StatusUri : string with get, set

Property Value

Type: String
See Also

Reference

ActivityStatusModel Class


ActivityStatusModel.TimeStamp Property

ActivityStatusModelTimeStamp Property
Gets or sets the server time when the activity yielded this status.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset TimeStamp { get; set; }
Public Property TimeStamp As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset TimeStamp {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member TimeStamp : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

ActivityStatusModel Class


ActivityStatusModel.Token Property

ActivityStatusModelToken Property
Gets or sets a token that identifies the request that initiated the activity.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ActivityTokenModel Token { get; set; }
Public Property Token As ActivityTokenModel
    Get
    Set
public:
property ActivityTokenModel^ Token {
    ActivityTokenModel^ get ();
    void set (ActivityTokenModel^ value);
}
member Token : ActivityTokenModel with get, set

Property Value

Type: ActivityTokenModel
See Also

Reference

ActivityStatusModel Class


ActivityStatusModel Methods

ActivityStatusModel Methods

The ActivityStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActivityStatusModel Class


ActivityTokenModel Class

ActivityTokenModel Class
Activity token model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActivityTokenModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ActivityTokenModel
Public NotInheritable Class ActivityTokenModel
public ref class ActivityTokenModel sealed
[<SealedAttribute>]
type ActivityTokenModel =  class end

The ActivityTokenModel type exposes the following members.

Constructors
 | Name | Description
Public method | ActivityTokenModel | Initializes a new instance of the ActivityTokenModel class
Top
Properties
 | Name | Description
Public property | ActivityNameFormatParameters | Gets or sets the activity name format parameters.
Public property | ActivityNameId | Gets or sets the activity name id.
Public property | Id | Gets or sets the unique identifier of this token.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ActivityTokenModel Constructor

ActivityTokenModel Constructor
Initializes a new instance of the ActivityTokenModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ActivityTokenModel()
Public Sub New
public:
ActivityTokenModel()
new : unit -> ActivityTokenModel
See Also

Reference

ActivityTokenModel Class


ActivityTokenModel Properties

ActivityTokenModel Properties

The ActivityTokenModel type exposes the following members.

Properties
 | Name | Description
Public property | ActivityNameFormatParameters | Gets or sets the activity name format parameters.
Public property | ActivityNameId | Gets or sets the activity name id.
Public property | Id | Gets or sets the unique identifier of this token.
Top
See Also

Reference

ActivityTokenModel Class


ActivityTokenModel.ActivityNameFormatParameters Property

ActivityTokenModelActivityNameFormatParameters Property
Gets or sets the activity name format parameters.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] ActivityNameFormatParameters { get; set; }
Public Property ActivityNameFormatParameters As String()
    Get
    Set
public:
property array<String^>^ ActivityNameFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member ActivityNameFormatParameters : string[] with get, set

Property Value

Type: String
See Also

Reference

ActivityTokenModel Class


ActivityTokenModel.ActivityNameId Property

ActivityTokenModelActivityNameId Property
Gets or sets the activity name id.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ActivityNameId { get; set; }
Public Property ActivityNameId As String
    Get
    Set
public:
property String^ ActivityNameId {
    String^ get ();
    void set (String^ value);
}
member ActivityNameId : string with get, set

Property Value

Type: String
See Also

Reference

ActivityTokenModel Class


ActivityTokenModel.Id Property

ActivityTokenModelId Property
Gets or sets the unique identifier of this token.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
member Id : Guid with get, set

Property Value

Type: Guid
See Also

Reference

ActivityTokenModel Class


ActivityTokenModel Methods

ActivityTokenModel Methods

The ActivityTokenModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ActivityTokenModel Class


AddressPersistedStateModel Class

AddressPersistedStateModel Class
Address persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsAddressPersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class AddressPersistedStateModel
Public NotInheritable Class AddressPersistedStateModel
public ref class AddressPersistedStateModel sealed
[<SealedAttribute>]
type AddressPersistedStateModel =  class end

The AddressPersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | AddressPersistedStateModel | Initializes a new instance of the AddressPersistedStateModel class
Top
Properties
 | Name | Description
Public property | NteContext | Gets or sets the NTE context.
Public property | SourceAddresss | Gets or sets the source address.
Public property | TargetNic | Gets or sets the target NIC.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


AddressPersistedStateModel Constructor

AddressPersistedStateModel Constructor
Initializes a new instance of the AddressPersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public AddressPersistedStateModel()
Public Sub New
public:
AddressPersistedStateModel()
new : unit -> AddressPersistedStateModel
See Also

Reference

AddressPersistedStateModel Class


AddressPersistedStateModel Properties

AddressPersistedStateModel Properties

The AddressPersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | NteContext | Gets or sets the NTE context.
Public property | SourceAddresss | Gets or sets the source address.
Public property | TargetNic | Gets or sets the target NIC.
Top
See Also

Reference

AddressPersistedStateModel Class


AddressPersistedStateModel.NteContext Property

AddressPersistedStateModelNteContext Property
Gets or sets the NTE context.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int NteContext { get; set; }
Public Property NteContext As Integer
    Get
    Set
public:
property int NteContext {
    int get ();
    void set (int value);
}
member NteContext : int with get, set

Property Value

Type: Int32
See Also

Reference

AddressPersistedStateModel Class


AddressPersistedStateModel.SourceAddresss Property

AddressPersistedStateModelSourceAddresss Property
Gets or sets the source address.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SourceAddresss { get; set; }
Public Property SourceAddresss As String
    Get
    Set
public:
property String^ SourceAddresss {
    String^ get ();
    void set (String^ value);
}
member SourceAddresss : string with get, set

Property Value

Type: String
See Also

Reference

AddressPersistedStateModel Class


AddressPersistedStateModel.TargetNic Property

AddressPersistedStateModelTargetNic Property
Gets or sets the target NIC.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string TargetNic { get; set; }
Public Property TargetNic As String
    Get
    Set
public:
property String^ TargetNic {
    String^ get ();
    void set (String^ value);
}
member TargetNic : string with get, set

Property Value

Type: String
See Also

Reference

AddressPersistedStateModel Class


AddressPersistedStateModel Methods

AddressPersistedStateModel Methods

The AddressPersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

AddressPersistedStateModel Class


ApplicationOptionsModel Class

ApplicationOptionsModel Class
Application options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsApplicationOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ApplicationOptionsModel
Public NotInheritable Class ApplicationOptionsModel
public ref class ApplicationOptionsModel sealed
[<SealedAttribute>]
type ApplicationOptionsModel =  class end

The ApplicationOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | ApplicationOptionsModel | Initializes a new instance of the ApplicationOptionsModel class
Top
Properties
 | Name | Description
Public property | AagInstances | Gets or sets aag instances.
Public property | DagTargetPublicFolderDataPath | Gets or sets dag target public folder data path.
Public property | DnsRecordLocks | Gets or sets the DNS record locks.
Public property | ExchangeCredentials | Gets or sets the exchange credentials.
Public property | IsAag | Gets or sets a value indicating whether this instance is aag.
Public property | IsDag | Gets or sets a value indicating whether this instance is dag.
Public property | MonitorScript | Gets or sets monitor script.
Public property | SourceDomain | Gets or sets the source server's primary domain.
Public property | SourceName | Gets or sets source name.
Public property | TargetDomain | Gets or sets the target server's primary domain.
Public property | TargetName | Gets or sets target name.
Public property | TestPostFailoverScript | Gets or sets script to run after target is brought online during a test failover (TDV).
Public property | TestPostFailoverScriptArguments | Gets or sets arguments for script to run after target is brought online during a test failover (TDV).
Public property | TestPreFailbackScript | Gets or sets script to run before failing back after a test failover (TDV).
Public property | TestPreFailbackScriptArguments | Gets or sets arguments for script to run before failing back after a test failover (TDV).
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ApplicationOptionsModel Constructor

ApplicationOptionsModel Constructor
Initializes a new instance of the ApplicationOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ApplicationOptionsModel()
Public Sub New
public:
ApplicationOptionsModel()
new : unit -> ApplicationOptionsModel
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel Properties

ApplicationOptionsModel Properties

The ApplicationOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | AagInstances | Gets or sets aag instances.
Public property | DagTargetPublicFolderDataPath | Gets or sets dag target public folder data path.
Public property | DnsRecordLocks | Gets or sets the DNS record locks.
Public property | ExchangeCredentials | Gets or sets the exchange credentials.
Public property | IsAag | Gets or sets a value indicating whether this instance is aag.
Public property | IsDag | Gets or sets a value indicating whether this instance is dag.
Public property | MonitorScript | Gets or sets monitor script.
Public property | SourceDomain | Gets or sets the source server's primary domain.
Public property | SourceName | Gets or sets source name.
Public property | TargetDomain | Gets or sets the target server's primary domain.
Public property | TargetName | Gets or sets target name.
Public property | TestPostFailoverScript | Gets or sets script to run after target is brought online during a test failover (TDV).
Public property | TestPostFailoverScriptArguments | Gets or sets arguments for script to run after target is brought online during a test failover (TDV).
Public property | TestPreFailbackScript | Gets or sets script to run before failing back after a test failover (TDV).
Public property | TestPreFailbackScriptArguments | Gets or sets arguments for script to run before failing back after a test failover (TDV).
Top
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.AagInstances Property

ApplicationOptionsModelAagInstances Property
Gets or sets aag instances.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> AagInstances { get; set; }
Public Property AagInstances As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ AagInstances {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member AagInstances : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.DagTargetPublicFolderDataPath Property

ApplicationOptionsModelDagTargetPublicFolderDataPath Property
Gets or sets dag target public folder data path.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string DagTargetPublicFolderDataPath { get; set; }
Public Property DagTargetPublicFolderDataPath As String
    Get
    Set
public:
property String^ DagTargetPublicFolderDataPath {
    String^ get ();
    void set (String^ value);
}
member DagTargetPublicFolderDataPath : string with get, set

Property Value

Type: String
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.DnsRecordLocks Property

ApplicationOptionsModelDnsRecordLocks Property
Gets or sets the DNS record locks.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<DnsRecordLockOptionsModel> DnsRecordLocks { get; set; }
Public Property DnsRecordLocks As IEnumerable(Of DnsRecordLockOptionsModel)
    Get
    Set
public:
property IEnumerable<DnsRecordLockOptionsModel^>^ DnsRecordLocks {
    IEnumerable<DnsRecordLockOptionsModel^>^ get ();
    void set (IEnumerable<DnsRecordLockOptionsModel^>^ value);
}
member DnsRecordLocks : IEnumerable<DnsRecordLockOptionsModel> with get, set

Property Value

Type: IEnumerable DnsRecordLockOptionsModel
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.ExchangeCredentials Property

ApplicationOptionsModelExchangeCredentials Property
Gets or sets the exchange credentials.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CredentialModel ExchangeCredentials { get; set; }
Public Property ExchangeCredentials As CredentialModel
    Get
    Set
public:
property CredentialModel^ ExchangeCredentials {
    CredentialModel^ get ();
    void set (CredentialModel^ value);
}
member ExchangeCredentials : CredentialModel with get, set

Property Value

Type: CredentialModel
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.IsAag Property

ApplicationOptionsModelIsAag Property
Gets or sets a value indicating whether this instance is aag.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsAag { get; set; }
Public Property IsAag As Boolean
    Get
    Set
public:
property bool IsAag {
    bool get ();
    void set (bool value);
}
member IsAag : bool with get, set

Property Value

Type: Boolean
if this instance is aag; otherwise, .
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.IsDag Property

ApplicationOptionsModelIsDag Property
Gets or sets a value indicating whether this instance is dag.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDag { get; set; }
Public Property IsDag As Boolean
    Get
    Set
public:
property bool IsDag {
    bool get ();
    void set (bool value);
}
member IsDag : bool with get, set

Property Value

Type: Boolean
if this instance is dag; otherwise, .
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.MonitorScript Property

ApplicationOptionsModelMonitorScript Property
Gets or sets monitor script.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string MonitorScript { get; set; }
Public Property MonitorScript As String
    Get
    Set
public:
property String^ MonitorScript {
    String^ get ();
    void set (String^ value);
}
member MonitorScript : string with get, set

Property Value

Type: String
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.SourceDomain Property

ApplicationOptionsModelSourceDomain Property
Gets or sets the source server's primary domain.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceDomain { get; set; }
Public Property SourceDomain As String
    Get
    Set
public:
property String^ SourceDomain {
    String^ get ();
    void set (String^ value);
}
member SourceDomain : string with get, set

Property Value

Type: String
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.SourceName Property

ApplicationOptionsModelSourceName Property
Gets or sets source name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceName { get; set; }
Public Property SourceName As String
    Get
    Set
public:
property String^ SourceName {
    String^ get ();
    void set (String^ value);
}
member SourceName : string with get, set

Property Value

Type: String
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.TargetDomain Property

ApplicationOptionsModelTargetDomain Property
Gets or sets the target server's primary domain.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetDomain { get; set; }
Public Property TargetDomain As String
    Get
    Set
public:
property String^ TargetDomain {
    String^ get ();
    void set (String^ value);
}
member TargetDomain : string with get, set

Property Value

Type: String
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.TargetName Property

ApplicationOptionsModelTargetName Property
Gets or sets target name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetName { get; set; }
Public Property TargetName As String
    Get
    Set
public:
property String^ TargetName {
    String^ get ();
    void set (String^ value);
}
member TargetName : string with get, set

Property Value

Type: String
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.TestPostFailoverScript Property

ApplicationOptionsModelTestPostFailoverScript Property
Gets or sets script to run after target is brought online during a test failover (TDV).

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TestPostFailoverScript { get; set; }
Public Property TestPostFailoverScript As String
    Get
    Set
public:
property String^ TestPostFailoverScript {
    String^ get ();
    void set (String^ value);
}
member TestPostFailoverScript : string with get, set

Property Value

Type: String
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.TestPostFailoverScriptArguments Property

ApplicationOptionsModelTestPostFailoverScriptArguments Property
Gets or sets arguments for script to run after target is brought online during a test failover (TDV).

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TestPostFailoverScriptArguments { get; set; }
Public Property TestPostFailoverScriptArguments As String
    Get
    Set
public:
property String^ TestPostFailoverScriptArguments {
    String^ get ();
    void set (String^ value);
}
member TestPostFailoverScriptArguments : string with get, set

Property Value

Type: String
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.TestPreFailbackScript Property

ApplicationOptionsModelTestPreFailbackScript Property
Gets or sets script to run before failing back after a test failover (TDV).

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TestPreFailbackScript { get; set; }
Public Property TestPreFailbackScript As String
    Get
    Set
public:
property String^ TestPreFailbackScript {
    String^ get ();
    void set (String^ value);
}
member TestPreFailbackScript : string with get, set

Property Value

Type: String
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel.TestPreFailbackScriptArguments Property

ApplicationOptionsModelTestPreFailbackScriptArguments Property
Gets or sets arguments for script to run before failing back after a test failover (TDV).

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TestPreFailbackScriptArguments { get; set; }
Public Property TestPreFailbackScriptArguments As String
    Get
    Set
public:
property String^ TestPreFailbackScriptArguments {
    String^ get ();
    void set (String^ value);
}
member TestPreFailbackScriptArguments : string with get, set

Property Value

Type: String
See Also

Reference

ApplicationOptionsModel Class


ApplicationOptionsModel Methods

ApplicationOptionsModel Methods

The ApplicationOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ApplicationOptionsModel Class


ArchiveCriteriaModel Class

ArchiveCriteriaModel Class
Archive criteria model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsArchiveCriteriaModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ArchiveCriteriaModel
Public NotInheritable Class ArchiveCriteriaModel
public ref class ArchiveCriteriaModel sealed
[<SealedAttribute>]
type ArchiveCriteriaModel =  class end

The ArchiveCriteriaModel type exposes the following members.

Constructors
 | Name | Description
Public method | ArchiveCriteriaModel | Initializes a new instance of the ArchiveCriteriaModel class
Top
Properties
 | Name | Description
Public property | Age | Gets or sets the age.
Public property | DiskUtilizationPercentage | Gets or sets the disk utilization as a percentage.
Public property | LogErrors | Gets or sets a value indicating whether [log errors].
Public property | MinimumFileSize | Gets or sets the minimum file size.
Public property | Paths | Gets or sets the paths.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ArchiveCriteriaModel Constructor

ArchiveCriteriaModel Constructor
Initializes a new instance of the ArchiveCriteriaModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ArchiveCriteriaModel()
Public Sub New
public:
ArchiveCriteriaModel()
new : unit -> ArchiveCriteriaModel
See Also

Reference

ArchiveCriteriaModel Class


ArchiveCriteriaModel Properties

ArchiveCriteriaModel Properties

The ArchiveCriteriaModel type exposes the following members.

Properties
 | Name | Description
Public property | Age | Gets or sets the age.
Public property | DiskUtilizationPercentage | Gets or sets the disk utilization as a percentage.
Public property | LogErrors | Gets or sets a value indicating whether [log errors].
Public property | MinimumFileSize | Gets or sets the minimum file size.
Public property | Paths | Gets or sets the paths.
Top
See Also

Reference

ArchiveCriteriaModel Class


ArchiveCriteriaModel.Age Property

ArchiveCriteriaModelAge Property
Gets or sets the age.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Age { get; set; }
Public Property Age As TimeSpan
    Get
    Set
public:
property TimeSpan Age {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Age : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

ArchiveCriteriaModel Class


ArchiveCriteriaModel.DiskUtilizationPercentage Property

ArchiveCriteriaModelDiskUtilizationPercentage Property
Gets or sets the disk utilization as a percentage.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int DiskUtilizationPercentage { get; set; }
Public Property DiskUtilizationPercentage As Integer
    Get
    Set
public:
property int DiskUtilizationPercentage {
    int get ();
    void set (int value);
}
member DiskUtilizationPercentage : int with get, set

Property Value

Type: Int32
See Also

Reference

ArchiveCriteriaModel Class


ArchiveCriteriaModel.LogErrors Property

ArchiveCriteriaModelLogErrors Property
Gets or sets a value indicating whether [log errors].

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool LogErrors { get; set; }
Public Property LogErrors As Boolean
    Get
    Set
public:
property bool LogErrors {
    bool get ();
    void set (bool value);
}
member LogErrors : bool with get, set

Property Value

Type: Boolean
if [log errors]; otherwise, .
See Also

Reference

ArchiveCriteriaModel Class


ArchiveCriteriaModel.MinimumFileSize Property

ArchiveCriteriaModelMinimumFileSize Property
Gets or sets the minimum file size.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long MinimumFileSize { get; set; }
Public Property MinimumFileSize As Long
    Get
    Set
public:
property long long MinimumFileSize {
    long long get ();
    void set (long long value);
}
member MinimumFileSize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

ArchiveCriteriaModel Class


ArchiveCriteriaModel.Paths Property

ArchiveCriteriaModelPaths Property
Gets or sets the paths.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] Paths { get; set; }
Public Property Paths As String()
    Get
    Set
public:
property array<String^>^ Paths {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member Paths : string[] with get, set

Property Value

Type: String
See Also

Reference

ArchiveCriteriaModel Class


ArchiveCriteriaModel Methods

ArchiveCriteriaModel Methods

The ArchiveCriteriaModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ArchiveCriteriaModel Class


ArchiveRestoreOption Enumeration

ArchiveRestoreOption Enumeration
Archive restore option.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum ArchiveRestoreOption
Public Enumeration ArchiveRestoreOption
public enum class ArchiveRestoreOption
type ArchiveRestoreOption
Members
Member name | Value | Description
None | 0 | The none
ArchiveBeforeRestore | 1 | The archive before restore
RecallBeforeRestore | 2 | The recall before restore
See Also

Reference

DoubleTake.Web.Models Namespace


ArchiveScheduleModel Class

ArchiveScheduleModel Class
Archive schedule model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsScheduleItemModel
DoubleTake.Web.ModelsArchiveScheduleModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ArchiveScheduleModel : ScheduleItemModel
Public NotInheritable Class ArchiveScheduleModel
    Inherits ScheduleItemModel
public ref class ArchiveScheduleModel sealed : public ScheduleItemModel
[<SealedAttribute>]
type ArchiveScheduleModel =
    class
        inherit ScheduleItemModel
    end

The ArchiveScheduleModel type exposes the following members.

Constructors
 | Name | Description
Public method | ArchiveScheduleModel | Initializes a new instance of the ArchiveScheduleModel class
Top
Properties
 | Name | Description
Public property | Criteria | Gets or sets the archive criteria.
Public property | Days | Gets or sets the days to run the archive.
Public property | IsEnabled | Gets or sets a value indicating whether or not the item is enabled. (Inherited from ScheduleItemModel.)
Public property | StartTime | Gets or sets the start time.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ArchiveScheduleModel Constructor

ArchiveScheduleModel Constructor
Initializes a new instance of the ArchiveScheduleModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ArchiveScheduleModel()
Public Sub New
public:
ArchiveScheduleModel()
new : unit -> ArchiveScheduleModel
See Also

Reference

ArchiveScheduleModel Class


ArchiveScheduleModel Properties

ArchiveScheduleModel Properties

The ArchiveScheduleModel type exposes the following members.

Properties
 | Name | Description
Public property | Criteria | Gets or sets the archive criteria.
Public property | Days | Gets or sets the days to run the archive.
Public property | IsEnabled | Gets or sets a value indicating whether or not the item is enabled. (Inherited from ScheduleItemModel.)
Public property | StartTime | Gets or sets the start time.
Top
See Also

Reference

ArchiveScheduleModel Class


ArchiveScheduleModel.Criteria Property

ArchiveScheduleModelCriteria Property
Gets or sets the archive criteria.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ArchiveCriteriaModel Criteria { get; set; }
Public Property Criteria As ArchiveCriteriaModel
    Get
    Set
public:
property ArchiveCriteriaModel^ Criteria {
    ArchiveCriteriaModel^ get ();
    void set (ArchiveCriteriaModel^ value);
}
member Criteria : ArchiveCriteriaModel with get, set

Property Value

Type: ArchiveCriteriaModel
See Also

Reference

ArchiveScheduleModel Class


ArchiveScheduleModel.Days Property

ArchiveScheduleModelDays Property
Gets or sets the days to run the archive.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Weekdays Days { get; set; }
Public Property Days As Weekdays
    Get
    Set
public:
property Weekdays Days {
    Weekdays get ();
    void set (Weekdays value);
}
member Days : Weekdays with get, set

Property Value

Type: Weekdays
See Also

Reference

ArchiveScheduleModel Class


ArchiveScheduleModel.StartTime Property

ArchiveScheduleModelStartTime Property
Gets or sets the start time.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
member StartTime : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

ArchiveScheduleModel Class


ArchiveScheduleModel Methods

ArchiveScheduleModel Methods

The ArchiveScheduleModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ArchiveScheduleModel Class


BackConnectionResultsModel Class

BackConnectionResultsModel Class
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsBackConnectionResultsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class BackConnectionResultsModel
Public NotInheritable Class BackConnectionResultsModel
public ref class BackConnectionResultsModel sealed
[<SealedAttribute>]
type BackConnectionResultsModel =  class end

The BackConnectionResultsModel type exposes the following members.

Constructors
 | Name | Description
Public method | BackConnectionResultsModel | Initializes a new instance of the BackConnectionResultsModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the exception.
Public property | Id | Gets or sets the identifier.
Public property | IsReady | Gets or sets a value indicating whether this instance is ready.
Public property | Log | Gets or sets the log.
Public property | StatusCode | Gets or sets the status code.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


BackConnectionResultsModel Constructor

BackConnectionResultsModel Constructor
Initializes a new instance of the BackConnectionResultsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public BackConnectionResultsModel()
Public Sub New
public:
BackConnectionResultsModel()
new : unit -> BackConnectionResultsModel
See Also

Reference

BackConnectionResultsModel Class


BackConnectionResultsModel Properties

BackConnectionResultsModel Properties

The BackConnectionResultsModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the exception.
Public property | Id | Gets or sets the identifier.
Public property | IsReady | Gets or sets a value indicating whether this instance is ready.
Public property | Log | Gets or sets the log.
Public property | StatusCode | Gets or sets the status code.
Top
See Also

Reference

BackConnectionResultsModel Class


BackConnectionResultsModel.Exception Property

BackConnectionResultsModelException Property
Gets or sets the exception.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Exception Exception { get; set; }
Public Property Exception As Exception
    Get
    Set
public:
property Exception^ Exception {
    Exception^ get ();
    void set (Exception^ value);
}
member Exception : Exception with get, set

Property Value

Type: Exception
The exception.
See Also

Reference

BackConnectionResultsModel Class


BackConnectionResultsModel.Id Property

BackConnectionResultsModelId Property
Gets or sets the identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
member Id : Guid with get, set

Property Value

Type: Guid
The identifier.
See Also

Reference

BackConnectionResultsModel Class


BackConnectionResultsModel.IsReady Property

BackConnectionResultsModelIsReady Property
Gets or sets a value indicating whether this instance is ready.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsReady { get; set; }
Public Property IsReady As Boolean
    Get
    Set
public:
property bool IsReady {
    bool get ();
    void set (bool value);
}
member IsReady : bool with get, set

Property Value

Type: Boolean
true if this instance is ready; otherwise, false.
See Also

Reference

BackConnectionResultsModel Class


BackConnectionResultsModel.Log Property

BackConnectionResultsModelLog Property
Gets or sets the log.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Log { get; set; }
Public Property Log As String
    Get
    Set
public:
property String^ Log {
    String^ get ();
    void set (String^ value);
}
member Log : string with get, set

Property Value

Type: String
The log.
See Also

Reference

BackConnectionResultsModel Class


BackConnectionResultsModel.StatusCode Property

BackConnectionResultsModelStatusCode Property
Gets or sets the status code.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public HttpStatusCode StatusCode { get; set; }
Public Property StatusCode As HttpStatusCode
    Get
    Set
public:
property HttpStatusCode StatusCode {
    HttpStatusCode get ();
    void set (HttpStatusCode value);
}
member StatusCode : HttpStatusCode with get, set

Property Value

Type: HttpStatusCode
The status code.
See Also

Reference

BackConnectionResultsModel Class


BackConnectionResultsModel Methods

BackConnectionResultsModel Methods

The BackConnectionResultsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BackConnectionResultsModel Class


BandwidthEntryModel Class

BandwidthEntryModel Class
Bandwidth entry model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsBandwidthEntryModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class BandwidthEntryModel
Public NotInheritable Class BandwidthEntryModel
public ref class BandwidthEntryModel sealed
[<SealedAttribute>]
type BandwidthEntryModel =  class end

The BandwidthEntryModel type exposes the following members.

Constructors
 | Name | Description
Public method | BandwidthEntryModel | Initializes a new instance of the BandwidthEntryModel class
Top
Properties
 | Name | Description
Public property | DaysOfWeek | Gets or sets the days of the week to which the entry applies.
Public property | EndTime | Gets or sets the end time of the entry.
Public property | EntryType | Gets or sets the type of the entry.
Public property | IsUnlimited | Gets or sets a value indicating whether or not this entry allows unlimited bandwidth.
Public property | Limit | Gets or sets the bandwidth limit for the entry, in bytes per second.
Public property | Name | Gets or sets the name of the bandwidth schedule entry.
Public property | StartTime | Gets or sets the start time of the entry.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


BandwidthEntryModel Constructor

BandwidthEntryModel Constructor
Initializes a new instance of the BandwidthEntryModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthEntryModel()
Public Sub New
public:
BandwidthEntryModel()
new : unit -> BandwidthEntryModel
See Also

Reference

BandwidthEntryModel Class


BandwidthEntryModel Properties

BandwidthEntryModel Properties

The BandwidthEntryModel type exposes the following members.

Properties
 | Name | Description
Public property | DaysOfWeek | Gets or sets the days of the week to which the entry applies.
Public property | EndTime | Gets or sets the end time of the entry.
Public property | EntryType | Gets or sets the type of the entry.
Public property | IsUnlimited | Gets or sets a value indicating whether or not this entry allows unlimited bandwidth.
Public property | Limit | Gets or sets the bandwidth limit for the entry, in bytes per second.
Public property | Name | Gets or sets the name of the bandwidth schedule entry.
Public property | StartTime | Gets or sets the start time of the entry.
Top
See Also

Reference

BandwidthEntryModel Class


BandwidthEntryModel.DaysOfWeek Property

BandwidthEntryModelDaysOfWeek Property
Gets or sets the days of the week to which the entry applies.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Weekdays DaysOfWeek { get; set; }
Public Property DaysOfWeek As Weekdays
    Get
    Set
public:
property Weekdays DaysOfWeek {
    Weekdays get ();
    void set (Weekdays value);
}
member DaysOfWeek : Weekdays with get, set

Property Value

Type: Weekdays
See Also

Reference

BandwidthEntryModel Class


BandwidthEntryModel.EndTime Property

BandwidthEntryModelEndTime Property
Gets or sets the end time of the entry.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime EndTime { get; set; }
Public Property EndTime As DateTime
    Get
    Set
public:
property DateTime EndTime {
    DateTime get ();
    void set (DateTime value);
}
member EndTime : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

BandwidthEntryModel Class


BandwidthEntryModel.EntryType Property

BandwidthEntryModelEntryType Property
Gets or sets the type of the entry.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthEntryType EntryType { get; set; }
Public Property EntryType As BandwidthEntryType
    Get
    Set
public:
property BandwidthEntryType EntryType {
    BandwidthEntryType get ();
    void set (BandwidthEntryType value);
}
member EntryType : BandwidthEntryType with get, set

Property Value

Type: BandwidthEntryType
See Also

Reference

BandwidthEntryModel Class


BandwidthEntryModel.IsUnlimited Property

BandwidthEntryModelIsUnlimited Property
Gets or sets a value indicating whether or not this entry allows unlimited bandwidth.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsUnlimited { get; set; }
Public Property IsUnlimited As Boolean
    Get
    Set
public:
property bool IsUnlimited {
    bool get ();
    void set (bool value);
}
member IsUnlimited : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BandwidthEntryModel Class


BandwidthEntryModel.Limit Property

BandwidthEntryModelLimit Property
Gets or sets the bandwidth limit for the entry, in bytes per second.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long Limit { get; set; }
Public Property Limit As Long
    Get
    Set
public:
property long long Limit {
    long long get ();
    void set (long long value);
}
member Limit : int64 with get, set

Property Value

Type: Int64
See Also

Reference

BandwidthEntryModel Class


BandwidthEntryModel.Name Property

BandwidthEntryModelName Property
Gets or sets the name of the bandwidth schedule entry.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

BandwidthEntryModel Class


BandwidthEntryModel.StartTime Property

BandwidthEntryModelStartTime Property
Gets or sets the start time of the entry.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
member StartTime : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

BandwidthEntryModel Class


BandwidthEntryModel Methods

BandwidthEntryModel Methods

The BandwidthEntryModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BandwidthEntryModel Class


BandwidthEntryType Enumeration

BandwidthEntryType Enumeration
Bandwidth entry type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum BandwidthEntryType
Public Enumeration BandwidthEntryType
public enum class BandwidthEntryType
type BandwidthEntryType
Members
Member name | Value | Description
Daytime | 0 | The daytime
Overnight | 1 | The overnight
See Also

Reference

DoubleTake.Web.Models Namespace


BandwidthLimitModel Class

BandwidthLimitModel Class
Used for specifying the current or new bandwidth limit and/or mode.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsBandwidthLimitModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public class BandwidthLimitModel
Public Class BandwidthLimitModel
public ref class BandwidthLimitModel
type BandwidthLimitModel =  class end

The BandwidthLimitModel type exposes the following members.

Constructors
 | Name | Description
Public method | BandwidthLimitModel | Initializes a new instance of the BandwidthLimitModel class
Top
Properties
 | Name | Description
Public property | Limit | Gets or sets the bandwidth limit in bytes per second.
Public property | Mode | Gets or sets the bandwidth limiting mode.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


BandwidthLimitModel Constructor

BandwidthLimitModel Constructor
Initializes a new instance of the BandwidthLimitModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthLimitModel()
Public Sub New
public:
BandwidthLimitModel()
new : unit -> BandwidthLimitModel
See Also

Reference

BandwidthLimitModel Class


BandwidthLimitModel Properties

BandwidthLimitModel Properties

The BandwidthLimitModel type exposes the following members.

Properties
 | Name | Description
Public property | Limit | Gets or sets the bandwidth limit in bytes per second.
Public property | Mode | Gets or sets the bandwidth limiting mode.
Top
See Also

Reference

BandwidthLimitModel Class


BandwidthLimitModel.Limit Property

BandwidthLimitModelLimit Property
Gets or sets the bandwidth limit in bytes per second.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long Limit { get; set; }
Public Property Limit As Long
    Get
    Set
public:
property long long Limit {
    long long get ();
    void set (long long value);
}
member Limit : int64 with get, set

Property Value

Type: Int64
See Also

Reference

BandwidthLimitModel Class


BandwidthLimitModel.Mode Property

BandwidthLimitModelMode Property
Gets or sets the bandwidth limiting mode.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthScheduleMode Mode { get; set; }
Public Property Mode As BandwidthScheduleMode
    Get
    Set
public:
property BandwidthScheduleMode Mode {
    BandwidthScheduleMode get ();
    void set (BandwidthScheduleMode value);
}
member Mode : BandwidthScheduleMode with get, set

Property Value

Type: BandwidthScheduleMode
See Also

Reference

BandwidthLimitModel Class


BandwidthLimitModel Methods

BandwidthLimitModel Methods

The BandwidthLimitModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BandwidthLimitModel Class


BandwidthOptionsModel Class

BandwidthOptionsModel Class
Bandwidth options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsBandwidthOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class BandwidthOptionsModel
Public NotInheritable Class BandwidthOptionsModel
public ref class BandwidthOptionsModel sealed
[<SealedAttribute>]
type BandwidthOptionsModel =  class end

The BandwidthOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | BandwidthOptionsModel | Initializes a new instance of the BandwidthOptionsModel class
Top
Properties
 | Name | Description
Public property | Entries | Gets or sets the entries in the bandwidth limiting schedule.
Public property | Limit | Gets or sets the bandwidth limit, in bytes per second.
Public property | Mode | Gets or sets the mode of the bandwidth schedule.
Public property | Specifications | Gets or sets the common bandwidth specifications, such as T1 or ISDN.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


BandwidthOptionsModel Constructor

BandwidthOptionsModel Constructor
Initializes a new instance of the BandwidthOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthOptionsModel()
Public Sub New
public:
BandwidthOptionsModel()
new : unit -> BandwidthOptionsModel
See Also

Reference

BandwidthOptionsModel Class


BandwidthOptionsModel Properties

BandwidthOptionsModel Properties

The BandwidthOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | Entries | Gets or sets the entries in the bandwidth limiting schedule.
Public property | Limit | Gets or sets the bandwidth limit, in bytes per second.
Public property | Mode | Gets or sets the mode of the bandwidth schedule.
Public property | Specifications | Gets or sets the common bandwidth specifications, such as T1 or ISDN.
Top
See Also

Reference

BandwidthOptionsModel Class


BandwidthOptionsModel.Entries Property

BandwidthOptionsModelEntries Property
Gets or sets the entries in the bandwidth limiting schedule.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthEntryModel[] Entries { get; set; }
Public Property Entries As BandwidthEntryModel()
    Get
    Set
public:
property array<BandwidthEntryModel^>^ Entries {
    array<BandwidthEntryModel^>^ get ();
    void set (array<BandwidthEntryModel^>^ value);
}
member Entries : BandwidthEntryModel[] with get, set

Property Value

Type: BandwidthEntryModel
See Also

Reference

BandwidthOptionsModel Class


BandwidthOptionsModel.Limit Property

BandwidthOptionsModelLimit Property
Gets or sets the bandwidth limit, in bytes per second.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long Limit { get; set; }
Public Property Limit As Long
    Get
    Set
public:
property long long Limit {
    long long get ();
    void set (long long value);
}
member Limit : int64 with get, set

Property Value

Type: Int64
See Also

Reference

BandwidthOptionsModel Class


BandwidthOptionsModel.Mode Property

BandwidthOptionsModelMode Property
Gets or sets the mode of the bandwidth schedule.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthScheduleMode Mode { get; set; }
Public Property Mode As BandwidthScheduleMode
    Get
    Set
public:
property BandwidthScheduleMode Mode {
    BandwidthScheduleMode get ();
    void set (BandwidthScheduleMode value);
}
member Mode : BandwidthScheduleMode with get, set

Property Value

Type: BandwidthScheduleMode
See Also

Reference

BandwidthOptionsModel Class


BandwidthOptionsModel.Specifications Property

BandwidthOptionsModelSpecifications Property
Gets or sets the common bandwidth specifications, such as T1 or ISDN.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthSpecificationModel[] Specifications { get; set; }
Public Property Specifications As BandwidthSpecificationModel()
    Get
    Set
public:
property array<BandwidthSpecificationModel^>^ Specifications {
    array<BandwidthSpecificationModel^>^ get ();
    void set (array<BandwidthSpecificationModel^>^ value);
}
member Specifications : BandwidthSpecificationModel[] with get, set

Property Value

Type: BandwidthSpecificationModel
See Also

Reference

BandwidthOptionsModel Class


BandwidthOptionsModel Methods

BandwidthOptionsModel Methods

The BandwidthOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BandwidthOptionsModel Class


BandwidthScheduleEntryModel Class

BandwidthScheduleEntryModel Class
Bandwidth schedule entry model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsBandwidthScheduleEntryModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class BandwidthScheduleEntryModel
Public NotInheritable Class BandwidthScheduleEntryModel
public ref class BandwidthScheduleEntryModel sealed
[<SealedAttribute>]
type BandwidthScheduleEntryModel =  class end

The BandwidthScheduleEntryModel type exposes the following members.

Constructors
 | Name | Description
Public method | BandwidthScheduleEntryModel | Initializes a new instance of the BandwidthScheduleEntryModel class
Top
Properties
 | Name | Description
Public property | DaysOfWeek | Gets or sets indicates the days on which this entry will be active.
Public property | IsUnlimited | Gets or sets a value indicating whether or not bandwidth is being limited while this entry is active.
Public property | Limit | Gets or sets the network throughput limit in Bps (bytes-per-second).
Public property | Name | Gets or sets the unique name of this entry.
Public property | StartTime | Gets or sets indicates time of day at which this entry will be active.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


BandwidthScheduleEntryModel Constructor

BandwidthScheduleEntryModel Constructor
Initializes a new instance of the BandwidthScheduleEntryModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthScheduleEntryModel()
Public Sub New
public:
BandwidthScheduleEntryModel()
new : unit -> BandwidthScheduleEntryModel
See Also

Reference

BandwidthScheduleEntryModel Class


BandwidthScheduleEntryModel Properties

BandwidthScheduleEntryModel Properties

The BandwidthScheduleEntryModel type exposes the following members.

Properties
 | Name | Description
Public property | DaysOfWeek | Gets or sets indicates the days on which this entry will be active.
Public property | IsUnlimited | Gets or sets a value indicating whether or not bandwidth is being limited while this entry is active.
Public property | Limit | Gets or sets the network throughput limit in Bps (bytes-per-second).
Public property | Name | Gets or sets the unique name of this entry.
Public property | StartTime | Gets or sets indicates time of day at which this entry will be active.
Top
See Also

Reference

BandwidthScheduleEntryModel Class


BandwidthScheduleEntryModel.DaysOfWeek Property

BandwidthScheduleEntryModelDaysOfWeek Property
Gets or sets indicates the days on which this entry will be active.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Weekdays DaysOfWeek { get; set; }
Public Property DaysOfWeek As Weekdays
    Get
    Set
public:
property Weekdays DaysOfWeek {
    Weekdays get ();
    void set (Weekdays value);
}
member DaysOfWeek : Weekdays with get, set

Property Value

Type: Weekdays
See Also

Reference

BandwidthScheduleEntryModel Class


BandwidthScheduleEntryModel.IsUnlimited Property

BandwidthScheduleEntryModelIsUnlimited Property
Gets or sets a value indicating whether or not bandwidth is being limited while this entry is active.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsUnlimited { get; set; }
Public Property IsUnlimited As Boolean
    Get
    Set
public:
property bool IsUnlimited {
    bool get ();
    void set (bool value);
}
member IsUnlimited : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BandwidthScheduleEntryModel Class


BandwidthScheduleEntryModel.Limit Property

BandwidthScheduleEntryModelLimit Property
Gets or sets the network throughput limit in Bps (bytes-per-second).

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long Limit { get; set; }
Public Property Limit As Long
    Get
    Set
public:
property long long Limit {
    long long get ();
    void set (long long value);
}
member Limit : int64 with get, set

Property Value

Type: Int64
See Also

Reference

BandwidthScheduleEntryModel Class


BandwidthScheduleEntryModel.Name Property

BandwidthScheduleEntryModelName Property
Gets or sets the unique name of this entry.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

BandwidthScheduleEntryModel Class


BandwidthScheduleEntryModel.StartTime Property

BandwidthScheduleEntryModelStartTime Property
Gets or sets indicates time of day at which this entry will be active.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
member StartTime : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

BandwidthScheduleEntryModel Class


BandwidthScheduleEntryModel Methods

BandwidthScheduleEntryModel Methods

The BandwidthScheduleEntryModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BandwidthScheduleEntryModel Class


BandwidthScheduleMode Enumeration

BandwidthScheduleMode Enumeration
Bandwidth schedule mode.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum BandwidthScheduleMode
Public Enumeration BandwidthScheduleMode
public enum class BandwidthScheduleMode
type BandwidthScheduleMode
Members
Member name | Value | Description
NotLimited | 0 | The not limited
Fixed | 1 | The fixed
Scheduled | 2 | The scheduled
See Also

Reference

DoubleTake.Web.Models Namespace


BandwidthScheduleModel Class

BandwidthScheduleModel Class
Bandwidth schedule model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsBandwidthScheduleModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class BandwidthScheduleModel
Public NotInheritable Class BandwidthScheduleModel
public ref class BandwidthScheduleModel sealed
[<SealedAttribute>]
type BandwidthScheduleModel =  class end

The BandwidthScheduleModel type exposes the following members.

Constructors
 | Name | Description
Public method | BandwidthScheduleModel | Initializes a new instance of the BandwidthScheduleModel class
Top
Properties
 | Name | Description
Public property | Current | Gets or sets the active bandwidth schedule entry.
Public property | Entries | Gets or sets the bandwidth schedule entries.
Public property | Mode | Gets or sets the current bandwidth schedule mode for a connection.
Public property | Specifications | Gets or sets the bandwidth specifications.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


BandwidthScheduleModel Constructor

BandwidthScheduleModel Constructor
Initializes a new instance of the BandwidthScheduleModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthScheduleModel()
Public Sub New
public:
BandwidthScheduleModel()
new : unit -> BandwidthScheduleModel
See Also

Reference

BandwidthScheduleModel Class


BandwidthScheduleModel Properties

BandwidthScheduleModel Properties

The BandwidthScheduleModel type exposes the following members.

Properties
 | Name | Description
Public property | Current | Gets or sets the active bandwidth schedule entry.
Public property | Entries | Gets or sets the bandwidth schedule entries.
Public property | Mode | Gets or sets the current bandwidth schedule mode for a connection.
Public property | Specifications | Gets or sets the bandwidth specifications.
Top
See Also

Reference

BandwidthScheduleModel Class


BandwidthScheduleModel.Current Property

BandwidthScheduleModelCurrent Property
Gets or sets the active bandwidth schedule entry.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthScheduleEntryModel Current { get; set; }
Public Property Current As BandwidthScheduleEntryModel
    Get
    Set
public:
property BandwidthScheduleEntryModel^ Current {
    BandwidthScheduleEntryModel^ get ();
    void set (BandwidthScheduleEntryModel^ value);
}
member Current : BandwidthScheduleEntryModel with get, set

Property Value

Type: BandwidthScheduleEntryModel
See Also

Reference

BandwidthScheduleModel Class


BandwidthScheduleModel.Entries Property

BandwidthScheduleModelEntries Property
Gets or sets the bandwidth schedule entries.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthScheduleEntryModel[] Entries { get; set; }
Public Property Entries As BandwidthScheduleEntryModel()
    Get
    Set
public:
property array<BandwidthScheduleEntryModel^>^ Entries {
    array<BandwidthScheduleEntryModel^>^ get ();
    void set (array<BandwidthScheduleEntryModel^>^ value);
}
member Entries : BandwidthScheduleEntryModel[] with get, set

Property Value

Type: BandwidthScheduleEntryModel
See Also

Reference

BandwidthScheduleModel Class


BandwidthScheduleModel.Mode Property

BandwidthScheduleModelMode Property
Gets or sets the current bandwidth schedule mode for a connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthScheduleMode Mode { get; set; }
Public Property Mode As BandwidthScheduleMode
    Get
    Set
public:
property BandwidthScheduleMode Mode {
    BandwidthScheduleMode get ();
    void set (BandwidthScheduleMode value);
}
member Mode : BandwidthScheduleMode with get, set

Property Value

Type: BandwidthScheduleMode
See Also

Reference

BandwidthScheduleModel Class


BandwidthScheduleModel.Specifications Property

BandwidthScheduleModelSpecifications Property
Gets or sets the bandwidth specifications.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthSpecificationModel[] Specifications { get; set; }
Public Property Specifications As BandwidthSpecificationModel()
    Get
    Set
public:
property array<BandwidthSpecificationModel^>^ Specifications {
    array<BandwidthSpecificationModel^>^ get ();
    void set (array<BandwidthSpecificationModel^>^ value);
}
member Specifications : BandwidthSpecificationModel[] with get, set

Property Value

Type: BandwidthSpecificationModel
See Also

Reference

BandwidthScheduleModel Class


BandwidthScheduleModel Methods

BandwidthScheduleModel Methods

The BandwidthScheduleModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BandwidthScheduleModel Class


BandwidthSpecificationModel Class

BandwidthSpecificationModel Class
Bandwidth specification model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsBandwidthSpecificationModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class BandwidthSpecificationModel
Public NotInheritable Class BandwidthSpecificationModel
public ref class BandwidthSpecificationModel sealed
[<SealedAttribute>]
type BandwidthSpecificationModel =  class end

The BandwidthSpecificationModel type exposes the following members.

Constructors
 | Name | Description
Public method | BandwidthSpecificationModel | Initializes a new instance of the BandwidthSpecificationModel class
Top
Properties
 | Name | Description
Public property | BandwidthType | Gets or sets the type of the bandwidth specification.
Public property | Key | Gets or sets the name of the bandwidth specification.
Public property | Value | Gets or sets the speed of the bandwidth specification, in bytes per second.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


BandwidthSpecificationModel Constructor

BandwidthSpecificationModel Constructor
Initializes a new instance of the BandwidthSpecificationModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthSpecificationModel()
Public Sub New
public:
BandwidthSpecificationModel()
new : unit -> BandwidthSpecificationModel
See Also

Reference

BandwidthSpecificationModel Class


BandwidthSpecificationModel Properties

BandwidthSpecificationModel Properties

The BandwidthSpecificationModel type exposes the following members.

Properties
 | Name | Description
Public property | BandwidthType | Gets or sets the type of the bandwidth specification.
Public property | Key | Gets or sets the name of the bandwidth specification.
Public property | Value | Gets or sets the speed of the bandwidth specification, in bytes per second.
Top
See Also

Reference

BandwidthSpecificationModel Class


BandwidthSpecificationModel.BandwidthType Property

BandwidthSpecificationModelBandwidthType Property
Gets or sets the type of the bandwidth specification.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthSpecificationType BandwidthType { get; set; }
Public Property BandwidthType As BandwidthSpecificationType
    Get
    Set
public:
property BandwidthSpecificationType BandwidthType {
    BandwidthSpecificationType get ();
    void set (BandwidthSpecificationType value);
}
member BandwidthType : BandwidthSpecificationType with get, set

Property Value

Type: BandwidthSpecificationType
See Also

Reference

BandwidthSpecificationModel Class


BandwidthSpecificationModel.Key Property

BandwidthSpecificationModelKey Property
Gets or sets the name of the bandwidth specification.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Key { get; set; }
Public Property Key As String
    Get
    Set
public:
property String^ Key {
    String^ get ();
    void set (String^ value);
}
member Key : string with get, set

Property Value

Type: String
See Also

Reference

BandwidthSpecificationModel Class


BandwidthSpecificationModel.Value Property

BandwidthSpecificationModelValue Property
Gets or sets the speed of the bandwidth specification, in bytes per second.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long Value { get; set; }
Public Property Value As Long
    Get
    Set
public:
property long long Value {
    long long get ();
    void set (long long value);
}
member Value : int64 with get, set

Property Value

Type: Int64
See Also

Reference

BandwidthSpecificationModel Class


BandwidthSpecificationModel Methods

BandwidthSpecificationModel Methods

The BandwidthSpecificationModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BandwidthSpecificationModel Class


BandwidthSpecificationType Enumeration

BandwidthSpecificationType Enumeration
Bandwidth specification type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum BandwidthSpecificationType
Public Enumeration BandwidthSpecificationType
public enum class BandwidthSpecificationType
type BandwidthSpecificationType
Members
Member name | Value | Description
LAN | 0 | The lan
WAN | 1 | The wan
See Also

Reference

DoubleTake.Web.Models Namespace


BooleanSettingModel Class

BooleanSettingModel Class
Boolean setting.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsNamedSettingModel
DoubleTake.Web.ModelsBooleanSettingModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class BooleanSettingModel : NamedSettingModel
Public Class BooleanSettingModel
    Inherits NamedSettingModel
public ref class BooleanSettingModel : public NamedSettingModel
type BooleanSettingModel =
    class
        inherit NamedSettingModel
    end

The BooleanSettingModel type exposes the following members.

Constructors
 | Name | Description
Public method | BooleanSettingModel | Initializes a new instance of the BooleanSettingModel class
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name. (Inherited from NamedSettingModel.)
Public property | TypeName | Gets or sets the type name. (Inherited from NamedSettingModel.)
Public property | Value | Gets or sets a value indicating whether the setting is true.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


BooleanSettingModel Constructor

BooleanSettingModel Constructor
Initializes a new instance of the BooleanSettingModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public BooleanSettingModel()
Public Sub New
public:
BooleanSettingModel()
new : unit -> BooleanSettingModel
See Also

Reference

BooleanSettingModel Class


BooleanSettingModel Properties

BooleanSettingModel Properties

The BooleanSettingModel type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name. (Inherited from NamedSettingModel.)
Public property | TypeName | Gets or sets the type name. (Inherited from NamedSettingModel.)
Public property | Value | Gets or sets a value indicating whether the setting is true.
Top
See Also

Reference

BooleanSettingModel Class


BooleanSettingModel.Value Property

BooleanSettingModelValue Property
Gets or sets a value indicating whether the setting is true.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool Value { get; set; }
Public Property Value As Boolean
    Get
    Set
public:
property bool Value {
    bool get ();
    void set (bool value);
}
member Value : bool with get, set

Property Value

Type: Boolean
See Also

Reference

BooleanSettingModel Class


BooleanSettingModel Methods

BooleanSettingModel Methods

The BooleanSettingModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BooleanSettingModel Class


ChangedItemsModel Class

ChangedItemsModel Class
Changed items model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsChangedItemsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ChangedItemsModel
Public NotInheritable Class ChangedItemsModel
public ref class ChangedItemsModel sealed
[<SealedAttribute>]
type ChangedItemsModel =  class end

The ChangedItemsModel type exposes the following members.

Constructors
 | Name | Description
Public method | ChangedItemsModel | Initializes a new instance of the ChangedItemsModel class
Top
Properties
 | Name | Description
Public property | LogicalItems | Gets or sets the logical items that changed.
Public property | LogicalRules | Gets or sets the new set of logical rules associated with this workload.
Public property | PhysicalItems | Gets or sets the physical items that changed.
Public property | PhysicalRules | Gets or sets the new set of physical rules associated with this workload.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ChangedItemsModel Constructor

ChangedItemsModel Constructor
Initializes a new instance of the ChangedItemsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ChangedItemsModel()
Public Sub New
public:
ChangedItemsModel()
new : unit -> ChangedItemsModel
See Also

Reference

ChangedItemsModel Class


ChangedItemsModel Properties

ChangedItemsModel Properties

The ChangedItemsModel type exposes the following members.

Properties
 | Name | Description
Public property | LogicalItems | Gets or sets the logical items that changed.
Public property | LogicalRules | Gets or sets the new set of logical rules associated with this workload.
Public property | PhysicalItems | Gets or sets the physical items that changed.
Public property | PhysicalRules | Gets or sets the new set of physical rules associated with this workload.
Top
See Also

Reference

ChangedItemsModel Class


ChangedItemsModel.LogicalItems Property

ChangedItemsModelLogicalItems Property
Gets or sets the logical items that changed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public LogicalItemModel[] LogicalItems { get; set; }
Public Property LogicalItems As LogicalItemModel()
    Get
    Set
public:
property array<LogicalItemModel^>^ LogicalItems {
    array<LogicalItemModel^>^ get ();
    void set (array<LogicalItemModel^>^ value);
}
member LogicalItems : LogicalItemModel[] with get, set

Property Value

Type: LogicalItemModel
See Also

Reference

ChangedItemsModel Class


ChangedItemsModel.LogicalRules Property

ChangedItemsModelLogicalRules Property
Gets or sets the new set of logical rules associated with this workload.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] LogicalRules { get; set; }
Public Property LogicalRules As String()
    Get
    Set
public:
property array<String^>^ LogicalRules {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member LogicalRules : string[] with get, set

Property Value

Type: String
See Also

Reference

ChangedItemsModel Class


ChangedItemsModel.PhysicalItems Property

ChangedItemsModelPhysicalItems Property
Gets or sets the physical items that changed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public PhysicalItemModel[] PhysicalItems { get; set; }
Public Property PhysicalItems As PhysicalItemModel()
    Get
    Set
public:
property array<PhysicalItemModel^>^ PhysicalItems {
    array<PhysicalItemModel^>^ get ();
    void set (array<PhysicalItemModel^>^ value);
}
member PhysicalItems : PhysicalItemModel[] with get, set

Property Value

Type: PhysicalItemModel
See Also

Reference

ChangedItemsModel Class


ChangedItemsModel.PhysicalRules Property

ChangedItemsModelPhysicalRules Property
Gets or sets the new set of physical rules associated with this workload.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public PhysicalRuleModel[] PhysicalRules { get; set; }
Public Property PhysicalRules As PhysicalRuleModel()
    Get
    Set
public:
property array<PhysicalRuleModel^>^ PhysicalRules {
    array<PhysicalRuleModel^>^ get ();
    void set (array<PhysicalRuleModel^>^ value);
}
member PhysicalRules : PhysicalRuleModel[] with get, set

Property Value

Type: PhysicalRuleModel
See Also

Reference

ChangedItemsModel Class


ChangedItemsModel Methods

ChangedItemsModel Methods

The ChangedItemsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ChangedItemsModel Class


CloudOptionsModel Class

CloudOptionsModel Class
Cloud options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCloudOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class CloudOptionsModel
Public NotInheritable Class CloudOptionsModel
public ref class CloudOptionsModel sealed
[<SealedAttribute>]
type CloudOptionsModel =  class end

The CloudOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | CloudOptionsModel | Initializes a new instance of the CloudOptionsModel class
Top
Properties
 | Name | Description
Public property | EngineJobType | Gets or sets the engine job type for the connection.
Public property | HardLinkLogPath | Gets or sets the path for the hard link processing log/report.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CloudOptionsModel Constructor

CloudOptionsModel Constructor
Initializes a new instance of the CloudOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CloudOptionsModel()
Public Sub New
public:
CloudOptionsModel()
new : unit -> CloudOptionsModel
See Also

Reference

CloudOptionsModel Class


CloudOptionsModel Properties

CloudOptionsModel Properties

The CloudOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | EngineJobType | Gets or sets the engine job type for the connection.
Public property | HardLinkLogPath | Gets or sets the path for the hard link processing log/report.
Top
See Also

Reference

CloudOptionsModel Class


CloudOptionsModel.EngineJobType Property

CloudOptionsModelEngineJobType Property
Gets or sets the engine job type for the connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public EngineJobType EngineJobType { get; set; }
Public Property EngineJobType As EngineJobType
    Get
    Set
public:
property EngineJobType EngineJobType {
    EngineJobType get ();
    void set (EngineJobType value);
}
member EngineJobType : EngineJobType with get, set

Property Value

Type: EngineJobType
See Also

Reference

CloudOptionsModel Class


CloudOptionsModel.HardLinkLogPath Property

CloudOptionsModelHardLinkLogPath Property
Gets or sets the path for the hard link processing log/report.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string HardLinkLogPath { get; set; }
Public Property HardLinkLogPath As String
    Get
    Set
public:
property String^ HardLinkLogPath {
    String^ get ();
    void set (String^ value);
}
member HardLinkLogPath : string with get, set

Property Value

Type: String
See Also

Reference

CloudOptionsModel Class


CloudOptionsModel Methods

CloudOptionsModel Methods

The CloudOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CloudOptionsModel Class


ClusteredVirtualMachineModel Class

ClusteredVirtualMachineModel Class
A clustered VM
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsClusteredVirtualMachineModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class ClusteredVirtualMachineModel
Public Class ClusteredVirtualMachineModel
public ref class ClusteredVirtualMachineModel
type ClusteredVirtualMachineModel =  class end

The ClusteredVirtualMachineModel type exposes the following members.

Constructors
 | Name | Description
Public method | ClusteredVirtualMachineModel | Initializes a new instance of the ClusteredVirtualMachineModel class
Top
Properties
 | Name | Description
Public property | Id | Gets or sets the unique identifier.
Public property | Name | Gets or sets the name of the VM.
Public property | OwningNode | Gets or sets the current owning node.
Public property | StoragePath | Gets or sets the storage location.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ClusteredVirtualMachineModel Constructor

ClusteredVirtualMachineModel Constructor
Initializes a new instance of the ClusteredVirtualMachineModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ClusteredVirtualMachineModel()
Public Sub New
public:
ClusteredVirtualMachineModel()
new : unit -> ClusteredVirtualMachineModel
See Also

Reference

ClusteredVirtualMachineModel Class


ClusteredVirtualMachineModel Properties

ClusteredVirtualMachineModel Properties

The ClusteredVirtualMachineModel type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets or sets the unique identifier.
Public property | Name | Gets or sets the name of the VM.
Public property | OwningNode | Gets or sets the current owning node.
Public property | StoragePath | Gets or sets the storage location.
Top
See Also

Reference

ClusteredVirtualMachineModel Class


ClusteredVirtualMachineModel.Id Property

ClusteredVirtualMachineModelId Property
Gets or sets the unique identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
member Id : string with get, set

Property Value

Type: String
See Also

Reference

ClusteredVirtualMachineModel Class


ClusteredVirtualMachineModel.Name Property

ClusteredVirtualMachineModelName Property
Gets or sets the name of the VM.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

ClusteredVirtualMachineModel Class


ClusteredVirtualMachineModel.OwningNode Property

ClusteredVirtualMachineModelOwningNode Property
Gets or sets the current owning node.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string OwningNode { get; set; }
Public Property OwningNode As String
    Get
    Set
public:
property String^ OwningNode {
    String^ get ();
    void set (String^ value);
}
member OwningNode : string with get, set

Property Value

Type: String
See Also

Reference

ClusteredVirtualMachineModel Class


ClusteredVirtualMachineModel.StoragePath Property

ClusteredVirtualMachineModelStoragePath Property
Gets or sets the storage location.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string StoragePath { get; set; }
Public Property StoragePath As String
    Get
    Set
public:
property String^ StoragePath {
    String^ get ();
    void set (String^ value);
}
member StoragePath : string with get, set

Property Value

Type: String
See Also

Reference

ClusteredVirtualMachineModel Class


ClusteredVirtualMachineModel Methods

ClusteredVirtualMachineModel Methods

The ClusteredVirtualMachineModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ClusteredVirtualMachineModel Class


ClusteredVirtualMachineResourceInfoModel Class

ClusteredVirtualMachineResourceInfoModel Class
Clustered virtual machine resource information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsClusteredVirtualMachineResourceInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class ClusteredVirtualMachineResourceInfoModel
Public Class ClusteredVirtualMachineResourceInfoModel
public ref class ClusteredVirtualMachineResourceInfoModel
type ClusteredVirtualMachineResourceInfoModel =  class end

The ClusteredVirtualMachineResourceInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ClusteredVirtualMachineResourceInfoModel | Initializes a new instance of the ClusteredVirtualMachineResourceInfoModel class
Top
Properties
 | Name | Description
Public property | VmCfgResourceName | Gets or sets the cluster VM configuration resource name.
Public property | VmGuid | Gets or sets the cluster VM GUID.
Public property | VmResourceName | Gets or sets the cluster VM resource name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ClusteredVirtualMachineResourceInfoModel Constructor

ClusteredVirtualMachineResourceInfoModel Constructor
Initializes a new instance of the ClusteredVirtualMachineResourceInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ClusteredVirtualMachineResourceInfoModel()
Public Sub New
public:
ClusteredVirtualMachineResourceInfoModel()
new : unit -> ClusteredVirtualMachineResourceInfoModel
See Also

Reference

ClusteredVirtualMachineResourceInfoModel Class


ClusteredVirtualMachineResourceInfoModel Properties

ClusteredVirtualMachineResourceInfoModel Properties

The ClusteredVirtualMachineResourceInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | VmCfgResourceName | Gets or sets the cluster VM configuration resource name.
Public property | VmGuid | Gets or sets the cluster VM GUID.
Public property | VmResourceName | Gets or sets the cluster VM resource name.
Top
See Also

Reference

ClusteredVirtualMachineResourceInfoModel Class


ClusteredVirtualMachineResourceInfoModel.VmCfgResourceName Property

ClusteredVirtualMachineResourceInfoModelVmCfgResourceName Property
Gets or sets the cluster VM configuration resource name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string VmCfgResourceName { get; set; }
Public Property VmCfgResourceName As String
    Get
    Set
public:
property String^ VmCfgResourceName {
    String^ get ();
    void set (String^ value);
}
member VmCfgResourceName : string with get, set

Property Value

Type: String
See Also

Reference

ClusteredVirtualMachineResourceInfoModel Class


ClusteredVirtualMachineResourceInfoModel.VmGuid Property

ClusteredVirtualMachineResourceInfoModelVmGuid Property
Gets or sets the cluster VM GUID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string VmGuid { get; set; }
Public Property VmGuid As String
    Get
    Set
public:
property String^ VmGuid {
    String^ get ();
    void set (String^ value);
}
member VmGuid : string with get, set

Property Value

Type: String
See Also

Reference

ClusteredVirtualMachineResourceInfoModel Class


ClusteredVirtualMachineResourceInfoModel.VmResourceName Property

ClusteredVirtualMachineResourceInfoModelVmResourceName Property
Gets or sets the cluster VM resource name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string VmResourceName { get; set; }
Public Property VmResourceName As String
    Get
    Set
public:
property String^ VmResourceName {
    String^ get ();
    void set (String^ value);
}
member VmResourceName : string with get, set

Property Value

Type: String
See Also

Reference

ClusteredVirtualMachineResourceInfoModel Class


ClusteredVirtualMachineResourceInfoModel Methods

ClusteredVirtualMachineResourceInfoModel Methods

The ClusteredVirtualMachineResourceInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ClusteredVirtualMachineResourceInfoModel Class


ClusteredVirtualMachinesInfoModel Class

ClusteredVirtualMachinesInfoModel Class
Clustered VM Groups
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsClusteredVirtualMachinesInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class ClusteredVirtualMachinesInfoModel
Public Class ClusteredVirtualMachinesInfoModel
public ref class ClusteredVirtualMachinesInfoModel
type ClusteredVirtualMachinesInfoModel =  class end

The ClusteredVirtualMachinesInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ClusteredVirtualMachinesInfoModel | Initializes a new instance of the ClusteredVirtualMachinesInfoModel class
Top
Properties
 | Name | Description
Public property | Group | Gets or sets the group name.
Public property | OwningNode | Gets or sets the owning node of the group.
Public property | VirtualMachine | Gets or sets the virtual machine information.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ClusteredVirtualMachinesInfoModel Constructor

ClusteredVirtualMachinesInfoModel Constructor
Initializes a new instance of the ClusteredVirtualMachinesInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ClusteredVirtualMachinesInfoModel()
Public Sub New
public:
ClusteredVirtualMachinesInfoModel()
new : unit -> ClusteredVirtualMachinesInfoModel
See Also

Reference

ClusteredVirtualMachinesInfoModel Class


ClusteredVirtualMachinesInfoModel Properties

ClusteredVirtualMachinesInfoModel Properties

The ClusteredVirtualMachinesInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Group | Gets or sets the group name.
Public property | OwningNode | Gets or sets the owning node of the group.
Public property | VirtualMachine | Gets or sets the virtual machine information.
Top
See Also

Reference

ClusteredVirtualMachinesInfoModel Class


ClusteredVirtualMachinesInfoModel.Group Property

ClusteredVirtualMachinesInfoModelGroup Property
Gets or sets the group name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Group { get; set; }
Public Property Group As String
    Get
    Set
public:
property String^ Group {
    String^ get ();
    void set (String^ value);
}
member Group : string with get, set

Property Value

Type: String
See Also

Reference

ClusteredVirtualMachinesInfoModel Class


ClusteredVirtualMachinesInfoModel.OwningNode Property

ClusteredVirtualMachinesInfoModelOwningNode Property
Gets or sets the owning node of the group.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string OwningNode { get; set; }
Public Property OwningNode As String
    Get
    Set
public:
property String^ OwningNode {
    String^ get ();
    void set (String^ value);
}
member OwningNode : string with get, set

Property Value

Type: String
The owning node.
See Also

Reference

ClusteredVirtualMachinesInfoModel Class


ClusteredVirtualMachinesInfoModel.VirtualMachine Property

ClusteredVirtualMachinesInfoModelVirtualMachine Property
Gets or sets the virtual machine information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ClusteredVirtualMachineModel[] VirtualMachine { get; set; }
Public Property VirtualMachine As ClusteredVirtualMachineModel()
    Get
    Set
public:
property array<ClusteredVirtualMachineModel^>^ VirtualMachine {
    array<ClusteredVirtualMachineModel^>^ get ();
    void set (array<ClusteredVirtualMachineModel^>^ value);
}
member VirtualMachine : ClusteredVirtualMachineModel[] with get, set

Property Value

Type: ClusteredVirtualMachineModel
The virtual machine information.
See Also

Reference

ClusteredVirtualMachinesInfoModel Class


ClusteredVirtualMachinesInfoModel Methods

ClusteredVirtualMachinesInfoModel Methods

The ClusteredVirtualMachinesInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ClusteredVirtualMachinesInfoModel Class


ClusterFilesAndFoldersQualificationResultsModel Class

ClusterFilesAndFoldersQualificationResultsModel Class
Cluster files and folders qualification results model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsClusterFilesAndFoldersQualificationResultsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ClusterFilesAndFoldersQualificationResultsModel
Public NotInheritable Class ClusterFilesAndFoldersQualificationResultsModel
public ref class ClusterFilesAndFoldersQualificationResultsModel sealed
[<SealedAttribute>]
type ClusterFilesAndFoldersQualificationResultsModel =  class end

The ClusterFilesAndFoldersQualificationResultsModel type exposes the following members.

Constructors
 | Name | Description
Public method | ClusterFilesAndFoldersQualificationResultsModel | Initializes a new instance of the ClusterFilesAndFoldersQualificationResultsModel class
Top
Properties
 | Name | Description
Public property | TargetFileServerQualificationResults | Gets or sets the volumes.
Public property | TargetGroupDiskOffline | Gets or sets a value indicating whether the target group disk is offline.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ClusterFilesAndFoldersQualificationResultsModel Constructor

ClusterFilesAndFoldersQualificationResultsModel Constructor
Initializes a new instance of the ClusterFilesAndFoldersQualificationResultsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ClusterFilesAndFoldersQualificationResultsModel()
Public Sub New
public:
ClusterFilesAndFoldersQualificationResultsModel()
new : unit -> ClusterFilesAndFoldersQualificationResultsModel
See Also

Reference

ClusterFilesAndFoldersQualificationResultsModel Class


ClusterFilesAndFoldersQualificationResultsModel Properties

ClusterFilesAndFoldersQualificationResultsModel Properties

The ClusterFilesAndFoldersQualificationResultsModel type exposes the following members.

Properties
 | Name | Description
Public property | TargetFileServerQualificationResults | Gets or sets the volumes.
Public property | TargetGroupDiskOffline | Gets or sets a value indicating whether the target group disk is offline.
Top
See Also

Reference

ClusterFilesAndFoldersQualificationResultsModel Class


ClusterFilesAndFoldersQualificationResultsModel.TargetFileServerQualificationResults Property

ClusterFilesAndFoldersQualificationResultsModelTargetFileServerQualificationResults Property
Gets or sets the volumes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TargetFileServerQualificationResultsModel[] TargetFileServerQualificationResults { get; set; }
Public Property TargetFileServerQualificationResults As TargetFileServerQualificationResultsModel()
    Get
    Set
public:
property array<TargetFileServerQualificationResultsModel^>^ TargetFileServerQualificationResults {
    array<TargetFileServerQualificationResultsModel^>^ get ();
    void set (array<TargetFileServerQualificationResultsModel^>^ value);
}
member TargetFileServerQualificationResults : TargetFileServerQualificationResultsModel[] with get, set

Property Value

Type: TargetFileServerQualificationResultsModel
See Also

Reference

ClusterFilesAndFoldersQualificationResultsModel Class


ClusterFilesAndFoldersQualificationResultsModel.TargetGroupDiskOffline Property

ClusterFilesAndFoldersQualificationResultsModelTargetGroupDiskOffline Property
Gets or sets a value indicating whether the target group disk is offline.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool TargetGroupDiskOffline { get; set; }
Public Property TargetGroupDiskOffline As Boolean
    Get
    Set
public:
property bool TargetGroupDiskOffline {
    bool get ();
    void set (bool value);
}
member TargetGroupDiskOffline : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ClusterFilesAndFoldersQualificationResultsModel Class


ClusterFilesAndFoldersQualificationResultsModel Methods

ClusterFilesAndFoldersQualificationResultsModel Methods

The ClusterFilesAndFoldersQualificationResultsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ClusterFilesAndFoldersQualificationResultsModel Class


ClusterGroupInfoModel Class

ClusterGroupInfoModel Class
Cluster group information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsClusterGroupInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class ClusterGroupInfoModel
Public Class ClusterGroupInfoModel
public ref class ClusterGroupInfoModel
type ClusterGroupInfoModel =  class end

The ClusterGroupInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ClusterGroupInfoModel | Initializes a new instance of the ClusterGroupInfoModel class
Top
Properties
 | Name | Description
Public property | Disks | Gets or sets the disks.
Public property | Group | Gets or sets the group.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ClusterGroupInfoModel Constructor

ClusterGroupInfoModel Constructor
Initializes a new instance of the ClusterGroupInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ClusterGroupInfoModel()
Public Sub New
public:
ClusterGroupInfoModel()
new : unit -> ClusterGroupInfoModel
See Also

Reference

ClusterGroupInfoModel Class


ClusterGroupInfoModel Properties

ClusterGroupInfoModel Properties

The ClusterGroupInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Disks | Gets or sets the disks.
Public property | Group | Gets or sets the group.
Top
See Also

Reference

ClusterGroupInfoModel Class


ClusterGroupInfoModel.Disks Property

ClusterGroupInfoModelDisks Property
Gets or sets the disks.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string[] Disks { get; set; }
Public Property Disks As String()
    Get
    Set
public:
property array<String^>^ Disks {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member Disks : string[] with get, set

Property Value

Type: String
The disks.
See Also

Reference

ClusterGroupInfoModel Class


ClusterGroupInfoModel.Group Property

ClusterGroupInfoModelGroup Property
Gets or sets the group.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Group { get; set; }
Public Property Group As String
    Get
    Set
public:
property String^ Group {
    String^ get ();
    void set (String^ value);
}
member Group : string with get, set

Property Value

Type: String
The group.
See Also

Reference

ClusterGroupInfoModel Class


ClusterGroupInfoModel Methods

ClusterGroupInfoModel Methods

The ClusterGroupInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ClusterGroupInfoModel Class


ClusterOptionsModel Class

ClusterOptionsModel Class
Cluster options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsClusterOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ClusterOptionsModel
Public NotInheritable Class ClusterOptionsModel
public ref class ClusterOptionsModel sealed
[<SealedAttribute>]
type ClusterOptionsModel =  class end

The ClusterOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | ClusterOptionsModel | Initializes a new instance of the ClusterOptionsModel class
Top
Properties
 | Name | Description
Public property | DependOnResources | Gets or sets the names of resources to depend on (overrides default storage resource, network name resource dependencies).
Public property | InitializeOnTargetNodeMove | Gets or sets a value indicating whether or not to initialize on target node move.
Public property | OriginalSourceClusterId | Gets or sets the original source cluster ID.
Public property | SourceClusterName | Gets or sets the name of the source cluster.
Public property | SourceGroupName | Gets or sets the name of the source group.
Public property | SourceIsCluster | Gets or sets a value indicating whether or not the source is part of a cluster.
Public property | TargetClusterName | Gets or sets the name of the target cluster.
Public property | TargetClusterResourceNamePrefix | Gets or sets the target cluster resource name prefix.
Public property | TargetClusterStoragePath | Gets or sets the target cluster storage location.
Public property | TargetGroupName | Gets or sets the name of the target group.
Public property | TargetIsCluster | Gets or sets a value indicating whether or not the target is part of a cluster.
Public property | TargetVirtualServers | Gets or sets the names of the target virtual servers.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ClusterOptionsModel Constructor

ClusterOptionsModel Constructor
Initializes a new instance of the ClusterOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ClusterOptionsModel()
Public Sub New
public:
ClusterOptionsModel()
new : unit -> ClusterOptionsModel
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel Properties

ClusterOptionsModel Properties

The ClusterOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | DependOnResources | Gets or sets the names of resources to depend on (overrides default storage resource, network name resource dependencies).
Public property | InitializeOnTargetNodeMove | Gets or sets a value indicating whether or not to initialize on target node move.
Public property | OriginalSourceClusterId | Gets or sets the original source cluster ID.
Public property | SourceClusterName | Gets or sets the name of the source cluster.
Public property | SourceGroupName | Gets or sets the name of the source group.
Public property | SourceIsCluster | Gets or sets a value indicating whether or not the source is part of a cluster.
Public property | TargetClusterName | Gets or sets the name of the target cluster.
Public property | TargetClusterResourceNamePrefix | Gets or sets the target cluster resource name prefix.
Public property | TargetClusterStoragePath | Gets or sets the target cluster storage location.
Public property | TargetGroupName | Gets or sets the name of the target group.
Public property | TargetIsCluster | Gets or sets a value indicating whether or not the target is part of a cluster.
Public property | TargetVirtualServers | Gets or sets the names of the target virtual servers.
Top
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel.DependOnResources Property

ClusterOptionsModelDependOnResources Property
Gets or sets the names of resources to depend on (overrides default storage resource, network name resource dependencies).

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> DependOnResources { get; set; }
Public Property DependOnResources As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ DependOnResources {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member DependOnResources : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel.InitializeOnTargetNodeMove Property

ClusterOptionsModelInitializeOnTargetNodeMove Property
Gets or sets a value indicating whether or not to initialize on target node move.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool InitializeOnTargetNodeMove { get; set; }
Public Property InitializeOnTargetNodeMove As Boolean
    Get
    Set
public:
property bool InitializeOnTargetNodeMove {
    bool get ();
    void set (bool value);
}
member InitializeOnTargetNodeMove : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel.OriginalSourceClusterId Property

ClusterOptionsModelOriginalSourceClusterId Property
Gets or sets the original source cluster ID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string OriginalSourceClusterId { get; set; }
Public Property OriginalSourceClusterId As String
    Get
    Set
public:
property String^ OriginalSourceClusterId {
    String^ get ();
    void set (String^ value);
}
member OriginalSourceClusterId : string with get, set

Property Value

Type: String
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel.SourceClusterName Property

ClusterOptionsModelSourceClusterName Property
Gets or sets the name of the source cluster.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceClusterName { get; set; }
Public Property SourceClusterName As String
    Get
    Set
public:
property String^ SourceClusterName {
    String^ get ();
    void set (String^ value);
}
member SourceClusterName : string with get, set

Property Value

Type: String
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel.SourceGroupName Property

ClusterOptionsModelSourceGroupName Property
Gets or sets the name of the source group.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceGroupName { get; set; }
Public Property SourceGroupName As String
    Get
    Set
public:
property String^ SourceGroupName {
    String^ get ();
    void set (String^ value);
}
member SourceGroupName : string with get, set

Property Value

Type: String
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel.SourceIsCluster Property

ClusterOptionsModelSourceIsCluster Property
Gets or sets a value indicating whether or not the source is part of a cluster.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool SourceIsCluster { get; set; }
Public Property SourceIsCluster As Boolean
    Get
    Set
public:
property bool SourceIsCluster {
    bool get ();
    void set (bool value);
}
member SourceIsCluster : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel.TargetClusterName Property

ClusterOptionsModelTargetClusterName Property
Gets or sets the name of the target cluster.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetClusterName { get; set; }
Public Property TargetClusterName As String
    Get
    Set
public:
property String^ TargetClusterName {
    String^ get ();
    void set (String^ value);
}
member TargetClusterName : string with get, set

Property Value

Type: String
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel.TargetClusterResourceNamePrefix Property

ClusterOptionsModelTargetClusterResourceNamePrefix Property
Gets or sets the target cluster resource name prefix.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetClusterResourceNamePrefix { get; set; }
Public Property TargetClusterResourceNamePrefix As String
    Get
    Set
public:
property String^ TargetClusterResourceNamePrefix {
    String^ get ();
    void set (String^ value);
}
member TargetClusterResourceNamePrefix : string with get, set

Property Value

Type: String
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel.TargetClusterStoragePath Property

ClusterOptionsModelTargetClusterStoragePath Property
Gets or sets the target cluster storage location.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetClusterStoragePath { get; set; }
Public Property TargetClusterStoragePath As String
    Get
    Set
public:
property String^ TargetClusterStoragePath {
    String^ get ();
    void set (String^ value);
}
member TargetClusterStoragePath : string with get, set

Property Value

Type: String
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel.TargetGroupName Property

ClusterOptionsModelTargetGroupName Property
Gets or sets the name of the target group.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetGroupName { get; set; }
Public Property TargetGroupName As String
    Get
    Set
public:
property String^ TargetGroupName {
    String^ get ();
    void set (String^ value);
}
member TargetGroupName : string with get, set

Property Value

Type: String
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel.TargetIsCluster Property

ClusterOptionsModelTargetIsCluster Property
Gets or sets a value indicating whether or not the target is part of a cluster.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool TargetIsCluster { get; set; }
Public Property TargetIsCluster As Boolean
    Get
    Set
public:
property bool TargetIsCluster {
    bool get ();
    void set (bool value);
}
member TargetIsCluster : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel.TargetVirtualServers Property

ClusterOptionsModelTargetVirtualServers Property
Gets or sets the names of the target virtual servers.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> TargetVirtualServers { get; set; }
Public Property TargetVirtualServers As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ TargetVirtualServers {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member TargetVirtualServers : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
See Also

Reference

ClusterOptionsModel Class


ClusterOptionsModel Methods

ClusterOptionsModel Methods

The ClusterOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ClusterOptionsModel Class


ClusterResourceInfoModel Class

ClusterResourceInfoModel Class
Cluster resource information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsClusterResourceInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class ClusterResourceInfoModel
Public Class ClusterResourceInfoModel
public ref class ClusterResourceInfoModel
type ClusterResourceInfoModel =  class end

The ClusterResourceInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ClusterResourceInfoModel | Initializes a new instance of the ClusterResourceInfoModel class
Top
Properties
 | Name | Description
Public property | Class | Gets or sets the class.
Public property | Group | Gets or sets the group.
Public property | IsStorageCSV | Obsolete. Gets or sets a value indicating whether the storage is CSV.
Public property | Name | Gets or sets the name.
Public property | Owner | Gets or sets the owner.
Public property | PossibleOwners | Gets or sets the possible owners.
Public property | Type | Gets or sets the type.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ClusterResourceInfoModel Constructor

ClusterResourceInfoModel Constructor
Initializes a new instance of the ClusterResourceInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ClusterResourceInfoModel()
Public Sub New
public:
ClusterResourceInfoModel()
new : unit -> ClusterResourceInfoModel
See Also

Reference

ClusterResourceInfoModel Class


ClusterResourceInfoModel Properties

ClusterResourceInfoModel Properties

The ClusterResourceInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Class | Gets or sets the class.
Public property | Group | Gets or sets the group.
Public property | IsStorageCSV | Obsolete. Gets or sets a value indicating whether the storage is CSV.
Public property | Name | Gets or sets the name.
Public property | Owner | Gets or sets the owner.
Public property | PossibleOwners | Gets or sets the possible owners.
Public property | Type | Gets or sets the type.
Top
See Also

Reference

ClusterResourceInfoModel Class


ClusterResourceInfoModel.Class Property

ClusterResourceInfoModelClass Property
Gets or sets the class.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> Class { get; set; }
Public Property Class As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> Class {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member Class : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

ClusterResourceInfoModel Class


ClusterResourceInfoModel.Group Property

ClusterResourceInfoModelGroup Property
Gets or sets the group.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Group { get; set; }
Public Property Group As String
    Get
    Set
public:
property String^ Group {
    String^ get ();
    void set (String^ value);
}
member Group : string with get, set

Property Value

Type: String
See Also

Reference

ClusterResourceInfoModel Class


ClusterResourceInfoModel.IsStorageCSV Property

ClusterResourceInfoModelIsStorageCSV Property

Note: This API is now obsolete.

Gets or sets a value indicating whether the storage is CSV.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
[ObsoleteAttribute("IsStorageCSV is deprecated, please use ICluster.IsStorageCSV instead.",
    true)]
public bool IsStorageCSV { get; set; }
<ObsoleteAttribute("IsStorageCSV is deprecated, please use ICluster.IsStorageCSV instead.",
    true)>
Public Property IsStorageCSV As Boolean
    Get
    Set
public:
[ObsoleteAttribute(L"IsStorageCSV is deprecated, please use ICluster.IsStorageCSV instead.",
    true)]
property bool IsStorageCSV {
    bool get ();
    void set (bool value);
}
[<ObsoleteAttribute("IsStorageCSV is deprecated, please use ICluster.IsStorageCSV instead.",
    true)>]
member IsStorageCSV : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ClusterResourceInfoModel Class


ClusterResourceInfoModel.Name Property

ClusterResourceInfoModelName Property
Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

ClusterResourceInfoModel Class


ClusterResourceInfoModel.Owner Property

ClusterResourceInfoModelOwner Property
Gets or sets the owner.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Owner { get; set; }
Public Property Owner As String
    Get
    Set
public:
property String^ Owner {
    String^ get ();
    void set (String^ value);
}
member Owner : string with get, set

Property Value

Type: String
See Also

Reference

ClusterResourceInfoModel Class


ClusterResourceInfoModel.PossibleOwners Property

ClusterResourceInfoModelPossibleOwners Property
Gets or sets the possible owners.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string[] PossibleOwners { get; set; }
Public Property PossibleOwners As String()
    Get
    Set
public:
property array<String^>^ PossibleOwners {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member PossibleOwners : string[] with get, set

Property Value

Type: String
See Also

Reference

ClusterResourceInfoModel Class


ClusterResourceInfoModel.Type Property

ClusterResourceInfoModelType Property
Gets or sets the type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}
member Type : string with get, set

Property Value

Type: String
See Also

Reference

ClusterResourceInfoModel Class


ClusterResourceInfoModel Methods

ClusterResourceInfoModel Methods

The ClusterResourceInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ClusterResourceInfoModel Class


ClusterResourceState Enumeration

ClusterResourceState Enumeration
Cluster resource state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum ClusterResourceState
Public Enumeration ClusterResourceState
public enum class ClusterResourceState
type ClusterResourceState
Members
Member name | Value | Description
Uninitialized | 0 | The uninitialized
OfflinePending | 1 | The offline pending
Offline | 2 | The offline
OnlinePending | 3 | The online pending
Online | 4 | The online
ResourceNotFound | 5 | The resource not found
Reconnected | 6 | The reconnected
Connected | 7 | The connected
See Also

Reference

DoubleTake.Web.Models Namespace


ComparisonOperationEnum Enumeration

ComparisonOperationEnum Enumeration
Represents the types of comparison operations.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public enum ComparisonOperationEnum
Public Enumeration ComparisonOperationEnum
public enum class ComparisonOperationEnum
type ComparisonOperationEnum
Members
Member name | Value | Description
Equal | 0 | Indicates that the comparison operation succeeds of the items are equal.
LessThan | 1 | Indicates that the comparison operation succeeds if the first item is less than the second item.
LessThanOrEqual | 2 | Indicates that the comparison operation succeeds if the first item is less than or equal to the second item.
GreatherThan | 3 | Indicates that the comparison operation succeeds if the first item is greater than the second item.
GreatherThanOrEqual | 4 | Indicates that the comparison operation succeeds if the first item is greater than or equal to the second item.
See Also

Reference

DoubleTake.Web.Models Namespace


CompositeActionInputModel Class

CompositeActionInputModel Class
Represents the input to a Composite action agent.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActionInputModel
DoubleTake.Web.ModelsCompositeActionInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class CompositeActionInputModel : ActionInputModel
Public Class CompositeActionInputModel
    Inherits ActionInputModel
public ref class CompositeActionInputModel : public ActionInputModel
type CompositeActionInputModel =
    class
        inherit ActionInputModel
    end

The CompositeActionInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | CompositeActionInputModel | Initializes a new instance of the CompositeActionInputModel class
Top
Properties
 | Name | Description
Public property | Actions | Gets or sets the enumerable collection of actions.
Public property | Credentials | Gets or sets the credentials to be used by the action. (Inherited from ActionInputModel.)
Public property | ParallelExecution | Gets or sets a value indicating whether the actions are to be executed in parallel.
Public property | QueryResult | Gets or sets the query result. (Inherited from ActionInputModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CompositeActionInputModel Constructor

CompositeActionInputModel Constructor
Initializes a new instance of the CompositeActionInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CompositeActionInputModel()
Public Sub New
public:
CompositeActionInputModel()
new : unit -> CompositeActionInputModel
See Also

Reference

CompositeActionInputModel Class


CompositeActionInputModel Properties

CompositeActionInputModel Properties

The CompositeActionInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Actions | Gets or sets the enumerable collection of actions.
Public property | Credentials | Gets or sets the credentials to be used by the action. (Inherited from ActionInputModel.)
Public property | ParallelExecution | Gets or sets a value indicating whether the actions are to be executed in parallel.
Public property | QueryResult | Gets or sets the query result. (Inherited from ActionInputModel.)
Top
See Also

Reference

CompositeActionInputModel Class


CompositeActionInputModel.Actions Property

CompositeActionInputModelActions Property
Gets or sets the enumerable collection of actions.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<MonitorActionModel> Actions { get; set; }
Public Property Actions As IEnumerable(Of MonitorActionModel)
    Get
    Set
public:
property IEnumerable<MonitorActionModel^>^ Actions {
    IEnumerable<MonitorActionModel^>^ get ();
    void set (IEnumerable<MonitorActionModel^>^ value);
}
member Actions : IEnumerable<MonitorActionModel> with get, set

Property Value

Type: IEnumerable MonitorActionModel
The enumerable collection of actions.
See Also

Reference

CompositeActionInputModel Class


CompositeActionInputModel.ParallelExecution Property

CompositeActionInputModelParallelExecution Property
Gets or sets a value indicating whether the actions are to be executed in parallel.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool ParallelExecution { get; set; }
Public Property ParallelExecution As Boolean
    Get
    Set
public:
property bool ParallelExecution {
    bool get ();
    void set (bool value);
}
member ParallelExecution : bool with get, set

Property Value

Type: Boolean
if the actions are to be executed in parallel; otherwise, .
Remarks
If this property is set to , the actions are executed synchronously in the order they exist in the Actions property.
See Also

Reference

CompositeActionInputModel Class


CompositeActionInputModel Methods

CompositeActionInputModel Methods

The CompositeActionInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CompositeActionInputModel Class


CompositeActionResultModel Class

CompositeActionResultModel Class
Represents the results of a composite action.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActionResultModel
DoubleTake.Web.ModelsCompositeActionResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class CompositeActionResultModel : ActionResultModel
Public Class CompositeActionResultModel
    Inherits ActionResultModel
public ref class CompositeActionResultModel : public ActionResultModel
type CompositeActionResultModel =
    class
        inherit ActionResultModel
    end

The CompositeActionResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | CompositeActionResultModel | Initializes a new instance of the CompositeActionResultModel class
Top
Properties
 | Name | Description
Public property | ActionResults | Gets or sets the action results.
Public property | Exception | Gets or sets the action exception. (Inherited from ActionResultModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CompositeActionResultModel Constructor

CompositeActionResultModel Constructor
Initializes a new instance of the CompositeActionResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CompositeActionResultModel()
Public Sub New
public:
CompositeActionResultModel()
new : unit -> CompositeActionResultModel
See Also

Reference

CompositeActionResultModel Class


CompositeActionResultModel Properties

CompositeActionResultModel Properties

The CompositeActionResultModel type exposes the following members.

Properties
 | Name | Description
Public property | ActionResults | Gets or sets the action results.
Public property | Exception | Gets or sets the action exception. (Inherited from ActionResultModel.)
Top
See Also

Reference

CompositeActionResultModel Class


CompositeActionResultModel.ActionResults Property

CompositeActionResultModelActionResults Property
Gets or sets the action results.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<ActionResultModel> ActionResults { get; set; }
Public Property ActionResults As IEnumerable(Of ActionResultModel)
    Get
    Set
public:
property IEnumerable<ActionResultModel^>^ ActionResults {
    IEnumerable<ActionResultModel^>^ get ();
    void set (IEnumerable<ActionResultModel^>^ value);
}
member ActionResults : IEnumerable<ActionResultModel> with get, set

Property Value

Type: IEnumerable ActionResultModel
The action results.
See Also

Reference

CompositeActionResultModel Class


CompositeActionResultModel Methods

CompositeActionResultModel Methods

The CompositeActionResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CompositeActionResultModel Class


CompositeQueryInputModel Class

CompositeQueryInputModel Class
Represents the input to a Composite query agent.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsCompositeQueryInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class CompositeQueryInputModel : QueryInputModel
Public Class CompositeQueryInputModel
    Inherits QueryInputModel
public ref class CompositeQueryInputModel : public QueryInputModel
type CompositeQueryInputModel =
    class
        inherit QueryInputModel
    end

The CompositeQueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | CompositeQueryInputModel | Initializes a new instance of the CompositeQueryInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | Operation | Gets or sets the mode of query aggregation.
Public property | ParallelExecution | Gets or sets a value indicating whether the queries are to be executed in parallel.
Public property | Queries | Gets or sets the enumerable collection of queries.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CompositeQueryInputModel Constructor

CompositeQueryInputModel Constructor
Initializes a new instance of the CompositeQueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CompositeQueryInputModel()
Public Sub New
public:
CompositeQueryInputModel()
new : unit -> CompositeQueryInputModel
See Also

Reference

CompositeQueryInputModel Class


CompositeQueryInputModel Properties

CompositeQueryInputModel Properties

The CompositeQueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | Operation | Gets or sets the mode of query aggregation.
Public property | ParallelExecution | Gets or sets a value indicating whether the queries are to be executed in parallel.
Public property | Queries | Gets or sets the enumerable collection of queries.
Top
See Also

Reference

CompositeQueryInputModel Class


CompositeQueryInputModel.Operation Property

CompositeQueryInputModelOperation Property
Gets or sets the mode of query aggregation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CompositeQueryOperationEnum Operation { get; set; }
Public Property Operation As CompositeQueryOperationEnum
    Get
    Set
public:
property CompositeQueryOperationEnum Operation {
    CompositeQueryOperationEnum get ();
    void set (CompositeQueryOperationEnum value);
}
member Operation : CompositeQueryOperationEnum with get, set

Property Value

Type: CompositeQueryOperationEnum
The mode.
See Also

Reference

CompositeQueryInputModel Class


CompositeQueryInputModel.ParallelExecution Property

CompositeQueryInputModelParallelExecution Property
Gets or sets a value indicating whether the queries are to be executed in parallel.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool ParallelExecution { get; set; }
Public Property ParallelExecution As Boolean
    Get
    Set
public:
property bool ParallelExecution {
    bool get ();
    void set (bool value);
}
member ParallelExecution : bool with get, set

Property Value

Type: Boolean
if the queries are to be executed in parallel; otherwise, .
Remarks
If this property is set to
See Also

Reference

CompositeQueryInputModel Class


CompositeQueryInputModel.Queries Property

CompositeQueryInputModelQueries Property
Gets or sets the enumerable collection of queries.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public MonitorQueryModel[] Queries { get; set; }
Public Property Queries As MonitorQueryModel()
    Get
    Set
public:
property array<MonitorQueryModel^>^ Queries {
    array<MonitorQueryModel^>^ get ();
    void set (array<MonitorQueryModel^>^ value);
}
member Queries : MonitorQueryModel[] with get, set

Property Value

Type: MonitorQueryModel
The the numerable collection of queries.
See Also

Reference

CompositeQueryInputModel Class


CompositeQueryInputModel Methods

CompositeQueryInputModel Methods

The CompositeQueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CompositeQueryInputModel Class


CompositeQueryOperationEnum Enumeration

CompositeQueryOperationEnum Enumeration
Defines how to evaluate a composite query.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public enum CompositeQueryOperationEnum
Public Enumeration CompositeQueryOperationEnum
public enum class CompositeQueryOperationEnum
type CompositeQueryOperationEnum
Members
Member name | Value | Description
And | 0 | Conjunctive operation that fails the query if any of the queries fail.
Or | 1 | Disjunctive operation that fails the query if all of the queries fail.
See Also

Reference

DoubleTake.Web.Models Namespace


CompositeQueryResultModel Class

CompositeQueryResultModel Class
Represents the results of a composite query.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultModel
DoubleTake.Web.ModelsCompositeQueryResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class CompositeQueryResultModel : QueryResultModel
Public Class CompositeQueryResultModel
    Inherits QueryResultModel
public ref class CompositeQueryResultModel : public QueryResultModel
type CompositeQueryResultModel =
    class
        inherit QueryResultModel
    end

The CompositeQueryResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | CompositeQueryResultModel | Initializes a new instance of the CompositeQueryResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | QueryResults | Gets or sets the query results.
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CompositeQueryResultModel Constructor

CompositeQueryResultModel Constructor
Initializes a new instance of the CompositeQueryResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CompositeQueryResultModel()
Public Sub New
public:
CompositeQueryResultModel()
new : unit -> CompositeQueryResultModel
See Also

Reference

CompositeQueryResultModel Class


CompositeQueryResultModel Properties

CompositeQueryResultModel Properties

The CompositeQueryResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | QueryResults | Gets or sets the query results.
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Top
See Also

Reference

CompositeQueryResultModel Class


CompositeQueryResultModel.QueryResults Property

CompositeQueryResultModelQueryResults Property
Gets or sets the query results.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<QueryResultModel> QueryResults { get; set; }
Public Property QueryResults As IEnumerable(Of QueryResultModel)
    Get
    Set
public:
property IEnumerable<QueryResultModel^>^ QueryResults {
    IEnumerable<QueryResultModel^>^ get ();
    void set (IEnumerable<QueryResultModel^>^ value);
}
member QueryResults : IEnumerable<QueryResultModel> with get, set

Property Value

Type: IEnumerable QueryResultModel
The query results.
See Also

Reference

CompositeQueryResultModel Class


CompositeQueryResultModel Methods

CompositeQueryResultModel Methods

The CompositeQueryResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CompositeQueryResultModel Class


CompressionLevelModel Class

CompressionLevelModel Class
Compression level model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCompressionLevelModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class CompressionLevelModel
Public NotInheritable Class CompressionLevelModel
public ref class CompressionLevelModel sealed
[<SealedAttribute>]
type CompressionLevelModel =  class end

The CompressionLevelModel type exposes the following members.

Constructors
 | Name | Description
Public method | CompressionLevelModel | Initializes a new instance of the CompressionLevelModel class
Top
Properties
 | Name | Description
Public property | Algorithm | Gets or sets the compression algorithm.
Public property | Level | Gets or sets the level of compression.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CompressionLevelModel Constructor

CompressionLevelModel Constructor
Initializes a new instance of the CompressionLevelModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CompressionLevelModel()
Public Sub New
public:
CompressionLevelModel()
new : unit -> CompressionLevelModel
See Also

Reference

CompressionLevelModel Class


CompressionLevelModel Properties

CompressionLevelModel Properties

The CompressionLevelModel type exposes the following members.

Properties
 | Name | Description
Public property | Algorithm | Gets or sets the compression algorithm.
Public property | Level | Gets or sets the level of compression.
Top
See Also

Reference

CompressionLevelModel Class


CompressionLevelModel.Algorithm Property

CompressionLevelModelAlgorithm Property
Gets or sets the compression algorithm.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int Algorithm { get; set; }
Public Property Algorithm As Integer
    Get
    Set
public:
property int Algorithm {
    int get ();
    void set (int value);
}
member Algorithm : int with get, set

Property Value

Type: Int32
See Also

Reference

CompressionLevelModel Class


CompressionLevelModel.Level Property

CompressionLevelModelLevel Property
Gets or sets the level of compression.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int Level { get; set; }
Public Property Level As Integer
    Get
    Set
public:
property int Level {
    int get ();
    void set (int value);
}
member Level : int with get, set

Property Value

Type: Int32
See Also

Reference

CompressionLevelModel Class


CompressionLevelModel Methods

CompressionLevelModel Methods

The CompressionLevelModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CompressionLevelModel Class


ConnectionConfigurationModel Class

ConnectionConfigurationModel Class
Connection configuration model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsConnectionConfigurationModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class ConnectionConfigurationModel
Public NotInheritable Class ConnectionConfigurationModel
public ref class ConnectionConfigurationModel sealed
[<SealedAttribute>]
type ConnectionConfigurationModel =  class end

The ConnectionConfigurationModel type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionConfigurationModel | Initializes a new instance of the ConnectionConfigurationModel class
Top
Properties
 | Name | Description
Public property | BandwidthCollar | Gets or sets the current bandwidth limit.
Public property | CompressionAlgorithm | Gets or sets the code for the compression algorithm being used for this connection.
Public property | CompressionEnabled | Gets or sets a value indicating whether transmitted data is compressed.
Public property | CompressionLevel | Gets or sets the level of compression configured on the connection.
Public property | ConnectionId | Gets or sets a one-based index for each connection established in a Double-Take instance.
Public property | Encrypt | Gets or sets a value indicating whether transmitted data is encrypted.
Public property | JobType | Gets or sets a product specific string indicating the type of job or workload protected by this connection.
Public property | PathTransformations | Gets or sets the file path transformations applied to files replicated by this connection.
Public property | ReplicationSetName | Gets or sets the name of the replication set used for this connection.
Public property | SourceRoute | Gets or sets the source endpoint used by the target for this connection.
Public property | TargetLoaded | Gets or sets a value indicating whether the target is loaded.
Public property | TargetName | Gets or sets the host name of the target, if available.
Public property | TargetRoute | Gets or sets the target endpoint used by the source for this connection.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ConnectionConfigurationModel Constructor

ConnectionConfigurationModel Constructor
Initializes a new instance of the ConnectionConfigurationModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ConnectionConfigurationModel()
Public Sub New
public:
ConnectionConfigurationModel()
new : unit -> ConnectionConfigurationModel
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel Properties

ConnectionConfigurationModel Properties

The ConnectionConfigurationModel type exposes the following members.

Properties
 | Name | Description
Public property | BandwidthCollar | Gets or sets the current bandwidth limit.
Public property | CompressionAlgorithm | Gets or sets the code for the compression algorithm being used for this connection.
Public property | CompressionEnabled | Gets or sets a value indicating whether transmitted data is compressed.
Public property | CompressionLevel | Gets or sets the level of compression configured on the connection.
Public property | ConnectionId | Gets or sets a one-based index for each connection established in a Double-Take instance.
Public property | Encrypt | Gets or sets a value indicating whether transmitted data is encrypted.
Public property | JobType | Gets or sets a product specific string indicating the type of job or workload protected by this connection.
Public property | PathTransformations | Gets or sets the file path transformations applied to files replicated by this connection.
Public property | ReplicationSetName | Gets or sets the name of the replication set used for this connection.
Public property | SourceRoute | Gets or sets the source endpoint used by the target for this connection.
Public property | TargetLoaded | Gets or sets a value indicating whether the target is loaded.
Public property | TargetName | Gets or sets the host name of the target, if available.
Public property | TargetRoute | Gets or sets the target endpoint used by the source for this connection.
Top
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.BandwidthCollar Property

ConnectionConfigurationModelBandwidthCollar Property
Gets or sets the current bandwidth limit.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int BandwidthCollar { get; set; }
Public Property BandwidthCollar As Integer
    Get
    Set
public:
property int BandwidthCollar {
    int get ();
    void set (int value);
}
member BandwidthCollar : int with get, set

Property Value

Type: Int32
Remarks
The bandwidth limit may vary according to the configured limit schedule.
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.CompressionAlgorithm Property

ConnectionConfigurationModelCompressionAlgorithm Property
Gets or sets the code for the compression algorithm being used for this connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int CompressionAlgorithm { get; set; }
Public Property CompressionAlgorithm As Integer
    Get
    Set
public:
property int CompressionAlgorithm {
    int get ();
    void set (int value);
}
member CompressionAlgorithm : int with get, set

Property Value

Type: Int32
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.CompressionEnabled Property

ConnectionConfigurationModelCompressionEnabled Property
Gets or sets a value indicating whether transmitted data is compressed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool CompressionEnabled { get; set; }
Public Property CompressionEnabled As Boolean
    Get
    Set
public:
property bool CompressionEnabled {
    bool get ();
    void set (bool value);
}
member CompressionEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.CompressionLevel Property

ConnectionConfigurationModelCompressionLevel Property
Gets or sets the level of compression configured on the connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int CompressionLevel { get; set; }
Public Property CompressionLevel As Integer
    Get
    Set
public:
property int CompressionLevel {
    int get ();
    void set (int value);
}
member CompressionLevel : int with get, set

Property Value

Type: Int32
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.ConnectionId Property

ConnectionConfigurationModelConnectionId Property
Gets or sets a one-based index for each connection established in a Double-Take instance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int ConnectionId { get; set; }
Public Property ConnectionId As Integer
    Get
    Set
public:
property int ConnectionId {
    int get ();
    void set (int value);
}
member ConnectionId : int with get, set

Property Value

Type: Int32
Remarks
This series is reset each time the Double-Take service is restarted.
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.Encrypt Property

ConnectionConfigurationModelEncrypt Property
Gets or sets a value indicating whether transmitted data is encrypted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool Encrypt { get; set; }
Public Property Encrypt As Boolean
    Get
    Set
public:
property bool Encrypt {
    bool get ();
    void set (bool value);
}
member Encrypt : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.JobType Property

ConnectionConfigurationModelJobType Property
Gets or sets a product specific string indicating the type of job or workload protected by this connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string JobType { get; set; }
Public Property JobType As String
    Get
    Set
public:
property String^ JobType {
    String^ get ();
    void set (String^ value);
}
member JobType : string with get, set

Property Value

Type: String
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.PathTransformations Property

ConnectionConfigurationModelPathTransformations Property
Gets or sets the file path transformations applied to files replicated by this connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public PathTransformationModel[] PathTransformations { get; set; }
Public Property PathTransformations As PathTransformationModel()
    Get
    Set
public:
property array<PathTransformationModel^>^ PathTransformations {
    array<PathTransformationModel^>^ get ();
    void set (array<PathTransformationModel^>^ value);
}
member PathTransformations : PathTransformationModel[] with get, set

Property Value

Type: PathTransformationModel
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.ReplicationSetName Property

ConnectionConfigurationModelReplicationSetName Property
Gets or sets the name of the replication set used for this connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ReplicationSetName { get; set; }
Public Property ReplicationSetName As String
    Get
    Set
public:
property String^ ReplicationSetName {
    String^ get ();
    void set (String^ value);
}
member ReplicationSetName : string with get, set

Property Value

Type: String
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.SourceRoute Property

ConnectionConfigurationModelSourceRoute Property
Gets or sets the source endpoint used by the target for this connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SourceRoute { get; set; }
Public Property SourceRoute As String
    Get
    Set
public:
property String^ SourceRoute {
    String^ get ();
    void set (String^ value);
}
member SourceRoute : string with get, set

Property Value

Type: String
Remarks
The address is specified in the format: [address]:[port]
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.TargetLoaded Property

ConnectionConfigurationModelTargetLoaded Property
Gets or sets a value indicating whether the target is loaded.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool TargetLoaded { get; set; }
Public Property TargetLoaded As Boolean
    Get
    Set
public:
property bool TargetLoaded {
    bool get ();
    void set (bool value);
}
member TargetLoaded : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.TargetName Property

ConnectionConfigurationModelTargetName Property
Gets or sets the host name of the target, if available.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string TargetName { get; set; }
Public Property TargetName As String
    Get
    Set
public:
property String^ TargetName {
    String^ get ();
    void set (String^ value);
}
member TargetName : string with get, set

Property Value

Type: String
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel.TargetRoute Property

ConnectionConfigurationModelTargetRoute Property
Gets or sets the target endpoint used by the source for this connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string TargetRoute { get; set; }
Public Property TargetRoute As String
    Get
    Set
public:
property String^ TargetRoute {
    String^ get ();
    void set (String^ value);
}
member TargetRoute : string with get, set

Property Value

Type: String
Remarks
The address is specified in the format: [address]:[port]
See Also

Reference

ConnectionConfigurationModel Class


ConnectionConfigurationModel Methods

ConnectionConfigurationModel Methods

The ConnectionConfigurationModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConnectionConfigurationModel Class


ConnectionInfoModel Class

ConnectionInfoModel Class
Connection information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsConnectionInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class ConnectionInfoModel
Public NotInheritable Class ConnectionInfoModel
public ref class ConnectionInfoModel sealed
[<SealedAttribute>]
type ConnectionInfoModel =  class end

The ConnectionInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionInfoModel | Initializes a new instance of the ConnectionInfoModel class
Top
Properties
 | Name | Description
Public property | Configuration | Gets or sets the servers and settings involved in the connection.
Public property | Guid | Gets or sets the unique ID of the connection.
Public property | SourceAddresses | Gets or sets the source addresses.
Public property | SourceName | Gets or sets the name of the source.
Public property | Statistics | Gets or sets various connection statistics collected by the Double-Take engine.
Public property | Status | Gets or sets the operational state of the connection.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ConnectionInfoModel Constructor

ConnectionInfoModel Constructor
Initializes a new instance of the ConnectionInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ConnectionInfoModel()
Public Sub New
public:
ConnectionInfoModel()
new : unit -> ConnectionInfoModel
See Also

Reference

ConnectionInfoModel Class


ConnectionInfoModel Properties

ConnectionInfoModel Properties

The ConnectionInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Configuration | Gets or sets the servers and settings involved in the connection.
Public property | Guid | Gets or sets the unique ID of the connection.
Public property | SourceAddresses | Gets or sets the source addresses.
Public property | SourceName | Gets or sets the name of the source.
Public property | Statistics | Gets or sets various connection statistics collected by the Double-Take engine.
Public property | Status | Gets or sets the operational state of the connection.
Top
See Also

Reference

ConnectionInfoModel Class


ConnectionInfoModel.Configuration Property

ConnectionInfoModelConfiguration Property
Gets or sets the servers and settings involved in the connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ConnectionConfigurationModel Configuration { get; set; }
Public Property Configuration As ConnectionConfigurationModel
    Get
    Set
public:
property ConnectionConfigurationModel^ Configuration {
    ConnectionConfigurationModel^ get ();
    void set (ConnectionConfigurationModel^ value);
}
member Configuration : ConnectionConfigurationModel with get, set

Property Value

Type: ConnectionConfigurationModel
The configuration.
See Also

Reference

ConnectionInfoModel Class


ConnectionInfoModel.Guid Property

ConnectionInfoModelGuid Property
Gets or sets the unique ID of the connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Guid Guid { get; set; }
Public Property Guid As Guid
    Get
    Set
public:
property Guid Guid {
    Guid get ();
    void set (Guid value);
}
member Guid : Guid with get, set

Property Value

Type: Guid
The GUID.
Remarks
This ID is generated by the Management Service and combines the multiple items required to uniquely identify a Double-Take engine connection into one. The two items required to uniquely identify a Double-Take engine connection are the replication set name and the target route.
See Also

Reference

ConnectionInfoModel Class


ConnectionInfoModel.SourceAddresses Property

ConnectionInfoModelSourceAddresses Property
Gets or sets the source addresses.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string[] SourceAddresses { get; set; }
Public Property SourceAddresses As String()
    Get
    Set
public:
property array<String^>^ SourceAddresses {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member SourceAddresses : string[] with get, set

Property Value

Type: String
The source addresses.
See Also

Reference

ConnectionInfoModel Class


ConnectionInfoModel.SourceName Property

ConnectionInfoModelSourceName Property
Gets or sets the name of the source.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SourceName { get; set; }
Public Property SourceName As String
    Get
    Set
public:
property String^ SourceName {
    String^ get ();
    void set (String^ value);
}
member SourceName : string with get, set

Property Value

Type: String
The name of the source.
See Also

Reference

ConnectionInfoModel Class


ConnectionInfoModel.Statistics Property

ConnectionInfoModelStatistics Property
Gets or sets various connection statistics collected by the Double-Take engine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ConnectionStatisticsModel Statistics { get; set; }
Public Property Statistics As ConnectionStatisticsModel
    Get
    Set
public:
property ConnectionStatisticsModel^ Statistics {
    ConnectionStatisticsModel^ get ();
    void set (ConnectionStatisticsModel^ value);
}
member Statistics : ConnectionStatisticsModel with get, set

Property Value

Type: ConnectionStatisticsModel
The statistics.
See Also

Reference

ConnectionInfoModel Class


ConnectionInfoModel.Status Property

ConnectionInfoModelStatus Property
Gets or sets the operational state of the connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ConnectionStatusModel Status { get; set; }
Public Property Status As ConnectionStatusModel
    Get
    Set
public:
property ConnectionStatusModel^ Status {
    ConnectionStatusModel^ get ();
    void set (ConnectionStatusModel^ value);
}
member Status : ConnectionStatusModel with get, set

Property Value

Type: ConnectionStatusModel
The status.
See Also

Reference

ConnectionInfoModel Class


ConnectionInfoModel Methods

ConnectionInfoModel Methods

The ConnectionInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConnectionInfoModel Class


ConnectionModeEnum Enumeration

ConnectionModeEnum Enumeration
Connectio nmode.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public enum ConnectionModeEnum
Public Enumeration ConnectionModeEnum
public enum class ConnectionModeEnum
type ConnectionModeEnum
Members
Member name | Value | Description
Manual | 0 | Manual
Scheduled | 1 | Scheduled
ManualRestoreRequired | 2 | Manual restore required
ScheduledRestoreRequired | 3 | Scheduled restore required
See Also

Reference

DoubleTake.Web.Models Namespace


ConnectionParametersModel Class

ConnectionParametersModel Class
Connection parameters.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsConnectionParametersModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class ConnectionParametersModel
Public NotInheritable Class ConnectionParametersModel
public ref class ConnectionParametersModel sealed
[<SealedAttribute>]
type ConnectionParametersModel =  class end

The ConnectionParametersModel type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionParametersModel | Initializes a new instance of the ConnectionParametersModel class
Top
Properties
 | Name | Description
Public property | CreateJobStatusResource | Gets or sets a value indicating whether [create job status resource].
Public property | DependOnResources | Gets or sets the names of resources to depend on (overrides default storage resource, network name resource dependencies).
Public property | EngineJobType | Gets or sets a value indicating the type of job for which this connection is to be utilized.
Public property | IsTdu | Gets or sets a value indicating whether or not connection is a TDU connection
Public property | JobId | Gets or sets the job identifier.
Public property | PathTransformations | Gets or sets how to map the path(s) of the workload items on the source to the path(s) where they will be replicated on the target.
Public property | ReplicationSetName | Gets or sets the name of the replication set to protect.
Public property | SourceClusterGroupName | Gets or sets the name of the source cluster group.
Public property | SourceIsClustered | Gets or sets a value indicating whether [source is clustered].
Public property | TargetAddress | Gets or sets the IP address on the target machine over which mirroring and replication should take place.
Public property | TargetEnginePort | Gets or sets the Double-Take engine port on the target.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ConnectionParametersModel Constructor

ConnectionParametersModel Constructor
Initializes a new instance of the ConnectionParametersModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ConnectionParametersModel()
Public Sub New
public:
ConnectionParametersModel()
new : unit -> ConnectionParametersModel
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel Properties

ConnectionParametersModel Properties

The ConnectionParametersModel type exposes the following members.

Properties
 | Name | Description
Public property | CreateJobStatusResource | Gets or sets a value indicating whether [create job status resource].
Public property | DependOnResources | Gets or sets the names of resources to depend on (overrides default storage resource, network name resource dependencies).
Public property | EngineJobType | Gets or sets a value indicating the type of job for which this connection is to be utilized.
Public property | IsTdu | Gets or sets a value indicating whether or not connection is a TDU connection
Public property | JobId | Gets or sets the job identifier.
Public property | PathTransformations | Gets or sets how to map the path(s) of the workload items on the source to the path(s) where they will be replicated on the target.
Public property | ReplicationSetName | Gets or sets the name of the replication set to protect.
Public property | SourceClusterGroupName | Gets or sets the name of the source cluster group.
Public property | SourceIsClustered | Gets or sets a value indicating whether [source is clustered].
Public property | TargetAddress | Gets or sets the IP address on the target machine over which mirroring and replication should take place.
Public property | TargetEnginePort | Gets or sets the Double-Take engine port on the target.
Top
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel.CreateJobStatusResource Property

ConnectionParametersModelCreateJobStatusResource Property
Gets or sets a value indicating whether [create job status resource].

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool CreateJobStatusResource { get; set; }
Public Property CreateJobStatusResource As Boolean
    Get
    Set
public:
property bool CreateJobStatusResource {
    bool get ();
    void set (bool value);
}
member CreateJobStatusResource : bool with get, set

Property Value

Type: Boolean
true if [create job status resource]; otherwise, false.
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel.DependOnResources Property

ConnectionParametersModelDependOnResources Property
Gets or sets the names of resources to depend on (overrides default storage resource, network name resource dependencies).

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string[] DependOnResources { get; set; }
Public Property DependOnResources As String()
    Get
    Set
public:
property array<String^>^ DependOnResources {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member DependOnResources : string[] with get, set

Property Value

Type: String
The list of resources to depend on.
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel.EngineJobType Property

ConnectionParametersModelEngineJobType Property
Gets or sets a value indicating the type of job for which this connection is to be utilized.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public EngineJobType EngineJobType { get; set; }
Public Property EngineJobType As EngineJobType
    Get
    Set
public:
property EngineJobType EngineJobType {
    EngineJobType get ();
    void set (EngineJobType value);
}
member EngineJobType : EngineJobType with get, set

Property Value

Type: EngineJobType
One or more values from the EngineJobType enumeration.
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel.IsTdu Property

ConnectionParametersModelIsTdu Property
Gets or sets a value indicating whether or not connection is a TDU connection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsTdu { get; set; }
Public Property IsTdu As Boolean
    Get
    Set
public:
property bool IsTdu {
    bool get ();
    void set (bool value);
}
member IsTdu : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel.JobId Property

ConnectionParametersModelJobId Property
Gets or sets the job identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Guid JobId { get; set; }
Public Property JobId As Guid
    Get
    Set
public:
property Guid JobId {
    Guid get ();
    void set (Guid value);
}
member JobId : Guid with get, set

Property Value

Type: Guid
The job identifier.
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel.PathTransformations Property

ConnectionParametersModelPathTransformations Property
Gets or sets how to map the path(s) of the workload items on the source to the path(s) where they will be replicated on the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public PathTransformationModel[] PathTransformations { get; set; }
Public Property PathTransformations As PathTransformationModel()
    Get
    Set
public:
property array<PathTransformationModel^>^ PathTransformations {
    array<PathTransformationModel^>^ get ();
    void set (array<PathTransformationModel^>^ value);
}
member PathTransformations : PathTransformationModel[] with get, set

Property Value

Type: PathTransformationModel
The path transformations.
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel.ReplicationSetName Property

ConnectionParametersModelReplicationSetName Property
Gets or sets the name of the replication set to protect.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ReplicationSetName { get; set; }
Public Property ReplicationSetName As String
    Get
    Set
public:
property String^ ReplicationSetName {
    String^ get ();
    void set (String^ value);
}
member ReplicationSetName : string with get, set

Property Value

Type: String
The name of the replication set.
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel.SourceClusterGroupName Property

ConnectionParametersModelSourceClusterGroupName Property
Gets or sets the name of the source cluster group.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SourceClusterGroupName { get; set; }
Public Property SourceClusterGroupName As String
    Get
    Set
public:
property String^ SourceClusterGroupName {
    String^ get ();
    void set (String^ value);
}
member SourceClusterGroupName : string with get, set

Property Value

Type: String
The name of the source cluster group.
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel.SourceIsClustered Property

ConnectionParametersModelSourceIsClustered Property
Gets or sets a value indicating whether [source is clustered].

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool SourceIsClustered { get; set; }
Public Property SourceIsClustered As Boolean
    Get
    Set
public:
property bool SourceIsClustered {
    bool get ();
    void set (bool value);
}
member SourceIsClustered : bool with get, set

Property Value

Type: Boolean
true if [source is clustered]; otherwise, false.
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel.TargetAddress Property

ConnectionParametersModelTargetAddress Property
Gets or sets the IP address on the target machine over which mirroring and replication should take place.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string TargetAddress { get; set; }
Public Property TargetAddress As String
    Get
    Set
public:
property String^ TargetAddress {
    String^ get ();
    void set (String^ value);
}
member TargetAddress : string with get, set

Property Value

Type: String
The target address.
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel.TargetEnginePort Property

ConnectionParametersModelTargetEnginePort Property
Gets or sets the Double-Take engine port on the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int TargetEnginePort { get; set; }
Public Property TargetEnginePort As Integer
    Get
    Set
public:
property int TargetEnginePort {
    int get ();
    void set (int value);
}
member TargetEnginePort : int with get, set

Property Value

Type: Int32
The target engine port.
See Also

Reference

ConnectionParametersModel Class


ConnectionParametersModel Methods

ConnectionParametersModel Methods

The ConnectionParametersModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConnectionParametersModel Class


ConnectionQualificationFailuresEnum Enumeration

ConnectionQualificationFailuresEnum Enumeration
Connection qualification failures

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public enum ConnectionQualificationFailuresEnum
Public Enumeration ConnectionQualificationFailuresEnum
public enum class ConnectionQualificationFailuresEnum
type ConnectionQualificationFailuresEnum
Members
Member name | Value | Description
None | 0 | None
RoutableAddressDetermination | 1 | Routable address determination
CompressionAlgorithmDetermination | 2 | Compression algorithm determination
RestoreRequiredDetermination | 4 | Restore required determination
See Also

Reference

DoubleTake.Web.Models Namespace


ConnectionQualificationResultModel Class

ConnectionQualificationResultModel Class
Connection qualification result.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsConnectionQualificationResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class ConnectionQualificationResultModel
Public NotInheritable Class ConnectionQualificationResultModel
public ref class ConnectionQualificationResultModel sealed
[<SealedAttribute>]
type ConnectionQualificationResultModel =  class end

The ConnectionQualificationResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionQualificationResultModel | Initializes a new instance of the ConnectionQualificationResultModel class
Top
Properties
 | Name | Description
Public property | CompressionLevels | Gets or sets the compression levels.
Public property | ConnectionPort | Gets or sets the connection port.
Public property | Failures | Gets or sets the failures.
Public property | IsQualified | Gets or sets a value indicating whether this instance is qualified.
Public property | IsRestoreRequired | Gets or sets a value indicating whether this instance is restore required.
Public property | RecommendedStartParameters | Gets or sets the recommended start parameters.
Public property | RoutableAddresses | Gets or sets the routable addresses.
Public property | TargetMachineName | Gets or sets the name of the target machine.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ConnectionQualificationResultModel Constructor

ConnectionQualificationResultModel Constructor
Initializes a new instance of the ConnectionQualificationResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ConnectionQualificationResultModel()
Public Sub New
public:
ConnectionQualificationResultModel()
new : unit -> ConnectionQualificationResultModel
See Also

Reference

ConnectionQualificationResultModel Class


ConnectionQualificationResultModel Properties

ConnectionQualificationResultModel Properties

The ConnectionQualificationResultModel type exposes the following members.

Properties
 | Name | Description
Public property | CompressionLevels | Gets or sets the compression levels.
Public property | ConnectionPort | Gets or sets the connection port.
Public property | Failures | Gets or sets the failures.
Public property | IsQualified | Gets or sets a value indicating whether this instance is qualified.
Public property | IsRestoreRequired | Gets or sets a value indicating whether this instance is restore required.
Public property | RecommendedStartParameters | Gets or sets the recommended start parameters.
Public property | RoutableAddresses | Gets or sets the routable addresses.
Public property | TargetMachineName | Gets or sets the name of the target machine.
Top
See Also

Reference

ConnectionQualificationResultModel Class


ConnectionQualificationResultModel.CompressionLevels Property

ConnectionQualificationResultModelCompressionLevels Property
Gets or sets the compression levels.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CompressionLevelModel[] CompressionLevels { get; set; }
Public Property CompressionLevels As CompressionLevelModel()
    Get
    Set
public:
property array<CompressionLevelModel^>^ CompressionLevels {
    array<CompressionLevelModel^>^ get ();
    void set (array<CompressionLevelModel^>^ value);
}
member CompressionLevels : CompressionLevelModel[] with get, set

Property Value

Type: CompressionLevelModel
The compression levels.
See Also

Reference

ConnectionQualificationResultModel Class


ConnectionQualificationResultModel.ConnectionPort Property

ConnectionQualificationResultModelConnectionPort Property
Gets or sets the connection port.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int ConnectionPort { get; set; }
Public Property ConnectionPort As Integer
    Get
    Set
public:
property int ConnectionPort {
    int get ();
    void set (int value);
}
member ConnectionPort : int with get, set

Property Value

Type: Int32
The connection port.
See Also

Reference

ConnectionQualificationResultModel Class


ConnectionQualificationResultModel.Failures Property

ConnectionQualificationResultModelFailures Property
Gets or sets the failures.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ConnectionQualificationFailuresEnum Failures { get; set; }
Public Property Failures As ConnectionQualificationFailuresEnum
    Get
    Set
public:
property ConnectionQualificationFailuresEnum Failures {
    ConnectionQualificationFailuresEnum get ();
    void set (ConnectionQualificationFailuresEnum value);
}
member Failures : ConnectionQualificationFailuresEnum with get, set

Property Value

Type: ConnectionQualificationFailuresEnum
The failures.
See Also

Reference

ConnectionQualificationResultModel Class


ConnectionQualificationResultModel.IsQualified Property

ConnectionQualificationResultModelIsQualified Property
Gets or sets a value indicating whether this instance is qualified.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsQualified { get; set; }
Public Property IsQualified As Boolean
    Get
    Set
public:
property bool IsQualified {
    bool get ();
    void set (bool value);
}
member IsQualified : bool with get, set

Property Value

Type: Boolean
if this instance is qualified; otherwise, .
See Also

Reference

ConnectionQualificationResultModel Class


ConnectionQualificationResultModel.IsRestoreRequired Property

ConnectionQualificationResultModelIsRestoreRequired Property
Gets or sets a value indicating whether this instance is restore required.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsRestoreRequired { get; set; }
Public Property IsRestoreRequired As Boolean
    Get
    Set
public:
property bool IsRestoreRequired {
    bool get ();
    void set (bool value);
}
member IsRestoreRequired : bool with get, set

Property Value

Type: Boolean
if this instance is restore required; otherwise, .
See Also

Reference

ConnectionQualificationResultModel Class


ConnectionQualificationResultModel.RecommendedStartParameters Property

ConnectionQualificationResultModelRecommendedStartParameters Property
Gets or sets the recommended start parameters.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ConnectionStartParametersModel RecommendedStartParameters { get; set; }
Public Property RecommendedStartParameters As ConnectionStartParametersModel
    Get
    Set
public:
property ConnectionStartParametersModel^ RecommendedStartParameters {
    ConnectionStartParametersModel^ get ();
    void set (ConnectionStartParametersModel^ value);
}
member RecommendedStartParameters : ConnectionStartParametersModel with get, set

Property Value

Type: ConnectionStartParametersModel
The recommended start parameters.
See Also

Reference

ConnectionQualificationResultModel Class


ConnectionQualificationResultModel.RoutableAddresses Property

ConnectionQualificationResultModelRoutableAddresses Property
Gets or sets the routable addresses.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public UnicastIPAddressModel[] RoutableAddresses { get; set; }
Public Property RoutableAddresses As UnicastIPAddressModel()
    Get
    Set
public:
property array<UnicastIPAddressModel^>^ RoutableAddresses {
    array<UnicastIPAddressModel^>^ get ();
    void set (array<UnicastIPAddressModel^>^ value);
}
member RoutableAddresses : UnicastIPAddressModel[] with get, set

Property Value

Type: UnicastIPAddressModel
The routable addresses.
See Also

Reference

ConnectionQualificationResultModel Class


ConnectionQualificationResultModel.TargetMachineName Property

ConnectionQualificationResultModelTargetMachineName Property
Gets or sets the name of the target machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string TargetMachineName { get; set; }
Public Property TargetMachineName As String
    Get
    Set
public:
property String^ TargetMachineName {
    String^ get ();
    void set (String^ value);
}
member TargetMachineName : string with get, set

Property Value

Type: String
The name of the target machine.
See Also

Reference

ConnectionQualificationResultModel Class


ConnectionQualificationResultModel Methods

ConnectionQualificationResultModel Methods

The ConnectionQualificationResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConnectionQualificationResultModel Class


ConnectionScheduleModel Class

ConnectionScheduleModel Class
Connection schedule model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsConnectionScheduleModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ConnectionScheduleModel
Public NotInheritable Class ConnectionScheduleModel
public ref class ConnectionScheduleModel sealed
[<SealedAttribute>]
type ConnectionScheduleModel =  class end

The ConnectionScheduleModel type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionScheduleModel | Initializes a new instance of the ConnectionScheduleModel class
Top
Properties
 | Name | Description
Public property | Archive | Gets or sets the archive schedule.
Public property | Bandwidth | Gets or sets the bandwidth schedule.
Public property | Orphans | Gets or sets the orphans schedule.
Public property | Transmission | Gets or sets the transmission schedule.
Public property | Verify | Gets or sets the verification schedule.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ConnectionScheduleModel Constructor

ConnectionScheduleModel Constructor
Initializes a new instance of the ConnectionScheduleModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectionScheduleModel()
Public Sub New
public:
ConnectionScheduleModel()
new : unit -> ConnectionScheduleModel
See Also

Reference

ConnectionScheduleModel Class


ConnectionScheduleModel Properties

ConnectionScheduleModel Properties

The ConnectionScheduleModel type exposes the following members.

Properties
 | Name | Description
Public property | Archive | Gets or sets the archive schedule.
Public property | Bandwidth | Gets or sets the bandwidth schedule.
Public property | Orphans | Gets or sets the orphans schedule.
Public property | Transmission | Gets or sets the transmission schedule.
Public property | Verify | Gets or sets the verification schedule.
Top
See Also

Reference

ConnectionScheduleModel Class


ConnectionScheduleModel.Archive Property

ConnectionScheduleModelArchive Property
Gets or sets the archive schedule.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ArchiveScheduleModel Archive { get; set; }
Public Property Archive As ArchiveScheduleModel
    Get
    Set
public:
property ArchiveScheduleModel^ Archive {
    ArchiveScheduleModel^ get ();
    void set (ArchiveScheduleModel^ value);
}
member Archive : ArchiveScheduleModel with get, set

Property Value

Type: ArchiveScheduleModel
See Also

Reference

ConnectionScheduleModel Class


ConnectionScheduleModel.Bandwidth Property

ConnectionScheduleModelBandwidth Property
Gets or sets the bandwidth schedule.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthScheduleModel Bandwidth { get; set; }
Public Property Bandwidth As BandwidthScheduleModel
    Get
    Set
public:
property BandwidthScheduleModel^ Bandwidth {
    BandwidthScheduleModel^ get ();
    void set (BandwidthScheduleModel^ value);
}
member Bandwidth : BandwidthScheduleModel with get, set

Property Value

Type: BandwidthScheduleModel
See Also

Reference

ConnectionScheduleModel Class


ConnectionScheduleModel.Orphans Property

ConnectionScheduleModelOrphans Property
Gets or sets the orphans schedule.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public OrphansScheduleModel Orphans { get; set; }
Public Property Orphans As OrphansScheduleModel
    Get
    Set
public:
property OrphansScheduleModel^ Orphans {
    OrphansScheduleModel^ get ();
    void set (OrphansScheduleModel^ value);
}
member Orphans : OrphansScheduleModel with get, set

Property Value

Type: OrphansScheduleModel
See Also

Reference

ConnectionScheduleModel Class


ConnectionScheduleModel.Transmission Property

ConnectionScheduleModelTransmission Property
Gets or sets the transmission schedule.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TransmissionScheduleModel Transmission { get; set; }
Public Property Transmission As TransmissionScheduleModel
    Get
    Set
public:
property TransmissionScheduleModel^ Transmission {
    TransmissionScheduleModel^ get ();
    void set (TransmissionScheduleModel^ value);
}
member Transmission : TransmissionScheduleModel with get, set

Property Value

Type: TransmissionScheduleModel
See Also

Reference

ConnectionScheduleModel Class


ConnectionScheduleModel.Verify Property

ConnectionScheduleModelVerify Property
Gets or sets the verification schedule.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VerifyScheduleModel Verify { get; set; }
Public Property Verify As VerifyScheduleModel
    Get
    Set
public:
property VerifyScheduleModel^ Verify {
    VerifyScheduleModel^ get ();
    void set (VerifyScheduleModel^ value);
}
member Verify : VerifyScheduleModel with get, set

Property Value

Type: VerifyScheduleModel
See Also

Reference

ConnectionScheduleModel Class


ConnectionScheduleModel Methods

ConnectionScheduleModel Methods

The ConnectionScheduleModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConnectionScheduleModel Class


ConnectionStartParametersModel Class

ConnectionStartParametersModel Class
Connection start parameters model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsConnectionStartParametersModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ConnectionStartParametersModel
Public NotInheritable Class ConnectionStartParametersModel
public ref class ConnectionStartParametersModel sealed
[<SealedAttribute>]
type ConnectionStartParametersModel =  class end

The ConnectionStartParametersModel type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionStartParametersModel | Initializes a new instance of the ConnectionStartParametersModel class
Top
Properties
 | Name | Description
Public property | ArchiveBinLocation | Gets or sets the volume on which to store all archived files on the target.
Public property | CompressionLevel | Gets or sets the compression to use for data passed over this connection.
Public property | IsEncrypted | Gets or sets a value indicating whether or not to encrypt the connection data stream.
Public property | IsMirrorEnabled | Gets or sets a value indicating whether or not to start a mirror when the connection is created.
Public property | IsPathBlockingEnabled | Gets or sets a value indicating whether or not to block outside access to the destination paths on the target machine.
Public property | IsReplicationEnabled | Gets or sets a value indicating whether or not to start replication when the connection is created.
Public property | IsRestore | Gets or sets a value indicating whether or not this instance is restore mirror.
Public property | MirrorParameters | Gets or sets parameters to be used for the initial connection mirror.
Public property | Schedule | Gets or sets the schedule to use for the connection.
Public property | ScriptPoints | Gets or sets script points to configure on the connection.
Public property | SnapshotSchedule | Gets or sets snapshot schedule configuration.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ConnectionStartParametersModel Constructor

ConnectionStartParametersModel Constructor
Initializes a new instance of the ConnectionStartParametersModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectionStartParametersModel()
Public Sub New
public:
ConnectionStartParametersModel()
new : unit -> ConnectionStartParametersModel
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel Properties

ConnectionStartParametersModel Properties

The ConnectionStartParametersModel type exposes the following members.

Properties
 | Name | Description
Public property | ArchiveBinLocation | Gets or sets the volume on which to store all archived files on the target.
Public property | CompressionLevel | Gets or sets the compression to use for data passed over this connection.
Public property | IsEncrypted | Gets or sets a value indicating whether or not to encrypt the connection data stream.
Public property | IsMirrorEnabled | Gets or sets a value indicating whether or not to start a mirror when the connection is created.
Public property | IsPathBlockingEnabled | Gets or sets a value indicating whether or not to block outside access to the destination paths on the target machine.
Public property | IsReplicationEnabled | Gets or sets a value indicating whether or not to start replication when the connection is created.
Public property | IsRestore | Gets or sets a value indicating whether or not this instance is restore mirror.
Public property | MirrorParameters | Gets or sets parameters to be used for the initial connection mirror.
Public property | Schedule | Gets or sets the schedule to use for the connection.
Public property | ScriptPoints | Gets or sets script points to configure on the connection.
Public property | SnapshotSchedule | Gets or sets snapshot schedule configuration.
Top
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel.ArchiveBinLocation Property

ConnectionStartParametersModelArchiveBinLocation Property
Gets or sets the volume on which to store all archived files on the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ArchiveBinLocation { get; set; }
Public Property ArchiveBinLocation As String
    Get
    Set
public:
property String^ ArchiveBinLocation {
    String^ get ();
    void set (String^ value);
}
member ArchiveBinLocation : string with get, set

Property Value

Type: String
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel.CompressionLevel Property

ConnectionStartParametersModelCompressionLevel Property
Gets or sets the compression to use for data passed over this connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CompressionLevelModel CompressionLevel { get; set; }
Public Property CompressionLevel As CompressionLevelModel
    Get
    Set
public:
property CompressionLevelModel^ CompressionLevel {
    CompressionLevelModel^ get ();
    void set (CompressionLevelModel^ value);
}
member CompressionLevel : CompressionLevelModel with get, set

Property Value

Type: CompressionLevelModel
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel.IsEncrypted Property

ConnectionStartParametersModelIsEncrypted Property
Gets or sets a value indicating whether or not to encrypt the connection data stream.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEncrypted { get; set; }
Public Property IsEncrypted As Boolean
    Get
    Set
public:
property bool IsEncrypted {
    bool get ();
    void set (bool value);
}
member IsEncrypted : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel.IsMirrorEnabled Property

ConnectionStartParametersModelIsMirrorEnabled Property
Gets or sets a value indicating whether or not to start a mirror when the connection is created.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsMirrorEnabled { get; set; }
Public Property IsMirrorEnabled As Boolean
    Get
    Set
public:
property bool IsMirrorEnabled {
    bool get ();
    void set (bool value);
}
member IsMirrorEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel.IsPathBlockingEnabled Property

ConnectionStartParametersModelIsPathBlockingEnabled Property
Gets or sets a value indicating whether or not to block outside access to the destination paths on the target machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPathBlockingEnabled { get; set; }
Public Property IsPathBlockingEnabled As Boolean
    Get
    Set
public:
property bool IsPathBlockingEnabled {
    bool get ();
    void set (bool value);
}
member IsPathBlockingEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel.IsReplicationEnabled Property

ConnectionStartParametersModelIsReplicationEnabled Property
Gets or sets a value indicating whether or not to start replication when the connection is created.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsReplicationEnabled { get; set; }
Public Property IsReplicationEnabled As Boolean
    Get
    Set
public:
property bool IsReplicationEnabled {
    bool get ();
    void set (bool value);
}
member IsReplicationEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel.IsRestore Property

ConnectionStartParametersModelIsRestore Property
Gets or sets a value indicating whether or not this instance is restore mirror.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsRestore { get; set; }
Public Property IsRestore As Boolean
    Get
    Set
public:
property bool IsRestore {
    bool get ();
    void set (bool value);
}
member IsRestore : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel.MirrorParameters Property

ConnectionStartParametersModelMirrorParameters Property
Gets or sets parameters to be used for the initial connection mirror.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public MirrorParametersModel MirrorParameters { get; set; }
Public Property MirrorParameters As MirrorParametersModel
    Get
    Set
public:
property MirrorParametersModel^ MirrorParameters {
    MirrorParametersModel^ get ();
    void set (MirrorParametersModel^ value);
}
member MirrorParameters : MirrorParametersModel with get, set

Property Value

Type: MirrorParametersModel
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel.Schedule Property

ConnectionStartParametersModelSchedule Property
Gets or sets the schedule to use for the connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectionScheduleModel Schedule { get; set; }
Public Property Schedule As ConnectionScheduleModel
    Get
    Set
public:
property ConnectionScheduleModel^ Schedule {
    ConnectionScheduleModel^ get ();
    void set (ConnectionScheduleModel^ value);
}
member Schedule : ConnectionScheduleModel with get, set

Property Value

Type: ConnectionScheduleModel
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel.ScriptPoints Property

ConnectionStartParametersModelScriptPoints Property
Gets or sets script points to configure on the connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptPointModel[] ScriptPoints { get; set; }
Public Property ScriptPoints As ScriptPointModel()
    Get
    Set
public:
property array<ScriptPointModel^>^ ScriptPoints {
    array<ScriptPointModel^>^ get ();
    void set (array<ScriptPointModel^>^ value);
}
member ScriptPoints : ScriptPointModel[] with get, set

Property Value

Type: ScriptPointModel
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel.SnapshotSchedule Property

ConnectionStartParametersModelSnapshotSchedule Property
Gets or sets snapshot schedule configuration.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public SnapshotScheduleModel SnapshotSchedule { get; set; }
Public Property SnapshotSchedule As SnapshotScheduleModel
    Get
    Set
public:
property SnapshotScheduleModel^ SnapshotSchedule {
    SnapshotScheduleModel^ get ();
    void set (SnapshotScheduleModel^ value);
}
member SnapshotSchedule : SnapshotScheduleModel with get, set

Property Value

Type: SnapshotScheduleModel
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStartParametersModel Methods

ConnectionStartParametersModel Methods

The ConnectionStartParametersModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConnectionStartParametersModel Class


ConnectionStatisticsModel Class

ConnectionStatisticsModel Class
Connection statistics.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsConnectionStatisticsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class ConnectionStatisticsModel
Public NotInheritable Class ConnectionStatisticsModel
public ref class ConnectionStatisticsModel sealed
[<SealedAttribute>]
type ConnectionStatisticsModel =  class end

The ConnectionStatisticsModel type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionStatisticsModel | Initializes a new instance of the ConnectionStatisticsModel class
Top
Properties
 | Name | Description
Public property | CurrentTime | Gets or sets the CurrentTime.
Public property | DiskQueueBytes | Gets or sets the number of bytes in the disk queue.
Public property | MirrorBytesRemaining | Gets or sets the mirror bytes remaining.
Public property | MirrorBytesSent | Gets or sets the mirror bytes sent.
Public property | MirrorBytesSkipped | Gets or sets the mirror bytes skipped.
Public property | MirrorBytesTransmitted | Gets or sets the mirror bytes transmitted.
Public property | MirrorEndTime | Gets or sets the MirrorEndTime.
Public property | MirrorOpsQueued | Gets or sets the mirror ops queued.
Public property | MirrorPermillage | Gets or sets the mirror permillage.
Public property | MirrorStartTime | Gets or sets the MirrorStartTime.
Public property | ReplicationBytesQueued | Gets or sets the replication bytes queued.
Public property | ReplicationBytesSent | Gets or sets the replication bytes sent.
Public property | ReplicationBytesTransmitted | Gets or sets the replication bytes transmitted.
Public property | ReplicationOpsQueued | Gets or sets the replication ops queued.
Public property | ReplicationSetCalcInProgress | Gets or sets a value indicating whether the repset calc is in progress.
Public property | Rpl | Gets or sets the Rpl.
Public property | Rpt | Gets or sets the Rpt.
Public property | TotalBytesSent | Gets or sets the total bytes sent.
Public property | TotalBytesTransmitted | Gets or sets the total bytes transmitted.
Public property | TotalOpsQueued | Gets or sets the total ops queued.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ConnectionStatisticsModel Constructor

ConnectionStatisticsModel Constructor
Initializes a new instance of the ConnectionStatisticsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ConnectionStatisticsModel()
Public Sub New
public:
ConnectionStatisticsModel()
new : unit -> ConnectionStatisticsModel
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel Properties

ConnectionStatisticsModel Properties

The ConnectionStatisticsModel type exposes the following members.

Properties
 | Name | Description
Public property | CurrentTime | Gets or sets the CurrentTime.
Public property | DiskQueueBytes | Gets or sets the number of bytes in the disk queue.
Public property | MirrorBytesRemaining | Gets or sets the mirror bytes remaining.
Public property | MirrorBytesSent | Gets or sets the mirror bytes sent.
Public property | MirrorBytesSkipped | Gets or sets the mirror bytes skipped.
Public property | MirrorBytesTransmitted | Gets or sets the mirror bytes transmitted.
Public property | MirrorEndTime | Gets or sets the MirrorEndTime.
Public property | MirrorOpsQueued | Gets or sets the mirror ops queued.
Public property | MirrorPermillage | Gets or sets the mirror permillage.
Public property | MirrorStartTime | Gets or sets the MirrorStartTime.
Public property | ReplicationBytesQueued | Gets or sets the replication bytes queued.
Public property | ReplicationBytesSent | Gets or sets the replication bytes sent.
Public property | ReplicationBytesTransmitted | Gets or sets the replication bytes transmitted.
Public property | ReplicationOpsQueued | Gets or sets the replication ops queued.
Public property | ReplicationSetCalcInProgress | Gets or sets a value indicating whether the repset calc is in progress.
Public property | Rpl | Gets or sets the Rpl.
Public property | Rpt | Gets or sets the Rpt.
Public property | TotalBytesSent | Gets or sets the total bytes sent.
Public property | TotalBytesTransmitted | Gets or sets the total bytes transmitted.
Public property | TotalOpsQueued | Gets or sets the total ops queued.
Top
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.CurrentTime Property

ConnectionStatisticsModelCurrentTime Property
Gets or sets the CurrentTime.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long CurrentTime { get; set; }
Public Property CurrentTime As Long
    Get
    Set
public:
property long long CurrentTime {
    long long get ();
    void set (long long value);
}
member CurrentTime : int64 with get, set

Property Value

Type: Int64
The CurrentTime.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.DiskQueueBytes Property

ConnectionStatisticsModelDiskQueueBytes Property
Gets or sets the number of bytes in the disk queue.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long DiskQueueBytes { get; set; }
Public Property DiskQueueBytes As Long
    Get
    Set
public:
property long long DiskQueueBytes {
    long long get ();
    void set (long long value);
}
member DiskQueueBytes : int64 with get, set

Property Value

Type: Int64
The disk queue bytes.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.MirrorBytesRemaining Property

ConnectionStatisticsModelMirrorBytesRemaining Property
Gets or sets the mirror bytes remaining.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long MirrorBytesRemaining { get; set; }
Public Property MirrorBytesRemaining As Long
    Get
    Set
public:
property long long MirrorBytesRemaining {
    long long get ();
    void set (long long value);
}
member MirrorBytesRemaining : int64 with get, set

Property Value

Type: Int64
The mirror bytes remaining.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.MirrorBytesSent Property

ConnectionStatisticsModelMirrorBytesSent Property
Gets or sets the mirror bytes sent.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long MirrorBytesSent { get; set; }
Public Property MirrorBytesSent As Long
    Get
    Set
public:
property long long MirrorBytesSent {
    long long get ();
    void set (long long value);
}
member MirrorBytesSent : int64 with get, set

Property Value

Type: Int64
The mirror bytes sent.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.MirrorBytesSkipped Property

ConnectionStatisticsModelMirrorBytesSkipped Property
Gets or sets the mirror bytes skipped.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long MirrorBytesSkipped { get; set; }
Public Property MirrorBytesSkipped As Long
    Get
    Set
public:
property long long MirrorBytesSkipped {
    long long get ();
    void set (long long value);
}
member MirrorBytesSkipped : int64 with get, set

Property Value

Type: Int64
The mirror bytes skipped.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.MirrorBytesTransmitted Property

ConnectionStatisticsModelMirrorBytesTransmitted Property
Gets or sets the mirror bytes transmitted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long MirrorBytesTransmitted { get; set; }
Public Property MirrorBytesTransmitted As Long
    Get
    Set
public:
property long long MirrorBytesTransmitted {
    long long get ();
    void set (long long value);
}
member MirrorBytesTransmitted : int64 with get, set

Property Value

Type: Int64
The mirror bytes transmitted.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.MirrorEndTime Property

ConnectionStatisticsModelMirrorEndTime Property
Gets or sets the MirrorEndTime.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long MirrorEndTime { get; set; }
Public Property MirrorEndTime As Long
    Get
    Set
public:
property long long MirrorEndTime {
    long long get ();
    void set (long long value);
}
member MirrorEndTime : int64 with get, set

Property Value

Type: Int64
The MirrorEndTime.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.MirrorOpsQueued Property

ConnectionStatisticsModelMirrorOpsQueued Property
Gets or sets the mirror ops queued.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long MirrorOpsQueued { get; set; }
Public Property MirrorOpsQueued As Long
    Get
    Set
public:
property long long MirrorOpsQueued {
    long long get ();
    void set (long long value);
}
member MirrorOpsQueued : int64 with get, set

Property Value

Type: Int64
The mirror ops queued.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.MirrorPermillage Property

ConnectionStatisticsModelMirrorPermillage Property
Gets or sets the mirror permillage.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public short MirrorPermillage { get; set; }
Public Property MirrorPermillage As Short
    Get
    Set
public:
property short MirrorPermillage {
    short get ();
    void set (short value);
}
member MirrorPermillage : int16 with get, set

Property Value

Type: Int16
The mirror permillage.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.MirrorStartTime Property

ConnectionStatisticsModelMirrorStartTime Property
Gets or sets the MirrorStartTime.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long MirrorStartTime { get; set; }
Public Property MirrorStartTime As Long
    Get
    Set
public:
property long long MirrorStartTime {
    long long get ();
    void set (long long value);
}
member MirrorStartTime : int64 with get, set

Property Value

Type: Int64
The MirrorStartTime.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.ReplicationBytesQueued Property

ConnectionStatisticsModelReplicationBytesQueued Property
Gets or sets the replication bytes queued.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long ReplicationBytesQueued { get; set; }
Public Property ReplicationBytesQueued As Long
    Get
    Set
public:
property long long ReplicationBytesQueued {
    long long get ();
    void set (long long value);
}
member ReplicationBytesQueued : int64 with get, set

Property Value

Type: Int64
The replication bytes queued.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.ReplicationBytesSent Property

ConnectionStatisticsModelReplicationBytesSent Property
Gets or sets the replication bytes sent.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long ReplicationBytesSent { get; set; }
Public Property ReplicationBytesSent As Long
    Get
    Set
public:
property long long ReplicationBytesSent {
    long long get ();
    void set (long long value);
}
member ReplicationBytesSent : int64 with get, set

Property Value

Type: Int64
The replication bytes sent.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.ReplicationBytesTransmitted Property

ConnectionStatisticsModelReplicationBytesTransmitted Property
Gets or sets the replication bytes transmitted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long ReplicationBytesTransmitted { get; set; }
Public Property ReplicationBytesTransmitted As Long
    Get
    Set
public:
property long long ReplicationBytesTransmitted {
    long long get ();
    void set (long long value);
}
member ReplicationBytesTransmitted : int64 with get, set

Property Value

Type: Int64
The replication bytes transmitted.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.ReplicationOpsQueued Property

ConnectionStatisticsModelReplicationOpsQueued Property
Gets or sets the replication ops queued.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long ReplicationOpsQueued { get; set; }
Public Property ReplicationOpsQueued As Long
    Get
    Set
public:
property long long ReplicationOpsQueued {
    long long get ();
    void set (long long value);
}
member ReplicationOpsQueued : int64 with get, set

Property Value

Type: Int64
The replication ops queued.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.ReplicationSetCalcInProgress Property

ConnectionStatisticsModelReplicationSetCalcInProgress Property
Gets or sets a value indicating whether the repset calc is in progress.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool ReplicationSetCalcInProgress { get; set; }
Public Property ReplicationSetCalcInProgress As Boolean
    Get
    Set
public:
property bool ReplicationSetCalcInProgress {
    bool get ();
    void set (bool value);
}
member ReplicationSetCalcInProgress : bool with get, set

Property Value

Type: Boolean
if the repset calculation is in progress; otherwise, .
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.Rpl Property

ConnectionStatisticsModelRpl Property
Gets or sets the Rpl.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long Rpl { get; set; }
Public Property Rpl As Long
    Get
    Set
public:
property long long Rpl {
    long long get ();
    void set (long long value);
}
member Rpl : int64 with get, set

Property Value

Type: Int64
The Rpl.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.Rpt Property

ConnectionStatisticsModelRpt Property
Gets or sets the Rpt.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long Rpt { get; set; }
Public Property Rpt As Long
    Get
    Set
public:
property long long Rpt {
    long long get ();
    void set (long long value);
}
member Rpt : int64 with get, set

Property Value

Type: Int64
The Rpt.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.TotalBytesSent Property

ConnectionStatisticsModelTotalBytesSent Property
Gets or sets the total bytes sent.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long TotalBytesSent { get; set; }
Public Property TotalBytesSent As Long
    Get
    Set
public:
property long long TotalBytesSent {
    long long get ();
    void set (long long value);
}
member TotalBytesSent : int64 with get, set

Property Value

Type: Int64
The total bytes sent.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.TotalBytesTransmitted Property

ConnectionStatisticsModelTotalBytesTransmitted Property
Gets or sets the total bytes transmitted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long TotalBytesTransmitted { get; set; }
Public Property TotalBytesTransmitted As Long
    Get
    Set
public:
property long long TotalBytesTransmitted {
    long long get ();
    void set (long long value);
}
member TotalBytesTransmitted : int64 with get, set

Property Value

Type: Int64
The total bytes transmitted.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel.TotalOpsQueued Property

ConnectionStatisticsModelTotalOpsQueued Property
Gets or sets the total ops queued.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long TotalOpsQueued { get; set; }
Public Property TotalOpsQueued As Long
    Get
    Set
public:
property long long TotalOpsQueued {
    long long get ();
    void set (long long value);
}
member TotalOpsQueued : int64 with get, set

Property Value

Type: Int64
The total ops queued.
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatisticsModel Methods

ConnectionStatisticsModel Methods

The ConnectionStatisticsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConnectionStatisticsModel Class


ConnectionStatusModel Class

ConnectionStatusModel Class
The connection status model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsConnectionStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class ConnectionStatusModel
Public NotInheritable Class ConnectionStatusModel
public ref class ConnectionStatusModel sealed
[<SealedAttribute>]
type ConnectionStatusModel =  class end

The ConnectionStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionStatusModel | Initializes a new instance of the ConnectionStatusModel class
Top
Properties
 | Name | Description
Public property | Alive | Gets or sets a value indicating whether the connection is active.
Public property | CmdRspQueueState | Gets or sets the QueueStateEnum of the command/response queue.
Public property | ConnectionMode | Gets or sets the connection mode.
Public property | Error | Gets or sets a value indicating whether the connection experienced a network error.
Public property | InitialMirrorComplete | Gets or sets a value indicating whether an initial mirror has completed for the connection.
Public property | IsRestoreRequired | Gets or sets a value indicating whether the source/target data may be out of sync and a restore is required.
Public property | IsScheduled | Gets or sets a value indicating whether the transmission is in a scheduled state.
Public property | MirrorQueueState | Gets or sets the QueueStateEnum of the mirror queue.
Public property | MirrorSize | Gets or sets the size of the replication set in bytes, if it has been calculated.
Public property | MirrorState | Gets or sets the operational state of the mirror.
Public property | PeerMemoryLow | Gets or sets a value indicating whether there's low memory on the target.
Public property | PendingAckQueueFull | Gets or sets a value indicating whether the pending ACK queue is full.
Public property | ReplicationQueueState | Gets or sets the QueueStateEnum of the replication queue.
Public property | ReplicationState | Gets or sets the operational state of replication.
Public property | Restoring | Gets or sets a value indicating whether the connection represented by this ConnectionStatusModel is restoring.
Public property | RetransmitQueueState | Gets or sets the QueueStateEnum of the retransmit queue.
Public property | StartTime | Gets or sets the start time.
Public property | TargetState | Gets or sets the known operational states of the connection target.
Public property | TransmissionMode | Gets or sets the operational state of replication and mirror.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ConnectionStatusModel Constructor

ConnectionStatusModel Constructor
Initializes a new instance of the ConnectionStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ConnectionStatusModel()
Public Sub New
public:
ConnectionStatusModel()
new : unit -> ConnectionStatusModel
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel Properties

ConnectionStatusModel Properties

The ConnectionStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | Alive | Gets or sets a value indicating whether the connection is active.
Public property | CmdRspQueueState | Gets or sets the QueueStateEnum of the command/response queue.
Public property | ConnectionMode | Gets or sets the connection mode.
Public property | Error | Gets or sets a value indicating whether the connection experienced a network error.
Public property | InitialMirrorComplete | Gets or sets a value indicating whether an initial mirror has completed for the connection.
Public property | IsRestoreRequired | Gets or sets a value indicating whether the source/target data may be out of sync and a restore is required.
Public property | IsScheduled | Gets or sets a value indicating whether the transmission is in a scheduled state.
Public property | MirrorQueueState | Gets or sets the QueueStateEnum of the mirror queue.
Public property | MirrorSize | Gets or sets the size of the replication set in bytes, if it has been calculated.
Public property | MirrorState | Gets or sets the operational state of the mirror.
Public property | PeerMemoryLow | Gets or sets a value indicating whether there's low memory on the target.
Public property | PendingAckQueueFull | Gets or sets a value indicating whether the pending ACK queue is full.
Public property | ReplicationQueueState | Gets or sets the QueueStateEnum of the replication queue.
Public property | ReplicationState | Gets or sets the operational state of replication.
Public property | Restoring | Gets or sets a value indicating whether the connection represented by this ConnectionStatusModel is restoring.
Public property | RetransmitQueueState | Gets or sets the QueueStateEnum of the retransmit queue.
Public property | StartTime | Gets or sets the start time.
Public property | TargetState | Gets or sets the known operational states of the connection target.
Public property | TransmissionMode | Gets or sets the operational state of replication and mirror.
Top
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.Alive Property

ConnectionStatusModelAlive Property
Gets or sets a value indicating whether the connection is active.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool Alive { get; set; }
Public Property Alive As Boolean
    Get
    Set
public:
property bool Alive {
    bool get ();
    void set (bool value);
}
member Alive : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.CmdRspQueueState Property

ConnectionStatusModelCmdRspQueueState Property
Gets or sets the QueueStateEnum of the command/response queue.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public QueueStateEnum CmdRspQueueState { get; set; }
Public Property CmdRspQueueState As QueueStateEnum
    Get
    Set
public:
property QueueStateEnum CmdRspQueueState {
    QueueStateEnum get ();
    void set (QueueStateEnum value);
}
member CmdRspQueueState : QueueStateEnum with get, set

Property Value

Type: QueueStateEnum
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.ConnectionMode Property

ConnectionStatusModelConnectionMode Property
Gets or sets the connection mode.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ConnectionModeEnum ConnectionMode { get; set; }
Public Property ConnectionMode As ConnectionModeEnum
    Get
    Set
public:
property ConnectionModeEnum ConnectionMode {
    ConnectionModeEnum get ();
    void set (ConnectionModeEnum value);
}
member ConnectionMode : ConnectionModeEnum with get, set

Property Value

Type: ConnectionModeEnum
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.Error Property

ConnectionStatusModelError Property
Gets or sets a value indicating whether the connection experienced a network error.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool Error { get; set; }
Public Property Error As Boolean
    Get
    Set
public:
property bool Error {
    bool get ();
    void set (bool value);
}
member Error : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.InitialMirrorComplete Property

ConnectionStatusModelInitialMirrorComplete Property
Gets or sets a value indicating whether an initial mirror has completed for the connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool InitialMirrorComplete { get; set; }
Public Property InitialMirrorComplete As Boolean
    Get
    Set
public:
property bool InitialMirrorComplete {
    bool get ();
    void set (bool value);
}
member InitialMirrorComplete : bool with get, set

Property Value

Type: Boolean
if an initial mirror has completed; otherwise, .
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.IsRestoreRequired Property

ConnectionStatusModelIsRestoreRequired Property
Gets or sets a value indicating whether the source/target data may be out of sync and a restore is required.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsRestoreRequired { get; set; }
Public Property IsRestoreRequired As Boolean
    Get
    Set
public:
property bool IsRestoreRequired {
    bool get ();
    void set (bool value);
}
member IsRestoreRequired : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.IsScheduled Property

ConnectionStatusModelIsScheduled Property
Gets or sets a value indicating whether the transmission is in a scheduled state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsScheduled { get; set; }
Public Property IsScheduled As Boolean
    Get
    Set
public:
property bool IsScheduled {
    bool get ();
    void set (bool value);
}
member IsScheduled : bool with get, set

Property Value

Type: Boolean
if transmission for this instance is scheduled; otherwise, .
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.MirrorQueueState Property

ConnectionStatusModelMirrorQueueState Property
Gets or sets the QueueStateEnum of the mirror queue.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public QueueStateEnum MirrorQueueState { get; set; }
Public Property MirrorQueueState As QueueStateEnum
    Get
    Set
public:
property QueueStateEnum MirrorQueueState {
    QueueStateEnum get ();
    void set (QueueStateEnum value);
}
member MirrorQueueState : QueueStateEnum with get, set

Property Value

Type: QueueStateEnum
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.MirrorSize Property

ConnectionStatusModelMirrorSize Property
Gets or sets the size of the replication set in bytes, if it has been calculated.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long MirrorSize { get; set; }
Public Property MirrorSize As Long
    Get
    Set
public:
property long long MirrorSize {
    long long get ();
    void set (long long value);
}
member MirrorSize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.MirrorState Property

ConnectionStatusModelMirrorState Property
Gets or sets the operational state of the mirror.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public MirrorState MirrorState { get; set; }
Public Property MirrorState As MirrorState
    Get
    Set
public:
property MirrorState MirrorState {
    MirrorState get ();
    void set (MirrorState value);
}
member MirrorState : MirrorState with get, set

Property Value

Type: MirrorState
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.PeerMemoryLow Property

ConnectionStatusModelPeerMemoryLow Property
Gets or sets a value indicating whether there's low memory on the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool PeerMemoryLow { get; set; }
Public Property PeerMemoryLow As Boolean
    Get
    Set
public:
property bool PeerMemoryLow {
    bool get ();
    void set (bool value);
}
member PeerMemoryLow : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.PendingAckQueueFull Property

ConnectionStatusModelPendingAckQueueFull Property
Gets or sets a value indicating whether the pending ACK queue is full.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool PendingAckQueueFull { get; set; }
Public Property PendingAckQueueFull As Boolean
    Get
    Set
public:
property bool PendingAckQueueFull {
    bool get ();
    void set (bool value);
}
member PendingAckQueueFull : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.ReplicationQueueState Property

ConnectionStatusModelReplicationQueueState Property
Gets or sets the QueueStateEnum of the replication queue.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public QueueStateEnum ReplicationQueueState { get; set; }
Public Property ReplicationQueueState As QueueStateEnum
    Get
    Set
public:
property QueueStateEnum ReplicationQueueState {
    QueueStateEnum get ();
    void set (QueueStateEnum value);
}
member ReplicationQueueState : QueueStateEnum with get, set

Property Value

Type: QueueStateEnum
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.ReplicationState Property

ConnectionStatusModelReplicationState Property
Gets or sets the operational state of replication.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ReplicationState ReplicationState { get; set; }
Public Property ReplicationState As ReplicationState
    Get
    Set
public:
property ReplicationState ReplicationState {
    ReplicationState get ();
    void set (ReplicationState value);
}
member ReplicationState : ReplicationState with get, set

Property Value

Type: ReplicationState
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.Restoring Property

ConnectionStatusModelRestoring Property
Gets or sets a value indicating whether the connection represented by this ConnectionStatusModel is restoring.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool Restoring { get; set; }
Public Property Restoring As Boolean
    Get
    Set
public:
property bool Restoring {
    bool get ();
    void set (bool value);
}
member Restoring : bool with get, set

Property Value

Type: Boolean
if the connection is restoring; otherwise, .
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.RetransmitQueueState Property

ConnectionStatusModelRetransmitQueueState Property
Gets or sets the QueueStateEnum of the retransmit queue.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public QueueStateEnum RetransmitQueueState { get; set; }
Public Property RetransmitQueueState As QueueStateEnum
    Get
    Set
public:
property QueueStateEnum RetransmitQueueState {
    QueueStateEnum get ();
    void set (QueueStateEnum value);
}
member RetransmitQueueState : QueueStateEnum with get, set

Property Value

Type: QueueStateEnum
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.StartTime Property

ConnectionStatusModelStartTime Property
Gets or sets the start time.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset StartTime { get; set; }
Public Property StartTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset StartTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member StartTime : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.TargetState Property

ConnectionStatusModelTargetState Property
Gets or sets the known operational states of the connection target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public TargetStates TargetState { get; set; }
Public Property TargetState As TargetStates
    Get
    Set
public:
property TargetStates TargetState {
    TargetStates get ();
    void set (TargetStates value);
}
member TargetState : TargetStates with get, set

Property Value

Type: TargetStates
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel.TransmissionMode Property

ConnectionStatusModelTransmissionMode Property
Gets or sets the operational state of replication and mirror.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public TransmissionMode TransmissionMode { get; set; }
Public Property TransmissionMode As TransmissionMode
    Get
    Set
public:
property TransmissionMode TransmissionMode {
    TransmissionMode get ();
    void set (TransmissionMode value);
}
member TransmissionMode : TransmissionMode with get, set

Property Value

Type: TransmissionMode
See Also

Reference

ConnectionStatusModel Class


ConnectionStatusModel Methods

ConnectionStatusModel Methods

The ConnectionStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ConnectionStatusModel Class


ControlledServerInfoModel Class

ControlledServerInfoModel Class
Represents information about a server managed by Controller Service
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsControlledServerInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class ControlledServerInfoModel
Public Class ControlledServerInfoModel
public ref class ControlledServerInfoModel
type ControlledServerInfoModel =  class end

The ControlledServerInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ControlledServerInfoModel | Initializes a new instance of the ControlledServerInfoModel class
Top
Properties
 | Name | Description
Public property | ProductInfo | Gets or sets the product information.
Public property | ServerInfo | Gets or sets the server information.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ControlledServerInfoModel Constructor

ControlledServerInfoModel Constructor
Initializes a new instance of the ControlledServerInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ControlledServerInfoModel()
Public Sub New
public:
ControlledServerInfoModel()
new : unit -> ControlledServerInfoModel
See Also

Reference

ControlledServerInfoModel Class


ControlledServerInfoModel Properties

ControlledServerInfoModel Properties

The ControlledServerInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | ProductInfo | Gets or sets the product information.
Public property | ServerInfo | Gets or sets the server information.
Top
See Also

Reference

ControlledServerInfoModel Class


ControlledServerInfoModel.ProductInfo Property

ControlledServerInfoModelProductInfo Property
Gets or sets the product information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ProductInfoModel ProductInfo { get; set; }
Public Property ProductInfo As ProductInfoModel
    Get
    Set
public:
property ProductInfoModel^ ProductInfo {
    ProductInfoModel^ get ();
    void set (ProductInfoModel^ value);
}
member ProductInfo : ProductInfoModel with get, set

Property Value

Type: ProductInfoModel
The product information.
See Also

Reference

ControlledServerInfoModel Class


ControlledServerInfoModel.ServerInfo Property

ControlledServerInfoModelServerInfo Property
Gets or sets the server information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ServerInfoModel ServerInfo { get; set; }
Public Property ServerInfo As ServerInfoModel
    Get
    Set
public:
property ServerInfoModel^ ServerInfo {
    ServerInfoModel^ get ();
    void set (ServerInfoModel^ value);
}
member ServerInfo : ServerInfoModel with get, set

Property Value

Type: ServerInfoModel
The server information.
See Also

Reference

ControlledServerInfoModel Class


ControlledServerInfoModel Methods

ControlledServerInfoModel Methods

The ControlledServerInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ControlledServerInfoModel Class


ControlledServerInfoSimpleModel Class

ControlledServerInfoSimpleModel Class
Represents information about a server managed by Controller Service
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsControlledServerInfoSimpleModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class ControlledServerInfoSimpleModel
Public Class ControlledServerInfoSimpleModel
public ref class ControlledServerInfoSimpleModel
type ControlledServerInfoSimpleModel =  class end

The ControlledServerInfoSimpleModel type exposes the following members.

Constructors
 | Name | Description
Public method | ControlledServerInfoSimpleModel | Initializes a new instance of the ControlledServerInfoSimpleModel class
Top
Properties
 | Name | Description
Public property | ServerName | Gets or sets the name of the server.
Public property | UniqueId | Gets or sets the unique identifier.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ControlledServerInfoSimpleModel Constructor

ControlledServerInfoSimpleModel Constructor
Initializes a new instance of the ControlledServerInfoSimpleModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ControlledServerInfoSimpleModel()
Public Sub New
public:
ControlledServerInfoSimpleModel()
new : unit -> ControlledServerInfoSimpleModel
See Also

Reference

ControlledServerInfoSimpleModel Class


ControlledServerInfoSimpleModel Properties

ControlledServerInfoSimpleModel Properties

The ControlledServerInfoSimpleModel type exposes the following members.

Properties
 | Name | Description
Public property | ServerName | Gets or sets the name of the server.
Public property | UniqueId | Gets or sets the unique identifier.
Top
See Also

Reference

ControlledServerInfoSimpleModel Class


ControlledServerInfoSimpleModel.ServerName Property

ControlledServerInfoSimpleModelServerName Property
Gets or sets the name of the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ServerName { get; set; }
Public Property ServerName As String
    Get
    Set
public:
property String^ ServerName {
    String^ get ();
    void set (String^ value);
}
member ServerName : string with get, set

Property Value

Type: String
The name of the server.
See Also

Reference

ControlledServerInfoSimpleModel Class


ControlledServerInfoSimpleModel.UniqueId Property

ControlledServerInfoSimpleModelUniqueId Property
Gets or sets the unique identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Guid UniqueId { get; set; }
Public Property UniqueId As Guid
    Get
    Set
public:
property Guid UniqueId {
    Guid get ();
    void set (Guid value);
}
member UniqueId : Guid with get, set

Property Value

Type: Guid
The unique identifier.
See Also

Reference

ControlledServerInfoSimpleModel Class


ControlledServerInfoSimpleModel Methods

ControlledServerInfoSimpleModel Methods

The ControlledServerInfoSimpleModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ControlledServerInfoSimpleModel Class


ControlOperationEnum Enumeration

ControlOperationEnum Enumeration
Control operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public enum ControlOperationEnum
Public Enumeration ControlOperationEnum
public enum class ControlOperationEnum
type ControlOperationEnum
Members
Member name | Value | Description
Start | 0 | Start the operation.
Stop | 1 | Stop the operation.
Pause | 2 | Pause the operation.
Resume | 3 | Resume the operation.
See Also

Reference

DoubleTake.Web.Models Namespace


CoreClusteredResourceStateEnum Enumeration

CoreClusteredResourceStateEnum Enumeration
Core clustered resource state

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public enum CoreClusteredResourceStateEnum
Public Enumeration CoreClusteredResourceStateEnum
public enum class CoreClusteredResourceStateEnum
type CoreClusteredResourceStateEnum
Members
Member name | Value | Description
Unknown | -1 | The unknown
Inherited | 0 | The inherited
Initializing | 1 | The initializing
Online | 2 | The online
Offline | 3 | The offline
Failed | 4 | The failed
Pending | 128 | The pending
OnlinePending | 129 | The online pending
OfflinePending | 130 | The offline pending
Added | 200 | The added
Deleted | 201 | The deleted
ResourceDoesNotExist | 1000 | The resource does not exist
See Also

Reference

DoubleTake.Web.Models Namespace


CoreClusterInfoModel Class

CoreClusterInfoModel Class
Data specific to the cluster. This is data that stays with the cluster during roll-over.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCoreClusterInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class CoreClusterInfoModel
Public Class CoreClusterInfoModel
public ref class CoreClusterInfoModel
type CoreClusterInfoModel =  class end

The CoreClusterInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | CoreClusterInfoModel | Initializes a new instance of the CoreClusterInfoModel class
Top
Properties
 | Name | Description
Public property | ClusterUniqueId | Gets or sets the unique id assigned to the cluster.
Public property | CoreClusterIPAddresses | Gets or sets the IP Addresses specific to the cluster.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CoreClusterInfoModel Constructor

CoreClusterInfoModel Constructor
Initializes a new instance of the CoreClusterInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CoreClusterInfoModel()
Public Sub New
public:
CoreClusterInfoModel()
new : unit -> CoreClusterInfoModel
See Also

Reference

CoreClusterInfoModel Class


CoreClusterInfoModel Properties

CoreClusterInfoModel Properties

The CoreClusterInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | ClusterUniqueId | Gets or sets the unique id assigned to the cluster.
Public property | CoreClusterIPAddresses | Gets or sets the IP Addresses specific to the cluster.
Top
See Also

Reference

CoreClusterInfoModel Class


CoreClusterInfoModel.ClusterUniqueId Property

CoreClusterInfoModelClusterUniqueId Property
Gets or sets the unique id assigned to the cluster.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ClusterUniqueId { get; set; }
Public Property ClusterUniqueId As String
    Get
    Set
public:
property String^ ClusterUniqueId {
    String^ get ();
    void set (String^ value);
}
member ClusterUniqueId : string with get, set

Property Value

Type: String
See Also

Reference

CoreClusterInfoModel Class


CoreClusterInfoModel.CoreClusterIPAddresses Property

CoreClusterInfoModelCoreClusterIPAddresses Property
Gets or sets the IP Addresses specific to the cluster.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public IPAddressModel[] CoreClusterIPAddresses { get; set; }
Public Property CoreClusterIPAddresses As IPAddressModel()
    Get
    Set
public:
property array<IPAddressModel^>^ CoreClusterIPAddresses {
    array<IPAddressModel^>^ get ();
    void set (array<IPAddressModel^>^ value);
}
member CoreClusterIPAddresses : IPAddressModel[] with get, set

Property Value

Type: IPAddressModel
See Also

Reference

CoreClusterInfoModel Class


CoreClusterInfoModel Methods

CoreClusterInfoModel Methods

The CoreClusterInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CoreClusterInfoModel Class


CoreConnectionDetailsModel Class

CoreConnectionDetailsModel Class
Core connection details model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCoreConnectionDetailsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class CoreConnectionDetailsModel
Public NotInheritable Class CoreConnectionDetailsModel
public ref class CoreConnectionDetailsModel sealed
[<SealedAttribute>]
type CoreConnectionDetailsModel =  class end

The CoreConnectionDetailsModel type exposes the following members.

Constructors
 | Name | Description
Public method | CoreConnectionDetailsModel | Initializes a new instance of the CoreConnectionDetailsModel class
Top
Properties
 | Name | Description
Public property | BandwidthCollar | Gets or sets the current bandwidth limit.
Public property | CompressionEnabled | Gets or sets a value indicating whether or not transmitted data is compressed.
Public property | CompressionLevel | Gets or sets the level of compression configured on the connection.
Public property | ConnectionId | Gets or sets a one-based index for each connection established in a Double-Take instance.
Public property | CurrentTime | Gets or sets the CurrentTime of the source.
Public property | DiskQueueBytes | Gets or sets the number of bytes in the disk queue.
Public property | Encrypted | Gets or sets a value indicating whether or not the job is currently encrypting network data.
Public property | InitialMirrorComplete | Gets or sets a value indicating whether or not the initial mirror for this connection has completed.
Public property | ManagedConnectionId | Gets or sets the identity of the connection as applied by the management service.
Public property | MirrorBytesRemaining | Gets or sets the number of mirror bytes remaining.
Public property | MirrorBytesSent | Gets or sets the number of mirror bytes sent.
Public property | MirrorBytesSkipped | Gets or sets the number of mirror bytes skipped.
Public property | MirrorBytesTransmitted | Gets or sets the number of mirror bytes transmitted.
Public property | MirrorEndTime | Gets or sets the MirrorEndTime of the source.
Public property | MirrorOpsQueued | Gets or sets the number of mirror ops queued.
Public property | MirrorPermillage | Gets or sets the mirror permillage.
Public property | MirrorStartTime | Gets or sets the MirrorStartTime of the source.
Public property | MirrorState | Gets or sets the operational state of the mirror.
Public property | Name | Gets or sets the name.
Public property | PeerMemoryLow | Gets or sets a value indicating whether or not the peer's memory is low.
Public property | ReplicationBytesQueued | Gets or sets the replication bytes queued on the source.
Public property | ReplicationBytesSent | Gets or sets the number of replication bytes sent.
Public property | ReplicationBytesTransmitted | Gets or sets the number of replication bytes transmitted.
Public property | ReplicationOpsQueued | Gets or sets the number of replication ops queued.
Public property | ReplicationSetCalcInProgress | Gets or sets a value indicating whether the engine's parallel repset calculation feature will start a mirror while the size of the repset is being determined.
Public property | ReplicationState | Gets or sets the operational state of replication.
Public property | Restoring | Gets or sets a value indicating whether the connection is restoring.
Public property | SourceAccessLevel | Gets or sets the source access level.
Public property | SourceAvailable | Gets or sets a value indicating whether or not the source server of this connection is available for communication from the server that owns the job.
Public property | SourceClusterResourceState | Gets or sets the state of the source cluster resource.
Public property | SourceEndpoint | Gets or sets the endpoint on the source server that is the route from the target server back to the source server of the connection.
Public property | SourceEngineAvailable | Gets or sets a value indicating whether or not source engine is available.
Public property | SourceMachineName | Gets or sets the name of the source server.
Public property | SourceRecoveryPointLatency | Gets or sets the RecoveryPointLatency of the source.
Public property | SourceRecoveryPointTime | Gets or sets the RecoveryPointTime of the source.
Public property | SourceUniqueId | Gets or sets the unique identifier of the source server.
Public property | StartTime | Gets or sets the time the connection was started.
Public property | TargetAccessLevel | Gets or sets the target access level.
Public property | TargetAvailable | Gets or sets a value indicating whether or not the target server of this connection is available for communication from the server that owns the job.
Public property | TargetEngineAvailable | Gets or sets a value indicating whether target engine is available.
Public property | TargetLoaded | Gets or sets a value indicating whether the target module is loaded on the target of the connection.
Public property | TargetMachineName | Gets or sets the name of the target server.
Public property | TargetQueueBytes | Gets or sets the number of bytes in the target queue.
Public property | TargetRoute | Gets or sets the endpoint on the target server that is the route the source server is using for this connection.
Public property | TargetState | Gets or sets the known operational states of the connection target.
Public property | TargetUniqueId | Gets or sets the unique identifier of the target server.
Public property | TotalBytesSent | Gets or sets the total bytes sent.
Public property | TotalBytesTransmitted | Gets or sets the total number of bytes transmitted.
Public property | TotalOpsQueued | Gets or sets the total number of ops queued.
Public property | TransmissionMode | Gets or sets the operational state of replication and mirroring.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CoreConnectionDetailsModel Constructor

CoreConnectionDetailsModel Constructor
Initializes a new instance of the CoreConnectionDetailsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionDetailsModel()
Public Sub New
public:
CoreConnectionDetailsModel()
new : unit -> CoreConnectionDetailsModel
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel Properties

CoreConnectionDetailsModel Properties

The CoreConnectionDetailsModel type exposes the following members.

Properties
 | Name | Description
Public property | BandwidthCollar | Gets or sets the current bandwidth limit.
Public property | CompressionEnabled | Gets or sets a value indicating whether or not transmitted data is compressed.
Public property | CompressionLevel | Gets or sets the level of compression configured on the connection.
Public property | ConnectionId | Gets or sets a one-based index for each connection established in a Double-Take instance.
Public property | CurrentTime | Gets or sets the CurrentTime of the source.
Public property | DiskQueueBytes | Gets or sets the number of bytes in the disk queue.
Public property | Encrypted | Gets or sets a value indicating whether or not the job is currently encrypting network data.
Public property | InitialMirrorComplete | Gets or sets a value indicating whether or not the initial mirror for this connection has completed.
Public property | ManagedConnectionId | Gets or sets the identity of the connection as applied by the management service.
Public property | MirrorBytesRemaining | Gets or sets the number of mirror bytes remaining.
Public property | MirrorBytesSent | Gets or sets the number of mirror bytes sent.
Public property | MirrorBytesSkipped | Gets or sets the number of mirror bytes skipped.
Public property | MirrorBytesTransmitted | Gets or sets the number of mirror bytes transmitted.
Public property | MirrorEndTime | Gets or sets the MirrorEndTime of the source.
Public property | MirrorOpsQueued | Gets or sets the number of mirror ops queued.
Public property | MirrorPermillage | Gets or sets the mirror permillage.
Public property | MirrorStartTime | Gets or sets the MirrorStartTime of the source.
Public property | MirrorState | Gets or sets the operational state of the mirror.
Public property | Name | Gets or sets the name.
Public property | PeerMemoryLow | Gets or sets a value indicating whether or not the peer's memory is low.
Public property | ReplicationBytesQueued | Gets or sets the replication bytes queued on the source.
Public property | ReplicationBytesSent | Gets or sets the number of replication bytes sent.
Public property | ReplicationBytesTransmitted | Gets or sets the number of replication bytes transmitted.
Public property | ReplicationOpsQueued | Gets or sets the number of replication ops queued.
Public property | ReplicationSetCalcInProgress | Gets or sets a value indicating whether the engine's parallel repset calculation feature will start a mirror while the size of the repset is being determined.
Public property | ReplicationState | Gets or sets the operational state of replication.
Public property | Restoring | Gets or sets a value indicating whether the connection is restoring.
Public property | SourceAccessLevel | Gets or sets the source access level.
Public property | SourceAvailable | Gets or sets a value indicating whether or not the source server of this connection is available for communication from the server that owns the job.
Public property | SourceClusterResourceState | Gets or sets the state of the source cluster resource.
Public property | SourceEndpoint | Gets or sets the endpoint on the source server that is the route from the target server back to the source server of the connection.
Public property | SourceEngineAvailable | Gets or sets a value indicating whether or not source engine is available.
Public property | SourceMachineName | Gets or sets the name of the source server.
Public property | SourceRecoveryPointLatency | Gets or sets the RecoveryPointLatency of the source.
Public property | SourceRecoveryPointTime | Gets or sets the RecoveryPointTime of the source.
Public property | SourceUniqueId | Gets or sets the unique identifier of the source server.
Public property | StartTime | Gets or sets the time the connection was started.
Public property | TargetAccessLevel | Gets or sets the target access level.
Public property | TargetAvailable | Gets or sets a value indicating whether or not the target server of this connection is available for communication from the server that owns the job.
Public property | TargetEngineAvailable | Gets or sets a value indicating whether target engine is available.
Public property | TargetLoaded | Gets or sets a value indicating whether the target module is loaded on the target of the connection.
Public property | TargetMachineName | Gets or sets the name of the target server.
Public property | TargetQueueBytes | Gets or sets the number of bytes in the target queue.
Public property | TargetRoute | Gets or sets the endpoint on the target server that is the route the source server is using for this connection.
Public property | TargetState | Gets or sets the known operational states of the connection target.
Public property | TargetUniqueId | Gets or sets the unique identifier of the target server.
Public property | TotalBytesSent | Gets or sets the total bytes sent.
Public property | TotalBytesTransmitted | Gets or sets the total number of bytes transmitted.
Public property | TotalOpsQueued | Gets or sets the total number of ops queued.
Public property | TransmissionMode | Gets or sets the operational state of replication and mirroring.
Top
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.BandwidthCollar Property

CoreConnectionDetailsModelBandwidthCollar Property
Gets or sets the current bandwidth limit.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int BandwidthCollar { get; set; }
Public Property BandwidthCollar As Integer
    Get
    Set
public:
property int BandwidthCollar {
    int get ();
    void set (int value);
}
member BandwidthCollar : int with get, set

Property Value

Type: Int32
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.CompressionEnabled Property

CoreConnectionDetailsModelCompressionEnabled Property
Gets or sets a value indicating whether or not transmitted data is compressed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CompressionEnabled { get; set; }
Public Property CompressionEnabled As Boolean
    Get
    Set
public:
property bool CompressionEnabled {
    bool get ();
    void set (bool value);
}
member CompressionEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.CompressionLevel Property

CoreConnectionDetailsModelCompressionLevel Property
Gets or sets the level of compression configured on the connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int CompressionLevel { get; set; }
Public Property CompressionLevel As Integer
    Get
    Set
public:
property int CompressionLevel {
    int get ();
    void set (int value);
}
member CompressionLevel : int with get, set

Property Value

Type: Int32
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.ConnectionId Property

CoreConnectionDetailsModelConnectionId Property
Gets or sets a one-based index for each connection established in a Double-Take instance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int ConnectionId { get; set; }
Public Property ConnectionId As Integer
    Get
    Set
public:
property int ConnectionId {
    int get ();
    void set (int value);
}
member ConnectionId : int with get, set

Property Value

Type: Int32
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.CurrentTime Property

CoreConnectionDetailsModelCurrentTime Property
Gets or sets the CurrentTime of the source.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset CurrentTime { get; set; }
Public Property CurrentTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset CurrentTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member CurrentTime : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.DiskQueueBytes Property

CoreConnectionDetailsModelDiskQueueBytes Property
Gets or sets the number of bytes in the disk queue.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long DiskQueueBytes { get; set; }
Public Property DiskQueueBytes As Long
    Get
    Set
public:
property long long DiskQueueBytes {
    long long get ();
    void set (long long value);
}
member DiskQueueBytes : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.Encrypted Property

CoreConnectionDetailsModelEncrypted Property
Gets or sets a value indicating whether or not the job is currently encrypting network data.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool Encrypted { get; set; }
Public Property Encrypted As Boolean
    Get
    Set
public:
property bool Encrypted {
    bool get ();
    void set (bool value);
}
member Encrypted : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.InitialMirrorComplete Property

CoreConnectionDetailsModelInitialMirrorComplete Property
Gets or sets a value indicating whether or not the initial mirror for this connection has completed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool InitialMirrorComplete { get; set; }
Public Property InitialMirrorComplete As Boolean
    Get
    Set
public:
property bool InitialMirrorComplete {
    bool get ();
    void set (bool value);
}
member InitialMirrorComplete : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.ManagedConnectionId Property

CoreConnectionDetailsModelManagedConnectionId Property
Gets or sets the identity of the connection as applied by the management service.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Guid ManagedConnectionId { get; set; }
Public Property ManagedConnectionId As Guid
    Get
    Set
public:
property Guid ManagedConnectionId {
    Guid get ();
    void set (Guid value);
}
member ManagedConnectionId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.MirrorBytesRemaining Property

CoreConnectionDetailsModelMirrorBytesRemaining Property
Gets or sets the number of mirror bytes remaining.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long MirrorBytesRemaining { get; set; }
Public Property MirrorBytesRemaining As Long
    Get
    Set
public:
property long long MirrorBytesRemaining {
    long long get ();
    void set (long long value);
}
member MirrorBytesRemaining : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.MirrorBytesSent Property

CoreConnectionDetailsModelMirrorBytesSent Property
Gets or sets the number of mirror bytes sent.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long MirrorBytesSent { get; set; }
Public Property MirrorBytesSent As Long
    Get
    Set
public:
property long long MirrorBytesSent {
    long long get ();
    void set (long long value);
}
member MirrorBytesSent : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.MirrorBytesSkipped Property

CoreConnectionDetailsModelMirrorBytesSkipped Property
Gets or sets the number of mirror bytes skipped.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long MirrorBytesSkipped { get; set; }
Public Property MirrorBytesSkipped As Long
    Get
    Set
public:
property long long MirrorBytesSkipped {
    long long get ();
    void set (long long value);
}
member MirrorBytesSkipped : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.MirrorBytesTransmitted Property

CoreConnectionDetailsModelMirrorBytesTransmitted Property
Gets or sets the number of mirror bytes transmitted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long MirrorBytesTransmitted { get; set; }
Public Property MirrorBytesTransmitted As Long
    Get
    Set
public:
property long long MirrorBytesTransmitted {
    long long get ();
    void set (long long value);
}
member MirrorBytesTransmitted : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.MirrorEndTime Property

CoreConnectionDetailsModelMirrorEndTime Property
Gets or sets the MirrorEndTime of the source.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset MirrorEndTime { get; set; }
Public Property MirrorEndTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset MirrorEndTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member MirrorEndTime : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.MirrorOpsQueued Property

CoreConnectionDetailsModelMirrorOpsQueued Property
Gets or sets the number of mirror ops queued.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long MirrorOpsQueued { get; set; }
Public Property MirrorOpsQueued As Long
    Get
    Set
public:
property long long MirrorOpsQueued {
    long long get ();
    void set (long long value);
}
member MirrorOpsQueued : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.MirrorPermillage Property

CoreConnectionDetailsModelMirrorPermillage Property
Gets or sets the mirror permillage.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public short MirrorPermillage { get; set; }
Public Property MirrorPermillage As Short
    Get
    Set
public:
property short MirrorPermillage {
    short get ();
    void set (short value);
}
member MirrorPermillage : int16 with get, set

Property Value

Type: Int16
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.MirrorStartTime Property

CoreConnectionDetailsModelMirrorStartTime Property
Gets or sets the MirrorStartTime of the source.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset MirrorStartTime { get; set; }
Public Property MirrorStartTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset MirrorStartTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member MirrorStartTime : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.MirrorState Property

CoreConnectionDetailsModelMirrorState Property
Gets or sets the operational state of the mirror.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public MirrorState MirrorState { get; set; }
Public Property MirrorState As MirrorState
    Get
    Set
public:
property MirrorState MirrorState {
    MirrorState get ();
    void set (MirrorState value);
}
member MirrorState : MirrorState with get, set

Property Value

Type: MirrorState
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.Name Property

CoreConnectionDetailsModelName Property
Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.PeerMemoryLow Property

CoreConnectionDetailsModelPeerMemoryLow Property
Gets or sets a value indicating whether or not the peer's memory is low.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool PeerMemoryLow { get; set; }
Public Property PeerMemoryLow As Boolean
    Get
    Set
public:
property bool PeerMemoryLow {
    bool get ();
    void set (bool value);
}
member PeerMemoryLow : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.ReplicationBytesQueued Property

CoreConnectionDetailsModelReplicationBytesQueued Property
Gets or sets the replication bytes queued on the source.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long ReplicationBytesQueued { get; set; }
Public Property ReplicationBytesQueued As Long
    Get
    Set
public:
property long long ReplicationBytesQueued {
    long long get ();
    void set (long long value);
}
member ReplicationBytesQueued : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.ReplicationBytesSent Property

CoreConnectionDetailsModelReplicationBytesSent Property
Gets or sets the number of replication bytes sent.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long ReplicationBytesSent { get; set; }
Public Property ReplicationBytesSent As Long
    Get
    Set
public:
property long long ReplicationBytesSent {
    long long get ();
    void set (long long value);
}
member ReplicationBytesSent : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.ReplicationBytesTransmitted Property

CoreConnectionDetailsModelReplicationBytesTransmitted Property
Gets or sets the number of replication bytes transmitted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long ReplicationBytesTransmitted { get; set; }
Public Property ReplicationBytesTransmitted As Long
    Get
    Set
public:
property long long ReplicationBytesTransmitted {
    long long get ();
    void set (long long value);
}
member ReplicationBytesTransmitted : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.ReplicationOpsQueued Property

CoreConnectionDetailsModelReplicationOpsQueued Property
Gets or sets the number of replication ops queued.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long ReplicationOpsQueued { get; set; }
Public Property ReplicationOpsQueued As Long
    Get
    Set
public:
property long long ReplicationOpsQueued {
    long long get ();
    void set (long long value);
}
member ReplicationOpsQueued : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.ReplicationSetCalcInProgress Property

CoreConnectionDetailsModelReplicationSetCalcInProgress Property
Gets or sets a value indicating whether the engine's parallel repset calculation feature will start a mirror while the size of the repset is being determined.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool ReplicationSetCalcInProgress { get; set; }
Public Property ReplicationSetCalcInProgress As Boolean
    Get
    Set
public:
property bool ReplicationSetCalcInProgress {
    bool get ();
    void set (bool value);
}
member ReplicationSetCalcInProgress : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.ReplicationState Property

CoreConnectionDetailsModelReplicationState Property
Gets or sets the operational state of replication.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ReplicationState ReplicationState { get; set; }
Public Property ReplicationState As ReplicationState
    Get
    Set
public:
property ReplicationState ReplicationState {
    ReplicationState get ();
    void set (ReplicationState value);
}
member ReplicationState : ReplicationState with get, set

Property Value

Type: ReplicationState
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.Restoring Property

CoreConnectionDetailsModelRestoring Property
Gets or sets a value indicating whether the connection is restoring.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool Restoring { get; set; }
Public Property Restoring As Boolean
    Get
    Set
public:
property bool Restoring {
    bool get ();
    void set (bool value);
}
member Restoring : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.SourceAccessLevel Property

CoreConnectionDetailsModelSourceAccessLevel Property
Gets or sets the source access level.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<AccessLevel> SourceAccessLevel { get; set; }
Public Property SourceAccessLevel As Nullable(Of AccessLevel)
    Get
    Set
public:
property Nullable<AccessLevel> SourceAccessLevel {
    Nullable<AccessLevel> get ();
    void set (Nullable<AccessLevel> value);
}
member SourceAccessLevel : Nullable<AccessLevel> with get, set

Property Value

Type: Nullable AccessLevel
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.SourceAvailable Property

CoreConnectionDetailsModelSourceAvailable Property
Gets or sets a value indicating whether or not the source server of this connection is available for communication from the server that owns the job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool SourceAvailable { get; set; }
Public Property SourceAvailable As Boolean
    Get
    Set
public:
property bool SourceAvailable {
    bool get ();
    void set (bool value);
}
member SourceAvailable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.SourceClusterResourceState Property

CoreConnectionDetailsModelSourceClusterResourceState Property
Gets or sets the state of the source cluster resource.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ClusterResourceState SourceClusterResourceState { get; set; }
Public Property SourceClusterResourceState As ClusterResourceState
    Get
    Set
public:
property ClusterResourceState SourceClusterResourceState {
    ClusterResourceState get ();
    void set (ClusterResourceState value);
}
member SourceClusterResourceState : ClusterResourceState with get, set

Property Value

Type: ClusterResourceState
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.SourceEndpoint Property

CoreConnectionDetailsModelSourceEndpoint Property
Gets or sets the endpoint on the source server that is the route from the target server back to the source server of the connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceEndpoint { get; set; }
Public Property SourceEndpoint As String
    Get
    Set
public:
property String^ SourceEndpoint {
    String^ get ();
    void set (String^ value);
}
member SourceEndpoint : string with get, set

Property Value

Type: String
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.SourceEngineAvailable Property

CoreConnectionDetailsModelSourceEngineAvailable Property
Gets or sets a value indicating whether or not source engine is available.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool SourceEngineAvailable { get; set; }
Public Property SourceEngineAvailable As Boolean
    Get
    Set
public:
property bool SourceEngineAvailable {
    bool get ();
    void set (bool value);
}
member SourceEngineAvailable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.SourceMachineName Property

CoreConnectionDetailsModelSourceMachineName Property
Gets or sets the name of the source server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceMachineName { get; set; }
Public Property SourceMachineName As String
    Get
    Set
public:
property String^ SourceMachineName {
    String^ get ();
    void set (String^ value);
}
member SourceMachineName : string with get, set

Property Value

Type: String
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.SourceRecoveryPointLatency Property

CoreConnectionDetailsModelSourceRecoveryPointLatency Property
Gets or sets the RecoveryPointLatency of the source.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long SourceRecoveryPointLatency { get; set; }
Public Property SourceRecoveryPointLatency As Long
    Get
    Set
public:
property long long SourceRecoveryPointLatency {
    long long get ();
    void set (long long value);
}
member SourceRecoveryPointLatency : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.SourceRecoveryPointTime Property

CoreConnectionDetailsModelSourceRecoveryPointTime Property
Gets or sets the RecoveryPointTime of the source.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset SourceRecoveryPointTime { get; set; }
Public Property SourceRecoveryPointTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset SourceRecoveryPointTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member SourceRecoveryPointTime : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.SourceUniqueId Property

CoreConnectionDetailsModelSourceUniqueId Property
Gets or sets the unique identifier of the source server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceUniqueId { get; set; }
Public Property SourceUniqueId As String
    Get
    Set
public:
property String^ SourceUniqueId {
    String^ get ();
    void set (String^ value);
}
member SourceUniqueId : string with get, set

Property Value

Type: String
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.StartTime Property

CoreConnectionDetailsModelStartTime Property
Gets or sets the time the connection was started.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset StartTime { get; set; }
Public Property StartTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset StartTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member StartTime : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TargetAccessLevel Property

CoreConnectionDetailsModelTargetAccessLevel Property
Gets or sets the target access level.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<AccessLevel> TargetAccessLevel { get; set; }
Public Property TargetAccessLevel As Nullable(Of AccessLevel)
    Get
    Set
public:
property Nullable<AccessLevel> TargetAccessLevel {
    Nullable<AccessLevel> get ();
    void set (Nullable<AccessLevel> value);
}
member TargetAccessLevel : Nullable<AccessLevel> with get, set

Property Value

Type: Nullable AccessLevel
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TargetAvailable Property

CoreConnectionDetailsModelTargetAvailable Property
Gets or sets a value indicating whether or not the target server of this connection is available for communication from the server that owns the job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool TargetAvailable { get; set; }
Public Property TargetAvailable As Boolean
    Get
    Set
public:
property bool TargetAvailable {
    bool get ();
    void set (bool value);
}
member TargetAvailable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TargetEngineAvailable Property

CoreConnectionDetailsModelTargetEngineAvailable Property
Gets or sets a value indicating whether target engine is available.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool TargetEngineAvailable { get; set; }
Public Property TargetEngineAvailable As Boolean
    Get
    Set
public:
property bool TargetEngineAvailable {
    bool get ();
    void set (bool value);
}
member TargetEngineAvailable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TargetLoaded Property

CoreConnectionDetailsModelTargetLoaded Property
Gets or sets a value indicating whether the target module is loaded on the target of the connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool TargetLoaded { get; set; }
Public Property TargetLoaded As Boolean
    Get
    Set
public:
property bool TargetLoaded {
    bool get ();
    void set (bool value);
}
member TargetLoaded : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TargetMachineName Property

CoreConnectionDetailsModelTargetMachineName Property
Gets or sets the name of the target server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetMachineName { get; set; }
Public Property TargetMachineName As String
    Get
    Set
public:
property String^ TargetMachineName {
    String^ get ();
    void set (String^ value);
}
member TargetMachineName : string with get, set

Property Value

Type: String
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TargetQueueBytes Property

CoreConnectionDetailsModelTargetQueueBytes Property
Gets or sets the number of bytes in the target queue.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long TargetQueueBytes { get; set; }
Public Property TargetQueueBytes As Long
    Get
    Set
public:
property long long TargetQueueBytes {
    long long get ();
    void set (long long value);
}
member TargetQueueBytes : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TargetRoute Property

CoreConnectionDetailsModelTargetRoute Property
Gets or sets the endpoint on the target server that is the route the source server is using for this connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetRoute { get; set; }
Public Property TargetRoute As String
    Get
    Set
public:
property String^ TargetRoute {
    String^ get ();
    void set (String^ value);
}
member TargetRoute : string with get, set

Property Value

Type: String
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TargetState Property

CoreConnectionDetailsModelTargetState Property
Gets or sets the known operational states of the connection target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TargetStates TargetState { get; set; }
Public Property TargetState As TargetStates
    Get
    Set
public:
property TargetStates TargetState {
    TargetStates get ();
    void set (TargetStates value);
}
member TargetState : TargetStates with get, set

Property Value

Type: TargetStates
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TargetUniqueId Property

CoreConnectionDetailsModelTargetUniqueId Property
Gets or sets the unique identifier of the target server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetUniqueId { get; set; }
Public Property TargetUniqueId As String
    Get
    Set
public:
property String^ TargetUniqueId {
    String^ get ();
    void set (String^ value);
}
member TargetUniqueId : string with get, set

Property Value

Type: String
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TotalBytesSent Property

CoreConnectionDetailsModelTotalBytesSent Property
Gets or sets the total bytes sent.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long TotalBytesSent { get; set; }
Public Property TotalBytesSent As Long
    Get
    Set
public:
property long long TotalBytesSent {
    long long get ();
    void set (long long value);
}
member TotalBytesSent : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TotalBytesTransmitted Property

CoreConnectionDetailsModelTotalBytesTransmitted Property
Gets or sets the total number of bytes transmitted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long TotalBytesTransmitted { get; set; }
Public Property TotalBytesTransmitted As Long
    Get
    Set
public:
property long long TotalBytesTransmitted {
    long long get ();
    void set (long long value);
}
member TotalBytesTransmitted : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TotalOpsQueued Property

CoreConnectionDetailsModelTotalOpsQueued Property
Gets or sets the total number of ops queued.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long TotalOpsQueued { get; set; }
Public Property TotalOpsQueued As Long
    Get
    Set
public:
property long long TotalOpsQueued {
    long long get ();
    void set (long long value);
}
member TotalOpsQueued : int64 with get, set

Property Value

Type: Int64
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel.TransmissionMode Property

CoreConnectionDetailsModelTransmissionMode Property
Gets or sets the operational state of replication and mirroring.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TransmissionMode TransmissionMode { get; set; }
Public Property TransmissionMode As TransmissionMode
    Get
    Set
public:
property TransmissionMode TransmissionMode {
    TransmissionMode get ();
    void set (TransmissionMode value);
}
member TransmissionMode : TransmissionMode with get, set

Property Value

Type: TransmissionMode
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionDetailsModel Methods

CoreConnectionDetailsModel Methods

The CoreConnectionDetailsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CoreConnectionDetailsModel Class


CoreConnectionOptionsModel Class

CoreConnectionOptionsModel Class
Core connection options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCoreConnectionOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class CoreConnectionOptionsModel
Public NotInheritable Class CoreConnectionOptionsModel
public ref class CoreConnectionOptionsModel sealed
[<SealedAttribute>]
type CoreConnectionOptionsModel =  class end

The CoreConnectionOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | CoreConnectionOptionsModel | Initializes a new instance of the CoreConnectionOptionsModel class
Top
Properties
 | Name | Description
Public property | ConnectionStartParameters | Gets or sets the parameters used to start the connection between the source and target servers.
Public property | PathTransformations | Gets or sets the path transformations.
Public property | TargetAddress | Gets or sets the target address.
Public property | TargetEnginePort | Gets or sets the engine port on the target server.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CoreConnectionOptionsModel Constructor

CoreConnectionOptionsModel Constructor
Initializes a new instance of the CoreConnectionOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionOptionsModel()
Public Sub New
public:
CoreConnectionOptionsModel()
new : unit -> CoreConnectionOptionsModel
See Also

Reference

CoreConnectionOptionsModel Class


CoreConnectionOptionsModel Properties

CoreConnectionOptionsModel Properties

The CoreConnectionOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionStartParameters | Gets or sets the parameters used to start the connection between the source and target servers.
Public property | PathTransformations | Gets or sets the path transformations.
Public property | TargetAddress | Gets or sets the target address.
Public property | TargetEnginePort | Gets or sets the engine port on the target server.
Top
See Also

Reference

CoreConnectionOptionsModel Class


CoreConnectionOptionsModel.ConnectionStartParameters Property

CoreConnectionOptionsModelConnectionStartParameters Property
Gets or sets the parameters used to start the connection between the source and target servers.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ConnectionStartParametersModel ConnectionStartParameters { get; set; }
Public Property ConnectionStartParameters As ConnectionStartParametersModel
    Get
    Set
public:
property ConnectionStartParametersModel^ ConnectionStartParameters {
    ConnectionStartParametersModel^ get ();
    void set (ConnectionStartParametersModel^ value);
}
member ConnectionStartParameters : ConnectionStartParametersModel with get, set

Property Value

Type: ConnectionStartParametersModel
See Also

Reference

CoreConnectionOptionsModel Class


CoreConnectionOptionsModel.PathTransformations Property

CoreConnectionOptionsModelPathTransformations Property
Gets or sets the path transformations.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public PathTransformationModel[] PathTransformations { get; set; }
Public Property PathTransformations As PathTransformationModel()
    Get
    Set
public:
property array<PathTransformationModel^>^ PathTransformations {
    array<PathTransformationModel^>^ get ();
    void set (array<PathTransformationModel^>^ value);
}
member PathTransformations : PathTransformationModel[] with get, set

Property Value

Type: PathTransformationModel
See Also

Reference

CoreConnectionOptionsModel Class


CoreConnectionOptionsModel.TargetAddress Property

CoreConnectionOptionsModelTargetAddress Property
Gets or sets the target address.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetAddress { get; set; }
Public Property TargetAddress As String
    Get
    Set
public:
property String^ TargetAddress {
    String^ get ();
    void set (String^ value);
}
member TargetAddress : string with get, set

Property Value

Type: String
See Also

Reference

CoreConnectionOptionsModel Class


CoreConnectionOptionsModel.TargetEnginePort Property

CoreConnectionOptionsModelTargetEnginePort Property
Gets or sets the engine port on the target server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int TargetEnginePort { get; set; }
Public Property TargetEnginePort As Integer
    Get
    Set
public:
property int TargetEnginePort {
    int get ();
    void set (int value);
}
member TargetEnginePort : int with get, set

Property Value

Type: Int32
See Also

Reference

CoreConnectionOptionsModel Class


CoreConnectionOptionsModel Methods

CoreConnectionOptionsModel Methods

The CoreConnectionOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CoreConnectionOptionsModel Class


CoreConnectionPersistedStateModel Class

CoreConnectionPersistedStateModel Class
The core connection persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCoreConnectionPersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class CoreConnectionPersistedStateModel
Public NotInheritable Class CoreConnectionPersistedStateModel
public ref class CoreConnectionPersistedStateModel sealed
[<SealedAttribute>]
type CoreConnectionPersistedStateModel =  class end

The CoreConnectionPersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | CoreConnectionPersistedStateModel | Initializes a new instance of the CoreConnectionPersistedStateModel class
Top
Properties
 | Name | Description
Public property | EngineConnectionId | Gets or sets the engine connection id.
Public property | Id | Gets or sets the core connection guid
Public property | InitialMirrorComplete | Gets or sets a value indicating whether the initial mirror is complete
Public property | SourceAddress | Gets or sets the source address.
Public property | SourceEnginePort | Gets or sets the source engine port.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CoreConnectionPersistedStateModel Constructor

CoreConnectionPersistedStateModel Constructor
Initializes a new instance of the CoreConnectionPersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionPersistedStateModel()
Public Sub New
public:
CoreConnectionPersistedStateModel()
new : unit -> CoreConnectionPersistedStateModel
See Also

Reference

CoreConnectionPersistedStateModel Class


CoreConnectionPersistedStateModel Properties

CoreConnectionPersistedStateModel Properties

The CoreConnectionPersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | EngineConnectionId | Gets or sets the engine connection id.
Public property | Id | Gets or sets the core connection guid
Public property | InitialMirrorComplete | Gets or sets a value indicating whether the initial mirror is complete
Public property | SourceAddress | Gets or sets the source address.
Public property | SourceEnginePort | Gets or sets the source engine port.
Top
See Also

Reference

CoreConnectionPersistedStateModel Class


CoreConnectionPersistedStateModel.EngineConnectionId Property

CoreConnectionPersistedStateModelEngineConnectionId Property
Gets or sets the engine connection id.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int EngineConnectionId { get; set; }
Public Property EngineConnectionId As Integer
    Get
    Set
public:
property int EngineConnectionId {
    int get ();
    void set (int value);
}
member EngineConnectionId : int with get, set

Property Value

Type: Int32
The engine connection id.
See Also

Reference

CoreConnectionPersistedStateModel Class


CoreConnectionPersistedStateModel.Id Property

CoreConnectionPersistedStateModelId Property
Gets or sets the core connection guid

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
member Id : Guid with get, set

Property Value

Type: Guid
See Also

Reference

CoreConnectionPersistedStateModel Class


CoreConnectionPersistedStateModel.InitialMirrorComplete Property

CoreConnectionPersistedStateModelInitialMirrorComplete Property
Gets or sets a value indicating whether the initial mirror is complete

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool InitialMirrorComplete { get; set; }
Public Property InitialMirrorComplete As Boolean
    Get
    Set
public:
property bool InitialMirrorComplete {
    bool get ();
    void set (bool value);
}
member InitialMirrorComplete : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreConnectionPersistedStateModel Class


CoreConnectionPersistedStateModel.SourceAddress Property

CoreConnectionPersistedStateModelSourceAddress Property
Gets or sets the source address.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SourceAddress { get; set; }
Public Property SourceAddress As String
    Get
    Set
public:
property String^ SourceAddress {
    String^ get ();
    void set (String^ value);
}
member SourceAddress : string with get, set

Property Value

Type: String
The source address.
See Also

Reference

CoreConnectionPersistedStateModel Class


CoreConnectionPersistedStateModel.SourceEnginePort Property

CoreConnectionPersistedStateModelSourceEnginePort Property
Gets or sets the source engine port.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int SourceEnginePort { get; set; }
Public Property SourceEnginePort As Integer
    Get
    Set
public:
property int SourceEnginePort {
    int get ();
    void set (int value);
}
member SourceEnginePort : int with get, set

Property Value

Type: Int32
The source engine port.
See Also

Reference

CoreConnectionPersistedStateModel Class


CoreConnectionPersistedStateModel Methods

CoreConnectionPersistedStateModel Methods

The CoreConnectionPersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CoreConnectionPersistedStateModel Class


CoreMonitorDetailsModel Class

CoreMonitorDetailsModel Class
Core monitor details model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCoreMonitorDetailsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class CoreMonitorDetailsModel
Public NotInheritable Class CoreMonitorDetailsModel
public ref class CoreMonitorDetailsModel sealed
[<SealedAttribute>]
type CoreMonitorDetailsModel =  class end

The CoreMonitorDetailsModel type exposes the following members.

Constructors
 | Name | Description
Public method | CoreMonitorDetailsModel | Initializes a new instance of the CoreMonitorDetailsModel class
Top
Properties
 | Name | Description
Public property | HighAvailabilityState | Gets or sets the high availability state.
Public property | MonitoredAddressStatuses | Gets or sets the status of the monitored addresses.
Public property | MonitorId | Gets or sets the unique identifier of the monitor.
Public property | MonitorName | Gets or sets the name of the monitor.
Public property | RestoreStates | Gets or sets the state of the restore operation (if any) on this monitor.
Public property | TargetAvailable | Gets or sets a value indicating whether or not the target machine, from which the details are obtained, is available.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CoreMonitorDetailsModel Constructor

CoreMonitorDetailsModel Constructor
Initializes a new instance of the CoreMonitorDetailsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CoreMonitorDetailsModel()
Public Sub New
public:
CoreMonitorDetailsModel()
new : unit -> CoreMonitorDetailsModel
See Also

Reference

CoreMonitorDetailsModel Class


CoreMonitorDetailsModel Properties

CoreMonitorDetailsModel Properties

The CoreMonitorDetailsModel type exposes the following members.

Properties
 | Name | Description
Public property | HighAvailabilityState | Gets or sets the high availability state.
Public property | MonitoredAddressStatuses | Gets or sets the status of the monitored addresses.
Public property | MonitorId | Gets or sets the unique identifier of the monitor.
Public property | MonitorName | Gets or sets the name of the monitor.
Public property | RestoreStates | Gets or sets the state of the restore operation (if any) on this monitor.
Public property | TargetAvailable | Gets or sets a value indicating whether or not the target machine, from which the details are obtained, is available.
Top
See Also

Reference

CoreMonitorDetailsModel Class


CoreMonitorDetailsModel.HighAvailabilityState Property

CoreMonitorDetailsModelHighAvailabilityState Property
Gets or sets the high availability state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public HighAvailabilityState HighAvailabilityState { get; set; }
Public Property HighAvailabilityState As HighAvailabilityState
    Get
    Set
public:
property HighAvailabilityState HighAvailabilityState {
    HighAvailabilityState get ();
    void set (HighAvailabilityState value);
}
member HighAvailabilityState : HighAvailabilityState with get, set

Property Value

Type: HighAvailabilityState
See Also

Reference

CoreMonitorDetailsModel Class


CoreMonitorDetailsModel.MonitoredAddressStatuses Property

CoreMonitorDetailsModelMonitoredAddressStatuses Property
Gets or sets the status of the monitored addresses.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public MonitoredAddressStatusModel[] MonitoredAddressStatuses { get; set; }
Public Property MonitoredAddressStatuses As MonitoredAddressStatusModel()
    Get
    Set
public:
property array<MonitoredAddressStatusModel^>^ MonitoredAddressStatuses {
    array<MonitoredAddressStatusModel^>^ get ();
    void set (array<MonitoredAddressStatusModel^>^ value);
}
member MonitoredAddressStatuses : MonitoredAddressStatusModel[] with get, set

Property Value

Type: MonitoredAddressStatusModel
See Also

Reference

CoreMonitorDetailsModel Class


CoreMonitorDetailsModel.MonitorId Property

CoreMonitorDetailsModelMonitorId Property
Gets or sets the unique identifier of the monitor.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Guid MonitorId { get; set; }
Public Property MonitorId As Guid
    Get
    Set
public:
property Guid MonitorId {
    Guid get ();
    void set (Guid value);
}
member MonitorId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

CoreMonitorDetailsModel Class


CoreMonitorDetailsModel.MonitorName Property

CoreMonitorDetailsModelMonitorName Property
Gets or sets the name of the monitor.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string MonitorName { get; set; }
Public Property MonitorName As String
    Get
    Set
public:
property String^ MonitorName {
    String^ get ();
    void set (String^ value);
}
member MonitorName : string with get, set

Property Value

Type: String
See Also

Reference

CoreMonitorDetailsModel Class


CoreMonitorDetailsModel.RestoreStates Property

CoreMonitorDetailsModelRestoreStates Property
Gets or sets the state of the restore operation (if any) on this monitor.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public RestoreStates RestoreStates { get; set; }
Public Property RestoreStates As RestoreStates
    Get
    Set
public:
property RestoreStates RestoreStates {
    RestoreStates get ();
    void set (RestoreStates value);
}
member RestoreStates : RestoreStates with get, set

Property Value

Type: RestoreStates
See Also

Reference

CoreMonitorDetailsModel Class


CoreMonitorDetailsModel.TargetAvailable Property

CoreMonitorDetailsModelTargetAvailable Property
Gets or sets a value indicating whether or not the target machine, from which the details are obtained, is available.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool TargetAvailable { get; set; }
Public Property TargetAvailable As Boolean
    Get
    Set
public:
property bool TargetAvailable {
    bool get ();
    void set (bool value);
}
member TargetAvailable : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreMonitorDetailsModel Class


CoreMonitorDetailsModel Methods

CoreMonitorDetailsModel Methods

The CoreMonitorDetailsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CoreMonitorDetailsModel Class


CoreMonitorOptionsModel Class

CoreMonitorOptionsModel Class
Core monitor options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCoreMonitorOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class CoreMonitorOptionsModel
Public NotInheritable Class CoreMonitorOptionsModel
public ref class CoreMonitorOptionsModel sealed
[<SealedAttribute>]
type CoreMonitorOptionsModel =  class end

The CoreMonitorOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | CoreMonitorOptionsModel | Initializes a new instance of the CoreMonitorOptionsModel class
Top
Properties
 | Name | Description
Public property | MonitorConfiguration | Gets or sets the monitor configuration.
Public property | ShouldPerformLanFailover | Gets or sets a value indicating whether or not LAN (identity) failover should be performed versus WAN (none or DNS) failover.
Public property | SourceDomain | Gets or sets the source domain.
Public property | SourceServer | Gets or sets the source server.
Public property | TargetDomain | Gets or sets the target domain.
Public property | TargetServer | Gets or sets the target server.
Public property | TotalTimeAllowed | Gets or sets the total time allowed without a successful ping before a failover condition is met.
Public property | UseTotalTimeAllowed | Gets or sets a value indicating whether or not to use the totalTimeAllowed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CoreMonitorOptionsModel Constructor

CoreMonitorOptionsModel Constructor
Initializes a new instance of the CoreMonitorOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CoreMonitorOptionsModel()
Public Sub New
public:
CoreMonitorOptionsModel()
new : unit -> CoreMonitorOptionsModel
See Also

Reference

CoreMonitorOptionsModel Class


CoreMonitorOptionsModel Properties

CoreMonitorOptionsModel Properties

The CoreMonitorOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | MonitorConfiguration | Gets or sets the monitor configuration.
Public property | ShouldPerformLanFailover | Gets or sets a value indicating whether or not LAN (identity) failover should be performed versus WAN (none or DNS) failover.
Public property | SourceDomain | Gets or sets the source domain.
Public property | SourceServer | Gets or sets the source server.
Public property | TargetDomain | Gets or sets the target domain.
Public property | TargetServer | Gets or sets the target server.
Public property | TotalTimeAllowed | Gets or sets the total time allowed without a successful ping before a failover condition is met.
Public property | UseTotalTimeAllowed | Gets or sets a value indicating whether or not to use the totalTimeAllowed.
Top
See Also

Reference

CoreMonitorOptionsModel Class


CoreMonitorOptionsModel.MonitorConfiguration Property

CoreMonitorOptionsModelMonitorConfiguration Property
Gets or sets the monitor configuration.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public MonitorConfigurationModel MonitorConfiguration { get; set; }
Public Property MonitorConfiguration As MonitorConfigurationModel
    Get
    Set
public:
property MonitorConfigurationModel^ MonitorConfiguration {
    MonitorConfigurationModel^ get ();
    void set (MonitorConfigurationModel^ value);
}
member MonitorConfiguration : MonitorConfigurationModel with get, set

Property Value

Type: MonitorConfigurationModel
See Also

Reference

CoreMonitorOptionsModel Class


CoreMonitorOptionsModel.ShouldPerformLanFailover Property

CoreMonitorOptionsModelShouldPerformLanFailover Property
Gets or sets a value indicating whether or not LAN (identity) failover should be performed versus WAN (none or DNS) failover.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> ShouldPerformLanFailover { get; set; }
Public Property ShouldPerformLanFailover As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> ShouldPerformLanFailover {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member ShouldPerformLanFailover : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

CoreMonitorOptionsModel Class


CoreMonitorOptionsModel.SourceDomain Property

CoreMonitorOptionsModelSourceDomain Property
Gets or sets the source domain.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceDomain { get; set; }
Public Property SourceDomain As String
    Get
    Set
public:
property String^ SourceDomain {
    String^ get ();
    void set (String^ value);
}
member SourceDomain : string with get, set

Property Value

Type: String
See Also

Reference

CoreMonitorOptionsModel Class


CoreMonitorOptionsModel.SourceServer Property

CoreMonitorOptionsModelSourceServer Property
Gets or sets the source server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceServer { get; set; }
Public Property SourceServer As String
    Get
    Set
public:
property String^ SourceServer {
    String^ get ();
    void set (String^ value);
}
member SourceServer : string with get, set

Property Value

Type: String
See Also

Reference

CoreMonitorOptionsModel Class


CoreMonitorOptionsModel.TargetDomain Property

CoreMonitorOptionsModelTargetDomain Property
Gets or sets the target domain.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetDomain { get; set; }
Public Property TargetDomain As String
    Get
    Set
public:
property String^ TargetDomain {
    String^ get ();
    void set (String^ value);
}
member TargetDomain : string with get, set

Property Value

Type: String
See Also

Reference

CoreMonitorOptionsModel Class


CoreMonitorOptionsModel.TargetServer Property

CoreMonitorOptionsModelTargetServer Property
Gets or sets the target server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetServer { get; set; }
Public Property TargetServer As String
    Get
    Set
public:
property String^ TargetServer {
    String^ get ();
    void set (String^ value);
}
member TargetServer : string with get, set

Property Value

Type: String
See Also

Reference

CoreMonitorOptionsModel Class


CoreMonitorOptionsModel.TotalTimeAllowed Property

CoreMonitorOptionsModelTotalTimeAllowed Property
Gets or sets the total time allowed without a successful ping before a failover condition is met.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan TotalTimeAllowed { get; set; }
Public Property TotalTimeAllowed As TimeSpan
    Get
    Set
public:
property TimeSpan TotalTimeAllowed {
    TimeSpan get ();
    void set (TimeSpan value);
}
member TotalTimeAllowed : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

CoreMonitorOptionsModel Class


CoreMonitorOptionsModel.UseTotalTimeAllowed Property

CoreMonitorOptionsModelUseTotalTimeAllowed Property
Gets or sets a value indicating whether or not to use the totalTimeAllowed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseTotalTimeAllowed { get; set; }
Public Property UseTotalTimeAllowed As Boolean
    Get
    Set
public:
property bool UseTotalTimeAllowed {
    bool get ();
    void set (bool value);
}
member UseTotalTimeAllowed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

CoreMonitorOptionsModel Class


CoreMonitorOptionsModel Methods

CoreMonitorOptionsModel Methods

The CoreMonitorOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CoreMonitorOptionsModel Class


CoreQualificationResultsModel Class

CoreQualificationResultsModel Class
Core qualification results model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCoreQualificationResultsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class CoreQualificationResultsModel
Public NotInheritable Class CoreQualificationResultsModel
public ref class CoreQualificationResultsModel sealed
[<SealedAttribute>]
type CoreQualificationResultsModel =  class end

The CoreQualificationResultsModel type exposes the following members.

Constructors
 | Name | Description
Public method | CoreQualificationResultsModel | Initializes a new instance of the CoreQualificationResultsModel class
Top
Properties
 | Name | Description
Public property | CompressionLevels | Gets or sets the compression levels.
Public property | DefaultAllToOneBasePath | Gets or sets the default base path to use for getting the recommended all-to-one path transformations.
Public property | SourceAddresses | Gets or sets the source machine's available IP addresses.
Public property | SourceEnginePort | Gets or sets the source engine port.
Public property | SourceMachineName | Gets or sets the name of the source machine.
Public property | SourceNetworkId | Gets or sets the source network id used to communicate with the source from the target.
Public property | SourceNetworkInterfaces | Gets or sets the source network interfaces.
Public property | SourceProductInfo | Gets or sets the source product info.
Public property | SourceVolumes | Gets or sets the source volumes.
Public property | TargetAddresses | Gets or sets the target machine's available IP addresses.
Public property | TargetEnginePort | Gets or sets the target engine port.
Public property | TargetMachineName | Gets or sets the name of the target machine.
Public property | TargetNetworkInterfaces | Gets or sets the target network interfaces.
Public property | TargetProductInfo | Gets or sets the target product info.
Public property | TargetVolumes | Gets or sets the target volumes.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CoreQualificationResultsModel Constructor

CoreQualificationResultsModel Constructor
Initializes a new instance of the CoreQualificationResultsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CoreQualificationResultsModel()
Public Sub New
public:
CoreQualificationResultsModel()
new : unit -> CoreQualificationResultsModel
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel Properties

CoreQualificationResultsModel Properties

The CoreQualificationResultsModel type exposes the following members.

Properties
 | Name | Description
Public property | CompressionLevels | Gets or sets the compression levels.
Public property | DefaultAllToOneBasePath | Gets or sets the default base path to use for getting the recommended all-to-one path transformations.
Public property | SourceAddresses | Gets or sets the source machine's available IP addresses.
Public property | SourceEnginePort | Gets or sets the source engine port.
Public property | SourceMachineName | Gets or sets the name of the source machine.
Public property | SourceNetworkId | Gets or sets the source network id used to communicate with the source from the target.
Public property | SourceNetworkInterfaces | Gets or sets the source network interfaces.
Public property | SourceProductInfo | Gets or sets the source product info.
Public property | SourceVolumes | Gets or sets the source volumes.
Public property | TargetAddresses | Gets or sets the target machine's available IP addresses.
Public property | TargetEnginePort | Gets or sets the target engine port.
Public property | TargetMachineName | Gets or sets the name of the target machine.
Public property | TargetNetworkInterfaces | Gets or sets the target network interfaces.
Public property | TargetProductInfo | Gets or sets the target product info.
Public property | TargetVolumes | Gets or sets the target volumes.
Top
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.CompressionLevels Property

CoreQualificationResultsModelCompressionLevels Property
Gets or sets the compression levels.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CompressionLevelModel[] CompressionLevels { get; set; }
Public Property CompressionLevels As CompressionLevelModel()
    Get
    Set
public:
property array<CompressionLevelModel^>^ CompressionLevels {
    array<CompressionLevelModel^>^ get ();
    void set (array<CompressionLevelModel^>^ value);
}
member CompressionLevels : CompressionLevelModel[] with get, set

Property Value

Type: CompressionLevelModel
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.DefaultAllToOneBasePath Property

CoreQualificationResultsModelDefaultAllToOneBasePath Property
Gets or sets the default base path to use for getting the recommended all-to-one path transformations.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string DefaultAllToOneBasePath { get; set; }
Public Property DefaultAllToOneBasePath As String
    Get
    Set
public:
property String^ DefaultAllToOneBasePath {
    String^ get ();
    void set (String^ value);
}
member DefaultAllToOneBasePath : string with get, set

Property Value

Type: String
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.SourceAddresses Property

CoreQualificationResultsModelSourceAddresses Property
Gets or sets the source machine's available IP addresses.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public UnicastNetworkAddressInfoModel[] SourceAddresses { get; set; }
Public Property SourceAddresses As UnicastNetworkAddressInfoModel()
    Get
    Set
public:
property array<UnicastNetworkAddressInfoModel^>^ SourceAddresses {
    array<UnicastNetworkAddressInfoModel^>^ get ();
    void set (array<UnicastNetworkAddressInfoModel^>^ value);
}
member SourceAddresses : UnicastNetworkAddressInfoModel[] with get, set

Property Value

Type: UnicastNetworkAddressInfoModel
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.SourceEnginePort Property

CoreQualificationResultsModelSourceEnginePort Property
Gets or sets the source engine port.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int SourceEnginePort { get; set; }
Public Property SourceEnginePort As Integer
    Get
    Set
public:
property int SourceEnginePort {
    int get ();
    void set (int value);
}
member SourceEnginePort : int with get, set

Property Value

Type: Int32
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.SourceMachineName Property

CoreQualificationResultsModelSourceMachineName Property
Gets or sets the name of the source machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceMachineName { get; set; }
Public Property SourceMachineName As String
    Get
    Set
public:
property String^ SourceMachineName {
    String^ get ();
    void set (String^ value);
}
member SourceMachineName : string with get, set

Property Value

Type: String
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.SourceNetworkId Property

CoreQualificationResultsModelSourceNetworkId Property
Gets or sets the source network id used to communicate with the source from the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceNetworkId { get; set; }
Public Property SourceNetworkId As String
    Get
    Set
public:
property String^ SourceNetworkId {
    String^ get ();
    void set (String^ value);
}
member SourceNetworkId : string with get, set

Property Value

Type: String
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.SourceNetworkInterfaces Property

CoreQualificationResultsModelSourceNetworkInterfaces Property
Gets or sets the source network interfaces.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public NetworkInterfaceInfoModel[] SourceNetworkInterfaces { get; set; }
Public Property SourceNetworkInterfaces As NetworkInterfaceInfoModel()
    Get
    Set
public:
property array<NetworkInterfaceInfoModel^>^ SourceNetworkInterfaces {
    array<NetworkInterfaceInfoModel^>^ get ();
    void set (array<NetworkInterfaceInfoModel^>^ value);
}
member SourceNetworkInterfaces : NetworkInterfaceInfoModel[] with get, set

Property Value

Type: NetworkInterfaceInfoModel
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.SourceProductInfo Property

CoreQualificationResultsModelSourceProductInfo Property
Gets or sets the source product info.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ProductInfoModel SourceProductInfo { get; set; }
Public Property SourceProductInfo As ProductInfoModel
    Get
    Set
public:
property ProductInfoModel^ SourceProductInfo {
    ProductInfoModel^ get ();
    void set (ProductInfoModel^ value);
}
member SourceProductInfo : ProductInfoModel with get, set

Property Value

Type: ProductInfoModel
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.SourceVolumes Property

CoreQualificationResultsModelSourceVolumes Property
Gets or sets the source volumes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VolumeModel[] SourceVolumes { get; set; }
Public Property SourceVolumes As VolumeModel()
    Get
    Set
public:
property array<VolumeModel^>^ SourceVolumes {
    array<VolumeModel^>^ get ();
    void set (array<VolumeModel^>^ value);
}
member SourceVolumes : VolumeModel[] with get, set

Property Value

Type: VolumeModel
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.TargetAddresses Property

CoreQualificationResultsModelTargetAddresses Property
Gets or sets the target machine's available IP addresses.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public UnicastNetworkAddressInfoModel[] TargetAddresses { get; set; }
Public Property TargetAddresses As UnicastNetworkAddressInfoModel()
    Get
    Set
public:
property array<UnicastNetworkAddressInfoModel^>^ TargetAddresses {
    array<UnicastNetworkAddressInfoModel^>^ get ();
    void set (array<UnicastNetworkAddressInfoModel^>^ value);
}
member TargetAddresses : UnicastNetworkAddressInfoModel[] with get, set

Property Value

Type: UnicastNetworkAddressInfoModel
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.TargetEnginePort Property

CoreQualificationResultsModelTargetEnginePort Property
Gets or sets the target engine port.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int TargetEnginePort { get; set; }
Public Property TargetEnginePort As Integer
    Get
    Set
public:
property int TargetEnginePort {
    int get ();
    void set (int value);
}
member TargetEnginePort : int with get, set

Property Value

Type: Int32
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.TargetMachineName Property

CoreQualificationResultsModelTargetMachineName Property
Gets or sets the name of the target machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetMachineName { get; set; }
Public Property TargetMachineName As String
    Get
    Set
public:
property String^ TargetMachineName {
    String^ get ();
    void set (String^ value);
}
member TargetMachineName : string with get, set

Property Value

Type: String
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.TargetNetworkInterfaces Property

CoreQualificationResultsModelTargetNetworkInterfaces Property
Gets or sets the target network interfaces.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public NetworkInterfaceInfoModel[] TargetNetworkInterfaces { get; set; }
Public Property TargetNetworkInterfaces As NetworkInterfaceInfoModel()
    Get
    Set
public:
property array<NetworkInterfaceInfoModel^>^ TargetNetworkInterfaces {
    array<NetworkInterfaceInfoModel^>^ get ();
    void set (array<NetworkInterfaceInfoModel^>^ value);
}
member TargetNetworkInterfaces : NetworkInterfaceInfoModel[] with get, set

Property Value

Type: NetworkInterfaceInfoModel
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.TargetProductInfo Property

CoreQualificationResultsModelTargetProductInfo Property
Gets or sets the target product info.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ProductInfoModel TargetProductInfo { get; set; }
Public Property TargetProductInfo As ProductInfoModel
    Get
    Set
public:
property ProductInfoModel^ TargetProductInfo {
    ProductInfoModel^ get ();
    void set (ProductInfoModel^ value);
}
member TargetProductInfo : ProductInfoModel with get, set

Property Value

Type: ProductInfoModel
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel.TargetVolumes Property

CoreQualificationResultsModelTargetVolumes Property
Gets or sets the target volumes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VolumeModel[] TargetVolumes { get; set; }
Public Property TargetVolumes As VolumeModel()
    Get
    Set
public:
property array<VolumeModel^>^ TargetVolumes {
    array<VolumeModel^>^ get ();
    void set (array<VolumeModel^>^ value);
}
member TargetVolumes : VolumeModel[] with get, set

Property Value

Type: VolumeModel
See Also

Reference

CoreQualificationResultsModel Class


CoreQualificationResultsModel Methods

CoreQualificationResultsModel Methods

The CoreQualificationResultsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CoreQualificationResultsModel Class


CreateConnectionModel Class

CreateConnectionModel Class
This class represents the parameters passed into the api/connections/create call
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCreateConnectionModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class CreateConnectionModel
Public NotInheritable Class CreateConnectionModel
public ref class CreateConnectionModel sealed
[<SealedAttribute>]
type CreateConnectionModel =  class end

The CreateConnectionModel type exposes the following members.

Constructors
 | Name | Description
Public method | CreateConnectionModel | Initializes a new instance of the CreateConnectionModel class
Top
Properties
 | Name | Description
Public property | ConnectionParameters | Gets or sets the connection parameters.
Public property | ConnectionStartParameters | Gets or sets the connection start parameters.
Public property | Rules | Gets or sets the rules.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CreateConnectionModel Constructor

CreateConnectionModel Constructor
Initializes a new instance of the CreateConnectionModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CreateConnectionModel()
Public Sub New
public:
CreateConnectionModel()
new : unit -> CreateConnectionModel
See Also

Reference

CreateConnectionModel Class


CreateConnectionModel Properties

CreateConnectionModel Properties

The CreateConnectionModel type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionParameters | Gets or sets the connection parameters.
Public property | ConnectionStartParameters | Gets or sets the connection start parameters.
Public property | Rules | Gets or sets the rules.
Top
See Also

Reference

CreateConnectionModel Class


CreateConnectionModel.ConnectionParameters Property

CreateConnectionModelConnectionParameters Property
Gets or sets the connection parameters.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ConnectionParametersModel ConnectionParameters { get; set; }
Public Property ConnectionParameters As ConnectionParametersModel
    Get
    Set
public:
property ConnectionParametersModel^ ConnectionParameters {
    ConnectionParametersModel^ get ();
    void set (ConnectionParametersModel^ value);
}
member ConnectionParameters : ConnectionParametersModel with get, set

Property Value

Type: ConnectionParametersModel
The connection parameters.
See Also

Reference

CreateConnectionModel Class


CreateConnectionModel.ConnectionStartParameters Property

CreateConnectionModelConnectionStartParameters Property
Gets or sets the connection start parameters.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ConnectionStartParametersModel ConnectionStartParameters { get; set; }
Public Property ConnectionStartParameters As ConnectionStartParametersModel
    Get
    Set
public:
property ConnectionStartParametersModel^ ConnectionStartParameters {
    ConnectionStartParametersModel^ get ();
    void set (ConnectionStartParametersModel^ value);
}
member ConnectionStartParameters : ConnectionStartParametersModel with get, set

Property Value

Type: ConnectionStartParametersModel
The connection start parameters.
See Also

Reference

CreateConnectionModel Class


CreateConnectionModel.Rules Property

CreateConnectionModelRules Property
Gets or sets the rules.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public PhysicalRuleModel[] Rules { get; set; }
Public Property Rules As PhysicalRuleModel()
    Get
    Set
public:
property array<PhysicalRuleModel^>^ Rules {
    array<PhysicalRuleModel^>^ get ();
    void set (array<PhysicalRuleModel^>^ value);
}
member Rules : PhysicalRuleModel[] with get, set

Property Value

Type: PhysicalRuleModel
The rules.
Remarks
This field is only used for creating connections on clustered servers.
See Also

Reference

CreateConnectionModel Class


CreateConnectionModel Methods

CreateConnectionModel Methods

The CreateConnectionModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreateConnectionModel Class


CreateDelegateWorkloadModel Class

CreateDelegateWorkloadModel Class
Parameters used in the CreateFromWithDelegation call
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCreateDelegateWorkloadModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class CreateDelegateWorkloadModel
Public NotInheritable Class CreateDelegateWorkloadModel
public ref class CreateDelegateWorkloadModel sealed
[<SealedAttribute>]
type CreateDelegateWorkloadModel =  class end

The CreateDelegateWorkloadModel type exposes the following members.

Constructors
 | Name | Description
Public method | CreateDelegateWorkloadModel | Initializes a new instance of the CreateDelegateWorkloadModel class
Top
Properties
 | Name | Description
Public property | Host | Gets or sets the host.
Public property | Workload | Gets or sets the workload.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CreateDelegateWorkloadModel Constructor

CreateDelegateWorkloadModel Constructor
Initializes a new instance of the CreateDelegateWorkloadModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CreateDelegateWorkloadModel()
Public Sub New
public:
CreateDelegateWorkloadModel()
new : unit -> CreateDelegateWorkloadModel
See Also

Reference

CreateDelegateWorkloadModel Class


CreateDelegateWorkloadModel Properties

CreateDelegateWorkloadModel Properties

The CreateDelegateWorkloadModel type exposes the following members.

Properties
 | Name | Description
Public property | Host | Gets or sets the host.
Public property | Workload | Gets or sets the workload.
Top
See Also

Reference

CreateDelegateWorkloadModel Class


CreateDelegateWorkloadModel.Host Property

CreateDelegateWorkloadModelHost Property
Gets or sets the host.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Uri Host { get; set; }
Public Property Host As Uri
    Get
    Set
public:
property Uri^ Host {
    Uri^ get ();
    void set (Uri^ value);
}
member Host : Uri with get, set

Property Value

Type: Uri
The host.
See Also

Reference

CreateDelegateWorkloadModel Class


CreateDelegateWorkloadModel.Workload Property

CreateDelegateWorkloadModelWorkload Property
Gets or sets the workload.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public WorkloadModel Workload { get; set; }
Public Property Workload As WorkloadModel
    Get
    Set
public:
property WorkloadModel^ Workload {
    WorkloadModel^ get ();
    void set (WorkloadModel^ value);
}
member Workload : WorkloadModel with get, set

Property Value

Type: WorkloadModel
The workload.
See Also

Reference

CreateDelegateWorkloadModel Class


CreateDelegateWorkloadModel Methods

CreateDelegateWorkloadModel Methods

The CreateDelegateWorkloadModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreateDelegateWorkloadModel Class


CreateFromExistingJobModel Class

CreateFromExistingJobModel Class
Contains the information needed to create a new job from and existing job.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCreateFromExistingJobModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class CreateFromExistingJobModel
Public NotInheritable Class CreateFromExistingJobModel
public ref class CreateFromExistingJobModel sealed
[<SealedAttribute>]
type CreateFromExistingJobModel =  class end

The CreateFromExistingJobModel type exposes the following members.

Constructors
 | Name | Description
Public method | CreateFromExistingJobModel | Initializes a new instance of the CreateFromExistingJobModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials.
Public property | JobInfo | Gets or sets the job information.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CreateFromExistingJobModel Constructor

CreateFromExistingJobModel Constructor
Initializes a new instance of the CreateFromExistingJobModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CreateFromExistingJobModel()
Public Sub New
public:
CreateFromExistingJobModel()
new : unit -> CreateFromExistingJobModel
See Also

Reference

CreateFromExistingJobModel Class


CreateFromExistingJobModel Properties

CreateFromExistingJobModel Properties

The CreateFromExistingJobModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials.
Public property | JobInfo | Gets or sets the job information.
Top
See Also

Reference

CreateFromExistingJobModel Class


CreateFromExistingJobModel.Credentials Property

CreateFromExistingJobModelCredentials Property
Gets or sets the credentials.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public JobCredentialsModel Credentials { get; set; }
Public Property Credentials As JobCredentialsModel
    Get
    Set
public:
property JobCredentialsModel^ Credentials {
    JobCredentialsModel^ get ();
    void set (JobCredentialsModel^ value);
}
member Credentials : JobCredentialsModel with get, set

Property Value

Type: JobCredentialsModel
The credentials.
See Also

Reference

CreateFromExistingJobModel Class


CreateFromExistingJobModel.JobInfo Property

CreateFromExistingJobModelJobInfo Property
Gets or sets the job information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public JobInfoPrivateModel JobInfo { get; set; }
Public Property JobInfo As JobInfoPrivateModel
    Get
    Set
public:
property JobInfoPrivateModel^ JobInfo {
    JobInfoPrivateModel^ get ();
    void set (JobInfoPrivateModel^ value);
}
member JobInfo : JobInfoPrivateModel with get, set

Property Value

Type: JobInfoPrivateModel
The job information.
See Also

Reference

CreateFromExistingJobModel Class


CreateFromExistingJobModel Methods

CreateFromExistingJobModel Methods

The CreateFromExistingJobModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreateFromExistingJobModel Class


CreateOptionsModel Class

CreateOptionsModel Class
Create options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCreateOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class CreateOptionsModel
Public NotInheritable Class CreateOptionsModel
public ref class CreateOptionsModel sealed
[<SealedAttribute>]
type CreateOptionsModel =  class end

The CreateOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | CreateOptionsModel | Initializes a new instance of the CreateOptionsModel class
Top
Properties
 | Name | Description
Public property | JobCredentials | Gets or sets the job credentials.
Public property | JobOptions | Gets or sets the job options.
Public property | JobType | Gets or sets the type of the job.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CreateOptionsModel Constructor

CreateOptionsModel Constructor
Initializes a new instance of the CreateOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CreateOptionsModel()
Public Sub New
public:
CreateOptionsModel()
new : unit -> CreateOptionsModel
See Also

Reference

CreateOptionsModel Class


CreateOptionsModel Properties

CreateOptionsModel Properties

The CreateOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | JobCredentials | Gets or sets the job credentials.
Public property | JobOptions | Gets or sets the job options.
Public property | JobType | Gets or sets the type of the job.
Top
See Also

Reference

CreateOptionsModel Class


CreateOptionsModel.JobCredentials Property

CreateOptionsModelJobCredentials Property
Gets or sets the job credentials.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public JobCredentialsModel JobCredentials { get; set; }
Public Property JobCredentials As JobCredentialsModel
    Get
    Set
public:
property JobCredentialsModel^ JobCredentials {
    JobCredentialsModel^ get ();
    void set (JobCredentialsModel^ value);
}
member JobCredentials : JobCredentialsModel with get, set

Property Value

Type: JobCredentialsModel
See Also

Reference

CreateOptionsModel Class


CreateOptionsModel.JobOptions Property

CreateOptionsModelJobOptions Property
Gets or sets the job options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public JobOptionsModel JobOptions { get; set; }
Public Property JobOptions As JobOptionsModel
    Get
    Set
public:
property JobOptionsModel^ JobOptions {
    JobOptionsModel^ get ();
    void set (JobOptionsModel^ value);
}
member JobOptions : JobOptionsModel with get, set

Property Value

Type: JobOptionsModel
See Also

Reference

CreateOptionsModel Class


CreateOptionsModel.JobType Property

CreateOptionsModelJobType Property
Gets or sets the type of the job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string JobType { get; set; }
Public Property JobType As String
    Get
    Set
public:
property String^ JobType {
    String^ get ();
    void set (String^ value);
}
member JobType : string with get, set

Property Value

Type: String
See Also

Reference

CreateOptionsModel Class


CreateOptionsModel Methods

CreateOptionsModel Methods

The CreateOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreateOptionsModel Class


CreateRepsetRequestModel Class

CreateRepsetRequestModel Class
Create repset request.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCreateRepsetRequestModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class CreateRepsetRequestModel
Public NotInheritable Class CreateRepsetRequestModel
public ref class CreateRepsetRequestModel sealed
[<SealedAttribute>]
type CreateRepsetRequestModel =  class end

The CreateRepsetRequestModel type exposes the following members.

Constructors
 | Name | Description
Public method | CreateRepsetRequestModel | Initializes a new instance of the CreateRepsetRequestModel class
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name.
Public property | PhysicalRules | Gets or sets the physical rules.
Public property | UsageType | Gets or sets the type of the usage.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CreateRepsetRequestModel Constructor

CreateRepsetRequestModel Constructor
Initializes a new instance of the CreateRepsetRequestModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CreateRepsetRequestModel()
Public Sub New
public:
CreateRepsetRequestModel()
new : unit -> CreateRepsetRequestModel
See Also

Reference

CreateRepsetRequestModel Class


CreateRepsetRequestModel Properties

CreateRepsetRequestModel Properties

The CreateRepsetRequestModel type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name.
Public property | PhysicalRules | Gets or sets the physical rules.
Public property | UsageType | Gets or sets the type of the usage.
Top
See Also

Reference

CreateRepsetRequestModel Class


CreateRepsetRequestModel.Name Property

CreateRepsetRequestModelName Property
Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

CreateRepsetRequestModel Class


CreateRepsetRequestModel.PhysicalRules Property

CreateRepsetRequestModelPhysicalRules Property
Gets or sets the physical rules.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public PhysicalRuleModel[] PhysicalRules { get; set; }
Public Property PhysicalRules As PhysicalRuleModel()
    Get
    Set
public:
property array<PhysicalRuleModel^>^ PhysicalRules {
    array<PhysicalRuleModel^>^ get ();
    void set (array<PhysicalRuleModel^>^ value);
}
member PhysicalRules : PhysicalRuleModel[] with get, set

Property Value

Type: PhysicalRuleModel
The physical rules.
See Also

Reference

CreateRepsetRequestModel Class


CreateRepsetRequestModel.UsageType Property

CreateRepsetRequestModelUsageType Property
Gets or sets the type of the usage.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ReplicationSetUsageType UsageType { get; set; }
Public Property UsageType As ReplicationSetUsageType
    Get
    Set
public:
property ReplicationSetUsageType UsageType {
    ReplicationSetUsageType get ();
    void set (ReplicationSetUsageType value);
}
member UsageType : ReplicationSetUsageType with get, set

Property Value

Type: ReplicationSetUsageType
The type of the usage.
See Also

Reference

CreateRepsetRequestModel Class


CreateRepsetRequestModel Methods

CreateRepsetRequestModel Methods

The CreateRepsetRequestModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CreateRepsetRequestModel Class


CredentialModel Class

CredentialModel Class
Credential model
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCredentialModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class CredentialModel
Public NotInheritable Class CredentialModel
public ref class CredentialModel sealed
[<SealedAttribute>]
type CredentialModel =  class end

The CredentialModel type exposes the following members.

Constructors
 | Name | Description
Public method | CredentialModel | Initializes a new instance of the CredentialModel class
Top
Properties
 | Name | Description
Public property | Domain | Gets or sets the domain.
Public property | Password | Gets or sets the password.
Public property | UserName | Gets or sets the user name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CredentialModel Constructor

CredentialModel Constructor
Initializes a new instance of the CredentialModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CredentialModel()
Public Sub New
public:
CredentialModel()
new : unit -> CredentialModel
See Also

Reference

CredentialModel Class


CredentialModel Properties

CredentialModel Properties

The CredentialModel type exposes the following members.

Properties
 | Name | Description
Public property | Domain | Gets or sets the domain.
Public property | Password | Gets or sets the password.
Public property | UserName | Gets or sets the user name.
Top
See Also

Reference

CredentialModel Class


CredentialModel.Domain Property

CredentialModelDomain Property
Gets or sets the domain.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Domain { get; set; }
Public Property Domain As String
    Get
    Set
public:
property String^ Domain {
    String^ get ();
    void set (String^ value);
}
member Domain : string with get, set

Property Value

Type: String
See Also

Reference

CredentialModel Class


CredentialModel.Password Property

CredentialModelPassword Property
Gets or sets the password.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
member Password : string with get, set

Property Value

Type: String
See Also

Reference

CredentialModel Class


CredentialModel.UserName Property

CredentialModelUserName Property
Gets or sets the user name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
member UserName : string with get, set

Property Value

Type: String
See Also

Reference

CredentialModel Class


CredentialModel Methods

CredentialModel Methods

The CredentialModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CredentialModel Class


CutoverDetailsModel Class

CutoverDetailsModel Class
Cut over details model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsCutoverDetailsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class CutoverDetailsModel
Public NotInheritable Class CutoverDetailsModel
public ref class CutoverDetailsModel sealed
[<SealedAttribute>]
type CutoverDetailsModel =  class end

The CutoverDetailsModel type exposes the following members.

Constructors
 | Name | Description
Public method | CutoverDetailsModel | Initializes a new instance of the CutoverDetailsModel class
Top
Properties
 | Name | Description
Public property | PercentComplete | Gets or sets the percentage complete of the cut over operation.
Public property | State | Gets or sets the state of the cut over operation.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


CutoverDetailsModel Constructor

CutoverDetailsModel Constructor
Initializes a new instance of the CutoverDetailsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CutoverDetailsModel()
Public Sub New
public:
CutoverDetailsModel()
new : unit -> CutoverDetailsModel
See Also

Reference

CutoverDetailsModel Class


CutoverDetailsModel Properties

CutoverDetailsModel Properties

The CutoverDetailsModel type exposes the following members.

Properties
 | Name | Description
Public property | PercentComplete | Gets or sets the percentage complete of the cut over operation.
Public property | State | Gets or sets the state of the cut over operation.
Top
See Also

Reference

CutoverDetailsModel Class


CutoverDetailsModel.PercentComplete Property

CutoverDetailsModelPercentComplete Property
Gets or sets the percentage complete of the cut over operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int PercentComplete { get; set; }
Public Property PercentComplete As Integer
    Get
    Set
public:
property int PercentComplete {
    int get ();
    void set (int value);
}
member PercentComplete : int with get, set

Property Value

Type: Int32
See Also

Reference

CutoverDetailsModel Class


CutoverDetailsModel.State Property

CutoverDetailsModelState Property
Gets or sets the state of the cut over operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int State { get; set; }
Public Property State As Integer
    Get
    Set
public:
property int State {
    int get ();
    void set (int value);
}
member State : int with get, set

Property Value

Type: Int32
See Also

Reference

CutoverDetailsModel Class


CutoverDetailsModel Methods

CutoverDetailsModel Methods

The CutoverDetailsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CutoverDetailsModel Class


DeleteJobRequestModel Class

DeleteJobRequestModel Class
Delete job request model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDeleteJobRequestModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class DeleteJobRequestModel
Public NotInheritable Class DeleteJobRequestModel
public ref class DeleteJobRequestModel sealed
[<SealedAttribute>]
type DeleteJobRequestModel =  class end

The DeleteJobRequestModel type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteJobRequestModel | Initializes a new instance of the DeleteJobRequestModel class
Top
Properties
 | Name | Description
Public property | DeleteReplica | Gets or sets a value indicating whether or not to delete the replica virtual machine.
Public property | DiscardTargetQueue | Gets or sets a value indicating whether or not to discard any replication or mirror operations in the target queue.
Public property | ImageOptions | Gets or sets the option for what to do with the image when the job is deleted.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DeleteJobRequestModel Constructor

DeleteJobRequestModel Constructor
Initializes a new instance of the DeleteJobRequestModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DeleteJobRequestModel()
Public Sub New
public:
DeleteJobRequestModel()
new : unit -> DeleteJobRequestModel
See Also

Reference

DeleteJobRequestModel Class


DeleteJobRequestModel Properties

DeleteJobRequestModel Properties

The DeleteJobRequestModel type exposes the following members.

Properties
 | Name | Description
Public property | DeleteReplica | Gets or sets a value indicating whether or not to delete the replica virtual machine.
Public property | DiscardTargetQueue | Gets or sets a value indicating whether or not to discard any replication or mirror operations in the target queue.
Public property | ImageOptions | Gets or sets the option for what to do with the image when the job is deleted.
Top
See Also

Reference

DeleteJobRequestModel Class


DeleteJobRequestModel.DeleteReplica Property

DeleteJobRequestModelDeleteReplica Property
Gets or sets a value indicating whether or not to delete the replica virtual machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool DeleteReplica { get; set; }
Public Property DeleteReplica As Boolean
    Get
    Set
public:
property bool DeleteReplica {
    bool get ();
    void set (bool value);
}
member DeleteReplica : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DeleteJobRequestModel Class


DeleteJobRequestModel.DiscardTargetQueue Property

DeleteJobRequestModelDiscardTargetQueue Property
Gets or sets a value indicating whether or not to discard any replication or mirror operations in the target queue.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool DiscardTargetQueue { get; set; }
Public Property DiscardTargetQueue As Boolean
    Get
    Set
public:
property bool DiscardTargetQueue {
    bool get ();
    void set (bool value);
}
member DiscardTargetQueue : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DeleteJobRequestModel Class


DeleteJobRequestModel.ImageOptions Property

DeleteJobRequestModelImageOptions Property
Gets or sets the option for what to do with the image when the job is deleted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ImageDeleteInfoModel ImageOptions { get; set; }
Public Property ImageOptions As ImageDeleteInfoModel
    Get
    Set
public:
property ImageDeleteInfoModel^ ImageOptions {
    ImageDeleteInfoModel^ get ();
    void set (ImageDeleteInfoModel^ value);
}
member ImageOptions : ImageDeleteInfoModel with get, set

Property Value

Type: ImageDeleteInfoModel
See Also

Reference

DeleteJobRequestModel Class


DeleteJobRequestModel Methods

DeleteJobRequestModel Methods

The DeleteJobRequestModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeleteJobRequestModel Class


DeleteOptionsModel Class

DeleteOptionsModel Class
Delete options.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDeleteOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class DeleteOptionsModel
Public NotInheritable Class DeleteOptionsModel
public ref class DeleteOptionsModel sealed
[<SealedAttribute>]
type DeleteOptionsModel =  class end

The DeleteOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | DeleteOptionsModel | Initializes a new instance of the DeleteOptionsModel class
Top
Properties
 | Name | Description
Public property | DeleteOnClusterResourceOffline | Gets or sets a value indicating whether the job is deleted because the target cluster resource went offline.
Public property | DeleteReplica | Gets or sets a value indicating whether the replica virtual machine should be deleted when the job is deleted.
Public property | DiscardTargetQueue | Gets or sets a value indicating whether any operations in the target queue should be deleted when the job is deleted.
Public property | ImageOptions | Gets or sets the option for what to do with the image when the job is deleted.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DeleteOptionsModel Constructor

DeleteOptionsModel Constructor
Initializes a new instance of the DeleteOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DeleteOptionsModel()
Public Sub New
public:
DeleteOptionsModel()
new : unit -> DeleteOptionsModel
See Also

Reference

DeleteOptionsModel Class


DeleteOptionsModel Properties

DeleteOptionsModel Properties

The DeleteOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | DeleteOnClusterResourceOffline | Gets or sets a value indicating whether the job is deleted because the target cluster resource went offline.
Public property | DeleteReplica | Gets or sets a value indicating whether the replica virtual machine should be deleted when the job is deleted.
Public property | DiscardTargetQueue | Gets or sets a value indicating whether any operations in the target queue should be deleted when the job is deleted.
Public property | ImageOptions | Gets or sets the option for what to do with the image when the job is deleted.
Top
See Also

Reference

DeleteOptionsModel Class


DeleteOptionsModel.DeleteOnClusterResourceOffline Property

DeleteOptionsModelDeleteOnClusterResourceOffline Property
Gets or sets a value indicating whether the job is deleted because the target cluster resource went offline.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool DeleteOnClusterResourceOffline { get; set; }
Public Property DeleteOnClusterResourceOffline As Boolean
    Get
    Set
public:
property bool DeleteOnClusterResourceOffline {
    bool get ();
    void set (bool value);
}
member DeleteOnClusterResourceOffline : bool with get, set

Property Value

Type: Boolean
true if delete is caused by target cluster resource going offline; otherwise, false.
See Also

Reference

DeleteOptionsModel Class


DeleteOptionsModel.DeleteReplica Property

DeleteOptionsModelDeleteReplica Property
Gets or sets a value indicating whether the replica virtual machine should be deleted when the job is deleted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool DeleteReplica { get; set; }
Public Property DeleteReplica As Boolean
    Get
    Set
public:
property bool DeleteReplica {
    bool get ();
    void set (bool value);
}
member DeleteReplica : bool with get, set

Property Value

Type: Boolean
if the replica virtual machine should be deleted; otherwise, .
See Also

Reference

DeleteOptionsModel Class


DeleteOptionsModel.DiscardTargetQueue Property

DeleteOptionsModelDiscardTargetQueue Property
Gets or sets a value indicating whether any operations in the target queue should be deleted when the job is deleted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool DiscardTargetQueue { get; set; }
Public Property DiscardTargetQueue As Boolean
    Get
    Set
public:
property bool DiscardTargetQueue {
    bool get ();
    void set (bool value);
}
member DiscardTargetQueue : bool with get, set

Property Value

Type: Boolean
to discard the target queue; otherwise, .
See Also

Reference

DeleteOptionsModel Class


DeleteOptionsModel.ImageOptions Property

DeleteOptionsModelImageOptions Property
Gets or sets the option for what to do with the image when the job is deleted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ImageDeleteInfoModel ImageOptions { get; set; }
Public Property ImageOptions As ImageDeleteInfoModel
    Get
    Set
public:
property ImageDeleteInfoModel^ ImageOptions {
    ImageDeleteInfoModel^ get ();
    void set (ImageDeleteInfoModel^ value);
}
member ImageOptions : ImageDeleteInfoModel with get, set

Property Value

Type: ImageDeleteInfoModel
See Also

Reference

DeleteOptionsModel Class


DeleteOptionsModel Methods

DeleteOptionsModel Methods

The DeleteOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DeleteOptionsModel Class


DesktopInteractionMode Enumeration

DesktopInteractionMode Enumeration
Desktop interaction mode.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum DesktopInteractionMode
Public Enumeration DesktopInteractionMode
public enum class DesktopInteractionMode
type DesktopInteractionMode
Members
Member name | Value | Description
None | 0 | The none
Interact | 1 | The interact
See Also

Reference

DoubleTake.Web.Models Namespace


DiagnosticsPersistedStateModel Class

DiagnosticsPersistedStateModel Class
Diagnostics persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDiagnosticsPersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class DiagnosticsPersistedStateModel
Public NotInheritable Class DiagnosticsPersistedStateModel
public ref class DiagnosticsPersistedStateModel sealed
[<SealedAttribute>]
type DiagnosticsPersistedStateModel =  class end

The DiagnosticsPersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | DiagnosticsPersistedStateModel | Initializes a new instance of the DiagnosticsPersistedStateModel class
Top
Properties
 | Name | Description
Public property | DiagnosticsConnectionPersistedState | Gets or sets the state of the diagnostics connection.
Public property | State | Gets or sets the state.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DiagnosticsPersistedStateModel Constructor

DiagnosticsPersistedStateModel Constructor
Initializes a new instance of the DiagnosticsPersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DiagnosticsPersistedStateModel()
Public Sub New
public:
DiagnosticsPersistedStateModel()
new : unit -> DiagnosticsPersistedStateModel
See Also

Reference

DiagnosticsPersistedStateModel Class


DiagnosticsPersistedStateModel Properties

DiagnosticsPersistedStateModel Properties

The DiagnosticsPersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | DiagnosticsConnectionPersistedState | Gets or sets the state of the diagnostics connection.
Public property | State | Gets or sets the state.
Top
See Also

Reference

DiagnosticsPersistedStateModel Class


DiagnosticsPersistedStateModel.DiagnosticsConnectionPersistedState Property

DiagnosticsPersistedStateModelDiagnosticsConnectionPersistedState Property
Gets or sets the state of the diagnostics connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionPersistedStateModel DiagnosticsConnectionPersistedState { get; set; }
Public Property DiagnosticsConnectionPersistedState As CoreConnectionPersistedStateModel
    Get
    Set
public:
property CoreConnectionPersistedStateModel^ DiagnosticsConnectionPersistedState {
    CoreConnectionPersistedStateModel^ get ();
    void set (CoreConnectionPersistedStateModel^ value);
}
member DiagnosticsConnectionPersistedState : CoreConnectionPersistedStateModel with get, set

Property Value

Type: CoreConnectionPersistedStateModel
The state of the diagnostics connection.
See Also

Reference

DiagnosticsPersistedStateModel Class


DiagnosticsPersistedStateModel.State Property

DiagnosticsPersistedStateModelState Property
Gets or sets the state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string State { get; set; }
Public Property State As String
    Get
    Set
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}
member State : string with get, set

Property Value

Type: String
The state.
See Also

Reference

DiagnosticsPersistedStateModel Class


DiagnosticsPersistedStateModel Methods

DiagnosticsPersistedStateModel Methods

The DiagnosticsPersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DiagnosticsPersistedStateModel Class


DirectoryItemModel Class

DirectoryItemModel Class
Directory item model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsProtectableItemModel
DoubleTake.Web.ModelsPhysicalItemModel
DoubleTake.Web.ModelsDirectoryItemModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public class DirectoryItemModel : PhysicalItemModel
Public Class DirectoryItemModel
    Inherits PhysicalItemModel
public ref class DirectoryItemModel : public PhysicalItemModel
type DirectoryItemModel =
    class
        inherit PhysicalItemModel
    end

The DirectoryItemModel type exposes the following members.

Constructors
 | Name | Description
Public method | DirectoryItemModel | Initializes a new instance of the DirectoryItemModel class
Top
Properties
 | Name | Description
Public property | Attributes | Gets or sets a value specifying the file system attributes of this item. (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | Gets or sets the available free space on this volume. (Inherited from PhysicalItemModel.)
Public property | ClassName | Gets or sets the class name. (Inherited from PhysicalItemModel.)
Public property | CreationTime | Gets or sets a value specifying the time this item was created. (Inherited from PhysicalItemModel.)
Public property | DriveFormat | Gets or sets the format of the drive. (Inherited from PhysicalItemModel.)
Public property | DriveType | Gets or sets the type of the drive. (Inherited from PhysicalItemModel.)
Public property | Id | Gets or sets the item identifier. (Inherited from ProtectableItemModel.)
Public property | IsContainer | Gets or sets a value indicating whether or not this item is a container of other items. (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | Gets or sets a value indicating whether or not this item is read only; that is, its Saturation cannot be changed. (Inherited from ProtectableItemModel.)
Public property | IsSupported | Gets or sets a value indicating whether this volume is supported. (Inherited from PhysicalItemModel.)
Public property | IsSystemDrive | Gets or sets a value indicating whether or not this volume is the system drive. (Inherited from PhysicalItemModel.)
Public property | ItemType | Gets or sets the type of this item. (Inherited from ProtectableItemModel.)
Public property | Label | Gets or sets the volume label. (Inherited from PhysicalItemModel.)
Public property | LastAccessTime | Gets or sets a value specifying the time this item was last accessed. (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | Gets or sets a value specifying the time this item was last written to. (Inherited from PhysicalItemModel.)
Public property | Metadata | Gets or sets a value specifying additional meta data for this item. (Inherited from PhysicalItemModel.)
Public property | Name | Gets or sets the name of this item. (Inherited from ProtectableItemModel.)
Public property | PartitionName | Gets or sets the partition name. (Inherited from ProtectableItemModel.)
Public property | Path | Gets or sets the path that uniquely identifies this item. (Inherited from ProtectableItemModel.)
Public property | Saturation | Gets or sets the saturation level of this item. (Inherited from ProtectableItemModel.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume. (Inherited from PhysicalItemModel.)
Public property | Size | Gets or sets a value indicating the physical size of the item. (Inherited from PhysicalItemModel.)
Public property | TotalSize | Gets or sets the total size of the volume. (Inherited from PhysicalItemModel.)
Public property | VolumeType | Gets or sets the volume type. (Inherited from PhysicalItemModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DirectoryItemModel Constructor

DirectoryItemModel Constructor
Initializes a new instance of the DirectoryItemModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DirectoryItemModel()
Public Sub New
public:
DirectoryItemModel()
new : unit -> DirectoryItemModel
See Also

Reference

DirectoryItemModel Class


DirectoryItemModel Properties

DirectoryItemModel Properties

The DirectoryItemModel type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets or sets a value specifying the file system attributes of this item. (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | Gets or sets the available free space on this volume. (Inherited from PhysicalItemModel.)
Public property | ClassName | Gets or sets the class name. (Inherited from PhysicalItemModel.)
Public property | CreationTime | Gets or sets a value specifying the time this item was created. (Inherited from PhysicalItemModel.)
Public property | DriveFormat | Gets or sets the format of the drive. (Inherited from PhysicalItemModel.)
Public property | DriveType | Gets or sets the type of the drive. (Inherited from PhysicalItemModel.)
Public property | Id | Gets or sets the item identifier. (Inherited from ProtectableItemModel.)
Public property | IsContainer | Gets or sets a value indicating whether or not this item is a container of other items. (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | Gets or sets a value indicating whether or not this item is read only; that is, its Saturation cannot be changed. (Inherited from ProtectableItemModel.)
Public property | IsSupported | Gets or sets a value indicating whether this volume is supported. (Inherited from PhysicalItemModel.)
Public property | IsSystemDrive | Gets or sets a value indicating whether or not this volume is the system drive. (Inherited from PhysicalItemModel.)
Public property | ItemType | Gets or sets the type of this item. (Inherited from ProtectableItemModel.)
Public property | Label | Gets or sets the volume label. (Inherited from PhysicalItemModel.)
Public property | LastAccessTime | Gets or sets a value specifying the time this item was last accessed. (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | Gets or sets a value specifying the time this item was last written to. (Inherited from PhysicalItemModel.)
Public property | Metadata | Gets or sets a value specifying additional meta data for this item. (Inherited from PhysicalItemModel.)
Public property | Name | Gets or sets the name of this item. (Inherited from ProtectableItemModel.)
Public property | PartitionName | Gets or sets the partition name. (Inherited from ProtectableItemModel.)
Public property | Path | Gets or sets the path that uniquely identifies this item. (Inherited from ProtectableItemModel.)
Public property | Saturation | Gets or sets the saturation level of this item. (Inherited from ProtectableItemModel.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume. (Inherited from PhysicalItemModel.)
Public property | Size | Gets or sets a value indicating the physical size of the item. (Inherited from PhysicalItemModel.)
Public property | TotalSize | Gets or sets the total size of the volume. (Inherited from PhysicalItemModel.)
Public property | VolumeType | Gets or sets the volume type. (Inherited from PhysicalItemModel.)
Top
See Also

Reference

DirectoryItemModel Class


DirectoryItemModel Methods

DirectoryItemModel Methods

The DirectoryItemModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DirectoryItemModel Class


DiskConfigStrategy Enumeration

DiskConfigStrategy Enumeration
Disk configuration strategy for the replica

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum DiskConfigStrategy
Public Enumeration DiskConfigStrategy
public enum class DiskConfigStrategy
type DiskConfigStrategy
Members
Member name | Value | Description
CreateDiskPerVolume | 0 | Create replica disk per volume.
MatchingSource | 1 | Create the same disk and layout with the source on the replica.
Customization | 2 | Custom the disk layout on the replica.
See Also

Reference

DoubleTake.Web.Models Namespace


DiskLayoutInitializeModel Class

DiskLayoutInitializeModel Class
Disk layout initialize.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDiskLayoutInitializeModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class DiskLayoutInitializeModel
Public NotInheritable Class DiskLayoutInitializeModel
public ref class DiskLayoutInitializeModel sealed
[<SealedAttribute>]
type DiskLayoutInitializeModel =  class end

The DiskLayoutInitializeModel type exposes the following members.

Constructors
 | Name | Description
Public method | DiskLayoutInitializeModel | Initializes a new instance of the DiskLayoutInitializeModel class
Top
Properties
 | Name | Description
Public property | BaseMountPoint | Gets or sets the base location to mount the volumes to.
Public property | DiskLayout | Gets or sets the disk layout to create and mount underneath the base mount point.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DiskLayoutInitializeModel Constructor

DiskLayoutInitializeModel Constructor
Initializes a new instance of the DiskLayoutInitializeModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DiskLayoutInitializeModel()
Public Sub New
public:
DiskLayoutInitializeModel()
new : unit -> DiskLayoutInitializeModel
See Also

Reference

DiskLayoutInitializeModel Class


DiskLayoutInitializeModel Properties

DiskLayoutInitializeModel Properties

The DiskLayoutInitializeModel type exposes the following members.

Properties
 | Name | Description
Public property | BaseMountPoint | Gets or sets the base location to mount the volumes to.
Public property | DiskLayout | Gets or sets the disk layout to create and mount underneath the base mount point.
Top
See Also

Reference

DiskLayoutInitializeModel Class


DiskLayoutInitializeModel.BaseMountPoint Property

DiskLayoutInitializeModelBaseMountPoint Property
Gets or sets the base location to mount the volumes to.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string BaseMountPoint { get; set; }
Public Property BaseMountPoint As String
    Get
    Set
public:
property String^ BaseMountPoint {
    String^ get ();
    void set (String^ value);
}
member BaseMountPoint : string with get, set

Property Value

Type: String
Remarks
Windows volumes will be converted to valid path by replacing the ':' with '_'.
See Also

Reference

DiskLayoutInitializeModel Class


DiskLayoutInitializeModel.DiskLayout Property

DiskLayoutInitializeModelDiskLayout Property
Gets or sets the disk layout to create and mount underneath the base mount point.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DiskLayoutModel[] DiskLayout { get; set; }
Public Property DiskLayout As DiskLayoutModel()
    Get
    Set
public:
property array<DiskLayoutModel^>^ DiskLayout {
    array<DiskLayoutModel^>^ get ();
    void set (array<DiskLayoutModel^>^ value);
}
member DiskLayout : DiskLayoutModel[] with get, set

Property Value

Type: DiskLayoutModel
See Also

Reference

DiskLayoutInitializeModel Class


DiskLayoutInitializeModel Methods

DiskLayoutInitializeModel Methods

The DiskLayoutInitializeModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DiskLayoutInitializeModel Class


DiskLayoutModel Class

DiskLayoutModel Class
Describes how a disk is to be partitioned and formatted. The DiskIdentifier is used to identify the disk to be partition. The Partitioning Scheme identifies if the disk is to use GPT or MBR. The array of PartitionInitializationInfo structures identifies how many partitions, what size and format they should have and other things.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDiskLayoutModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class DiskLayoutModel
Public NotInheritable Class DiskLayoutModel
public ref class DiskLayoutModel sealed
[<SealedAttribute>]
type DiskLayoutModel =  class end

The DiskLayoutModel type exposes the following members.

Constructors
 | Name | Description
Public method | DiskLayoutModel | Initializes a new instance of the DiskLayoutModel class
Top
Properties
 | Name | Description
Public property | DiskIdentifier | Gets or sets the value used to identify the disk to the appliance. This would be the disk number in Windows and something else (device name?) in Linux.
Public property | PartitioningScheme | Gets or sets a value indicating what partitioning scheme to use. Example GPT or MBR
Public property | PartitionInitializationInfos | Gets or sets a list of partition descriptions for the entire disk. The number of entries here determines how many partitions you end up with.
Public property | ShouldPartitionDisk | Gets or sets a value indicating whether we should partition the disk or not.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DiskLayoutModel Constructor

DiskLayoutModel Constructor
Initializes a new instance of the DiskLayoutModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DiskLayoutModel()
Public Sub New
public:
DiskLayoutModel()
new : unit -> DiskLayoutModel
See Also

Reference

DiskLayoutModel Class


DiskLayoutModel Properties

DiskLayoutModel Properties

The DiskLayoutModel type exposes the following members.

Properties
 | Name | Description
Public property | DiskIdentifier | Gets or sets the value used to identify the disk to the appliance. This would be the disk number in Windows and something else (device name?) in Linux.
Public property | PartitioningScheme | Gets or sets a value indicating what partitioning scheme to use. Example GPT or MBR
Public property | PartitionInitializationInfos | Gets or sets a list of partition descriptions for the entire disk. The number of entries here determines how many partitions you end up with.
Public property | ShouldPartitionDisk | Gets or sets a value indicating whether we should partition the disk or not.
Top
See Also

Reference

DiskLayoutModel Class


DiskLayoutModel.DiskIdentifier Property

DiskLayoutModelDiskIdentifier Property
Gets or sets the value used to identify the disk to the appliance. This would be the disk number in Windows and something else (device name?) in Linux.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string DiskIdentifier { get; set; }
Public Property DiskIdentifier As String
    Get
    Set
public:
property String^ DiskIdentifier {
    String^ get ();
    void set (String^ value);
}
member DiskIdentifier : string with get, set

Property Value

Type: String
See Also

Reference

DiskLayoutModel Class


DiskLayoutModel.PartitioningScheme Property

DiskLayoutModelPartitioningScheme Property
Gets or sets a value indicating what partitioning scheme to use. Example GPT or MBR

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string PartitioningScheme { get; set; }
Public Property PartitioningScheme As String
    Get
    Set
public:
property String^ PartitioningScheme {
    String^ get ();
    void set (String^ value);
}
member PartitioningScheme : string with get, set

Property Value

Type: String
See Also

Reference

DiskLayoutModel Class


DiskLayoutModel.PartitionInitializationInfos Property

DiskLayoutModelPartitionInitializationInfos Property
Gets or sets a list of partition descriptions for the entire disk. The number of entries here determines how many partitions you end up with.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DiskPartitionLayoutModel[] PartitionInitializationInfos { get; set; }
Public Property PartitionInitializationInfos As DiskPartitionLayoutModel()
    Get
    Set
public:
property array<DiskPartitionLayoutModel^>^ PartitionInitializationInfos {
    array<DiskPartitionLayoutModel^>^ get ();
    void set (array<DiskPartitionLayoutModel^>^ value);
}
member PartitionInitializationInfos : DiskPartitionLayoutModel[] with get, set

Property Value

Type: DiskPartitionLayoutModel
See Also

Reference

DiskLayoutModel Class


DiskLayoutModel.ShouldPartitionDisk Property

DiskLayoutModelShouldPartitionDisk Property
Gets or sets a value indicating whether we should partition the disk or not.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldPartitionDisk { get; set; }
Public Property ShouldPartitionDisk As Boolean
    Get
    Set
public:
property bool ShouldPartitionDisk {
    bool get ();
    void set (bool value);
}
member ShouldPartitionDisk : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DiskLayoutModel Class


DiskLayoutModel Methods

DiskLayoutModel Methods

The DiskLayoutModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DiskLayoutModel Class


DiskLayoutResultModel Class

DiskLayoutResultModel Class
Disk layout extraction result from a source system state scrape.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDiskLayoutResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class DiskLayoutResultModel
Public NotInheritable Class DiskLayoutResultModel
public ref class DiskLayoutResultModel sealed
[<SealedAttribute>]
type DiskLayoutResultModel =  class end

The DiskLayoutResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | DiskLayoutResultModel | Initializes a new instance of the DiskLayoutResultModel class.
Public method | DiskLayoutResultModel(DiskLayoutModel, Boolean, String) | Initializes a new instance of the DiskLayoutResultModel class.
Top
Properties
 | Name | Description
Public property | DiskLayout | Gets or sets the disk layout.
Public property | Messages | Gets or sets any messages for the extraction.
Public property | Success | Gets or sets a value indicating whether the extraction was successful.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DiskLayoutResultModel Constructor

DiskLayoutResultModel Constructor
Overload List
 | Name | Description
Public method | DiskLayoutResultModel | Initializes a new instance of the DiskLayoutResultModel class.
Public method | DiskLayoutResultModel(DiskLayoutModel, Boolean, String) | Initializes a new instance of the DiskLayoutResultModel class.
Top
See Also

Reference

DiskLayoutResultModel Class


DiskLayoutResultModel Constructor

DiskLayoutResultModel Constructor
Initializes a new instance of the DiskLayoutResultModel class.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DiskLayoutResultModel()
Public Sub New
public:
DiskLayoutResultModel()
new : unit -> DiskLayoutResultModel
See Also

Reference

DiskLayoutResultModel Class
DiskLayoutResultModel Overload


DiskLayoutResultModel Constructor (DiskLayoutModel[], Boolean, String)

DiskLayoutResultModel Constructor (DiskLayoutModel, Boolean, String)
Initializes a new instance of the DiskLayoutResultModel class.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DiskLayoutResultModel(
    DiskLayoutModel[] diskLayout,
    bool success,
    string messages
)
Public Sub New (
    diskLayout As DiskLayoutModel(),
    success As Boolean,
    messages As String
)
public:
DiskLayoutResultModel(
    array<DiskLayoutModel^>^ diskLayout,
    bool success,
    String^ messages
)
new :
        diskLayout : DiskLayoutModel[] *
        success : bool *
        messages : string -> DiskLayoutResultModel

Parameters

diskLayout
Type: DoubleTake.Web.ModelsDiskLayoutModel
The disk layout.
success
Type: SystemBoolean
if set to [success].
messages
Type: SystemString
The messages.
See Also

Reference

DiskLayoutResultModel Class
DiskLayoutResultModel Overload


DiskLayoutResultModel Properties

DiskLayoutResultModel Properties

The DiskLayoutResultModel type exposes the following members.

Properties
 | Name | Description
Public property | DiskLayout | Gets or sets the disk layout.
Public property | Messages | Gets or sets any messages for the extraction.
Public property | Success | Gets or sets a value indicating whether the extraction was successful.
Top
See Also

Reference

DiskLayoutResultModel Class


DiskLayoutResultModel.DiskLayout Property

DiskLayoutResultModelDiskLayout Property
Gets or sets the disk layout.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DiskLayoutModel[] DiskLayout { get; set; }
Public Property DiskLayout As DiskLayoutModel()
    Get
    Set
public:
property array<DiskLayoutModel^>^ DiskLayout {
    array<DiskLayoutModel^>^ get ();
    void set (array<DiskLayoutModel^>^ value);
}
member DiskLayout : DiskLayoutModel[] with get, set

Property Value

Type: DiskLayoutModel
See Also

Reference

DiskLayoutResultModel Class


DiskLayoutResultModel.Messages Property

DiskLayoutResultModelMessages Property
Gets or sets any messages for the extraction.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Messages { get; set; }
Public Property Messages As String
    Get
    Set
public:
property String^ Messages {
    String^ get ();
    void set (String^ value);
}
member Messages : string with get, set

Property Value

Type: String
See Also

Reference

DiskLayoutResultModel Class


DiskLayoutResultModel.Success Property

DiskLayoutResultModelSuccess Property
Gets or sets a value indicating whether the extraction was successful.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool Success { get; set; }
Public Property Success As Boolean
    Get
    Set
public:
property bool Success {
    bool get ();
    void set (bool value);
}
member Success : bool with get, set

Property Value

Type: Boolean
true if success; otherwise, false.
See Also

Reference

DiskLayoutResultModel Class


DiskLayoutResultModel Methods

DiskLayoutResultModel Methods

The DiskLayoutResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DiskLayoutResultModel Class


DiskLayoutStatusResultModel Class

DiskLayoutStatusResultModel Class
Disk layout status result.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDiskLayoutStatusResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class DiskLayoutStatusResultModel
Public NotInheritable Class DiskLayoutStatusResultModel
public ref class DiskLayoutStatusResultModel sealed
[<SealedAttribute>]
type DiskLayoutStatusResultModel =  class end

The DiskLayoutStatusResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | DiskLayoutStatusResultModel | Initializes a new instance of the DiskLayoutStatusResultModel class
Top
Properties
 | Name | Description
Public property | Completed | Gets or sets a value indicating whether this InitializeDisk() is has completed running.
Public property | Messages | Gets or sets the log.
Public property | Success | Gets or sets a value indicating whether this InitializeDisk() is a success.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DiskLayoutStatusResultModel Constructor

DiskLayoutStatusResultModel Constructor
Initializes a new instance of the DiskLayoutStatusResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DiskLayoutStatusResultModel()
Public Sub New
public:
DiskLayoutStatusResultModel()
new : unit -> DiskLayoutStatusResultModel
See Also

Reference

DiskLayoutStatusResultModel Class


DiskLayoutStatusResultModel Properties

DiskLayoutStatusResultModel Properties

The DiskLayoutStatusResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Completed | Gets or sets a value indicating whether this InitializeDisk() is has completed running.
Public property | Messages | Gets or sets the log.
Public property | Success | Gets or sets a value indicating whether this InitializeDisk() is a success.
Top
See Also

Reference

DiskLayoutStatusResultModel Class


DiskLayoutStatusResultModel.Completed Property

DiskLayoutStatusResultModelCompleted Property
Gets or sets a value indicating whether this InitializeDisk() is has completed running.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool Completed { get; set; }
Public Property Completed As Boolean
    Get
    Set
public:
property bool Completed {
    bool get ();
    void set (bool value);
}
member Completed : bool with get, set

Property Value

Type: Boolean
true if completed; otherwise, false.
See Also

Reference

DiskLayoutStatusResultModel Class


DiskLayoutStatusResultModel.Messages Property

DiskLayoutStatusResultModelMessages Property
Gets or sets the log.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Messages { get; set; }
Public Property Messages As String
    Get
    Set
public:
property String^ Messages {
    String^ get ();
    void set (String^ value);
}
member Messages : string with get, set

Property Value

Type: String
The log generated by the InitializeDisk() operation.
See Also

Reference

DiskLayoutStatusResultModel Class


DiskLayoutStatusResultModel.Success Property

DiskLayoutStatusResultModelSuccess Property
Gets or sets a value indicating whether this InitializeDisk() is a success.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool Success { get; set; }
Public Property Success As Boolean
    Get
    Set
public:
property bool Success {
    bool get ();
    void set (bool value);
}
member Success : bool with get, set

Property Value

Type: Boolean
true if success; otherwise, false.
See Also

Reference

DiskLayoutStatusResultModel Class


DiskLayoutStatusResultModel Methods

DiskLayoutStatusResultModel Methods

The DiskLayoutStatusResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DiskLayoutStatusResultModel Class


DiskLayoutVerifyResultsModel Class

DiskLayoutVerifyResultsModel Class
Results of disk layout verification.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDiskLayoutVerifyResultsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class DiskLayoutVerifyResultsModel
Public NotInheritable Class DiskLayoutVerifyResultsModel
public ref class DiskLayoutVerifyResultsModel sealed
[<SealedAttribute>]
type DiskLayoutVerifyResultsModel =  class end

The DiskLayoutVerifyResultsModel type exposes the following members.

Constructors
 | Name | Description
Public method | DiskLayoutVerifyResultsModel | Initializes a new instance of the DiskLayoutVerifyResultsModel class
Top
Properties
 | Name | Description
Public property | IsValid | Gets or sets a value indicating whether the layout is valid.
Public property | Messages | Gets or sets validation messages.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DiskLayoutVerifyResultsModel Constructor

DiskLayoutVerifyResultsModel Constructor
Initializes a new instance of the DiskLayoutVerifyResultsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DiskLayoutVerifyResultsModel()
Public Sub New
public:
DiskLayoutVerifyResultsModel()
new : unit -> DiskLayoutVerifyResultsModel
See Also

Reference

DiskLayoutVerifyResultsModel Class


DiskLayoutVerifyResultsModel Properties

DiskLayoutVerifyResultsModel Properties

The DiskLayoutVerifyResultsModel type exposes the following members.

Properties
 | Name | Description
Public property | IsValid | Gets or sets a value indicating whether the layout is valid.
Public property | Messages | Gets or sets validation messages.
Top
See Also

Reference

DiskLayoutVerifyResultsModel Class


DiskLayoutVerifyResultsModel.IsValid Property

DiskLayoutVerifyResultsModelIsValid Property
Gets or sets a value indicating whether the layout is valid.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid { get; set; }
Public Property IsValid As Boolean
    Get
    Set
public:
property bool IsValid {
    bool get ();
    void set (bool value);
}
member IsValid : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DiskLayoutVerifyResultsModel Class


DiskLayoutVerifyResultsModel.Messages Property

DiskLayoutVerifyResultsModelMessages Property
Gets or sets validation messages.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Messages { get; set; }
Public Property Messages As String
    Get
    Set
public:
property String^ Messages {
    String^ get ();
    void set (String^ value);
}
member Messages : string with get, set

Property Value

Type: String
See Also

Reference

DiskLayoutVerifyResultsModel Class


DiskLayoutVerifyResultsModel Methods

DiskLayoutVerifyResultsModel Methods

The DiskLayoutVerifyResultsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DiskLayoutVerifyResultsModel Class


DiskLayoutWithEnvironmentModel Class

DiskLayoutWithEnvironmentModel Class
Disk layout environment constraints.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDiskLayoutWithEnvironmentModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class DiskLayoutWithEnvironmentModel
Public NotInheritable Class DiskLayoutWithEnvironmentModel
public ref class DiskLayoutWithEnvironmentModel sealed
[<SealedAttribute>]
type DiskLayoutWithEnvironmentModel =  class end

The DiskLayoutWithEnvironmentModel type exposes the following members.

Constructors
 | Name | Description
Public method | DiskLayoutWithEnvironmentModel | Initializes a new instance of the DiskLayoutWithEnvironmentModel class
Top
Properties
 | Name | Description
Public property | Disks | Gets or sets the disks to setup in this environment
Public property | FirstDiskMaxSize | Gets or sets the maximum size of the first disk in megabytes.
Public property | OtherDisksMaxSize | Gets or sets the maximum size of the remaining disks in megabytes.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DiskLayoutWithEnvironmentModel Constructor

DiskLayoutWithEnvironmentModel Constructor
Initializes a new instance of the DiskLayoutWithEnvironmentModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DiskLayoutWithEnvironmentModel()
Public Sub New
public:
DiskLayoutWithEnvironmentModel()
new : unit -> DiskLayoutWithEnvironmentModel
See Also

Reference

DiskLayoutWithEnvironmentModel Class


DiskLayoutWithEnvironmentModel Properties

DiskLayoutWithEnvironmentModel Properties

The DiskLayoutWithEnvironmentModel type exposes the following members.

Properties
 | Name | Description
Public property | Disks | Gets or sets the disks to setup in this environment
Public property | FirstDiskMaxSize | Gets or sets the maximum size of the first disk in megabytes.
Public property | OtherDisksMaxSize | Gets or sets the maximum size of the remaining disks in megabytes.
Top
See Also

Reference

DiskLayoutWithEnvironmentModel Class


DiskLayoutWithEnvironmentModel.Disks Property

DiskLayoutWithEnvironmentModelDisks Property
Gets or sets the disks to setup in this environment

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DiskLayoutModel[] Disks { get; set; }
Public Property Disks As DiskLayoutModel()
    Get
    Set
public:
property array<DiskLayoutModel^>^ Disks {
    array<DiskLayoutModel^>^ get ();
    void set (array<DiskLayoutModel^>^ value);
}
member Disks : DiskLayoutModel[] with get, set

Property Value

Type: DiskLayoutModel
See Also

Reference

DiskLayoutWithEnvironmentModel Class


DiskLayoutWithEnvironmentModel.FirstDiskMaxSize Property

DiskLayoutWithEnvironmentModelFirstDiskMaxSize Property
Gets or sets the maximum size of the first disk in megabytes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int FirstDiskMaxSize { get; set; }
Public Property FirstDiskMaxSize As Integer
    Get
    Set
public:
property int FirstDiskMaxSize {
    int get ();
    void set (int value);
}
member FirstDiskMaxSize : int with get, set

Property Value

Type: Int32
See Also

Reference

DiskLayoutWithEnvironmentModel Class


DiskLayoutWithEnvironmentModel.OtherDisksMaxSize Property

DiskLayoutWithEnvironmentModelOtherDisksMaxSize Property
Gets or sets the maximum size of the remaining disks in megabytes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int OtherDisksMaxSize { get; set; }
Public Property OtherDisksMaxSize As Integer
    Get
    Set
public:
property int OtherDisksMaxSize {
    int get ();
    void set (int value);
}
member OtherDisksMaxSize : int with get, set

Property Value

Type: Int32
See Also

Reference

DiskLayoutWithEnvironmentModel Class


DiskLayoutWithEnvironmentModel Methods

DiskLayoutWithEnvironmentModel Methods

The DiskLayoutWithEnvironmentModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DiskLayoutWithEnvironmentModel Class


DiskModel Class

DiskModel Class
Represents a disk for the server.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDiskModel
DoubleTake.Web.ModelsDiskOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public class DiskModel
Public Class DiskModel
public ref class DiskModel
type DiskModel =  class end

The DiskModel type exposes the following members.

Constructors
 | Name | Description
Public method | DiskModel | Initializes a new instance of the DiskModel class
Top
Properties
 | Name | Description
Public property | DiskName | Gets or sets is the name of the disk.
Public property | Partitions | Gets or sets are the partitions on the disk.
Public property | PartTableType | Gets or sets is the partition table type.
Public property | SizeInB | Gets or sets is the size of the disk in bytes
Public property | Valid | Gets or sets determine whether or not this Disk is a valid one.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DiskModel Constructor

DiskModel Constructor
Initializes a new instance of the DiskModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DiskModel()
Public Sub New
public:
DiskModel()
new : unit -> DiskModel
See Also

Reference

DiskModel Class


DiskModel Properties

DiskModel Properties

The DiskModel type exposes the following members.

Properties
 | Name | Description
Public property | DiskName | Gets or sets is the name of the disk.
Public property | Partitions | Gets or sets are the partitions on the disk.
Public property | PartTableType | Gets or sets is the partition table type.
Public property | SizeInB | Gets or sets is the size of the disk in bytes
Public property | Valid | Gets or sets determine whether or not this Disk is a valid one.
Top
See Also

Reference

DiskModel Class


DiskModel.DiskName Property

DiskModelDiskName Property
Gets or sets is the name of the disk.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string DiskName { get; set; }
Public Property DiskName As String
    Get
    Set
public:
property String^ DiskName {
    String^ get ();
    void set (String^ value);
}
member DiskName : string with get, set

Property Value

Type: String
See Also

Reference

DiskModel Class


DiskModel.Partitions Property

DiskModelPartitions Property
Gets or sets are the partitions on the disk.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public PartitionModel[] Partitions { get; set; }
Public Property Partitions As PartitionModel()
    Get
    Set
public:
property array<PartitionModel^>^ Partitions {
    array<PartitionModel^>^ get ();
    void set (array<PartitionModel^>^ value);
}
member Partitions : PartitionModel[] with get, set

Property Value

Type: PartitionModel
See Also

Reference

DiskModel Class


DiskModel.PartTableType Property

DiskModelPartTableType Property
Gets or sets is the partition table type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string PartTableType { get; set; }
Public Property PartTableType As String
    Get
    Set
public:
property String^ PartTableType {
    String^ get ();
    void set (String^ value);
}
member PartTableType : string with get, set

Property Value

Type: String
See Also

Reference

DiskModel Class


DiskModel.SizeInB Property

DiskModelSizeInB Property
Gets or sets is the size of the disk in bytes

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long SizeInB { get; set; }
Public Property SizeInB As Long
    Get
    Set
public:
property long long SizeInB {
    long long get ();
    void set (long long value);
}
member SizeInB : int64 with get, set

Property Value

Type: Int64
See Also

Reference

DiskModel Class


DiskModel.Valid Property

DiskModelValid Property
Gets or sets determine whether or not this Disk is a valid one.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool Valid { get; set; }
Public Property Valid As Boolean
    Get
    Set
public:
property bool Valid {
    bool get ();
    void set (bool value);
}
member Valid : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DiskModel Class


DiskModel Methods

DiskModel Methods

The DiskModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DiskModel Class


DiskOptionsModel Class

DiskOptionsModel Class
Represents a disk for the server.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDiskModel
DoubleTake.Web.ModelsDiskOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public class DiskOptionsModel : DiskModel
Public Class DiskOptionsModel
    Inherits DiskModel
public ref class DiskOptionsModel : public DiskModel
type DiskOptionsModel =
    class
        inherit DiskModel
    end

The DiskOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | DiskOptionsModel | Initializes a new instance of the DiskOptionsModel class
Top
Properties
 | Name | Description
Public property | DesiredSizeInB | Gets or sets the desired size in bytes of the new disk.
Public property | DiskControllerType | Gets or sets the disk controller. IDE—Use this value to create an IDE disk. SCSI—Use this value to create a SCSI disk.
Public property | DiskName | Gets or sets is the name of the disk. (Inherited from DiskModel.)
Public property | DiskProvisioningType | Gets or sets the disk type. Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V.
Public property | Partitions | Gets or sets are the partitions on the disk. (Inherited from DiskModel.)
Public property | PartTableType | Gets or sets is the partition table type. (Inherited from DiskModel.)
Public property | PreexistingDiskPath | Gets or sets the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created.
Public property | SizeInB | Gets or sets is the size of the disk in bytes (Inherited from DiskModel.)
Public property | Valid | Gets or sets determine whether or not this Disk is a valid one. (Inherited from DiskModel.)
Public property | VirtualDiskPath | Gets or sets the path on the host where the disk should be stored.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DiskOptionsModel Constructor

DiskOptionsModel Constructor
Initializes a new instance of the DiskOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DiskOptionsModel()
Public Sub New
public:
DiskOptionsModel()
new : unit -> DiskOptionsModel
See Also

Reference

DiskOptionsModel Class


DiskOptionsModel Properties

DiskOptionsModel Properties

The DiskOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | DesiredSizeInB | Gets or sets the desired size in bytes of the new disk.
Public property | DiskControllerType | Gets or sets the disk controller. IDE—Use this value to create an IDE disk. SCSI—Use this value to create a SCSI disk.
Public property | DiskName | Gets or sets is the name of the disk. (Inherited from DiskModel.)
Public property | DiskProvisioningType | Gets or sets the disk type. Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V.
Public property | Partitions | Gets or sets are the partitions on the disk. (Inherited from DiskModel.)
Public property | PartTableType | Gets or sets is the partition table type. (Inherited from DiskModel.)
Public property | PreexistingDiskPath | Gets or sets the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created.
Public property | SizeInB | Gets or sets is the size of the disk in bytes (Inherited from DiskModel.)
Public property | Valid | Gets or sets determine whether or not this Disk is a valid one. (Inherited from DiskModel.)
Public property | VirtualDiskPath | Gets or sets the path on the host where the disk should be stored.
Top
See Also

Reference

DiskOptionsModel Class


DiskOptionsModel.DesiredSizeInB Property

DiskOptionsModelDesiredSizeInB Property
Gets or sets the desired size in bytes of the new disk.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long DesiredSizeInB { get; set; }
Public Property DesiredSizeInB As Long
    Get
    Set
public:
property long long DesiredSizeInB {
    long long get ();
    void set (long long value);
}
member DesiredSizeInB : int64 with get, set

Property Value

Type: Int64
The desired size in bytes.
See Also

Reference

DiskOptionsModel Class


DiskOptionsModel.DiskControllerType Property

DiskOptionsModelDiskControllerType Property

Gets or sets the disk controller.

IDE—Use this value to create an IDE disk.

SCSI—Use this value to create a SCSI disk.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string DiskControllerType { get; set; }
Public Property DiskControllerType As String
    Get
    Set
public:
property String^ DiskControllerType {
    String^ get ();
    void set (String^ value);
}
member DiskControllerType : string with get, set

Property Value

Type: String
The type of the disk controller.
See Also

Reference

DiskOptionsModel Class


DiskOptionsModel.DiskProvisioningType Property

DiskOptionsModelDiskProvisioningType Property
Gets or sets the disk type.

Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks.

Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks.

Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string DiskProvisioningType { get; set; }
Public Property DiskProvisioningType As String
    Get
    Set
public:
property String^ DiskProvisioningType {
    String^ get ();
    void set (String^ value);
}
member DiskProvisioningType : string with get, set

Property Value

Type: String
The type of the disk provisioning.
See Also

Reference

DiskOptionsModel Class


DiskOptionsModel.PreexistingDiskPath Property

DiskOptionsModelPreexistingDiskPath Property
Gets or sets the full path and file name of an existing virtual disk that you want to reuse. If this value is null, a new virtual disk will be created.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string PreexistingDiskPath { get; set; }
Public Property PreexistingDiskPath As String
    Get
    Set
public:
property String^ PreexistingDiskPath {
    String^ get ();
    void set (String^ value);
}
member PreexistingDiskPath : string with get, set

Property Value

Type: String
The path of this pre-existing path.
See Also

Reference

DiskOptionsModel Class


DiskOptionsModel.VirtualDiskPath Property

DiskOptionsModelVirtualDiskPath Property
Gets or sets the path on the host where the disk should be stored.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string VirtualDiskPath { get; set; }
Public Property VirtualDiskPath As String
    Get
    Set
public:
property String^ VirtualDiskPath {
    String^ get ();
    void set (String^ value);
}
member VirtualDiskPath : string with get, set

Property Value

Type: String
The path of this item.
See Also

Reference

DiskOptionsModel Class


DiskOptionsModel Methods

DiskOptionsModel Methods

The DiskOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DiskOptionsModel Class


DiskPartitionLayoutModel Class

DiskPartitionLayoutModel Class
Disk partition layout model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDiskPartitionLayoutModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class DiskPartitionLayoutModel
Public NotInheritable Class DiskPartitionLayoutModel
public ref class DiskPartitionLayoutModel sealed
[<SealedAttribute>]
type DiskPartitionLayoutModel =  class end

The DiskPartitionLayoutModel type exposes the following members.

Constructors
 | Name | Description
Public method | DiskPartitionLayoutModel | Initializes a new instance of the DiskPartitionLayoutModel class
Top
Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating whether the partition should be made active.
Public property | Align | Gets or sets the partition offset will be a multiple of this value. If the Offset value is given, it will be round to the closest multiple of this value.
Public property | FileSystemType | Gets or sets the file system type such as NTFS, RFS. See FileSystemTypes class. If null, RECOMMENDED is used.
Public property | INodeSize | Gets or sets the INode size.
Public property | IsBoot | Gets or sets a value indicating whether this partition is a boot partition.
Public property | Label | Gets or sets the string to be used as the label of the volume. This is optional.
Public property | MountPoint | Gets or sets Where to mount the partition. (If the mount point looks like a {driveletter}: We will attempt to assign that drive letter to the volume.
Public property | Offset | Gets or sets the offset, in kilobytes, at which the partition is created. If offset is 0, the partition will start at the beginning of the first free space on the disk that is large enough to hold the new partition.
Public property | PartitionType | Gets or sets one of the partition types from the PartitionTypes class
Public property | QuickFormat | Gets or sets a value indicating whether we should use a "quick" format.
Public property | ShouldCreateMountPointDirectory | Gets or sets a value indicating whether InitializeDisk should create mount point directory or not.
Public property | ShouldFormatPartition | Gets or sets a value indicating whether the partition should be formatted.
Public property | Size | Gets or sets the size in Megabytes of the partition. If the size is 0 then it will consume the rest of the space.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DiskPartitionLayoutModel Constructor

DiskPartitionLayoutModel Constructor
Initializes a new instance of the DiskPartitionLayoutModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DiskPartitionLayoutModel()
Public Sub New
public:
DiskPartitionLayoutModel()
new : unit -> DiskPartitionLayoutModel
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel Properties

DiskPartitionLayoutModel Properties

The DiskPartitionLayoutModel type exposes the following members.

Properties
 | Name | Description
Public property | Active | Gets or sets a value indicating whether the partition should be made active.
Public property | Align | Gets or sets the partition offset will be a multiple of this value. If the Offset value is given, it will be round to the closest multiple of this value.
Public property | FileSystemType | Gets or sets the file system type such as NTFS, RFS. See FileSystemTypes class. If null, RECOMMENDED is used.
Public property | INodeSize | Gets or sets the INode size.
Public property | IsBoot | Gets or sets a value indicating whether this partition is a boot partition.
Public property | Label | Gets or sets the string to be used as the label of the volume. This is optional.
Public property | MountPoint | Gets or sets Where to mount the partition. (If the mount point looks like a {driveletter}: We will attempt to assign that drive letter to the volume.
Public property | Offset | Gets or sets the offset, in kilobytes, at which the partition is created. If offset is 0, the partition will start at the beginning of the first free space on the disk that is large enough to hold the new partition.
Public property | PartitionType | Gets or sets one of the partition types from the PartitionTypes class
Public property | QuickFormat | Gets or sets a value indicating whether we should use a "quick" format.
Public property | ShouldCreateMountPointDirectory | Gets or sets a value indicating whether InitializeDisk should create mount point directory or not.
Public property | ShouldFormatPartition | Gets or sets a value indicating whether the partition should be formatted.
Public property | Size | Gets or sets the size in Megabytes of the partition. If the size is 0 then it will consume the rest of the space.
Top
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.Active Property

DiskPartitionLayoutModelActive Property
Gets or sets a value indicating whether the partition should be made active.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool Active { get; set; }
Public Property Active As Boolean
    Get
    Set
public:
property bool Active {
    bool get ();
    void set (bool value);
}
member Active : bool with get, set

Property Value

Type: Boolean
true if active; otherwise, false.
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.Align Property

DiskPartitionLayoutModelAlign Property
Gets or sets the partition offset will be a multiple of this value. If the Offset value is given, it will be round to the closest multiple of this value.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int Align { get; set; }
Public Property Align As Integer
    Get
    Set
public:
property int Align {
    int get ();
    void set (int value);
}
member Align : int with get, set

Property Value

Type: Int32
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.FileSystemType Property

DiskPartitionLayoutModelFileSystemType Property
Gets or sets the file system type such as NTFS, RFS. See FileSystemTypes class. If null, RECOMMENDED is used.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string FileSystemType { get; set; }
Public Property FileSystemType As String
    Get
    Set
public:
property String^ FileSystemType {
    String^ get ();
    void set (String^ value);
}
member FileSystemType : string with get, set

Property Value

Type: String
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.INodeSize Property

DiskPartitionLayoutModelINodeSize Property
Gets or sets the INode size.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int INodeSize { get; set; }
Public Property INodeSize As Integer
    Get
    Set
public:
property int INodeSize {
    int get ();
    void set (int value);
}
member INodeSize : int with get, set

Property Value

Type: Int32
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.IsBoot Property

DiskPartitionLayoutModelIsBoot Property
Gets or sets a value indicating whether this partition is a boot partition.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsBoot { get; set; }
Public Property IsBoot As Boolean
    Get
    Set
public:
property bool IsBoot {
    bool get ();
    void set (bool value);
}
member IsBoot : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.Label Property

DiskPartitionLayoutModelLabel Property
Gets or sets the string to be used as the label of the volume. This is optional.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Label { get; set; }
Public Property Label As String
    Get
    Set
public:
property String^ Label {
    String^ get ();
    void set (String^ value);
}
member Label : string with get, set

Property Value

Type: String
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.MountPoint Property

DiskPartitionLayoutModelMountPoint Property
Gets or sets Where to mount the partition. (If the mount point looks like a {driveletter}: We will attempt to assign that drive letter to the volume.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string MountPoint { get; set; }
Public Property MountPoint As String
    Get
    Set
public:
property String^ MountPoint {
    String^ get ();
    void set (String^ value);
}
member MountPoint : string with get, set

Property Value

Type: String
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.Offset Property

DiskPartitionLayoutModelOffset Property
Gets or sets the offset, in kilobytes, at which the partition is created. If offset is 0, the partition will start at the beginning of the first free space on the disk that is large enough to hold the new partition.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int Offset { get; set; }
Public Property Offset As Integer
    Get
    Set
public:
property int Offset {
    int get ();
    void set (int value);
}
member Offset : int with get, set

Property Value

Type: Int32
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.PartitionType Property

DiskPartitionLayoutModelPartitionType Property
Gets or sets one of the partition types from the PartitionTypes class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string PartitionType { get; set; }
Public Property PartitionType As String
    Get
    Set
public:
property String^ PartitionType {
    String^ get ();
    void set (String^ value);
}
member PartitionType : string with get, set

Property Value

Type: String
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.QuickFormat Property

DiskPartitionLayoutModelQuickFormat Property
Gets or sets a value indicating whether we should use a "quick" format.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool QuickFormat { get; set; }
Public Property QuickFormat As Boolean
    Get
    Set
public:
property bool QuickFormat {
    bool get ();
    void set (bool value);
}
member QuickFormat : bool with get, set

Property Value

Type: Boolean
true if Quick format is desired; otherwise, false.
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.ShouldCreateMountPointDirectory Property

DiskPartitionLayoutModelShouldCreateMountPointDirectory Property
Gets or sets a value indicating whether InitializeDisk should create mount point directory or not.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldCreateMountPointDirectory { get; set; }
Public Property ShouldCreateMountPointDirectory As Boolean
    Get
    Set
public:
property bool ShouldCreateMountPointDirectory {
    bool get ();
    void set (bool value);
}
member ShouldCreateMountPointDirectory : bool with get, set

Property Value

Type: Boolean
true if InitializeDisk should create mount point directory; otherwise, false.
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.ShouldFormatPartition Property

DiskPartitionLayoutModelShouldFormatPartition Property
Gets or sets a value indicating whether the partition should be formatted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldFormatPartition { get; set; }
Public Property ShouldFormatPartition As Boolean
    Get
    Set
public:
property bool ShouldFormatPartition {
    bool get ();
    void set (bool value);
}
member ShouldFormatPartition : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel.Size Property

DiskPartitionLayoutModelSize Property
Gets or sets the size in Megabytes of the partition. If the size is 0 then it will consume the rest of the space.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int Size { get; set; }
Public Property Size As Integer
    Get
    Set
public:
property int Size {
    int get ();
    void set (int value);
}
member Size : int with get, set

Property Value

Type: Int32
See Also

Reference

DiskPartitionLayoutModel Class


DiskPartitionLayoutModel Methods

DiskPartitionLayoutModel Methods

The DiskPartitionLayoutModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DiskPartitionLayoutModel Class


DnsDomainDetailsModel Class

DnsDomainDetailsModel Class
DNS domain details model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDnsDomainDetailsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class DnsDomainDetailsModel
Public NotInheritable Class DnsDomainDetailsModel
public ref class DnsDomainDetailsModel sealed
[<SealedAttribute>]
type DnsDomainDetailsModel =  class end

The DnsDomainDetailsModel type exposes the following members.

Constructors
 | Name | Description
Public method | DnsDomainDetailsModel | Initializes a new instance of the DnsDomainDetailsModel class
Top
Properties
 | Name | Description
Public property | AddressMappings | Gets or sets the list of IP addresses to be updated.
Public property | Credentials | Gets or sets the domain credentials.
Public property | DnsServers | Gets or sets the list of DNS servers to be updated.
Public property | DomainName | Gets or sets the name of the domain.
Public property | ShouldUpdateTtl | Gets or sets a value indicating whether or not the time-to-live value should be updated for this record.
Public property | TtlValue | Gets or sets the TTL value, in seconds.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DnsDomainDetailsModel Constructor

DnsDomainDetailsModel Constructor
Initializes a new instance of the DnsDomainDetailsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DnsDomainDetailsModel()
Public Sub New
public:
DnsDomainDetailsModel()
new : unit -> DnsDomainDetailsModel
See Also

Reference

DnsDomainDetailsModel Class


DnsDomainDetailsModel Properties

DnsDomainDetailsModel Properties

The DnsDomainDetailsModel type exposes the following members.

Properties
 | Name | Description
Public property | AddressMappings | Gets or sets the list of IP addresses to be updated.
Public property | Credentials | Gets or sets the domain credentials.
Public property | DnsServers | Gets or sets the list of DNS servers to be updated.
Public property | DomainName | Gets or sets the name of the domain.
Public property | ShouldUpdateTtl | Gets or sets a value indicating whether or not the time-to-live value should be updated for this record.
Public property | TtlValue | Gets or sets the TTL value, in seconds.
Top
See Also

Reference

DnsDomainDetailsModel Class


DnsDomainDetailsModel.AddressMappings Property

DnsDomainDetailsModelAddressMappings Property
Gets or sets the list of IP addresses to be updated.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public NetworkAddressMapModel[] AddressMappings { get; set; }
Public Property AddressMappings As NetworkAddressMapModel()
    Get
    Set
public:
property array<NetworkAddressMapModel^>^ AddressMappings {
    array<NetworkAddressMapModel^>^ get ();
    void set (array<NetworkAddressMapModel^>^ value);
}
member AddressMappings : NetworkAddressMapModel[] with get, set

Property Value

Type: NetworkAddressMapModel
See Also

Reference

DnsDomainDetailsModel Class


DnsDomainDetailsModel.Credentials Property

DnsDomainDetailsModelCredentials Property
Gets or sets the domain credentials.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CredentialModel Credentials { get; set; }
Public Property Credentials As CredentialModel
    Get
    Set
public:
property CredentialModel^ Credentials {
    CredentialModel^ get ();
    void set (CredentialModel^ value);
}
member Credentials : CredentialModel with get, set

Property Value

Type: CredentialModel
See Also

Reference

DnsDomainDetailsModel Class


DnsDomainDetailsModel.DnsServers Property

DnsDomainDetailsModelDnsServers Property
Gets or sets the list of DNS servers to be updated.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DnsServerDetailModel[] DnsServers { get; set; }
Public Property DnsServers As DnsServerDetailModel()
    Get
    Set
public:
property array<DnsServerDetailModel^>^ DnsServers {
    array<DnsServerDetailModel^>^ get ();
    void set (array<DnsServerDetailModel^>^ value);
}
member DnsServers : DnsServerDetailModel[] with get, set

Property Value

Type: DnsServerDetailModel
See Also

Reference

DnsDomainDetailsModel Class


DnsDomainDetailsModel.DomainName Property

DnsDomainDetailsModelDomainName Property
Gets or sets the name of the domain.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string DomainName { get; set; }
Public Property DomainName As String
    Get
    Set
public:
property String^ DomainName {
    String^ get ();
    void set (String^ value);
}
member DomainName : string with get, set

Property Value

Type: String
See Also

Reference

DnsDomainDetailsModel Class


DnsDomainDetailsModel.ShouldUpdateTtl Property

DnsDomainDetailsModelShouldUpdateTtl Property
Gets or sets a value indicating whether or not the time-to-live value should be updated for this record.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldUpdateTtl { get; set; }
Public Property ShouldUpdateTtl As Boolean
    Get
    Set
public:
property bool ShouldUpdateTtl {
    bool get ();
    void set (bool value);
}
member ShouldUpdateTtl : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DnsDomainDetailsModel Class


DnsDomainDetailsModel.TtlValue Property

DnsDomainDetailsModelTtlValue Property
Gets or sets the TTL value, in seconds.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int TtlValue { get; set; }
Public Property TtlValue As Integer
    Get
    Set
public:
property int TtlValue {
    int get ();
    void set (int value);
}
member TtlValue : int with get, set

Property Value

Type: Int32
See Also

Reference

DnsDomainDetailsModel Class


DnsDomainDetailsModel Methods

DnsDomainDetailsModel Methods

The DnsDomainDetailsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DnsDomainDetailsModel Class


DnsDomainDetailsPrototypeModel Class

DnsDomainDetailsPrototypeModel Class
DNS domain details prototype model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDnsDomainDetailsPrototypeModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class DnsDomainDetailsPrototypeModel
Public NotInheritable Class DnsDomainDetailsPrototypeModel
public ref class DnsDomainDetailsPrototypeModel sealed
[<SealedAttribute>]
type DnsDomainDetailsPrototypeModel =  class end

The DnsDomainDetailsPrototypeModel type exposes the following members.

Constructors
 | Name | Description
Public method | DnsDomainDetailsPrototypeModel | Initializes a new instance of the DnsDomainDetailsPrototypeModel class
Top
Properties
 | Name | Description
Public property | DnsServers | Gets or sets the DNS servers.
Public property | Domain | Gets or sets the domain.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DnsDomainDetailsPrototypeModel Constructor

DnsDomainDetailsPrototypeModel Constructor
Initializes a new instance of the DnsDomainDetailsPrototypeModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DnsDomainDetailsPrototypeModel()
Public Sub New
public:
DnsDomainDetailsPrototypeModel()
new : unit -> DnsDomainDetailsPrototypeModel
See Also

Reference

DnsDomainDetailsPrototypeModel Class


DnsDomainDetailsPrototypeModel Properties

DnsDomainDetailsPrototypeModel Properties

The DnsDomainDetailsPrototypeModel type exposes the following members.

Properties
 | Name | Description
Public property | DnsServers | Gets or sets the DNS servers.
Public property | Domain | Gets or sets the domain.
Top
See Also

Reference

DnsDomainDetailsPrototypeModel Class


DnsDomainDetailsPrototypeModel.DnsServers Property

DnsDomainDetailsPrototypeModelDnsServers Property
Gets or sets the DNS servers.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string[] DnsServers { get; set; }
Public Property DnsServers As String()
    Get
    Set
public:
property array<String^>^ DnsServers {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member DnsServers : string[] with get, set

Property Value

Type: String
See Also

Reference

DnsDomainDetailsPrototypeModel Class


DnsDomainDetailsPrototypeModel.Domain Property

DnsDomainDetailsPrototypeModelDomain Property
Gets or sets the domain.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Domain { get; set; }
Public Property Domain As String
    Get
    Set
public:
property String^ Domain {
    String^ get ();
    void set (String^ value);
}
member Domain : string with get, set

Property Value

Type: String
See Also

Reference

DnsDomainDetailsPrototypeModel Class


DnsDomainDetailsPrototypeModel Methods

DnsDomainDetailsPrototypeModel Methods

The DnsDomainDetailsPrototypeModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DnsDomainDetailsPrototypeModel Class


DnsOptionsModel Class

DnsOptionsModel Class
DNS options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDnsOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class DnsOptionsModel
Public NotInheritable Class DnsOptionsModel
public ref class DnsOptionsModel sealed
[<SealedAttribute>]
type DnsOptionsModel =  class end

The DnsOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | DnsOptionsModel | Initializes a new instance of the DnsOptionsModel class
Top
Properties
 | Name | Description
Public property | AdditionalDns | Gets or sets specifies an additional source server DN to lock.
Public property | AllIPAddressesNeedMapping | Gets or sets defines if the current environment being protected require all IP addresses to be mapped to an appropriate target IP address.
Public property | AlternateTrustees | Gets or sets overrides the default trustees of "NT AUTHORITY/SYSTEM" and the source computer account (for clustered environments).
Public property | Domains | Gets or sets the domains that will be updated during failover.
Public property | Enabled | Gets or sets a value indicating whether or not DNS failover is enabled on this job.
Public property | SourceServerInWorkgroup | Gets or sets a value indicating whether or not the source server is in a work group.
Public property | SourceServerName | Gets or sets the name of the source server.
Public property | TargetServerName | Gets or sets the name of the target server.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DnsOptionsModel Constructor

DnsOptionsModel Constructor
Initializes a new instance of the DnsOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DnsOptionsModel()
Public Sub New
public:
DnsOptionsModel()
new : unit -> DnsOptionsModel
See Also

Reference

DnsOptionsModel Class


DnsOptionsModel Properties

DnsOptionsModel Properties

The DnsOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalDns | Gets or sets specifies an additional source server DN to lock.
Public property | AllIPAddressesNeedMapping | Gets or sets defines if the current environment being protected require all IP addresses to be mapped to an appropriate target IP address.
Public property | AlternateTrustees | Gets or sets overrides the default trustees of "NT AUTHORITY/SYSTEM" and the source computer account (for clustered environments).
Public property | Domains | Gets or sets the domains that will be updated during failover.
Public property | Enabled | Gets or sets a value indicating whether or not DNS failover is enabled on this job.
Public property | SourceServerInWorkgroup | Gets or sets a value indicating whether or not the source server is in a work group.
Public property | SourceServerName | Gets or sets the name of the source server.
Public property | TargetServerName | Gets or sets the name of the target server.
Top
See Also

Reference

DnsOptionsModel Class


DnsOptionsModel.AdditionalDns Property

DnsOptionsModelAdditionalDns Property
Gets or sets specifies an additional source server DN to lock.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] AdditionalDns { get; set; }
Public Property AdditionalDns As String()
    Get
    Set
public:
property array<String^>^ AdditionalDns {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member AdditionalDns : string[] with get, set

Property Value

Type: String
See Also

Reference

DnsOptionsModel Class


DnsOptionsModel.AllIPAddressesNeedMapping Property

DnsOptionsModelAllIPAddressesNeedMapping Property
Gets or sets defines if the current environment being protected require all IP addresses to be mapped to an appropriate target IP address.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> AllIPAddressesNeedMapping { get; set; }
Public Property AllIPAddressesNeedMapping As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> AllIPAddressesNeedMapping {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member AllIPAddressesNeedMapping : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

DnsOptionsModel Class


DnsOptionsModel.AlternateTrustees Property

DnsOptionsModelAlternateTrustees Property
Gets or sets overrides the default trustees of "NT AUTHORITY/SYSTEM" and the source computer account (for clustered environments).

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] AlternateTrustees { get; set; }
Public Property AlternateTrustees As String()
    Get
    Set
public:
property array<String^>^ AlternateTrustees {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member AlternateTrustees : string[] with get, set

Property Value

Type: String
See Also

Reference

DnsOptionsModel Class


DnsOptionsModel.Domains Property

DnsOptionsModelDomains Property
Gets or sets the domains that will be updated during failover.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DnsDomainDetailsModel[] Domains { get; set; }
Public Property Domains As DnsDomainDetailsModel()
    Get
    Set
public:
property array<DnsDomainDetailsModel^>^ Domains {
    array<DnsDomainDetailsModel^>^ get ();
    void set (array<DnsDomainDetailsModel^>^ value);
}
member Domains : DnsDomainDetailsModel[] with get, set

Property Value

Type: DnsDomainDetailsModel
See Also

Reference

DnsOptionsModel Class


DnsOptionsModel.Enabled Property

DnsOptionsModelEnabled Property
Gets or sets a value indicating whether or not DNS failover is enabled on this job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DnsOptionsModel Class


DnsOptionsModel.SourceServerInWorkgroup Property

DnsOptionsModelSourceServerInWorkgroup Property
Gets or sets a value indicating whether or not the source server is in a work group.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool SourceServerInWorkgroup { get; set; }
Public Property SourceServerInWorkgroup As Boolean
    Get
    Set
public:
property bool SourceServerInWorkgroup {
    bool get ();
    void set (bool value);
}
member SourceServerInWorkgroup : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DnsOptionsModel Class


DnsOptionsModel.SourceServerName Property

DnsOptionsModelSourceServerName Property
Gets or sets the name of the source server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceServerName { get; set; }
Public Property SourceServerName As String
    Get
    Set
public:
property String^ SourceServerName {
    String^ get ();
    void set (String^ value);
}
member SourceServerName : string with get, set

Property Value

Type: String
See Also

Reference

DnsOptionsModel Class


DnsOptionsModel.TargetServerName Property

DnsOptionsModelTargetServerName Property
Gets or sets the name of the target server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetServerName { get; set; }
Public Property TargetServerName As String
    Get
    Set
public:
property String^ TargetServerName {
    String^ get ();
    void set (String^ value);
}
member TargetServerName : string with get, set

Property Value

Type: String
See Also

Reference

DnsOptionsModel Class


DnsOptionsModel Methods

DnsOptionsModel Methods

The DnsOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DnsOptionsModel Class


DnsRecordLockOptionsModel Class

DnsRecordLockOptionsModel Class
DNS record lock options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDnsRecordLockOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class DnsRecordLockOptionsModel
Public NotInheritable Class DnsRecordLockOptionsModel
public ref class DnsRecordLockOptionsModel sealed
[<SealedAttribute>]
type DnsRecordLockOptionsModel =  class end

The DnsRecordLockOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | DnsRecordLockOptionsModel | Initializes a new instance of the DnsRecordLockOptionsModel class
Top
Properties
 | Name | Description
Public property | AdditionalDns | Gets or sets the additional DNS.
Public property | DnsServer | Gets or sets the DNS server.
Public property | Server | Gets or sets the server.
Public property | Trustees | Gets or sets the trustees.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DnsRecordLockOptionsModel Constructor

DnsRecordLockOptionsModel Constructor
Initializes a new instance of the DnsRecordLockOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DnsRecordLockOptionsModel()
Public Sub New
public:
DnsRecordLockOptionsModel()
new : unit -> DnsRecordLockOptionsModel
See Also

Reference

DnsRecordLockOptionsModel Class


DnsRecordLockOptionsModel Properties

DnsRecordLockOptionsModel Properties

The DnsRecordLockOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalDns | Gets or sets the additional DNS.
Public property | DnsServer | Gets or sets the DNS server.
Public property | Server | Gets or sets the server.
Public property | Trustees | Gets or sets the trustees.
Top
See Also

Reference

DnsRecordLockOptionsModel Class


DnsRecordLockOptionsModel.AdditionalDns Property

DnsRecordLockOptionsModelAdditionalDns Property
Gets or sets the additional DNS.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> AdditionalDns { get; set; }
Public Property AdditionalDns As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ AdditionalDns {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member AdditionalDns : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
See Also

Reference

DnsRecordLockOptionsModel Class


DnsRecordLockOptionsModel.DnsServer Property

DnsRecordLockOptionsModelDnsServer Property
Gets or sets the DNS server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string DnsServer { get; set; }
Public Property DnsServer As String
    Get
    Set
public:
property String^ DnsServer {
    String^ get ();
    void set (String^ value);
}
member DnsServer : string with get, set

Property Value

Type: String
See Also

Reference

DnsRecordLockOptionsModel Class


DnsRecordLockOptionsModel.Server Property

DnsRecordLockOptionsModelServer Property
Gets or sets the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Server { get; set; }
Public Property Server As String
    Get
    Set
public:
property String^ Server {
    String^ get ();
    void set (String^ value);
}
member Server : string with get, set

Property Value

Type: String
See Also

Reference

DnsRecordLockOptionsModel Class


DnsRecordLockOptionsModel.Trustees Property

DnsRecordLockOptionsModelTrustees Property
Gets or sets the trustees.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> Trustees { get; set; }
Public Property Trustees As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ Trustees {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member Trustees : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
See Also

Reference

DnsRecordLockOptionsModel Class


DnsRecordLockOptionsModel Methods

DnsRecordLockOptionsModel Methods

The DnsRecordLockOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DnsRecordLockOptionsModel Class


DnsServerDetailModel Class

DnsServerDetailModel Class
DNS server detail model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDnsServerDetailModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class DnsServerDetailModel
Public NotInheritable Class DnsServerDetailModel
public ref class DnsServerDetailModel sealed
[<SealedAttribute>]
type DnsServerDetailModel =  class end

The DnsServerDetailModel type exposes the following members.

Constructors
 | Name | Description
Public method | DnsServerDetailModel | Initializes a new instance of the DnsServerDetailModel class
Top
Properties
 | Name | Description
Public property | Address | Gets or sets the address of the DNS server.
Public property | Origin | Gets or sets the origin of the DNS server.
Public property | SelectedForUpdate | Gets or sets a value indicating whether or not this DNS server will be updated during DNS failover.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DnsServerDetailModel Constructor

DnsServerDetailModel Constructor
Initializes a new instance of the DnsServerDetailModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DnsServerDetailModel()
Public Sub New
public:
DnsServerDetailModel()
new : unit -> DnsServerDetailModel
See Also

Reference

DnsServerDetailModel Class


DnsServerDetailModel Properties

DnsServerDetailModel Properties

The DnsServerDetailModel type exposes the following members.

Properties
 | Name | Description
Public property | Address | Gets or sets the address of the DNS server.
Public property | Origin | Gets or sets the origin of the DNS server.
Public property | SelectedForUpdate | Gets or sets a value indicating whether or not this DNS server will be updated during DNS failover.
Top
See Also

Reference

DnsServerDetailModel Class


DnsServerDetailModel.Address Property

DnsServerDetailModelAddress Property
Gets or sets the address of the DNS server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Address { get; set; }
Public Property Address As String
    Get
    Set
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}
member Address : string with get, set

Property Value

Type: String
See Also

Reference

DnsServerDetailModel Class


DnsServerDetailModel.Origin Property

DnsServerDetailModelOrigin Property
Gets or sets the origin of the DNS server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Origin { get; set; }
Public Property Origin As String
    Get
    Set
public:
property String^ Origin {
    String^ get ();
    void set (String^ value);
}
member Origin : string with get, set

Property Value

Type: String
See Also

Reference

DnsServerDetailModel Class


DnsServerDetailModel.SelectedForUpdate Property

DnsServerDetailModelSelectedForUpdate Property
Gets or sets a value indicating whether or not this DNS server will be updated during DNS failover.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool SelectedForUpdate { get; set; }
Public Property SelectedForUpdate As Boolean
    Get
    Set
public:
property bool SelectedForUpdate {
    bool get ();
    void set (bool value);
}
member SelectedForUpdate : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DnsServerDetailModel Class


DnsServerDetailModel Methods

DnsServerDetailModel Methods

The DnsServerDetailModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DnsServerDetailModel Class


DriveTypeEnum Enumeration

DriveTypeEnum Enumeration
Drive type

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public enum DriveTypeEnum
Public Enumeration DriveTypeEnum
public enum class DriveTypeEnum
type DriveTypeEnum
Members
Member name | Value | Description
Unknown | 0 | The unknown
NoRootDirectory | 1 | The no root directory
Removable | 2 | The removable
Fixed | 3 | The fixed
Network | 4 | The network
CdRom | 5 | The cd rom
Ram | 6 | The ram
See Also

Reference

DoubleTake.Web.Models Namespace


DTAVPersistedStateModel Class

DTAVPersistedStateModel Class
DTAV persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDTAVPersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class DTAVPersistedStateModel
Public NotInheritable Class DTAVPersistedStateModel
public ref class DTAVPersistedStateModel sealed
[<SealedAttribute>]
type DTAVPersistedStateModel =  class end

The DTAVPersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | DTAVPersistedStateModel | Initializes a new instance of the DTAVPersistedStateModel class
Top
Properties
 | Name | Description
Public property | JobCreationDate | Gets or sets the job creation date.
Public property | JobState | Gets or sets the state of the job.
Public property | JobVersion | Gets or sets the job version.
Public property | Licensed | Gets or sets a value indicating whether this DTAVPersistedStateModel is licensed.
Public property | LicenseData | Gets or sets the license data.
Public property | SavedSnapshots | Gets or sets the saved snapshots.
Public property | SnapshotName | Gets or sets the name of the snapshot.
Public property | TargetVmGuid | Gets or sets the target vm unique identifier.
Public property | VmdkdInfoList | Gets or sets the VMDKD information list.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DTAVPersistedStateModel Constructor

DTAVPersistedStateModel Constructor
Initializes a new instance of the DTAVPersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DTAVPersistedStateModel()
Public Sub New
public:
DTAVPersistedStateModel()
new : unit -> DTAVPersistedStateModel
See Also

Reference

DTAVPersistedStateModel Class


DTAVPersistedStateModel Properties

DTAVPersistedStateModel Properties

The DTAVPersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | JobCreationDate | Gets or sets the job creation date.
Public property | JobState | Gets or sets the state of the job.
Public property | JobVersion | Gets or sets the job version.
Public property | Licensed | Gets or sets a value indicating whether this DTAVPersistedStateModel is licensed.
Public property | LicenseData | Gets or sets the license data.
Public property | SavedSnapshots | Gets or sets the saved snapshots.
Public property | SnapshotName | Gets or sets the name of the snapshot.
Public property | TargetVmGuid | Gets or sets the target vm unique identifier.
Public property | VmdkdInfoList | Gets or sets the VMDKD information list.
Top
See Also

Reference

DTAVPersistedStateModel Class


DTAVPersistedStateModel.JobCreationDate Property

DTAVPersistedStateModelJobCreationDate Property
Gets or sets the job creation date.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset JobCreationDate { get; set; }
Public Property JobCreationDate As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset JobCreationDate {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member JobCreationDate : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
The job creation date.
See Also

Reference

DTAVPersistedStateModel Class


DTAVPersistedStateModel.JobState Property

DTAVPersistedStateModelJobState Property
Gets or sets the state of the job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public JobStateModel JobState { get; set; }
Public Property JobState As JobStateModel
    Get
    Set
public:
property JobStateModel^ JobState {
    JobStateModel^ get ();
    void set (JobStateModel^ value);
}
member JobState : JobStateModel with get, set

Property Value

Type: JobStateModel
The state of the job.
See Also

Reference

DTAVPersistedStateModel Class


DTAVPersistedStateModel.JobVersion Property

DTAVPersistedStateModelJobVersion Property
Gets or sets the job version.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ProductVersionModel JobVersion { get; set; }
Public Property JobVersion As ProductVersionModel
    Get
    Set
public:
property ProductVersionModel^ JobVersion {
    ProductVersionModel^ get ();
    void set (ProductVersionModel^ value);
}
member JobVersion : ProductVersionModel with get, set

Property Value

Type: ProductVersionModel
The job version.
See Also

Reference

DTAVPersistedStateModel Class


DTAVPersistedStateModel.Licensed Property

DTAVPersistedStateModelLicensed Property
Gets or sets a value indicating whether this DTAVPersistedStateModel is licensed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool Licensed { get; set; }
Public Property Licensed As Boolean
    Get
    Set
public:
property bool Licensed {
    bool get ();
    void set (bool value);
}
member Licensed : bool with get, set

Property Value

Type: Boolean
true if licensed; otherwise, false.
See Also

Reference

DTAVPersistedStateModel Class


DTAVPersistedStateModel.LicenseData Property

DTAVPersistedStateModelLicenseData Property
Gets or sets the license data.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string LicenseData { get; set; }
Public Property LicenseData As String
    Get
    Set
public:
property String^ LicenseData {
    String^ get ();
    void set (String^ value);
}
member LicenseData : string with get, set

Property Value

Type: String
The license data.
See Also

Reference

DTAVPersistedStateModel Class


DTAVPersistedStateModel.SavedSnapshots Property

DTAVPersistedStateModelSavedSnapshots Property
Gets or sets the saved snapshots.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public List<PITSnapshotRecordModel> SavedSnapshots { get; set; }
Public Property SavedSnapshots As List(Of PITSnapshotRecordModel)
    Get
    Set
public:
property List<PITSnapshotRecordModel^>^ SavedSnapshots {
    List<PITSnapshotRecordModel^>^ get ();
    void set (List<PITSnapshotRecordModel^>^ value);
}
member SavedSnapshots : List<PITSnapshotRecordModel> with get, set

Property Value

Type: List PITSnapshotRecordModel
See Also

Reference

DTAVPersistedStateModel Class


DTAVPersistedStateModel.SnapshotName Property

DTAVPersistedStateModelSnapshotName Property
Gets or sets the name of the snapshot.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SnapshotName { get; set; }
Public Property SnapshotName As String
    Get
    Set
public:
property String^ SnapshotName {
    String^ get ();
    void set (String^ value);
}
member SnapshotName : string with get, set

Property Value

Type: String
The name of the snapshot.
See Also

Reference

DTAVPersistedStateModel Class


DTAVPersistedStateModel.TargetVmGuid Property

DTAVPersistedStateModelTargetVmGuid Property
Gets or sets the target vm unique identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string TargetVmGuid { get; set; }
Public Property TargetVmGuid As String
    Get
    Set
public:
property String^ TargetVmGuid {
    String^ get ();
    void set (String^ value);
}
member TargetVmGuid : string with get, set

Property Value

Type: String
The target vm unique identifier.
See Also

Reference

DTAVPersistedStateModel Class


DTAVPersistedStateModel.VmdkdInfoList Property

DTAVPersistedStateModelVmdkdInfoList Property
Gets or sets the VMDKD information list.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public List<VmdkInfoModel> VmdkdInfoList { get; set; }
Public Property VmdkdInfoList As List(Of VmdkInfoModel)
    Get
    Set
public:
property List<VmdkInfoModel^>^ VmdkdInfoList {
    List<VmdkInfoModel^>^ get ();
    void set (List<VmdkInfoModel^>^ value);
}
member VmdkdInfoList : List<VmdkInfoModel> with get, set

Property Value

Type: List VmdkInfoModel
The VMDKD information list.
See Also

Reference

DTAVPersistedStateModel Class


DTAVPersistedStateModel Methods

DTAVPersistedStateModel Methods

The DTAVPersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DTAVPersistedStateModel Class


DTHVPersistedStateModel Class

DTHVPersistedStateModel Class
DTHV persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDTHVPersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class DTHVPersistedStateModel
Public NotInheritable Class DTHVPersistedStateModel
public ref class DTHVPersistedStateModel sealed
[<SealedAttribute>]
type DTHVPersistedStateModel =  class end

The DTHVPersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | DTHVPersistedStateModel | Initializes a new instance of the DTHVPersistedStateModel class
Top
Properties
 | Name | Description
Public property | DeleteOptions | Gets or sets the delete options.
Public property | FailoverMonitorPersistedState | Gets or sets the state of the monitor persisted.
Public property | FailoverOptions | Gets or sets the failover options.
Public property | PowerSourceVm | Gets or sets a value indicating whether the source Vm was on before failover.
Public property | ProtectionConnectionPersistedState | Gets or sets the main connection's persisted state.
Public property | ProtectionTargetState | Gets or sets the state of the protection target.
Public property | RevertConnectionPersistedState | Gets or sets the state of the replica vm revert persisted.
Public property | SourceEndpoint | Gets or sets the source endpoint.
Public property | State | Gets or sets the state of the protection connection persisted.
Public property | TargetRoute | Gets or sets a value representing target route
Public property | TargetVmCfgResourceName | Gets or sets the name of the target vm CFG resource.
Public property | TargetVMGuid | Gets or sets the target vm unique identifier.
Public property | TargetVmResourceName | Gets or sets the name of the target vm resource.
Public property | VhdMapping | Gets or sets a value representing source and target VHD mappings
Public property | VirtualSwitchMonitorPersistedState | Gets or sets the state of the monitor persisted.
Public property | VMConfigMonitorPersistedState | Gets or sets the state of the monitor persisted.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DTHVPersistedStateModel Constructor

DTHVPersistedStateModel Constructor
Initializes a new instance of the DTHVPersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DTHVPersistedStateModel()
Public Sub New
public:
DTHVPersistedStateModel()
new : unit -> DTHVPersistedStateModel
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel Properties

DTHVPersistedStateModel Properties

The DTHVPersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | DeleteOptions | Gets or sets the delete options.
Public property | FailoverMonitorPersistedState | Gets or sets the state of the monitor persisted.
Public property | FailoverOptions | Gets or sets the failover options.
Public property | PowerSourceVm | Gets or sets a value indicating whether the source Vm was on before failover.
Public property | ProtectionConnectionPersistedState | Gets or sets the main connection's persisted state.
Public property | ProtectionTargetState | Gets or sets the state of the protection target.
Public property | RevertConnectionPersistedState | Gets or sets the state of the replica vm revert persisted.
Public property | SourceEndpoint | Gets or sets the source endpoint.
Public property | State | Gets or sets the state of the protection connection persisted.
Public property | TargetRoute | Gets or sets a value representing target route
Public property | TargetVmCfgResourceName | Gets or sets the name of the target vm CFG resource.
Public property | TargetVMGuid | Gets or sets the target vm unique identifier.
Public property | TargetVmResourceName | Gets or sets the name of the target vm resource.
Public property | VhdMapping | Gets or sets a value representing source and target VHD mappings
Public property | VirtualSwitchMonitorPersistedState | Gets or sets the state of the monitor persisted.
Public property | VMConfigMonitorPersistedState | Gets or sets the state of the monitor persisted.
Top
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.DeleteOptions Property

DTHVPersistedStateModelDeleteOptions Property
Gets or sets the delete options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DeleteOptionsModel DeleteOptions { get; set; }
Public Property DeleteOptions As DeleteOptionsModel
    Get
    Set
public:
property DeleteOptionsModel^ DeleteOptions {
    DeleteOptionsModel^ get ();
    void set (DeleteOptionsModel^ value);
}
member DeleteOptions : DeleteOptionsModel with get, set

Property Value

Type: DeleteOptionsModel
The delete options.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.FailoverMonitorPersistedState Property

DTHVPersistedStateModelFailoverMonitorPersistedState Property
Gets or sets the state of the monitor persisted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CoreMonitorPersistedStateModel FailoverMonitorPersistedState { get; set; }
Public Property FailoverMonitorPersistedState As CoreMonitorPersistedStateModel
    Get
    Set
public:
property CoreMonitorPersistedStateModel^ FailoverMonitorPersistedState {
    CoreMonitorPersistedStateModel^ get ();
    void set (CoreMonitorPersistedStateModel^ value);
}
member FailoverMonitorPersistedState : CoreMonitorPersistedStateModel with get, set

Property Value

Type: CoreMonitorPersistedStateModel
The state of the monitor persisted.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.FailoverOptions Property

DTHVPersistedStateModelFailoverOptions Property
Gets or sets the failover options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public FailoverOptionsModel FailoverOptions { get; set; }
Public Property FailoverOptions As FailoverOptionsModel
    Get
    Set
public:
property FailoverOptionsModel^ FailoverOptions {
    FailoverOptionsModel^ get ();
    void set (FailoverOptionsModel^ value);
}
member FailoverOptions : FailoverOptionsModel with get, set

Property Value

Type: FailoverOptionsModel
The failover options.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.PowerSourceVm Property

DTHVPersistedStateModelPowerSourceVm Property
Gets or sets a value indicating whether the source Vm was on before failover.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool PowerSourceVm { get; set; }
Public Property PowerSourceVm As Boolean
    Get
    Set
public:
property bool PowerSourceVm {
    bool get ();
    void set (bool value);
}
member PowerSourceVm : bool with get, set

Property Value

Type: Boolean
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.ProtectionConnectionPersistedState Property

DTHVPersistedStateModelProtectionConnectionPersistedState Property
Gets or sets the main connection's persisted state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionPersistedStateModel ProtectionConnectionPersistedState { get; set; }
Public Property ProtectionConnectionPersistedState As CoreConnectionPersistedStateModel
    Get
    Set
public:
property CoreConnectionPersistedStateModel^ ProtectionConnectionPersistedState {
    CoreConnectionPersistedStateModel^ get ();
    void set (CoreConnectionPersistedStateModel^ value);
}
member ProtectionConnectionPersistedState : CoreConnectionPersistedStateModel with get, set

Property Value

Type: CoreConnectionPersistedStateModel
The main connection's persisted state.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.ProtectionTargetState Property

DTHVPersistedStateModelProtectionTargetState Property
Gets or sets the state of the protection target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TargetStates> ProtectionTargetState { get; set; }
Public Property ProtectionTargetState As Nullable(Of TargetStates)
    Get
    Set
public:
property Nullable<TargetStates> ProtectionTargetState {
    Nullable<TargetStates> get ();
    void set (Nullable<TargetStates> value);
}
member ProtectionTargetState : Nullable<TargetStates> with get, set

Property Value

Type: Nullable TargetStates
The state of the protection target.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.RevertConnectionPersistedState Property

DTHVPersistedStateModelRevertConnectionPersistedState Property
Gets or sets the state of the replica vm revert persisted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionPersistedStateModel RevertConnectionPersistedState { get; set; }
Public Property RevertConnectionPersistedState As CoreConnectionPersistedStateModel
    Get
    Set
public:
property CoreConnectionPersistedStateModel^ RevertConnectionPersistedState {
    CoreConnectionPersistedStateModel^ get ();
    void set (CoreConnectionPersistedStateModel^ value);
}
member RevertConnectionPersistedState : CoreConnectionPersistedStateModel with get, set

Property Value

Type: CoreConnectionPersistedStateModel
The state of the Replica vm revert persisted.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.SourceEndpoint Property

DTHVPersistedStateModelSourceEndpoint Property
Gets or sets the source endpoint.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SourceEndpoint { get; set; }
Public Property SourceEndpoint As String
    Get
    Set
public:
property String^ SourceEndpoint {
    String^ get ();
    void set (String^ value);
}
member SourceEndpoint : string with get, set

Property Value

Type: String
The source endpoint.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.State Property

DTHVPersistedStateModelState Property
Gets or sets the state of the protection connection persisted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public JobStateModel State { get; set; }
Public Property State As JobStateModel
    Get
    Set
public:
property JobStateModel^ State {
    JobStateModel^ get ();
    void set (JobStateModel^ value);
}
member State : JobStateModel with get, set

Property Value

Type: JobStateModel
The state of the protection connection persisted.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.TargetRoute Property

DTHVPersistedStateModelTargetRoute Property
Gets or sets a value representing target route

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string TargetRoute { get; set; }
Public Property TargetRoute As String
    Get
    Set
public:
property String^ TargetRoute {
    String^ get ();
    void set (String^ value);
}
member TargetRoute : string with get, set

Property Value

Type: String
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.TargetVmCfgResourceName Property

DTHVPersistedStateModelTargetVmCfgResourceName Property
Gets or sets the name of the target vm CFG resource.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string TargetVmCfgResourceName { get; set; }
Public Property TargetVmCfgResourceName As String
    Get
    Set
public:
property String^ TargetVmCfgResourceName {
    String^ get ();
    void set (String^ value);
}
member TargetVmCfgResourceName : string with get, set

Property Value

Type: String
The name of the target vm CFG resource.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.TargetVMGuid Property

DTHVPersistedStateModelTargetVMGuid Property
Gets or sets the target vm unique identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string TargetVMGuid { get; set; }
Public Property TargetVMGuid As String
    Get
    Set
public:
property String^ TargetVMGuid {
    String^ get ();
    void set (String^ value);
}
member TargetVMGuid : string with get, set

Property Value

Type: String
The target vm unique identifier.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.TargetVmResourceName Property

DTHVPersistedStateModelTargetVmResourceName Property
Gets or sets the name of the target vm resource.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string TargetVmResourceName { get; set; }
Public Property TargetVmResourceName As String
    Get
    Set
public:
property String^ TargetVmResourceName {
    String^ get ();
    void set (String^ value);
}
member TargetVmResourceName : string with get, set

Property Value

Type: String
The name of the target vm resource.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.VhdMapping Property

DTHVPersistedStateModelVhdMapping Property
Gets or sets a value representing source and target VHD mappings

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VHDMappingModel[] VhdMapping { get; set; }
Public Property VhdMapping As VHDMappingModel()
    Get
    Set
public:
property array<VHDMappingModel^>^ VhdMapping {
    array<VHDMappingModel^>^ get ();
    void set (array<VHDMappingModel^>^ value);
}
member VhdMapping : VHDMappingModel[] with get, set

Property Value

Type: VHDMappingModel
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.VirtualSwitchMonitorPersistedState Property

DTHVPersistedStateModelVirtualSwitchMonitorPersistedState Property
Gets or sets the state of the monitor persisted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CoreMonitorPersistedStateModel VirtualSwitchMonitorPersistedState { get; set; }
Public Property VirtualSwitchMonitorPersistedState As CoreMonitorPersistedStateModel
    Get
    Set
public:
property CoreMonitorPersistedStateModel^ VirtualSwitchMonitorPersistedState {
    CoreMonitorPersistedStateModel^ get ();
    void set (CoreMonitorPersistedStateModel^ value);
}
member VirtualSwitchMonitorPersistedState : CoreMonitorPersistedStateModel with get, set

Property Value

Type: CoreMonitorPersistedStateModel
The state of the monitor persisted.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel.VMConfigMonitorPersistedState Property

DTHVPersistedStateModelVMConfigMonitorPersistedState Property
Gets or sets the state of the monitor persisted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CoreMonitorPersistedStateModel VMConfigMonitorPersistedState { get; set; }
Public Property VMConfigMonitorPersistedState As CoreMonitorPersistedStateModel
    Get
    Set
public:
property CoreMonitorPersistedStateModel^ VMConfigMonitorPersistedState {
    CoreMonitorPersistedStateModel^ get ();
    void set (CoreMonitorPersistedStateModel^ value);
}
member VMConfigMonitorPersistedState : CoreMonitorPersistedStateModel with get, set

Property Value

Type: CoreMonitorPersistedStateModel
The state of the vm config monitor persisted.
See Also

Reference

DTHVPersistedStateModel Class


DTHVPersistedStateModel Methods

DTHVPersistedStateModel Methods

The DTHVPersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DTHVPersistedStateModel Class


DtInfoCollectionProgressEnum Enumeration

DtInfoCollectionProgressEnum Enumeration
Double-Take information collection progress

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public enum DtInfoCollectionProgressEnum
Public Enumeration DtInfoCollectionProgressEnum
public enum class DtInfoCollectionProgressEnum
type DtInfoCollectionProgressEnum
Members
Member name | Value | Description
Generating | 0 | The generating
Buffering | 1 | The buffering
DataAvailable | 2 | The data available
Complete | 3 | The complete
Error | 4 | The error
Canceled | 5 | The canceled
See Also

Reference

DoubleTake.Web.Models Namespace


DtInfoCollectionStatusModel Class

DtInfoCollectionStatusModel Class
DTInfo collection status.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDtInfoCollectionStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class DtInfoCollectionStatusModel
Public Class DtInfoCollectionStatusModel
public ref class DtInfoCollectionStatusModel
type DtInfoCollectionStatusModel =  class end

The DtInfoCollectionStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | DtInfoCollectionStatusModel | Initializes a new instance of the DtInfoCollectionStatusModel class
Top
Properties
 | Name | Description
Public property | ArchiveName | Gets or sets the name of the archive.
Public property | Data | Gets or sets the data.
Public property | ErrorMessage | Gets or sets the error message.
Public property | Progress | Gets or sets the progress.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DtInfoCollectionStatusModel Constructor

DtInfoCollectionStatusModel Constructor
Initializes a new instance of the DtInfoCollectionStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DtInfoCollectionStatusModel()
Public Sub New
public:
DtInfoCollectionStatusModel()
new : unit -> DtInfoCollectionStatusModel
See Also

Reference

DtInfoCollectionStatusModel Class


DtInfoCollectionStatusModel Properties

DtInfoCollectionStatusModel Properties

The DtInfoCollectionStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | ArchiveName | Gets or sets the name of the archive.
Public property | Data | Gets or sets the data.
Public property | ErrorMessage | Gets or sets the error message.
Public property | Progress | Gets or sets the progress.
Top
See Also

Reference

DtInfoCollectionStatusModel Class


DtInfoCollectionStatusModel.ArchiveName Property

DtInfoCollectionStatusModelArchiveName Property
Gets or sets the name of the archive.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ArchiveName { get; set; }
Public Property ArchiveName As String
    Get
    Set
public:
property String^ ArchiveName {
    String^ get ();
    void set (String^ value);
}
member ArchiveName : string with get, set

Property Value

Type: String
The name of the archive.
See Also

Reference

DtInfoCollectionStatusModel Class


DtInfoCollectionStatusModel.Data Property

DtInfoCollectionStatusModelData Property
Gets or sets the data.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public byte[][] Data { get; set; }
Public Property Data As Byte()()
    Get
    Set
public:
property array<array<unsigned char>^>^ Data {
    array<array<unsigned char>^>^ get ();
    void set (array<array<unsigned char>^>^ value);
}
member Data : byte[][] with get, set

Property Value

Type: Byte
The data.
See Also

Reference

DtInfoCollectionStatusModel Class


DtInfoCollectionStatusModel.ErrorMessage Property

DtInfoCollectionStatusModelErrorMessage Property
Gets or sets the error message.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ErrorMessage { get; set; }
Public Property ErrorMessage As String
    Get
    Set
public:
property String^ ErrorMessage {
    String^ get ();
    void set (String^ value);
}
member ErrorMessage : string with get, set

Property Value

Type: String
The error message.
See Also

Reference

DtInfoCollectionStatusModel Class


DtInfoCollectionStatusModel.Progress Property

DtInfoCollectionStatusModelProgress Property
Gets or sets the progress.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DtInfoCollectionProgressEnum Progress { get; set; }
Public Property Progress As DtInfoCollectionProgressEnum
    Get
    Set
public:
property DtInfoCollectionProgressEnum Progress {
    DtInfoCollectionProgressEnum get ();
    void set (DtInfoCollectionProgressEnum value);
}
member Progress : DtInfoCollectionProgressEnum with get, set

Property Value

Type: DtInfoCollectionProgressEnum
The progress.
See Also

Reference

DtInfoCollectionStatusModel Class


DtInfoCollectionStatusModel Methods

DtInfoCollectionStatusModel Methods

The DtInfoCollectionStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DtInfoCollectionStatusModel Class


DtmuActivationStatusModel Class

DtmuActivationStatusModel Class
DTMU activation status.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDtmuActivationStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class DtmuActivationStatusModel
Public Class DtmuActivationStatusModel
public ref class DtmuActivationStatusModel
type DtmuActivationStatusModel =  class end

The DtmuActivationStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | DtmuActivationStatusModel | Initializes a new instance of the DtmuActivationStatusModel class
Top
Properties
 | Name | Description
Public property | Code | Gets or sets the code.
Public property | IsValid | Gets or sets a value indicating whether the status is valid.
Public property | MajorVersion | Gets or sets the major version.
Public property | MinorVersion | Gets or sets the minor version.
Public property | ProductCode | Gets or sets the product code.
Public property | ProductName | Gets or sets the name of the product.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DtmuActivationStatusModel Constructor

DtmuActivationStatusModel Constructor
Initializes a new instance of the DtmuActivationStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DtmuActivationStatusModel()
Public Sub New
public:
DtmuActivationStatusModel()
new : unit -> DtmuActivationStatusModel
See Also

Reference

DtmuActivationStatusModel Class


DtmuActivationStatusModel Properties

DtmuActivationStatusModel Properties

The DtmuActivationStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | Code | Gets or sets the code.
Public property | IsValid | Gets or sets a value indicating whether the status is valid.
Public property | MajorVersion | Gets or sets the major version.
Public property | MinorVersion | Gets or sets the minor version.
Public property | ProductCode | Gets or sets the product code.
Public property | ProductName | Gets or sets the name of the product.
Top
See Also

Reference

DtmuActivationStatusModel Class


DtmuActivationStatusModel.Code Property

DtmuActivationStatusModelCode Property
Gets or sets the code.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Code { get; set; }
Public Property Code As String
    Get
    Set
public:
property String^ Code {
    String^ get ();
    void set (String^ value);
}
member Code : string with get, set

Property Value

Type: String
The code.
See Also

Reference

DtmuActivationStatusModel Class


DtmuActivationStatusModel.IsValid Property

DtmuActivationStatusModelIsValid Property
Gets or sets a value indicating whether the status is valid.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsValid { get; set; }
Public Property IsValid As Boolean
    Get
    Set
public:
property bool IsValid {
    bool get ();
    void set (bool value);
}
member IsValid : bool with get, set

Property Value

Type: Boolean
if this instance is valid; otherwise, .
See Also

Reference

DtmuActivationStatusModel Class


DtmuActivationStatusModel.MajorVersion Property

DtmuActivationStatusModelMajorVersion Property
Gets or sets the major version.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int MajorVersion { get; set; }
Public Property MajorVersion As Integer
    Get
    Set
public:
property int MajorVersion {
    int get ();
    void set (int value);
}
member MajorVersion : int with get, set

Property Value

Type: Int32
The major version.
See Also

Reference

DtmuActivationStatusModel Class


DtmuActivationStatusModel.MinorVersion Property

DtmuActivationStatusModelMinorVersion Property
Gets or sets the minor version.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int MinorVersion { get; set; }
Public Property MinorVersion As Integer
    Get
    Set
public:
property int MinorVersion {
    int get ();
    void set (int value);
}
member MinorVersion : int with get, set

Property Value

Type: Int32
The minor version.
See Also

Reference

DtmuActivationStatusModel Class


DtmuActivationStatusModel.ProductCode Property

DtmuActivationStatusModelProductCode Property
Gets or sets the product code.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int ProductCode { get; set; }
Public Property ProductCode As Integer
    Get
    Set
public:
property int ProductCode {
    int get ();
    void set (int value);
}
member ProductCode : int with get, set

Property Value

Type: Int32
The product code.
See Also

Reference

DtmuActivationStatusModel Class


DtmuActivationStatusModel.ProductName Property

DtmuActivationStatusModelProductName Property
Gets or sets the name of the product.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ProductName { get; set; }
Public Property ProductName As String
    Get
    Set
public:
property String^ ProductName {
    String^ get ();
    void set (String^ value);
}
member ProductName : string with get, set

Property Value

Type: String
The name of the product.
See Also

Reference

DtmuActivationStatusModel Class


DtmuActivationStatusModel Methods

DtmuActivationStatusModel Methods

The DtmuActivationStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DtmuActivationStatusModel Class


DtmuConfigurationModel Class

DtmuConfigurationModel Class
DTMU configuration model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDtmuConfigurationModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public class DtmuConfigurationModel
Public Class DtmuConfigurationModel
public ref class DtmuConfigurationModel
type DtmuConfigurationModel =  class end

The DtmuConfigurationModel type exposes the following members.

Constructors
 | Name | Description
Public method | DtmuConfigurationModel | Initializes a new instance of the DtmuConfigurationModel class
Top
Properties
 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether Dtmu has been enabled.
Public property | ProductCode | Gets or sets the product code.
Public property | ProviderName | Gets or sets the name of the provider.
Public property | UserName | Gets or sets the name of the user.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DtmuConfigurationModel Constructor

DtmuConfigurationModel Constructor
Initializes a new instance of the DtmuConfigurationModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DtmuConfigurationModel()
Public Sub New
public:
DtmuConfigurationModel()
new : unit -> DtmuConfigurationModel
See Also

Reference

DtmuConfigurationModel Class


DtmuConfigurationModel Properties

DtmuConfigurationModel Properties

The DtmuConfigurationModel type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets or sets a value indicating whether Dtmu has been enabled.
Public property | ProductCode | Gets or sets the product code.
Public property | ProviderName | Gets or sets the name of the provider.
Public property | UserName | Gets or sets the name of the user.
Top
See Also

Reference

DtmuConfigurationModel Class


DtmuConfigurationModel.Enabled Property

DtmuConfigurationModelEnabled Property
Gets or sets a value indicating whether Dtmu has been enabled.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
Remarks
When setting configuration, this value is ignored and will always be set to true. When getting the configuration, this value is the value obtained from the configuration file.
See Also

Reference

DtmuConfigurationModel Class


DtmuConfigurationModel.ProductCode Property

DtmuConfigurationModelProductCode Property
Gets or sets the product code.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int ProductCode { get; set; }
Public Property ProductCode As Integer
    Get
    Set
public:
property int ProductCode {
    int get ();
    void set (int value);
}
member ProductCode : int with get, set

Property Value

Type: Int32
The product code.
See Also

Reference

DtmuConfigurationModel Class


DtmuConfigurationModel.ProviderName Property

DtmuConfigurationModelProviderName Property
Gets or sets the name of the provider.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ProviderName { get; set; }
Public Property ProviderName As String
    Get
    Set
public:
property String^ ProviderName {
    String^ get ();
    void set (String^ value);
}
member ProviderName : string with get, set

Property Value

Type: String
The name of the provider.
See Also

Reference

DtmuConfigurationModel Class


DtmuConfigurationModel.UserName Property

DtmuConfigurationModelUserName Property
Gets or sets the name of the user.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
member UserName : string with get, set

Property Value

Type: String
The name of the user.
See Also

Reference

DtmuConfigurationModel Class


DtmuConfigurationModel Methods

DtmuConfigurationModel Methods

The DtmuConfigurationModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DtmuConfigurationModel Class


DtmuJobStatusEnum Enumeration

DtmuJobStatusEnum Enumeration
DTMU job status

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public enum DtmuJobStatusEnum
Public Enumeration DtmuJobStatusEnum
public enum class DtmuJobStatusEnum
type DtmuJobStatusEnum
Members
Member name | Value | Description
Unknown | 0 | The unknown
Ok | 1 | The ok
SourceConnectivityError | 2 | The source connectivity error
Error | 3 | The error
See Also

Reference

DoubleTake.Web.Models Namespace


DtmuProductModel Class

DtmuProductModel Class
DTMU product model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDtmuProductModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public class DtmuProductModel
Public Class DtmuProductModel
public ref class DtmuProductModel
type DtmuProductModel =  class end

The DtmuProductModel type exposes the following members.

Constructors
 | Name | Description
Public method | DtmuProductModel | Initializes a new instance of the DtmuProductModel class
Top
Properties
 | Name | Description
Public property | ProductCode | Gets or sets the product code.
Public property | ProductName | Gets or sets the name of the product.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DtmuProductModel Constructor

DtmuProductModel Constructor
Initializes a new instance of the DtmuProductModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DtmuProductModel()
Public Sub New
public:
DtmuProductModel()
new : unit -> DtmuProductModel
See Also

Reference

DtmuProductModel Class


DtmuProductModel Properties

DtmuProductModel Properties

The DtmuProductModel type exposes the following members.

Properties
 | Name | Description
Public property | ProductCode | Gets or sets the product code.
Public property | ProductName | Gets or sets the name of the product.
Top
See Also

Reference

DtmuProductModel Class


DtmuProductModel.ProductCode Property

DtmuProductModelProductCode Property
Gets or sets the product code.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int ProductCode { get; set; }
Public Property ProductCode As Integer
    Get
    Set
public:
property int ProductCode {
    int get ();
    void set (int value);
}
member ProductCode : int with get, set

Property Value

Type: Int32
The product code.
See Also

Reference

DtmuProductModel Class


DtmuProductModel.ProductName Property

DtmuProductModelProductName Property
Gets or sets the name of the product.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ProductName { get; set; }
Public Property ProductName As String
    Get
    Set
public:
property String^ ProductName {
    String^ get ();
    void set (String^ value);
}
member ProductName : string with get, set

Property Value

Type: String
The name of the product.
See Also

Reference

DtmuProductModel Class


DtmuProductModel Methods

DtmuProductModel Methods

The DtmuProductModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DtmuProductModel Class


DtscStatusQueryInputModel Class

DtscStatusQueryInputModel Class
Inputs for a DtscStatus monitor
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsDtscStatusQueryInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class DtscStatusQueryInputModel : QueryInputModel
Public Class DtscStatusQueryInputModel
    Inherits QueryInputModel
public ref class DtscStatusQueryInputModel : public QueryInputModel
type DtscStatusQueryInputModel =
    class
        inherit QueryInputModel
    end

The DtscStatusQueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | DtscStatusQueryInputModel | Initializes a new instance of the DtscStatusQueryInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | ReplicationSetName | Gets or sets the name of the replication set.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryInputModel


DtscStatusQueryInputModel Constructor

DtscStatusQueryInputModel Constructor
Initializes a new instance of the DtscStatusQueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DtscStatusQueryInputModel()
Public Sub New
public:
DtscStatusQueryInputModel()
new : unit -> DtscStatusQueryInputModel
See Also

Reference

DtscStatusQueryInputModel Class


DtscStatusQueryInputModel Properties

DtscStatusQueryInputModel Properties

The DtscStatusQueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | ReplicationSetName | Gets or sets the name of the replication set.
Top
See Also

Reference

DtscStatusQueryInputModel Class


DtscStatusQueryInputModel.ReplicationSetName Property

DtscStatusQueryInputModelReplicationSetName Property
Gets or sets the name of the replication set.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ReplicationSetName { get; set; }
Public Property ReplicationSetName As String
    Get
    Set
public:
property String^ ReplicationSetName {
    String^ get ();
    void set (String^ value);
}
member ReplicationSetName : string with get, set

Property Value

Type: String
The name of the replication set.
See Also

Reference

DtscStatusQueryInputModel Class


DtscStatusQueryInputModel Methods

DtscStatusQueryInputModel Methods

The DtscStatusQueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DtscStatusQueryInputModel Class


DtscStatusQueryResultModel Class

DtscStatusQueryResultModel Class
Represents the results of a Dtsc status query.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultModel
DoubleTake.Web.ModelsDtscStatusQueryResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class DtscStatusQueryResultModel : QueryResultModel
Public Class DtscStatusQueryResultModel
    Inherits QueryResultModel
public ref class DtscStatusQueryResultModel : public QueryResultModel
type DtscStatusQueryResultModel =
    class
        inherit QueryResultModel
    end

The DtscStatusQueryResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | DtscStatusQueryResultModel | Initializes a new instance of the DtscStatusQueryResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | OwningNode | Gets or sets the owning node.
Public property | ResourceState | Gets or sets the state of the resource.
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryResultModel


DtscStatusQueryResultModel Constructor

DtscStatusQueryResultModel Constructor
Initializes a new instance of the DtscStatusQueryResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DtscStatusQueryResultModel()
Public Sub New
public:
DtscStatusQueryResultModel()
new : unit -> DtscStatusQueryResultModel
See Also

Reference

DtscStatusQueryResultModel Class


DtscStatusQueryResultModel Properties

DtscStatusQueryResultModel Properties

The DtscStatusQueryResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | OwningNode | Gets or sets the owning node.
Public property | ResourceState | Gets or sets the state of the resource.
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Top
See Also

Reference

DtscStatusQueryResultModel Class


DtscStatusQueryResultModel.OwningNode Property

DtscStatusQueryResultModelOwningNode Property
Gets or sets the owning node.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string OwningNode { get; set; }
Public Property OwningNode As String
    Get
    Set
public:
property String^ OwningNode {
    String^ get ();
    void set (String^ value);
}
member OwningNode : string with get, set

Property Value

Type: String
The owning node.
See Also

Reference

DtscStatusQueryResultModel Class


DtscStatusQueryResultModel.ResourceState Property

DtscStatusQueryResultModelResourceState Property
Gets or sets the state of the resource.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int ResourceState { get; set; }
Public Property ResourceState As Integer
    Get
    Set
public:
property int ResourceState {
    int get ();
    void set (int value);
}
member ResourceState : int with get, set

Property Value

Type: Int32
The state of the resource.
See Also

Reference

DtscStatusQueryResultModel Class


DtscStatusQueryResultModel Methods

DtscStatusQueryResultModel Methods

The DtscStatusQueryResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DtscStatusQueryResultModel Class


DTTargetResourceQueryInputModel Class

DTTargetResourceQueryInputModel Class
The Input parameters to monitor a resource on a Target machine
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsDTTargetResourceQueryInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class DTTargetResourceQueryInputModel : QueryInputModel
Public Class DTTargetResourceQueryInputModel
    Inherits QueryInputModel
public ref class DTTargetResourceQueryInputModel : public QueryInputModel
type DTTargetResourceQueryInputModel =
    class
        inherit QueryInputModel
    end

The DTTargetResourceQueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | DTTargetResourceQueryInputModel | Initializes a new instance of the DTTargetResourceQueryInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | JobId | Gets or sets the job identifier.
Public property | ResourceName | Gets or sets the name of the resource.
Public property | TargetHostName | Gets or sets the name of the target host.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryInputModel


DTTargetResourceQueryInputModel Constructor

DTTargetResourceQueryInputModel Constructor
Initializes a new instance of the DTTargetResourceQueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DTTargetResourceQueryInputModel()
Public Sub New
public:
DTTargetResourceQueryInputModel()
new : unit -> DTTargetResourceQueryInputModel
See Also

Reference

DTTargetResourceQueryInputModel Class


DTTargetResourceQueryInputModel Properties

DTTargetResourceQueryInputModel Properties

The DTTargetResourceQueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | JobId | Gets or sets the job identifier.
Public property | ResourceName | Gets or sets the name of the resource.
Public property | TargetHostName | Gets or sets the name of the target host.
Top
See Also

Reference

DTTargetResourceQueryInputModel Class


DTTargetResourceQueryInputModel.JobId Property

DTTargetResourceQueryInputModelJobId Property
Gets or sets the job identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string JobId { get; set; }
Public Property JobId As String
    Get
    Set
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}
member JobId : string with get, set

Property Value

Type: String
The job identifier.
See Also

Reference

DTTargetResourceQueryInputModel Class


DTTargetResourceQueryInputModel.ResourceName Property

DTTargetResourceQueryInputModelResourceName Property
Gets or sets the name of the resource.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ResourceName { get; set; }
Public Property ResourceName As String
    Get
    Set
public:
property String^ ResourceName {
    String^ get ();
    void set (String^ value);
}
member ResourceName : string with get, set

Property Value

Type: String
The name of the resource.
See Also

Reference

DTTargetResourceQueryInputModel Class


DTTargetResourceQueryInputModel.TargetHostName Property

DTTargetResourceQueryInputModelTargetHostName Property
Gets or sets the name of the target host.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string TargetHostName { get; set; }
Public Property TargetHostName As String
    Get
    Set
public:
property String^ TargetHostName {
    String^ get ();
    void set (String^ value);
}
member TargetHostName : string with get, set

Property Value

Type: String
The name of the target host.
See Also

Reference

DTTargetResourceQueryInputModel Class


DTTargetResourceQueryInputModel Methods

DTTargetResourceQueryInputModel Methods

The DTTargetResourceQueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DTTargetResourceQueryInputModel Class


DynamicServiceEndpointModel Class

DynamicServiceEndpointModel Class
Dynamic service endpoint model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsDynamicServiceEndpointModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class DynamicServiceEndpointModel
Public NotInheritable Class DynamicServiceEndpointModel
public ref class DynamicServiceEndpointModel sealed
[<SealedAttribute>]
type DynamicServiceEndpointModel =  class end

The DynamicServiceEndpointModel type exposes the following members.

Constructors
 | Name | Description
Public method | DynamicServiceEndpointModel | Initializes a new instance of the DynamicServiceEndpointModel class
Top
Properties
 | Name | Description
Public property | Port | Gets or sets port where the service is hosted.
Public property | ProtocolTags | Gets or sets attributes and information necessary to connect.
Public property | RelativeUri | Gets or sets relative uri where the service is hosted.
Public property | ServiceTag | Gets or sets service tag associated with the endpoint.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


DynamicServiceEndpointModel Constructor

DynamicServiceEndpointModel Constructor
Initializes a new instance of the DynamicServiceEndpointModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DynamicServiceEndpointModel()
Public Sub New
public:
DynamicServiceEndpointModel()
new : unit -> DynamicServiceEndpointModel
See Also

Reference

DynamicServiceEndpointModel Class


DynamicServiceEndpointModel Properties

DynamicServiceEndpointModel Properties

The DynamicServiceEndpointModel type exposes the following members.

Properties
 | Name | Description
Public property | Port | Gets or sets port where the service is hosted.
Public property | ProtocolTags | Gets or sets attributes and information necessary to connect.
Public property | RelativeUri | Gets or sets relative uri where the service is hosted.
Public property | ServiceTag | Gets or sets service tag associated with the endpoint.
Top
See Also

Reference

DynamicServiceEndpointModel Class


DynamicServiceEndpointModel.Port Property

DynamicServiceEndpointModelPort Property
Gets or sets port where the service is hosted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int Port { get; set; }
Public Property Port As Integer
    Get
    Set
public:
property int Port {
    int get ();
    void set (int value);
}
member Port : int with get, set

Property Value

Type: Int32
See Also

Reference

DynamicServiceEndpointModel Class


DynamicServiceEndpointModel.ProtocolTags Property

DynamicServiceEndpointModelProtocolTags Property
Gets or sets attributes and information necessary to connect.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> ProtocolTags { get; set; }
Public Property ProtocolTags As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ ProtocolTags {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member ProtocolTags : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
Remarks
This list of protocol tags is intended to be a hint to clients. It may include schemes, authentication models, protocols necessary to connect to the service.
See Also

Reference

DynamicServiceEndpointModel Class


DynamicServiceEndpointModel.RelativeUri Property

DynamicServiceEndpointModelRelativeUri Property
Gets or sets relative uri where the service is hosted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string RelativeUri { get; set; }
Public Property RelativeUri As String
    Get
    Set
public:
property String^ RelativeUri {
    String^ get ();
    void set (String^ value);
}
member RelativeUri : string with get, set

Property Value

Type: String
See Also

Reference

DynamicServiceEndpointModel Class


DynamicServiceEndpointModel.ServiceTag Property

DynamicServiceEndpointModelServiceTag Property
Gets or sets service tag associated with the endpoint.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ServiceTag { get; set; }
Public Property ServiceTag As String
    Get
    Set
public:
property String^ ServiceTag {
    String^ get ();
    void set (String^ value);
}
member ServiceTag : string with get, set

Property Value

Type: String
See Also

Reference

DynamicServiceEndpointModel Class


DynamicServiceEndpointModel Methods

DynamicServiceEndpointModel Methods

The DynamicServiceEndpointModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DynamicServiceEndpointModel Class


EmailNotificationCategoriesEnum Enumeration

EmailNotificationCategoriesEnum Enumeration
Email notification categories

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public enum EmailNotificationCategoriesEnum
Public Enumeration EmailNotificationCategoriesEnum
public enum class EmailNotificationCategoriesEnum
type EmailNotificationCategoriesEnum
Members
Member name | Value | Description
None | 0 | None
Information | 1 | Information
Warning | 2 | Warning
Error | 4 | Error
All | 255 | All
See Also

Reference

DoubleTake.Web.Models Namespace


EmailNotificationSettingsModel Class

EmailNotificationSettingsModel Class
Email notification settings model
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsEmailNotificationSettingsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class EmailNotificationSettingsModel
Public NotInheritable Class EmailNotificationSettingsModel
public ref class EmailNotificationSettingsModel sealed
[<SealedAttribute>]
type EmailNotificationSettingsModel =  class end

The EmailNotificationSettingsModel type exposes the following members.

Constructors
 | Name | Description
Public method | EmailNotificationSettingsModel | Initializes a new instance of the EmailNotificationSettingsModel class
Top
Properties
 | Name | Description
Public property | Categories | Gets or sets the Double-Take "EmailIncludeCategories" registry setting.
Public property | ExcludeIds | Gets or sets the Double-Take "EmailExcludeIds" registry setting.
Public property | FromAddress | Gets or sets the Double-Take "EmailFromAddress" registry setting.
Public property | IsEnabled | Gets or sets a value indicating whether the Double-Take "EmailEnabled" registry setting is true.
Public property | IsEventDescriptionInSubject | Gets or sets a value indicating whether the Double-Take "EmailSubjectDesc" registry setting is true.
Public property | IsSmtpLogOnEnabled | Gets or sets a value indicating whether the Double-Take "EmailSmtpLogin" registry setting is true.
Public property | Password | Gets or sets the Double-Take "EmailPassword" registry setting.
Public property | Port | Gets or sets the Double-Take "EmailServerPort" registry setting.
Public property | Recipients | Gets or sets the Double-Take "EmailNotificationList" registry setting.
Public property | Server | Gets or sets the Double-Take "EmailServer" registry setting.
Public property | SubjectPrefix | Gets or sets the Double-Take "EmailSubjectPrefix" registry setting.
Public property | UserName | Gets or sets the Double-Take "EmailUsername" registry setting.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


EmailNotificationSettingsModel Constructor

EmailNotificationSettingsModel Constructor
Initializes a new instance of the EmailNotificationSettingsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public EmailNotificationSettingsModel()
Public Sub New
public:
EmailNotificationSettingsModel()
new : unit -> EmailNotificationSettingsModel
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel Properties

EmailNotificationSettingsModel Properties

The EmailNotificationSettingsModel type exposes the following members.

Properties
 | Name | Description
Public property | Categories | Gets or sets the Double-Take "EmailIncludeCategories" registry setting.
Public property | ExcludeIds | Gets or sets the Double-Take "EmailExcludeIds" registry setting.
Public property | FromAddress | Gets or sets the Double-Take "EmailFromAddress" registry setting.
Public property | IsEnabled | Gets or sets a value indicating whether the Double-Take "EmailEnabled" registry setting is true.
Public property | IsEventDescriptionInSubject | Gets or sets a value indicating whether the Double-Take "EmailSubjectDesc" registry setting is true.
Public property | IsSmtpLogOnEnabled | Gets or sets a value indicating whether the Double-Take "EmailSmtpLogin" registry setting is true.
Public property | Password | Gets or sets the Double-Take "EmailPassword" registry setting.
Public property | Port | Gets or sets the Double-Take "EmailServerPort" registry setting.
Public property | Recipients | Gets or sets the Double-Take "EmailNotificationList" registry setting.
Public property | Server | Gets or sets the Double-Take "EmailServer" registry setting.
Public property | SubjectPrefix | Gets or sets the Double-Take "EmailSubjectPrefix" registry setting.
Public property | UserName | Gets or sets the Double-Take "EmailUsername" registry setting.
Top
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel.Categories Property

EmailNotificationSettingsModelCategories Property
Gets or sets the Double-Take "EmailIncludeCategories" registry setting.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public EmailNotificationCategoriesEnum Categories { get; set; }
Public Property Categories As EmailNotificationCategoriesEnum
    Get
    Set
public:
property EmailNotificationCategoriesEnum Categories {
    EmailNotificationCategoriesEnum get ();
    void set (EmailNotificationCategoriesEnum value);
}
member Categories : EmailNotificationCategoriesEnum with get, set

Property Value

Type: EmailNotificationCategoriesEnum
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel.ExcludeIds Property

EmailNotificationSettingsModelExcludeIds Property
Gets or sets the Double-Take "EmailExcludeIds" registry setting.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string[] ExcludeIds { get; set; }
Public Property ExcludeIds As String()
    Get
    Set
public:
property array<String^>^ ExcludeIds {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member ExcludeIds : string[] with get, set

Property Value

Type: String
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel.FromAddress Property

EmailNotificationSettingsModelFromAddress Property
Gets or sets the Double-Take "EmailFromAddress" registry setting.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string FromAddress { get; set; }
Public Property FromAddress As String
    Get
    Set
public:
property String^ FromAddress {
    String^ get ();
    void set (String^ value);
}
member FromAddress : string with get, set

Property Value

Type: String
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel.IsEnabled Property

EmailNotificationSettingsModelIsEnabled Property
Gets or sets a value indicating whether the Double-Take "EmailEnabled" registry setting is true.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsEnabled { get; set; }
Public Property IsEnabled As Boolean
    Get
    Set
public:
property bool IsEnabled {
    bool get ();
    void set (bool value);
}
member IsEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel.IsEventDescriptionInSubject Property

EmailNotificationSettingsModelIsEventDescriptionInSubject Property
Gets or sets a value indicating whether the Double-Take "EmailSubjectDesc" registry setting is true.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsEventDescriptionInSubject { get; set; }
Public Property IsEventDescriptionInSubject As Boolean
    Get
    Set
public:
property bool IsEventDescriptionInSubject {
    bool get ();
    void set (bool value);
}
member IsEventDescriptionInSubject : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel.IsSmtpLogOnEnabled Property

EmailNotificationSettingsModelIsSmtpLogOnEnabled Property
Gets or sets a value indicating whether the Double-Take "EmailSmtpLogin" registry setting is true.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsSmtpLogOnEnabled { get; set; }
Public Property IsSmtpLogOnEnabled As Boolean
    Get
    Set
public:
property bool IsSmtpLogOnEnabled {
    bool get ();
    void set (bool value);
}
member IsSmtpLogOnEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel.Password Property

EmailNotificationSettingsModelPassword Property
Gets or sets the Double-Take "EmailPassword" registry setting.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}
member Password : string with get, set

Property Value

Type: String
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel.Port Property

EmailNotificationSettingsModelPort Property
Gets or sets the Double-Take "EmailServerPort" registry setting.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int Port { get; set; }
Public Property Port As Integer
    Get
    Set
public:
property int Port {
    int get ();
    void set (int value);
}
member Port : int with get, set

Property Value

Type: Int32
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel.Recipients Property

EmailNotificationSettingsModelRecipients Property
Gets or sets the Double-Take "EmailNotificationList" registry setting.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string[] Recipients { get; set; }
Public Property Recipients As String()
    Get
    Set
public:
property array<String^>^ Recipients {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member Recipients : string[] with get, set

Property Value

Type: String
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel.Server Property

EmailNotificationSettingsModelServer Property
Gets or sets the Double-Take "EmailServer" registry setting.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Server { get; set; }
Public Property Server As String
    Get
    Set
public:
property String^ Server {
    String^ get ();
    void set (String^ value);
}
member Server : string with get, set

Property Value

Type: String
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel.SubjectPrefix Property

EmailNotificationSettingsModelSubjectPrefix Property
Gets or sets the Double-Take "EmailSubjectPrefix" registry setting.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SubjectPrefix { get; set; }
Public Property SubjectPrefix As String
    Get
    Set
public:
property String^ SubjectPrefix {
    String^ get ();
    void set (String^ value);
}
member SubjectPrefix : string with get, set

Property Value

Type: String
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel.UserName Property

EmailNotificationSettingsModelUserName Property
Gets or sets the Double-Take "EmailUsername" registry setting.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
member UserName : string with get, set

Property Value

Type: String
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationSettingsModel Methods

EmailNotificationSettingsModel Methods

The EmailNotificationSettingsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EmailNotificationSettingsModel Class


EmailNotificationTestParametersModel Class

EmailNotificationTestParametersModel Class
Email notification test parameters.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsEmailNotificationTestParametersModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class EmailNotificationTestParametersModel
Public Class EmailNotificationTestParametersModel
public ref class EmailNotificationTestParametersModel
type EmailNotificationTestParametersModel =  class end

The EmailNotificationTestParametersModel type exposes the following members.

Constructors
 | Name | Description
Public method | EmailNotificationTestParametersModel | Initializes a new instance of the EmailNotificationTestParametersModel class
Top
Properties
 | Name | Description
Public property | BodyText | Gets or sets the body text.
Public property | Recipients | Gets or sets the recipients.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


EmailNotificationTestParametersModel Constructor

EmailNotificationTestParametersModel Constructor
Initializes a new instance of the EmailNotificationTestParametersModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public EmailNotificationTestParametersModel()
Public Sub New
public:
EmailNotificationTestParametersModel()
new : unit -> EmailNotificationTestParametersModel
See Also

Reference

EmailNotificationTestParametersModel Class


EmailNotificationTestParametersModel Properties

EmailNotificationTestParametersModel Properties

The EmailNotificationTestParametersModel type exposes the following members.

Properties
 | Name | Description
Public property | BodyText | Gets or sets the body text.
Public property | Recipients | Gets or sets the recipients.
Top
See Also

Reference

EmailNotificationTestParametersModel Class


EmailNotificationTestParametersModel.BodyText Property

EmailNotificationTestParametersModelBodyText Property
Gets or sets the body text.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string BodyText { get; set; }
Public Property BodyText As String
    Get
    Set
public:
property String^ BodyText {
    String^ get ();
    void set (String^ value);
}
member BodyText : string with get, set

Property Value

Type: String
See Also

Reference

EmailNotificationTestParametersModel Class


EmailNotificationTestParametersModel.Recipients Property

EmailNotificationTestParametersModelRecipients Property
Gets or sets the recipients.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string[] Recipients { get; set; }
Public Property Recipients As String()
    Get
    Set
public:
property array<String^>^ Recipients {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member Recipients : string[] with get, set

Property Value

Type: String
See Also

Reference

EmailNotificationTestParametersModel Class


EmailNotificationTestParametersModel Methods

EmailNotificationTestParametersModel Methods

The EmailNotificationTestParametersModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EmailNotificationTestParametersModel Class


EmailOptionsModel Class

EmailOptionsModel Class
Email options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsEmailOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class EmailOptionsModel
Public NotInheritable Class EmailOptionsModel
public ref class EmailOptionsModel sealed
[<SealedAttribute>]
type EmailOptionsModel =  class end

The EmailOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | EmailOptionsModel | Initializes a new instance of the EmailOptionsModel class
Top
Properties
 | Name | Description
Public property | ConnectionSecurity | Gets or sets connection security.
Public property | Enabled | Gets or sets a value indicating whether or not e-mail notifications are enabled.
Public property | EntryIdFilter | Gets or sets entry id filter.
Public property | EntryTypeFilter | Gets or sets value that specifies one or more comma-delimited Windows Event Log entry types (Error, Warning, etc.) for which e-mail notifications should be sent.
Public property | From | Gets or sets email address that will be placed in the From field of the e-mail message.
Public property | IncludeEventDescriptionInSubject | Gets or sets a value indicating whether or not to include the event description in the subject of the notification e-mails.
Public property | LoginRequired | Gets or sets a value indicating whether to login to the SMTP server or not.
Public property | SmtpCredentials | Gets or sets the SMTP credentials - missing to use the SMTP server anonymously.
Public property | SmtpPort | Gets or sets the SMTP port - missing to use the default SMTP port (25).
Public property | SmtpServer | Gets or sets the SMTP server.
Public property | SubjectPrefix | Gets or sets text that will be added to the beginning of the e-mail subject.
Public property | To | Gets or sets one or more comma-delimited e-mail addresses to which the e-mail notifications will be sent.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


EmailOptionsModel Constructor

EmailOptionsModel Constructor
Initializes a new instance of the EmailOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public EmailOptionsModel()
Public Sub New
public:
EmailOptionsModel()
new : unit -> EmailOptionsModel
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel Properties

EmailOptionsModel Properties

The EmailOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionSecurity | Gets or sets connection security.
Public property | Enabled | Gets or sets a value indicating whether or not e-mail notifications are enabled.
Public property | EntryIdFilter | Gets or sets entry id filter.
Public property | EntryTypeFilter | Gets or sets value that specifies one or more comma-delimited Windows Event Log entry types (Error, Warning, etc.) for which e-mail notifications should be sent.
Public property | From | Gets or sets email address that will be placed in the From field of the e-mail message.
Public property | IncludeEventDescriptionInSubject | Gets or sets a value indicating whether or not to include the event description in the subject of the notification e-mails.
Public property | LoginRequired | Gets or sets a value indicating whether to login to the SMTP server or not.
Public property | SmtpCredentials | Gets or sets the SMTP credentials - missing to use the SMTP server anonymously.
Public property | SmtpPort | Gets or sets the SMTP port - missing to use the default SMTP port (25).
Public property | SmtpServer | Gets or sets the SMTP server.
Public property | SubjectPrefix | Gets or sets text that will be added to the beginning of the e-mail subject.
Public property | To | Gets or sets one or more comma-delimited e-mail addresses to which the e-mail notifications will be sent.
Top
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel.ConnectionSecurity Property

EmailOptionsModelConnectionSecurity Property
Gets or sets connection security.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public SmtpConnectionSecurity ConnectionSecurity { get; set; }
Public Property ConnectionSecurity As SmtpConnectionSecurity
    Get
    Set
public:
property SmtpConnectionSecurity ConnectionSecurity {
    SmtpConnectionSecurity get ();
    void set (SmtpConnectionSecurity value);
}
member ConnectionSecurity : SmtpConnectionSecurity with get, set

Property Value

Type: SmtpConnectionSecurity
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel.Enabled Property

EmailOptionsModelEnabled Property
Gets or sets a value indicating whether or not e-mail notifications are enabled.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}
member Enabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel.EntryIdFilter Property

EmailOptionsModelEntryIdFilter Property
Gets or sets entry id filter.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string EntryIdFilter { get; set; }
Public Property EntryIdFilter As String
    Get
    Set
public:
property String^ EntryIdFilter {
    String^ get ();
    void set (String^ value);
}
member EntryIdFilter : string with get, set

Property Value

Type: String
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel.EntryTypeFilter Property

EmailOptionsModelEntryTypeFilter Property
Gets or sets value that specifies one or more comma-delimited Windows Event Log entry types (Error, Warning, etc.) for which e-mail notifications should be sent.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string EntryTypeFilter { get; set; }
Public Property EntryTypeFilter As String
    Get
    Set
public:
property String^ EntryTypeFilter {
    String^ get ();
    void set (String^ value);
}
member EntryTypeFilter : string with get, set

Property Value

Type: String
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel.From Property

EmailOptionsModelFrom Property
Gets or sets email address that will be placed in the From field of the e-mail message.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string From { get; set; }
Public Property From As String
    Get
    Set
public:
property String^ From {
    String^ get ();
    void set (String^ value);
}
member From : string with get, set

Property Value

Type: String
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel.IncludeEventDescriptionInSubject Property

EmailOptionsModelIncludeEventDescriptionInSubject Property
Gets or sets a value indicating whether or not to include the event description in the subject of the notification e-mails.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IncludeEventDescriptionInSubject { get; set; }
Public Property IncludeEventDescriptionInSubject As Boolean
    Get
    Set
public:
property bool IncludeEventDescriptionInSubject {
    bool get ();
    void set (bool value);
}
member IncludeEventDescriptionInSubject : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel.LoginRequired Property

EmailOptionsModelLoginRequired Property
Gets or sets a value indicating whether to login to the SMTP server or not.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool LoginRequired { get; set; }
Public Property LoginRequired As Boolean
    Get
    Set
public:
property bool LoginRequired {
    bool get ();
    void set (bool value);
}
member LoginRequired : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel.SmtpCredentials Property

EmailOptionsModelSmtpCredentials Property
Gets or sets the SMTP credentials - missing to use the SMTP server anonymously.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CredentialModel SmtpCredentials { get; set; }
Public Property SmtpCredentials As CredentialModel
    Get
    Set
public:
property CredentialModel^ SmtpCredentials {
    CredentialModel^ get ();
    void set (CredentialModel^ value);
}
member SmtpCredentials : CredentialModel with get, set

Property Value

Type: CredentialModel
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel.SmtpPort Property

EmailOptionsModelSmtpPort Property
Gets or sets the SMTP port - missing to use the default SMTP port (25).

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> SmtpPort { get; set; }
Public Property SmtpPort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> SmtpPort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member SmtpPort : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel.SmtpServer Property

EmailOptionsModelSmtpServer Property
Gets or sets the SMTP server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SmtpServer { get; set; }
Public Property SmtpServer As String
    Get
    Set
public:
property String^ SmtpServer {
    String^ get ();
    void set (String^ value);
}
member SmtpServer : string with get, set

Property Value

Type: String
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel.SubjectPrefix Property

EmailOptionsModelSubjectPrefix Property
Gets or sets text that will be added to the beginning of the e-mail subject.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SubjectPrefix { get; set; }
Public Property SubjectPrefix As String
    Get
    Set
public:
property String^ SubjectPrefix {
    String^ get ();
    void set (String^ value);
}
member SubjectPrefix : string with get, set

Property Value

Type: String
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel.To Property

EmailOptionsModelTo Property
Gets or sets one or more comma-delimited e-mail addresses to which the e-mail notifications will be sent.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string To { get; set; }
Public Property To As String
    Get
    Set
public:
property String^ To {
    String^ get ();
    void set (String^ value);
}
member To : string with get, set

Property Value

Type: String
See Also

Reference

EmailOptionsModel Class


EmailOptionsModel Methods

EmailOptionsModel Methods

The EmailOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EmailOptionsModel Class


EmailTestModel Class

EmailTestModel Class
Email test model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsEmailTestModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public class EmailTestModel
Public Class EmailTestModel
public ref class EmailTestModel
type EmailTestModel =  class end

The EmailTestModel type exposes the following members.

Constructors
 | Name | Description
Public method | EmailTestModel | Initializes a new instance of the EmailTestModel class
Top
Properties
 | Name | Description
Public property | Body | Gets or sets the email body.
Public property | Options | Gets or sets the email options.
Public property | To | Gets or sets the recipient list.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


EmailTestModel Constructor

EmailTestModel Constructor
Initializes a new instance of the EmailTestModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public EmailTestModel()
Public Sub New
public:
EmailTestModel()
new : unit -> EmailTestModel
See Also

Reference

EmailTestModel Class


EmailTestModel Properties

EmailTestModel Properties

The EmailTestModel type exposes the following members.

Properties
 | Name | Description
Public property | Body | Gets or sets the email body.
Public property | Options | Gets or sets the email options.
Public property | To | Gets or sets the recipient list.
Top
See Also

Reference

EmailTestModel Class


EmailTestModel.Body Property

EmailTestModelBody Property
Gets or sets the email body.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Body { get; set; }
Public Property Body As String
    Get
    Set
public:
property String^ Body {
    String^ get ();
    void set (String^ value);
}
member Body : string with get, set

Property Value

Type: String
See Also

Reference

EmailTestModel Class


EmailTestModel.Options Property

EmailTestModelOptions Property
Gets or sets the email options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public EmailOptionsModel Options { get; set; }
Public Property Options As EmailOptionsModel
    Get
    Set
public:
property EmailOptionsModel^ Options {
    EmailOptionsModel^ get ();
    void set (EmailOptionsModel^ value);
}
member Options : EmailOptionsModel with get, set

Property Value

Type: EmailOptionsModel
See Also

Reference

EmailTestModel Class


EmailTestModel.To Property

EmailTestModelTo Property
Gets or sets the recipient list.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string To { get; set; }
Public Property To As String
    Get
    Set
public:
property String^ To {
    String^ get ();
    void set (String^ value);
}
member To : string with get, set

Property Value

Type: String
See Also

Reference

EmailTestModel Class


EmailTestModel Methods

EmailTestModel Methods

The EmailTestModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EmailTestModel Class


EngineControlStatusModel Class

EngineControlStatusModel Class
Engine control status model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsEngineControlStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class EngineControlStatusModel
Public NotInheritable Class EngineControlStatusModel
public ref class EngineControlStatusModel sealed
[<SealedAttribute>]
type EngineControlStatusModel =  class end

The EngineControlStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | EngineControlStatusModel | Initializes a new instance of the EngineControlStatusModel class
Top
Properties
 | Name | Description
Public property | CanPauseMirror | Gets or sets a value indicating whether mirroring can be paused on the engine connection represented by this instance.
Public property | CanPauseTarget | Gets or sets a value indicating whether the target can be paused for the engine connection represented by this instance.
Public property | CanPauseTransmission | Gets or sets a value indicating whether transmission can be paused on the engine connection represented by this instance.
Public property | CanProcessOrphans | Gets or sets a value indicating whether orphans can be processed on the engine connection represented by this instance.
Public property | CanResumeMirror | Gets or sets a value indicating whether mirroring can be resumed on the engine connection represented by this instance.
Public property | CanResumeTarget | Gets or sets a value indicating whether the target can be resumed for the engine connection represented by this instance.
Public property | CanResumeTransmission | Gets or sets a value indicating whether transmission can be resumed on the engine connection represented by this instance.
Public property | CanSetBandwidth | Gets or sets a value indicating whether the bandwidth limit can be set on the engine connection represented by this instance.
Public property | CanStartMirror | Gets or sets a value indicating whether mirroring can be started on the engine connection represented by this instance.
Public property | CanStartTransmission | Gets or sets a value indicating whether transmission can be started on the engine connection represented by this instance.
Public property | CanStopMirror | Gets or sets a value indicating whether mirroring can be stopped on the engine connection represented by this instance.
Public property | CanTakeSnapshot | Gets or sets a value indicating whether a snapshot can be taken for the engine connection represented by this instance.
Public property | CanUpdateShares | Gets or sets a value indicating whether shares can be updated.
Public property | CanVerify | Gets or sets a value indicating whether verification can be performed on the engine connection represented by this instance.
Public property | ConnectionId | Gets or sets the connection id.
Public property | Role | Gets or sets the role of the engine connection in the job.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


EngineControlStatusModel Constructor

EngineControlStatusModel Constructor
Initializes a new instance of the EngineControlStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public EngineControlStatusModel()
Public Sub New
public:
EngineControlStatusModel()
new : unit -> EngineControlStatusModel
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel Properties

EngineControlStatusModel Properties

The EngineControlStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | CanPauseMirror | Gets or sets a value indicating whether mirroring can be paused on the engine connection represented by this instance.
Public property | CanPauseTarget | Gets or sets a value indicating whether the target can be paused for the engine connection represented by this instance.
Public property | CanPauseTransmission | Gets or sets a value indicating whether transmission can be paused on the engine connection represented by this instance.
Public property | CanProcessOrphans | Gets or sets a value indicating whether orphans can be processed on the engine connection represented by this instance.
Public property | CanResumeMirror | Gets or sets a value indicating whether mirroring can be resumed on the engine connection represented by this instance.
Public property | CanResumeTarget | Gets or sets a value indicating whether the target can be resumed for the engine connection represented by this instance.
Public property | CanResumeTransmission | Gets or sets a value indicating whether transmission can be resumed on the engine connection represented by this instance.
Public property | CanSetBandwidth | Gets or sets a value indicating whether the bandwidth limit can be set on the engine connection represented by this instance.
Public property | CanStartMirror | Gets or sets a value indicating whether mirroring can be started on the engine connection represented by this instance.
Public property | CanStartTransmission | Gets or sets a value indicating whether transmission can be started on the engine connection represented by this instance.
Public property | CanStopMirror | Gets or sets a value indicating whether mirroring can be stopped on the engine connection represented by this instance.
Public property | CanTakeSnapshot | Gets or sets a value indicating whether a snapshot can be taken for the engine connection represented by this instance.
Public property | CanUpdateShares | Gets or sets a value indicating whether shares can be updated.
Public property | CanVerify | Gets or sets a value indicating whether verification can be performed on the engine connection represented by this instance.
Public property | ConnectionId | Gets or sets the connection id.
Public property | Role | Gets or sets the role of the engine connection in the job.
Top
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanPauseMirror Property

EngineControlStatusModelCanPauseMirror Property
Gets or sets a value indicating whether mirroring can be paused on the engine connection represented by this instance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanPauseMirror { get; set; }
Public Property CanPauseMirror As Boolean
    Get
    Set
public:
property bool CanPauseMirror {
    bool get ();
    void set (bool value);
}
member CanPauseMirror : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanPauseTarget Property

EngineControlStatusModelCanPauseTarget Property
Gets or sets a value indicating whether the target can be paused for the engine connection represented by this instance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanPauseTarget { get; set; }
Public Property CanPauseTarget As Boolean
    Get
    Set
public:
property bool CanPauseTarget {
    bool get ();
    void set (bool value);
}
member CanPauseTarget : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanPauseTransmission Property

EngineControlStatusModelCanPauseTransmission Property
Gets or sets a value indicating whether transmission can be paused on the engine connection represented by this instance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanPauseTransmission { get; set; }
Public Property CanPauseTransmission As Boolean
    Get
    Set
public:
property bool CanPauseTransmission {
    bool get ();
    void set (bool value);
}
member CanPauseTransmission : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanProcessOrphans Property

EngineControlStatusModelCanProcessOrphans Property
Gets or sets a value indicating whether orphans can be processed on the engine connection represented by this instance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanProcessOrphans { get; set; }
Public Property CanProcessOrphans As Boolean
    Get
    Set
public:
property bool CanProcessOrphans {
    bool get ();
    void set (bool value);
}
member CanProcessOrphans : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanResumeMirror Property

EngineControlStatusModelCanResumeMirror Property
Gets or sets a value indicating whether mirroring can be resumed on the engine connection represented by this instance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanResumeMirror { get; set; }
Public Property CanResumeMirror As Boolean
    Get
    Set
public:
property bool CanResumeMirror {
    bool get ();
    void set (bool value);
}
member CanResumeMirror : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanResumeTarget Property

EngineControlStatusModelCanResumeTarget Property
Gets or sets a value indicating whether the target can be resumed for the engine connection represented by this instance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanResumeTarget { get; set; }
Public Property CanResumeTarget As Boolean
    Get
    Set
public:
property bool CanResumeTarget {
    bool get ();
    void set (bool value);
}
member CanResumeTarget : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanResumeTransmission Property

EngineControlStatusModelCanResumeTransmission Property
Gets or sets a value indicating whether transmission can be resumed on the engine connection represented by this instance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanResumeTransmission { get; set; }
Public Property CanResumeTransmission As Boolean
    Get
    Set
public:
property bool CanResumeTransmission {
    bool get ();
    void set (bool value);
}
member CanResumeTransmission : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanSetBandwidth Property

EngineControlStatusModelCanSetBandwidth Property
Gets or sets a value indicating whether the bandwidth limit can be set on the engine connection represented by this instance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanSetBandwidth { get; set; }
Public Property CanSetBandwidth As Boolean
    Get
    Set
public:
property bool CanSetBandwidth {
    bool get ();
    void set (bool value);
}
member CanSetBandwidth : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanStartMirror Property

EngineControlStatusModelCanStartMirror Property
Gets or sets a value indicating whether mirroring can be started on the engine connection represented by this instance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanStartMirror { get; set; }
Public Property CanStartMirror As Boolean
    Get
    Set
public:
property bool CanStartMirror {
    bool get ();
    void set (bool value);
}
member CanStartMirror : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanStartTransmission Property

EngineControlStatusModelCanStartTransmission Property
Gets or sets a value indicating whether transmission can be started on the engine connection represented by this instance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanStartTransmission { get; set; }
Public Property CanStartTransmission As Boolean
    Get
    Set
public:
property bool CanStartTransmission {
    bool get ();
    void set (bool value);
}
member CanStartTransmission : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanStopMirror Property

EngineControlStatusModelCanStopMirror Property
Gets or sets a value indicating whether mirroring can be stopped on the engine connection represented by this instance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanStopMirror { get; set; }
Public Property CanStopMirror As Boolean
    Get
    Set
public:
property bool CanStopMirror {
    bool get ();
    void set (bool value);
}
member CanStopMirror : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanTakeSnapshot Property

EngineControlStatusModelCanTakeSnapshot Property
Gets or sets a value indicating whether a snapshot can be taken for the engine connection represented by this instance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanTakeSnapshot { get; set; }
Public Property CanTakeSnapshot As Boolean
    Get
    Set
public:
property bool CanTakeSnapshot {
    bool get ();
    void set (bool value);
}
member CanTakeSnapshot : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanUpdateShares Property

EngineControlStatusModelCanUpdateShares Property
Gets or sets a value indicating whether shares can be updated.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanUpdateShares { get; set; }
Public Property CanUpdateShares As Boolean
    Get
    Set
public:
property bool CanUpdateShares {
    bool get ();
    void set (bool value);
}
member CanUpdateShares : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.CanVerify Property

EngineControlStatusModelCanVerify Property
Gets or sets a value indicating whether verification can be performed on the engine connection represented by this instance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanVerify { get; set; }
Public Property CanVerify As Boolean
    Get
    Set
public:
property bool CanVerify {
    bool get ();
    void set (bool value);
}
member CanVerify : bool with get, set

Property Value

Type: Boolean
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.ConnectionId Property

EngineControlStatusModelConnectionId Property
Gets or sets the connection id.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Guid ConnectionId { get; set; }
Public Property ConnectionId As Guid
    Get
    Set
public:
property Guid ConnectionId {
    Guid get ();
    void set (Guid value);
}
member ConnectionId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel.Role Property

EngineControlStatusModelRole Property
Gets or sets the role of the engine connection in the job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Role { get; set; }
Public Property Role As String
    Get
    Set
public:
property String^ Role {
    String^ get ();
    void set (String^ value);
}
member Role : string with get, set

Property Value

Type: String
See Also

Reference

EngineControlStatusModel Class


EngineControlStatusModel Methods

EngineControlStatusModel Methods

The EngineControlStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EngineControlStatusModel Class


EngineJobType Enumeration

EngineJobType Enumeration
Engine job type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum EngineJobType
<FlagsAttribute>
Public Enumeration EngineJobType
[FlagsAttribute]
public enum class EngineJobType
[<FlagsAttribute>]
type EngineJobType
Members
Member name | Value | Description
NormalJob | 0 | The normal job
ImageJob | 1 | The image job
RecoveryJob | 2 | The recovery job
FullServerJob | 4 | The full server job
GeoClusterJob | 8 | The geo cluster job
MigrationJob | 16 | The migration job
FullServerRevertJob | 32 | The full server revert job
VraRecoveryJob | 64 | The vra recovery job
VraMigrationJob | 128 | The vra migration job
DataOnlyOption | 256 | The data only option
VraJob | 512 | The vra job
HyperVJob | 1024 | The hyper v job
Win32MirrorOption | 2048 | The win32 mirror option
SourceConnectionResourceJob | 4096 | The source connection resource job
FullServerBackupJob | 8192 | The full server backup job
UvraJob | 16384 | The uvra job
NonClientAccessibleSnapshot | 32768 | The non client accessible snapshot
FfoJob | 65536 | The ffo job
LvraJob | 131072 | The lvra job
Invalid | 65535 | The invalid
See Also

Reference

DoubleTake.Web.Models Namespace


ErrorInfoModel Class

ErrorInfoModel Class
Represents job error properties.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsErrorInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class ErrorInfoModel
Public NotInheritable Class ErrorInfoModel
public ref class ErrorInfoModel sealed
[<SealedAttribute>]
type ErrorInfoModel =  class end

The ErrorInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorInfoModel | Initializes a new instance of the ErrorInfoModel class
Top
Properties
 | Name | Description
Public property | Details | Gets or sets a value of error details
Public property | Health | Gets or sets the health.
Public property | Id | Gets or sets a value of error Id
Public property | Message | Gets or sets a value of error message
Public property | Timestamp | Gets or sets a value of error time stamp
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ErrorInfoModel Constructor

ErrorInfoModel Constructor
Initializes a new instance of the ErrorInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ErrorInfoModel()
Public Sub New
public:
ErrorInfoModel()
new : unit -> ErrorInfoModel
See Also

Reference

ErrorInfoModel Class


ErrorInfoModel Properties

ErrorInfoModel Properties

The ErrorInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Details | Gets or sets a value of error details
Public property | Health | Gets or sets the health.
Public property | Id | Gets or sets a value of error Id
Public property | Message | Gets or sets a value of error message
Public property | Timestamp | Gets or sets a value of error time stamp
Top
See Also

Reference

ErrorInfoModel Class


ErrorInfoModel.Details Property

ErrorInfoModelDetails Property
Gets or sets a value of error details

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Details { get; set; }
Public Property Details As String
    Get
    Set
public:
property String^ Details {
    String^ get ();
    void set (String^ value);
}
member Details : string with get, set

Property Value

Type: String
See Also

Reference

ErrorInfoModel Class


ErrorInfoModel.Health Property

ErrorInfoModelHealth Property
Gets or sets the health.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Health Health { get; set; }
Public Property Health As Health
    Get
    Set
public:
property Health Health {
    Health get ();
    void set (Health value);
}
member Health : Health with get, set

Property Value

Type: Health
The health.
See Also

Reference

ErrorInfoModel Class


ErrorInfoModel.Id Property

ErrorInfoModelId Property
Gets or sets a value of error Id

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int Id { get; set; }
Public Property Id As Integer
    Get
    Set
public:
property int Id {
    int get ();
    void set (int value);
}
member Id : int with get, set

Property Value

Type: Int32
See Also

Reference

ErrorInfoModel Class


ErrorInfoModel.Message Property

ErrorInfoModelMessage Property
Gets or sets a value of error message

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Property Value

Type: String
See Also

Reference

ErrorInfoModel Class


ErrorInfoModel.Timestamp Property

ErrorInfoModelTimestamp Property
Gets or sets a value of error time stamp

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DateTime Timestamp { get; set; }
Public Property Timestamp As DateTime
    Get
    Set
public:
property DateTime Timestamp {
    DateTime get ();
    void set (DateTime value);
}
member Timestamp : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

ErrorInfoModel Class


ErrorInfoModel Methods

ErrorInfoModel Methods

The ErrorInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ErrorInfoModel Class


ESXInfoModel Class

ESXInfoModel Class
This class represents the general information about an ESX server.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsESXInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class ESXInfoModel
Public Class ESXInfoModel
public ref class ESXInfoModel
type ESXInfoModel =  class end

The ESXInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ESXInfoModel | Initializes a new instance of the ESXInfoModel class
Top
Properties
 | Name | Description
Public property | FullName | Gets or sets the full name including the build number of the ESX server.
Public property | HasUserPermissions | Gets or sets a value indicating whether the logged on user has the required permissions on ESX server.
Public property | UserRoleID | Gets or sets the logged on user's role id.
Public property | Version | Gets or sets the version of the ESX server.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ESXInfoModel Constructor

ESXInfoModel Constructor
Initializes a new instance of the ESXInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ESXInfoModel()
Public Sub New
public:
ESXInfoModel()
new : unit -> ESXInfoModel
See Also

Reference

ESXInfoModel Class


ESXInfoModel Properties

ESXInfoModel Properties

The ESXInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | FullName | Gets or sets the full name including the build number of the ESX server.
Public property | HasUserPermissions | Gets or sets a value indicating whether the logged on user has the required permissions on ESX server.
Public property | UserRoleID | Gets or sets the logged on user's role id.
Public property | Version | Gets or sets the version of the ESX server.
Top
See Also

Reference

ESXInfoModel Class


ESXInfoModel.FullName Property

ESXInfoModelFullName Property
Gets or sets the full name including the build number of the ESX server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string FullName { get; set; }
Public Property FullName As String
    Get
    Set
public:
property String^ FullName {
    String^ get ();
    void set (String^ value);
}
member FullName : string with get, set

Property Value

Type: String
See Also

Reference

ESXInfoModel Class


ESXInfoModel.HasUserPermissions Property

ESXInfoModelHasUserPermissions Property
Gets or sets a value indicating whether the logged on user has the required permissions on ESX server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool HasUserPermissions { get; set; }
Public Property HasUserPermissions As Boolean
    Get
    Set
public:
property bool HasUserPermissions {
    bool get ();
    void set (bool value);
}
member HasUserPermissions : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ESXInfoModel Class


ESXInfoModel.UserRoleID Property

ESXInfoModelUserRoleID Property
Gets or sets the logged on user's role id.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int UserRoleID { get; set; }
Public Property UserRoleID As Integer
    Get
    Set
public:
property int UserRoleID {
    int get ();
    void set (int value);
}
member UserRoleID : int with get, set

Property Value

Type: Int32
See Also

Reference

ESXInfoModel Class


ESXInfoModel.Version Property

ESXInfoModelVersion Property
Gets or sets the version of the ESX server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Version { get; set; }
Public Property Version As String
    Get
    Set
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}
member Version : string with get, set

Property Value

Type: String
See Also

Reference

ESXInfoModel Class


ESXInfoModel Methods

ESXInfoModel Methods

The ESXInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ESXInfoModel Class


EventLogModel Class

EventLogModel Class
Event log model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsEventLogModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class EventLogModel
Public NotInheritable Class EventLogModel
public ref class EventLogModel sealed
[<SealedAttribute>]
type EventLogModel =  class end

The EventLogModel type exposes the following members.

Constructors
 | Name | Description
Public method | EventLogModel | Initializes a new instance of the EventLogModel class
Top
Properties
 | Name | Description
Public property | Category | Gets or sets the text associated with the categoryNumber for this entry.
Public property | CategoryNumber | Gets or sets the category number of the event log entry.
Public property | EntryType | Gets or sets the event type of this entry.
Public property | Id | Gets or sets the id of this entry in the event log.
Public property | InstanceId | Gets or sets the resource identifier that designates the message text of the event entry.
Public property | MachineName | Gets or sets the name of the computer on which this entry was generated.
Public property | Message | Gets or sets the localized message associated with this event entry.
Public property | ReplacementStrings | Gets or sets the replacement strings associated with the event log entry.
Public property | Source | Gets or sets the name of the application that generated this event.
Public property | TimeGenerated | Gets or sets the local time at which this event was generated.
Public property | TimeWritten | Gets or sets the local time at which this event was written to the log.
Public property | UserName | Gets or sets the name of the user who is responsible for this event.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


EventLogModel Constructor

EventLogModel Constructor
Initializes a new instance of the EventLogModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public EventLogModel()
Public Sub New
public:
EventLogModel()
new : unit -> EventLogModel
See Also

Reference

EventLogModel Class


EventLogModel Properties

EventLogModel Properties

The EventLogModel type exposes the following members.

Properties
 | Name | Description
Public property | Category | Gets or sets the text associated with the categoryNumber for this entry.
Public property | CategoryNumber | Gets or sets the category number of the event log entry.
Public property | EntryType | Gets or sets the event type of this entry.
Public property | Id | Gets or sets the id of this entry in the event log.
Public property | InstanceId | Gets or sets the resource identifier that designates the message text of the event entry.
Public property | MachineName | Gets or sets the name of the computer on which this entry was generated.
Public property | Message | Gets or sets the localized message associated with this event entry.
Public property | ReplacementStrings | Gets or sets the replacement strings associated with the event log entry.
Public property | Source | Gets or sets the name of the application that generated this event.
Public property | TimeGenerated | Gets or sets the local time at which this event was generated.
Public property | TimeWritten | Gets or sets the local time at which this event was written to the log.
Public property | UserName | Gets or sets the name of the user who is responsible for this event.
Top
See Also

Reference

EventLogModel Class


EventLogModel.Category Property

EventLogModelCategory Property
Gets or sets the text associated with the categoryNumber for this entry.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Category { get; set; }
Public Property Category As String
    Get
    Set
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}
member Category : string with get, set

Property Value

Type: String
See Also

Reference

EventLogModel Class


EventLogModel.CategoryNumber Property

EventLogModelCategoryNumber Property
Gets or sets the category number of the event log entry.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public short CategoryNumber { get; set; }
Public Property CategoryNumber As Short
    Get
    Set
public:
property short CategoryNumber {
    short get ();
    void set (short value);
}
member CategoryNumber : int16 with get, set

Property Value

Type: Int16
See Also

Reference

EventLogModel Class


EventLogModel.EntryType Property

EventLogModelEntryType Property
Gets or sets the event type of this entry.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public EventLogEntryType EntryType { get; set; }
Public Property EntryType As EventLogEntryType
    Get
    Set
public:
property EventLogEntryType EntryType {
    EventLogEntryType get ();
    void set (EventLogEntryType value);
}
member EntryType : EventLogEntryType with get, set

Property Value

Type: EventLogEntryType
See Also

Reference

EventLogModel Class


EventLogModel.Id Property

EventLogModelId Property
Gets or sets the id of this entry in the event log.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int Id { get; set; }
Public Property Id As Integer
    Get
    Set
public:
property int Id {
    int get ();
    void set (int value);
}
member Id : int with get, set

Property Value

Type: Int32
See Also

Reference

EventLogModel Class


EventLogModel.InstanceId Property

EventLogModelInstanceId Property
Gets or sets the resource identifier that designates the message text of the event entry.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long InstanceId { get; set; }
Public Property InstanceId As Long
    Get
    Set
public:
property long long InstanceId {
    long long get ();
    void set (long long value);
}
member InstanceId : int64 with get, set

Property Value

Type: Int64
See Also

Reference

EventLogModel Class


EventLogModel.MachineName Property

EventLogModelMachineName Property
Gets or sets the name of the computer on which this entry was generated.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string MachineName { get; set; }
Public Property MachineName As String
    Get
    Set
public:
property String^ MachineName {
    String^ get ();
    void set (String^ value);
}
member MachineName : string with get, set

Property Value

Type: String
See Also

Reference

EventLogModel Class


EventLogModel.Message Property

EventLogModelMessage Property
Gets or sets the localized message associated with this event entry.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Property Value

Type: String
See Also

Reference

EventLogModel Class


EventLogModel.ReplacementStrings Property

EventLogModelReplacementStrings Property
Gets or sets the replacement strings associated with the event log entry.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] ReplacementStrings { get; set; }
Public Property ReplacementStrings As String()
    Get
    Set
public:
property array<String^>^ ReplacementStrings {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member ReplacementStrings : string[] with get, set

Property Value

Type: String
See Also

Reference

EventLogModel Class


EventLogModel.Source Property

EventLogModelSource Property
Gets or sets the name of the application that generated this event.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Source { get; set; }
Public Property Source As String
    Get
    Set
public:
property String^ Source {
    String^ get ();
    void set (String^ value);
}
member Source : string with get, set

Property Value

Type: String
See Also

Reference

EventLogModel Class


EventLogModel.TimeGenerated Property

EventLogModelTimeGenerated Property
Gets or sets the local time at which this event was generated.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset TimeGenerated { get; set; }
Public Property TimeGenerated As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset TimeGenerated {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member TimeGenerated : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

EventLogModel Class


EventLogModel.TimeWritten Property

EventLogModelTimeWritten Property
Gets or sets the local time at which this event was written to the log.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset TimeWritten { get; set; }
Public Property TimeWritten As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset TimeWritten {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member TimeWritten : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

EventLogModel Class


EventLogModel.UserName Property

EventLogModelUserName Property
Gets or sets the name of the user who is responsible for this event.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}
member UserName : string with get, set

Property Value

Type: String
See Also

Reference

EventLogModel Class


EventLogModel Methods

EventLogModel Methods

The EventLogModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EventLogModel Class


ExtendedLowLevelStateModel Class

ExtendedLowLevelStateModel Class
Extended low level state model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsExtendedLowLevelStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ExtendedLowLevelStateModel
Public NotInheritable Class ExtendedLowLevelStateModel
public ref class ExtendedLowLevelStateModel sealed
[<SealedAttribute>]
type ExtendedLowLevelStateModel =  class end

The ExtendedLowLevelStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | ExtendedLowLevelStateModel | Initializes a new instance of the ExtendedLowLevelStateModel class
Top
Properties
 | Name | Description
Public property | Health | Gets or sets the health of the low level state.
Public property | MessageId | Gets or sets a value representing a message identifier for this low level state.
Public property | MessageIdFormatParameters | Gets or sets the message format parameters for this low level state.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ExtendedLowLevelStateModel Constructor

ExtendedLowLevelStateModel Constructor
Initializes a new instance of the ExtendedLowLevelStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ExtendedLowLevelStateModel()
Public Sub New
public:
ExtendedLowLevelStateModel()
new : unit -> ExtendedLowLevelStateModel
See Also

Reference

ExtendedLowLevelStateModel Class


ExtendedLowLevelStateModel Properties

ExtendedLowLevelStateModel Properties

The ExtendedLowLevelStateModel type exposes the following members.

Properties
 | Name | Description
Public property | Health | Gets or sets the health of the low level state.
Public property | MessageId | Gets or sets a value representing a message identifier for this low level state.
Public property | MessageIdFormatParameters | Gets or sets the message format parameters for this low level state.
Top
See Also

Reference

ExtendedLowLevelStateModel Class


ExtendedLowLevelStateModel.Health Property

ExtendedLowLevelStateModelHealth Property
Gets or sets the health of the low level state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Health Health { get; set; }
Public Property Health As Health
    Get
    Set
public:
property Health Health {
    Health get ();
    void set (Health value);
}
member Health : Health with get, set

Property Value

Type: Health
See Also

Reference

ExtendedLowLevelStateModel Class


ExtendedLowLevelStateModel.MessageId Property

ExtendedLowLevelStateModelMessageId Property
Gets or sets a value representing a message identifier for this low level state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string MessageId { get; set; }
Public Property MessageId As String
    Get
    Set
public:
property String^ MessageId {
    String^ get ();
    void set (String^ value);
}
member MessageId : string with get, set

Property Value

Type: String
See Also

Reference

ExtendedLowLevelStateModel Class


ExtendedLowLevelStateModel.MessageIdFormatParameters Property

ExtendedLowLevelStateModelMessageIdFormatParameters Property
Gets or sets the message format parameters for this low level state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] MessageIdFormatParameters { get; set; }
Public Property MessageIdFormatParameters As String()
    Get
    Set
public:
property array<String^>^ MessageIdFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member MessageIdFormatParameters : string[] with get, set

Property Value

Type: String
See Also

Reference

ExtendedLowLevelStateModel Class


ExtendedLowLevelStateModel Methods

ExtendedLowLevelStateModel Methods

The ExtendedLowLevelStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ExtendedLowLevelStateModel Class


FailbackOptionsModel Class

FailbackOptionsModel Class
Failback options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFailbackOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class FailbackOptionsModel
Public NotInheritable Class FailbackOptionsModel
public ref class FailbackOptionsModel sealed
[<SealedAttribute>]
type FailbackOptionsModel =  class end

The FailbackOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | FailbackOptionsModel | Initializes a new instance of the FailbackOptionsModel class
Top
Properties
 | Name | Description
Public property | NewMonitorOptions | Gets or sets the monitor options for the new source server.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FailbackOptionsModel Constructor

FailbackOptionsModel Constructor
Initializes a new instance of the FailbackOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FailbackOptionsModel()
Public Sub New
public:
FailbackOptionsModel()
new : unit -> FailbackOptionsModel
See Also

Reference

FailbackOptionsModel Class


FailbackOptionsModel Properties

FailbackOptionsModel Properties

The FailbackOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | NewMonitorOptions | Gets or sets the monitor options for the new source server.
Top
See Also

Reference

FailbackOptionsModel Class


FailbackOptionsModel.NewMonitorOptions Property

FailbackOptionsModelNewMonitorOptions Property
Gets or sets the monitor options for the new source server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CoreMonitorOptionsModel NewMonitorOptions { get; set; }
Public Property NewMonitorOptions As CoreMonitorOptionsModel
    Get
    Set
public:
property CoreMonitorOptionsModel^ NewMonitorOptions {
    CoreMonitorOptionsModel^ get ();
    void set (CoreMonitorOptionsModel^ value);
}
member NewMonitorOptions : CoreMonitorOptionsModel with get, set

Property Value

Type: CoreMonitorOptionsModel
See Also

Reference

FailbackOptionsModel Class


FailbackOptionsModel Methods

FailbackOptionsModel Methods

The FailbackOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FailbackOptionsModel Class


FailoverAddressesOption Enumeration

FailoverAddressesOption Enumeration
Failover addresses option.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum FailoverAddressesOption
Public Enumeration FailoverAddressesOption
public enum class FailoverAddressesOption
type FailoverAddressesOption
Members
Member name | Value | Description
Monitored | 0 | The monitored
All | 1 | All
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverDataAction Enumeration

FailoverDataAction Enumeration
Failover data action.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum FailoverDataAction
Public Enumeration FailoverDataAction
public enum class FailoverDataAction
type FailoverDataAction
Members
Member name | Value | Description
Apply | 0 | The apply
Flush | 1 | The flush
Revert | 2 | The revert
Unknown | 3 | The unknown
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverItems Enumeration

FailoverItems Enumeration
Failover items.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum FailoverItems
<FlagsAttribute>
Public Enumeration FailoverItems
[FlagsAttribute]
public enum class FailoverItems
[<FlagsAttribute>]
type FailoverItems
Members
Member name | Value | Description
None | 0 | The none
IPAddresses | 1 | The IP addresses
Name | 2 | The name
Shares | 4 | The shares
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverMode Enumeration

FailoverMode Enumeration
Failover mode.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum FailoverMode
Public Enumeration FailoverMode
public enum class FailoverMode
type FailoverMode
Members
Member name | Value | Description
Live | 0 | The live
Test | 1 | The test
Snapshot | 2 | The snapshot
SetRestoreRequiredOnly | 3 | The set restore required only
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverOptionsModel Class

FailoverOptionsModel Class
Failover options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFailoverOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class FailoverOptionsModel
Public NotInheritable Class FailoverOptionsModel
public ref class FailoverOptionsModel sealed
[<SealedAttribute>]
type FailoverOptionsModel =  class end

The FailoverOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | FailoverOptionsModel | Initializes a new instance of the FailoverOptionsModel class
Top
Properties
 | Name | Description
Public property | FailoverDataAction | Gets or sets the failover data action.
Public property | FailoverMode | Gets or sets the failover mode.
Public property | FailoverType | Gets or sets the failover type.
Public property | SnapshotId | Gets or sets the snapshot id to apply to the target server during failover.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverOptionsModel Constructor

FailoverOptionsModel Constructor
Initializes a new instance of the FailoverOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverOptionsModel()
Public Sub New
public:
FailoverOptionsModel()
new : unit -> FailoverOptionsModel
See Also

Reference

FailoverOptionsModel Class


FailoverOptionsModel Properties

FailoverOptionsModel Properties

The FailoverOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | FailoverDataAction | Gets or sets the failover data action.
Public property | FailoverMode | Gets or sets the failover mode.
Public property | FailoverType | Gets or sets the failover type.
Public property | SnapshotId | Gets or sets the snapshot id to apply to the target server during failover.
Top
See Also

Reference

FailoverOptionsModel Class


FailoverOptionsModel.FailoverDataAction Property

FailoverOptionsModelFailoverDataAction Property
Gets or sets the failover data action.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverDataAction FailoverDataAction { get; set; }
Public Property FailoverDataAction As FailoverDataAction
    Get
    Set
public:
property FailoverDataAction FailoverDataAction {
    FailoverDataAction get ();
    void set (FailoverDataAction value);
}
member FailoverDataAction : FailoverDataAction with get, set

Property Value

Type: FailoverDataAction
See Also

Reference

FailoverOptionsModel Class


FailoverOptionsModel.FailoverMode Property

FailoverOptionsModelFailoverMode Property
Gets or sets the failover mode.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverMode FailoverMode { get; set; }
Public Property FailoverMode As FailoverMode
    Get
    Set
public:
property FailoverMode FailoverMode {
    FailoverMode get ();
    void set (FailoverMode value);
}
member FailoverMode : FailoverMode with get, set

Property Value

Type: FailoverMode
See Also

Reference

FailoverOptionsModel Class


FailoverOptionsModel.FailoverType Property

FailoverOptionsModelFailoverType Property
Gets or sets the failover type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverType FailoverType { get; set; }
Public Property FailoverType As FailoverType
    Get
    Set
public:
property FailoverType FailoverType {
    FailoverType get ();
    void set (FailoverType value);
}
member FailoverType : FailoverType with get, set

Property Value

Type: FailoverType
See Also

Reference

FailoverOptionsModel Class


FailoverOptionsModel.SnapshotId Property

FailoverOptionsModelSnapshotId Property
Gets or sets the snapshot id to apply to the target server during failover.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Guid SnapshotId { get; set; }
Public Property SnapshotId As Guid
    Get
    Set
public:
property Guid SnapshotId {
    Guid get ();
    void set (Guid value);
}
member SnapshotId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

FailoverOptionsModel Class


FailoverOptionsModel Methods

FailoverOptionsModel Methods

The FailoverOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FailoverOptionsModel Class


FailoverPersistedStateModel Class

FailoverPersistedStateModel Class
Failover persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFailoverPersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class FailoverPersistedStateModel
Public NotInheritable Class FailoverPersistedStateModel
public ref class FailoverPersistedStateModel sealed
[<SealedAttribute>]
type FailoverPersistedStateModel =  class end

The FailoverPersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | FailoverPersistedStateModel | Initializes a new instance of the FailoverPersistedStateModel class
Top
Properties
 | Name | Description
Public property | FailedOverAddresses | Gets or sets the failed over addresses.
Public property | FailedOverShares | Gets or sets the failed over shares.
Public property | LastKnownSourceShares | Gets or sets the last known source shares.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverPersistedStateModel Constructor

FailoverPersistedStateModel Constructor
Initializes a new instance of the FailoverPersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public FailoverPersistedStateModel()
Public Sub New
public:
FailoverPersistedStateModel()
new : unit -> FailoverPersistedStateModel
See Also

Reference

FailoverPersistedStateModel Class


FailoverPersistedStateModel Properties

FailoverPersistedStateModel Properties

The FailoverPersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | FailedOverAddresses | Gets or sets the failed over addresses.
Public property | FailedOverShares | Gets or sets the failed over shares.
Public property | LastKnownSourceShares | Gets or sets the last known source shares.
Top
See Also

Reference

FailoverPersistedStateModel Class


FailoverPersistedStateModel.FailedOverAddresses Property

FailoverPersistedStateModelFailedOverAddresses Property
Gets or sets the failed over addresses.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<AddressPersistedStateModel> FailedOverAddresses { get; set; }
Public Property FailedOverAddresses As IEnumerable(Of AddressPersistedStateModel)
    Get
    Set
public:
property IEnumerable<AddressPersistedStateModel^>^ FailedOverAddresses {
    IEnumerable<AddressPersistedStateModel^>^ get ();
    void set (IEnumerable<AddressPersistedStateModel^>^ value);
}
member FailedOverAddresses : IEnumerable<AddressPersistedStateModel> with get, set

Property Value

Type: IEnumerable AddressPersistedStateModel
The failed over addresses.
See Also

Reference

FailoverPersistedStateModel Class


FailoverPersistedStateModel.FailedOverShares Property

FailoverPersistedStateModelFailedOverShares Property
Gets or sets the failed over shares.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<ShareModel> FailedOverShares { get; set; }
Public Property FailedOverShares As IEnumerable(Of ShareModel)
    Get
    Set
public:
property IEnumerable<ShareModel^>^ FailedOverShares {
    IEnumerable<ShareModel^>^ get ();
    void set (IEnumerable<ShareModel^>^ value);
}
member FailedOverShares : IEnumerable<ShareModel> with get, set

Property Value

Type: IEnumerable ShareModel
The failed over shares.
See Also

Reference

FailoverPersistedStateModel Class


FailoverPersistedStateModel.LastKnownSourceShares Property

FailoverPersistedStateModelLastKnownSourceShares Property
Gets or sets the last known source shares.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<ShareModel> LastKnownSourceShares { get; set; }
Public Property LastKnownSourceShares As IEnumerable(Of ShareModel)
    Get
    Set
public:
property IEnumerable<ShareModel^>^ LastKnownSourceShares {
    IEnumerable<ShareModel^>^ get ();
    void set (IEnumerable<ShareModel^>^ value);
}
member LastKnownSourceShares : IEnumerable<ShareModel> with get, set

Property Value

Type: IEnumerable ShareModel
The last known source shares.
See Also

Reference

FailoverPersistedStateModel Class


FailoverPersistedStateModel Methods

FailoverPersistedStateModel Methods

The FailoverPersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FailoverPersistedStateModel Class


FailoverProcessingOptions Enumeration

FailoverProcessingOptions Enumeration
Failover processing options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum FailoverProcessingOptions
<FlagsAttribute>
Public Enumeration FailoverProcessingOptions
[FlagsAttribute]
public enum class FailoverProcessingOptions
[<FlagsAttribute>]
type FailoverProcessingOptions
Members
Member name | Value | Description
None | 0 | The none
UserInterventionRequired | 1 | The user intervention required
UseShareFile | 2 | The use share file
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverReplaceActions Enumeration

FailoverReplaceActions Enumeration
Failover replace actions.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum FailoverReplaceActions
<FlagsAttribute>
Public Enumeration FailoverReplaceActions
[FlagsAttribute]
public enum class FailoverReplaceActions
[<FlagsAttribute>]
type FailoverReplaceActions
Members
Member name | Value | Description
Address | 2 | The address
Name | 1 | The name
None | 0 | The none
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverReport Class

FailoverReport Class
Failover report information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFailoverReport

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class FailoverReport
Public NotInheritable Class FailoverReport
public ref class FailoverReport sealed
[<SealedAttribute>]
type FailoverReport =  class end

The FailoverReport type exposes the following members.

Constructors
 | Name | Description
Public method | FailoverReport | Initializes a new instance of the FailoverReport class
Top
Properties
 | Name | Description
Public property | failoverSuccess | Whether the failover was a success
Public property | failoverType | Type of failover being done.
Public property | isReverse | Whether this is the reverse of the source in an FFO job.
Public property | jobId | Job id being reported
Public property | jobName | Name of the job
Public property | jobType | This is the job type as described within JobInfo.cs
Public property | snapshotLabel | Label for the snapshot used. (Empty string for live data.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | targetedMachineInfo | Information about the target machine.
Public field | times | Times for this failover
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverReport Constructor

FailoverReport Constructor
Initializes a new instance of the FailoverReport class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverReport()
Public Sub New
public:
FailoverReport()
new : unit -> FailoverReport
See Also

Reference

FailoverReport Class


FailoverReport Properties

FailoverReport Properties

The FailoverReport type exposes the following members.

Properties
 | Name | Description
Public property | failoverSuccess | Whether the failover was a success
Public property | failoverType | Type of failover being done.
Public property | isReverse | Whether this is the reverse of the source in an FFO job.
Public property | jobId | Job id being reported
Public property | jobName | Name of the job
Public property | jobType | This is the job type as described within JobInfo.cs
Public property | snapshotLabel | Label for the snapshot used. (Empty string for live data.)
Top
See Also

Reference

FailoverReport Class


FailoverReport.failoverSuccess Property

FailoverReportfailoverSuccess Property
Whether the failover was a success

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool failoverSuccess { get; set; }
Public Property failoverSuccess As Boolean
    Get
    Set
public:
property bool failoverSuccess {
    bool get ();
    void set (bool value);
}
member failoverSuccess : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FailoverReport Class


FailoverReport.failoverType Property

FailoverReportfailoverType Property
Type of failover being done.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverStyle failoverType { get; set; }
Public Property failoverType As FailoverStyle
    Get
    Set
public:
property FailoverStyle failoverType {
    FailoverStyle get ();
    void set (FailoverStyle value);
}
member failoverType : FailoverStyle with get, set

Property Value

Type: FailoverStyle
See Also

Reference

FailoverReport Class


FailoverReport.isReverse Property

FailoverReportisReverse Property
Whether this is the reverse of the source in an FFO job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool isReverse { get; set; }
Public Property isReverse As Boolean
    Get
    Set
public:
property bool isReverse {
    bool get ();
    void set (bool value);
}
member isReverse : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FailoverReport Class


FailoverReport.jobId Property

FailoverReportjobId Property
Job id being reported

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string jobId { get; set; }
Public Property jobId As String
    Get
    Set
public:
property String^ jobId {
    String^ get ();
    void set (String^ value);
}
member jobId : string with get, set

Property Value

Type: String
See Also

Reference

FailoverReport Class


FailoverReport.jobName Property

FailoverReportjobName Property
Name of the job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string jobName { get; set; }
Public Property jobName As String
    Get
    Set
public:
property String^ jobName {
    String^ get ();
    void set (String^ value);
}
member jobName : string with get, set

Property Value

Type: String
See Also

Reference

FailoverReport Class


FailoverReport.jobType Property

FailoverReportjobType Property
This is the job type as described within JobInfo.cs

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string jobType { get; set; }
Public Property jobType As String
    Get
    Set
public:
property String^ jobType {
    String^ get ();
    void set (String^ value);
}
member jobType : string with get, set

Property Value

Type: String
See Also

Reference

FailoverReport Class


FailoverReport.snapshotLabel Property

FailoverReportsnapshotLabel Property
Label for the snapshot used. (Empty string for live data.)

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string snapshotLabel { get; set; }
Public Property snapshotLabel As String
    Get
    Set
public:
property String^ snapshotLabel {
    String^ get ();
    void set (String^ value);
}
member snapshotLabel : string with get, set

Property Value

Type: String
See Also

Reference

FailoverReport Class


FailoverReport Methods

FailoverReport Methods

The FailoverReport type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FailoverReport Class


FailoverReport Fields

FailoverReport Fields

The FailoverReport type exposes the following members.

Fields
 | Name | Description
Public field | targetedMachineInfo | Information about the target machine.
Public field | times | Times for this failover
Top
See Also

Reference

FailoverReport Class


FailoverReport.targetedMachineInfo Field

FailoverReporttargetedMachineInfo Field
Information about the target machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public MachineInfoClassModel targetedMachineInfo
Public targetedMachineInfo As MachineInfoClassModel
public:
MachineInfoClassModel^ targetedMachineInfo
val mutable targetedMachineInfo: MachineInfoClassModel

Field Value

Type: MachineInfoClassModel
See Also

Reference

FailoverReport Class


FailoverReport.times Field

FailoverReporttimes Field
Times for this failover

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TimesClassModel times
Public times As TimesClassModel
public:
TimesClassModel^ times
val mutable times: TimesClassModel

Field Value

Type: TimesClassModel
See Also

Reference

FailoverReport Class


FailoverReportingModel Class

FailoverReportingModel Class
Failover reporting data model
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFailoverReportingModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class FailoverReportingModel
Public NotInheritable Class FailoverReportingModel
public ref class FailoverReportingModel sealed
[<SealedAttribute>]
type FailoverReportingModel =  class end

The FailoverReportingModel type exposes the following members.

Constructors
 | Name | Description
Public method | FailoverReportingModel | Initializes a new instance of the FailoverReportingModel class
Top
Properties
 | Name | Description
Public property | failoverSuccess | Whether the failover was a success
Public property | failoverType | Type of failover being done.
Public property | isReverse | Whether this is the reverse of the source in an FFO job.
Public property | jobId | Job id being reported
Public property | jobName | Name of the job
Public property | jobType | This is the job type as described within JobInfo.cs
Public property | snapshotLabel | Label for the snapshot used. (Empty string for live data.)
Public property | targetedMachineInfo | Information about the target machine.
Public property | times | Times for this failover
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverReportingModel Constructor

FailoverReportingModel Constructor
Initializes a new instance of the FailoverReportingModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public FailoverReportingModel()
Public Sub New
public:
FailoverReportingModel()
new : unit -> FailoverReportingModel
See Also

Reference

FailoverReportingModel Class


FailoverReportingModel Properties

FailoverReportingModel Properties

The FailoverReportingModel type exposes the following members.

Properties
 | Name | Description
Public property | failoverSuccess | Whether the failover was a success
Public property | failoverType | Type of failover being done.
Public property | isReverse | Whether this is the reverse of the source in an FFO job.
Public property | jobId | Job id being reported
Public property | jobName | Name of the job
Public property | jobType | This is the job type as described within JobInfo.cs
Public property | snapshotLabel | Label for the snapshot used. (Empty string for live data.)
Public property | targetedMachineInfo | Information about the target machine.
Public property | times | Times for this failover
Top
See Also

Reference

FailoverReportingModel Class


FailoverReportingModel.failoverSuccess Property

FailoverReportingModelfailoverSuccess Property
Whether the failover was a success

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool failoverSuccess { get; set; }
Public Property failoverSuccess As Boolean
    Get
    Set
public:
property bool failoverSuccess {
    bool get ();
    void set (bool value);
}
member failoverSuccess : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FailoverReportingModel Class


FailoverReportingModel.failoverType Property

FailoverReportingModelfailoverType Property
Type of failover being done.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public FailoverReportTypeEnum failoverType { get; set; }
Public Property failoverType As FailoverReportTypeEnum
    Get
    Set
public:
property FailoverReportTypeEnum failoverType {
    FailoverReportTypeEnum get ();
    void set (FailoverReportTypeEnum value);
}
member failoverType : FailoverReportTypeEnum with get, set

Property Value

Type: FailoverReportTypeEnum
See Also

Reference

FailoverReportingModel Class


FailoverReportingModel.isReverse Property

FailoverReportingModelisReverse Property
Whether this is the reverse of the source in an FFO job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool isReverse { get; set; }
Public Property isReverse As Boolean
    Get
    Set
public:
property bool isReverse {
    bool get ();
    void set (bool value);
}
member isReverse : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FailoverReportingModel Class


FailoverReportingModel.jobId Property

FailoverReportingModeljobId Property
Job id being reported

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string jobId { get; set; }
Public Property jobId As String
    Get
    Set
public:
property String^ jobId {
    String^ get ();
    void set (String^ value);
}
member jobId : string with get, set

Property Value

Type: String
See Also

Reference

FailoverReportingModel Class


FailoverReportingModel.jobName Property

FailoverReportingModeljobName Property
Name of the job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string jobName { get; set; }
Public Property jobName As String
    Get
    Set
public:
property String^ jobName {
    String^ get ();
    void set (String^ value);
}
member jobName : string with get, set

Property Value

Type: String
See Also

Reference

FailoverReportingModel Class


FailoverReportingModel.jobType Property

FailoverReportingModeljobType Property
This is the job type as described within JobInfo.cs

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string jobType { get; set; }
Public Property jobType As String
    Get
    Set
public:
property String^ jobType {
    String^ get ();
    void set (String^ value);
}
member jobType : string with get, set

Property Value

Type: String
See Also

Reference

FailoverReportingModel Class


FailoverReportingModel.snapshotLabel Property

FailoverReportingModelsnapshotLabel Property
Label for the snapshot used. (Empty string for live data.)

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string snapshotLabel { get; set; }
Public Property snapshotLabel As String
    Get
    Set
public:
property String^ snapshotLabel {
    String^ get ();
    void set (String^ value);
}
member snapshotLabel : string with get, set

Property Value

Type: String
See Also

Reference

FailoverReportingModel Class


FailoverReportingModel.targetedMachineInfo Property

FailoverReportingModeltargetedMachineInfo Property
Information about the target machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public FailoverReportMachineInfoModel targetedMachineInfo { get; set; }
Public Property targetedMachineInfo As FailoverReportMachineInfoModel
    Get
    Set
public:
property FailoverReportMachineInfoModel^ targetedMachineInfo {
    FailoverReportMachineInfoModel^ get ();
    void set (FailoverReportMachineInfoModel^ value);
}
member targetedMachineInfo : FailoverReportMachineInfoModel with get, set

Property Value

Type: FailoverReportMachineInfoModel
See Also

Reference

FailoverReportingModel Class


FailoverReportingModel.times Property

FailoverReportingModeltimes Property
Times for this failover

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public FailoverReportTimesModel times { get; set; }
Public Property times As FailoverReportTimesModel
    Get
    Set
public:
property FailoverReportTimesModel^ times {
    FailoverReportTimesModel^ get ();
    void set (FailoverReportTimesModel^ value);
}
member times : FailoverReportTimesModel with get, set

Property Value

Type: FailoverReportTimesModel
See Also

Reference

FailoverReportingModel Class


FailoverReportingModel Methods

FailoverReportingModel Methods

The FailoverReportingModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FailoverReportingModel Class


FailoverReportMachineInfoModel Class

FailoverReportMachineInfoModel Class
Data about the target machine
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFailoverReportMachineInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class FailoverReportMachineInfoModel
Public NotInheritable Class FailoverReportMachineInfoModel
public ref class FailoverReportMachineInfoModel sealed
[<SealedAttribute>]
type FailoverReportMachineInfoModel =  class end

The FailoverReportMachineInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | FailoverReportMachineInfoModel | Initializes a new instance of the FailoverReportMachineInfoModel class
Top
Properties
 | Name | Description
Public property | os | OS on the machine.
Public property | osVersion | OS version on the machine.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverReportMachineInfoModel Constructor

FailoverReportMachineInfoModel Constructor
Initializes a new instance of the FailoverReportMachineInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public FailoverReportMachineInfoModel()
Public Sub New
public:
FailoverReportMachineInfoModel()
new : unit -> FailoverReportMachineInfoModel
See Also

Reference

FailoverReportMachineInfoModel Class


FailoverReportMachineInfoModel Properties

FailoverReportMachineInfoModel Properties

The FailoverReportMachineInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | os | OS on the machine.
Public property | osVersion | OS version on the machine.
Top
See Also

Reference

FailoverReportMachineInfoModel Class


FailoverReportMachineInfoModel.os Property

FailoverReportMachineInfoModelos Property
OS on the machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string os { get; set; }
Public Property os As String
    Get
    Set
public:
property String^ os {
    String^ get ();
    void set (String^ value);
}
member os : string with get, set

Property Value

Type: String
See Also

Reference

FailoverReportMachineInfoModel Class


FailoverReportMachineInfoModel.osVersion Property

FailoverReportMachineInfoModelosVersion Property
OS version on the machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string osVersion { get; set; }
Public Property osVersion As String
    Get
    Set
public:
property String^ osVersion {
    String^ get ();
    void set (String^ value);
}
member osVersion : string with get, set

Property Value

Type: String
See Also

Reference

FailoverReportMachineInfoModel Class


FailoverReportMachineInfoModel Methods

FailoverReportMachineInfoModel Methods

The FailoverReportMachineInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FailoverReportMachineInfoModel Class


FailoverReportTimesModel Class

FailoverReportTimesModel Class
Time at various points of the failover.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFailoverReportTimesModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class FailoverReportTimesModel
Public NotInheritable Class FailoverReportTimesModel
public ref class FailoverReportTimesModel sealed
[<SealedAttribute>]
type FailoverReportTimesModel =  class end

The FailoverReportTimesModel type exposes the following members.

Constructors
 | Name | Description
Public method | FailoverReportTimesModel | Initializes a new instance of the FailoverReportTimesModel class
Top
Properties
 | Name | Description
Public property | completed | Time that the failover is considered complete.
Public property | startProcessing | Time the failover processing started.
Public property | startReboot | Time when the reboot started. NOTE: For data only jobs, this time will be null.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverReportTimesModel Constructor

FailoverReportTimesModel Constructor
Initializes a new instance of the FailoverReportTimesModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public FailoverReportTimesModel()
Public Sub New
public:
FailoverReportTimesModel()
new : unit -> FailoverReportTimesModel
See Also

Reference

FailoverReportTimesModel Class


FailoverReportTimesModel Properties

FailoverReportTimesModel Properties

The FailoverReportTimesModel type exposes the following members.

Properties
 | Name | Description
Public property | completed | Time that the failover is considered complete.
Public property | startProcessing | Time the failover processing started.
Public property | startReboot | Time when the reboot started. NOTE: For data only jobs, this time will be null.
Top
See Also

Reference

FailoverReportTimesModel Class


FailoverReportTimesModel.completed Property

FailoverReportTimesModelcompleted Property
Time that the failover is considered complete.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> completed { get; set; }
Public Property completed As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> completed {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member completed : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

FailoverReportTimesModel Class


FailoverReportTimesModel.startProcessing Property

FailoverReportTimesModelstartProcessing Property
Time the failover processing started.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DateTime startProcessing { get; set; }
Public Property startProcessing As DateTime
    Get
    Set
public:
property DateTime startProcessing {
    DateTime get ();
    void set (DateTime value);
}
member startProcessing : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

FailoverReportTimesModel Class


FailoverReportTimesModel.startReboot Property

FailoverReportTimesModelstartReboot Property
Time when the reboot started. NOTE: For data only jobs, this time will be null.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> startReboot { get; set; }
Public Property startReboot As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> startReboot {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member startReboot : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

FailoverReportTimesModel Class


FailoverReportTimesModel Methods

FailoverReportTimesModel Methods

The FailoverReportTimesModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FailoverReportTimesModel Class


FailoverReportTypeEnum Enumeration

FailoverReportTypeEnum Enumeration
Type of failover being used.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public enum FailoverReportTypeEnum
Public Enumeration FailoverReportTypeEnum
public enum class FailoverReportTypeEnum
type FailoverReportTypeEnum
Members
Member name | Value | Description
Live | 0 | Live failover is being done.
Test | 1 | Test failover is being done.
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverScriptConfigurationModel Class

FailoverScriptConfigurationModel Class
Failover script configuration model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFailoverScriptConfigurationModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public class FailoverScriptConfigurationModel
Public Class FailoverScriptConfigurationModel
public ref class FailoverScriptConfigurationModel
type FailoverScriptConfigurationModel =  class end

The FailoverScriptConfigurationModel type exposes the following members.

Constructors
 | Name | Description
Public method | FailoverScriptConfigurationModel | Initializes a new instance of the FailoverScriptConfigurationModel class
Top
Properties
 | Name | Description
Public property | PostFailbackScript | Gets or sets script to be run after the failback operation completes.
Public property | PostFailbackScriptArgs | Gets or sets arguments to be used when running the post-failback script.
Public property | PostFailoverScript | Gets or sets script to be run after the failover operation completes.
Public property | PostFailoverScriptArgs | Gets or sets arguments to be used when running the post-failover script.
Public property | PreFailbackScript | Gets or sets script to be run before the failback operation is started.
Public property | PreFailbackScriptArgs | Gets or sets arguments to be used when running the pre-failback script.
Public property | PreFailbackWait | Gets or sets a value indicating whether or not to wait for the pre-failback script to complete before continuing with the failback operation.
Public property | PreFailoverScript | Gets or sets script to be run before the failover operation is started.
Public property | PreFailoverScriptArgs | Gets or sets arguments to be used when running the pre-failover script.
Public property | PreFailoverWait | Gets or sets a value indicating whether or not to wait for the pre-failover script to complete before continuing with the failover operation.
Public property | SourcePostFailbackScript | Gets or sets script to be run after the failback operation completes.
Public property | SourcePostFailbackScriptArgs | Gets or sets arguments to be used when running the source post-failback script.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverScriptConfigurationModel Constructor

FailoverScriptConfigurationModel Constructor
Initializes a new instance of the FailoverScriptConfigurationModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverScriptConfigurationModel()
Public Sub New
public:
FailoverScriptConfigurationModel()
new : unit -> FailoverScriptConfigurationModel
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel Properties

FailoverScriptConfigurationModel Properties

The FailoverScriptConfigurationModel type exposes the following members.

Properties
 | Name | Description
Public property | PostFailbackScript | Gets or sets script to be run after the failback operation completes.
Public property | PostFailbackScriptArgs | Gets or sets arguments to be used when running the post-failback script.
Public property | PostFailoverScript | Gets or sets script to be run after the failover operation completes.
Public property | PostFailoverScriptArgs | Gets or sets arguments to be used when running the post-failover script.
Public property | PreFailbackScript | Gets or sets script to be run before the failback operation is started.
Public property | PreFailbackScriptArgs | Gets or sets arguments to be used when running the pre-failback script.
Public property | PreFailbackWait | Gets or sets a value indicating whether or not to wait for the pre-failback script to complete before continuing with the failback operation.
Public property | PreFailoverScript | Gets or sets script to be run before the failover operation is started.
Public property | PreFailoverScriptArgs | Gets or sets arguments to be used when running the pre-failover script.
Public property | PreFailoverWait | Gets or sets a value indicating whether or not to wait for the pre-failover script to complete before continuing with the failover operation.
Public property | SourcePostFailbackScript | Gets or sets script to be run after the failback operation completes.
Public property | SourcePostFailbackScriptArgs | Gets or sets arguments to be used when running the source post-failback script.
Top
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel.PostFailbackScript Property

FailoverScriptConfigurationModelPostFailbackScript Property
Gets or sets script to be run after the failback operation completes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string PostFailbackScript { get; set; }
Public Property PostFailbackScript As String
    Get
    Set
public:
property String^ PostFailbackScript {
    String^ get ();
    void set (String^ value);
}
member PostFailbackScript : string with get, set

Property Value

Type: String
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel.PostFailbackScriptArgs Property

FailoverScriptConfigurationModelPostFailbackScriptArgs Property
Gets or sets arguments to be used when running the post-failback script.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string PostFailbackScriptArgs { get; set; }
Public Property PostFailbackScriptArgs As String
    Get
    Set
public:
property String^ PostFailbackScriptArgs {
    String^ get ();
    void set (String^ value);
}
member PostFailbackScriptArgs : string with get, set

Property Value

Type: String
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel.PostFailoverScript Property

FailoverScriptConfigurationModelPostFailoverScript Property
Gets or sets script to be run after the failover operation completes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string PostFailoverScript { get; set; }
Public Property PostFailoverScript As String
    Get
    Set
public:
property String^ PostFailoverScript {
    String^ get ();
    void set (String^ value);
}
member PostFailoverScript : string with get, set

Property Value

Type: String
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel.PostFailoverScriptArgs Property

FailoverScriptConfigurationModelPostFailoverScriptArgs Property
Gets or sets arguments to be used when running the post-failover script.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string PostFailoverScriptArgs { get; set; }
Public Property PostFailoverScriptArgs As String
    Get
    Set
public:
property String^ PostFailoverScriptArgs {
    String^ get ();
    void set (String^ value);
}
member PostFailoverScriptArgs : string with get, set

Property Value

Type: String
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel.PreFailbackScript Property

FailoverScriptConfigurationModelPreFailbackScript Property
Gets or sets script to be run before the failback operation is started.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string PreFailbackScript { get; set; }
Public Property PreFailbackScript As String
    Get
    Set
public:
property String^ PreFailbackScript {
    String^ get ();
    void set (String^ value);
}
member PreFailbackScript : string with get, set

Property Value

Type: String
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel.PreFailbackScriptArgs Property

FailoverScriptConfigurationModelPreFailbackScriptArgs Property
Gets or sets arguments to be used when running the pre-failback script.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string PreFailbackScriptArgs { get; set; }
Public Property PreFailbackScriptArgs As String
    Get
    Set
public:
property String^ PreFailbackScriptArgs {
    String^ get ();
    void set (String^ value);
}
member PreFailbackScriptArgs : string with get, set

Property Value

Type: String
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel.PreFailbackWait Property

FailoverScriptConfigurationModelPreFailbackWait Property
Gets or sets a value indicating whether or not to wait for the pre-failback script to complete before continuing with the failback operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool PreFailbackWait { get; set; }
Public Property PreFailbackWait As Boolean
    Get
    Set
public:
property bool PreFailbackWait {
    bool get ();
    void set (bool value);
}
member PreFailbackWait : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel.PreFailoverScript Property

FailoverScriptConfigurationModelPreFailoverScript Property
Gets or sets script to be run before the failover operation is started.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string PreFailoverScript { get; set; }
Public Property PreFailoverScript As String
    Get
    Set
public:
property String^ PreFailoverScript {
    String^ get ();
    void set (String^ value);
}
member PreFailoverScript : string with get, set

Property Value

Type: String
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel.PreFailoverScriptArgs Property

FailoverScriptConfigurationModelPreFailoverScriptArgs Property
Gets or sets arguments to be used when running the pre-failover script.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string PreFailoverScriptArgs { get; set; }
Public Property PreFailoverScriptArgs As String
    Get
    Set
public:
property String^ PreFailoverScriptArgs {
    String^ get ();
    void set (String^ value);
}
member PreFailoverScriptArgs : string with get, set

Property Value

Type: String
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel.PreFailoverWait Property

FailoverScriptConfigurationModelPreFailoverWait Property
Gets or sets a value indicating whether or not to wait for the pre-failover script to complete before continuing with the failover operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool PreFailoverWait { get; set; }
Public Property PreFailoverWait As Boolean
    Get
    Set
public:
property bool PreFailoverWait {
    bool get ();
    void set (bool value);
}
member PreFailoverWait : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel.SourcePostFailbackScript Property

FailoverScriptConfigurationModelSourcePostFailbackScript Property
Gets or sets script to be run after the failback operation completes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourcePostFailbackScript { get; set; }
Public Property SourcePostFailbackScript As String
    Get
    Set
public:
property String^ SourcePostFailbackScript {
    String^ get ();
    void set (String^ value);
}
member SourcePostFailbackScript : string with get, set

Property Value

Type: String
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel.SourcePostFailbackScriptArgs Property

FailoverScriptConfigurationModelSourcePostFailbackScriptArgs Property
Gets or sets arguments to be used when running the source post-failback script.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourcePostFailbackScriptArgs { get; set; }
Public Property SourcePostFailbackScriptArgs As String
    Get
    Set
public:
property String^ SourcePostFailbackScriptArgs {
    String^ get ();
    void set (String^ value);
}
member SourcePostFailbackScriptArgs : string with get, set

Property Value

Type: String
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverScriptConfigurationModel Methods

FailoverScriptConfigurationModel Methods

The FailoverScriptConfigurationModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FailoverScriptConfigurationModel Class


FailoverStyle Enumeration

FailoverStyle Enumeration
Type of failover being used.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum FailoverStyle
Public Enumeration FailoverStyle
public enum class FailoverStyle
type FailoverStyle
Members
Member name | Value | Description
Live | 0 | Live failover is being done.
Test | 1 | Test failover is being done.
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverTrigger Enumeration

FailoverTrigger Enumeration
Failover trigger.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum FailoverTrigger
Public Enumeration FailoverTrigger
public enum class FailoverTrigger
type FailoverTrigger
Members
Member name | Value | Description
OneAddressFails | 0 | The one address fails
AllAddressesFail | 1 | All addresses fail
See Also

Reference

DoubleTake.Web.Models Namespace


FailoverType Enumeration

FailoverType Enumeration
Failover type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum FailoverType
Public Enumeration FailoverType
public enum class FailoverType
type FailoverType
Members
Member name | Value | Description
FullServer | 1 | The full server
Normal | 0 | The normal
See Also

Reference

DoubleTake.Web.Models Namespace


FeatureModel Class

FeatureModel Class
Feature model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFeatureModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class FeatureModel
Public NotInheritable Class FeatureModel
public ref class FeatureModel sealed
[<SealedAttribute>]
type FeatureModel =  class end

The FeatureModel type exposes the following members.

Constructors
 | Name | Description
Public method | FeatureModel | Initializes a new instance of the FeatureModel class
Top
Properties
 | Name | Description
Public property | Endpoint | Gets or sets the endpoint that identifies the location of this service.
Public property | Tag | Gets or sets a tag that identifies the role of this service.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FeatureModel Constructor

FeatureModel Constructor
Initializes a new instance of the FeatureModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FeatureModel()
Public Sub New
public:
FeatureModel()
new : unit -> FeatureModel
See Also

Reference

FeatureModel Class


FeatureModel Properties

FeatureModel Properties

The FeatureModel type exposes the following members.

Properties
 | Name | Description
Public property | Endpoint | Gets or sets the endpoint that identifies the location of this service.
Public property | Tag | Gets or sets a tag that identifies the role of this service.
Top
See Also

Reference

FeatureModel Class


FeatureModel.Endpoint Property

FeatureModelEndpoint Property
Gets or sets the endpoint that identifies the location of this service.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Uri Endpoint { get; set; }
Public Property Endpoint As Uri
    Get
    Set
public:
property Uri^ Endpoint {
    Uri^ get ();
    void set (Uri^ value);
}
member Endpoint : Uri with get, set

Property Value

Type: Uri
See Also

Reference

FeatureModel Class


FeatureModel.Tag Property

FeatureModelTag Property
Gets or sets a tag that identifies the role of this service.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Tag { get; set; }
Public Property Tag As String
    Get
    Set
public:
property String^ Tag {
    String^ get ();
    void set (String^ value);
}
member Tag : string with get, set

Property Value

Type: String
See Also

Reference

FeatureModel Class


FeatureModel Methods

FeatureModel Methods

The FeatureModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FeatureModel Class


FileItemModel Class

FileItemModel Class
File item model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsProtectableItemModel
DoubleTake.Web.ModelsPhysicalItemModel
DoubleTake.Web.ModelsFileItemModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class FileItemModel : PhysicalItemModel
Public NotInheritable Class FileItemModel
    Inherits PhysicalItemModel
public ref class FileItemModel sealed : public PhysicalItemModel
[<SealedAttribute>]
type FileItemModel =
    class
        inherit PhysicalItemModel
    end

The FileItemModel type exposes the following members.

Constructors
 | Name | Description
Public method | FileItemModel | Initializes a new instance of the FileItemModel class
Top
Properties
 | Name | Description
Public property | Attributes | Gets or sets a value specifying the file system attributes of this item. (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | Gets or sets the available free space on this volume. (Inherited from PhysicalItemModel.)
Public property | ClassName | Gets or sets the class name. (Inherited from PhysicalItemModel.)
Public property | CreationTime | Gets or sets a value specifying the time this item was created. (Inherited from PhysicalItemModel.)
Public property | DriveFormat | Gets or sets the format of the drive. (Inherited from PhysicalItemModel.)
Public property | DriveType | Gets or sets the type of the drive. (Inherited from PhysicalItemModel.)
Public property | Id | Gets or sets the item identifier. (Inherited from ProtectableItemModel.)
Public property | IsContainer | Gets or sets a value indicating whether or not this item is a container of other items. (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | Gets or sets a value indicating whether or not this item is read only; that is, its Saturation cannot be changed. (Inherited from ProtectableItemModel.)
Public property | IsSupported | Gets or sets a value indicating whether this volume is supported. (Inherited from PhysicalItemModel.)
Public property | IsSystemDrive | Gets or sets a value indicating whether or not this volume is the system drive. (Inherited from PhysicalItemModel.)
Public property | ItemType | Gets or sets the type of this item. (Inherited from ProtectableItemModel.)
Public property | Label | Gets or sets the volume label. (Inherited from PhysicalItemModel.)
Public property | LastAccessTime | Gets or sets a value specifying the time this item was last accessed. (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | Gets or sets a value specifying the time this item was last written to. (Inherited from PhysicalItemModel.)
Public property | Metadata | Gets or sets a value specifying additional meta data for this item. (Inherited from PhysicalItemModel.)
Public property | Name | Gets or sets the name of this item. (Inherited from ProtectableItemModel.)
Public property | PartitionName | Gets or sets the partition name. (Inherited from ProtectableItemModel.)
Public property | Path | Gets or sets the path that uniquely identifies this item. (Inherited from ProtectableItemModel.)
Public property | Saturation | Gets or sets the saturation level of this item. (Inherited from ProtectableItemModel.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume. (Inherited from PhysicalItemModel.)
Public property | Size | Gets or sets a value indicating the physical size of the item. (Inherited from PhysicalItemModel.)
Public property | TotalSize | Gets or sets the total size of the volume. (Inherited from PhysicalItemModel.)
Public property | VolumeType | Gets or sets the volume type. (Inherited from PhysicalItemModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FileItemModel Constructor

FileItemModel Constructor
Initializes a new instance of the FileItemModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FileItemModel()
Public Sub New
public:
FileItemModel()
new : unit -> FileItemModel
See Also

Reference

FileItemModel Class


FileItemModel Properties

FileItemModel Properties

The FileItemModel type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets or sets a value specifying the file system attributes of this item. (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | Gets or sets the available free space on this volume. (Inherited from PhysicalItemModel.)
Public property | ClassName | Gets or sets the class name. (Inherited from PhysicalItemModel.)
Public property | CreationTime | Gets or sets a value specifying the time this item was created. (Inherited from PhysicalItemModel.)
Public property | DriveFormat | Gets or sets the format of the drive. (Inherited from PhysicalItemModel.)
Public property | DriveType | Gets or sets the type of the drive. (Inherited from PhysicalItemModel.)
Public property | Id | Gets or sets the item identifier. (Inherited from ProtectableItemModel.)
Public property | IsContainer | Gets or sets a value indicating whether or not this item is a container of other items. (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | Gets or sets a value indicating whether or not this item is read only; that is, its Saturation cannot be changed. (Inherited from ProtectableItemModel.)
Public property | IsSupported | Gets or sets a value indicating whether this volume is supported. (Inherited from PhysicalItemModel.)
Public property | IsSystemDrive | Gets or sets a value indicating whether or not this volume is the system drive. (Inherited from PhysicalItemModel.)
Public property | ItemType | Gets or sets the type of this item. (Inherited from ProtectableItemModel.)
Public property | Label | Gets or sets the volume label. (Inherited from PhysicalItemModel.)
Public property | LastAccessTime | Gets or sets a value specifying the time this item was last accessed. (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | Gets or sets a value specifying the time this item was last written to. (Inherited from PhysicalItemModel.)
Public property | Metadata | Gets or sets a value specifying additional meta data for this item. (Inherited from PhysicalItemModel.)
Public property | Name | Gets or sets the name of this item. (Inherited from ProtectableItemModel.)
Public property | PartitionName | Gets or sets the partition name. (Inherited from ProtectableItemModel.)
Public property | Path | Gets or sets the path that uniquely identifies this item. (Inherited from ProtectableItemModel.)
Public property | Saturation | Gets or sets the saturation level of this item. (Inherited from ProtectableItemModel.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume. (Inherited from PhysicalItemModel.)
Public property | Size | Gets or sets a value indicating the physical size of the item. (Inherited from PhysicalItemModel.)
Public property | TotalSize | Gets or sets the total size of the volume. (Inherited from PhysicalItemModel.)
Public property | VolumeType | Gets or sets the volume type. (Inherited from PhysicalItemModel.)
Top
See Also

Reference

FileItemModel Class


FileItemModel Methods

FileItemModel Methods

The FileItemModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FileItemModel Class


FilesAndFoldersPersistedStateModel Class

FilesAndFoldersPersistedStateModel Class
Files and Folders persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFilesAndFoldersPersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class FilesAndFoldersPersistedStateModel
Public NotInheritable Class FilesAndFoldersPersistedStateModel
public ref class FilesAndFoldersPersistedStateModel sealed
[<SealedAttribute>]
type FilesAndFoldersPersistedStateModel =  class end

The FilesAndFoldersPersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | FilesAndFoldersPersistedStateModel | Initializes a new instance of the FilesAndFoldersPersistedStateModel class
Top
Properties
 | Name | Description
Public property | FailedSubState | Gets or sets a value indicating the sub-state when the State property is Failed.
Public property | MainConnectionPersistedState | Gets or sets the main connection's persisted state.
Public property | MonitorId | Gets or sets the id of the Monitoring Framework monitor used by this job.
Public property | MonitorPersistedState | Gets or sets the monitor's persisted state.
Public property | OriginalSourceAddress | Gets or sets the original source address.
Public property | OriginalSourceHostUri | Gets or sets the original source URI.
Public property | OriginalSourceMachineName | Gets or sets the name of the original source machine.
Public property | OriginalSourceUniqueId | Gets or sets the original source's unique id.
Public property | RestoreTargetHostUri | Gets or sets the restore target URI.
Public property | RestoreTargetUniqueId | Gets or sets the restore target's unique id.
Public property | State | Gets or sets the persisted state of the job.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FilesAndFoldersPersistedStateModel Constructor

FilesAndFoldersPersistedStateModel Constructor
Initializes a new instance of the FilesAndFoldersPersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public FilesAndFoldersPersistedStateModel()
Public Sub New
public:
FilesAndFoldersPersistedStateModel()
new : unit -> FilesAndFoldersPersistedStateModel
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel Properties

FilesAndFoldersPersistedStateModel Properties

The FilesAndFoldersPersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | FailedSubState | Gets or sets a value indicating the sub-state when the State property is Failed.
Public property | MainConnectionPersistedState | Gets or sets the main connection's persisted state.
Public property | MonitorId | Gets or sets the id of the Monitoring Framework monitor used by this job.
Public property | MonitorPersistedState | Gets or sets the monitor's persisted state.
Public property | OriginalSourceAddress | Gets or sets the original source address.
Public property | OriginalSourceHostUri | Gets or sets the original source URI.
Public property | OriginalSourceMachineName | Gets or sets the name of the original source machine.
Public property | OriginalSourceUniqueId | Gets or sets the original source's unique id.
Public property | RestoreTargetHostUri | Gets or sets the restore target URI.
Public property | RestoreTargetUniqueId | Gets or sets the restore target's unique id.
Public property | State | Gets or sets the persisted state of the job.
Top
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel.FailedSubState Property

FilesAndFoldersPersistedStateModelFailedSubState Property
Gets or sets a value indicating the sub-state when the State property is Failed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string FailedSubState { get; set; }
Public Property FailedSubState As String
    Get
    Set
public:
property String^ FailedSubState {
    String^ get ();
    void set (String^ value);
}
member FailedSubState : string with get, set

Property Value

Type: String
The sub-state when the State property is Failed.
Remarks
Possible values for this property:
Value | Description
FailedOver | The job is in a failed-over state which means that the target is standing in for the source.
FailedBack | The target is no longer standing in for the source
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel.MainConnectionPersistedState Property

FilesAndFoldersPersistedStateModelMainConnectionPersistedState Property
Gets or sets the main connection's persisted state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionPersistedStateModel MainConnectionPersistedState { get; set; }
Public Property MainConnectionPersistedState As CoreConnectionPersistedStateModel
    Get
    Set
public:
property CoreConnectionPersistedStateModel^ MainConnectionPersistedState {
    CoreConnectionPersistedStateModel^ get ();
    void set (CoreConnectionPersistedStateModel^ value);
}
member MainConnectionPersistedState : CoreConnectionPersistedStateModel with get, set

Property Value

Type: CoreConnectionPersistedStateModel
The main connection's persisted state.
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel.MonitorId Property

FilesAndFoldersPersistedStateModelMonitorId Property
Gets or sets the id of the Monitoring Framework monitor used by this job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Guid MonitorId { get; set; }
Public Property MonitorId As Guid
    Get
    Set
public:
property Guid MonitorId {
    Guid get ();
    void set (Guid value);
}
member MonitorId : Guid with get, set

Property Value

Type: Guid
The id of the Monitoring Framework monitor used by this job.
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel.MonitorPersistedState Property

FilesAndFoldersPersistedStateModelMonitorPersistedState Property
Gets or sets the monitor's persisted state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CoreMonitorPersistedStateModel MonitorPersistedState { get; set; }
Public Property MonitorPersistedState As CoreMonitorPersistedStateModel
    Get
    Set
public:
property CoreMonitorPersistedStateModel^ MonitorPersistedState {
    CoreMonitorPersistedStateModel^ get ();
    void set (CoreMonitorPersistedStateModel^ value);
}
member MonitorPersistedState : CoreMonitorPersistedStateModel with get, set

Property Value

Type: CoreMonitorPersistedStateModel
The monitor's persisted state.
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel.OriginalSourceAddress Property

FilesAndFoldersPersistedStateModelOriginalSourceAddress Property
Gets or sets the original source address.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string OriginalSourceAddress { get; set; }
Public Property OriginalSourceAddress As String
    Get
    Set
public:
property String^ OriginalSourceAddress {
    String^ get ();
    void set (String^ value);
}
member OriginalSourceAddress : string with get, set

Property Value

Type: String
The original source address.
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel.OriginalSourceHostUri Property

FilesAndFoldersPersistedStateModelOriginalSourceHostUri Property
Gets or sets the original source URI.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Uri OriginalSourceHostUri { get; set; }
Public Property OriginalSourceHostUri As Uri
    Get
    Set
public:
property Uri^ OriginalSourceHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
member OriginalSourceHostUri : Uri with get, set

Property Value

Type: Uri
The original source URI.
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel.OriginalSourceMachineName Property

FilesAndFoldersPersistedStateModelOriginalSourceMachineName Property
Gets or sets the name of the original source machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string OriginalSourceMachineName { get; set; }
Public Property OriginalSourceMachineName As String
    Get
    Set
public:
property String^ OriginalSourceMachineName {
    String^ get ();
    void set (String^ value);
}
member OriginalSourceMachineName : string with get, set

Property Value

Type: String
The name of the original source machine.
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel.OriginalSourceUniqueId Property

FilesAndFoldersPersistedStateModelOriginalSourceUniqueId Property
Gets or sets the original source's unique id.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string OriginalSourceUniqueId { get; set; }
Public Property OriginalSourceUniqueId As String
    Get
    Set
public:
property String^ OriginalSourceUniqueId {
    String^ get ();
    void set (String^ value);
}
member OriginalSourceUniqueId : string with get, set

Property Value

Type: String
The original source's unique id.
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel.RestoreTargetHostUri Property

FilesAndFoldersPersistedStateModelRestoreTargetHostUri Property
Gets or sets the restore target URI.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Uri RestoreTargetHostUri { get; set; }
Public Property RestoreTargetHostUri As Uri
    Get
    Set
public:
property Uri^ RestoreTargetHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
member RestoreTargetHostUri : Uri with get, set

Property Value

Type: Uri
The restore target URI.
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel.RestoreTargetUniqueId Property

FilesAndFoldersPersistedStateModelRestoreTargetUniqueId Property
Gets or sets the restore target's unique id.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string RestoreTargetUniqueId { get; set; }
Public Property RestoreTargetUniqueId As String
    Get
    Set
public:
property String^ RestoreTargetUniqueId {
    String^ get ();
    void set (String^ value);
}
member RestoreTargetUniqueId : string with get, set

Property Value

Type: String
The restore target's unique id.
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel.State Property

FilesAndFoldersPersistedStateModelState Property
Gets or sets the persisted state of the job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string State { get; set; }
Public Property State As String
    Get
    Set
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}
member State : string with get, set

Property Value

Type: String
The persisted state of the job.
Remarks
Possible values for this property:
Value | Description
None | No state had been determined due to failed initialization.
Stopped | The job was in a stopped state.
Protecting | The job was in a protecting state.
Restoring | The job was restoring.
Failed | The job was in a failed state.
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FilesAndFoldersPersistedStateModel Methods

FilesAndFoldersPersistedStateModel Methods

The FilesAndFoldersPersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FilesAndFoldersPersistedStateModel Class


FileSystemAttributes Enumeration

FileSystemAttributes Enumeration
File system attributes

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum FileSystemAttributes
<FlagsAttribute>
Public Enumeration FileSystemAttributes
[FlagsAttribute]
public enum class FileSystemAttributes
[<FlagsAttribute>]
type FileSystemAttributes
Members
Member name | Value | Description
ReadOnly | 1 | The read only
Hidden | 2 | The hidden
System | 4 | The system
Directory | 16 | The directory
Archive | 32 | The archive
Normal | 128 | The normal
Temporary | 256 | The temporary
SparseFile | 512 | The sparse file
ReparsePoint | 1024 | The reparse point
Compressed | 2048 | The compressed
Offline | 4096 | The offline
NotContentIndexed | 8192 | The not content indexed
Encrypted | 16384 | The encrypted
See Also

Reference

DoubleTake.Web.Models Namespace


FixJobOptionsRequestModel Class

FixJobOptionsRequestModel Class
Fix job options request model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFixJobOptionsRequestModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class FixJobOptionsRequestModel
Public NotInheritable Class FixJobOptionsRequestModel
public ref class FixJobOptionsRequestModel sealed
[<SealedAttribute>]
type FixJobOptionsRequestModel =  class end

The FixJobOptionsRequestModel type exposes the following members.

Constructors
 | Name | Description
Public method | FixJobOptionsRequestModel | Initializes a new instance of the FixJobOptionsRequestModel class
Top
Properties
 | Name | Description
Public property | JobOptions | Gets or sets the job options.
Public property | StepsToFix | Gets or sets the steps to fix.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FixJobOptionsRequestModel Constructor

FixJobOptionsRequestModel Constructor
Initializes a new instance of the FixJobOptionsRequestModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FixJobOptionsRequestModel()
Public Sub New
public:
FixJobOptionsRequestModel()
new : unit -> FixJobOptionsRequestModel
See Also

Reference

FixJobOptionsRequestModel Class


FixJobOptionsRequestModel Properties

FixJobOptionsRequestModel Properties

The FixJobOptionsRequestModel type exposes the following members.

Properties
 | Name | Description
Public property | JobOptions | Gets or sets the job options.
Public property | StepsToFix | Gets or sets the steps to fix.
Top
See Also

Reference

FixJobOptionsRequestModel Class


FixJobOptionsRequestModel.JobOptions Property

FixJobOptionsRequestModelJobOptions Property
Gets or sets the job options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public JobOptionsModel JobOptions { get; set; }
Public Property JobOptions As JobOptionsModel
    Get
    Set
public:
property JobOptionsModel^ JobOptions {
    JobOptionsModel^ get ();
    void set (JobOptionsModel^ value);
}
member JobOptions : JobOptionsModel with get, set

Property Value

Type: JobOptionsModel
The job options.
See Also

Reference

FixJobOptionsRequestModel Class


FixJobOptionsRequestModel.StepsToFix Property

FixJobOptionsRequestModelStepsToFix Property
Gets or sets the steps to fix.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VerificationStepModel[] StepsToFix { get; set; }
Public Property StepsToFix As VerificationStepModel()
    Get
    Set
public:
property array<VerificationStepModel^>^ StepsToFix {
    array<VerificationStepModel^>^ get ();
    void set (array<VerificationStepModel^>^ value);
}
member StepsToFix : VerificationStepModel[] with get, set

Property Value

Type: VerificationStepModel
The steps to fix.
See Also

Reference

FixJobOptionsRequestModel Class


FixJobOptionsRequestModel Methods

FixJobOptionsRequestModel Methods

The FixJobOptionsRequestModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FixJobOptionsRequestModel Class


FixJobOptionsStatusModel Class

FixJobOptionsStatusModel Class
Fix job options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActivityStatusModel
DoubleTake.Web.ModelsFixJobOptionsStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class FixJobOptionsStatusModel : ActivityStatusModel
Public NotInheritable Class FixJobOptionsStatusModel
    Inherits ActivityStatusModel
public ref class FixJobOptionsStatusModel sealed : public ActivityStatusModel
[<SealedAttribute>]
type FixJobOptionsStatusModel =
    class
        inherit ActivityStatusModel
    end

The FixJobOptionsStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | FixJobOptionsStatusModel | Initializes a new instance of the FixJobOptionsStatusModel class
Top
Properties
 | Name | Description
Public property | Duration | Gets or sets a value the duration of the activity at the time this status was yielded. (Inherited from ActivityStatusModel.)
Public property | JobOptions | Gets or sets the new job options after the fixing is complete.
Public property | MessageFormatParameters | Gets or sets the message format parameters. (Inherited from ActivityStatusModel.)
Public property | MessageId | Gets or sets a value representing a message identifier. (Inherited from ActivityStatusModel.)
Public property | RequesterUserName | Gets or sets the user that initiated the activity. (Inherited from ActivityStatusModel.)
Public property | Status | Gets or sets the current status of the activity. (Inherited from ActivityStatusModel.)
Public property | StatusUri | Gets or sets the URI to call to obtain further status information - missing if the status is 'completed', 'canceled' or 'faulted'. (Inherited from ActivityStatusModel.)
Public property | TimeStamp | Gets or sets the server time when the activity yielded this status. (Inherited from ActivityStatusModel.)
Public property | Token | Gets or sets a token that identifies the request that initiated the activity. (Inherited from ActivityStatusModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FixJobOptionsStatusModel Constructor

FixJobOptionsStatusModel Constructor
Initializes a new instance of the FixJobOptionsStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FixJobOptionsStatusModel()
Public Sub New
public:
FixJobOptionsStatusModel()
new : unit -> FixJobOptionsStatusModel
See Also

Reference

FixJobOptionsStatusModel Class


FixJobOptionsStatusModel Properties

FixJobOptionsStatusModel Properties

The FixJobOptionsStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | Duration | Gets or sets a value the duration of the activity at the time this status was yielded. (Inherited from ActivityStatusModel.)
Public property | JobOptions | Gets or sets the new job options after the fixing is complete.
Public property | MessageFormatParameters | Gets or sets the message format parameters. (Inherited from ActivityStatusModel.)
Public property | MessageId | Gets or sets a value representing a message identifier. (Inherited from ActivityStatusModel.)
Public property | RequesterUserName | Gets or sets the user that initiated the activity. (Inherited from ActivityStatusModel.)
Public property | Status | Gets or sets the current status of the activity. (Inherited from ActivityStatusModel.)
Public property | StatusUri | Gets or sets the URI to call to obtain further status information - missing if the status is 'completed', 'canceled' or 'faulted'. (Inherited from ActivityStatusModel.)
Public property | TimeStamp | Gets or sets the server time when the activity yielded this status. (Inherited from ActivityStatusModel.)
Public property | Token | Gets or sets a token that identifies the request that initiated the activity. (Inherited from ActivityStatusModel.)
Top
See Also

Reference

FixJobOptionsStatusModel Class


FixJobOptionsStatusModel.JobOptions Property

FixJobOptionsStatusModelJobOptions Property
Gets or sets the new job options after the fixing is complete.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public JobOptionsModel JobOptions { get; set; }
Public Property JobOptions As JobOptionsModel
    Get
    Set
public:
property JobOptionsModel^ JobOptions {
    JobOptionsModel^ get ();
    void set (JobOptionsModel^ value);
}
member JobOptions : JobOptionsModel with get, set

Property Value

Type: JobOptionsModel
See Also

Reference

FixJobOptionsStatusModel Class


FixJobOptionsStatusModel Methods

FixJobOptionsStatusModel Methods

The FixJobOptionsStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FixJobOptionsStatusModel Class


FixRecommendedJobOptionsRequestModel Class

FixRecommendedJobOptionsRequestModel Class
Fix recommended job options request model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFixRecommendedJobOptionsRequestModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public class FixRecommendedJobOptionsRequestModel
Public Class FixRecommendedJobOptionsRequestModel
public ref class FixRecommendedJobOptionsRequestModel
type FixRecommendedJobOptionsRequestModel =  class end

The FixRecommendedJobOptionsRequestModel type exposes the following members.

Constructors
 | Name | Description
Public method | FixRecommendedJobOptionsRequestModel | Initializes a new instance of the FixRecommendedJobOptionsRequestModel class
Top
Properties
 | Name | Description
Public property | JobCredentials | Gets or sets the job credentials.
Public property | JobOptions | Gets or sets the job options.
Public property | JobType | Gets or sets the type of the job.
Public property | StepsToFix | Gets or sets the steps to fix.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FixRecommendedJobOptionsRequestModel Constructor

FixRecommendedJobOptionsRequestModel Constructor
Initializes a new instance of the FixRecommendedJobOptionsRequestModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FixRecommendedJobOptionsRequestModel()
Public Sub New
public:
FixRecommendedJobOptionsRequestModel()
new : unit -> FixRecommendedJobOptionsRequestModel
See Also

Reference

FixRecommendedJobOptionsRequestModel Class


FixRecommendedJobOptionsRequestModel Properties

FixRecommendedJobOptionsRequestModel Properties

The FixRecommendedJobOptionsRequestModel type exposes the following members.

Properties
 | Name | Description
Public property | JobCredentials | Gets or sets the job credentials.
Public property | JobOptions | Gets or sets the job options.
Public property | JobType | Gets or sets the type of the job.
Public property | StepsToFix | Gets or sets the steps to fix.
Top
See Also

Reference

FixRecommendedJobOptionsRequestModel Class


FixRecommendedJobOptionsRequestModel.JobCredentials Property

FixRecommendedJobOptionsRequestModelJobCredentials Property
Gets or sets the job credentials.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public JobCredentialsModel JobCredentials { get; set; }
Public Property JobCredentials As JobCredentialsModel
    Get
    Set
public:
property JobCredentialsModel^ JobCredentials {
    JobCredentialsModel^ get ();
    void set (JobCredentialsModel^ value);
}
member JobCredentials : JobCredentialsModel with get, set

Property Value

Type: JobCredentialsModel
The job credentials.
See Also

Reference

FixRecommendedJobOptionsRequestModel Class


FixRecommendedJobOptionsRequestModel.JobOptions Property

FixRecommendedJobOptionsRequestModelJobOptions Property
Gets or sets the job options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public JobOptionsModel JobOptions { get; set; }
Public Property JobOptions As JobOptionsModel
    Get
    Set
public:
property JobOptionsModel^ JobOptions {
    JobOptionsModel^ get ();
    void set (JobOptionsModel^ value);
}
member JobOptions : JobOptionsModel with get, set

Property Value

Type: JobOptionsModel
The job options.
See Also

Reference

FixRecommendedJobOptionsRequestModel Class


FixRecommendedJobOptionsRequestModel.JobType Property

FixRecommendedJobOptionsRequestModelJobType Property
Gets or sets the type of the job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string JobType { get; set; }
Public Property JobType As String
    Get
    Set
public:
property String^ JobType {
    String^ get ();
    void set (String^ value);
}
member JobType : string with get, set

Property Value

Type: String
The type of the job.
See Also

Reference

FixRecommendedJobOptionsRequestModel Class


FixRecommendedJobOptionsRequestModel.StepsToFix Property

FixRecommendedJobOptionsRequestModelStepsToFix Property
Gets or sets the steps to fix.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VerificationStepModel[] StepsToFix { get; set; }
Public Property StepsToFix As VerificationStepModel()
    Get
    Set
public:
property array<VerificationStepModel^>^ StepsToFix {
    array<VerificationStepModel^>^ get ();
    void set (array<VerificationStepModel^>^ value);
}
member StepsToFix : VerificationStepModel[] with get, set

Property Value

Type: VerificationStepModel
The steps to fix.
See Also

Reference

FixRecommendedJobOptionsRequestModel Class


FixRecommendedJobOptionsRequestModel Methods

FixRecommendedJobOptionsRequestModel Methods

The FixRecommendedJobOptionsRequestModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FixRecommendedJobOptionsRequestModel Class


FullServerFailoverOptionsModel Class

FullServerFailoverOptionsModel Class
Full server failover options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFullServerFailoverOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class FullServerFailoverOptionsModel
Public NotInheritable Class FullServerFailoverOptionsModel
public ref class FullServerFailoverOptionsModel sealed
[<SealedAttribute>]
type FullServerFailoverOptionsModel =  class end

The FullServerFailoverOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | FullServerFailoverOptionsModel | Initializes a new instance of the FullServerFailoverOptionsModel class
Top
Properties
 | Name | Description
Public property | AdditionalStagingFolders | Gets or sets the additional folders that should be staged on the target server.
Public property | CreateBackupConnection | Gets or sets a value indicating whether or not the job should create a backup connection to put the target server's system on the source server.
Public property | RemoveOrphans | Gets or sets a value indicating whether or not orphans should be removed.
Public property | ReverseRoute | Gets or sets the reverse route.
Public property | ReverseRouteEnginePort | Gets or sets the engine port on the reverse route.
Public property | ShutdownSourceServer | Gets or sets a value indicating whether or not to shut down the source server during cut over.
Public property | SourceChecksumAll | Gets or sets a value indicating whether or not a checksum should be used for all files when comparing them.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FullServerFailoverOptionsModel Constructor

FullServerFailoverOptionsModel Constructor
Initializes a new instance of the FullServerFailoverOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FullServerFailoverOptionsModel()
Public Sub New
public:
FullServerFailoverOptionsModel()
new : unit -> FullServerFailoverOptionsModel
See Also

Reference

FullServerFailoverOptionsModel Class


FullServerFailoverOptionsModel Properties

FullServerFailoverOptionsModel Properties

The FullServerFailoverOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalStagingFolders | Gets or sets the additional folders that should be staged on the target server.
Public property | CreateBackupConnection | Gets or sets a value indicating whether or not the job should create a backup connection to put the target server's system on the source server.
Public property | RemoveOrphans | Gets or sets a value indicating whether or not orphans should be removed.
Public property | ReverseRoute | Gets or sets the reverse route.
Public property | ReverseRouteEnginePort | Gets or sets the engine port on the reverse route.
Public property | ShutdownSourceServer | Gets or sets a value indicating whether or not to shut down the source server during cut over.
Public property | SourceChecksumAll | Gets or sets a value indicating whether or not a checksum should be used for all files when comparing them.
Top
See Also

Reference

FullServerFailoverOptionsModel Class


FullServerFailoverOptionsModel.AdditionalStagingFolders Property

FullServerFailoverOptionsModelAdditionalStagingFolders Property
Gets or sets the additional folders that should be staged on the target server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] AdditionalStagingFolders { get; set; }
Public Property AdditionalStagingFolders As String()
    Get
    Set
public:
property array<String^>^ AdditionalStagingFolders {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member AdditionalStagingFolders : string[] with get, set

Property Value

Type: String
See Also

Reference

FullServerFailoverOptionsModel Class


FullServerFailoverOptionsModel.CreateBackupConnection Property

FullServerFailoverOptionsModelCreateBackupConnection Property
Gets or sets a value indicating whether or not the job should create a backup connection to put the target server's system on the source server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CreateBackupConnection { get; set; }
Public Property CreateBackupConnection As Boolean
    Get
    Set
public:
property bool CreateBackupConnection {
    bool get ();
    void set (bool value);
}
member CreateBackupConnection : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FullServerFailoverOptionsModel Class


FullServerFailoverOptionsModel.RemoveOrphans Property

FullServerFailoverOptionsModelRemoveOrphans Property
Gets or sets a value indicating whether or not orphans should be removed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool RemoveOrphans { get; set; }
Public Property RemoveOrphans As Boolean
    Get
    Set
public:
property bool RemoveOrphans {
    bool get ();
    void set (bool value);
}
member RemoveOrphans : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FullServerFailoverOptionsModel Class


FullServerFailoverOptionsModel.ReverseRoute Property

FullServerFailoverOptionsModelReverseRoute Property
Gets or sets the reverse route.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ReverseRoute { get; set; }
Public Property ReverseRoute As String
    Get
    Set
public:
property String^ ReverseRoute {
    String^ get ();
    void set (String^ value);
}
member ReverseRoute : string with get, set

Property Value

Type: String
See Also

Reference

FullServerFailoverOptionsModel Class


FullServerFailoverOptionsModel.ReverseRouteEnginePort Property

FullServerFailoverOptionsModelReverseRouteEnginePort Property
Gets or sets the engine port on the reverse route.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> ReverseRouteEnginePort { get; set; }
Public Property ReverseRouteEnginePort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> ReverseRouteEnginePort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member ReverseRouteEnginePort : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

FullServerFailoverOptionsModel Class


FullServerFailoverOptionsModel.ShutdownSourceServer Property

FullServerFailoverOptionsModelShutdownSourceServer Property
Gets or sets a value indicating whether or not to shut down the source server during cut over.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShutdownSourceServer { get; set; }
Public Property ShutdownSourceServer As Boolean
    Get
    Set
public:
property bool ShutdownSourceServer {
    bool get ();
    void set (bool value);
}
member ShutdownSourceServer : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FullServerFailoverOptionsModel Class


FullServerFailoverOptionsModel.SourceChecksumAll Property

FullServerFailoverOptionsModelSourceChecksumAll Property
Gets or sets a value indicating whether or not a checksum should be used for all files when comparing them.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool SourceChecksumAll { get; set; }
Public Property SourceChecksumAll As Boolean
    Get
    Set
public:
property bool SourceChecksumAll {
    bool get ();
    void set (bool value);
}
member SourceChecksumAll : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FullServerFailoverOptionsModel Class


FullServerFailoverOptionsModel Methods

FullServerFailoverOptionsModel Methods

The FullServerFailoverOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FullServerFailoverOptionsModel Class


FullServerJobDetailsModel Class

FullServerJobDetailsModel Class
Full server job details.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFullServerJobDetailsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class FullServerJobDetailsModel
Public NotInheritable Class FullServerJobDetailsModel
public ref class FullServerJobDetailsModel sealed
[<SealedAttribute>]
type FullServerJobDetailsModel =  class end

The FullServerJobDetailsModel type exposes the following members.

Constructors
 | Name | Description
Public method | FullServerJobDetailsModel | Initializes a new instance of the FullServerJobDetailsModel class
Top
Properties
 | Name | Description
Public property | BackupConnectionDetails | Gets or sets the details of the backup connection.
Public property | CutoverDetails | Gets or sets the details of the cut over operation.
Public property | ProtectionConnectionDetails | Gets or sets the details of the protection connection.
Public property | RecoveryConnectionDetails | Gets or sets the details of the recovery connection.
Public property | SystemVolumeRevertConnectionDetails | Gets or sets the details of the system volume revert connection.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FullServerJobDetailsModel Constructor

FullServerJobDetailsModel Constructor
Initializes a new instance of the FullServerJobDetailsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FullServerJobDetailsModel()
Public Sub New
public:
FullServerJobDetailsModel()
new : unit -> FullServerJobDetailsModel
See Also

Reference

FullServerJobDetailsModel Class


FullServerJobDetailsModel Properties

FullServerJobDetailsModel Properties

The FullServerJobDetailsModel type exposes the following members.

Properties
 | Name | Description
Public property | BackupConnectionDetails | Gets or sets the details of the backup connection.
Public property | CutoverDetails | Gets or sets the details of the cut over operation.
Public property | ProtectionConnectionDetails | Gets or sets the details of the protection connection.
Public property | RecoveryConnectionDetails | Gets or sets the details of the recovery connection.
Public property | SystemVolumeRevertConnectionDetails | Gets or sets the details of the system volume revert connection.
Top
See Also

Reference

FullServerJobDetailsModel Class


FullServerJobDetailsModel.BackupConnectionDetails Property

FullServerJobDetailsModelBackupConnectionDetails Property
Gets or sets the details of the backup connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionDetailsModel BackupConnectionDetails { get; set; }
Public Property BackupConnectionDetails As CoreConnectionDetailsModel
    Get
    Set
public:
property CoreConnectionDetailsModel^ BackupConnectionDetails {
    CoreConnectionDetailsModel^ get ();
    void set (CoreConnectionDetailsModel^ value);
}
member BackupConnectionDetails : CoreConnectionDetailsModel with get, set

Property Value

Type: CoreConnectionDetailsModel
See Also

Reference

FullServerJobDetailsModel Class


FullServerJobDetailsModel.CutoverDetails Property

FullServerJobDetailsModelCutoverDetails Property
Gets or sets the details of the cut over operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CutoverDetailsModel CutoverDetails { get; set; }
Public Property CutoverDetails As CutoverDetailsModel
    Get
    Set
public:
property CutoverDetailsModel^ CutoverDetails {
    CutoverDetailsModel^ get ();
    void set (CutoverDetailsModel^ value);
}
member CutoverDetails : CutoverDetailsModel with get, set

Property Value

Type: CutoverDetailsModel
See Also

Reference

FullServerJobDetailsModel Class


FullServerJobDetailsModel.ProtectionConnectionDetails Property

FullServerJobDetailsModelProtectionConnectionDetails Property
Gets or sets the details of the protection connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionDetailsModel ProtectionConnectionDetails { get; set; }
Public Property ProtectionConnectionDetails As CoreConnectionDetailsModel
    Get
    Set
public:
property CoreConnectionDetailsModel^ ProtectionConnectionDetails {
    CoreConnectionDetailsModel^ get ();
    void set (CoreConnectionDetailsModel^ value);
}
member ProtectionConnectionDetails : CoreConnectionDetailsModel with get, set

Property Value

Type: CoreConnectionDetailsModel
See Also

Reference

FullServerJobDetailsModel Class


FullServerJobDetailsModel.RecoveryConnectionDetails Property

FullServerJobDetailsModelRecoveryConnectionDetails Property
Gets or sets the details of the recovery connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionDetailsModel RecoveryConnectionDetails { get; set; }
Public Property RecoveryConnectionDetails As CoreConnectionDetailsModel
    Get
    Set
public:
property CoreConnectionDetailsModel^ RecoveryConnectionDetails {
    CoreConnectionDetailsModel^ get ();
    void set (CoreConnectionDetailsModel^ value);
}
member RecoveryConnectionDetails : CoreConnectionDetailsModel with get, set

Property Value

Type: CoreConnectionDetailsModel
See Also

Reference

FullServerJobDetailsModel Class


FullServerJobDetailsModel.SystemVolumeRevertConnectionDetails Property

FullServerJobDetailsModelSystemVolumeRevertConnectionDetails Property
Gets or sets the details of the system volume revert connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionDetailsModel SystemVolumeRevertConnectionDetails { get; set; }
Public Property SystemVolumeRevertConnectionDetails As CoreConnectionDetailsModel
    Get
    Set
public:
property CoreConnectionDetailsModel^ SystemVolumeRevertConnectionDetails {
    CoreConnectionDetailsModel^ get ();
    void set (CoreConnectionDetailsModel^ value);
}
member SystemVolumeRevertConnectionDetails : CoreConnectionDetailsModel with get, set

Property Value

Type: CoreConnectionDetailsModel
See Also

Reference

FullServerJobDetailsModel Class


FullServerJobDetailsModel Methods

FullServerJobDetailsModel Methods

The FullServerJobDetailsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FullServerJobDetailsModel Class


FullServerJobTypeEnum Enumeration

FullServerJobTypeEnum Enumeration
This enum is used during System State verification as well as rule generation of all full server job types. It is basically a wrapper for the SSMCLI::JobType enum class. It tells system state which rules and transform paths to generate, and/or validators to run. This has been around forever so the names are a little funky and don't really equate to the current job names. I have included what the current jobs should be using. For additional information, see Ed or Louie. Validation: -Move Server Migration job should use MoveServerMigration -All others should use FullServerProtection Rules and transforms: -Any job that is using a snapshot for recovery/failover/failback should use SnapshotMirror -A Full Server Failover job that has a DR image repository server as it's source should use ImageRepositoryFailover -All others should use FullServerProtection

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public enum FullServerJobTypeEnum
Public Enumeration FullServerJobTypeEnum
public enum class FullServerJobTypeEnum
type FullServerJobTypeEnum
Members
Member name | Value | Description
FullServerProtection | 0 | The full server protection
ImageRepositoryFailover | 1 | The image repository failover
BackupRecovery | 2 | The backup recovery
MoveServerMigration | 3 | The move server migration
PreFailoverTest | 4 | The pre failover test
PreFailoverTestWithReservedIPs | 5 | The pre failover test with reserved i ps
SnapshotMirror | 6 | The snapshot mirror
See Also

Reference

DoubleTake.Web.Models Namespace


FullServerNicMappingsModel Class

FullServerNicMappingsModel Class
Full server NIC mappings model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFullServerNicMappingsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class FullServerNicMappingsModel
Public NotInheritable Class FullServerNicMappingsModel
public ref class FullServerNicMappingsModel sealed
[<SealedAttribute>]
type FullServerNicMappingsModel =  class end

The FullServerNicMappingsModel type exposes the following members.

Constructors
 | Name | Description
Public method | FullServerNicMappingsModel | Initializes a new instance of the FullServerNicMappingsModel class
Top
Properties
 | Name | Description
Public property | SourceNic | Gets or sets the network interface on the source server.
Public property | TargetNic | Gets or sets the network interface on the target server.
Public property | TargetNicList | Gets or sets the list of network interfaces on the target server.
Public property | TestFailoverTargetNic | Gets or sets the NIC on the test failover target server.
Public property | TestFailoverTargetNicList | Gets or sets the list of NICs on the test failover target server.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FullServerNicMappingsModel Constructor

FullServerNicMappingsModel Constructor
Initializes a new instance of the FullServerNicMappingsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FullServerNicMappingsModel()
Public Sub New
public:
FullServerNicMappingsModel()
new : unit -> FullServerNicMappingsModel
See Also

Reference

FullServerNicMappingsModel Class


FullServerNicMappingsModel Properties

FullServerNicMappingsModel Properties

The FullServerNicMappingsModel type exposes the following members.

Properties
 | Name | Description
Public property | SourceNic | Gets or sets the network interface on the source server.
Public property | TargetNic | Gets or sets the network interface on the target server.
Public property | TargetNicList | Gets or sets the list of network interfaces on the target server.
Public property | TestFailoverTargetNic | Gets or sets the NIC on the test failover target server.
Public property | TestFailoverTargetNicList | Gets or sets the list of NICs on the test failover target server.
Top
See Also

Reference

FullServerNicMappingsModel Class


FullServerNicMappingsModel.SourceNic Property

FullServerNicMappingsModelSourceNic Property
Gets or sets the network interface on the source server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceNic { get; set; }
Public Property SourceNic As String
    Get
    Set
public:
property String^ SourceNic {
    String^ get ();
    void set (String^ value);
}
member SourceNic : string with get, set

Property Value

Type: String
See Also

Reference

FullServerNicMappingsModel Class


FullServerNicMappingsModel.TargetNic Property

FullServerNicMappingsModelTargetNic Property
Gets or sets the network interface on the target server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetNic { get; set; }
Public Property TargetNic As String
    Get
    Set
public:
property String^ TargetNic {
    String^ get ();
    void set (String^ value);
}
member TargetNic : string with get, set

Property Value

Type: String
See Also

Reference

FullServerNicMappingsModel Class


FullServerNicMappingsModel.TargetNicList Property

FullServerNicMappingsModelTargetNicList Property
Gets or sets the list of network interfaces on the target server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] TargetNicList { get; set; }
Public Property TargetNicList As String()
    Get
    Set
public:
property array<String^>^ TargetNicList {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member TargetNicList : string[] with get, set

Property Value

Type: String
See Also

Reference

FullServerNicMappingsModel Class


FullServerNicMappingsModel.TestFailoverTargetNic Property

FullServerNicMappingsModelTestFailoverTargetNic Property
Gets or sets the NIC on the test failover target server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TestFailoverTargetNic { get; set; }
Public Property TestFailoverTargetNic As String
    Get
    Set
public:
property String^ TestFailoverTargetNic {
    String^ get ();
    void set (String^ value);
}
member TestFailoverTargetNic : string with get, set

Property Value

Type: String
The network interface on the test failover target server.
See Also

Reference

FullServerNicMappingsModel Class


FullServerNicMappingsModel.TestFailoverTargetNicList Property

FullServerNicMappingsModelTestFailoverTargetNicList Property
Gets or sets the list of NICs on the test failover target server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] TestFailoverTargetNicList { get; set; }
Public Property TestFailoverTargetNicList As String()
    Get
    Set
public:
property array<String^>^ TestFailoverTargetNicList {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member TestFailoverTargetNicList : string[] with get, set

Property Value

Type: String
The test failover target list of network interfaces on the test failover target server.
See Also

Reference

FullServerNicMappingsModel Class


FullServerNicMappingsModel Methods

FullServerNicMappingsModel Methods

The FullServerNicMappingsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FullServerNicMappingsModel Class


FullServerPersistedStateModel Class

FullServerPersistedStateModel Class
Full server persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFullServerPersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class FullServerPersistedStateModel
Public NotInheritable Class FullServerPersistedStateModel
public ref class FullServerPersistedStateModel sealed
[<SealedAttribute>]
type FullServerPersistedStateModel =  class end

The FullServerPersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | FullServerPersistedStateModel | Initializes a new instance of the FullServerPersistedStateModel class
Top
Properties
 | Name | Description
Public property | BackupConnectionPersistedState | Gets or sets the state of the backup connection persisted.
Public property | BackupTargetState | Gets or sets the state of the backup target.
Public property | FailoverOptions | Gets or sets the failover options.
Public property | ProtectionConnectionPersistedState | Gets or sets the state of the protection connection persisted.
Public property | ProtectionTargetState | Gets or sets the state of the protection target.
Public property | RecoveryConnectionPersistedState | Gets or sets the state of the recovery connection persisted.
Public property | RecoveryTargetState | Gets or sets the state of the recovery target.
Public property | State | Gets or sets the state.
Public property | SystemVolumeRevertPersistedState | Gets or sets the state of the system volume revert persisted.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FullServerPersistedStateModel Constructor

FullServerPersistedStateModel Constructor
Initializes a new instance of the FullServerPersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public FullServerPersistedStateModel()
Public Sub New
public:
FullServerPersistedStateModel()
new : unit -> FullServerPersistedStateModel
See Also

Reference

FullServerPersistedStateModel Class


FullServerPersistedStateModel Properties

FullServerPersistedStateModel Properties

The FullServerPersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | BackupConnectionPersistedState | Gets or sets the state of the backup connection persisted.
Public property | BackupTargetState | Gets or sets the state of the backup target.
Public property | FailoverOptions | Gets or sets the failover options.
Public property | ProtectionConnectionPersistedState | Gets or sets the state of the protection connection persisted.
Public property | ProtectionTargetState | Gets or sets the state of the protection target.
Public property | RecoveryConnectionPersistedState | Gets or sets the state of the recovery connection persisted.
Public property | RecoveryTargetState | Gets or sets the state of the recovery target.
Public property | State | Gets or sets the state.
Public property | SystemVolumeRevertPersistedState | Gets or sets the state of the system volume revert persisted.
Top
See Also

Reference

FullServerPersistedStateModel Class


FullServerPersistedStateModel.BackupConnectionPersistedState Property

FullServerPersistedStateModelBackupConnectionPersistedState Property
Gets or sets the state of the backup connection persisted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionPersistedStateModel BackupConnectionPersistedState { get; set; }
Public Property BackupConnectionPersistedState As CoreConnectionPersistedStateModel
    Get
    Set
public:
property CoreConnectionPersistedStateModel^ BackupConnectionPersistedState {
    CoreConnectionPersistedStateModel^ get ();
    void set (CoreConnectionPersistedStateModel^ value);
}
member BackupConnectionPersistedState : CoreConnectionPersistedStateModel with get, set

Property Value

Type: CoreConnectionPersistedStateModel
The state of the backup connection persisted.
See Also

Reference

FullServerPersistedStateModel Class


FullServerPersistedStateModel.BackupTargetState Property

FullServerPersistedStateModelBackupTargetState Property
Gets or sets the state of the backup target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TargetStates> BackupTargetState { get; set; }
Public Property BackupTargetState As Nullable(Of TargetStates)
    Get
    Set
public:
property Nullable<TargetStates> BackupTargetState {
    Nullable<TargetStates> get ();
    void set (Nullable<TargetStates> value);
}
member BackupTargetState : Nullable<TargetStates> with get, set

Property Value

Type: Nullable TargetStates
The state of the backup target.
See Also

Reference

FullServerPersistedStateModel Class


FullServerPersistedStateModel.FailoverOptions Property

FullServerPersistedStateModelFailoverOptions Property
Gets or sets the failover options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public FailoverOptionsModel FailoverOptions { get; set; }
Public Property FailoverOptions As FailoverOptionsModel
    Get
    Set
public:
property FailoverOptionsModel^ FailoverOptions {
    FailoverOptionsModel^ get ();
    void set (FailoverOptionsModel^ value);
}
member FailoverOptions : FailoverOptionsModel with get, set

Property Value

Type: FailoverOptionsModel
The failover options.
See Also

Reference

FullServerPersistedStateModel Class


FullServerPersistedStateModel.ProtectionConnectionPersistedState Property

FullServerPersistedStateModelProtectionConnectionPersistedState Property
Gets or sets the state of the protection connection persisted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionPersistedStateModel ProtectionConnectionPersistedState { get; set; }
Public Property ProtectionConnectionPersistedState As CoreConnectionPersistedStateModel
    Get
    Set
public:
property CoreConnectionPersistedStateModel^ ProtectionConnectionPersistedState {
    CoreConnectionPersistedStateModel^ get ();
    void set (CoreConnectionPersistedStateModel^ value);
}
member ProtectionConnectionPersistedState : CoreConnectionPersistedStateModel with get, set

Property Value

Type: CoreConnectionPersistedStateModel
The state of the protection connection persisted.
See Also

Reference

FullServerPersistedStateModel Class


FullServerPersistedStateModel.ProtectionTargetState Property

FullServerPersistedStateModelProtectionTargetState Property
Gets or sets the state of the protection target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TargetStates> ProtectionTargetState { get; set; }
Public Property ProtectionTargetState As Nullable(Of TargetStates)
    Get
    Set
public:
property Nullable<TargetStates> ProtectionTargetState {
    Nullable<TargetStates> get ();
    void set (Nullable<TargetStates> value);
}
member ProtectionTargetState : Nullable<TargetStates> with get, set

Property Value

Type: Nullable TargetStates
The state of the protection target.
See Also

Reference

FullServerPersistedStateModel Class


FullServerPersistedStateModel.RecoveryConnectionPersistedState Property

FullServerPersistedStateModelRecoveryConnectionPersistedState Property
Gets or sets the state of the recovery connection persisted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionPersistedStateModel RecoveryConnectionPersistedState { get; set; }
Public Property RecoveryConnectionPersistedState As CoreConnectionPersistedStateModel
    Get
    Set
public:
property CoreConnectionPersistedStateModel^ RecoveryConnectionPersistedState {
    CoreConnectionPersistedStateModel^ get ();
    void set (CoreConnectionPersistedStateModel^ value);
}
member RecoveryConnectionPersistedState : CoreConnectionPersistedStateModel with get, set

Property Value

Type: CoreConnectionPersistedStateModel
The state of the protection connection persisted.
See Also

Reference

FullServerPersistedStateModel Class


FullServerPersistedStateModel.RecoveryTargetState Property

FullServerPersistedStateModelRecoveryTargetState Property
Gets or sets the state of the recovery target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TargetStates> RecoveryTargetState { get; set; }
Public Property RecoveryTargetState As Nullable(Of TargetStates)
    Get
    Set
public:
property Nullable<TargetStates> RecoveryTargetState {
    Nullable<TargetStates> get ();
    void set (Nullable<TargetStates> value);
}
member RecoveryTargetState : Nullable<TargetStates> with get, set

Property Value

Type: Nullable TargetStates
The state of the recovery target.
See Also

Reference

FullServerPersistedStateModel Class


FullServerPersistedStateModel.State Property

FullServerPersistedStateModelState Property
Gets or sets the state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string State { get; set; }
Public Property State As String
    Get
    Set
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}
member State : string with get, set

Property Value

Type: String
The state.
See Also

Reference

FullServerPersistedStateModel Class


FullServerPersistedStateModel.SystemVolumeRevertPersistedState Property

FullServerPersistedStateModelSystemVolumeRevertPersistedState Property
Gets or sets the state of the system volume revert persisted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionPersistedStateModel SystemVolumeRevertPersistedState { get; set; }
Public Property SystemVolumeRevertPersistedState As CoreConnectionPersistedStateModel
    Get
    Set
public:
property CoreConnectionPersistedStateModel^ SystemVolumeRevertPersistedState {
    CoreConnectionPersistedStateModel^ get ();
    void set (CoreConnectionPersistedStateModel^ value);
}
member SystemVolumeRevertPersistedState : CoreConnectionPersistedStateModel with get, set

Property Value

Type: CoreConnectionPersistedStateModel
The state of the system volume revert persisted.
See Also

Reference

FullServerPersistedStateModel Class


FullServerPersistedStateModel Methods

FullServerPersistedStateModel Methods

The FullServerPersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FullServerPersistedStateModel Class


FullServerTestFailoverOptionsModel Class

FullServerTestFailoverOptionsModel Class
Full server test failover options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsFullServerTestFailoverOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class FullServerTestFailoverOptionsModel
Public NotInheritable Class FullServerTestFailoverOptionsModel
public ref class FullServerTestFailoverOptionsModel sealed
[<SealedAttribute>]
type FullServerTestFailoverOptionsModel =  class end

The FullServerTestFailoverOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | FullServerTestFailoverOptionsModel | Initializes a new instance of the FullServerTestFailoverOptionsModel class
Top
Properties
 | Name | Description
Public property | DeleteSnapshots | Gets or sets the value indicating whether or not to delete snapshots.
Public property | FailoverName | Gets or sets the server name to apply to the test failover server.
Public property | NicMappings | Gets or sets the NIC mappings for full server testfailover.
Public property | TestFailoverServerAddress | Gets or sets the test failover server address to use for the replication service connection.
Public property | TestFailoverServerCredential | Gets or sets the test failover server credentials.
Public property | TestFailoverServerEnginePort | Gets or sets the test failover server engine port to use for the replication service connection.
Public property | TestFailoverServerReservedAddress | Gets or sets the IP address that will remain on the test failover server after a test failover.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


FullServerTestFailoverOptionsModel Constructor

FullServerTestFailoverOptionsModel Constructor
Initializes a new instance of the FullServerTestFailoverOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FullServerTestFailoverOptionsModel()
Public Sub New
public:
FullServerTestFailoverOptionsModel()
new : unit -> FullServerTestFailoverOptionsModel
See Also

Reference

FullServerTestFailoverOptionsModel Class


FullServerTestFailoverOptionsModel Properties

FullServerTestFailoverOptionsModel Properties

The FullServerTestFailoverOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | DeleteSnapshots | Gets or sets the value indicating whether or not to delete snapshots.
Public property | FailoverName | Gets or sets the server name to apply to the test failover server.
Public property | NicMappings | Gets or sets the NIC mappings for full server testfailover.
Public property | TestFailoverServerAddress | Gets or sets the test failover server address to use for the replication service connection.
Public property | TestFailoverServerCredential | Gets or sets the test failover server credentials.
Public property | TestFailoverServerEnginePort | Gets or sets the test failover server engine port to use for the replication service connection.
Public property | TestFailoverServerReservedAddress | Gets or sets the IP address that will remain on the test failover server after a test failover.
Top
See Also

Reference

FullServerTestFailoverOptionsModel Class


FullServerTestFailoverOptionsModel.DeleteSnapshots Property

FullServerTestFailoverOptionsModelDeleteSnapshots Property
Gets or sets the value indicating whether or not to delete snapshots.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool DeleteSnapshots { get; set; }
Public Property DeleteSnapshots As Boolean
    Get
    Set
public:
property bool DeleteSnapshots {
    bool get ();
    void set (bool value);
}
member DeleteSnapshots : bool with get, set

Property Value

Type: Boolean
See Also

Reference

FullServerTestFailoverOptionsModel Class


FullServerTestFailoverOptionsModel.FailoverName Property

FullServerTestFailoverOptionsModelFailoverName Property
Gets or sets the server name to apply to the test failover server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string FailoverName { get; set; }
Public Property FailoverName As String
    Get
    Set
public:
property String^ FailoverName {
    String^ get ();
    void set (String^ value);
}
member FailoverName : string with get, set

Property Value

Type: String
Remarks
Typically this would be set to the source server name if failing over the name. If not set, the test failover server name will not be changed.
See Also

Reference

FullServerTestFailoverOptionsModel Class


FullServerTestFailoverOptionsModel.NicMappings Property

FullServerTestFailoverOptionsModelNicMappings Property
Gets or sets the NIC mappings for full server testfailover.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FullServerNicMappingsModel[] NicMappings { get; set; }
Public Property NicMappings As FullServerNicMappingsModel()
    Get
    Set
public:
property array<FullServerNicMappingsModel^>^ NicMappings {
    array<FullServerNicMappingsModel^>^ get ();
    void set (array<FullServerNicMappingsModel^>^ value);
}
member NicMappings : FullServerNicMappingsModel[] with get, set

Property Value

Type: FullServerNicMappingsModel
The network interface mappings.
See Also

Reference

FullServerTestFailoverOptionsModel Class


FullServerTestFailoverOptionsModel.TestFailoverServerAddress Property

FullServerTestFailoverOptionsModelTestFailoverServerAddress Property
Gets or sets the test failover server address to use for the replication service connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TestFailoverServerAddress { get; set; }
Public Property TestFailoverServerAddress As String
    Get
    Set
public:
property String^ TestFailoverServerAddress {
    String^ get ();
    void set (String^ value);
}
member TestFailoverServerAddress : string with get, set

Property Value

Type: String
See Also

Reference

FullServerTestFailoverOptionsModel Class


FullServerTestFailoverOptionsModel.TestFailoverServerCredential Property

FullServerTestFailoverOptionsModelTestFailoverServerCredential Property
Gets or sets the test failover server credentials.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TestFailoverServerCredentialModel TestFailoverServerCredential { get; set; }
Public Property TestFailoverServerCredential As TestFailoverServerCredentialModel
    Get
    Set
public:
property TestFailoverServerCredentialModel^ TestFailoverServerCredential {
    TestFailoverServerCredentialModel^ get ();
    void set (TestFailoverServerCredentialModel^ value);
}
member TestFailoverServerCredential : TestFailoverServerCredentialModel with get, set

Property Value

Type: TestFailoverServerCredentialModel
See Also

Reference

FullServerTestFailoverOptionsModel Class


FullServerTestFailoverOptionsModel.TestFailoverServerEnginePort Property

FullServerTestFailoverOptionsModelTestFailoverServerEnginePort Property
Gets or sets the test failover server engine port to use for the replication service connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> TestFailoverServerEnginePort { get; set; }
Public Property TestFailoverServerEnginePort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> TestFailoverServerEnginePort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member TestFailoverServerEnginePort : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

FullServerTestFailoverOptionsModel Class


FullServerTestFailoverOptionsModel.TestFailoverServerReservedAddress Property

FullServerTestFailoverOptionsModelTestFailoverServerReservedAddress Property
Gets or sets the IP address that will remain on the test failover server after a test failover.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TestFailoverServerReservedAddress { get; set; }
Public Property TestFailoverServerReservedAddress As String
    Get
    Set
public:
property String^ TestFailoverServerReservedAddress {
    String^ get ();
    void set (String^ value);
}
member TestFailoverServerReservedAddress : string with get, set

Property Value

Type: String
See Also

Reference

FullServerTestFailoverOptionsModel Class


FullServerTestFailoverOptionsModel Methods

FullServerTestFailoverOptionsModel Methods

The FullServerTestFailoverOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FullServerTestFailoverOptionsModel Class


Health Enumeration

Health Enumeration
Health.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum Health
Public Enumeration Health
public enum class Health
type Health
Members
Member name | Value | Description
Unknown | 0 | The unknown
Ok | 1 | The ok
Warning | 2 | The warning
Error | 3 | The error
See Also

Reference

DoubleTake.Web.Models Namespace


HeartbeatPingQueryInputModel Class

HeartbeatPingQueryInputModel Class
Represents the input to a Double-Take heartbeat ping query agent.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsHeartbeatPingQueryInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class HeartbeatPingQueryInputModel : QueryInputModel
Public Class HeartbeatPingQueryInputModel
    Inherits QueryInputModel
public ref class HeartbeatPingQueryInputModel : public QueryInputModel
type HeartbeatPingQueryInputModel =
    class
        inherit QueryInputModel
    end

The HeartbeatPingQueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | HeartbeatPingQueryInputModel | Initializes a new instance of the HeartbeatPingQueryInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | EnginePort | Gets or sets the engine port.
Public property | IPAddress | Gets or sets the IP address to ping for a heartbeat.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


HeartbeatPingQueryInputModel Constructor

HeartbeatPingQueryInputModel Constructor
Initializes a new instance of the HeartbeatPingQueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public HeartbeatPingQueryInputModel()
Public Sub New
public:
HeartbeatPingQueryInputModel()
new : unit -> HeartbeatPingQueryInputModel
See Also

Reference

HeartbeatPingQueryInputModel Class


HeartbeatPingQueryInputModel Properties

HeartbeatPingQueryInputModel Properties

The HeartbeatPingQueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | EnginePort | Gets or sets the engine port.
Public property | IPAddress | Gets or sets the IP address to ping for a heartbeat.
Top
See Also

Reference

HeartbeatPingQueryInputModel Class


HeartbeatPingQueryInputModel.EnginePort Property

HeartbeatPingQueryInputModelEnginePort Property
Gets or sets the engine port.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> EnginePort { get; set; }
Public Property EnginePort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> EnginePort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member EnginePort : Nullable<int> with get, set

Property Value

Type: Nullable Int32
The engine port.
See Also

Reference

HeartbeatPingQueryInputModel Class


HeartbeatPingQueryInputModel.IPAddress Property

HeartbeatPingQueryInputModelIPAddress Property
Gets or sets the IP address to ping for a heartbeat.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string IPAddress { get; set; }
Public Property IPAddress As String
    Get
    Set
public:
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
member IPAddress : string with get, set

Property Value

Type: String
The IP address to ping for a heartbeat.
See Also

Reference

HeartbeatPingQueryInputModel Class


HeartbeatPingQueryInputModel Methods

HeartbeatPingQueryInputModel Methods

The HeartbeatPingQueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HeartbeatPingQueryInputModel Class


HeartbeatPingQueryResultModel Class

HeartbeatPingQueryResultModel Class
Represents the results of a heartbeat ping query.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultModel
DoubleTake.Web.ModelsHeartbeatPingQueryResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class HeartbeatPingQueryResultModel : QueryResultModel
Public Class HeartbeatPingQueryResultModel
    Inherits QueryResultModel
public ref class HeartbeatPingQueryResultModel : public QueryResultModel
type HeartbeatPingQueryResultModel =
    class
        inherit QueryResultModel
    end

The HeartbeatPingQueryResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | HeartbeatPingQueryResultModel | Initializes a new instance of the HeartbeatPingQueryResultModel class
Top
Properties
 | Name | Description
Public property | EnginePort | Gets or sets the engine port that was used to ping.
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | IPAddress | Gets or sets the IP address that was pinged during this query.
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


HeartbeatPingQueryResultModel Constructor

HeartbeatPingQueryResultModel Constructor
Initializes a new instance of the HeartbeatPingQueryResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public HeartbeatPingQueryResultModel()
Public Sub New
public:
HeartbeatPingQueryResultModel()
new : unit -> HeartbeatPingQueryResultModel
See Also

Reference

HeartbeatPingQueryResultModel Class


HeartbeatPingQueryResultModel Properties

HeartbeatPingQueryResultModel Properties

The HeartbeatPingQueryResultModel type exposes the following members.

Properties
 | Name | Description
Public property | EnginePort | Gets or sets the engine port that was used to ping.
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | IPAddress | Gets or sets the IP address that was pinged during this query.
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Top
See Also

Reference

HeartbeatPingQueryResultModel Class


HeartbeatPingQueryResultModel.EnginePort Property

HeartbeatPingQueryResultModelEnginePort Property
Gets or sets the engine port that was used to ping.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int EnginePort { get; set; }
Public Property EnginePort As Integer
    Get
    Set
public:
property int EnginePort {
    int get ();
    void set (int value);
}
member EnginePort : int with get, set

Property Value

Type: Int32
The engine port that was used to ping.
See Also

Reference

HeartbeatPingQueryResultModel Class


HeartbeatPingQueryResultModel.IPAddress Property

HeartbeatPingQueryResultModelIPAddress Property
Gets or sets the IP address that was pinged during this query.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string IPAddress { get; set; }
Public Property IPAddress As String
    Get
    Set
public:
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
member IPAddress : string with get, set

Property Value

Type: String
The IP address that was pinged during this query.
See Also

Reference

HeartbeatPingQueryResultModel Class


HeartbeatPingQueryResultModel Methods

HeartbeatPingQueryResultModel Methods

The HeartbeatPingQueryResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

HeartbeatPingQueryResultModel Class


HighAvailabilityState Enumeration

HighAvailabilityState Enumeration
High availability state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum HighAvailabilityState
Public Enumeration HighAvailabilityState
public enum class HighAvailabilityState
type HighAvailabilityState
Members
Member name | Value | Description
FailbackOccurring | 80 | The failback occurring
FailbackRemonitor | 96 | The failback remonitor
FailbackRequired | 64 | The failback required
FailoverMonitoring | 16 | The failover monitoring
FailoverOccurring | 48 | The failover occurring
FailoverRequired | 32 | The failover required
Illegal | -1 | The illegal
None | 0 | The none
See Also

Reference

DoubleTake.Web.Models Namespace


HighLevelState Enumeration

HighLevelState Enumeration
High level state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum HighLevelState
Public Enumeration HighLevelState
public enum class HighLevelState
type HighLevelState
Members
Member name | Value | Description
Unknown | 0 | The unknown
Created | 1 | The created
Deleting | 2 | The deleting
FailedBack | 3 | The failed back
FailedOver | 4 | The failed over
FailingBack | 5 | The failing back
FailingOver | 6 | The failing over
FailoverFailed | 7 | The failover failed
FailoverPending | 8 | The failover pending
Mirroring | 9 | The mirroring
MirrorRequired | 10 | The mirror required
Paused | 11 | The paused
Pausing | 12 | The pausing
Protecting | 13 | The protecting
Provisioning | 14 | The provisioning
Restored | 15 | The restored
RestoreFailed | 16 | The restore failed
RestorePaused | 17 | The restore paused
RestoreRequired | 18 | The restore required
Restoring | 19 | The restoring
Resuming | 20 | The resuming
Reversing | 21 | The reversing
Reverting | 22 | The reverting
Starting | 23 | The starting
Stopped | 24 | The stopped
Stopping | 25 | The stopping
Undoing | 26 | The undoing
RevertingSnapshot | 27 | The reverting snapshot
UpdatingTargetImage | 28 | The updating target image
CredentialsRequired | 29 | The credentials required
ActivationCodeWarning | 30 | The activation code warning
ActivationCodeError | 31 | The activation code error
EngineConnectionWarning | 32 | The engine connection warning
EngineConnectionError | 33 | The engine connection error
EngineServiceWarning | 34 | The engine service warning
EngineServiceError | 35 | The engine service error
ServerCommunicationWarning | 36 | The server communication warning
ServerCommunicationError | 37 | The server communication error
TargetInfoNotAvailable | 38 | The target information not available
Editing | 39 | Job edit in progress
See Also

Reference

DoubleTake.Web.Models Namespace


IcmpPingQueryInputModel Class

IcmpPingQueryInputModel Class
Represents the input to an ICMP ping query agent.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsIcmpPingQueryInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class IcmpPingQueryInputModel : QueryInputModel
Public Class IcmpPingQueryInputModel
    Inherits QueryInputModel
public ref class IcmpPingQueryInputModel : public QueryInputModel
type IcmpPingQueryInputModel =
    class
        inherit QueryInputModel
    end

The IcmpPingQueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | IcmpPingQueryInputModel | Initializes a new instance of the IcmpPingQueryInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | NetworkId | Gets or sets the server name or IP address to ping.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


IcmpPingQueryInputModel Constructor

IcmpPingQueryInputModel Constructor
Initializes a new instance of the IcmpPingQueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public IcmpPingQueryInputModel()
Public Sub New
public:
IcmpPingQueryInputModel()
new : unit -> IcmpPingQueryInputModel
See Also

Reference

IcmpPingQueryInputModel Class


IcmpPingQueryInputModel Properties

IcmpPingQueryInputModel Properties

The IcmpPingQueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | NetworkId | Gets or sets the server name or IP address to ping.
Top
See Also

Reference

IcmpPingQueryInputModel Class


IcmpPingQueryInputModel.NetworkId Property

IcmpPingQueryInputModelNetworkId Property
Gets or sets the server name or IP address to ping.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string NetworkId { get; set; }
Public Property NetworkId As String
    Get
    Set
public:
property String^ NetworkId {
    String^ get ();
    void set (String^ value);
}
member NetworkId : string with get, set

Property Value

Type: String
The server name or IP address to ping.
See Also

Reference

IcmpPingQueryInputModel Class


IcmpPingQueryInputModel Methods

IcmpPingQueryInputModel Methods

The IcmpPingQueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IcmpPingQueryInputModel Class


IcmpPingQueryResultModel Class

IcmpPingQueryResultModel Class
Represents the results of an ICMP ping query.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultModel
DoubleTake.Web.ModelsIcmpPingQueryResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class IcmpPingQueryResultModel : QueryResultModel
Public Class IcmpPingQueryResultModel
    Inherits QueryResultModel
public ref class IcmpPingQueryResultModel : public QueryResultModel
type IcmpPingQueryResultModel =
    class
        inherit QueryResultModel
    end

The IcmpPingQueryResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | IcmpPingQueryResultModel | Initializes a new instance of the IcmpPingQueryResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | ExceptionDetail | Gets or sets the exception detail.
Public property | NetworkId | Gets or sets the network id that was pinged.
Public property | ReplyAddress | Gets or sets the IP address from which the reply was sent.
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Public property | Roundtrip | Gets or sets the duration of the ICMP ping round-trip.
Public property | Status | Gets or sets the IPStatus from the ping reply as a string.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


IcmpPingQueryResultModel Constructor

IcmpPingQueryResultModel Constructor
Initializes a new instance of the IcmpPingQueryResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public IcmpPingQueryResultModel()
Public Sub New
public:
IcmpPingQueryResultModel()
new : unit -> IcmpPingQueryResultModel
See Also

Reference

IcmpPingQueryResultModel Class


IcmpPingQueryResultModel Properties

IcmpPingQueryResultModel Properties

The IcmpPingQueryResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | ExceptionDetail | Gets or sets the exception detail.
Public property | NetworkId | Gets or sets the network id that was pinged.
Public property | ReplyAddress | Gets or sets the IP address from which the reply was sent.
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Public property | Roundtrip | Gets or sets the duration of the ICMP ping round-trip.
Public property | Status | Gets or sets the IPStatus from the ping reply as a string.
Top
See Also

Reference

IcmpPingQueryResultModel Class


IcmpPingQueryResultModel.ExceptionDetail Property

IcmpPingQueryResultModelExceptionDetail Property
Gets or sets the exception detail.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ExceptionDetailModel ExceptionDetail { get; set; }
Public Property ExceptionDetail As ExceptionDetailModel
    Get
    Set
public:
property ExceptionDetailModel^ ExceptionDetail {
    ExceptionDetailModel^ get ();
    void set (ExceptionDetailModel^ value);
}
member ExceptionDetail : ExceptionDetailModel with get, set

Property Value

Type: ExceptionDetailModel
The exception detail.
Remarks
This property will only be non- if an exception was thrown by the ICMP ping operation.
See Also

Reference

IcmpPingQueryResultModel Class


IcmpPingQueryResultModel.NetworkId Property

IcmpPingQueryResultModelNetworkId Property
Gets or sets the network id that was pinged.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string NetworkId { get; set; }
Public Property NetworkId As String
    Get
    Set
public:
property String^ NetworkId {
    String^ get ();
    void set (String^ value);
}
member NetworkId : string with get, set

Property Value

Type: String
The network id that was pinged.
See Also

Reference

IcmpPingQueryResultModel Class


IcmpPingQueryResultModel.ReplyAddress Property

IcmpPingQueryResultModelReplyAddress Property
Gets or sets the IP address from which the reply was sent.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ReplyAddress { get; set; }
Public Property ReplyAddress As String
    Get
    Set
public:
property String^ ReplyAddress {
    String^ get ();
    void set (String^ value);
}
member ReplyAddress : string with get, set

Property Value

Type: String
The IP address from which the reply was sent.
See Also

Reference

IcmpPingQueryResultModel Class


IcmpPingQueryResultModel.Roundtrip Property

IcmpPingQueryResultModelRoundtrip Property
Gets or sets the duration of the ICMP ping round-trip.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Roundtrip { get; set; }
Public Property Roundtrip As TimeSpan
    Get
    Set
public:
property TimeSpan Roundtrip {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Roundtrip : TimeSpan with get, set

Property Value

Type: TimeSpan
The duration of the ICMP ping round-trip.
See Also

Reference

IcmpPingQueryResultModel Class


IcmpPingQueryResultModel.Status Property

IcmpPingQueryResultModelStatus Property
Gets or sets the IPStatus from the ping reply as a string.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Status { get; set; }
Public Property Status As String
    Get
    Set
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}
member Status : string with get, set

Property Value

Type: String
The IPStatus from the ping reply as a string.
See Also

Reference

IcmpPingQueryResultModel Class


IcmpPingQueryResultModel Methods

IcmpPingQueryResultModel Methods

The IcmpPingQueryResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IcmpPingQueryResultModel Class


ImageDeleteInfoModel Class

ImageDeleteInfoModel Class
Image delete info model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsImageDeleteInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ImageDeleteInfoModel
Public NotInheritable Class ImageDeleteInfoModel
public ref class ImageDeleteInfoModel sealed
[<SealedAttribute>]
type ImageDeleteInfoModel =  class end

The ImageDeleteInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ImageDeleteInfoModel | Initializes a new instance of the ImageDeleteInfoModel class
Top
Properties
 | Name | Description
Public property | DeleteImage | Gets or sets a value indicating whether [delete image].
Public property | ImageId | Gets or sets the image identifier.
Public property | VhdDeleteAction | Gets or sets the VHD delete action.
Public property | VhdsToDelete | Gets or sets the VHDS to delete.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ImageDeleteInfoModel Constructor

ImageDeleteInfoModel Constructor
Initializes a new instance of the ImageDeleteInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ImageDeleteInfoModel()
Public Sub New
public:
ImageDeleteInfoModel()
new : unit -> ImageDeleteInfoModel
See Also

Reference

ImageDeleteInfoModel Class


ImageDeleteInfoModel Properties

ImageDeleteInfoModel Properties

The ImageDeleteInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | DeleteImage | Gets or sets a value indicating whether [delete image].
Public property | ImageId | Gets or sets the image identifier.
Public property | VhdDeleteAction | Gets or sets the VHD delete action.
Public property | VhdsToDelete | Gets or sets the VHDS to delete.
Top
See Also

Reference

ImageDeleteInfoModel Class


ImageDeleteInfoModel.DeleteImage Property

ImageDeleteInfoModelDeleteImage Property
Gets or sets a value indicating whether [delete image].

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool DeleteImage { get; set; }
Public Property DeleteImage As Boolean
    Get
    Set
public:
property bool DeleteImage {
    bool get ();
    void set (bool value);
}
member DeleteImage : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ImageDeleteInfoModel Class


ImageDeleteInfoModel.ImageId Property

ImageDeleteInfoModelImageId Property
Gets or sets the image identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Guid ImageId { get; set; }
Public Property ImageId As Guid
    Get
    Set
public:
property Guid ImageId {
    Guid get ();
    void set (Guid value);
}
member ImageId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

ImageDeleteInfoModel Class


ImageDeleteInfoModel.VhdDeleteAction Property

ImageDeleteInfoModelVhdDeleteAction Property
Gets or sets the VHD delete action.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VhdDeleteActionType VhdDeleteAction { get; set; }
Public Property VhdDeleteAction As VhdDeleteActionType
    Get
    Set
public:
property VhdDeleteActionType VhdDeleteAction {
    VhdDeleteActionType get ();
    void set (VhdDeleteActionType value);
}
member VhdDeleteAction : VhdDeleteActionType with get, set

Property Value

Type: VhdDeleteActionType
See Also

Reference

ImageDeleteInfoModel Class


ImageDeleteInfoModel.VhdsToDelete Property

ImageDeleteInfoModelVhdsToDelete Property
Gets or sets the VHDS to delete.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> VhdsToDelete { get; set; }
Public Property VhdsToDelete As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ VhdsToDelete {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member VhdsToDelete : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
See Also

Reference

ImageDeleteInfoModel Class


ImageDeleteInfoModel Methods

ImageDeleteInfoModel Methods

The ImageDeleteInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageDeleteInfoModel Class


ImageDeleteInfosModel Class

ImageDeleteInfosModel Class
Image delete infos model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsImageDeleteInfosModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public class ImageDeleteInfosModel
Public Class ImageDeleteInfosModel
public ref class ImageDeleteInfosModel
type ImageDeleteInfosModel =  class end

The ImageDeleteInfosModel type exposes the following members.

Constructors
 | Name | Description
Public method | ImageDeleteInfosModel | Initializes a new instance of the ImageDeleteInfosModel class
Top
Properties
 | Name | Description
Public property | DeleteInfos | Gets or sets the delete infos.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ImageDeleteInfosModel Constructor

ImageDeleteInfosModel Constructor
Initializes a new instance of the ImageDeleteInfosModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ImageDeleteInfosModel()
Public Sub New
public:
ImageDeleteInfosModel()
new : unit -> ImageDeleteInfosModel
See Also

Reference

ImageDeleteInfosModel Class


ImageDeleteInfosModel Properties

ImageDeleteInfosModel Properties

The ImageDeleteInfosModel type exposes the following members.

Properties
 | Name | Description
Public property | DeleteInfos | Gets or sets the delete infos.
Top
See Also

Reference

ImageDeleteInfosModel Class


ImageDeleteInfosModel.DeleteInfos Property

ImageDeleteInfosModelDeleteInfos Property
Gets or sets the delete infos.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ImageDeleteInfoModel[] DeleteInfos { get; set; }
Public Property DeleteInfos As ImageDeleteInfoModel()
    Get
    Set
public:
property array<ImageDeleteInfoModel^>^ DeleteInfos {
    array<ImageDeleteInfoModel^>^ get ();
    void set (array<ImageDeleteInfoModel^>^ value);
}
member DeleteInfos : ImageDeleteInfoModel[] with get, set

Property Value

Type: ImageDeleteInfoModel
See Also

Reference

ImageDeleteInfosModel Class


ImageDeleteInfosModel Methods

ImageDeleteInfosModel Methods

The ImageDeleteInfosModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageDeleteInfosModel Class


ImageInfoModel Class

ImageInfoModel Class
Image info model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsImageInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ImageInfoModel
Public NotInheritable Class ImageInfoModel
public ref class ImageInfoModel sealed
[<SealedAttribute>]
type ImageInfoModel =  class end

The ImageInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ImageInfoModel | Initializes a new instance of the ImageInfoModel class
Top
Properties
 | Name | Description
Public property | CreationTimestamp | Gets or sets the date and time when the image was created.
Public property | Description | Gets or sets the description of the image.
Public property | Id | Gets or sets the image unique ID.
Public property | ImageName | Gets or sets the name of the image.
Public property | ImageType | Gets or sets the type of image.
Public property | ProtectionConnectionId | Gets or sets the connection ID, if there is a protection job using the image.
Public property | ProtectionJobName | Gets or sets the job name, if there is a protection job using the image.
Public property | Snapshots | Gets or sets the current list of snapshots for the connection.
Public property | SourceImageMountLocation | Gets or sets the full path to the root of image data where each of the .vhd files are mounted in a subdirectory by volume letter.
Public property | SourceName | Gets or sets the name of the source that contained the original the image data.
Public property | State | Gets or sets the state of the target.
Public property | VhdFiles | Gets or sets information about a virtual hard disk used to store an image.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ImageInfoModel Constructor

ImageInfoModel Constructor
Initializes a new instance of the ImageInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ImageInfoModel()
Public Sub New
public:
ImageInfoModel()
new : unit -> ImageInfoModel
See Also

Reference

ImageInfoModel Class


ImageInfoModel Properties

ImageInfoModel Properties

The ImageInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | CreationTimestamp | Gets or sets the date and time when the image was created.
Public property | Description | Gets or sets the description of the image.
Public property | Id | Gets or sets the image unique ID.
Public property | ImageName | Gets or sets the name of the image.
Public property | ImageType | Gets or sets the type of image.
Public property | ProtectionConnectionId | Gets or sets the connection ID, if there is a protection job using the image.
Public property | ProtectionJobName | Gets or sets the job name, if there is a protection job using the image.
Public property | Snapshots | Gets or sets the current list of snapshots for the connection.
Public property | SourceImageMountLocation | Gets or sets the full path to the root of image data where each of the .vhd files are mounted in a subdirectory by volume letter.
Public property | SourceName | Gets or sets the name of the source that contained the original the image data.
Public property | State | Gets or sets the state of the target.
Public property | VhdFiles | Gets or sets information about a virtual hard disk used to store an image.
Top
See Also

Reference

ImageInfoModel Class


ImageInfoModel.CreationTimestamp Property

ImageInfoModelCreationTimestamp Property
Gets or sets the date and time when the image was created.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime CreationTimestamp { get; set; }
Public Property CreationTimestamp As DateTime
    Get
    Set
public:
property DateTime CreationTimestamp {
    DateTime get ();
    void set (DateTime value);
}
member CreationTimestamp : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

ImageInfoModel Class


ImageInfoModel.Description Property

ImageInfoModelDescription Property
Gets or sets the description of the image.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

ImageInfoModel Class


ImageInfoModel.Id Property

ImageInfoModelId Property
Gets or sets the image unique ID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
member Id : Guid with get, set

Property Value

Type: Guid
See Also

Reference

ImageInfoModel Class


ImageInfoModel.ImageName Property

ImageInfoModelImageName Property
Gets or sets the name of the image.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ImageName { get; set; }
Public Property ImageName As String
    Get
    Set
public:
property String^ ImageName {
    String^ get ();
    void set (String^ value);
}
member ImageName : string with get, set

Property Value

Type: String
See Also

Reference

ImageInfoModel Class


ImageInfoModel.ImageType Property

ImageInfoModelImageType Property
Gets or sets the type of image.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ImageType ImageType { get; set; }
Public Property ImageType As ImageType
    Get
    Set
public:
property ImageType ImageType {
    ImageType get ();
    void set (ImageType value);
}
member ImageType : ImageType with get, set

Property Value

Type: ImageType
See Also

Reference

ImageInfoModel Class


ImageInfoModel.ProtectionConnectionId Property

ImageInfoModelProtectionConnectionId Property
Gets or sets the connection ID, if there is a protection job using the image.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ProtectionConnectionId { get; set; }
Public Property ProtectionConnectionId As String
    Get
    Set
public:
property String^ ProtectionConnectionId {
    String^ get ();
    void set (String^ value);
}
member ProtectionConnectionId : string with get, set

Property Value

Type: String
See Also

Reference

ImageInfoModel Class


ImageInfoModel.ProtectionJobName Property

ImageInfoModelProtectionJobName Property
Gets or sets the job name, if there is a protection job using the image.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ProtectionJobName { get; set; }
Public Property ProtectionJobName As String
    Get
    Set
public:
property String^ ProtectionJobName {
    String^ get ();
    void set (String^ value);
}
member ProtectionJobName : string with get, set

Property Value

Type: String
See Also

Reference

ImageInfoModel Class


ImageInfoModel.Snapshots Property

ImageInfoModelSnapshots Property
Gets or sets the current list of snapshots for the connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public SnapshotEntryModel[] Snapshots { get; set; }
Public Property Snapshots As SnapshotEntryModel()
    Get
    Set
public:
property array<SnapshotEntryModel^>^ Snapshots {
    array<SnapshotEntryModel^>^ get ();
    void set (array<SnapshotEntryModel^>^ value);
}
member Snapshots : SnapshotEntryModel[] with get, set

Property Value

Type: SnapshotEntryModel
See Also

Reference

ImageInfoModel Class


ImageInfoModel.SourceImageMountLocation Property

ImageInfoModelSourceImageMountLocation Property
Gets or sets the full path to the root of image data where each of the .vhd files are mounted in a subdirectory by volume letter.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceImageMountLocation { get; set; }
Public Property SourceImageMountLocation As String
    Get
    Set
public:
property String^ SourceImageMountLocation {
    String^ get ();
    void set (String^ value);
}
member SourceImageMountLocation : string with get, set

Property Value

Type: String
See Also

Reference

ImageInfoModel Class


ImageInfoModel.SourceName Property

ImageInfoModelSourceName Property
Gets or sets the name of the source that contained the original the image data.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceName { get; set; }
Public Property SourceName As String
    Get
    Set
public:
property String^ SourceName {
    String^ get ();
    void set (String^ value);
}
member SourceName : string with get, set

Property Value

Type: String
See Also

Reference

ImageInfoModel Class


ImageInfoModel.State Property

ImageInfoModelState Property
Gets or sets the state of the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TargetStates State { get; set; }
Public Property State As TargetStates
    Get
    Set
public:
property TargetStates State {
    TargetStates get ();
    void set (TargetStates value);
}
member State : TargetStates with get, set

Property Value

Type: TargetStates
See Also

Reference

ImageInfoModel Class


ImageInfoModel.VhdFiles Property

ImageInfoModelVhdFiles Property
Gets or sets information about a virtual hard disk used to store an image.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ImageVhdInfoModel[] VhdFiles { get; set; }
Public Property VhdFiles As ImageVhdInfoModel()
    Get
    Set
public:
property array<ImageVhdInfoModel^>^ VhdFiles {
    array<ImageVhdInfoModel^>^ get ();
    void set (array<ImageVhdInfoModel^>^ value);
}
member VhdFiles : ImageVhdInfoModel[] with get, set

Property Value

Type: ImageVhdInfoModel
See Also

Reference

ImageInfoModel Class


ImageInfoModel Methods

ImageInfoModel Methods

The ImageInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageInfoModel Class


ImageProtectionJobDetailsModel Class

ImageProtectionJobDetailsModel Class
Image protection job details model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsImageProtectionJobDetailsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ImageProtectionJobDetailsModel
Public NotInheritable Class ImageProtectionJobDetailsModel
public ref class ImageProtectionJobDetailsModel sealed
[<SealedAttribute>]
type ImageProtectionJobDetailsModel =  class end

The ImageProtectionJobDetailsModel type exposes the following members.

Constructors
 | Name | Description
Public method | ImageProtectionJobDetailsModel | Initializes a new instance of the ImageProtectionJobDetailsModel class
Top
Properties
 | Name | Description
Public property | ProtectionConnectionDetails | Gets or sets the details of the protection connection.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ImageProtectionJobDetailsModel Constructor

ImageProtectionJobDetailsModel Constructor
Initializes a new instance of the ImageProtectionJobDetailsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ImageProtectionJobDetailsModel()
Public Sub New
public:
ImageProtectionJobDetailsModel()
new : unit -> ImageProtectionJobDetailsModel
See Also

Reference

ImageProtectionJobDetailsModel Class


ImageProtectionJobDetailsModel Properties

ImageProtectionJobDetailsModel Properties

The ImageProtectionJobDetailsModel type exposes the following members.

Properties
 | Name | Description
Public property | ProtectionConnectionDetails | Gets or sets the details of the protection connection.
Top
See Also

Reference

ImageProtectionJobDetailsModel Class


ImageProtectionJobDetailsModel.ProtectionConnectionDetails Property

ImageProtectionJobDetailsModelProtectionConnectionDetails Property
Gets or sets the details of the protection connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionDetailsModel ProtectionConnectionDetails { get; set; }
Public Property ProtectionConnectionDetails As CoreConnectionDetailsModel
    Get
    Set
public:
property CoreConnectionDetailsModel^ ProtectionConnectionDetails {
    CoreConnectionDetailsModel^ get ();
    void set (CoreConnectionDetailsModel^ value);
}
member ProtectionConnectionDetails : CoreConnectionDetailsModel with get, set

Property Value

Type: CoreConnectionDetailsModel
See Also

Reference

ImageProtectionJobDetailsModel Class


ImageProtectionJobDetailsModel Methods

ImageProtectionJobDetailsModel Methods

The ImageProtectionJobDetailsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageProtectionJobDetailsModel Class


ImageProtectionOptionsModel Class

ImageProtectionOptionsModel Class
Image protection options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsImageProtectionOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ImageProtectionOptionsModel
Public NotInheritable Class ImageProtectionOptionsModel
public ref class ImageProtectionOptionsModel sealed
[<SealedAttribute>]
type ImageProtectionOptionsModel =  class end

The ImageProtectionOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | ImageProtectionOptionsModel | Initializes a new instance of the ImageProtectionOptionsModel class
Top
Properties
 | Name | Description
Public property | ImageId | Gets or sets the value used to uniquely identify the image in the image store.
Public property | ImageName | Gets or sets the name of the image.
Public property | VhdInfo | Gets or sets the information on the VHDs of the image.
Public property | VhdsToDeleteOnRemove | Gets or sets the list of VHD files to delete (specified by volume letter) from disk when the corresponding protected volume has been removed from the image.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ImageProtectionOptionsModel Constructor

ImageProtectionOptionsModel Constructor
Initializes a new instance of the ImageProtectionOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ImageProtectionOptionsModel()
Public Sub New
public:
ImageProtectionOptionsModel()
new : unit -> ImageProtectionOptionsModel
See Also

Reference

ImageProtectionOptionsModel Class


ImageProtectionOptionsModel Properties

ImageProtectionOptionsModel Properties

The ImageProtectionOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | ImageId | Gets or sets the value used to uniquely identify the image in the image store.
Public property | ImageName | Gets or sets the name of the image.
Public property | VhdInfo | Gets or sets the information on the VHDs of the image.
Public property | VhdsToDeleteOnRemove | Gets or sets the list of VHD files to delete (specified by volume letter) from disk when the corresponding protected volume has been removed from the image.
Top
See Also

Reference

ImageProtectionOptionsModel Class


ImageProtectionOptionsModel.ImageId Property

ImageProtectionOptionsModelImageId Property
Gets or sets the value used to uniquely identify the image in the image store.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Guid ImageId { get; set; }
Public Property ImageId As Guid
    Get
    Set
public:
property Guid ImageId {
    Guid get ();
    void set (Guid value);
}
member ImageId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

ImageProtectionOptionsModel Class


ImageProtectionOptionsModel.ImageName Property

ImageProtectionOptionsModelImageName Property
Gets or sets the name of the image.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ImageName { get; set; }
Public Property ImageName As String
    Get
    Set
public:
property String^ ImageName {
    String^ get ();
    void set (String^ value);
}
member ImageName : string with get, set

Property Value

Type: String
See Also

Reference

ImageProtectionOptionsModel Class


ImageProtectionOptionsModel.VhdInfo Property

ImageProtectionOptionsModelVhdInfo Property
Gets or sets the information on the VHDs of the image.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ImageVhdInfoModel[] VhdInfo { get; set; }
Public Property VhdInfo As ImageVhdInfoModel()
    Get
    Set
public:
property array<ImageVhdInfoModel^>^ VhdInfo {
    array<ImageVhdInfoModel^>^ get ();
    void set (array<ImageVhdInfoModel^>^ value);
}
member VhdInfo : ImageVhdInfoModel[] with get, set

Property Value

Type: ImageVhdInfoModel
See Also

Reference

ImageProtectionOptionsModel Class


ImageProtectionOptionsModel.VhdsToDeleteOnRemove Property

ImageProtectionOptionsModelVhdsToDeleteOnRemove Property
Gets or sets the list of VHD files to delete (specified by volume letter) from disk when the corresponding protected volume has been removed from the image.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> VhdsToDeleteOnRemove { get; set; }
Public Property VhdsToDeleteOnRemove As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ VhdsToDeleteOnRemove {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member VhdsToDeleteOnRemove : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
See Also

Reference

ImageProtectionOptionsModel Class


ImageProtectionOptionsModel Methods

ImageProtectionOptionsModel Methods

The ImageProtectionOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageProtectionOptionsModel Class


ImageProtectionPersistedStateModel Class

ImageProtectionPersistedStateModel Class
Image protection persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsImageProtectionPersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class ImageProtectionPersistedStateModel
Public NotInheritable Class ImageProtectionPersistedStateModel
public ref class ImageProtectionPersistedStateModel sealed
[<SealedAttribute>]
type ImageProtectionPersistedStateModel =  class end

The ImageProtectionPersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | ImageProtectionPersistedStateModel | Initializes a new instance of the ImageProtectionPersistedStateModel class
Top
Properties
 | Name | Description
Public property | ProtectionConnectionPersistedState | Gets or sets the state of the protection connection persisted.
Public property | ProtectionTargetState | Gets or sets the state of the protection target.
Public property | State | Gets or sets the state.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ImageProtectionPersistedStateModel Constructor

ImageProtectionPersistedStateModel Constructor
Initializes a new instance of the ImageProtectionPersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ImageProtectionPersistedStateModel()
Public Sub New
public:
ImageProtectionPersistedStateModel()
new : unit -> ImageProtectionPersistedStateModel
See Also

Reference

ImageProtectionPersistedStateModel Class


ImageProtectionPersistedStateModel Properties

ImageProtectionPersistedStateModel Properties

The ImageProtectionPersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | ProtectionConnectionPersistedState | Gets or sets the state of the protection connection persisted.
Public property | ProtectionTargetState | Gets or sets the state of the protection target.
Public property | State | Gets or sets the state.
Top
See Also

Reference

ImageProtectionPersistedStateModel Class


ImageProtectionPersistedStateModel.ProtectionConnectionPersistedState Property

ImageProtectionPersistedStateModelProtectionConnectionPersistedState Property
Gets or sets the state of the protection connection persisted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionPersistedStateModel ProtectionConnectionPersistedState { get; set; }
Public Property ProtectionConnectionPersistedState As CoreConnectionPersistedStateModel
    Get
    Set
public:
property CoreConnectionPersistedStateModel^ ProtectionConnectionPersistedState {
    CoreConnectionPersistedStateModel^ get ();
    void set (CoreConnectionPersistedStateModel^ value);
}
member ProtectionConnectionPersistedState : CoreConnectionPersistedStateModel with get, set

Property Value

Type: CoreConnectionPersistedStateModel
The state of the protection connection persisted.
See Also

Reference

ImageProtectionPersistedStateModel Class


ImageProtectionPersistedStateModel.ProtectionTargetState Property

ImageProtectionPersistedStateModelProtectionTargetState Property
Gets or sets the state of the protection target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TargetStates> ProtectionTargetState { get; set; }
Public Property ProtectionTargetState As Nullable(Of TargetStates)
    Get
    Set
public:
property Nullable<TargetStates> ProtectionTargetState {
    Nullable<TargetStates> get ();
    void set (Nullable<TargetStates> value);
}
member ProtectionTargetState : Nullable<TargetStates> with get, set

Property Value

Type: Nullable TargetStates
The state of the protection target.
See Also

Reference

ImageProtectionPersistedStateModel Class


ImageProtectionPersistedStateModel.State Property

ImageProtectionPersistedStateModelState Property
Gets or sets the state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string State { get; set; }
Public Property State As String
    Get
    Set
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}
member State : string with get, set

Property Value

Type: String
The state.
See Also

Reference

ImageProtectionPersistedStateModel Class


ImageProtectionPersistedStateModel Methods

ImageProtectionPersistedStateModel Methods

The ImageProtectionPersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageProtectionPersistedStateModel Class


ImageRecoveryJobDetailsModel Class

ImageRecoveryJobDetailsModel Class
Image recovery job details model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsImageRecoveryJobDetailsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ImageRecoveryJobDetailsModel
Public NotInheritable Class ImageRecoveryJobDetailsModel
public ref class ImageRecoveryJobDetailsModel sealed
[<SealedAttribute>]
type ImageRecoveryJobDetailsModel =  class end

The ImageRecoveryJobDetailsModel type exposes the following members.

Constructors
 | Name | Description
Public method | ImageRecoveryJobDetailsModel | Initializes a new instance of the ImageRecoveryJobDetailsModel class
Top
Properties
 | Name | Description
Public property | CutoverDetails | Gets or sets the details of the cut over operation.
Public property | RecoveryConnectionDetails | Gets or sets the details of the recovery connection.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ImageRecoveryJobDetailsModel Constructor

ImageRecoveryJobDetailsModel Constructor
Initializes a new instance of the ImageRecoveryJobDetailsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ImageRecoveryJobDetailsModel()
Public Sub New
public:
ImageRecoveryJobDetailsModel()
new : unit -> ImageRecoveryJobDetailsModel
See Also

Reference

ImageRecoveryJobDetailsModel Class


ImageRecoveryJobDetailsModel Properties

ImageRecoveryJobDetailsModel Properties

The ImageRecoveryJobDetailsModel type exposes the following members.

Properties
 | Name | Description
Public property | CutoverDetails | Gets or sets the details of the cut over operation.
Public property | RecoveryConnectionDetails | Gets or sets the details of the recovery connection.
Top
See Also

Reference

ImageRecoveryJobDetailsModel Class


ImageRecoveryJobDetailsModel.CutoverDetails Property

ImageRecoveryJobDetailsModelCutoverDetails Property
Gets or sets the details of the cut over operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CutoverDetailsModel CutoverDetails { get; set; }
Public Property CutoverDetails As CutoverDetailsModel
    Get
    Set
public:
property CutoverDetailsModel^ CutoverDetails {
    CutoverDetailsModel^ get ();
    void set (CutoverDetailsModel^ value);
}
member CutoverDetails : CutoverDetailsModel with get, set

Property Value

Type: CutoverDetailsModel
See Also

Reference

ImageRecoveryJobDetailsModel Class


ImageRecoveryJobDetailsModel.RecoveryConnectionDetails Property

ImageRecoveryJobDetailsModelRecoveryConnectionDetails Property
Gets or sets the details of the recovery connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionDetailsModel RecoveryConnectionDetails { get; set; }
Public Property RecoveryConnectionDetails As CoreConnectionDetailsModel
    Get
    Set
public:
property CoreConnectionDetailsModel^ RecoveryConnectionDetails {
    CoreConnectionDetailsModel^ get ();
    void set (CoreConnectionDetailsModel^ value);
}
member RecoveryConnectionDetails : CoreConnectionDetailsModel with get, set

Property Value

Type: CoreConnectionDetailsModel
See Also

Reference

ImageRecoveryJobDetailsModel Class


ImageRecoveryJobDetailsModel Methods

ImageRecoveryJobDetailsModel Methods

The ImageRecoveryJobDetailsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageRecoveryJobDetailsModel Class


ImageRecoveryOptionsModel Class

ImageRecoveryOptionsModel Class
Image recovery options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsImageRecoveryOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ImageRecoveryOptionsModel
Public NotInheritable Class ImageRecoveryOptionsModel
public ref class ImageRecoveryOptionsModel sealed
[<SealedAttribute>]
type ImageRecoveryOptionsModel =  class end

The ImageRecoveryOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | ImageRecoveryOptionsModel | Initializes a new instance of the ImageRecoveryOptionsModel class
Top
Properties
 | Name | Description
Public property | AdditionalStagingFolders | Gets or sets the additional folders that should be staged on the target server.
Public property | ImageId | Gets or sets the unique identifier of the image which will be recovered.
Public property | ImageRecoveryDataLocation | Gets or sets the location of the original source's image data during an image recovery job.
Public property | ShutdownSourceServer | Gets or sets a value indicating whether or not to shut down the source server during cut over.
Public property | SnapshotSetId | Gets or sets the unique identifier of the snapshot set which will be recovered.
Public property | UserInitiatedCutover | Gets or sets a value indicating whether or not the user initiates cut over.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ImageRecoveryOptionsModel Constructor

ImageRecoveryOptionsModel Constructor
Initializes a new instance of the ImageRecoveryOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ImageRecoveryOptionsModel()
Public Sub New
public:
ImageRecoveryOptionsModel()
new : unit -> ImageRecoveryOptionsModel
See Also

Reference

ImageRecoveryOptionsModel Class


ImageRecoveryOptionsModel Properties

ImageRecoveryOptionsModel Properties

The ImageRecoveryOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | AdditionalStagingFolders | Gets or sets the additional folders that should be staged on the target server.
Public property | ImageId | Gets or sets the unique identifier of the image which will be recovered.
Public property | ImageRecoveryDataLocation | Gets or sets the location of the original source's image data during an image recovery job.
Public property | ShutdownSourceServer | Gets or sets a value indicating whether or not to shut down the source server during cut over.
Public property | SnapshotSetId | Gets or sets the unique identifier of the snapshot set which will be recovered.
Public property | UserInitiatedCutover | Gets or sets a value indicating whether or not the user initiates cut over.
Top
See Also

Reference

ImageRecoveryOptionsModel Class


ImageRecoveryOptionsModel.AdditionalStagingFolders Property

ImageRecoveryOptionsModelAdditionalStagingFolders Property
Gets or sets the additional folders that should be staged on the target server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] AdditionalStagingFolders { get; set; }
Public Property AdditionalStagingFolders As String()
    Get
    Set
public:
property array<String^>^ AdditionalStagingFolders {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member AdditionalStagingFolders : string[] with get, set

Property Value

Type: String
See Also

Reference

ImageRecoveryOptionsModel Class


ImageRecoveryOptionsModel.ImageId Property

ImageRecoveryOptionsModelImageId Property
Gets or sets the unique identifier of the image which will be recovered.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Guid ImageId { get; set; }
Public Property ImageId As Guid
    Get
    Set
public:
property Guid ImageId {
    Guid get ();
    void set (Guid value);
}
member ImageId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

ImageRecoveryOptionsModel Class


ImageRecoveryOptionsModel.ImageRecoveryDataLocation Property

ImageRecoveryOptionsModelImageRecoveryDataLocation Property
Gets or sets the location of the original source's image data during an image recovery job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ImageRecoveryDataLocation { get; set; }
Public Property ImageRecoveryDataLocation As String
    Get
    Set
public:
property String^ ImageRecoveryDataLocation {
    String^ get ();
    void set (String^ value);
}
member ImageRecoveryDataLocation : string with get, set

Property Value

Type: String
See Also

Reference

ImageRecoveryOptionsModel Class


ImageRecoveryOptionsModel.ShutdownSourceServer Property

ImageRecoveryOptionsModelShutdownSourceServer Property
Gets or sets a value indicating whether or not to shut down the source server during cut over.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShutdownSourceServer { get; set; }
Public Property ShutdownSourceServer As Boolean
    Get
    Set
public:
property bool ShutdownSourceServer {
    bool get ();
    void set (bool value);
}
member ShutdownSourceServer : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ImageRecoveryOptionsModel Class


ImageRecoveryOptionsModel.SnapshotSetId Property

ImageRecoveryOptionsModelSnapshotSetId Property
Gets or sets the unique identifier of the snapshot set which will be recovered.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Guid SnapshotSetId { get; set; }
Public Property SnapshotSetId As Guid
    Get
    Set
public:
property Guid SnapshotSetId {
    Guid get ();
    void set (Guid value);
}
member SnapshotSetId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

ImageRecoveryOptionsModel Class


ImageRecoveryOptionsModel.UserInitiatedCutover Property

ImageRecoveryOptionsModelUserInitiatedCutover Property
Gets or sets a value indicating whether or not the user initiates cut over.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool UserInitiatedCutover { get; set; }
Public Property UserInitiatedCutover As Boolean
    Get
    Set
public:
property bool UserInitiatedCutover {
    bool get ();
    void set (bool value);
}
member UserInitiatedCutover : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ImageRecoveryOptionsModel Class


ImageRecoveryOptionsModel Methods

ImageRecoveryOptionsModel Methods

The ImageRecoveryOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageRecoveryOptionsModel Class


ImageRecoveryPersistedStateModel Class

ImageRecoveryPersistedStateModel Class
Image recovery persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsImageRecoveryPersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class ImageRecoveryPersistedStateModel
Public NotInheritable Class ImageRecoveryPersistedStateModel
public ref class ImageRecoveryPersistedStateModel sealed
[<SealedAttribute>]
type ImageRecoveryPersistedStateModel =  class end

The ImageRecoveryPersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | ImageRecoveryPersistedStateModel | Initializes a new instance of the ImageRecoveryPersistedStateModel class
Top
Properties
 | Name | Description
Public property | FailoverOptions | Gets or sets the failover options.
Public property | RecoveryConnectionPersistedState | Gets or sets the state of the recovery connection persisted.
Public property | RecoveryTargetState | Gets or sets the state of the recovery target.
Public property | State | Gets or sets the state.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ImageRecoveryPersistedStateModel Constructor

ImageRecoveryPersistedStateModel Constructor
Initializes a new instance of the ImageRecoveryPersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ImageRecoveryPersistedStateModel()
Public Sub New
public:
ImageRecoveryPersistedStateModel()
new : unit -> ImageRecoveryPersistedStateModel
See Also

Reference

ImageRecoveryPersistedStateModel Class


ImageRecoveryPersistedStateModel Properties

ImageRecoveryPersistedStateModel Properties

The ImageRecoveryPersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | FailoverOptions | Gets or sets the failover options.
Public property | RecoveryConnectionPersistedState | Gets or sets the state of the recovery connection persisted.
Public property | RecoveryTargetState | Gets or sets the state of the recovery target.
Public property | State | Gets or sets the state.
Top
See Also

Reference

ImageRecoveryPersistedStateModel Class


ImageRecoveryPersistedStateModel.FailoverOptions Property

ImageRecoveryPersistedStateModelFailoverOptions Property
Gets or sets the failover options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public FailoverOptionsModel FailoverOptions { get; set; }
Public Property FailoverOptions As FailoverOptionsModel
    Get
    Set
public:
property FailoverOptionsModel^ FailoverOptions {
    FailoverOptionsModel^ get ();
    void set (FailoverOptionsModel^ value);
}
member FailoverOptions : FailoverOptionsModel with get, set

Property Value

Type: FailoverOptionsModel
The failover options.
See Also

Reference

ImageRecoveryPersistedStateModel Class


ImageRecoveryPersistedStateModel.RecoveryConnectionPersistedState Property

ImageRecoveryPersistedStateModelRecoveryConnectionPersistedState Property
Gets or sets the state of the recovery connection persisted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionPersistedStateModel RecoveryConnectionPersistedState { get; set; }
Public Property RecoveryConnectionPersistedState As CoreConnectionPersistedStateModel
    Get
    Set
public:
property CoreConnectionPersistedStateModel^ RecoveryConnectionPersistedState {
    CoreConnectionPersistedStateModel^ get ();
    void set (CoreConnectionPersistedStateModel^ value);
}
member RecoveryConnectionPersistedState : CoreConnectionPersistedStateModel with get, set

Property Value

Type: CoreConnectionPersistedStateModel
The state of the protection connection persisted.
See Also

Reference

ImageRecoveryPersistedStateModel Class


ImageRecoveryPersistedStateModel.RecoveryTargetState Property

ImageRecoveryPersistedStateModelRecoveryTargetState Property
Gets or sets the state of the recovery target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TargetStates> RecoveryTargetState { get; set; }
Public Property RecoveryTargetState As Nullable(Of TargetStates)
    Get
    Set
public:
property Nullable<TargetStates> RecoveryTargetState {
    Nullable<TargetStates> get ();
    void set (Nullable<TargetStates> value);
}
member RecoveryTargetState : Nullable<TargetStates> with get, set

Property Value

Type: Nullable TargetStates
The state of the recovery target.
See Also

Reference

ImageRecoveryPersistedStateModel Class


ImageRecoveryPersistedStateModel.State Property

ImageRecoveryPersistedStateModelState Property
Gets or sets the state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string State { get; set; }
Public Property State As String
    Get
    Set
public:
property String^ State {
    String^ get ();
    void set (String^ value);
}
member State : string with get, set

Property Value

Type: String
The state.
See Also

Reference

ImageRecoveryPersistedStateModel Class


ImageRecoveryPersistedStateModel Methods

ImageRecoveryPersistedStateModel Methods

The ImageRecoveryPersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageRecoveryPersistedStateModel Class


ImageType Enumeration

ImageType Enumeration
The image type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum ImageType
Public Enumeration ImageType
public enum class ImageType
type ImageType
Members
Member name | Value | Description
DataOnly | 0 | The data only
FullServer | 1 | The full server
Unknown | 2 | The unknown
See Also

Reference

DoubleTake.Web.Models Namespace


ImageVhdInfoModel Class

ImageVhdInfoModel Class
Image VHD info model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsImageVhdInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ImageVhdInfoModel
Public NotInheritable Class ImageVhdInfoModel
public ref class ImageVhdInfoModel sealed
[<SealedAttribute>]
type ImageVhdInfoModel =  class end

The ImageVhdInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ImageVhdInfoModel | Initializes a new instance of the ImageVhdInfoModel class
Top
Properties
 | Name | Description
Public property | FilePath | Gets or sets full path to the VHD file.
Public property | FormatType | Gets or sets the format type of the VHD file.
Public property | SizeInMB | Gets or sets size of the VHD file in Megabytes.
Public property | UseExistingVhd | Gets or sets a value indicating whether or not existing VHD file should be used.
Public property | VolumeLetter | Gets or sets volume letter of the original volume this VHD is storing.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ImageVhdInfoModel Constructor

ImageVhdInfoModel Constructor
Initializes a new instance of the ImageVhdInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ImageVhdInfoModel()
Public Sub New
public:
ImageVhdInfoModel()
new : unit -> ImageVhdInfoModel
See Also

Reference

ImageVhdInfoModel Class


ImageVhdInfoModel Properties

ImageVhdInfoModel Properties

The ImageVhdInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | FilePath | Gets or sets full path to the VHD file.
Public property | FormatType | Gets or sets the format type of the VHD file.
Public property | SizeInMB | Gets or sets size of the VHD file in Megabytes.
Public property | UseExistingVhd | Gets or sets a value indicating whether or not existing VHD file should be used.
Public property | VolumeLetter | Gets or sets volume letter of the original volume this VHD is storing.
Top
See Also

Reference

ImageVhdInfoModel Class


ImageVhdInfoModel.FilePath Property

ImageVhdInfoModelFilePath Property
Gets or sets full path to the VHD file.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string FilePath { get; set; }
Public Property FilePath As String
    Get
    Set
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}
member FilePath : string with get, set

Property Value

Type: String
See Also

Reference

ImageVhdInfoModel Class


ImageVhdInfoModel.FormatType Property

ImageVhdInfoModelFormatType Property
Gets or sets the format type of the VHD file.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string FormatType { get; set; }
Public Property FormatType As String
    Get
    Set
public:
property String^ FormatType {
    String^ get ();
    void set (String^ value);
}
member FormatType : string with get, set

Property Value

Type: String
See Also

Reference

ImageVhdInfoModel Class


ImageVhdInfoModel.SizeInMB Property

ImageVhdInfoModelSizeInMB Property
Gets or sets size of the VHD file in Megabytes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long SizeInMB { get; set; }
Public Property SizeInMB As Long
    Get
    Set
public:
property long long SizeInMB {
    long long get ();
    void set (long long value);
}
member SizeInMB : int64 with get, set

Property Value

Type: Int64
See Also

Reference

ImageVhdInfoModel Class


ImageVhdInfoModel.UseExistingVhd Property

ImageVhdInfoModelUseExistingVhd Property
Gets or sets a value indicating whether or not existing VHD file should be used.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseExistingVhd { get; set; }
Public Property UseExistingVhd As Boolean
    Get
    Set
public:
property bool UseExistingVhd {
    bool get ();
    void set (bool value);
}
member UseExistingVhd : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ImageVhdInfoModel Class


ImageVhdInfoModel.VolumeLetter Property

ImageVhdInfoModelVolumeLetter Property
Gets or sets volume letter of the original volume this VHD is storing.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string VolumeLetter { get; set; }
Public Property VolumeLetter As String
    Get
    Set
public:
property String^ VolumeLetter {
    String^ get ();
    void set (String^ value);
}
member VolumeLetter : string with get, set

Property Value

Type: String
See Also

Reference

ImageVhdInfoModel Class


ImageVhdInfoModel Methods

ImageVhdInfoModel Methods

The ImageVhdInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ImageVhdInfoModel Class


InclusionMode Enumeration

InclusionMode Enumeration
Inclusion mode.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum InclusionMode
Public Enumeration InclusionMode
public enum class InclusionMode
type InclusionMode
Members
Member name | Value | Description
Include | 0 | The include
Exclude | 1 | The exclude
See Also

Reference

DoubleTake.Web.Models Namespace


IntegerSettingModel Class

IntegerSettingModel Class
Integer setting.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsNamedSettingModel
DoubleTake.Web.ModelsIntegerSettingModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class IntegerSettingModel : NamedSettingModel
Public Class IntegerSettingModel
    Inherits NamedSettingModel
public ref class IntegerSettingModel : public NamedSettingModel
type IntegerSettingModel =
    class
        inherit NamedSettingModel
    end

The IntegerSettingModel type exposes the following members.

Constructors
 | Name | Description
Public method | IntegerSettingModel | Initializes a new instance of the IntegerSettingModel class
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name. (Inherited from NamedSettingModel.)
Public property | TypeName | Gets or sets the type name. (Inherited from NamedSettingModel.)
Public property | Value | Gets or sets the value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


IntegerSettingModel Constructor

IntegerSettingModel Constructor
Initializes a new instance of the IntegerSettingModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public IntegerSettingModel()
Public Sub New
public:
IntegerSettingModel()
new : unit -> IntegerSettingModel
See Also

Reference

IntegerSettingModel Class


IntegerSettingModel Properties

IntegerSettingModel Properties

The IntegerSettingModel type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name. (Inherited from NamedSettingModel.)
Public property | TypeName | Gets or sets the type name. (Inherited from NamedSettingModel.)
Public property | Value | Gets or sets the value.
Top
See Also

Reference

IntegerSettingModel Class


IntegerSettingModel.Value Property

IntegerSettingModelValue Property
Gets or sets the value.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long Value { get; set; }
Public Property Value As Long
    Get
    Set
public:
property long long Value {
    long long get ();
    void set (long long value);
}
member Value : int64 with get, set

Property Value

Type: Int64
See Also

Reference

IntegerSettingModel Class


IntegerSettingModel Methods

IntegerSettingModel Methods

The IntegerSettingModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IntegerSettingModel Class


IPAddressModel Class

IPAddressModel Class
IP address.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsIPAddressModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class IPAddressModel
Public Class IPAddressModel
public ref class IPAddressModel
type IPAddressModel =  class end

The IPAddressModel type exposes the following members.

Constructors
 | Name | Description
Public method | IPAddressModel | Initializes a new instance of the IPAddressModel class
Top
Properties
 | Name | Description
Public property | Address | Gets or sets the address.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


IPAddressModel Constructor

IPAddressModel Constructor
Initializes a new instance of the IPAddressModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public IPAddressModel()
Public Sub New
public:
IPAddressModel()
new : unit -> IPAddressModel
See Also

Reference

IPAddressModel Class


IPAddressModel Properties

IPAddressModel Properties

The IPAddressModel type exposes the following members.

Properties
 | Name | Description
Public property | Address | Gets or sets the address.
Top
See Also

Reference

IPAddressModel Class


IPAddressModel.Address Property

IPAddressModelAddress Property
Gets or sets the address.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public byte[] Address { get; set; }
Public Property Address As Byte()
    Get
    Set
public:
property array<unsigned char>^ Address {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member Address : byte[] with get, set

Property Value

Type: Byte
The address.
See Also

Reference

IPAddressModel Class


IPAddressModel Methods

IPAddressModel Methods

The IPAddressModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IPAddressModel Class


JobActionModel Class

JobActionModel Class
Job action model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsJobActionModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class JobActionModel
Public NotInheritable Class JobActionModel
public ref class JobActionModel sealed
[<SealedAttribute>]
type JobActionModel =  class end

The JobActionModel type exposes the following members.

Constructors
 | Name | Description
Public method | JobActionModel | Initializes a new instance of the JobActionModel class
Top
Properties
 | Name | Description
Public property | Duration | Gets or sets the duration of this action.
Public property | ErrorCode | Gets or sets the error code associated with this action.
Public property | ExceptionMessage | Gets or sets the message from the underlying exception.
Public property | Id | Gets or sets a unique identifier for this action.
Public property | MessageFormatParameters | Gets or sets the message format parameters for this action.
Public property | MessageId | Gets or sets the message identifier for this action.
Public property | RequestingUserName | Gets or sets the name of the user that requested this action.
Public property | Status | Gets or sets the status of this action.
Public property | Timestamp | Gets or sets the timestamp when this action occurred.
Public property | TitleFormatParameters | Gets or sets the title format parameters for this action.
Public property | TitleId | Gets or sets the title identifier for this action.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


JobActionModel Constructor

JobActionModel Constructor
Initializes a new instance of the JobActionModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public JobActionModel()
Public Sub New
public:
JobActionModel()
new : unit -> JobActionModel
See Also

Reference

JobActionModel Class


JobActionModel Properties

JobActionModel Properties

The JobActionModel type exposes the following members.

Properties
 | Name | Description
Public property | Duration | Gets or sets the duration of this action.
Public property | ErrorCode | Gets or sets the error code associated with this action.
Public property | ExceptionMessage | Gets or sets the message from the underlying exception.
Public property | Id | Gets or sets a unique identifier for this action.
Public property | MessageFormatParameters | Gets or sets the message format parameters for this action.
Public property | MessageId | Gets or sets the message identifier for this action.
Public property | RequestingUserName | Gets or sets the name of the user that requested this action.
Public property | Status | Gets or sets the status of this action.
Public property | Timestamp | Gets or sets the timestamp when this action occurred.
Public property | TitleFormatParameters | Gets or sets the title format parameters for this action.
Public property | TitleId | Gets or sets the title identifier for this action.
Top
See Also

Reference

JobActionModel Class


JobActionModel.Duration Property

JobActionModelDuration Property
Gets or sets the duration of this action.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Duration { get; set; }
Public Property Duration As TimeSpan
    Get
    Set
public:
property TimeSpan Duration {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Duration : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

JobActionModel Class


JobActionModel.ErrorCode Property

JobActionModelErrorCode Property
Gets or sets the error code associated with this action.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int ErrorCode { get; set; }
Public Property ErrorCode As Integer
    Get
    Set
public:
property int ErrorCode {
    int get ();
    void set (int value);
}
member ErrorCode : int with get, set

Property Value

Type: Int32
See Also

Reference

JobActionModel Class


JobActionModel.ExceptionMessage Property

JobActionModelExceptionMessage Property
Gets or sets the message from the underlying exception.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ExceptionMessage { get; set; }
Public Property ExceptionMessage As String
    Get
    Set
public:
property String^ ExceptionMessage {
    String^ get ();
    void set (String^ value);
}
member ExceptionMessage : string with get, set

Property Value

Type: String
See Also

Reference

JobActionModel Class


JobActionModel.Id Property

JobActionModelId Property
Gets or sets a unique identifier for this action.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
member Id : Guid with get, set

Property Value

Type: Guid
See Also

Reference

JobActionModel Class


JobActionModel.MessageFormatParameters Property

JobActionModelMessageFormatParameters Property
Gets or sets the message format parameters for this action.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] MessageFormatParameters { get; set; }
Public Property MessageFormatParameters As String()
    Get
    Set
public:
property array<String^>^ MessageFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member MessageFormatParameters : string[] with get, set

Property Value

Type: String
See Also

Reference

JobActionModel Class


JobActionModel.MessageId Property

JobActionModelMessageId Property
Gets or sets the message identifier for this action.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string MessageId { get; set; }
Public Property MessageId As String
    Get
    Set
public:
property String^ MessageId {
    String^ get ();
    void set (String^ value);
}
member MessageId : string with get, set

Property Value

Type: String
See Also

Reference

JobActionModel Class


JobActionModel.RequestingUserName Property

JobActionModelRequestingUserName Property
Gets or sets the name of the user that requested this action.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string RequestingUserName { get; set; }
Public Property RequestingUserName As String
    Get
    Set
public:
property String^ RequestingUserName {
    String^ get ();
    void set (String^ value);
}
member RequestingUserName : string with get, set

Property Value

Type: String
See Also

Reference

JobActionModel Class


JobActionModel.Status Property

JobActionModelStatus Property
Gets or sets the status of this action.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ActionStatus Status { get; set; }
Public Property Status As ActionStatus
    Get
    Set
public:
property ActionStatus Status {
    ActionStatus get ();
    void set (ActionStatus value);
}
member Status : ActionStatus with get, set

Property Value

Type: ActionStatus
See Also

Reference

JobActionModel Class


JobActionModel.Timestamp Property

JobActionModelTimestamp Property
Gets or sets the timestamp when this action occurred.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset Timestamp { get; set; }
Public Property Timestamp As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset Timestamp {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member Timestamp : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

JobActionModel Class


JobActionModel.TitleFormatParameters Property

JobActionModelTitleFormatParameters Property
Gets or sets the title format parameters for this action.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] TitleFormatParameters { get; set; }
Public Property TitleFormatParameters As String()
    Get
    Set
public:
property array<String^>^ TitleFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member TitleFormatParameters : string[] with get, set

Property Value

Type: String
See Also

Reference

JobActionModel Class


JobActionModel.TitleId Property

JobActionModelTitleId Property
Gets or sets the title identifier for this action.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TitleId { get; set; }
Public Property TitleId As String
    Get
    Set
public:
property String^ TitleId {
    String^ get ();
    void set (String^ value);
}
member TitleId : string with get, set

Property Value

Type: String
See Also

Reference

JobActionModel Class


JobActionModel Methods

JobActionModel Methods

The JobActionModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobActionModel Class


JobCredentialsModel Class

JobCredentialsModel Class
Job credentials model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsJobCredentialsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public class JobCredentialsModel
Public Class JobCredentialsModel
public ref class JobCredentialsModel
type JobCredentialsModel =  class end

The JobCredentialsModel type exposes the following members.

Constructors
 | Name | Description
Public method | JobCredentialsModel | Initializes a new instance of the JobCredentialsModel class
Top
Properties
 | Name | Description
Public property | OtherServers | Gets or sets the connection information for other servers.
Public property | SourceServer | Gets or sets the source server connection information.
Public property | TargetServer | Gets or sets the target server connection information.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


JobCredentialsModel Constructor

JobCredentialsModel Constructor
Initializes a new instance of the JobCredentialsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public JobCredentialsModel()
Public Sub New
public:
JobCredentialsModel()
new : unit -> JobCredentialsModel
See Also

Reference

JobCredentialsModel Class


JobCredentialsModel Properties

JobCredentialsModel Properties

The JobCredentialsModel type exposes the following members.

Properties
 | Name | Description
Public property | OtherServers | Gets or sets the connection information for other servers.
Public property | SourceServer | Gets or sets the source server connection information.
Public property | TargetServer | Gets or sets the target server connection information.
Top
See Also

Reference

JobCredentialsModel Class


JobCredentialsModel.OtherServers Property

JobCredentialsModelOtherServers Property
Gets or sets the connection information for other servers.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, ServiceConnectionModel> OtherServers { get; set; }
Public Property OtherServers As IDictionary(Of String, ServiceConnectionModel)
    Get
    Set
public:
property IDictionary<String^, ServiceConnectionModel^>^ OtherServers {
    IDictionary<String^, ServiceConnectionModel^>^ get ();
    void set (IDictionary<String^, ServiceConnectionModel^>^ value);
}
member OtherServers : IDictionary<string, ServiceConnectionModel> with get, set

Property Value

Type: IDictionary String, ServiceConnectionModel
See Also

Reference

JobCredentialsModel Class


JobCredentialsModel.SourceServer Property

JobCredentialsModelSourceServer Property
Gets or sets the source server connection information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ServiceConnectionModel SourceServer { get; set; }
Public Property SourceServer As ServiceConnectionModel
    Get
    Set
public:
property ServiceConnectionModel^ SourceServer {
    ServiceConnectionModel^ get ();
    void set (ServiceConnectionModel^ value);
}
member SourceServer : ServiceConnectionModel with get, set

Property Value

Type: ServiceConnectionModel
See Also

Reference

JobCredentialsModel Class


JobCredentialsModel.TargetServer Property

JobCredentialsModelTargetServer Property
Gets or sets the target server connection information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ServiceConnectionModel TargetServer { get; set; }
Public Property TargetServer As ServiceConnectionModel
    Get
    Set
public:
property ServiceConnectionModel^ TargetServer {
    ServiceConnectionModel^ get ();
    void set (ServiceConnectionModel^ value);
}
member TargetServer : ServiceConnectionModel with get, set

Property Value

Type: ServiceConnectionModel
See Also

Reference

JobCredentialsModel Class


JobCredentialsModel Methods

JobCredentialsModel Methods

The JobCredentialsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobCredentialsModel Class


JobInfoModel Class

JobInfoModel Class
Job info model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsJobInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class JobInfoModel
Public NotInheritable Class JobInfoModel
public ref class JobInfoModel sealed
[<SealedAttribute>]
type JobInfoModel =  class end

The JobInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | JobInfoModel | Initializes a new instance of the JobInfoModel class
Top
Properties
 | Name | Description
Public property | CreatorUserName | Gets or sets the name of the user who created this job.
Public property | Features | Gets or sets the additional features supported by this job.
Public property | Id | Gets or sets the unique identifier of this job.
Public property | JobType | Gets or sets the type of this job.
Public property | LoadedFromDisk | Gets or sets a value indicating whether this job was loaded from persistence.
Public property | Managed | Gets or sets a value indicating whether or not this job is managed by the unified job manager.
Public property | Options | Gets or sets the current options for this job.
Public property | OtherServers | Gets or sets the server connection information for other servers involved in the job.
Public property | SourceServer | Gets or sets the source server connection information.
Public property | SourceUniqueId | Gets or sets the unique identifier of the source server.
Public property | Statistics | Gets or sets the current statistics of this job.
Public property | Status | Gets or sets the current status of this job.
Public property | TargetServer | Gets or sets the target server connection information.
Public property | TargetUniqueId | Gets or sets the unique identifier of the target server.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


JobInfoModel Constructor

JobInfoModel Constructor
Initializes a new instance of the JobInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public JobInfoModel()
Public Sub New
public:
JobInfoModel()
new : unit -> JobInfoModel
See Also

Reference

JobInfoModel Class


JobInfoModel Properties

JobInfoModel Properties

The JobInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | CreatorUserName | Gets or sets the name of the user who created this job.
Public property | Features | Gets or sets the additional features supported by this job.
Public property | Id | Gets or sets the unique identifier of this job.
Public property | JobType | Gets or sets the type of this job.
Public property | LoadedFromDisk | Gets or sets a value indicating whether this job was loaded from persistence.
Public property | Managed | Gets or sets a value indicating whether or not this job is managed by the unified job manager.
Public property | Options | Gets or sets the current options for this job.
Public property | OtherServers | Gets or sets the server connection information for other servers involved in the job.
Public property | SourceServer | Gets or sets the source server connection information.
Public property | SourceUniqueId | Gets or sets the unique identifier of the source server.
Public property | Statistics | Gets or sets the current statistics of this job.
Public property | Status | Gets or sets the current status of this job.
Public property | TargetServer | Gets or sets the target server connection information.
Public property | TargetUniqueId | Gets or sets the unique identifier of the target server.
Top
See Also

Reference

JobInfoModel Class


JobInfoModel.CreatorUserName Property

JobInfoModelCreatorUserName Property
Gets or sets the name of the user who created this job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string CreatorUserName { get; set; }
Public Property CreatorUserName As String
    Get
    Set
public:
property String^ CreatorUserName {
    String^ get ();
    void set (String^ value);
}
member CreatorUserName : string with get, set

Property Value

Type: String
See Also

Reference

JobInfoModel Class


JobInfoModel.Features Property

JobInfoModelFeatures Property
Gets or sets the additional features supported by this job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FeatureModel[] Features { get; set; }
Public Property Features As FeatureModel()
    Get
    Set
public:
property array<FeatureModel^>^ Features {
    array<FeatureModel^>^ get ();
    void set (array<FeatureModel^>^ value);
}
member Features : FeatureModel[] with get, set

Property Value

Type: FeatureModel
See Also

Reference

JobInfoModel Class


JobInfoModel.Id Property

JobInfoModelId Property
Gets or sets the unique identifier of this job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
member Id : Guid with get, set

Property Value

Type: Guid
See Also

Reference

JobInfoModel Class


JobInfoModel.JobType Property

JobInfoModelJobType Property
Gets or sets the type of this job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string JobType { get; set; }
Public Property JobType As String
    Get
    Set
public:
property String^ JobType {
    String^ get ();
    void set (String^ value);
}
member JobType : string with get, set

Property Value

Type: String
See Also

Reference

JobInfoModel Class


JobInfoModel.LoadedFromDisk Property

JobInfoModelLoadedFromDisk Property
Gets or sets a value indicating whether this job was loaded from persistence.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool LoadedFromDisk { get; set; }
Public Property LoadedFromDisk As Boolean
    Get
    Set
public:
property bool LoadedFromDisk {
    bool get ();
    void set (bool value);
}
member LoadedFromDisk : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobInfoModel Class


JobInfoModel.Managed Property

JobInfoModelManaged Property
Gets or sets a value indicating whether or not this job is managed by the unified job manager.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool Managed { get; set; }
Public Property Managed As Boolean
    Get
    Set
public:
property bool Managed {
    bool get ();
    void set (bool value);
}
member Managed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobInfoModel Class


JobInfoModel.Options Property

JobInfoModelOptions Property
Gets or sets the current options for this job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public JobOptionsModel Options { get; set; }
Public Property Options As JobOptionsModel
    Get
    Set
public:
property JobOptionsModel^ Options {
    JobOptionsModel^ get ();
    void set (JobOptionsModel^ value);
}
member Options : JobOptionsModel with get, set

Property Value

Type: JobOptionsModel
See Also

Reference

JobInfoModel Class


JobInfoModel.OtherServers Property

JobInfoModelOtherServers Property
Gets or sets the server connection information for other servers involved in the job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, ServiceConnectionModel> OtherServers { get; set; }
Public Property OtherServers As IDictionary(Of String, ServiceConnectionModel)
    Get
    Set
public:
property IDictionary<String^, ServiceConnectionModel^>^ OtherServers {
    IDictionary<String^, ServiceConnectionModel^>^ get ();
    void set (IDictionary<String^, ServiceConnectionModel^>^ value);
}
member OtherServers : IDictionary<string, ServiceConnectionModel> with get, set

Property Value

Type: IDictionary String, ServiceConnectionModel
See Also

Reference

JobInfoModel Class


JobInfoModel.SourceServer Property

JobInfoModelSourceServer Property
Gets or sets the source server connection information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ServiceConnectionModel SourceServer { get; set; }
Public Property SourceServer As ServiceConnectionModel
    Get
    Set
public:
property ServiceConnectionModel^ SourceServer {
    ServiceConnectionModel^ get ();
    void set (ServiceConnectionModel^ value);
}
member SourceServer : ServiceConnectionModel with get, set

Property Value

Type: ServiceConnectionModel
See Also

Reference

JobInfoModel Class


JobInfoModel.SourceUniqueId Property

JobInfoModelSourceUniqueId Property
Gets or sets the unique identifier of the source server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceUniqueId { get; set; }
Public Property SourceUniqueId As String
    Get
    Set
public:
property String^ SourceUniqueId {
    String^ get ();
    void set (String^ value);
}
member SourceUniqueId : string with get, set

Property Value

Type: String
See Also

Reference

JobInfoModel Class


JobInfoModel.Statistics Property

JobInfoModelStatistics Property
Gets or sets the current statistics of this job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public JobStatisticsModel Statistics { get; set; }
Public Property Statistics As JobStatisticsModel
    Get
    Set
public:
property JobStatisticsModel^ Statistics {
    JobStatisticsModel^ get ();
    void set (JobStatisticsModel^ value);
}
member Statistics : JobStatisticsModel with get, set

Property Value

Type: JobStatisticsModel
See Also

Reference

JobInfoModel Class


JobInfoModel.Status Property

JobInfoModelStatus Property
Gets or sets the current status of this job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public JobStatusModel Status { get; set; }
Public Property Status As JobStatusModel
    Get
    Set
public:
property JobStatusModel^ Status {
    JobStatusModel^ get ();
    void set (JobStatusModel^ value);
}
member Status : JobStatusModel with get, set

Property Value

Type: JobStatusModel
See Also

Reference

JobInfoModel Class


JobInfoModel.TargetServer Property

JobInfoModelTargetServer Property
Gets or sets the target server connection information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ServiceConnectionModel TargetServer { get; set; }
Public Property TargetServer As ServiceConnectionModel
    Get
    Set
public:
property ServiceConnectionModel^ TargetServer {
    ServiceConnectionModel^ get ();
    void set (ServiceConnectionModel^ value);
}
member TargetServer : ServiceConnectionModel with get, set

Property Value

Type: ServiceConnectionModel
See Also

Reference

JobInfoModel Class


JobInfoModel.TargetUniqueId Property

JobInfoModelTargetUniqueId Property
Gets or sets the unique identifier of the target server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetUniqueId { get; set; }
Public Property TargetUniqueId As String
    Get
    Set
public:
property String^ TargetUniqueId {
    String^ get ();
    void set (String^ value);
}
member TargetUniqueId : string with get, set

Property Value

Type: String
See Also

Reference

JobInfoModel Class


JobInfoModel Methods

JobInfoModel Methods

The JobInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobInfoModel Class


JobInfoPrivateModel Class

JobInfoPrivateModel Class
Used for storing the status information for a job. It tells you whether or not the job is started. If it is started, it provides the status information for each connection that is associated with this job.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsJobInfoPrivateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class JobInfoPrivateModel
Public NotInheritable Class JobInfoPrivateModel
public ref class JobInfoPrivateModel sealed
[<SealedAttribute>]
type JobInfoPrivateModel =  class end

The JobInfoPrivateModel type exposes the following members.

Constructors
 | Name | Description
Public method | JobInfoPrivateModel | Initializes a new instance of the JobInfoPrivateModel class
Top
Properties
 | Name | Description
Public property | CreatorUserName | Gets or sets the name of the user who created the job.
Public property | Features | Gets or sets a service endpoint that provides additional features for a job.
Public property | Id | Gets or sets the unique identifier.
Public property | JobType | Gets or sets the type of job.
Public property | LoadedFromDisk | Gets or sets a value indicating whether the job was loaded from persistence.
Public property | Managed | Gets or sets a value indicating whether the job is managed.
Public property | Options | Gets or sets the current options for the job.
Public property | OtherHostUris | Gets or sets the URIs for other servers involved in the job.
Public property | SourceHostUri | Gets or sets the source URI.
Public property | SourceUniqueId | Gets or sets the unique ID of the source server.
Public property | Statistics | Gets or sets the current statistics of the job
Public property | Status | Gets or sets the current state of the job.
Public property | TargetHostUri | Gets or sets the target URI.
Public property | TargetUniqueId | Gets or sets the unique ID of the target server.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


JobInfoPrivateModel Constructor

JobInfoPrivateModel Constructor
Initializes a new instance of the JobInfoPrivateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public JobInfoPrivateModel()
Public Sub New
public:
JobInfoPrivateModel()
new : unit -> JobInfoPrivateModel
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel Properties

JobInfoPrivateModel Properties

The JobInfoPrivateModel type exposes the following members.

Properties
 | Name | Description
Public property | CreatorUserName | Gets or sets the name of the user who created the job.
Public property | Features | Gets or sets a service endpoint that provides additional features for a job.
Public property | Id | Gets or sets the unique identifier.
Public property | JobType | Gets or sets the type of job.
Public property | LoadedFromDisk | Gets or sets a value indicating whether the job was loaded from persistence.
Public property | Managed | Gets or sets a value indicating whether the job is managed.
Public property | Options | Gets or sets the current options for the job.
Public property | OtherHostUris | Gets or sets the URIs for other servers involved in the job.
Public property | SourceHostUri | Gets or sets the source URI.
Public property | SourceUniqueId | Gets or sets the unique ID of the source server.
Public property | Statistics | Gets or sets the current statistics of the job
Public property | Status | Gets or sets the current state of the job.
Public property | TargetHostUri | Gets or sets the target URI.
Public property | TargetUniqueId | Gets or sets the unique ID of the target server.
Top
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.CreatorUserName Property

JobInfoPrivateModelCreatorUserName Property
Gets or sets the name of the user who created the job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string CreatorUserName { get; set; }
Public Property CreatorUserName As String
    Get
    Set
public:
property String^ CreatorUserName {
    String^ get ();
    void set (String^ value);
}
member CreatorUserName : string with get, set

Property Value

Type: String
The name of the user who created this job.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.Features Property

JobInfoPrivateModelFeatures Property
Gets or sets a service endpoint that provides additional features for a job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public FeatureModel[] Features { get; set; }
Public Property Features As FeatureModel()
    Get
    Set
public:
property array<FeatureModel^>^ Features {
    array<FeatureModel^>^ get ();
    void set (array<FeatureModel^>^ value);
}
member Features : FeatureModel[] with get, set

Property Value

Type: FeatureModel
An array of Feature that includes the additional features supported by this job.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.Id Property

JobInfoPrivateModelId Property
Gets or sets the unique identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
member Id : Guid with get, set

Property Value

Type: Guid
The unique identifier.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.JobType Property

JobInfoPrivateModelJobType Property
Gets or sets the type of job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string JobType { get; set; }
Public Property JobType As String
    Get
    Set
public:
property String^ JobType {
    String^ get ();
    void set (String^ value);
}
member JobType : string with get, set

Property Value

Type: String
The type of this job.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.LoadedFromDisk Property

JobInfoPrivateModelLoadedFromDisk Property
Gets or sets a value indicating whether the job was loaded from persistence.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool LoadedFromDisk { get; set; }
Public Property LoadedFromDisk As Boolean
    Get
    Set
public:
property bool LoadedFromDisk {
    bool get ();
    void set (bool value);
}
member LoadedFromDisk : bool with get, set

Property Value

Type: Boolean
if this job was loaded from persistence; otherwise, .
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.Managed Property

JobInfoPrivateModelManaged Property
Gets or sets a value indicating whether the job is managed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool Managed { get; set; }
Public Property Managed As Boolean
    Get
    Set
public:
property bool Managed {
    bool get ();
    void set (bool value);
}
member Managed : bool with get, set

Property Value

Type: Boolean
if this job is managed; otherwise, .
Remarks
This property is intended to be used by transitional implementations of jobs that want to allow their jobs to be visible to the job manager, but will be responsible for creating those jobs and managing their lifetime. Typically, jobs who have this property set to will be added to the job manager using the [M:Add] method.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.Options Property

JobInfoPrivateModelOptions Property
Gets or sets the current options for the job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public JobOptionsModel Options { get; set; }
Public Property Options As JobOptionsModel
    Get
    Set
public:
property JobOptionsModel^ Options {
    JobOptionsModel^ get ();
    void set (JobOptionsModel^ value);
}
member Options : JobOptionsModel with get, set

Property Value

Type: JobOptionsModel
A JobOptions that represents the current options for this job.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.OtherHostUris Property

JobInfoPrivateModelOtherHostUris Property
Gets or sets the URIs for other servers involved in the job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, Uri> OtherHostUris { get; set; }
Public Property OtherHostUris As IDictionary(Of String, Uri)
    Get
    Set
public:
property IDictionary<String^, Uri^>^ OtherHostUris {
    IDictionary<String^, Uri^>^ get ();
    void set (IDictionary<String^, Uri^>^ value);
}
member OtherHostUris : IDictionary<string, Uri> with get, set

Property Value

Type: IDictionary String, Uri
The other server URIs.
Remarks
This property serves as a replacement for the OtherNetworkIds property. Please refrain from using the OtherNetworkIds property.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.SourceHostUri Property

JobInfoPrivateModelSourceHostUri Property
Gets or sets the source URI.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Uri SourceHostUri { get; set; }
Public Property SourceHostUri As Uri
    Get
    Set
public:
property Uri^ SourceHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
member SourceHostUri : Uri with get, set

Property Value

Type: Uri
The source URI.
Remarks
This property serves as a replacement for the SourceNetworkId and SourceManagementPort properties because both of these pieces of information can be provided in and extracted from the URI.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.SourceUniqueId Property

JobInfoPrivateModelSourceUniqueId Property
Gets or sets the unique ID of the source server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SourceUniqueId { get; set; }
Public Property SourceUniqueId As String
    Get
    Set
public:
property String^ SourceUniqueId {
    String^ get ();
    void set (String^ value);
}
member SourceUniqueId : string with get, set

Property Value

Type: String
The unique identifier of the source server.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.Statistics Property

JobInfoPrivateModelStatistics Property
Gets or sets the current statistics of the job

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public JobStatisticsModel Statistics { get; set; }
Public Property Statistics As JobStatisticsModel
    Get
    Set
public:
property JobStatisticsModel^ Statistics {
    JobStatisticsModel^ get ();
    void set (JobStatisticsModel^ value);
}
member Statistics : JobStatisticsModel with get, set

Property Value

Type: JobStatisticsModel
A JobStatistics that represents the current statistics of this job.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.Status Property

JobInfoPrivateModelStatus Property
Gets or sets the current state of the job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public JobStatusModel Status { get; set; }
Public Property Status As JobStatusModel
    Get
    Set
public:
property JobStatusModel^ Status {
    JobStatusModel^ get ();
    void set (JobStatusModel^ value);
}
member Status : JobStatusModel with get, set

Property Value

Type: JobStatusModel
A JobStatus that represents the current status of this job.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.TargetHostUri Property

JobInfoPrivateModelTargetHostUri Property
Gets or sets the target URI.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Uri TargetHostUri { get; set; }
Public Property TargetHostUri As Uri
    Get
    Set
public:
property Uri^ TargetHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
member TargetHostUri : Uri with get, set

Property Value

Type: Uri
The target URI.
Remarks
This property serves as a replacement for the TargetNetworkId and TargetManagementPort properties because both of these pieces of information can be provided in and extracted from the URI.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel.TargetUniqueId Property

JobInfoPrivateModelTargetUniqueId Property
Gets or sets the unique ID of the target server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string TargetUniqueId { get; set; }
Public Property TargetUniqueId As String
    Get
    Set
public:
property String^ TargetUniqueId {
    String^ get ();
    void set (String^ value);
}
member TargetUniqueId : string with get, set

Property Value

Type: String
The unique identifier of the target server.
See Also

Reference

JobInfoPrivateModel Class


JobInfoPrivateModel Methods

JobInfoPrivateModel Methods

The JobInfoPrivateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobInfoPrivateModel Class


JobOptionsModel Class

JobOptionsModel Class
Job options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsJobOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class JobOptionsModel
Public NotInheritable Class JobOptionsModel
public ref class JobOptionsModel sealed
[<SealedAttribute>]
type JobOptionsModel =  class end

The JobOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | JobOptionsModel | Initializes a new instance of the JobOptionsModel class
Top
Properties
 | Name | Description
Public property | ApplicationOptions | Gets or sets the options for application-specific protection jobs.
Public property | BandwidthOptions | Gets or sets the options for bandwidth limiting.
Public property | CloudOptions | Gets or sets the options for cloud jobs.
Public property | ClusterOptions | Gets or sets the cluster options.
Public property | CoreConnectionOptions | Gets or sets the core connection options.
Public property | CoreMonitorOptions | Gets or sets the core monitor options.
Public property | DnsOptions | Gets or sets the DNS options.
Public property | FailoverMonitoringEnabled | Gets or sets a value indicating whether or not failover monitoring is enabled.
Public property | FullServerFailoverOptions | Gets or sets the options for full server failover jobs.
Public property | FullServerTestFailoverOptions | This value represents the testfailover options for full server jobs.
Public property | ImageProtectionOptions | Gets or sets the options for image protection jobs.
Public property | ImageRecoveryOptions | Gets or sets the options for image recovery jobs.
Public property | ManagementServiceTargetPort | Gets or sets the port used by ManagementService.
Public property | MonitoringOptions | Gets or sets the monitoring options.
Public property | Name | Gets or sets the name of this job.
Public property | SimpleFailoverMonitorOptions | Gets or sets the options for failover monitoring without using IP address.
Public property | SystemStateOptions | Gets or sets the system state options.
Public property | TargetServicesOptions | Gets or sets target service options.
Public property | UnmanagedConnectionOptions | Gets or sets the options for jobs that use an unmanaged connection.
Public property | VcdVappOptions | Gets or sets new DTAV (Linux).
Public property | VraOptions | Gets or sets the options for jobs that use Virtual Recovery Assistant.
Public property | Workload | Gets or sets the workload to be protected by this job.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


JobOptionsModel Constructor

JobOptionsModel Constructor
Initializes a new instance of the JobOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public JobOptionsModel()
Public Sub New
public:
JobOptionsModel()
new : unit -> JobOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel Properties

JobOptionsModel Properties

The JobOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationOptions | Gets or sets the options for application-specific protection jobs.
Public property | BandwidthOptions | Gets or sets the options for bandwidth limiting.
Public property | CloudOptions | Gets or sets the options for cloud jobs.
Public property | ClusterOptions | Gets or sets the cluster options.
Public property | CoreConnectionOptions | Gets or sets the core connection options.
Public property | CoreMonitorOptions | Gets or sets the core monitor options.
Public property | DnsOptions | Gets or sets the DNS options.
Public property | FailoverMonitoringEnabled | Gets or sets a value indicating whether or not failover monitoring is enabled.
Public property | FullServerFailoverOptions | Gets or sets the options for full server failover jobs.
Public property | FullServerTestFailoverOptions | This value represents the testfailover options for full server jobs.
Public property | ImageProtectionOptions | Gets or sets the options for image protection jobs.
Public property | ImageRecoveryOptions | Gets or sets the options for image recovery jobs.
Public property | ManagementServiceTargetPort | Gets or sets the port used by ManagementService.
Public property | MonitoringOptions | Gets or sets the monitoring options.
Public property | Name | Gets or sets the name of this job.
Public property | SimpleFailoverMonitorOptions | Gets or sets the options for failover monitoring without using IP address.
Public property | SystemStateOptions | Gets or sets the system state options.
Public property | TargetServicesOptions | Gets or sets target service options.
Public property | UnmanagedConnectionOptions | Gets or sets the options for jobs that use an unmanaged connection.
Public property | VcdVappOptions | Gets or sets new DTAV (Linux).
Public property | VraOptions | Gets or sets the options for jobs that use Virtual Recovery Assistant.
Public property | Workload | Gets or sets the workload to be protected by this job.
Top
See Also

Reference

JobOptionsModel Class


JobOptionsModel.ApplicationOptions Property

JobOptionsModelApplicationOptions Property
Gets or sets the options for application-specific protection jobs.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ApplicationOptionsModel ApplicationOptions { get; set; }
Public Property ApplicationOptions As ApplicationOptionsModel
    Get
    Set
public:
property ApplicationOptionsModel^ ApplicationOptions {
    ApplicationOptionsModel^ get ();
    void set (ApplicationOptionsModel^ value);
}
member ApplicationOptions : ApplicationOptionsModel with get, set

Property Value

Type: ApplicationOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.BandwidthOptions Property

JobOptionsModelBandwidthOptions Property
Gets or sets the options for bandwidth limiting.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public BandwidthOptionsModel BandwidthOptions { get; set; }
Public Property BandwidthOptions As BandwidthOptionsModel
    Get
    Set
public:
property BandwidthOptionsModel^ BandwidthOptions {
    BandwidthOptionsModel^ get ();
    void set (BandwidthOptionsModel^ value);
}
member BandwidthOptions : BandwidthOptionsModel with get, set

Property Value

Type: BandwidthOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.CloudOptions Property

JobOptionsModelCloudOptions Property
Gets or sets the options for cloud jobs.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CloudOptionsModel CloudOptions { get; set; }
Public Property CloudOptions As CloudOptionsModel
    Get
    Set
public:
property CloudOptionsModel^ CloudOptions {
    CloudOptionsModel^ get ();
    void set (CloudOptionsModel^ value);
}
member CloudOptions : CloudOptionsModel with get, set

Property Value

Type: CloudOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.ClusterOptions Property

JobOptionsModelClusterOptions Property
Gets or sets the cluster options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ClusterOptionsModel ClusterOptions { get; set; }
Public Property ClusterOptions As ClusterOptionsModel
    Get
    Set
public:
property ClusterOptionsModel^ ClusterOptions {
    ClusterOptionsModel^ get ();
    void set (ClusterOptionsModel^ value);
}
member ClusterOptions : ClusterOptionsModel with get, set

Property Value

Type: ClusterOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.CoreConnectionOptions Property

JobOptionsModelCoreConnectionOptions Property
Gets or sets the core connection options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionOptionsModel CoreConnectionOptions { get; set; }
Public Property CoreConnectionOptions As CoreConnectionOptionsModel
    Get
    Set
public:
property CoreConnectionOptionsModel^ CoreConnectionOptions {
    CoreConnectionOptionsModel^ get ();
    void set (CoreConnectionOptionsModel^ value);
}
member CoreConnectionOptions : CoreConnectionOptionsModel with get, set

Property Value

Type: CoreConnectionOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.CoreMonitorOptions Property

JobOptionsModelCoreMonitorOptions Property
Gets or sets the core monitor options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CoreMonitorOptionsModel CoreMonitorOptions { get; set; }
Public Property CoreMonitorOptions As CoreMonitorOptionsModel
    Get
    Set
public:
property CoreMonitorOptionsModel^ CoreMonitorOptions {
    CoreMonitorOptionsModel^ get ();
    void set (CoreMonitorOptionsModel^ value);
}
member CoreMonitorOptions : CoreMonitorOptionsModel with get, set

Property Value

Type: CoreMonitorOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.DnsOptions Property

JobOptionsModelDnsOptions Property
Gets or sets the DNS options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DnsOptionsModel DnsOptions { get; set; }
Public Property DnsOptions As DnsOptionsModel
    Get
    Set
public:
property DnsOptionsModel^ DnsOptions {
    DnsOptionsModel^ get ();
    void set (DnsOptionsModel^ value);
}
member DnsOptions : DnsOptionsModel with get, set

Property Value

Type: DnsOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.FailoverMonitoringEnabled Property

JobOptionsModelFailoverMonitoringEnabled Property
Gets or sets a value indicating whether or not failover monitoring is enabled.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> FailoverMonitoringEnabled { get; set; }
Public Property FailoverMonitoringEnabled As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> FailoverMonitoringEnabled {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member FailoverMonitoringEnabled : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

JobOptionsModel Class


JobOptionsModel.FullServerFailoverOptions Property

JobOptionsModelFullServerFailoverOptions Property
Gets or sets the options for full server failover jobs.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FullServerFailoverOptionsModel FullServerFailoverOptions { get; set; }
Public Property FullServerFailoverOptions As FullServerFailoverOptionsModel
    Get
    Set
public:
property FullServerFailoverOptionsModel^ FullServerFailoverOptions {
    FullServerFailoverOptionsModel^ get ();
    void set (FullServerFailoverOptionsModel^ value);
}
member FullServerFailoverOptions : FullServerFailoverOptionsModel with get, set

Property Value

Type: FullServerFailoverOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.FullServerTestFailoverOptions Property

JobOptionsModelFullServerTestFailoverOptions Property
This value represents the testfailover options for full server jobs.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FullServerTestFailoverOptionsModel FullServerTestFailoverOptions { get; set; }
Public Property FullServerTestFailoverOptions As FullServerTestFailoverOptionsModel
    Get
    Set
public:
property FullServerTestFailoverOptionsModel^ FullServerTestFailoverOptions {
    FullServerTestFailoverOptionsModel^ get ();
    void set (FullServerTestFailoverOptionsModel^ value);
}
member FullServerTestFailoverOptions : FullServerTestFailoverOptionsModel with get, set

Property Value

Type: FullServerTestFailoverOptionsModel
The testfailover options for full server failover jobs.
See Also

Reference

JobOptionsModel Class


JobOptionsModel.ImageProtectionOptions Property

JobOptionsModelImageProtectionOptions Property
Gets or sets the options for image protection jobs.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ImageProtectionOptionsModel ImageProtectionOptions { get; set; }
Public Property ImageProtectionOptions As ImageProtectionOptionsModel
    Get
    Set
public:
property ImageProtectionOptionsModel^ ImageProtectionOptions {
    ImageProtectionOptionsModel^ get ();
    void set (ImageProtectionOptionsModel^ value);
}
member ImageProtectionOptions : ImageProtectionOptionsModel with get, set

Property Value

Type: ImageProtectionOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.ImageRecoveryOptions Property

JobOptionsModelImageRecoveryOptions Property
Gets or sets the options for image recovery jobs.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ImageRecoveryOptionsModel ImageRecoveryOptions { get; set; }
Public Property ImageRecoveryOptions As ImageRecoveryOptionsModel
    Get
    Set
public:
property ImageRecoveryOptionsModel^ ImageRecoveryOptions {
    ImageRecoveryOptionsModel^ get ();
    void set (ImageRecoveryOptionsModel^ value);
}
member ImageRecoveryOptions : ImageRecoveryOptionsModel with get, set

Property Value

Type: ImageRecoveryOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.ManagementServiceTargetPort Property

JobOptionsModelManagementServiceTargetPort Property
Gets or sets the port used by ManagementService.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> ManagementServiceTargetPort { get; set; }
Public Property ManagementServiceTargetPort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> ManagementServiceTargetPort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member ManagementServiceTargetPort : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

JobOptionsModel Class


JobOptionsModel.MonitoringOptions Property

JobOptionsModelMonitoringOptions Property
Gets or sets the monitoring options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public MonitoringOptionsModel MonitoringOptions { get; set; }
Public Property MonitoringOptions As MonitoringOptionsModel
    Get
    Set
public:
property MonitoringOptionsModel^ MonitoringOptions {
    MonitoringOptionsModel^ get ();
    void set (MonitoringOptionsModel^ value);
}
member MonitoringOptions : MonitoringOptionsModel with get, set

Property Value

Type: MonitoringOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.Name Property

JobOptionsModelName Property
Gets or sets the name of this job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

JobOptionsModel Class


JobOptionsModel.SimpleFailoverMonitorOptions Property

JobOptionsModelSimpleFailoverMonitorOptions Property
Gets or sets the options for failover monitoring without using IP address.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public SimpleFailoverMonitorOptionsModel SimpleFailoverMonitorOptions { get; set; }
Public Property SimpleFailoverMonitorOptions As SimpleFailoverMonitorOptionsModel
    Get
    Set
public:
property SimpleFailoverMonitorOptionsModel^ SimpleFailoverMonitorOptions {
    SimpleFailoverMonitorOptionsModel^ get ();
    void set (SimpleFailoverMonitorOptionsModel^ value);
}
member SimpleFailoverMonitorOptions : SimpleFailoverMonitorOptionsModel with get, set

Property Value

Type: SimpleFailoverMonitorOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.SystemStateOptions Property

JobOptionsModelSystemStateOptions Property
Gets or sets the system state options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public SystemStateOptionsModel SystemStateOptions { get; set; }
Public Property SystemStateOptions As SystemStateOptionsModel
    Get
    Set
public:
property SystemStateOptionsModel^ SystemStateOptions {
    SystemStateOptionsModel^ get ();
    void set (SystemStateOptionsModel^ value);
}
member SystemStateOptions : SystemStateOptionsModel with get, set

Property Value

Type: SystemStateOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.TargetServicesOptions Property

JobOptionsModelTargetServicesOptions Property
Gets or sets target service options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TargetServicesOptionsModel TargetServicesOptions { get; set; }
Public Property TargetServicesOptions As TargetServicesOptionsModel
    Get
    Set
public:
property TargetServicesOptionsModel^ TargetServicesOptions {
    TargetServicesOptionsModel^ get ();
    void set (TargetServicesOptionsModel^ value);
}
member TargetServicesOptions : TargetServicesOptionsModel with get, set

Property Value

Type: TargetServicesOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.UnmanagedConnectionOptions Property

JobOptionsModelUnmanagedConnectionOptions Property
Gets or sets the options for jobs that use an unmanaged connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public UnmanagedConnectionOptionsModel UnmanagedConnectionOptions { get; set; }
Public Property UnmanagedConnectionOptions As UnmanagedConnectionOptionsModel
    Get
    Set
public:
property UnmanagedConnectionOptionsModel^ UnmanagedConnectionOptions {
    UnmanagedConnectionOptionsModel^ get ();
    void set (UnmanagedConnectionOptionsModel^ value);
}
member UnmanagedConnectionOptions : UnmanagedConnectionOptionsModel with get, set

Property Value

Type: UnmanagedConnectionOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.VcdVappOptions Property

JobOptionsModelVcdVappOptions Property
Gets or sets new DTAV (Linux).

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VcdVappOptionsModel VcdVappOptions { get; set; }
Public Property VcdVappOptions As VcdVappOptionsModel
    Get
    Set
public:
property VcdVappOptionsModel^ VcdVappOptions {
    VcdVappOptionsModel^ get ();
    void set (VcdVappOptionsModel^ value);
}
member VcdVappOptions : VcdVappOptionsModel with get, set

Property Value

Type: VcdVappOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.VraOptions Property

JobOptionsModelVraOptions Property
Gets or sets the options for jobs that use Virtual Recovery Assistant.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VraOptionsModel VraOptions { get; set; }
Public Property VraOptions As VraOptionsModel
    Get
    Set
public:
property VraOptionsModel^ VraOptions {
    VraOptionsModel^ get ();
    void set (VraOptionsModel^ value);
}
member VraOptions : VraOptionsModel with get, set

Property Value

Type: VraOptionsModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel.Workload Property

JobOptionsModelWorkload Property
Gets or sets the workload to be protected by this job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public WorkloadModel Workload { get; set; }
Public Property Workload As WorkloadModel
    Get
    Set
public:
property WorkloadModel^ Workload {
    WorkloadModel^ get ();
    void set (WorkloadModel^ value);
}
member Workload : WorkloadModel with get, set

Property Value

Type: WorkloadModel
See Also

Reference

JobOptionsModel Class


JobOptionsModel Methods

JobOptionsModel Methods

The JobOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobOptionsModel Class


JobParametersModel Class

JobParametersModel Class
Job parameters.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsJobParametersModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class JobParametersModel
Public NotInheritable Class JobParametersModel
public ref class JobParametersModel sealed
[<SealedAttribute>]
type JobParametersModel =  class end

The JobParametersModel type exposes the following members.

Constructors
 | Name | Description
Public method | JobParametersModel | Initializes a new instance of the JobParametersModel class
Top
Properties
 | Name | Description
Public property | ConnectionStartParameters | Gets or sets the connection start parameters.
Public property | EngineJobType | Gets or sets the engine job type.
Public property | JobType | Gets or sets the the job type.
Public property | Monitor | Gets or sets the configuration of a monitor that is to be utilized for this job if it is to be an Availability job.
Public property | PathTransformations | Gets or sets the path transformations. These tell the service where on the target to mirror and replicate the data from where on the source. There must be at least one PathTransformationModel for each volume referenced in the workload rules.
Public property | Properties | Gets or sets the properties.
Public property | SourceAddresses | Gets or sets the source addresses.
Public property | TargetAddress | Gets or sets the target address over which the data will be mirrored and replicated from the source.
Public property | WorkloadRules | Gets or sets the workload rules. These rules define what data will be mirrored and replicated by this job.
Public property | WorkloadType | Gets or sets the type of workload to create. See Create
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


JobParametersModel Constructor

JobParametersModel Constructor
Initializes a new instance of the JobParametersModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public JobParametersModel()
Public Sub New
public:
JobParametersModel()
new : unit -> JobParametersModel
See Also

Reference

JobParametersModel Class


JobParametersModel Properties

JobParametersModel Properties

The JobParametersModel type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionStartParameters | Gets or sets the connection start parameters.
Public property | EngineJobType | Gets or sets the engine job type.
Public property | JobType | Gets or sets the the job type.
Public property | Monitor | Gets or sets the configuration of a monitor that is to be utilized for this job if it is to be an Availability job.
Public property | PathTransformations | Gets or sets the path transformations. These tell the service where on the target to mirror and replicate the data from where on the source. There must be at least one PathTransformationModel for each volume referenced in the workload rules.
Public property | Properties | Gets or sets the properties.
Public property | SourceAddresses | Gets or sets the source addresses.
Public property | TargetAddress | Gets or sets the target address over which the data will be mirrored and replicated from the source.
Public property | WorkloadRules | Gets or sets the workload rules. These rules define what data will be mirrored and replicated by this job.
Public property | WorkloadType | Gets or sets the type of workload to create. See Create
Top
See Also

Reference

JobParametersModel Class


JobParametersModel.ConnectionStartParameters Property

JobParametersModelConnectionStartParameters Property
Gets or sets the connection start parameters.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ConnectionStartParametersModel ConnectionStartParameters { get; set; }
Public Property ConnectionStartParameters As ConnectionStartParametersModel
    Get
    Set
public:
property ConnectionStartParametersModel^ ConnectionStartParameters {
    ConnectionStartParametersModel^ get ();
    void set (ConnectionStartParametersModel^ value);
}
member ConnectionStartParameters : ConnectionStartParametersModel with get, set

Property Value

Type: ConnectionStartParametersModel
The connection start parameters.
See Also

Reference

JobParametersModel Class


JobParametersModel.EngineJobType Property

JobParametersModelEngineJobType Property
Gets or sets the engine job type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public EngineJobType EngineJobType { get; set; }
Public Property EngineJobType As EngineJobType
    Get
    Set
public:
property EngineJobType EngineJobType {
    EngineJobType get ();
    void set (EngineJobType value);
}
member EngineJobType : EngineJobType with get, set

Property Value

Type: EngineJobType
The engine job type.
See Also

Reference

JobParametersModel Class


JobParametersModel.JobType Property

JobParametersModelJobType Property
Gets or sets the the job type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string JobType { get; set; }
Public Property JobType As String
    Get
    Set
public:
property String^ JobType {
    String^ get ();
    void set (String^ value);
}
member JobType : string with get, set

Property Value

Type: String
The the job type.
See Also

Reference

JobParametersModel Class


JobParametersModel.Monitor Property

JobParametersModelMonitor Property
Gets or sets the configuration of a monitor that is to be utilized for this job if it is to be an Availability job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public MonitorConfigurationModel Monitor { get; set; }
Public Property Monitor As MonitorConfigurationModel
    Get
    Set
public:
property MonitorConfigurationModel^ Monitor {
    MonitorConfigurationModel^ get ();
    void set (MonitorConfigurationModel^ value);
}
member Monitor : MonitorConfigurationModel with get, set

Property Value

Type: MonitorConfigurationModel
See Also

Reference

JobParametersModel Class


JobParametersModel.PathTransformations Property

JobParametersModelPathTransformations Property
Gets or sets the path transformations. These tell the service where on the target to mirror and replicate the data from where on the source. There must be at least one PathTransformationModel for each volume referenced in the workload rules.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public PathTransformationModel[] PathTransformations { get; set; }
Public Property PathTransformations As PathTransformationModel()
    Get
    Set
public:
property array<PathTransformationModel^>^ PathTransformations {
    array<PathTransformationModel^>^ get ();
    void set (array<PathTransformationModel^>^ value);
}
member PathTransformations : PathTransformationModel[] with get, set

Property Value

Type: PathTransformationModel
The path transformations.
See Also

Reference

JobParametersModel Class


JobParametersModel.Properties Property

JobParametersModelProperties Property
Gets or sets the properties.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public PropertyModel[] Properties { get; set; }
Public Property Properties As PropertyModel()
    Get
    Set
public:
property array<PropertyModel^>^ Properties {
    array<PropertyModel^>^ get ();
    void set (array<PropertyModel^>^ value);
}
member Properties : PropertyModel[] with get, set

Property Value

Type: PropertyModel
See Also

Reference

JobParametersModel Class


JobParametersModel.SourceAddresses Property

JobParametersModelSourceAddresses Property
Gets or sets the source addresses.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public UnicastIPAddressModel[] SourceAddresses { get; set; }
Public Property SourceAddresses As UnicastIPAddressModel()
    Get
    Set
public:
property array<UnicastIPAddressModel^>^ SourceAddresses {
    array<UnicastIPAddressModel^>^ get ();
    void set (array<UnicastIPAddressModel^>^ value);
}
member SourceAddresses : UnicastIPAddressModel[] with get, set

Property Value

Type: UnicastIPAddressModel
The source addresses.
Remarks
These addresses are used by the Management Service on the job host to communicate with the source. If there is a NAT firewall in between the source and the target
See Also

Reference

JobParametersModel Class


JobParametersModel.TargetAddress Property

JobParametersModelTargetAddress Property
Gets or sets the target address over which the data will be mirrored and replicated from the source.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public UnicastIPAddressModel TargetAddress { get; set; }
Public Property TargetAddress As UnicastIPAddressModel
    Get
    Set
public:
property UnicastIPAddressModel^ TargetAddress {
    UnicastIPAddressModel^ get ();
    void set (UnicastIPAddressModel^ value);
}
member TargetAddress : UnicastIPAddressModel with get, set

Property Value

Type: UnicastIPAddressModel
The target address.
See Also

Reference

JobParametersModel Class


JobParametersModel.WorkloadRules Property

JobParametersModelWorkloadRules Property
Gets or sets the workload rules. These rules define what data will be mirrored and replicated by this job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public PhysicalRuleModel[] WorkloadRules { get; set; }
Public Property WorkloadRules As PhysicalRuleModel()
    Get
    Set
public:
property array<PhysicalRuleModel^>^ WorkloadRules {
    array<PhysicalRuleModel^>^ get ();
    void set (array<PhysicalRuleModel^>^ value);
}
member WorkloadRules : PhysicalRuleModel[] with get, set

Property Value

Type: PhysicalRuleModel
The workload rules.
See Also

Reference

JobParametersModel Class


JobParametersModel.WorkloadType Property

JobParametersModelWorkloadType Property
Gets or sets the type of workload to create. See Create

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string WorkloadType { get; set; }
Public Property WorkloadType As String
    Get
    Set
public:
property String^ WorkloadType {
    String^ get ();
    void set (String^ value);
}
member WorkloadType : string with get, set

Property Value

Type: String
See Also

Reference

JobParametersModel Class
DoubleTake.Web.Models Namespace
ICoreWorkload.Create


JobParametersModel Methods

JobParametersModel Methods

The JobParametersModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobParametersModel Class


JobQualificationResultsModel Class

JobQualificationResultsModel Class
Job qualification results model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsJobQualificationResultsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class JobQualificationResultsModel
Public NotInheritable Class JobQualificationResultsModel
public ref class JobQualificationResultsModel sealed
[<SealedAttribute>]
type JobQualificationResultsModel =  class end

The JobQualificationResultsModel type exposes the following members.

Constructors
 | Name | Description
Public method | JobQualificationResultsModel | Initializes a new instance of the JobQualificationResultsModel class
Top
Properties
 | Name | Description
Public property | ClusterFilesAndFoldersQualificationResults | Gets or sets the cluster files and folders qualification results.
Public property | CoreQualificationResults | Gets or sets the possible options that apply to engine connection and monitor.
Public property | SourceBehindNat | Gets or sets a value indicating whether the source is behind a NAT firewall.
Public property | SourceHostUri | Gets or sets the source host URI.
Public property | SupportsFrameworkMonitoring | Gets or sets a value indicating whether the machine supports framework monitoring.
Public property | SuppressFailoverMonitorOptions | Gets or sets a value indicating whether to suppress failover monitor options.
Public property | VcdVappQualificationResults | Gets or sets the possible options that apply to new DTVI job.
Public property | VraQualificationResults | Gets or sets the possible options that apply to VRA job.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


JobQualificationResultsModel Constructor

JobQualificationResultsModel Constructor
Initializes a new instance of the JobQualificationResultsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public JobQualificationResultsModel()
Public Sub New
public:
JobQualificationResultsModel()
new : unit -> JobQualificationResultsModel
See Also

Reference

JobQualificationResultsModel Class


JobQualificationResultsModel Properties

JobQualificationResultsModel Properties

The JobQualificationResultsModel type exposes the following members.

Properties
 | Name | Description
Public property | ClusterFilesAndFoldersQualificationResults | Gets or sets the cluster files and folders qualification results.
Public property | CoreQualificationResults | Gets or sets the possible options that apply to engine connection and monitor.
Public property | SourceBehindNat | Gets or sets a value indicating whether the source is behind a NAT firewall.
Public property | SourceHostUri | Gets or sets the source host URI.
Public property | SupportsFrameworkMonitoring | Gets or sets a value indicating whether the machine supports framework monitoring.
Public property | SuppressFailoverMonitorOptions | Gets or sets a value indicating whether to suppress failover monitor options.
Public property | VcdVappQualificationResults | Gets or sets the possible options that apply to new DTVI job.
Public property | VraQualificationResults | Gets or sets the possible options that apply to VRA job.
Top
See Also

Reference

JobQualificationResultsModel Class


JobQualificationResultsModel.ClusterFilesAndFoldersQualificationResults Property

JobQualificationResultsModelClusterFilesAndFoldersQualificationResults Property
Gets or sets the cluster files and folders qualification results.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ClusterFilesAndFoldersQualificationResultsModel ClusterFilesAndFoldersQualificationResults { get; set; }
Public Property ClusterFilesAndFoldersQualificationResults As ClusterFilesAndFoldersQualificationResultsModel
    Get
    Set
public:
property ClusterFilesAndFoldersQualificationResultsModel^ ClusterFilesAndFoldersQualificationResults {
    ClusterFilesAndFoldersQualificationResultsModel^ get ();
    void set (ClusterFilesAndFoldersQualificationResultsModel^ value);
}
member ClusterFilesAndFoldersQualificationResults : ClusterFilesAndFoldersQualificationResultsModel with get, set

Property Value

Type: ClusterFilesAndFoldersQualificationResultsModel
See Also

Reference

JobQualificationResultsModel Class


JobQualificationResultsModel.CoreQualificationResults Property

JobQualificationResultsModelCoreQualificationResults Property
Gets or sets the possible options that apply to engine connection and monitor.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CoreQualificationResultsModel CoreQualificationResults { get; set; }
Public Property CoreQualificationResults As CoreQualificationResultsModel
    Get
    Set
public:
property CoreQualificationResultsModel^ CoreQualificationResults {
    CoreQualificationResultsModel^ get ();
    void set (CoreQualificationResultsModel^ value);
}
member CoreQualificationResults : CoreQualificationResultsModel with get, set

Property Value

Type: CoreQualificationResultsModel
See Also

Reference

JobQualificationResultsModel Class


JobQualificationResultsModel.SourceBehindNat Property

JobQualificationResultsModelSourceBehindNat Property
Gets or sets a value indicating whether the source is behind a NAT firewall.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool SourceBehindNat { get; set; }
Public Property SourceBehindNat As Boolean
    Get
    Set
public:
property bool SourceBehindNat {
    bool get ();
    void set (bool value);
}
member SourceBehindNat : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobQualificationResultsModel Class


JobQualificationResultsModel.SourceHostUri Property

JobQualificationResultsModelSourceHostUri Property
Gets or sets the source host URI.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Uri SourceHostUri { get; set; }
Public Property SourceHostUri As Uri
    Get
    Set
public:
property Uri^ SourceHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
member SourceHostUri : Uri with get, set

Property Value

Type: Uri
See Also

Reference

JobQualificationResultsModel Class


JobQualificationResultsModel.SupportsFrameworkMonitoring Property

JobQualificationResultsModelSupportsFrameworkMonitoring Property
Gets or sets a value indicating whether the machine supports framework monitoring.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool SupportsFrameworkMonitoring { get; set; }
Public Property SupportsFrameworkMonitoring As Boolean
    Get
    Set
public:
property bool SupportsFrameworkMonitoring {
    bool get ();
    void set (bool value);
}
member SupportsFrameworkMonitoring : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobQualificationResultsModel Class


JobQualificationResultsModel.SuppressFailoverMonitorOptions Property

JobQualificationResultsModelSuppressFailoverMonitorOptions Property
Gets or sets a value indicating whether to suppress failover monitor options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool SuppressFailoverMonitorOptions { get; set; }
Public Property SuppressFailoverMonitorOptions As Boolean
    Get
    Set
public:
property bool SuppressFailoverMonitorOptions {
    bool get ();
    void set (bool value);
}
member SuppressFailoverMonitorOptions : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobQualificationResultsModel Class


JobQualificationResultsModel.VcdVappQualificationResults Property

JobQualificationResultsModelVcdVappQualificationResults Property
Gets or sets the possible options that apply to new DTVI job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VcdVappOptionsModel VcdVappQualificationResults { get; set; }
Public Property VcdVappQualificationResults As VcdVappOptionsModel
    Get
    Set
public:
property VcdVappOptionsModel^ VcdVappQualificationResults {
    VcdVappOptionsModel^ get ();
    void set (VcdVappOptionsModel^ value);
}
member VcdVappQualificationResults : VcdVappOptionsModel with get, set

Property Value

Type: VcdVappOptionsModel
See Also

Reference

JobQualificationResultsModel Class


JobQualificationResultsModel.VraQualificationResults Property

JobQualificationResultsModelVraQualificationResults Property
Gets or sets the possible options that apply to VRA job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VraQualificationResultsModel VraQualificationResults { get; set; }
Public Property VraQualificationResults As VraQualificationResultsModel
    Get
    Set
public:
property VraQualificationResultsModel^ VraQualificationResults {
    VraQualificationResultsModel^ get ();
    void set (VraQualificationResultsModel^ value);
}
member VraQualificationResults : VraQualificationResultsModel with get, set

Property Value

Type: VraQualificationResultsModel
See Also

Reference

JobQualificationResultsModel Class


JobQualificationResultsModel Methods

JobQualificationResultsModel Methods

The JobQualificationResultsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobQualificationResultsModel Class


JobStateModel Class

JobStateModel Class
Represents job state information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsJobStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class JobStateModel
Public NotInheritable Class JobStateModel
public ref class JobStateModel sealed
[<SealedAttribute>]
type JobStateModel =  class end

The JobStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | JobStateModel | Initializes a new instance of the JobStateModel class
Top
Properties
 | Name | Description
Public property | HasError | Gets or sets a value indicating whether the job has an error.
Public property | HighLevel | Gets or sets the high level state.
Public property | IsInSync | Gets or sets a value indicating whether the job is already in sync
Public property | LowLevel | Gets or sets a value of low level state
Public property | RecentErrors | Gets or sets a value of list of recent errors
Public property | SourceActivationCodeMessages | Gets or sets the activation code messages.
Public property | TargetActivationCodeMessages | Gets or sets the activation code messages.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


JobStateModel Constructor

JobStateModel Constructor
Initializes a new instance of the JobStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public JobStateModel()
Public Sub New
public:
JobStateModel()
new : unit -> JobStateModel
See Also

Reference

JobStateModel Class


JobStateModel Properties

JobStateModel Properties

The JobStateModel type exposes the following members.

Properties
 | Name | Description
Public property | HasError | Gets or sets a value indicating whether the job has an error.
Public property | HighLevel | Gets or sets the high level state.
Public property | IsInSync | Gets or sets a value indicating whether the job is already in sync
Public property | LowLevel | Gets or sets a value of low level state
Public property | RecentErrors | Gets or sets a value of list of recent errors
Public property | SourceActivationCodeMessages | Gets or sets the activation code messages.
Public property | TargetActivationCodeMessages | Gets or sets the activation code messages.
Top
See Also

Reference

JobStateModel Class


JobStateModel.HasError Property

JobStateModelHasError Property
Gets or sets a value indicating whether the job has an error.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool HasError { get; set; }
Public Property HasError As Boolean
    Get
    Set
public:
property bool HasError {
    bool get ();
    void set (bool value);
}
member HasError : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStateModel Class


JobStateModel.HighLevel Property

JobStateModelHighLevel Property
Gets or sets the high level state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string HighLevel { get; set; }
Public Property HighLevel As String
    Get
    Set
public:
property String^ HighLevel {
    String^ get ();
    void set (String^ value);
}
member HighLevel : string with get, set

Property Value

Type: String
The high level state.
See Also

Reference

JobStateModel Class


JobStateModel.IsInSync Property

JobStateModelIsInSync Property
Gets or sets a value indicating whether the job is already in sync

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsInSync { get; set; }
Public Property IsInSync As Boolean
    Get
    Set
public:
property bool IsInSync {
    bool get ();
    void set (bool value);
}
member IsInSync : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStateModel Class


JobStateModel.LowLevel Property

JobStateModelLowLevel Property
Gets or sets a value of low level state

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string LowLevel { get; set; }
Public Property LowLevel As String
    Get
    Set
public:
property String^ LowLevel {
    String^ get ();
    void set (String^ value);
}
member LowLevel : string with get, set

Property Value

Type: String
See Also

Reference

JobStateModel Class


JobStateModel.RecentErrors Property

JobStateModelRecentErrors Property
Gets or sets a value of list of recent errors

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public List<ErrorInfoModel> RecentErrors { get; set; }
Public Property RecentErrors As List(Of ErrorInfoModel)
    Get
    Set
public:
property List<ErrorInfoModel^>^ RecentErrors {
    List<ErrorInfoModel^>^ get ();
    void set (List<ErrorInfoModel^>^ value);
}
member RecentErrors : List<ErrorInfoModel> with get, set

Property Value

Type: List ErrorInfoModel
See Also

Reference

JobStateModel Class


JobStateModel.SourceActivationCodeMessages Property

JobStateModelSourceActivationCodeMessages Property
Gets or sets the activation code messages.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ExtendedLowLevelStateModel[] SourceActivationCodeMessages { get; set; }
Public Property SourceActivationCodeMessages As ExtendedLowLevelStateModel()
    Get
    Set
public:
property array<ExtendedLowLevelStateModel^>^ SourceActivationCodeMessages {
    array<ExtendedLowLevelStateModel^>^ get ();
    void set (array<ExtendedLowLevelStateModel^>^ value);
}
member SourceActivationCodeMessages : ExtendedLowLevelStateModel[] with get, set

Property Value

Type: ExtendedLowLevelStateModel
The activation code messages.
See Also

Reference

JobStateModel Class


JobStateModel.TargetActivationCodeMessages Property

JobStateModelTargetActivationCodeMessages Property
Gets or sets the activation code messages.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ExtendedLowLevelStateModel[] TargetActivationCodeMessages { get; set; }
Public Property TargetActivationCodeMessages As ExtendedLowLevelStateModel()
    Get
    Set
public:
property array<ExtendedLowLevelStateModel^>^ TargetActivationCodeMessages {
    array<ExtendedLowLevelStateModel^>^ get ();
    void set (array<ExtendedLowLevelStateModel^>^ value);
}
member TargetActivationCodeMessages : ExtendedLowLevelStateModel[] with get, set

Property Value

Type: ExtendedLowLevelStateModel
The activation code messages.
See Also

Reference

JobStateModel Class


JobStateModel Methods

JobStateModel Methods

The JobStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobStateModel Class


JobStatisticsModel Class

JobStatisticsModel Class
Job statistics model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsJobStatisticsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class JobStatisticsModel
Public NotInheritable Class JobStatisticsModel
public ref class JobStatisticsModel sealed
[<SealedAttribute>]
type JobStatisticsModel =  class end

The JobStatisticsModel type exposes the following members.

Constructors
 | Name | Description
Public method | JobStatisticsModel | Initializes a new instance of the JobStatisticsModel class
Top
Properties
 | Name | Description
Public property | CoreConnectionDetails | Gets or sets the core connection details.
Public property | CoreMonitorDetails | Gets or sets the core monitor details.
Public property | FullServerJobDetails | Gets or sets the full server job details.
Public property | ImageProtectionJobDetails | Gets or sets the image protection job details.
Public property | ImageRecoveryJobDetails | Gets or sets the image recovery job details.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


JobStatisticsModel Constructor

JobStatisticsModel Constructor
Initializes a new instance of the JobStatisticsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public JobStatisticsModel()
Public Sub New
public:
JobStatisticsModel()
new : unit -> JobStatisticsModel
See Also

Reference

JobStatisticsModel Class


JobStatisticsModel Properties

JobStatisticsModel Properties

The JobStatisticsModel type exposes the following members.

Properties
 | Name | Description
Public property | CoreConnectionDetails | Gets or sets the core connection details.
Public property | CoreMonitorDetails | Gets or sets the core monitor details.
Public property | FullServerJobDetails | Gets or sets the full server job details.
Public property | ImageProtectionJobDetails | Gets or sets the image protection job details.
Public property | ImageRecoveryJobDetails | Gets or sets the image recovery job details.
Top
See Also

Reference

JobStatisticsModel Class


JobStatisticsModel.CoreConnectionDetails Property

JobStatisticsModelCoreConnectionDetails Property
Gets or sets the core connection details.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CoreConnectionDetailsModel CoreConnectionDetails { get; set; }
Public Property CoreConnectionDetails As CoreConnectionDetailsModel
    Get
    Set
public:
property CoreConnectionDetailsModel^ CoreConnectionDetails {
    CoreConnectionDetailsModel^ get ();
    void set (CoreConnectionDetailsModel^ value);
}
member CoreConnectionDetails : CoreConnectionDetailsModel with get, set

Property Value

Type: CoreConnectionDetailsModel
See Also

Reference

JobStatisticsModel Class


JobStatisticsModel.CoreMonitorDetails Property

JobStatisticsModelCoreMonitorDetails Property
Gets or sets the core monitor details.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CoreMonitorDetailsModel CoreMonitorDetails { get; set; }
Public Property CoreMonitorDetails As CoreMonitorDetailsModel
    Get
    Set
public:
property CoreMonitorDetailsModel^ CoreMonitorDetails {
    CoreMonitorDetailsModel^ get ();
    void set (CoreMonitorDetailsModel^ value);
}
member CoreMonitorDetails : CoreMonitorDetailsModel with get, set

Property Value

Type: CoreMonitorDetailsModel
See Also

Reference

JobStatisticsModel Class


JobStatisticsModel.FullServerJobDetails Property

JobStatisticsModelFullServerJobDetails Property
Gets or sets the full server job details.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FullServerJobDetailsModel FullServerJobDetails { get; set; }
Public Property FullServerJobDetails As FullServerJobDetailsModel
    Get
    Set
public:
property FullServerJobDetailsModel^ FullServerJobDetails {
    FullServerJobDetailsModel^ get ();
    void set (FullServerJobDetailsModel^ value);
}
member FullServerJobDetails : FullServerJobDetailsModel with get, set

Property Value

Type: FullServerJobDetailsModel
See Also

Reference

JobStatisticsModel Class


JobStatisticsModel.ImageProtectionJobDetails Property

JobStatisticsModelImageProtectionJobDetails Property
Gets or sets the image protection job details.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ImageProtectionJobDetailsModel ImageProtectionJobDetails { get; set; }
Public Property ImageProtectionJobDetails As ImageProtectionJobDetailsModel
    Get
    Set
public:
property ImageProtectionJobDetailsModel^ ImageProtectionJobDetails {
    ImageProtectionJobDetailsModel^ get ();
    void set (ImageProtectionJobDetailsModel^ value);
}
member ImageProtectionJobDetails : ImageProtectionJobDetailsModel with get, set

Property Value

Type: ImageProtectionJobDetailsModel
See Also

Reference

JobStatisticsModel Class


JobStatisticsModel.ImageRecoveryJobDetails Property

JobStatisticsModelImageRecoveryJobDetails Property
Gets or sets the image recovery job details.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ImageRecoveryJobDetailsModel ImageRecoveryJobDetails { get; set; }
Public Property ImageRecoveryJobDetails As ImageRecoveryJobDetailsModel
    Get
    Set
public:
property ImageRecoveryJobDetailsModel^ ImageRecoveryJobDetails {
    ImageRecoveryJobDetailsModel^ get ();
    void set (ImageRecoveryJobDetailsModel^ value);
}
member ImageRecoveryJobDetails : ImageRecoveryJobDetailsModel with get, set

Property Value

Type: ImageRecoveryJobDetailsModel
See Also

Reference

JobStatisticsModel Class


JobStatisticsModel Methods

JobStatisticsModel Methods

The JobStatisticsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobStatisticsModel Class


JobStatusModel Class

JobStatusModel Class
Job status model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsJobStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class JobStatusModel
Public NotInheritable Class JobStatusModel
public ref class JobStatusModel sealed
[<SealedAttribute>]
type JobStatusModel =  class end

The JobStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | JobStatusModel | Initializes a new instance of the JobStatusModel class
Top
Properties
 | Name | Description
Public property | Actions | Gets or sets a list of actions recently associated with this job.
Public property | CanCreateImageRecovery | Gets or sets a value indicating whether an image protection job is in a viable state to create an image recovery job off of.
Public property | CanDelete | Gets or sets a value indicating whether this job can currently be deleted.
Public property | CanEdit | Gets or sets a value indicating whether this job can currently be edited.
Public property | CanFailback | Gets or sets a value indicating whether this job can currently be failed back.
Public property | CanFailover | Gets or sets a value indicating whether this job can currently be failed over.
Public property | CanPause | Gets or sets a value indicating whether this job can currently be paused.
Public property | CanRestore | Gets or sets a value indicating whether this job can currently be restored.
Public property | CanReverse | Gets or sets a value indicating whether this job can currently be reversed.
Public property | CanStart | Gets or sets a value indicating whether this job can currently be started.
Public property | CanStop | Gets or sets a value indicating whether this job can currently be stopped.
Public property | CanUndoFailover | Gets or sets a value indicating whether the failover of this job can be currently undone.
Public property | EngineControlStatuses | Gets or sets the engine control statuses.
Public property | ExtendedLowLevelStates | Gets or sets the extended low level states of this job.
Public property | Health | Gets or sets the health of this job.
Public property | HighLevelState | Gets or sets the high level state of this job.
Public property | IsInError | Gets or sets a value indicating whether this job is in an error state.
Public property | LowLevelState | Gets or sets the low level state of this job.
Public property | PermillageComplete | Gets or sets the permillage complete of the current activity of this job.
Public property | TargetState | Gets or sets the state of the data on the target server.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


JobStatusModel Constructor

JobStatusModel Constructor
Initializes a new instance of the JobStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public JobStatusModel()
Public Sub New
public:
JobStatusModel()
new : unit -> JobStatusModel
See Also

Reference

JobStatusModel Class


JobStatusModel Properties

JobStatusModel Properties

The JobStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | Actions | Gets or sets a list of actions recently associated with this job.
Public property | CanCreateImageRecovery | Gets or sets a value indicating whether an image protection job is in a viable state to create an image recovery job off of.
Public property | CanDelete | Gets or sets a value indicating whether this job can currently be deleted.
Public property | CanEdit | Gets or sets a value indicating whether this job can currently be edited.
Public property | CanFailback | Gets or sets a value indicating whether this job can currently be failed back.
Public property | CanFailover | Gets or sets a value indicating whether this job can currently be failed over.
Public property | CanPause | Gets or sets a value indicating whether this job can currently be paused.
Public property | CanRestore | Gets or sets a value indicating whether this job can currently be restored.
Public property | CanReverse | Gets or sets a value indicating whether this job can currently be reversed.
Public property | CanStart | Gets or sets a value indicating whether this job can currently be started.
Public property | CanStop | Gets or sets a value indicating whether this job can currently be stopped.
Public property | CanUndoFailover | Gets or sets a value indicating whether the failover of this job can be currently undone.
Public property | EngineControlStatuses | Gets or sets the engine control statuses.
Public property | ExtendedLowLevelStates | Gets or sets the extended low level states of this job.
Public property | Health | Gets or sets the health of this job.
Public property | HighLevelState | Gets or sets the high level state of this job.
Public property | IsInError | Gets or sets a value indicating whether this job is in an error state.
Public property | LowLevelState | Gets or sets the low level state of this job.
Public property | PermillageComplete | Gets or sets the permillage complete of the current activity of this job.
Public property | TargetState | Gets or sets the state of the data on the target server.
Top
See Also

Reference

JobStatusModel Class


JobStatusModel.Actions Property

JobStatusModelActions Property
Gets or sets a list of actions recently associated with this job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public JobActionModel[] Actions { get; set; }
Public Property Actions As JobActionModel()
    Get
    Set
public:
property array<JobActionModel^>^ Actions {
    array<JobActionModel^>^ get ();
    void set (array<JobActionModel^>^ value);
}
member Actions : JobActionModel[] with get, set

Property Value

Type: JobActionModel
See Also

Reference

JobStatusModel Class


JobStatusModel.CanCreateImageRecovery Property

JobStatusModelCanCreateImageRecovery Property
Gets or sets a value indicating whether an image protection job is in a viable state to create an image recovery job off of.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanCreateImageRecovery { get; set; }
Public Property CanCreateImageRecovery As Boolean
    Get
    Set
public:
property bool CanCreateImageRecovery {
    bool get ();
    void set (bool value);
}
member CanCreateImageRecovery : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStatusModel Class


JobStatusModel.CanDelete Property

JobStatusModelCanDelete Property
Gets or sets a value indicating whether this job can currently be deleted.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanDelete { get; set; }
Public Property CanDelete As Boolean
    Get
    Set
public:
property bool CanDelete {
    bool get ();
    void set (bool value);
}
member CanDelete : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStatusModel Class


JobStatusModel.CanEdit Property

JobStatusModelCanEdit Property
Gets or sets a value indicating whether this job can currently be edited.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanEdit { get; set; }
Public Property CanEdit As Boolean
    Get
    Set
public:
property bool CanEdit {
    bool get ();
    void set (bool value);
}
member CanEdit : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStatusModel Class


JobStatusModel.CanFailback Property

JobStatusModelCanFailback Property
Gets or sets a value indicating whether this job can currently be failed back.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanFailback { get; set; }
Public Property CanFailback As Boolean
    Get
    Set
public:
property bool CanFailback {
    bool get ();
    void set (bool value);
}
member CanFailback : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStatusModel Class


JobStatusModel.CanFailover Property

JobStatusModelCanFailover Property
Gets or sets a value indicating whether this job can currently be failed over.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanFailover { get; set; }
Public Property CanFailover As Boolean
    Get
    Set
public:
property bool CanFailover {
    bool get ();
    void set (bool value);
}
member CanFailover : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStatusModel Class


JobStatusModel.CanPause Property

JobStatusModelCanPause Property
Gets or sets a value indicating whether this job can currently be paused.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanPause { get; set; }
Public Property CanPause As Boolean
    Get
    Set
public:
property bool CanPause {
    bool get ();
    void set (bool value);
}
member CanPause : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStatusModel Class


JobStatusModel.CanRestore Property

JobStatusModelCanRestore Property
Gets or sets a value indicating whether this job can currently be restored.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanRestore { get; set; }
Public Property CanRestore As Boolean
    Get
    Set
public:
property bool CanRestore {
    bool get ();
    void set (bool value);
}
member CanRestore : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStatusModel Class


JobStatusModel.CanReverse Property

JobStatusModelCanReverse Property
Gets or sets a value indicating whether this job can currently be reversed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanReverse { get; set; }
Public Property CanReverse As Boolean
    Get
    Set
public:
property bool CanReverse {
    bool get ();
    void set (bool value);
}
member CanReverse : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStatusModel Class


JobStatusModel.CanStart Property

JobStatusModelCanStart Property
Gets or sets a value indicating whether this job can currently be started.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanStart { get; set; }
Public Property CanStart As Boolean
    Get
    Set
public:
property bool CanStart {
    bool get ();
    void set (bool value);
}
member CanStart : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStatusModel Class


JobStatusModel.CanStop Property

JobStatusModelCanStop Property
Gets or sets a value indicating whether this job can currently be stopped.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanStop { get; set; }
Public Property CanStop As Boolean
    Get
    Set
public:
property bool CanStop {
    bool get ();
    void set (bool value);
}
member CanStop : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStatusModel Class


JobStatusModel.CanUndoFailover Property

JobStatusModelCanUndoFailover Property
Gets or sets a value indicating whether the failover of this job can be currently undone.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanUndoFailover { get; set; }
Public Property CanUndoFailover As Boolean
    Get
    Set
public:
property bool CanUndoFailover {
    bool get ();
    void set (bool value);
}
member CanUndoFailover : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStatusModel Class


JobStatusModel.EngineControlStatuses Property

JobStatusModelEngineControlStatuses Property
Gets or sets the engine control statuses.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public EngineControlStatusModel[] EngineControlStatuses { get; set; }
Public Property EngineControlStatuses As EngineControlStatusModel()
    Get
    Set
public:
property array<EngineControlStatusModel^>^ EngineControlStatuses {
    array<EngineControlStatusModel^>^ get ();
    void set (array<EngineControlStatusModel^>^ value);
}
member EngineControlStatuses : EngineControlStatusModel[] with get, set

Property Value

Type: EngineControlStatusModel
See Also

Reference

JobStatusModel Class


JobStatusModel.ExtendedLowLevelStates Property

JobStatusModelExtendedLowLevelStates Property
Gets or sets the extended low level states of this job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ExtendedLowLevelStateModel[] ExtendedLowLevelStates { get; set; }
Public Property ExtendedLowLevelStates As ExtendedLowLevelStateModel()
    Get
    Set
public:
property array<ExtendedLowLevelStateModel^>^ ExtendedLowLevelStates {
    array<ExtendedLowLevelStateModel^>^ get ();
    void set (array<ExtendedLowLevelStateModel^>^ value);
}
member ExtendedLowLevelStates : ExtendedLowLevelStateModel[] with get, set

Property Value

Type: ExtendedLowLevelStateModel
See Also

Reference

JobStatusModel Class


JobStatusModel.Health Property

JobStatusModelHealth Property
Gets or sets the health of this job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Health Health { get; set; }
Public Property Health As Health
    Get
    Set
public:
property Health Health {
    Health get ();
    void set (Health value);
}
member Health : Health with get, set

Property Value

Type: Health
See Also

Reference

JobStatusModel Class


JobStatusModel.HighLevelState Property

JobStatusModelHighLevelState Property
Gets or sets the high level state of this job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public HighLevelState HighLevelState { get; set; }
Public Property HighLevelState As HighLevelState
    Get
    Set
public:
property HighLevelState HighLevelState {
    HighLevelState get ();
    void set (HighLevelState value);
}
member HighLevelState : HighLevelState with get, set

Property Value

Type: HighLevelState
See Also

Reference

JobStatusModel Class


JobStatusModel.IsInError Property

JobStatusModelIsInError Property
Gets or sets a value indicating whether this job is in an error state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsInError { get; set; }
Public Property IsInError As Boolean
    Get
    Set
public:
property bool IsInError {
    bool get ();
    void set (bool value);
}
member IsInError : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobStatusModel Class


JobStatusModel.LowLevelState Property

JobStatusModelLowLevelState Property
Gets or sets the low level state of this job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string LowLevelState { get; set; }
Public Property LowLevelState As String
    Get
    Set
public:
property String^ LowLevelState {
    String^ get ();
    void set (String^ value);
}
member LowLevelState : string with get, set

Property Value

Type: String
See Also

Reference

JobStatusModel Class


JobStatusModel.PermillageComplete Property

JobStatusModelPermillageComplete Property
Gets or sets the permillage complete of the current activity of this job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int PermillageComplete { get; set; }
Public Property PermillageComplete As Integer
    Get
    Set
public:
property int PermillageComplete {
    int get ();
    void set (int value);
}
member PermillageComplete : int with get, set

Property Value

Type: Int32
See Also

Reference

JobStatusModel Class


JobStatusModel.TargetState Property

JobStatusModelTargetState Property
Gets or sets the state of the data on the target server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetState { get; set; }
Public Property TargetState As String
    Get
    Set
public:
property String^ TargetState {
    String^ get ();
    void set (String^ value);
}
member TargetState : string with get, set

Property Value

Type: String
See Also

Reference

JobStatusModel Class


JobStatusModel Methods

JobStatusModel Methods

The JobStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobStatusModel Class


JobUsageDataModel Class

JobUsageDataModel Class
Job usage data.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsJobUsageDataModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class JobUsageDataModel
Public NotInheritable Class JobUsageDataModel
public ref class JobUsageDataModel sealed
[<SealedAttribute>]
type JobUsageDataModel =  class end

The JobUsageDataModel type exposes the following members.

Constructors
 | Name | Description
Public method | JobUsageDataModel | Initializes a new instance of the JobUsageDataModel class
Top
Properties
 | Name | Description
Public property | IsInitialData | Gets or sets a value indicating whether the initial data was recorded when the job was created.
Public property | JobOrConnectionId | Gets or sets the job or connection ID.
Public property | JobOrConnectionName | Gets or sets the job or connection name.
Public property | JobOrConnectionType | Gets or sets the job or connection type.
Public property | JobStatus | Gets or sets the job status.
Public property | PersistencePath | Gets or sets the job persistence path.
Public property | SourceActivationStatus | Gets or sets the source activation status.
Public property | SourceNetworkId | Gets or sets the source network ID (usually host name).
Public property | SourceUniqueId | Gets or sets the source unique ID (aka hardware ID).
Public property | TargetNetworkId | Gets or sets the target network ID (usually host name).
Public property | TargetUniqueId | Gets or sets the target unique ID (aka hardware ID).
Public property | Timestamp | Gets or sets the time when the data was collected.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


JobUsageDataModel Constructor

JobUsageDataModel Constructor
Initializes a new instance of the JobUsageDataModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public JobUsageDataModel()
Public Sub New
public:
JobUsageDataModel()
new : unit -> JobUsageDataModel
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel Properties

JobUsageDataModel Properties

The JobUsageDataModel type exposes the following members.

Properties
 | Name | Description
Public property | IsInitialData | Gets or sets a value indicating whether the initial data was recorded when the job was created.
Public property | JobOrConnectionId | Gets or sets the job or connection ID.
Public property | JobOrConnectionName | Gets or sets the job or connection name.
Public property | JobOrConnectionType | Gets or sets the job or connection type.
Public property | JobStatus | Gets or sets the job status.
Public property | PersistencePath | Gets or sets the job persistence path.
Public property | SourceActivationStatus | Gets or sets the source activation status.
Public property | SourceNetworkId | Gets or sets the source network ID (usually host name).
Public property | SourceUniqueId | Gets or sets the source unique ID (aka hardware ID).
Public property | TargetNetworkId | Gets or sets the target network ID (usually host name).
Public property | TargetUniqueId | Gets or sets the target unique ID (aka hardware ID).
Public property | Timestamp | Gets or sets the time when the data was collected.
Top
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel.IsInitialData Property

JobUsageDataModelIsInitialData Property
Gets or sets a value indicating whether the initial data was recorded when the job was created.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsInitialData { get; set; }
Public Property IsInitialData As Boolean
    Get
    Set
public:
property bool IsInitialData {
    bool get ();
    void set (bool value);
}
member IsInitialData : bool with get, set

Property Value

Type: Boolean
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel.JobOrConnectionId Property

JobUsageDataModelJobOrConnectionId Property
Gets or sets the job or connection ID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Guid JobOrConnectionId { get; set; }
Public Property JobOrConnectionId As Guid
    Get
    Set
public:
property Guid JobOrConnectionId {
    Guid get ();
    void set (Guid value);
}
member JobOrConnectionId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel.JobOrConnectionName Property

JobUsageDataModelJobOrConnectionName Property
Gets or sets the job or connection name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string JobOrConnectionName { get; set; }
Public Property JobOrConnectionName As String
    Get
    Set
public:
property String^ JobOrConnectionName {
    String^ get ();
    void set (String^ value);
}
member JobOrConnectionName : string with get, set

Property Value

Type: String
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel.JobOrConnectionType Property

JobUsageDataModelJobOrConnectionType Property
Gets or sets the job or connection type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string JobOrConnectionType { get; set; }
Public Property JobOrConnectionType As String
    Get
    Set
public:
property String^ JobOrConnectionType {
    String^ get ();
    void set (String^ value);
}
member JobOrConnectionType : string with get, set

Property Value

Type: String
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel.JobStatus Property

JobUsageDataModelJobStatus Property
Gets or sets the job status.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DtmuJobStatusEnum JobStatus { get; set; }
Public Property JobStatus As DtmuJobStatusEnum
    Get
    Set
public:
property DtmuJobStatusEnum JobStatus {
    DtmuJobStatusEnum get ();
    void set (DtmuJobStatusEnum value);
}
member JobStatus : DtmuJobStatusEnum with get, set

Property Value

Type: DtmuJobStatusEnum
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel.PersistencePath Property

JobUsageDataModelPersistencePath Property
Gets or sets the job persistence path.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string PersistencePath { get; set; }
Public Property PersistencePath As String
    Get
    Set
public:
property String^ PersistencePath {
    String^ get ();
    void set (String^ value);
}
member PersistencePath : string with get, set

Property Value

Type: String
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel.SourceActivationStatus Property

JobUsageDataModelSourceActivationStatus Property
Gets or sets the source activation status.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DtmuActivationStatusModel SourceActivationStatus { get; set; }
Public Property SourceActivationStatus As DtmuActivationStatusModel
    Get
    Set
public:
property DtmuActivationStatusModel^ SourceActivationStatus {
    DtmuActivationStatusModel^ get ();
    void set (DtmuActivationStatusModel^ value);
}
member SourceActivationStatus : DtmuActivationStatusModel with get, set

Property Value

Type: DtmuActivationStatusModel
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel.SourceNetworkId Property

JobUsageDataModelSourceNetworkId Property
Gets or sets the source network ID (usually host name).

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SourceNetworkId { get; set; }
Public Property SourceNetworkId As String
    Get
    Set
public:
property String^ SourceNetworkId {
    String^ get ();
    void set (String^ value);
}
member SourceNetworkId : string with get, set

Property Value

Type: String
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel.SourceUniqueId Property

JobUsageDataModelSourceUniqueId Property
Gets or sets the source unique ID (aka hardware ID).

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Guid SourceUniqueId { get; set; }
Public Property SourceUniqueId As Guid
    Get
    Set
public:
property Guid SourceUniqueId {
    Guid get ();
    void set (Guid value);
}
member SourceUniqueId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel.TargetNetworkId Property

JobUsageDataModelTargetNetworkId Property
Gets or sets the target network ID (usually host name).

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string TargetNetworkId { get; set; }
Public Property TargetNetworkId As String
    Get
    Set
public:
property String^ TargetNetworkId {
    String^ get ();
    void set (String^ value);
}
member TargetNetworkId : string with get, set

Property Value

Type: String
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel.TargetUniqueId Property

JobUsageDataModelTargetUniqueId Property
Gets or sets the target unique ID (aka hardware ID).

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Guid TargetUniqueId { get; set; }
Public Property TargetUniqueId As Guid
    Get
    Set
public:
property Guid TargetUniqueId {
    Guid get ();
    void set (Guid value);
}
member TargetUniqueId : Guid with get, set

Property Value

Type: Guid
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel.Timestamp Property

JobUsageDataModelTimestamp Property
Gets or sets the time when the data was collected.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset Timestamp { get; set; }
Public Property Timestamp As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset Timestamp {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member Timestamp : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

JobUsageDataModel Class


JobUsageDataModel Methods

JobUsageDataModel Methods

The JobUsageDataModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

JobUsageDataModel Class


LicenseType Enumeration

LicenseType Enumeration
License type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum LicenseType
Public Enumeration LicenseType
public enum class LicenseType
type LicenseType
Members
Member name | Value | Description
NotApplicable | 0 | not applicable
Limited | 1 | limited
Single | 2 | single
Site | 3 | site
NodeLockedKey | 4 | node locked key
See Also

Reference

DoubleTake.Web.Models Namespace


LinuxJobPersistedStateModel Class

LinuxJobPersistedStateModel Class
Linux job persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsLinuxJobPersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class LinuxJobPersistedStateModel
Public NotInheritable Class LinuxJobPersistedStateModel
public ref class LinuxJobPersistedStateModel sealed
[<SealedAttribute>]
type LinuxJobPersistedStateModel =  class end

The LinuxJobPersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | LinuxJobPersistedStateModel | Initializes a new instance of the LinuxJobPersistedStateModel class
Top
Properties
 | Name | Description
Public property | CurrentJobStateFlagStack | Gets or sets the current job state flag stack.
Public property | DeserializedJobStateFlagStack | Gets or sets the deserialized job state flag stack.
Public property | PreviousJobStateFlagStack | Gets or sets the previous job state flag stack.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


LinuxJobPersistedStateModel Constructor

LinuxJobPersistedStateModel Constructor
Initializes a new instance of the LinuxJobPersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public LinuxJobPersistedStateModel()
Public Sub New
public:
LinuxJobPersistedStateModel()
new : unit -> LinuxJobPersistedStateModel
See Also

Reference

LinuxJobPersistedStateModel Class


LinuxJobPersistedStateModel Properties

LinuxJobPersistedStateModel Properties

The LinuxJobPersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | CurrentJobStateFlagStack | Gets or sets the current job state flag stack.
Public property | DeserializedJobStateFlagStack | Gets or sets the deserialized job state flag stack.
Public property | PreviousJobStateFlagStack | Gets or sets the previous job state flag stack.
Top
See Also

Reference

LinuxJobPersistedStateModel Class


LinuxJobPersistedStateModel.CurrentJobStateFlagStack Property

LinuxJobPersistedStateModelCurrentJobStateFlagStack Property
Gets or sets the current job state flag stack.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public LinuxJobStateFlagStackModel CurrentJobStateFlagStack { get; set; }
Public Property CurrentJobStateFlagStack As LinuxJobStateFlagStackModel
    Get
    Set
public:
property LinuxJobStateFlagStackModel^ CurrentJobStateFlagStack {
    LinuxJobStateFlagStackModel^ get ();
    void set (LinuxJobStateFlagStackModel^ value);
}
member CurrentJobStateFlagStack : LinuxJobStateFlagStackModel with get, set

Property Value

Type: LinuxJobStateFlagStackModel
The current job state flag stack.
See Also

Reference

LinuxJobPersistedStateModel Class


LinuxJobPersistedStateModel.DeserializedJobStateFlagStack Property

LinuxJobPersistedStateModelDeserializedJobStateFlagStack Property
Gets or sets the deserialized job state flag stack.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public LinuxJobStateFlagStackModel DeserializedJobStateFlagStack { get; set; }
Public Property DeserializedJobStateFlagStack As LinuxJobStateFlagStackModel
    Get
    Set
public:
property LinuxJobStateFlagStackModel^ DeserializedJobStateFlagStack {
    LinuxJobStateFlagStackModel^ get ();
    void set (LinuxJobStateFlagStackModel^ value);
}
member DeserializedJobStateFlagStack : LinuxJobStateFlagStackModel with get, set

Property Value

Type: LinuxJobStateFlagStackModel
The deserialized job state flag stack.
See Also

Reference

LinuxJobPersistedStateModel Class


LinuxJobPersistedStateModel.PreviousJobStateFlagStack Property

LinuxJobPersistedStateModelPreviousJobStateFlagStack Property
Gets or sets the previous job state flag stack.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public LinuxJobStateFlagStackModel PreviousJobStateFlagStack { get; set; }
Public Property PreviousJobStateFlagStack As LinuxJobStateFlagStackModel
    Get
    Set
public:
property LinuxJobStateFlagStackModel^ PreviousJobStateFlagStack {
    LinuxJobStateFlagStackModel^ get ();
    void set (LinuxJobStateFlagStackModel^ value);
}
member PreviousJobStateFlagStack : LinuxJobStateFlagStackModel with get, set

Property Value

Type: LinuxJobStateFlagStackModel
The previous job state flag stack.
See Also

Reference

LinuxJobPersistedStateModel Class


LinuxJobPersistedStateModel Methods

LinuxJobPersistedStateModel Methods

The LinuxJobPersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LinuxJobPersistedStateModel Class


LinuxJobStateFlagModel Class

LinuxJobStateFlagModel Class
String representation of a JobStateFlag, defined privately by the Linux job implementation
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsLinuxJobStateFlagModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class LinuxJobStateFlagModel
Public NotInheritable Class LinuxJobStateFlagModel
public ref class LinuxJobStateFlagModel sealed
[<SealedAttribute>]
type LinuxJobStateFlagModel =  class end

The LinuxJobStateFlagModel type exposes the following members.

Constructors
 | Name | Description
Public method | LinuxJobStateFlagModel | Initializes a new instance of the LinuxJobStateFlagModel class
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


LinuxJobStateFlagModel Constructor

LinuxJobStateFlagModel Constructor
Initializes a new instance of the LinuxJobStateFlagModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public LinuxJobStateFlagModel()
Public Sub New
public:
LinuxJobStateFlagModel()
new : unit -> LinuxJobStateFlagModel
See Also

Reference

LinuxJobStateFlagModel Class


LinuxJobStateFlagModel Properties

LinuxJobStateFlagModel Properties

The LinuxJobStateFlagModel type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name.
Top
See Also

Reference

LinuxJobStateFlagModel Class


LinuxJobStateFlagModel.Name Property

LinuxJobStateFlagModelName Property
Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

LinuxJobStateFlagModel Class


LinuxJobStateFlagModel Methods

LinuxJobStateFlagModel Methods

The LinuxJobStateFlagModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LinuxJobStateFlagModel Class


LinuxJobStateFlagStackLevelModel Class

LinuxJobStateFlagStackLevelModel Class
Linux job state flag stack level.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsLinuxJobStateFlagStackLevelModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class LinuxJobStateFlagStackLevelModel
Public NotInheritable Class LinuxJobStateFlagStackLevelModel
public ref class LinuxJobStateFlagStackLevelModel sealed
[<SealedAttribute>]
type LinuxJobStateFlagStackLevelModel =  class end

The LinuxJobStateFlagStackLevelModel type exposes the following members.

Constructors
 | Name | Description
Public method | LinuxJobStateFlagStackLevelModel | Initializes a new instance of the LinuxJobStateFlagStackLevelModel class
Top
Properties
 | Name | Description
Public property | JobStateFlags | Gets or sets the job state flags.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


LinuxJobStateFlagStackLevelModel Constructor

LinuxJobStateFlagStackLevelModel Constructor
Initializes a new instance of the LinuxJobStateFlagStackLevelModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public LinuxJobStateFlagStackLevelModel()
Public Sub New
public:
LinuxJobStateFlagStackLevelModel()
new : unit -> LinuxJobStateFlagStackLevelModel
See Also

Reference

LinuxJobStateFlagStackLevelModel Class


LinuxJobStateFlagStackLevelModel Properties

LinuxJobStateFlagStackLevelModel Properties

The LinuxJobStateFlagStackLevelModel type exposes the following members.

Properties
 | Name | Description
Public property | JobStateFlags | Gets or sets the job state flags.
Top
See Also

Reference

LinuxJobStateFlagStackLevelModel Class


LinuxJobStateFlagStackLevelModel.JobStateFlags Property

LinuxJobStateFlagStackLevelModelJobStateFlags Property
Gets or sets the job state flags.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public LinuxJobStateFlagModel[] JobStateFlags { get; set; }
Public Property JobStateFlags As LinuxJobStateFlagModel()
    Get
    Set
public:
property array<LinuxJobStateFlagModel^>^ JobStateFlags {
    array<LinuxJobStateFlagModel^>^ get ();
    void set (array<LinuxJobStateFlagModel^>^ value);
}
member JobStateFlags : LinuxJobStateFlagModel[] with get, set

Property Value

Type: LinuxJobStateFlagModel
The job state flags.
See Also

Reference

LinuxJobStateFlagStackLevelModel Class


LinuxJobStateFlagStackLevelModel Methods

LinuxJobStateFlagStackLevelModel Methods

The LinuxJobStateFlagStackLevelModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LinuxJobStateFlagStackLevelModel Class


LinuxJobStateFlagStackModel Class

LinuxJobStateFlagStackModel Class
A stack levels containing LinuxJobStateFlag values, as managed privately by the Linux job implementation. Each level in the stack is contains an array of one or more JobStateFlag values.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsLinuxJobStateFlagStackModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class LinuxJobStateFlagStackModel
Public NotInheritable Class LinuxJobStateFlagStackModel
public ref class LinuxJobStateFlagStackModel sealed
[<SealedAttribute>]
type LinuxJobStateFlagStackModel =  class end

The LinuxJobStateFlagStackModel type exposes the following members.

Constructors
 | Name | Description
Public method | LinuxJobStateFlagStackModel | Initializes a new instance of the LinuxJobStateFlagStackModel class
Top
Properties
 | Name | Description
Public property | JobStateFlagStackLevels | Gets or sets the job state flag stack levels.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


LinuxJobStateFlagStackModel Constructor

LinuxJobStateFlagStackModel Constructor
Initializes a new instance of the LinuxJobStateFlagStackModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public LinuxJobStateFlagStackModel()
Public Sub New
public:
LinuxJobStateFlagStackModel()
new : unit -> LinuxJobStateFlagStackModel
See Also

Reference

LinuxJobStateFlagStackModel Class


LinuxJobStateFlagStackModel Properties

LinuxJobStateFlagStackModel Properties

The LinuxJobStateFlagStackModel type exposes the following members.

Properties
 | Name | Description
Public property | JobStateFlagStackLevels | Gets or sets the job state flag stack levels.
Top
See Also

Reference

LinuxJobStateFlagStackModel Class


LinuxJobStateFlagStackModel.JobStateFlagStackLevels Property

LinuxJobStateFlagStackModelJobStateFlagStackLevels Property
Gets or sets the job state flag stack levels.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public LinuxJobStateFlagStackLevelModel[] JobStateFlagStackLevels { get; set; }
Public Property JobStateFlagStackLevels As LinuxJobStateFlagStackLevelModel()
    Get
    Set
public:
property array<LinuxJobStateFlagStackLevelModel^>^ JobStateFlagStackLevels {
    array<LinuxJobStateFlagStackLevelModel^>^ get ();
    void set (array<LinuxJobStateFlagStackLevelModel^>^ value);
}
member JobStateFlagStackLevels : LinuxJobStateFlagStackLevelModel[] with get, set

Property Value

Type: LinuxJobStateFlagStackLevelModel
The job state flag stack levels.
See Also

Reference

LinuxJobStateFlagStackModel Class


LinuxJobStateFlagStackModel Methods

LinuxJobStateFlagStackModel Methods

The LinuxJobStateFlagStackModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LinuxJobStateFlagStackModel Class


LogActionInputModel Class

LogActionInputModel Class
Represents the input to a log action.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActionInputModel
DoubleTake.Web.ModelsLogActionInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class LogActionInputModel : ActionInputModel
Public Class LogActionInputModel
    Inherits ActionInputModel
public ref class LogActionInputModel : public ActionInputModel
type LogActionInputModel =
    class
        inherit ActionInputModel
    end

The LogActionInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | LogActionInputModel | Initializes a new instance of the LogActionInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the action. (Inherited from ActionInputModel.)
Public property | EventType | Gets or sets the type of the event.
Public property | Message | Gets or sets the message.
Public property | MessageFormatParameters | Gets or sets the message format parameters.
Public property | QueryResult | Gets or sets the query result. (Inherited from ActionInputModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


LogActionInputModel Constructor

LogActionInputModel Constructor
Initializes a new instance of the LogActionInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public LogActionInputModel()
Public Sub New
public:
LogActionInputModel()
new : unit -> LogActionInputModel
See Also

Reference

LogActionInputModel Class


LogActionInputModel Properties

LogActionInputModel Properties

The LogActionInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the action. (Inherited from ActionInputModel.)
Public property | EventType | Gets or sets the type of the event.
Public property | Message | Gets or sets the message.
Public property | MessageFormatParameters | Gets or sets the message format parameters.
Public property | QueryResult | Gets or sets the query result. (Inherited from ActionInputModel.)
Top
See Also

Reference

LogActionInputModel Class


LogActionInputModel.EventType Property

LogActionInputModelEventType Property
Gets or sets the type of the event.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public TraceEventType EventType { get; set; }
Public Property EventType As TraceEventType
    Get
    Set
public:
property TraceEventType EventType {
    TraceEventType get ();
    void set (TraceEventType value);
}
member EventType : TraceEventType with get, set

Property Value

Type: TraceEventType
The type of the event.
See Also

Reference

LogActionInputModel Class


LogActionInputModel.Message Property

LogActionInputModelMessage Property
Gets or sets the message.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Property Value

Type: String
The message.
See Also

Reference

LogActionInputModel Class


LogActionInputModel.MessageFormatParameters Property

LogActionInputModelMessageFormatParameters Property
Gets or sets the message format parameters.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string[] MessageFormatParameters { get; set; }
Public Property MessageFormatParameters As String()
    Get
    Set
public:
property array<String^>^ MessageFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member MessageFormatParameters : string[] with get, set

Property Value

Type: String
The message format parameters.
See Also

Reference

LogActionInputModel Class


LogActionInputModel Methods

LogActionInputModel Methods

The LogActionInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LogActionInputModel Class


LogicalItemModel Class

LogicalItemModel Class
Logical item model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsProtectableItemModel
DoubleTake.Web.ModelsLogicalItemModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class LogicalItemModel : ProtectableItemModel
Public NotInheritable Class LogicalItemModel
    Inherits ProtectableItemModel
public ref class LogicalItemModel sealed : public ProtectableItemModel
[<SealedAttribute>]
type LogicalItemModel =
    class
        inherit ProtectableItemModel
    end

The LogicalItemModel type exposes the following members.

Constructors
 | Name | Description
Public method | LogicalItemModel | Initializes a new instance of the LogicalItemModel class
Top
Properties
 | Name | Description
Public property | Id | Gets or sets the item identifier. (Inherited from ProtectableItemModel.)
Public property | IsContainer | Gets or sets a value indicating whether or not this item is a container of other items. (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | Gets or sets a value indicating whether or not this item is read only; that is, its Saturation cannot be changed. (Inherited from ProtectableItemModel.)
Public property | ItemType | Gets or sets the type of this item. (Inherited from ProtectableItemModel.)
Public property | Metadata | Gets or sets additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type.
Public property | Name | Gets or sets the name of this item. (Inherited from ProtectableItemModel.)
Public property | PartitionName | Gets or sets the partition name. (Inherited from ProtectableItemModel.)
Public property | Path | Gets or sets the path that uniquely identifies this item. (Inherited from ProtectableItemModel.)
Public property | Saturation | Gets or sets the saturation level of this item. (Inherited from ProtectableItemModel.)
Public property | SaturationDefault | Gets or sets the default saturation level of the item. Typically, this value is used to display a visual state in the user interface.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


LogicalItemModel Constructor

LogicalItemModel Constructor
Initializes a new instance of the LogicalItemModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public LogicalItemModel()
Public Sub New
public:
LogicalItemModel()
new : unit -> LogicalItemModel
See Also

Reference

LogicalItemModel Class


LogicalItemModel Properties

LogicalItemModel Properties

The LogicalItemModel type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets or sets the item identifier. (Inherited from ProtectableItemModel.)
Public property | IsContainer | Gets or sets a value indicating whether or not this item is a container of other items. (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | Gets or sets a value indicating whether or not this item is read only; that is, its Saturation cannot be changed. (Inherited from ProtectableItemModel.)
Public property | ItemType | Gets or sets the type of this item. (Inherited from ProtectableItemModel.)
Public property | Metadata | Gets or sets additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type.
Public property | Name | Gets or sets the name of this item. (Inherited from ProtectableItemModel.)
Public property | PartitionName | Gets or sets the partition name. (Inherited from ProtectableItemModel.)
Public property | Path | Gets or sets the path that uniquely identifies this item. (Inherited from ProtectableItemModel.)
Public property | Saturation | Gets or sets the saturation level of this item. (Inherited from ProtectableItemModel.)
Public property | SaturationDefault | Gets or sets the default saturation level of the item. Typically, this value is used to display a visual state in the user interface.
Top
See Also

Reference

LogicalItemModel Class


LogicalItemModel.Metadata Property

LogicalItemModelMetadata Property
Gets or sets additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but you must be able to determine the format and decipher the metadata based on the type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Metadata { get; set; }
Public Property Metadata As String
    Get
    Set
public:
property String^ Metadata {
    String^ get ();
    void set (String^ value);
}
member Metadata : string with get, set

Property Value

Type: String
The metadata.
Remarks
This property is used to specify any additional metadata that may be displayed for a particular type of item. This metadata is not in any particular format, but one must be able to determine the format and decipher the metadata based on the type.
See Also

Reference

LogicalItemModel Class


LogicalItemModel.SaturationDefault Property

LogicalItemModelSaturationDefault Property
Gets or sets the default saturation level of the item. Typically, this value is used to display a visual state in the user interface.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public SaturationLevel SaturationDefault { get; set; }
Public Property SaturationDefault As SaturationLevel
    Get
    Set
public:
property SaturationLevel SaturationDefault {
    SaturationLevel get ();
    void set (SaturationLevel value);
}
member SaturationDefault : SaturationLevel with get, set

Property Value

Type: SaturationLevel
The default saturation level.
See Also

Reference

LogicalItemModel Class


LogicalItemModel Methods

LogicalItemModel Methods

The LogicalItemModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LogicalItemModel Class


LogicalVolumeModel Class

LogicalVolumeModel Class
Logical volume model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsProtectableItemModel
DoubleTake.Web.ModelsPhysicalItemModel
DoubleTake.Web.ModelsVolumeModel
DoubleTake.Web.ModelsVolumeOptionsModel
DoubleTake.Web.ModelsLogicalVolumeModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public class LogicalVolumeModel : VolumeOptionsModel
Public Class LogicalVolumeModel
    Inherits VolumeOptionsModel
public ref class LogicalVolumeModel : public VolumeOptionsModel
type LogicalVolumeModel =
    class
        inherit VolumeOptionsModel
    end

The LogicalVolumeModel type exposes the following members.

Constructors
 | Name | Description
Public method | LogicalVolumeModel | Initializes a new instance of the LogicalVolumeModel class
Top
Properties
 | Name | Description
Public property | Attributes | Gets or sets a value specifying the file system attributes of this item. (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | Gets or sets the available free space on this volume. (Inherited from PhysicalItemModel.)
Public property | ClassName | Gets or sets the class name. (Inherited from PhysicalItemModel.)
Public property | CreationTime | Gets or sets a value specifying the time this item was created. (Inherited from PhysicalItemModel.)
Public property | DesiredSize | Gets or sets the size that the user wants the drive to be. (Inherited from VolumeOptionsModel.)
Public property | DiskControllerType | Gets or sets the type of the disk controller. (Inherited from VolumeOptionsModel.)
Public property | DiskProvisioningType | Gets or sets the type of the disk provisioning. (Inherited from VolumeOptionsModel.)
Public property | DriveFormat | Gets or sets the format of the drive. (Inherited from PhysicalItemModel.)
Public property | DriveType | Gets or sets the type of the drive. (Inherited from PhysicalItemModel.)
Public property | Id | Gets or sets the item identifier. (Inherited from ProtectableItemModel.)
Public property | IsContainer | Gets or sets a value indicating whether or not this item is a container of other items. (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | Gets or sets a value indicating whether or not this item is read only; that is, its Saturation cannot be changed. (Inherited from ProtectableItemModel.)
Public property | IsSupported | Gets or sets a value indicating whether this volume is supported. (Inherited from PhysicalItemModel.)
Public property | IsSystemDrive | Gets or sets a value indicating whether or not this volume is the system drive. (Inherited from PhysicalItemModel.)
Public property | ItemType | Gets or sets the type of this item. (Inherited from ProtectableItemModel.)
Public property | Label | Gets or sets the volume label. (Inherited from PhysicalItemModel.)
Public property | LastAccessTime | Gets or sets a value specifying the time this item was last accessed. (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | Gets or sets a value specifying the time this item was last written to. (Inherited from PhysicalItemModel.)
Public property | LogicalVolumeName | Gets or sets the logical volume name.
Public property | Metadata | Gets or sets a value specifying additional meta data for this item. (Inherited from PhysicalItemModel.)
Public property | Name | Gets or sets the name of this item. (Inherited from ProtectableItemModel.)
Public property | PartitionName | Gets or sets the partition name. (Inherited from ProtectableItemModel.)
Public property | Path | Gets or sets the path that uniquely identifies this item. (Inherited from ProtectableItemModel.)
Public property | PreexistingDiskPath | Gets or sets the path of preexisting disk. (Inherited from VolumeOptionsModel.)
Public property | Saturation | Gets or sets the saturation level of this item. (Inherited from ProtectableItemModel.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume. (Inherited from PhysicalItemModel.)
Public property | Size | Gets or sets a value indicating the physical size of the item. (Inherited from PhysicalItemModel.)
Public property | TotalSize | Gets or sets the total size of the volume. (Inherited from PhysicalItemModel.)
Public property | VirtualDiskPath | Gets or sets the path on the host where the volume should be stored. (Inherited from VolumeOptionsModel.)
Public property | VolumeSignature | Gets or sets the volume signature. (Inherited from VolumeOptionsModel.)
Public property | VolumeType | Gets or sets the volume type. (Inherited from PhysicalItemModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


LogicalVolumeModel Constructor

LogicalVolumeModel Constructor
Initializes a new instance of the LogicalVolumeModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public LogicalVolumeModel()
Public Sub New
public:
LogicalVolumeModel()
new : unit -> LogicalVolumeModel
See Also

Reference

LogicalVolumeModel Class


LogicalVolumeModel Properties

LogicalVolumeModel Properties

The LogicalVolumeModel type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets or sets a value specifying the file system attributes of this item. (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | Gets or sets the available free space on this volume. (Inherited from PhysicalItemModel.)
Public property | ClassName | Gets or sets the class name. (Inherited from PhysicalItemModel.)
Public property | CreationTime | Gets or sets a value specifying the time this item was created. (Inherited from PhysicalItemModel.)
Public property | DesiredSize | Gets or sets the size that the user wants the drive to be. (Inherited from VolumeOptionsModel.)
Public property | DiskControllerType | Gets or sets the type of the disk controller. (Inherited from VolumeOptionsModel.)
Public property | DiskProvisioningType | Gets or sets the type of the disk provisioning. (Inherited from VolumeOptionsModel.)
Public property | DriveFormat | Gets or sets the format of the drive. (Inherited from PhysicalItemModel.)
Public property | DriveType | Gets or sets the type of the drive. (Inherited from PhysicalItemModel.)
Public property | Id | Gets or sets the item identifier. (Inherited from ProtectableItemModel.)
Public property | IsContainer | Gets or sets a value indicating whether or not this item is a container of other items. (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | Gets or sets a value indicating whether or not this item is read only; that is, its Saturation cannot be changed. (Inherited from ProtectableItemModel.)
Public property | IsSupported | Gets or sets a value indicating whether this volume is supported. (Inherited from PhysicalItemModel.)
Public property | IsSystemDrive | Gets or sets a value indicating whether or not this volume is the system drive. (Inherited from PhysicalItemModel.)
Public property | ItemType | Gets or sets the type of this item. (Inherited from ProtectableItemModel.)
Public property | Label | Gets or sets the volume label. (Inherited from PhysicalItemModel.)
Public property | LastAccessTime | Gets or sets a value specifying the time this item was last accessed. (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | Gets or sets a value specifying the time this item was last written to. (Inherited from PhysicalItemModel.)
Public property | LogicalVolumeName | Gets or sets the logical volume name.
Public property | Metadata | Gets or sets a value specifying additional meta data for this item. (Inherited from PhysicalItemModel.)
Public property | Name | Gets or sets the name of this item. (Inherited from ProtectableItemModel.)
Public property | PartitionName | Gets or sets the partition name. (Inherited from ProtectableItemModel.)
Public property | Path | Gets or sets the path that uniquely identifies this item. (Inherited from ProtectableItemModel.)
Public property | PreexistingDiskPath | Gets or sets the path of preexisting disk. (Inherited from VolumeOptionsModel.)
Public property | Saturation | Gets or sets the saturation level of this item. (Inherited from ProtectableItemModel.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume. (Inherited from PhysicalItemModel.)
Public property | Size | Gets or sets a value indicating the physical size of the item. (Inherited from PhysicalItemModel.)
Public property | TotalSize | Gets or sets the total size of the volume. (Inherited from PhysicalItemModel.)
Public property | VirtualDiskPath | Gets or sets the path on the host where the volume should be stored. (Inherited from VolumeOptionsModel.)
Public property | VolumeSignature | Gets or sets the volume signature. (Inherited from VolumeOptionsModel.)
Public property | VolumeType | Gets or sets the volume type. (Inherited from PhysicalItemModel.)
Top
See Also

Reference

LogicalVolumeModel Class


LogicalVolumeModel.LogicalVolumeName Property

LogicalVolumeModelLogicalVolumeName Property
Gets or sets the logical volume name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string LogicalVolumeName { get; set; }
Public Property LogicalVolumeName As String
    Get
    Set
public:
property String^ LogicalVolumeName {
    String^ get ();
    void set (String^ value);
}
member LogicalVolumeName : string with get, set

Property Value

Type: String
See Also

Reference

LogicalVolumeModel Class


LogicalVolumeModel Methods

LogicalVolumeModel Methods

The LogicalVolumeModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LogicalVolumeModel Class


LogMessageModel Class

LogMessageModel Class
Log message model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsLogMessageModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class LogMessageModel
Public NotInheritable Class LogMessageModel
public ref class LogMessageModel sealed
[<SealedAttribute>]
type LogMessageModel =  class end

The LogMessageModel type exposes the following members.

Constructors
 | Name | Description
Public method | LogMessageModel | Initializes a new instance of the LogMessageModel class
Top
Properties
 | Name | Description
Public property | Hash | Gets or sets the message hash used to differentiate messages written with the same timestamp.
Public property | Id | Gets or sets the message id.
Public property | MessageType | Gets or sets the message type.
Public property | ProcessId | Gets or sets the process id of the process that generated this message.
Public property | Sequence | Gets or sets the message's sequence number within the log file.
Public property | Source | Gets or sets the log file source.
Public property | Text | Gets or sets the descriptive portion of the message.
Public property | ThreadId | Gets or sets the thread id of the thread that generated this message.
Public property | Timestamp | Gets or sets the local time when this message was generated.
Public property | TimestampOffset | Gets or sets the time when this message was generated, relative to UTC.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


LogMessageModel Constructor

LogMessageModel Constructor
Initializes a new instance of the LogMessageModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public LogMessageModel()
Public Sub New
public:
LogMessageModel()
new : unit -> LogMessageModel
See Also

Reference

LogMessageModel Class


LogMessageModel Properties

LogMessageModel Properties

The LogMessageModel type exposes the following members.

Properties
 | Name | Description
Public property | Hash | Gets or sets the message hash used to differentiate messages written with the same timestamp.
Public property | Id | Gets or sets the message id.
Public property | MessageType | Gets or sets the message type.
Public property | ProcessId | Gets or sets the process id of the process that generated this message.
Public property | Sequence | Gets or sets the message's sequence number within the log file.
Public property | Source | Gets or sets the log file source.
Public property | Text | Gets or sets the descriptive portion of the message.
Public property | ThreadId | Gets or sets the thread id of the thread that generated this message.
Public property | Timestamp | Gets or sets the local time when this message was generated.
Public property | TimestampOffset | Gets or sets the time when this message was generated, relative to UTC.
Top
See Also

Reference

LogMessageModel Class


LogMessageModel.Hash Property

LogMessageModelHash Property
Gets or sets the message hash used to differentiate messages written with the same timestamp.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int Hash { get; set; }
Public Property Hash As Integer
    Get
    Set
public:
property int Hash {
    int get ();
    void set (int value);
}
member Hash : int with get, set

Property Value

Type: Int32
See Also

Reference

LogMessageModel Class


LogMessageModel.Id Property

LogMessageModelId Property
Gets or sets the message id.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int Id { get; set; }
Public Property Id As Integer
    Get
    Set
public:
property int Id {
    int get ();
    void set (int value);
}
member Id : int with get, set

Property Value

Type: Int32
See Also

Reference

LogMessageModel Class


LogMessageModel.MessageType Property

LogMessageModelMessageType Property
Gets or sets the message type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int MessageType { get; set; }
Public Property MessageType As Integer
    Get
    Set
public:
property int MessageType {
    int get ();
    void set (int value);
}
member MessageType : int with get, set

Property Value

Type: Int32
See Also

Reference

LogMessageModel Class


LogMessageModel.ProcessId Property

LogMessageModelProcessId Property
Gets or sets the process id of the process that generated this message.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int ProcessId { get; set; }
Public Property ProcessId As Integer
    Get
    Set
public:
property int ProcessId {
    int get ();
    void set (int value);
}
member ProcessId : int with get, set

Property Value

Type: Int32
See Also

Reference

LogMessageModel Class


LogMessageModel.Sequence Property

LogMessageModelSequence Property
Gets or sets the message's sequence number within the log file.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int Sequence { get; set; }
Public Property Sequence As Integer
    Get
    Set
public:
property int Sequence {
    int get ();
    void set (int value);
}
member Sequence : int with get, set

Property Value

Type: Int32
See Also

Reference

LogMessageModel Class


LogMessageModel.Source Property

LogMessageModelSource Property
Gets or sets the log file source.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Source { get; set; }
Public Property Source As String
    Get
    Set
public:
property String^ Source {
    String^ get ();
    void set (String^ value);
}
member Source : string with get, set

Property Value

Type: String
See Also

Reference

LogMessageModel Class


LogMessageModel.Text Property

LogMessageModelText Property
Gets or sets the descriptive portion of the message.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Text { get; set; }
Public Property Text As String
    Get
    Set
public:
property String^ Text {
    String^ get ();
    void set (String^ value);
}
member Text : string with get, set

Property Value

Type: String
See Also

Reference

LogMessageModel Class


LogMessageModel.ThreadId Property

LogMessageModelThreadId Property
Gets or sets the thread id of the thread that generated this message.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int ThreadId { get; set; }
Public Property ThreadId As Integer
    Get
    Set
public:
property int ThreadId {
    int get ();
    void set (int value);
}
member ThreadId : int with get, set

Property Value

Type: Int32
See Also

Reference

LogMessageModel Class


LogMessageModel.Timestamp Property

LogMessageModelTimestamp Property
Gets or sets the local time when this message was generated.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime Timestamp { get; set; }
Public Property Timestamp As DateTime
    Get
    Set
public:
property DateTime Timestamp {
    DateTime get ();
    void set (DateTime value);
}
member Timestamp : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

LogMessageModel Class


LogMessageModel.TimestampOffset Property

LogMessageModelTimestampOffset Property
Gets or sets the time when this message was generated, relative to UTC.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset TimestampOffset { get; set; }
Public Property TimestampOffset As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset TimestampOffset {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member TimestampOffset : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

LogMessageModel Class


LogMessageModel Methods

LogMessageModel Methods

The LogMessageModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LogMessageModel Class


LvmOptionsModel Class

LvmOptionsModel Class
Lvm options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsLvmOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class LvmOptionsModel
Public NotInheritable Class LvmOptionsModel
public ref class LvmOptionsModel sealed
[<SealedAttribute>]
type LvmOptionsModel =  class end

The LvmOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | LvmOptionsModel | Initializes a new instance of the LvmOptionsModel class
Top
Properties
 | Name | Description
Public property | VolumeGroups | Gets or sets the volume groups.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


LvmOptionsModel Constructor

LvmOptionsModel Constructor
Initializes a new instance of the LvmOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public LvmOptionsModel()
Public Sub New
public:
LvmOptionsModel()
new : unit -> LvmOptionsModel
See Also

Reference

LvmOptionsModel Class


LvmOptionsModel Properties

LvmOptionsModel Properties

The LvmOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | VolumeGroups | Gets or sets the volume groups.
Top
See Also

Reference

LvmOptionsModel Class


LvmOptionsModel.VolumeGroups Property

LvmOptionsModelVolumeGroups Property
Gets or sets the volume groups.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VolumeGroupModel[] VolumeGroups { get; set; }
Public Property VolumeGroups As VolumeGroupModel()
    Get
    Set
public:
property array<VolumeGroupModel^>^ VolumeGroups {
    array<VolumeGroupModel^>^ get ();
    void set (array<VolumeGroupModel^>^ value);
}
member VolumeGroups : VolumeGroupModel[] with get, set

Property Value

Type: VolumeGroupModel
See Also

Reference

LvmOptionsModel Class


LvmOptionsModel Methods

LvmOptionsModel Methods

The LvmOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

LvmOptionsModel Class


MachineInfoClassModel Class

MachineInfoClassModel Class
Data about the target machine
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMachineInfoClassModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class MachineInfoClassModel
Public NotInheritable Class MachineInfoClassModel
public ref class MachineInfoClassModel sealed
[<SealedAttribute>]
type MachineInfoClassModel =  class end

The MachineInfoClassModel type exposes the following members.

Constructors
 | Name | Description
Public method | MachineInfoClassModel | Initializes a new instance of the MachineInfoClassModel class
Top
Properties
 | Name | Description
Public property | os | OS on the machine.
Public property | osVersion | OS version on the machine.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MachineInfoClassModel Constructor

MachineInfoClassModel Constructor
Initializes a new instance of the MachineInfoClassModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public MachineInfoClassModel()
Public Sub New
public:
MachineInfoClassModel()
new : unit -> MachineInfoClassModel
See Also

Reference

MachineInfoClassModel Class


MachineInfoClassModel Properties

MachineInfoClassModel Properties

The MachineInfoClassModel type exposes the following members.

Properties
 | Name | Description
Public property | os | OS on the machine.
Public property | osVersion | OS version on the machine.
Top
See Also

Reference

MachineInfoClassModel Class


MachineInfoClassModel.os Property

MachineInfoClassModelos Property
OS on the machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string os { get; set; }
Public Property os As String
    Get
    Set
public:
property String^ os {
    String^ get ();
    void set (String^ value);
}
member os : string with get, set

Property Value

Type: String
See Also

Reference

MachineInfoClassModel Class


MachineInfoClassModel.osVersion Property

MachineInfoClassModelosVersion Property
OS version on the machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string osVersion { get; set; }
Public Property osVersion As String
    Get
    Set
public:
property String^ osVersion {
    String^ get ();
    void set (String^ value);
}
member osVersion : string with get, set

Property Value

Type: String
See Also

Reference

MachineInfoClassModel Class


MachineInfoClassModel Methods

MachineInfoClassModel Methods

The MachineInfoClassModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MachineInfoClassModel Class


MachineInfoModel Class

MachineInfoModel Class
Machine info model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMachineInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class MachineInfoModel
Public NotInheritable Class MachineInfoModel
public ref class MachineInfoModel sealed
[<SealedAttribute>]
type MachineInfoModel =  class end

The MachineInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | MachineInfoModel | Initializes a new instance of the MachineInfoModel class
Top
Properties
 | Name | Description
Public property | ProductInfo | Gets or sets the product information on the server.
Public property | ServerInfo | Gets or sets the server information on the server.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MachineInfoModel Constructor

MachineInfoModel Constructor
Initializes a new instance of the MachineInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public MachineInfoModel()
Public Sub New
public:
MachineInfoModel()
new : unit -> MachineInfoModel
See Also

Reference

MachineInfoModel Class


MachineInfoModel Properties

MachineInfoModel Properties

The MachineInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | ProductInfo | Gets or sets the product information on the server.
Public property | ServerInfo | Gets or sets the server information on the server.
Top
See Also

Reference

MachineInfoModel Class


MachineInfoModel.ProductInfo Property

MachineInfoModelProductInfo Property
Gets or sets the product information on the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ProductInfoModel ProductInfo { get; set; }
Public Property ProductInfo As ProductInfoModel
    Get
    Set
public:
property ProductInfoModel^ ProductInfo {
    ProductInfoModel^ get ();
    void set (ProductInfoModel^ value);
}
member ProductInfo : ProductInfoModel with get, set

Property Value

Type: ProductInfoModel
See Also

Reference

MachineInfoModel Class


MachineInfoModel.ServerInfo Property

MachineInfoModelServerInfo Property
Gets or sets the server information on the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ServerInfoModel ServerInfo { get; set; }
Public Property ServerInfo As ServerInfoModel
    Get
    Set
public:
property ServerInfoModel^ ServerInfo {
    ServerInfoModel^ get ();
    void set (ServerInfoModel^ value);
}
member ServerInfo : ServerInfoModel with get, set

Property Value

Type: ServerInfoModel
See Also

Reference

MachineInfoModel Class


MachineInfoModel Methods

MachineInfoModel Methods

The MachineInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MachineInfoModel Class


MirrorComparisonCriteria Enumeration

MirrorComparisonCriteria Enumeration
Mirror comparison criteria.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum MirrorComparisonCriteria
Public Enumeration MirrorComparisonCriteria
public enum class MirrorComparisonCriteria
type MirrorComparisonCriteria
Members
Member name | Value | Description
None | 0 | The none
Newer | 1 | The newer
Checksum | 2 | The checksum
See Also

Reference

DoubleTake.Web.Models Namespace


MirrorOperationOptions Enumeration

MirrorOperationOptions Enumeration
Mirror operation options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum MirrorOperationOptions
Public Enumeration MirrorOperationOptions
public enum class MirrorOperationOptions
type MirrorOperationOptions
Members
Member name | Value | Description
None | 0 | The none
Synchronize | 1 | The synchronize
Report | 2 | The report
CalculateDifferences | 4 | The calculate differences
CalculateSize | 8 | The calculate size
ProcessOrphans | 16 | The process orphans
See Also

Reference

DoubleTake.Web.Models Namespace


MirrorParametersModel Class

MirrorParametersModel Class
Mirror parameters model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMirrorParametersModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class MirrorParametersModel
Public NotInheritable Class MirrorParametersModel
public ref class MirrorParametersModel sealed
[<SealedAttribute>]
type MirrorParametersModel =  class end

The MirrorParametersModel type exposes the following members.

Constructors
 | Name | Description
Public method | MirrorParametersModel | Initializes a new instance of the MirrorParametersModel class
Top
Properties
 | Name | Description
Public property | ComparisonCriteria | Gets or sets specifies how to compare the workload items on the source with the replica on the target.
Public property | Options | Gets or sets mirror operation options.
Public property | OverrideJobOrphansProcessing | Gets or sets a value indicating whether or not to override the job's orphan processing setting.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MirrorParametersModel Constructor

MirrorParametersModel Constructor
Initializes a new instance of the MirrorParametersModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public MirrorParametersModel()
Public Sub New
public:
MirrorParametersModel()
new : unit -> MirrorParametersModel
See Also

Reference

MirrorParametersModel Class


MirrorParametersModel Properties

MirrorParametersModel Properties

The MirrorParametersModel type exposes the following members.

Properties
 | Name | Description
Public property | ComparisonCriteria | Gets or sets specifies how to compare the workload items on the source with the replica on the target.
Public property | Options | Gets or sets mirror operation options.
Public property | OverrideJobOrphansProcessing | Gets or sets a value indicating whether or not to override the job's orphan processing setting.
Top
See Also

Reference

MirrorParametersModel Class


MirrorParametersModel.ComparisonCriteria Property

MirrorParametersModelComparisonCriteria Property
Gets or sets specifies how to compare the workload items on the source with the replica on the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public MirrorComparisonCriteria ComparisonCriteria { get; set; }
Public Property ComparisonCriteria As MirrorComparisonCriteria
    Get
    Set
public:
property MirrorComparisonCriteria ComparisonCriteria {
    MirrorComparisonCriteria get ();
    void set (MirrorComparisonCriteria value);
}
member ComparisonCriteria : MirrorComparisonCriteria with get, set

Property Value

Type: MirrorComparisonCriteria
See Also

Reference

MirrorParametersModel Class


MirrorParametersModel.Options Property

MirrorParametersModelOptions Property
Gets or sets mirror operation options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public MirrorOperationOptions Options { get; set; }
Public Property Options As MirrorOperationOptions
    Get
    Set
public:
property MirrorOperationOptions Options {
    MirrorOperationOptions get ();
    void set (MirrorOperationOptions value);
}
member Options : MirrorOperationOptions with get, set

Property Value

Type: MirrorOperationOptions
See Also

Reference

MirrorParametersModel Class


MirrorParametersModel.OverrideJobOrphansProcessing Property

MirrorParametersModelOverrideJobOrphansProcessing Property
Gets or sets a value indicating whether or not to override the job's orphan processing setting.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool OverrideJobOrphansProcessing { get; set; }
Public Property OverrideJobOrphansProcessing As Boolean
    Get
    Set
public:
property bool OverrideJobOrphansProcessing {
    bool get ();
    void set (bool value);
}
member OverrideJobOrphansProcessing : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MirrorParametersModel Class


MirrorParametersModel Methods

MirrorParametersModel Methods

The MirrorParametersModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MirrorParametersModel Class


MirrorState Enumeration

MirrorState Enumeration
Mirror state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum MirrorState
Public Enumeration MirrorState
public enum class MirrorState
type MirrorState
Members
Member name | Value | Description
Calculating | 0 | The calculating
Idle | 1 | The idle
Mirror | 2 | The mirror
Pause | 3 | The pause
RemoveOrphans | 4 | The remove orphans
RepsetVerify | 5 | The repset verify
Restore | 6 | The restore
Stopped | 7 | The stopped
Waiting | 8 | The waiting
Unknown | 9 | The unknown
See Also

Reference

DoubleTake.Web.Models Namespace


ModifyReplicationSetRulesRequestModel Class

ModifyReplicationSetRulesRequestModel Class
Modify replication set rules request.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsModifyReplicationSetRulesRequestModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class ModifyReplicationSetRulesRequestModel
Public NotInheritable Class ModifyReplicationSetRulesRequestModel
public ref class ModifyReplicationSetRulesRequestModel sealed
[<SealedAttribute>]
type ModifyReplicationSetRulesRequestModel =  class end

The ModifyReplicationSetRulesRequestModel type exposes the following members.

Constructors
 | Name | Description
Public method | ModifyReplicationSetRulesRequestModel | Initializes a new instance of the ModifyReplicationSetRulesRequestModel class
Top
Properties
 | Name | Description
Public property | PhysicalRules | Gets or sets the physical rules.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ModifyReplicationSetRulesRequestModel Constructor

ModifyReplicationSetRulesRequestModel Constructor
Initializes a new instance of the ModifyReplicationSetRulesRequestModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ModifyReplicationSetRulesRequestModel()
Public Sub New
public:
ModifyReplicationSetRulesRequestModel()
new : unit -> ModifyReplicationSetRulesRequestModel
See Also

Reference

ModifyReplicationSetRulesRequestModel Class


ModifyReplicationSetRulesRequestModel Properties

ModifyReplicationSetRulesRequestModel Properties

The ModifyReplicationSetRulesRequestModel type exposes the following members.

Properties
 | Name | Description
Public property | PhysicalRules | Gets or sets the physical rules.
Top
See Also

Reference

ModifyReplicationSetRulesRequestModel Class


ModifyReplicationSetRulesRequestModel.PhysicalRules Property

ModifyReplicationSetRulesRequestModelPhysicalRules Property
Gets or sets the physical rules.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public PhysicalRuleModel[] PhysicalRules { get; set; }
Public Property PhysicalRules As PhysicalRuleModel()
    Get
    Set
public:
property array<PhysicalRuleModel^>^ PhysicalRules {
    array<PhysicalRuleModel^>^ get ();
    void set (array<PhysicalRuleModel^>^ value);
}
member PhysicalRules : PhysicalRuleModel[] with get, set

Property Value

Type: PhysicalRuleModel
The physical rules.
See Also

Reference

ModifyReplicationSetRulesRequestModel Class


ModifyReplicationSetRulesRequestModel Methods

ModifyReplicationSetRulesRequestModel Methods

The ModifyReplicationSetRulesRequestModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ModifyReplicationSetRulesRequestModel Class


MonitorableAddressInfoModel Class

MonitorableAddressInfoModel Class
Used to specify a monitorable IP address that can be used to configure a failover monitor.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMonitorableAddressInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class MonitorableAddressInfoModel
Public Class MonitorableAddressInfoModel
public ref class MonitorableAddressInfoModel
type MonitorableAddressInfoModel =  class end

The MonitorableAddressInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorableAddressInfoModel | Initializes a new instance of the MonitorableAddressInfoModel class
Top
Properties
 | Name | Description
Public property | Address | Gets or sets the IP address and subnet mask (IPv4-only) of an address that can be monitored from the target.
Public property | InterfaceMacAddress | Gets or sets the MAC address of the NIC on which this address resides.
Public property | TargetInterfaceGuids | Gets or sets a list of GUIDs specifying target NICs that can monitor this address.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MonitorableAddressInfoModel Constructor

MonitorableAddressInfoModel Constructor
Initializes a new instance of the MonitorableAddressInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public MonitorableAddressInfoModel()
Public Sub New
public:
MonitorableAddressInfoModel()
new : unit -> MonitorableAddressInfoModel
See Also

Reference

MonitorableAddressInfoModel Class


MonitorableAddressInfoModel Properties

MonitorableAddressInfoModel Properties

The MonitorableAddressInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Address | Gets or sets the IP address and subnet mask (IPv4-only) of an address that can be monitored from the target.
Public property | InterfaceMacAddress | Gets or sets the MAC address of the NIC on which this address resides.
Public property | TargetInterfaceGuids | Gets or sets a list of GUIDs specifying target NICs that can monitor this address.
Top
See Also

Reference

MonitorableAddressInfoModel Class


MonitorableAddressInfoModel.Address Property

MonitorableAddressInfoModelAddress Property
Gets or sets the IP address and subnet mask (IPv4-only) of an address that can be monitored from the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public UnicastIPAddressModel Address { get; set; }
Public Property Address As UnicastIPAddressModel
    Get
    Set
public:
property UnicastIPAddressModel^ Address {
    UnicastIPAddressModel^ get ();
    void set (UnicastIPAddressModel^ value);
}
member Address : UnicastIPAddressModel with get, set

Property Value

Type: UnicastIPAddressModel
See Also

Reference

MonitorableAddressInfoModel Class


MonitorableAddressInfoModel.InterfaceMacAddress Property

MonitorableAddressInfoModelInterfaceMacAddress Property
Gets or sets the MAC address of the NIC on which this address resides.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string InterfaceMacAddress { get; set; }
Public Property InterfaceMacAddress As String
    Get
    Set
public:
property String^ InterfaceMacAddress {
    String^ get ();
    void set (String^ value);
}
member InterfaceMacAddress : string with get, set

Property Value

Type: String
See Also

Reference

MonitorableAddressInfoModel Class


MonitorableAddressInfoModel.TargetInterfaceGuids Property

MonitorableAddressInfoModelTargetInterfaceGuids Property
Gets or sets a list of GUIDs specifying target NICs that can monitor this address.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string[] TargetInterfaceGuids { get; set; }
Public Property TargetInterfaceGuids As String()
    Get
    Set
public:
property array<String^>^ TargetInterfaceGuids {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member TargetInterfaceGuids : string[] with get, set

Property Value

Type: String
See Also

Reference

MonitorableAddressInfoModel Class


MonitorableAddressInfoModel Methods

MonitorableAddressInfoModel Methods

The MonitorableAddressInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonitorableAddressInfoModel Class


MonitorActionFlatModel Class

MonitorActionFlatModel Class
Represents an action that is run in the context of a monitor.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMonitorActionFlatModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class MonitorActionFlatModel
Public Class MonitorActionFlatModel
public ref class MonitorActionFlatModel
type MonitorActionFlatModel =  class end

The MonitorActionFlatModel type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorActionFlatModel | Initializes a new instance of the MonitorActionFlatModel class
Top
Properties
 | Name | Description
Public property | Input | Gets or sets the input arguments.
Public property | Name | Gets or sets the name.
Public property | RemoteServerCredentials | Gets or sets the remote server credentials.
Public property | RemoteServerUri | Gets or sets the remote server on which to run this action. Set this to to run the action locally.
Public property | Timeout | Gets or sets the timeout.
Public property | UniqueId | Gets or sets the unique id for this query.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MonitorActionFlatModel Constructor

MonitorActionFlatModel Constructor
Initializes a new instance of the MonitorActionFlatModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public MonitorActionFlatModel()
Public Sub New
public:
MonitorActionFlatModel()
new : unit -> MonitorActionFlatModel
See Also

Reference

MonitorActionFlatModel Class


MonitorActionFlatModel Properties

MonitorActionFlatModel Properties

The MonitorActionFlatModel type exposes the following members.

Properties
 | Name | Description
Public property | Input | Gets or sets the input arguments.
Public property | Name | Gets or sets the name.
Public property | RemoteServerCredentials | Gets or sets the remote server credentials.
Public property | RemoteServerUri | Gets or sets the remote server on which to run this action. Set this to to run the action locally.
Public property | Timeout | Gets or sets the timeout.
Public property | UniqueId | Gets or sets the unique id for this query.
Top
See Also

Reference

MonitorActionFlatModel Class


MonitorActionFlatModel.Input Property

MonitorActionFlatModelInput Property
Gets or sets the input arguments.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ActionInputFlatModel Input { get; set; }
Public Property Input As ActionInputFlatModel
    Get
    Set
public:
property ActionInputFlatModel^ Input {
    ActionInputFlatModel^ get ();
    void set (ActionInputFlatModel^ value);
}
member Input : ActionInputFlatModel with get, set

Property Value

Type: ActionInputFlatModel
The input arguments.
See Also

Reference

MonitorActionFlatModel Class


MonitorActionFlatModel.Name Property

MonitorActionFlatModelName Property
Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

MonitorActionFlatModel Class


MonitorActionFlatModel.RemoteServerCredentials Property

MonitorActionFlatModelRemoteServerCredentials Property
Gets or sets the remote server credentials.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CredentialModel RemoteServerCredentials { get; set; }
Public Property RemoteServerCredentials As CredentialModel
    Get
    Set
public:
property CredentialModel^ RemoteServerCredentials {
    CredentialModel^ get ();
    void set (CredentialModel^ value);
}
member RemoteServerCredentials : CredentialModel with get, set

Property Value

Type: CredentialModel
The remote server credentials.
See Also

Reference

MonitorActionFlatModel Class


MonitorActionFlatModel.RemoteServerUri Property

MonitorActionFlatModelRemoteServerUri Property
Gets or sets the remote server on which to run this action. Set this to to run the action locally.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Uri RemoteServerUri { get; set; }
Public Property RemoteServerUri As Uri
    Get
    Set
public:
property Uri^ RemoteServerUri {
    Uri^ get ();
    void set (Uri^ value);
}
member RemoteServerUri : Uri with get, set

Property Value

Type: Uri
The remote server.
See Also

Reference

MonitorActionFlatModel Class


MonitorActionFlatModel.Timeout Property

MonitorActionFlatModelTimeout Property
Gets or sets the timeout.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Timeout { get; set; }
Public Property Timeout As TimeSpan
    Get
    Set
public:
property TimeSpan Timeout {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Timeout : TimeSpan with get, set

Property Value

Type: TimeSpan
The timeout.
See Also

Reference

MonitorActionFlatModel Class


MonitorActionFlatModel.UniqueId Property

MonitorActionFlatModelUniqueId Property
Gets or sets the unique id for this query.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Guid UniqueId { get; set; }
Public Property UniqueId As Guid
    Get
    Set
public:
property Guid UniqueId {
    Guid get ();
    void set (Guid value);
}
member UniqueId : Guid with get, set

Property Value

Type: Guid
The unique id.
See Also

Reference

MonitorActionFlatModel Class


MonitorActionFlatModel Methods

MonitorActionFlatModel Methods

The MonitorActionFlatModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonitorActionFlatModel Class


MonitorActionModel Class

MonitorActionModel Class
Represents an action that is run in the context of a monitor.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMonitorActionModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class MonitorActionModel
Public Class MonitorActionModel
public ref class MonitorActionModel
type MonitorActionModel =  class end

The MonitorActionModel type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorActionModel | Initializes a new instance of the MonitorActionModel class
Top
Properties
 | Name | Description
Public property | Input | Gets or sets the input arguments.
Public property | Name | Gets or sets the name.
Public property | RemoteServerCredentials | Gets or sets the remote server credentials.
Public property | RemoteServerUri | Gets or sets the remote server on which to run this action. Set this to to run the action locally.
Public property | Timeout | Gets or sets the timeout.
Public property | UniqueId | Gets or sets the unique id for this query.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MonitorActionModel Constructor

MonitorActionModel Constructor
Initializes a new instance of the MonitorActionModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public MonitorActionModel()
Public Sub New
public:
MonitorActionModel()
new : unit -> MonitorActionModel
See Also

Reference

MonitorActionModel Class


MonitorActionModel Properties

MonitorActionModel Properties

The MonitorActionModel type exposes the following members.

Properties
 | Name | Description
Public property | Input | Gets or sets the input arguments.
Public property | Name | Gets or sets the name.
Public property | RemoteServerCredentials | Gets or sets the remote server credentials.
Public property | RemoteServerUri | Gets or sets the remote server on which to run this action. Set this to to run the action locally.
Public property | Timeout | Gets or sets the timeout.
Public property | UniqueId | Gets or sets the unique id for this query.
Top
See Also

Reference

MonitorActionModel Class


MonitorActionModel.Input Property

MonitorActionModelInput Property
Gets or sets the input arguments.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ActionInputModel Input { get; set; }
Public Property Input As ActionInputModel
    Get
    Set
public:
property ActionInputModel^ Input {
    ActionInputModel^ get ();
    void set (ActionInputModel^ value);
}
member Input : ActionInputModel with get, set

Property Value

Type: ActionInputModel
The input arguments.
See Also

Reference

MonitorActionModel Class


MonitorActionModel.Name Property

MonitorActionModelName Property
Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

MonitorActionModel Class


MonitorActionModel.RemoteServerCredentials Property

MonitorActionModelRemoteServerCredentials Property
Gets or sets the remote server credentials.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CredentialModel RemoteServerCredentials { get; set; }
Public Property RemoteServerCredentials As CredentialModel
    Get
    Set
public:
property CredentialModel^ RemoteServerCredentials {
    CredentialModel^ get ();
    void set (CredentialModel^ value);
}
member RemoteServerCredentials : CredentialModel with get, set

Property Value

Type: CredentialModel
The remote server credentials.
See Also

Reference

MonitorActionModel Class


MonitorActionModel.RemoteServerUri Property

MonitorActionModelRemoteServerUri Property
Gets or sets the remote server on which to run this action. Set this to to run the action locally.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Uri RemoteServerUri { get; set; }
Public Property RemoteServerUri As Uri
    Get
    Set
public:
property Uri^ RemoteServerUri {
    Uri^ get ();
    void set (Uri^ value);
}
member RemoteServerUri : Uri with get, set

Property Value

Type: Uri
The remote server.
See Also

Reference

MonitorActionModel Class


MonitorActionModel.Timeout Property

MonitorActionModelTimeout Property
Gets or sets the timeout.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Timeout { get; set; }
Public Property Timeout As TimeSpan
    Get
    Set
public:
property TimeSpan Timeout {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Timeout : TimeSpan with get, set

Property Value

Type: TimeSpan
The timeout.
See Also

Reference

MonitorActionModel Class


MonitorActionModel.UniqueId Property

MonitorActionModelUniqueId Property
Gets or sets the unique id for this query.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Guid UniqueId { get; set; }
Public Property UniqueId As Guid
    Get
    Set
public:
property Guid UniqueId {
    Guid get ();
    void set (Guid value);
}
member UniqueId : Guid with get, set

Property Value

Type: Guid
The unique id.
See Also

Reference

MonitorActionModel Class


MonitorActionModel Methods

MonitorActionModel Methods

The MonitorActionModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonitorActionModel Class


MonitorConfigurationModel Class

MonitorConfigurationModel Class
Monitor configuration model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMonitorConfigurationModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class MonitorConfigurationModel
Public NotInheritable Class MonitorConfigurationModel
public ref class MonitorConfigurationModel sealed
[<SealedAttribute>]
type MonitorConfigurationModel =  class end

The MonitorConfigurationModel type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorConfigurationModel | Initializes a new instance of the MonitorConfigurationModel class
Top
Properties
 | Name | Description
Public property | ActiveDirectoryCredentials | Gets or sets the active directory credentials.
Public property | ActiveDirectoryOptions | Gets or sets the active directory options.
Public property | Addresses | Gets or sets the array of monitor address configurations specifying the IP addresses to be monitored.
Public property | DataAction | Gets or sets the failover data action.
Public property | FailoverAddressesOption | Gets or sets the failover IP addresses option.
Public property | FailoverType | Gets or sets the failover type.
Public property | ItemsToFailover | Gets or sets the failover items.
Public property | MaxScriptFailures | Gets or sets the number of times the monitoring script can fail before giving up the script monitoring.
Public property | Name | Gets or sets the name of the failover monitor.
Public property | ProcessingOptions | Gets or sets the processing options.
Public property | ReplaceActions | Gets or sets the replace actions.
Public property | ScriptMonitorEngine | Gets or sets the script monitor engine.
Public property | ScriptMonitorName | Gets or sets the name of the script monitor.
Public property | Scripts | Gets or sets the failover script configuration.
Public property | SourceEndpoint | Gets or sets the source IP endpoint to be used to communicate with Double-Take on the source.
Public property | SSMLogPath | Gets or sets the SSM log path.
Public property | SSMManualReboot | Gets or sets a value indicating whether or not SSM manual reboot.
Public property | SSMRecoveryType | Gets or sets the type of the SSM recovery.
Public property | SSMSourceNicGuids | Gets or sets the SSM source NIC GUIDs.
Public property | SSMStagingPath | Gets or sets the SSM staging path.
Public property | SSMTargetNicGuids | Gets or sets the SSM target NIC GUIDs.
Public property | Trigger | Gets or sets the failover trigger.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MonitorConfigurationModel Constructor

MonitorConfigurationModel Constructor
Initializes a new instance of the MonitorConfigurationModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public MonitorConfigurationModel()
Public Sub New
public:
MonitorConfigurationModel()
new : unit -> MonitorConfigurationModel
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel Properties

MonitorConfigurationModel Properties

The MonitorConfigurationModel type exposes the following members.

Properties
 | Name | Description
Public property | ActiveDirectoryCredentials | Gets or sets the active directory credentials.
Public property | ActiveDirectoryOptions | Gets or sets the active directory options.
Public property | Addresses | Gets or sets the array of monitor address configurations specifying the IP addresses to be monitored.
Public property | DataAction | Gets or sets the failover data action.
Public property | FailoverAddressesOption | Gets or sets the failover IP addresses option.
Public property | FailoverType | Gets or sets the failover type.
Public property | ItemsToFailover | Gets or sets the failover items.
Public property | MaxScriptFailures | Gets or sets the number of times the monitoring script can fail before giving up the script monitoring.
Public property | Name | Gets or sets the name of the failover monitor.
Public property | ProcessingOptions | Gets or sets the processing options.
Public property | ReplaceActions | Gets or sets the replace actions.
Public property | ScriptMonitorEngine | Gets or sets the script monitor engine.
Public property | ScriptMonitorName | Gets or sets the name of the script monitor.
Public property | Scripts | Gets or sets the failover script configuration.
Public property | SourceEndpoint | Gets or sets the source IP endpoint to be used to communicate with Double-Take on the source.
Public property | SSMLogPath | Gets or sets the SSM log path.
Public property | SSMManualReboot | Gets or sets a value indicating whether or not SSM manual reboot.
Public property | SSMRecoveryType | Gets or sets the type of the SSM recovery.
Public property | SSMSourceNicGuids | Gets or sets the SSM source NIC GUIDs.
Public property | SSMStagingPath | Gets or sets the SSM staging path.
Public property | SSMTargetNicGuids | Gets or sets the SSM target NIC GUIDs.
Public property | Trigger | Gets or sets the failover trigger.
Top
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.ActiveDirectoryCredentials Property

MonitorConfigurationModelActiveDirectoryCredentials Property
Gets or sets the active directory credentials.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CredentialModel ActiveDirectoryCredentials { get; set; }
Public Property ActiveDirectoryCredentials As CredentialModel
    Get
    Set
public:
property CredentialModel^ ActiveDirectoryCredentials {
    CredentialModel^ get ();
    void set (CredentialModel^ value);
}
member ActiveDirectoryCredentials : CredentialModel with get, set

Property Value

Type: CredentialModel
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.ActiveDirectoryOptions Property

MonitorConfigurationModelActiveDirectoryOptions Property
Gets or sets the active directory options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ActiveDirectoryFailoverOptions ActiveDirectoryOptions { get; set; }
Public Property ActiveDirectoryOptions As ActiveDirectoryFailoverOptions
    Get
    Set
public:
property ActiveDirectoryFailoverOptions ActiveDirectoryOptions {
    ActiveDirectoryFailoverOptions get ();
    void set (ActiveDirectoryFailoverOptions value);
}
member ActiveDirectoryOptions : ActiveDirectoryFailoverOptions with get, set

Property Value

Type: ActiveDirectoryFailoverOptions
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.Addresses Property

MonitorConfigurationModelAddresses Property
Gets or sets the array of monitor address configurations specifying the IP addresses to be monitored.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public MonitoredAddressConfigurationModel[] Addresses { get; set; }
Public Property Addresses As MonitoredAddressConfigurationModel()
    Get
    Set
public:
property array<MonitoredAddressConfigurationModel^>^ Addresses {
    array<MonitoredAddressConfigurationModel^>^ get ();
    void set (array<MonitoredAddressConfigurationModel^>^ value);
}
member Addresses : MonitoredAddressConfigurationModel[] with get, set

Property Value

Type: MonitoredAddressConfigurationModel
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.DataAction Property

MonitorConfigurationModelDataAction Property
Gets or sets the failover data action.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverDataAction DataAction { get; set; }
Public Property DataAction As FailoverDataAction
    Get
    Set
public:
property FailoverDataAction DataAction {
    FailoverDataAction get ();
    void set (FailoverDataAction value);
}
member DataAction : FailoverDataAction with get, set

Property Value

Type: FailoverDataAction
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.FailoverAddressesOption Property

MonitorConfigurationModelFailoverAddressesOption Property
Gets or sets the failover IP addresses option.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverAddressesOption FailoverAddressesOption { get; set; }
Public Property FailoverAddressesOption As FailoverAddressesOption
    Get
    Set
public:
property FailoverAddressesOption FailoverAddressesOption {
    FailoverAddressesOption get ();
    void set (FailoverAddressesOption value);
}
member FailoverAddressesOption : FailoverAddressesOption with get, set

Property Value

Type: FailoverAddressesOption
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.FailoverType Property

MonitorConfigurationModelFailoverType Property
Gets or sets the failover type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverType FailoverType { get; set; }
Public Property FailoverType As FailoverType
    Get
    Set
public:
property FailoverType FailoverType {
    FailoverType get ();
    void set (FailoverType value);
}
member FailoverType : FailoverType with get, set

Property Value

Type: FailoverType
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.ItemsToFailover Property

MonitorConfigurationModelItemsToFailover Property
Gets or sets the failover items.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverItems ItemsToFailover { get; set; }
Public Property ItemsToFailover As FailoverItems
    Get
    Set
public:
property FailoverItems ItemsToFailover {
    FailoverItems get ();
    void set (FailoverItems value);
}
member ItemsToFailover : FailoverItems with get, set

Property Value

Type: FailoverItems
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.MaxScriptFailures Property

MonitorConfigurationModelMaxScriptFailures Property
Gets or sets the number of times the monitoring script can fail before giving up the script monitoring.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int MaxScriptFailures { get; set; }
Public Property MaxScriptFailures As Integer
    Get
    Set
public:
property int MaxScriptFailures {
    int get ();
    void set (int value);
}
member MaxScriptFailures : int with get, set

Property Value

Type: Int32
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.Name Property

MonitorConfigurationModelName Property
Gets or sets the name of the failover monitor.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.ProcessingOptions Property

MonitorConfigurationModelProcessingOptions Property
Gets or sets the processing options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverProcessingOptions ProcessingOptions { get; set; }
Public Property ProcessingOptions As FailoverProcessingOptions
    Get
    Set
public:
property FailoverProcessingOptions ProcessingOptions {
    FailoverProcessingOptions get ();
    void set (FailoverProcessingOptions value);
}
member ProcessingOptions : FailoverProcessingOptions with get, set

Property Value

Type: FailoverProcessingOptions
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.ReplaceActions Property

MonitorConfigurationModelReplaceActions Property
Gets or sets the replace actions.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverReplaceActions ReplaceActions { get; set; }
Public Property ReplaceActions As FailoverReplaceActions
    Get
    Set
public:
property FailoverReplaceActions ReplaceActions {
    FailoverReplaceActions get ();
    void set (FailoverReplaceActions value);
}
member ReplaceActions : FailoverReplaceActions with get, set

Property Value

Type: FailoverReplaceActions
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.ScriptMonitorEngine Property

MonitorConfigurationModelScriptMonitorEngine Property
Gets or sets the script monitor engine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ScriptMonitorEngine { get; set; }
Public Property ScriptMonitorEngine As String
    Get
    Set
public:
property String^ ScriptMonitorEngine {
    String^ get ();
    void set (String^ value);
}
member ScriptMonitorEngine : string with get, set

Property Value

Type: String
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.ScriptMonitorName Property

MonitorConfigurationModelScriptMonitorName Property
Gets or sets the name of the script monitor.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ScriptMonitorName { get; set; }
Public Property ScriptMonitorName As String
    Get
    Set
public:
property String^ ScriptMonitorName {
    String^ get ();
    void set (String^ value);
}
member ScriptMonitorName : string with get, set

Property Value

Type: String
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.Scripts Property

MonitorConfigurationModelScripts Property
Gets or sets the failover script configuration.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverScriptConfigurationModel Scripts { get; set; }
Public Property Scripts As FailoverScriptConfigurationModel
    Get
    Set
public:
property FailoverScriptConfigurationModel^ Scripts {
    FailoverScriptConfigurationModel^ get ();
    void set (FailoverScriptConfigurationModel^ value);
}
member Scripts : FailoverScriptConfigurationModel with get, set

Property Value

Type: FailoverScriptConfigurationModel
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.SourceEndpoint Property

MonitorConfigurationModelSourceEndpoint Property
Gets or sets the source IP endpoint to be used to communicate with Double-Take on the source.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceEndpoint { get; set; }
Public Property SourceEndpoint As String
    Get
    Set
public:
property String^ SourceEndpoint {
    String^ get ();
    void set (String^ value);
}
member SourceEndpoint : string with get, set

Property Value

Type: String
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.SSMLogPath Property

MonitorConfigurationModelSSMLogPath Property
Gets or sets the SSM log path.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SSMLogPath { get; set; }
Public Property SSMLogPath As String
    Get
    Set
public:
property String^ SSMLogPath {
    String^ get ();
    void set (String^ value);
}
member SSMLogPath : string with get, set

Property Value

Type: String
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.SSMManualReboot Property

MonitorConfigurationModelSSMManualReboot Property
Gets or sets a value indicating whether or not SSM manual reboot.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool SSMManualReboot { get; set; }
Public Property SSMManualReboot As Boolean
    Get
    Set
public:
property bool SSMManualReboot {
    bool get ();
    void set (bool value);
}
member SSMManualReboot : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.SSMRecoveryType Property

MonitorConfigurationModelSSMRecoveryType Property
Gets or sets the type of the SSM recovery.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public SsmRecoveryType SSMRecoveryType { get; set; }
Public Property SSMRecoveryType As SsmRecoveryType
    Get
    Set
public:
property SsmRecoveryType SSMRecoveryType {
    SsmRecoveryType get ();
    void set (SsmRecoveryType value);
}
member SSMRecoveryType : SsmRecoveryType with get, set

Property Value

Type: SsmRecoveryType
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.SSMSourceNicGuids Property

MonitorConfigurationModelSSMSourceNicGuids Property
Gets or sets the SSM source NIC GUIDs.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SSMSourceNicGuids { get; set; }
Public Property SSMSourceNicGuids As String
    Get
    Set
public:
property String^ SSMSourceNicGuids {
    String^ get ();
    void set (String^ value);
}
member SSMSourceNicGuids : string with get, set

Property Value

Type: String
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.SSMStagingPath Property

MonitorConfigurationModelSSMStagingPath Property
Gets or sets the SSM staging path.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SSMStagingPath { get; set; }
Public Property SSMStagingPath As String
    Get
    Set
public:
property String^ SSMStagingPath {
    String^ get ();
    void set (String^ value);
}
member SSMStagingPath : string with get, set

Property Value

Type: String
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.SSMTargetNicGuids Property

MonitorConfigurationModelSSMTargetNicGuids Property
Gets or sets the SSM target NIC GUIDs.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SSMTargetNicGuids { get; set; }
Public Property SSMTargetNicGuids As String
    Get
    Set
public:
property String^ SSMTargetNicGuids {
    String^ get ();
    void set (String^ value);
}
member SSMTargetNicGuids : string with get, set

Property Value

Type: String
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel.Trigger Property

MonitorConfigurationModelTrigger Property
Gets or sets the failover trigger.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverTrigger Trigger { get; set; }
Public Property Trigger As FailoverTrigger
    Get
    Set
public:
property FailoverTrigger Trigger {
    FailoverTrigger get ();
    void set (FailoverTrigger value);
}
member Trigger : FailoverTrigger with get, set

Property Value

Type: FailoverTrigger
See Also

Reference

MonitorConfigurationModel Class


MonitorConfigurationModel Methods

MonitorConfigurationModel Methods

The MonitorConfigurationModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonitorConfigurationModel Class


MonitoredAddressConfigurationModel Class

MonitoredAddressConfigurationModel Class
Monitored address configuration model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMonitoredAddressConfigurationModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class MonitoredAddressConfigurationModel
Public NotInheritable Class MonitoredAddressConfigurationModel
public ref class MonitoredAddressConfigurationModel sealed
[<SealedAttribute>]
type MonitoredAddressConfigurationModel =  class end

The MonitoredAddressConfigurationModel type exposes the following members.

Constructors
 | Name | Description
Public method | MonitoredAddressConfigurationModel | Initializes a new instance of the MonitoredAddressConfigurationModel class
Top
Properties
 | Name | Description
Public property | Address | Gets or sets the IP address.
Public property | EnginePort | Gets or sets the engine port.
Public property | MacAddress | Gets or sets the MAC address of the source NIC on which this address resides.
Public property | MaxPingAttempts | Gets or sets the maximum number of ping attempts before the IP address is considered to be failed.
Public property | NicName | Gets or sets the name of the target NIC to use to monitor this IP address.
Public property | PingInterval | Gets or sets the interval at which the source address is pinged to determine a failure condition.
Public property | PingMethods | Gets or sets the ping methods to be used to ping the IP address
Public property | SubnetMask | Gets or sets the subnet mask.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MonitoredAddressConfigurationModel Constructor

MonitoredAddressConfigurationModel Constructor
Initializes a new instance of the MonitoredAddressConfigurationModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public MonitoredAddressConfigurationModel()
Public Sub New
public:
MonitoredAddressConfigurationModel()
new : unit -> MonitoredAddressConfigurationModel
See Also

Reference

MonitoredAddressConfigurationModel Class


MonitoredAddressConfigurationModel Properties

MonitoredAddressConfigurationModel Properties

The MonitoredAddressConfigurationModel type exposes the following members.

Properties
 | Name | Description
Public property | Address | Gets or sets the IP address.
Public property | EnginePort | Gets or sets the engine port.
Public property | MacAddress | Gets or sets the MAC address of the source NIC on which this address resides.
Public property | MaxPingAttempts | Gets or sets the maximum number of ping attempts before the IP address is considered to be failed.
Public property | NicName | Gets or sets the name of the target NIC to use to monitor this IP address.
Public property | PingInterval | Gets or sets the interval at which the source address is pinged to determine a failure condition.
Public property | PingMethods | Gets or sets the ping methods to be used to ping the IP address
Public property | SubnetMask | Gets or sets the subnet mask.
Top
See Also

Reference

MonitoredAddressConfigurationModel Class


MonitoredAddressConfigurationModel.Address Property

MonitoredAddressConfigurationModelAddress Property
Gets or sets the IP address.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Address { get; set; }
Public Property Address As String
    Get
    Set
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}
member Address : string with get, set

Property Value

Type: String
See Also

Reference

MonitoredAddressConfigurationModel Class


MonitoredAddressConfigurationModel.EnginePort Property

MonitoredAddressConfigurationModelEnginePort Property
Gets or sets the engine port.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> EnginePort { get; set; }
Public Property EnginePort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> EnginePort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member EnginePort : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

MonitoredAddressConfigurationModel Class


MonitoredAddressConfigurationModel.MacAddress Property

MonitoredAddressConfigurationModelMacAddress Property
Gets or sets the MAC address of the source NIC on which this address resides.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string MacAddress { get; set; }
Public Property MacAddress As String
    Get
    Set
public:
property String^ MacAddress {
    String^ get ();
    void set (String^ value);
}
member MacAddress : string with get, set

Property Value

Type: String
See Also

Reference

MonitoredAddressConfigurationModel Class


MonitoredAddressConfigurationModel.MaxPingAttempts Property

MonitoredAddressConfigurationModelMaxPingAttempts Property
Gets or sets the maximum number of ping attempts before the IP address is considered to be failed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public short MaxPingAttempts { get; set; }
Public Property MaxPingAttempts As Short
    Get
    Set
public:
property short MaxPingAttempts {
    short get ();
    void set (short value);
}
member MaxPingAttempts : int16 with get, set

Property Value

Type: Int16
See Also

Reference

MonitoredAddressConfigurationModel Class


MonitoredAddressConfigurationModel.NicName Property

MonitoredAddressConfigurationModelNicName Property
Gets or sets the name of the target NIC to use to monitor this IP address.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string NicName { get; set; }
Public Property NicName As String
    Get
    Set
public:
property String^ NicName {
    String^ get ();
    void set (String^ value);
}
member NicName : string with get, set

Property Value

Type: String
See Also

Reference

MonitoredAddressConfigurationModel Class


MonitoredAddressConfigurationModel.PingInterval Property

MonitoredAddressConfigurationModelPingInterval Property
Gets or sets the interval at which the source address is pinged to determine a failure condition.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan PingInterval { get; set; }
Public Property PingInterval As TimeSpan
    Get
    Set
public:
property TimeSpan PingInterval {
    TimeSpan get ();
    void set (TimeSpan value);
}
member PingInterval : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

MonitoredAddressConfigurationModel Class


MonitoredAddressConfigurationModel.PingMethods Property

MonitoredAddressConfigurationModelPingMethods Property
Gets or sets the ping methods to be used to ping the IP address

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public PingMethods PingMethods { get; set; }
Public Property PingMethods As PingMethods
    Get
    Set
public:
property PingMethods PingMethods {
    PingMethods get ();
    void set (PingMethods value);
}
member PingMethods : PingMethods with get, set

Property Value

Type: PingMethods
See Also

Reference

MonitoredAddressConfigurationModel Class


MonitoredAddressConfigurationModel.SubnetMask Property

MonitoredAddressConfigurationModelSubnetMask Property
Gets or sets the subnet mask.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SubnetMask { get; set; }
Public Property SubnetMask As String
    Get
    Set
public:
property String^ SubnetMask {
    String^ get ();
    void set (String^ value);
}
member SubnetMask : string with get, set

Property Value

Type: String
See Also

Reference

MonitoredAddressConfigurationModel Class


MonitoredAddressConfigurationModel Methods

MonitoredAddressConfigurationModel Methods

The MonitoredAddressConfigurationModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonitoredAddressConfigurationModel Class


MonitoredAddressStatusModel Class

MonitoredAddressStatusModel Class
Monitored address status.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMonitoredAddressStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class MonitoredAddressStatusModel
Public NotInheritable Class MonitoredAddressStatusModel
public ref class MonitoredAddressStatusModel sealed
[<SealedAttribute>]
type MonitoredAddressStatusModel =  class end

The MonitoredAddressStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | MonitoredAddressStatusModel | Initializes a new instance of the MonitoredAddressStatusModel class
Top
Properties
 | Name | Description
Public property | Address | Gets or sets the IP address that is being monitored.
Public property | Alive | Gets or sets a value indicating whether the IP address is responding to ping attempts.
Public property | FailoverConditionMet | Gets or sets a value indicating whether the IP addresses is considered failed.
Public property | RemainingTime | Gets or sets the time remaining before the IP address is considered failed.
Public property | WarningConditionMet | Gets or sets a value indicating whether the IP address is considered in a warning condition.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MonitoredAddressStatusModel Constructor

MonitoredAddressStatusModel Constructor
Initializes a new instance of the MonitoredAddressStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public MonitoredAddressStatusModel()
Public Sub New
public:
MonitoredAddressStatusModel()
new : unit -> MonitoredAddressStatusModel
See Also

Reference

MonitoredAddressStatusModel Class


MonitoredAddressStatusModel Properties

MonitoredAddressStatusModel Properties

The MonitoredAddressStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | Address | Gets or sets the IP address that is being monitored.
Public property | Alive | Gets or sets a value indicating whether the IP address is responding to ping attempts.
Public property | FailoverConditionMet | Gets or sets a value indicating whether the IP addresses is considered failed.
Public property | RemainingTime | Gets or sets the time remaining before the IP address is considered failed.
Public property | WarningConditionMet | Gets or sets a value indicating whether the IP address is considered in a warning condition.
Top
See Also

Reference

MonitoredAddressStatusModel Class


MonitoredAddressStatusModel.Address Property

MonitoredAddressStatusModelAddress Property
Gets or sets the IP address that is being monitored.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Address { get; set; }
Public Property Address As String
    Get
    Set
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}
member Address : string with get, set

Property Value

Type: String
See Also

Reference

MonitoredAddressStatusModel Class


MonitoredAddressStatusModel.Alive Property

MonitoredAddressStatusModelAlive Property
Gets or sets a value indicating whether the IP address is responding to ping attempts.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool Alive { get; set; }
Public Property Alive As Boolean
    Get
    Set
public:
property bool Alive {
    bool get ();
    void set (bool value);
}
member Alive : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MonitoredAddressStatusModel Class


MonitoredAddressStatusModel.FailoverConditionMet Property

MonitoredAddressStatusModelFailoverConditionMet Property
Gets or sets a value indicating whether the IP addresses is considered failed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool FailoverConditionMet { get; set; }
Public Property FailoverConditionMet As Boolean
    Get
    Set
public:
property bool FailoverConditionMet {
    bool get ();
    void set (bool value);
}
member FailoverConditionMet : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MonitoredAddressStatusModel Class


MonitoredAddressStatusModel.RemainingTime Property

MonitoredAddressStatusModelRemainingTime Property
Gets or sets the time remaining before the IP address is considered failed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan RemainingTime { get; set; }
Public Property RemainingTime As TimeSpan
    Get
    Set
public:
property TimeSpan RemainingTime {
    TimeSpan get ();
    void set (TimeSpan value);
}
member RemainingTime : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

MonitoredAddressStatusModel Class


MonitoredAddressStatusModel.WarningConditionMet Property

MonitoredAddressStatusModelWarningConditionMet Property
Gets or sets a value indicating whether the IP address is considered in a warning condition.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool WarningConditionMet { get; set; }
Public Property WarningConditionMet As Boolean
    Get
    Set
public:
property bool WarningConditionMet {
    bool get ();
    void set (bool value);
}
member WarningConditionMet : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MonitoredAddressStatusModel Class


MonitoredAddressStatusModel Methods

MonitoredAddressStatusModel Methods

The MonitoredAddressStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonitoredAddressStatusModel Class


MonitorInfoModel Class

MonitorInfoModel Class
Monitor information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMonitorInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class MonitorInfoModel
Public Class MonitorInfoModel
public ref class MonitorInfoModel
type MonitorInfoModel =  class end

The MonitorInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorInfoModel | Initializes a new instance of the MonitorInfoModel class
Top
Properties
 | Name | Description
Public property | Configuration | Gets or sets the MonitorConfiguration.
Public property | Guid | Gets or sets the unique id of the monitor.
Public property | Name | Gets or sets the name of the monitor.
Public property | Status | Gets or sets the MonitorStatus.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MonitorInfoModel Constructor

MonitorInfoModel Constructor
Initializes a new instance of the MonitorInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public MonitorInfoModel()
Public Sub New
public:
MonitorInfoModel()
new : unit -> MonitorInfoModel
See Also

Reference

MonitorInfoModel Class


MonitorInfoModel Properties

MonitorInfoModel Properties

The MonitorInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Configuration | Gets or sets the MonitorConfiguration.
Public property | Guid | Gets or sets the unique id of the monitor.
Public property | Name | Gets or sets the name of the monitor.
Public property | Status | Gets or sets the MonitorStatus.
Top
See Also

Reference

MonitorInfoModel Class


MonitorInfoModel.Configuration Property

MonitorInfoModelConfiguration Property
Gets or sets the MonitorConfiguration.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public MonitorConfigurationModel Configuration { get; set; }
Public Property Configuration As MonitorConfigurationModel
    Get
    Set
public:
property MonitorConfigurationModel^ Configuration {
    MonitorConfigurationModel^ get ();
    void set (MonitorConfigurationModel^ value);
}
member Configuration : MonitorConfigurationModel with get, set

Property Value

Type: MonitorConfigurationModel
The MonitorConfiguration.
See Also

Reference

MonitorInfoModel Class


MonitorInfoModel.Guid Property

MonitorInfoModelGuid Property
Gets or sets the unique id of the monitor.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Guid Guid { get; set; }
Public Property Guid As Guid
    Get
    Set
public:
property Guid Guid {
    Guid get ();
    void set (Guid value);
}
member Guid : Guid with get, set

Property Value

Type: Guid
The unique id of the monitor.
See Also

Reference

MonitorInfoModel Class


MonitorInfoModel.Name Property

MonitorInfoModelName Property
Gets or sets the name of the monitor.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name of the monitor.
Remarks
This is typically the host name or IP address of the source machine.
See Also

Reference

MonitorInfoModel Class


MonitorInfoModel.Status Property

MonitorInfoModelStatus Property
Gets or sets the MonitorStatus.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public MonitorStatusModel Status { get; set; }
Public Property Status As MonitorStatusModel
    Get
    Set
public:
property MonitorStatusModel^ Status {
    MonitorStatusModel^ get ();
    void set (MonitorStatusModel^ value);
}
member Status : MonitorStatusModel with get, set

Property Value

Type: MonitorStatusModel
The MonitorStatus.
See Also

Reference

MonitorInfoModel Class


MonitorInfoModel Methods

MonitorInfoModel Methods

The MonitorInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonitorInfoModel Class


MonitoringOptionsModel Class

MonitoringOptionsModel Class
Monitoring options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMonitoringOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class MonitoringOptionsModel
Public NotInheritable Class MonitoringOptionsModel
public ref class MonitoringOptionsModel sealed
[<SealedAttribute>]
type MonitoringOptionsModel =  class end

The MonitoringOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | MonitoringOptionsModel | Initializes a new instance of the MonitoringOptionsModel class
Top
Properties
 | Name | Description
Public property | ServiceMonitoringEnabled | Gets or sets a value indicating whether service monitoring is enabled.
Public property | ServiceMonitoringOptions | Gets or sets the service monitoring options.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MonitoringOptionsModel Constructor

MonitoringOptionsModel Constructor
Initializes a new instance of the MonitoringOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public MonitoringOptionsModel()
Public Sub New
public:
MonitoringOptionsModel()
new : unit -> MonitoringOptionsModel
See Also

Reference

MonitoringOptionsModel Class


MonitoringOptionsModel Properties

MonitoringOptionsModel Properties

The MonitoringOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | ServiceMonitoringEnabled | Gets or sets a value indicating whether service monitoring is enabled.
Public property | ServiceMonitoringOptions | Gets or sets the service monitoring options.
Top
See Also

Reference

MonitoringOptionsModel Class


MonitoringOptionsModel.ServiceMonitoringEnabled Property

MonitoringOptionsModelServiceMonitoringEnabled Property
Gets or sets a value indicating whether service monitoring is enabled.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool ServiceMonitoringEnabled { get; set; }
Public Property ServiceMonitoringEnabled As Boolean
    Get
    Set
public:
property bool ServiceMonitoringEnabled {
    bool get ();
    void set (bool value);
}
member ServiceMonitoringEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MonitoringOptionsModel Class


MonitoringOptionsModel.ServiceMonitoringOptions Property

MonitoringOptionsModelServiceMonitoringOptions Property
Gets or sets the service monitoring options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ServiceMonitoringOptionsModel ServiceMonitoringOptions { get; set; }
Public Property ServiceMonitoringOptions As ServiceMonitoringOptionsModel
    Get
    Set
public:
property ServiceMonitoringOptionsModel^ ServiceMonitoringOptions {
    ServiceMonitoringOptionsModel^ get ();
    void set (ServiceMonitoringOptionsModel^ value);
}
member ServiceMonitoringOptions : ServiceMonitoringOptionsModel with get, set

Property Value

Type: ServiceMonitoringOptionsModel
See Also

Reference

MonitoringOptionsModel Class


MonitoringOptionsModel Methods

MonitoringOptionsModel Methods

The MonitoringOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonitoringOptionsModel Class


MonitorQualificationResultModel Class

MonitorQualificationResultModel Class
An instance of this class is returned from a QualifyMonitor operation on the ICoreService service.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMonitorQualificationResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class MonitorQualificationResultModel
Public NotInheritable Class MonitorQualificationResultModel
public ref class MonitorQualificationResultModel sealed
[<SealedAttribute>]
type MonitorQualificationResultModel =  class end

The MonitorQualificationResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorQualificationResultModel | Initializes a new instance of the MonitorQualificationResultModel class
Top
Properties
 | Name | Description
Public property | DefaultMonitor | Gets or sets a pre-populated monitor with default values for the configuration properties.
Public property | IsQualified | Gets or sets a value indicating whether or not the machine in question can be monitored.
Public property | MonitorableAddresses | Gets or sets a list of monitorable addresses from the target's point of view.
Public property | SourceMachineName | Gets or sets the host name of the machine to be monitored. Use this name for the name of the monitor being created.
Public property | TargetInterfaces | Gets or sets information about all the network interfaces on the target machine.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MonitorQualificationResultModel Constructor

MonitorQualificationResultModel Constructor
Initializes a new instance of the MonitorQualificationResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public MonitorQualificationResultModel()
Public Sub New
public:
MonitorQualificationResultModel()
new : unit -> MonitorQualificationResultModel
See Also

Reference

MonitorQualificationResultModel Class


MonitorQualificationResultModel Properties

MonitorQualificationResultModel Properties

The MonitorQualificationResultModel type exposes the following members.

Properties
 | Name | Description
Public property | DefaultMonitor | Gets or sets a pre-populated monitor with default values for the configuration properties.
Public property | IsQualified | Gets or sets a value indicating whether or not the machine in question can be monitored.
Public property | MonitorableAddresses | Gets or sets a list of monitorable addresses from the target's point of view.
Public property | SourceMachineName | Gets or sets the host name of the machine to be monitored. Use this name for the name of the monitor being created.
Public property | TargetInterfaces | Gets or sets information about all the network interfaces on the target machine.
Top
See Also

Reference

MonitorQualificationResultModel Class


MonitorQualificationResultModel.DefaultMonitor Property

MonitorQualificationResultModelDefaultMonitor Property
Gets or sets a pre-populated monitor with default values for the configuration properties.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public MonitorConfigurationModel DefaultMonitor { get; set; }
Public Property DefaultMonitor As MonitorConfigurationModel
    Get
    Set
public:
property MonitorConfigurationModel^ DefaultMonitor {
    MonitorConfigurationModel^ get ();
    void set (MonitorConfigurationModel^ value);
}
member DefaultMonitor : MonitorConfigurationModel with get, set

Property Value

Type: MonitorConfigurationModel
See Also

Reference

MonitorQualificationResultModel Class


MonitorQualificationResultModel.IsQualified Property

MonitorQualificationResultModelIsQualified Property
Gets or sets a value indicating whether or not the machine in question can be monitored.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsQualified { get; set; }
Public Property IsQualified As Boolean
    Get
    Set
public:
property bool IsQualified {
    bool get ();
    void set (bool value);
}
member IsQualified : bool with get, set

Property Value

Type: Boolean
See Also

Reference

MonitorQualificationResultModel Class


MonitorQualificationResultModel.MonitorableAddresses Property

MonitorQualificationResultModelMonitorableAddresses Property
Gets or sets a list of monitorable addresses from the target's point of view.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public MonitorableAddressInfoModel[] MonitorableAddresses { get; set; }
Public Property MonitorableAddresses As MonitorableAddressInfoModel()
    Get
    Set
public:
property array<MonitorableAddressInfoModel^>^ MonitorableAddresses {
    array<MonitorableAddressInfoModel^>^ get ();
    void set (array<MonitorableAddressInfoModel^>^ value);
}
member MonitorableAddresses : MonitorableAddressInfoModel[] with get, set

Property Value

Type: MonitorableAddressInfoModel
See Also

Reference

MonitorQualificationResultModel Class


MonitorQualificationResultModel.SourceMachineName Property

MonitorQualificationResultModelSourceMachineName Property
Gets or sets the host name of the machine to be monitored. Use this name for the name of the monitor being created.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SourceMachineName { get; set; }
Public Property SourceMachineName As String
    Get
    Set
public:
property String^ SourceMachineName {
    String^ get ();
    void set (String^ value);
}
member SourceMachineName : string with get, set

Property Value

Type: String
See Also

Reference

MonitorQualificationResultModel Class


MonitorQualificationResultModel.TargetInterfaces Property

MonitorQualificationResultModelTargetInterfaces Property
Gets or sets information about all the network interfaces on the target machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public NetworkInterfaceInfoModel[] TargetInterfaces { get; set; }
Public Property TargetInterfaces As NetworkInterfaceInfoModel()
    Get
    Set
public:
property array<NetworkInterfaceInfoModel^>^ TargetInterfaces {
    array<NetworkInterfaceInfoModel^>^ get ();
    void set (array<NetworkInterfaceInfoModel^>^ value);
}
member TargetInterfaces : NetworkInterfaceInfoModel[] with get, set

Property Value

Type: NetworkInterfaceInfoModel
See Also

Reference

MonitorQualificationResultModel Class


MonitorQualificationResultModel Methods

MonitorQualificationResultModel Methods

The MonitorQualificationResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonitorQualificationResultModel Class


MonitorQueryFlatModel Class

MonitorQueryFlatModel Class
Monitor query flat.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMonitorQueryFlatModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class MonitorQueryFlatModel
Public Class MonitorQueryFlatModel
public ref class MonitorQueryFlatModel
type MonitorQueryFlatModel =  class end

The MonitorQueryFlatModel type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorQueryFlatModel | Initializes a new instance of the MonitorQueryFlatModel class
Top
Properties
 | Name | Description
Public property | Input | Gets or sets the input.
Public property | Name | Gets or sets the name.
Public property | RemoteServerCredentials | Gets or sets the remote server credentials.
Public property | RemoteServerUri | Gets or sets the remote server URI.
Public property | Timeout | Gets or sets the timeout.
Public property | UniqueId | Gets or sets the unique id for this query.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MonitorQueryFlatModel Constructor

MonitorQueryFlatModel Constructor
Initializes a new instance of the MonitorQueryFlatModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public MonitorQueryFlatModel()
Public Sub New
public:
MonitorQueryFlatModel()
new : unit -> MonitorQueryFlatModel
See Also

Reference

MonitorQueryFlatModel Class


MonitorQueryFlatModel Properties

MonitorQueryFlatModel Properties

The MonitorQueryFlatModel type exposes the following members.

Properties
 | Name | Description
Public property | Input | Gets or sets the input.
Public property | Name | Gets or sets the name.
Public property | RemoteServerCredentials | Gets or sets the remote server credentials.
Public property | RemoteServerUri | Gets or sets the remote server URI.
Public property | Timeout | Gets or sets the timeout.
Public property | UniqueId | Gets or sets the unique id for this query.
Top
See Also

Reference

MonitorQueryFlatModel Class


MonitorQueryFlatModel.Input Property

MonitorQueryFlatModelInput Property
Gets or sets the input.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public QueryInputFlatModel Input { get; set; }
Public Property Input As QueryInputFlatModel
    Get
    Set
public:
property QueryInputFlatModel^ Input {
    QueryInputFlatModel^ get ();
    void set (QueryInputFlatModel^ value);
}
member Input : QueryInputFlatModel with get, set

Property Value

Type: QueryInputFlatModel
The input.
See Also

Reference

MonitorQueryFlatModel Class


MonitorQueryFlatModel.Name Property

MonitorQueryFlatModelName Property
Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

MonitorQueryFlatModel Class


MonitorQueryFlatModel.RemoteServerCredentials Property

MonitorQueryFlatModelRemoteServerCredentials Property
Gets or sets the remote server credentials.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CredentialModel RemoteServerCredentials { get; set; }
Public Property RemoteServerCredentials As CredentialModel
    Get
    Set
public:
property CredentialModel^ RemoteServerCredentials {
    CredentialModel^ get ();
    void set (CredentialModel^ value);
}
member RemoteServerCredentials : CredentialModel with get, set

Property Value

Type: CredentialModel
The remote server credentials.
See Also

Reference

MonitorQueryFlatModel Class


MonitorQueryFlatModel.RemoteServerUri Property

MonitorQueryFlatModelRemoteServerUri Property
Gets or sets the remote server URI.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Uri RemoteServerUri { get; set; }
Public Property RemoteServerUri As Uri
    Get
    Set
public:
property Uri^ RemoteServerUri {
    Uri^ get ();
    void set (Uri^ value);
}
member RemoteServerUri : Uri with get, set

Property Value

Type: Uri
The remote server URI.
See Also

Reference

MonitorQueryFlatModel Class


MonitorQueryFlatModel.Timeout Property

MonitorQueryFlatModelTimeout Property
Gets or sets the timeout.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Timeout { get; set; }
Public Property Timeout As TimeSpan
    Get
    Set
public:
property TimeSpan Timeout {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Timeout : TimeSpan with get, set

Property Value

Type: TimeSpan
The timeout.
See Also

Reference

MonitorQueryFlatModel Class


MonitorQueryFlatModel.UniqueId Property

MonitorQueryFlatModelUniqueId Property
Gets or sets the unique id for this query.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Guid UniqueId { get; set; }
Public Property UniqueId As Guid
    Get
    Set
public:
property Guid UniqueId {
    Guid get ();
    void set (Guid value);
}
member UniqueId : Guid with get, set

Property Value

Type: Guid
The unique id.
See Also

Reference

MonitorQueryFlatModel Class


MonitorQueryFlatModel Methods

MonitorQueryFlatModel Methods

The MonitorQueryFlatModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonitorQueryFlatModel Class


MonitorQueryModel Class

MonitorQueryModel Class
This class is part of the MonitorActivity class which contains both query and action.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMonitorQueryModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class MonitorQueryModel
Public Class MonitorQueryModel
public ref class MonitorQueryModel
type MonitorQueryModel =  class end

The MonitorQueryModel type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorQueryModel | Initializes a new instance of the MonitorQueryModel class
Top
Properties
 | Name | Description
Public property | Input | Gets or sets the input.
Public property | Name | Gets or sets the name.
Public property | RemoteServerCredentials | Gets or sets the remote server credentials.
Public property | RemoteServerUri | Gets or sets the remote server URI.
Public property | Timeout | Gets or sets the timeout.
Public property | UniqueId | Gets or sets the unique id for this query.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MonitorQueryModel Constructor

MonitorQueryModel Constructor
Initializes a new instance of the MonitorQueryModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public MonitorQueryModel()
Public Sub New
public:
MonitorQueryModel()
new : unit -> MonitorQueryModel
See Also

Reference

MonitorQueryModel Class


MonitorQueryModel Properties

MonitorQueryModel Properties

The MonitorQueryModel type exposes the following members.

Properties
 | Name | Description
Public property | Input | Gets or sets the input.
Public property | Name | Gets or sets the name.
Public property | RemoteServerCredentials | Gets or sets the remote server credentials.
Public property | RemoteServerUri | Gets or sets the remote server URI.
Public property | Timeout | Gets or sets the timeout.
Public property | UniqueId | Gets or sets the unique id for this query.
Top
See Also

Reference

MonitorQueryModel Class


MonitorQueryModel.Input Property

MonitorQueryModelInput Property
Gets or sets the input.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public QueryInputModel Input { get; set; }
Public Property Input As QueryInputModel
    Get
    Set
public:
property QueryInputModel^ Input {
    QueryInputModel^ get ();
    void set (QueryInputModel^ value);
}
member Input : QueryInputModel with get, set

Property Value

Type: QueryInputModel
The input.
See Also

Reference

MonitorQueryModel Class


MonitorQueryModel.Name Property

MonitorQueryModelName Property
Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

MonitorQueryModel Class


MonitorQueryModel.RemoteServerCredentials Property

MonitorQueryModelRemoteServerCredentials Property
Gets or sets the remote server credentials.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CredentialModel RemoteServerCredentials { get; set; }
Public Property RemoteServerCredentials As CredentialModel
    Get
    Set
public:
property CredentialModel^ RemoteServerCredentials {
    CredentialModel^ get ();
    void set (CredentialModel^ value);
}
member RemoteServerCredentials : CredentialModel with get, set

Property Value

Type: CredentialModel
The remote server credentials.
See Also

Reference

MonitorQueryModel Class


MonitorQueryModel.RemoteServerUri Property

MonitorQueryModelRemoteServerUri Property
Gets or sets the remote server URI.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Uri RemoteServerUri { get; set; }
Public Property RemoteServerUri As Uri
    Get
    Set
public:
property Uri^ RemoteServerUri {
    Uri^ get ();
    void set (Uri^ value);
}
member RemoteServerUri : Uri with get, set

Property Value

Type: Uri
The remote server URI.
See Also

Reference

MonitorQueryModel Class


MonitorQueryModel.Timeout Property

MonitorQueryModelTimeout Property
Gets or sets the timeout.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Timeout { get; set; }
Public Property Timeout As TimeSpan
    Get
    Set
public:
property TimeSpan Timeout {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Timeout : TimeSpan with get, set

Property Value

Type: TimeSpan
The timeout.
See Also

Reference

MonitorQueryModel Class


MonitorQueryModel.UniqueId Property

MonitorQueryModelUniqueId Property
Gets or sets the unique id for this query.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Guid UniqueId { get; set; }
Public Property UniqueId As Guid
    Get
    Set
public:
property Guid UniqueId {
    Guid get ();
    void set (Guid value);
}
member UniqueId : Guid with get, set

Property Value

Type: Guid
The unique id.
See Also

Reference

MonitorQueryModel Class


MonitorQueryModel Methods

MonitorQueryModel Methods

The MonitorQueryModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonitorQueryModel Class


MonitorResultEnum Enumeration

MonitorResultEnum Enumeration
Monitor result

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public enum MonitorResultEnum
Public Enumeration MonitorResultEnum
public enum class MonitorResultEnum
type MonitorResultEnum
Members
Member name | Value | Description
Success | 0 | The success
Failure | 1 | The failure
Indeterminate | 2 | The indeterminate
See Also

Reference

DoubleTake.Web.Models Namespace


MonitorStatusModel Class

MonitorStatusModel Class
Monitor status.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsMonitorStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class MonitorStatusModel
Public Class MonitorStatusModel
public ref class MonitorStatusModel
type MonitorStatusModel =  class end

The MonitorStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | MonitorStatusModel | Initializes a new instance of the MonitorStatusModel class
Top
Properties
 | Name | Description
Public property | Addresses | Gets or sets the addresses that are being monitored.
Public property | Name | Gets or sets the name of the monitor.
Public property | RestoreStates | Gets or sets the RestoreStates.
Public property | Status | Gets or sets the HighAvailabilityState.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MonitorStatusModel Constructor

MonitorStatusModel Constructor
Initializes a new instance of the MonitorStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public MonitorStatusModel()
Public Sub New
public:
MonitorStatusModel()
new : unit -> MonitorStatusModel
See Also

Reference

MonitorStatusModel Class


MonitorStatusModel Properties

MonitorStatusModel Properties

The MonitorStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | Addresses | Gets or sets the addresses that are being monitored.
Public property | Name | Gets or sets the name of the monitor.
Public property | RestoreStates | Gets or sets the RestoreStates.
Public property | Status | Gets or sets the HighAvailabilityState.
Top
See Also

Reference

MonitorStatusModel Class


MonitorStatusModel.Addresses Property

MonitorStatusModelAddresses Property
Gets or sets the addresses that are being monitored.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public MonitoredAddressStatusModel[] Addresses { get; set; }
Public Property Addresses As MonitoredAddressStatusModel()
    Get
    Set
public:
property array<MonitoredAddressStatusModel^>^ Addresses {
    array<MonitoredAddressStatusModel^>^ get ();
    void set (array<MonitoredAddressStatusModel^>^ value);
}
member Addresses : MonitoredAddressStatusModel[] with get, set

Property Value

Type: MonitoredAddressStatusModel
The addresses.
See Also

Reference

MonitorStatusModel Class


MonitorStatusModel.Name Property

MonitorStatusModelName Property
Gets or sets the name of the monitor.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name of the monitor.
Remarks
The name of the monitor is usually the
See Also

Reference

MonitorStatusModel Class


MonitorStatusModel.RestoreStates Property

MonitorStatusModelRestoreStates Property
Gets or sets the RestoreStates.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public RestoreStates RestoreStates { get; set; }
Public Property RestoreStates As RestoreStates
    Get
    Set
public:
property RestoreStates RestoreStates {
    RestoreStates get ();
    void set (RestoreStates value);
}
member RestoreStates : RestoreStates with get, set

Property Value

Type: RestoreStates
The RestoreStates.
See Also

Reference

MonitorStatusModel Class


MonitorStatusModel.Status Property

MonitorStatusModelStatus Property
Gets or sets the HighAvailabilityState.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public HighAvailabilityState Status { get; set; }
Public Property Status As HighAvailabilityState
    Get
    Set
public:
property HighAvailabilityState Status {
    HighAvailabilityState get ();
    void set (HighAvailabilityState value);
}
member Status : HighAvailabilityState with get, set

Property Value

Type: HighAvailabilityState
The HighAvailabilityState.
See Also

Reference

MonitorStatusModel Class


MonitorStatusModel Methods

MonitorStatusModel Methods

The MonitorStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MonitorStatusModel Class


MultiStringSettingModel Class

MultiStringSettingModel Class
Multi-string setting.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsNamedSettingModel
DoubleTake.Web.ModelsMultiStringSettingModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class MultiStringSettingModel : NamedSettingModel
Public Class MultiStringSettingModel
    Inherits NamedSettingModel
public ref class MultiStringSettingModel : public NamedSettingModel
type MultiStringSettingModel =
    class
        inherit NamedSettingModel
    end

The MultiStringSettingModel type exposes the following members.

Constructors
 | Name | Description
Public method | MultiStringSettingModel | Initializes a new instance of the MultiStringSettingModel class
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name. (Inherited from NamedSettingModel.)
Public property | TypeName | Gets or sets the type name. (Inherited from NamedSettingModel.)
Public property | Value | Gets or sets the value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


MultiStringSettingModel Constructor

MultiStringSettingModel Constructor
Initializes a new instance of the MultiStringSettingModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public MultiStringSettingModel()
Public Sub New
public:
MultiStringSettingModel()
new : unit -> MultiStringSettingModel
See Also

Reference

MultiStringSettingModel Class


MultiStringSettingModel Properties

MultiStringSettingModel Properties

The MultiStringSettingModel type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name. (Inherited from NamedSettingModel.)
Public property | TypeName | Gets or sets the type name. (Inherited from NamedSettingModel.)
Public property | Value | Gets or sets the value.
Top
See Also

Reference

MultiStringSettingModel Class


MultiStringSettingModel.Value Property

MultiStringSettingModelValue Property
Gets or sets the value.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string[] Value { get; set; }
Public Property Value As String()
    Get
    Set
public:
property array<String^>^ Value {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member Value : string[] with get, set

Property Value

Type: String
See Also

Reference

MultiStringSettingModel Class


MultiStringSettingModel Methods

MultiStringSettingModel Methods

The MultiStringSettingModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

MultiStringSettingModel Class


NamedSettingModel Class

NamedSettingModel Class
Named setting.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsNamedSettingModel
DoubleTake.Web.ModelsBooleanSettingModel
DoubleTake.Web.ModelsIntegerSettingModel
DoubleTake.Web.ModelsMultiStringSettingModel
DoubleTake.Web.ModelsStringSettingModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class NamedSettingModel
Public Class NamedSettingModel
public ref class NamedSettingModel
type NamedSettingModel =  class end

The NamedSettingModel type exposes the following members.

Constructors
 | Name | Description
Public method | NamedSettingModel | Initializes a new instance of the NamedSettingModel class
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name.
Public property | TypeName | Gets or sets the type name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


NamedSettingModel Constructor

NamedSettingModel Constructor
Initializes a new instance of the NamedSettingModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public NamedSettingModel()
Public Sub New
public:
NamedSettingModel()
new : unit -> NamedSettingModel
See Also

Reference

NamedSettingModel Class


NamedSettingModel Properties

NamedSettingModel Properties

The NamedSettingModel type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name.
Public property | TypeName | Gets or sets the type name.
Top
See Also

Reference

NamedSettingModel Class


NamedSettingModel.Name Property

NamedSettingModelName Property
Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

NamedSettingModel Class


NamedSettingModel.TypeName Property

NamedSettingModelTypeName Property
Gets or sets the type name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string TypeName { get; set; }
Public Property TypeName As String
    Get
    Set
public:
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}
member TypeName : string with get, set

Property Value

Type: String
See Also

Reference

NamedSettingModel Class


NamedSettingModel Methods

NamedSettingModel Methods

The NamedSettingModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NamedSettingModel Class


NetworkAddressMapModel Class

NetworkAddressMapModel Class
Network address map model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsNetworkAddressMapModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class NetworkAddressMapModel
Public NotInheritable Class NetworkAddressMapModel
public ref class NetworkAddressMapModel sealed
[<SealedAttribute>]
type NetworkAddressMapModel =  class end

The NetworkAddressMapModel type exposes the following members.

Constructors
 | Name | Description
Public method | NetworkAddressMapModel | Initializes a new instance of the NetworkAddressMapModel class
Top
Properties
 | Name | Description
Public property | ShouldUpdateTtl | Gets or sets a value indicating whether the time-to-live value should be updated for this record.
Public property | SourceIP | Gets or sets the IP address on the source server.
Public property | TargetIP | Gets or sets the IP address on the target server.
Public property | TtlValue | Gets or sets the TTL value, in seconds.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


NetworkAddressMapModel Constructor

NetworkAddressMapModel Constructor
Initializes a new instance of the NetworkAddressMapModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public NetworkAddressMapModel()
Public Sub New
public:
NetworkAddressMapModel()
new : unit -> NetworkAddressMapModel
See Also

Reference

NetworkAddressMapModel Class


NetworkAddressMapModel Properties

NetworkAddressMapModel Properties

The NetworkAddressMapModel type exposes the following members.

Properties
 | Name | Description
Public property | ShouldUpdateTtl | Gets or sets a value indicating whether the time-to-live value should be updated for this record.
Public property | SourceIP | Gets or sets the IP address on the source server.
Public property | TargetIP | Gets or sets the IP address on the target server.
Public property | TtlValue | Gets or sets the TTL value, in seconds.
Top
See Also

Reference

NetworkAddressMapModel Class


NetworkAddressMapModel.ShouldUpdateTtl Property

NetworkAddressMapModelShouldUpdateTtl Property
Gets or sets a value indicating whether the time-to-live value should be updated for this record.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldUpdateTtl { get; set; }
Public Property ShouldUpdateTtl As Boolean
    Get
    Set
public:
property bool ShouldUpdateTtl {
    bool get ();
    void set (bool value);
}
member ShouldUpdateTtl : bool with get, set

Property Value

Type: Boolean
See Also

Reference

NetworkAddressMapModel Class


NetworkAddressMapModel.SourceIP Property

NetworkAddressMapModelSourceIP Property
Gets or sets the IP address on the source server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceIP { get; set; }
Public Property SourceIP As String
    Get
    Set
public:
property String^ SourceIP {
    String^ get ();
    void set (String^ value);
}
member SourceIP : string with get, set

Property Value

Type: String
See Also

Reference

NetworkAddressMapModel Class


NetworkAddressMapModel.TargetIP Property

NetworkAddressMapModelTargetIP Property
Gets or sets the IP address on the target server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetIP { get; set; }
Public Property TargetIP As String
    Get
    Set
public:
property String^ TargetIP {
    String^ get ();
    void set (String^ value);
}
member TargetIP : string with get, set

Property Value

Type: String
See Also

Reference

NetworkAddressMapModel Class


NetworkAddressMapModel.TtlValue Property

NetworkAddressMapModelTtlValue Property
Gets or sets the TTL value, in seconds.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int TtlValue { get; set; }
Public Property TtlValue As Integer
    Get
    Set
public:
property int TtlValue {
    int get ();
    void set (int value);
}
member TtlValue : int with get, set

Property Value

Type: Int32
See Also

Reference

NetworkAddressMapModel Class


NetworkAddressMapModel Methods

NetworkAddressMapModel Methods

The NetworkAddressMapModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NetworkAddressMapModel Class


NetworkInterfaceInfoModel Class

NetworkInterfaceInfoModel Class
Network interface info model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsNetworkInterfaceInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class NetworkInterfaceInfoModel
Public NotInheritable Class NetworkInterfaceInfoModel
public ref class NetworkInterfaceInfoModel sealed
[<SealedAttribute>]
type NetworkInterfaceInfoModel =  class end

The NetworkInterfaceInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | NetworkInterfaceInfoModel | Initializes a new instance of the NetworkInterfaceInfoModel class
Top
Properties
 | Name | Description
Public property | Addresses | Gets or sets a value that represents the IP addresses on the network interface.
Public property | Description | Gets or sets the description of the network interface.
Public property | DnsDomain | Gets or sets the DNS Domain.
Public property | DnsServers | Gets or sets the DNS servers.
Public property | Gateways | Gets or sets the gateways.
Public property | Guid | Gets or sets a value that represents the unique identifier of the network interface.
Public property | Index | Gets or sets the index of the network interface.
Public property | InterfaceIndex | Gets or sets the index of the network interface.
Public property | MacAddress | Gets or sets the MAC address.
Public property | Name | Gets or sets a value that represents the friendly name of the network interface.
Public property | PnpInstanceId | Gets or sets the PNP instance id.
Public property | ServiceName | Gets or sets the service name of the network interface.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


NetworkInterfaceInfoModel Constructor

NetworkInterfaceInfoModel Constructor
Initializes a new instance of the NetworkInterfaceInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public NetworkInterfaceInfoModel()
Public Sub New
public:
NetworkInterfaceInfoModel()
new : unit -> NetworkInterfaceInfoModel
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel Properties

NetworkInterfaceInfoModel Properties

The NetworkInterfaceInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Addresses | Gets or sets a value that represents the IP addresses on the network interface.
Public property | Description | Gets or sets the description of the network interface.
Public property | DnsDomain | Gets or sets the DNS Domain.
Public property | DnsServers | Gets or sets the DNS servers.
Public property | Gateways | Gets or sets the gateways.
Public property | Guid | Gets or sets a value that represents the unique identifier of the network interface.
Public property | Index | Gets or sets the index of the network interface.
Public property | InterfaceIndex | Gets or sets the index of the network interface.
Public property | MacAddress | Gets or sets the MAC address.
Public property | Name | Gets or sets a value that represents the friendly name of the network interface.
Public property | PnpInstanceId | Gets or sets the PNP instance id.
Public property | ServiceName | Gets or sets the service name of the network interface.
Top
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel.Addresses Property

NetworkInterfaceInfoModelAddresses Property
Gets or sets a value that represents the IP addresses on the network interface.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public UnicastNetworkAddressInfoModel[] Addresses { get; set; }
Public Property Addresses As UnicastNetworkAddressInfoModel()
    Get
    Set
public:
property array<UnicastNetworkAddressInfoModel^>^ Addresses {
    array<UnicastNetworkAddressInfoModel^>^ get ();
    void set (array<UnicastNetworkAddressInfoModel^>^ value);
}
member Addresses : UnicastNetworkAddressInfoModel[] with get, set

Property Value

Type: UnicastNetworkAddressInfoModel
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel.Description Property

NetworkInterfaceInfoModelDescription Property
Gets or sets the description of the network interface.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel.DnsDomain Property

NetworkInterfaceInfoModelDnsDomain Property
Gets or sets the DNS Domain.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string DnsDomain { get; set; }
Public Property DnsDomain As String
    Get
    Set
public:
property String^ DnsDomain {
    String^ get ();
    void set (String^ value);
}
member DnsDomain : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel.DnsServers Property

NetworkInterfaceInfoModelDnsServers Property
Gets or sets the DNS servers.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] DnsServers { get; set; }
Public Property DnsServers As String()
    Get
    Set
public:
property array<String^>^ DnsServers {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member DnsServers : string[] with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel.Gateways Property

NetworkInterfaceInfoModelGateways Property
Gets or sets the gateways.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] Gateways { get; set; }
Public Property Gateways As String()
    Get
    Set
public:
property array<String^>^ Gateways {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member Gateways : string[] with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel.Guid Property

NetworkInterfaceInfoModelGuid Property
Gets or sets a value that represents the unique identifier of the network interface.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Guid { get; set; }
Public Property Guid As String
    Get
    Set
public:
property String^ Guid {
    String^ get ();
    void set (String^ value);
}
member Guid : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel.Index Property

NetworkInterfaceInfoModelIndex Property
Gets or sets the index of the network interface.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set
public:
property int Index {
    int get ();
    void set (int value);
}
member Index : int with get, set

Property Value

Type: Int32
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel.InterfaceIndex Property

NetworkInterfaceInfoModelInterfaceIndex Property
Gets or sets the index of the network interface.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int InterfaceIndex { get; set; }
Public Property InterfaceIndex As Integer
    Get
    Set
public:
property int InterfaceIndex {
    int get ();
    void set (int value);
}
member InterfaceIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel.MacAddress Property

NetworkInterfaceInfoModelMacAddress Property
Gets or sets the MAC address.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string MacAddress { get; set; }
Public Property MacAddress As String
    Get
    Set
public:
property String^ MacAddress {
    String^ get ();
    void set (String^ value);
}
member MacAddress : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel.Name Property

NetworkInterfaceInfoModelName Property
Gets or sets a value that represents the friendly name of the network interface.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel.PnpInstanceId Property

NetworkInterfaceInfoModelPnpInstanceId Property
Gets or sets the PNP instance id.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string PnpInstanceId { get; set; }
Public Property PnpInstanceId As String
    Get
    Set
public:
property String^ PnpInstanceId {
    String^ get ();
    void set (String^ value);
}
member PnpInstanceId : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel.ServiceName Property

NetworkInterfaceInfoModelServiceName Property
Gets or sets the service name of the network interface.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
member ServiceName : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceInfoModel Methods

NetworkInterfaceInfoModel Methods

The NetworkInterfaceInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NetworkInterfaceInfoModel Class


NetworkInterfaceModel Class

NetworkInterfaceModel Class
Network interface model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsNetworkInterfaceModel
DoubleTake.Web.ModelsVirtualNetworkInterfaceInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public class NetworkInterfaceModel
Public Class NetworkInterfaceModel
public ref class NetworkInterfaceModel
type NetworkInterfaceModel =  class end

The NetworkInterfaceModel type exposes the following members.

Constructors
 | Name | Description
Public method | NetworkInterfaceModel | Initializes a new instance of the NetworkInterfaceModel class
Top
Properties
 | Name | Description
Public property | Description | Gets or sets the description of the network interface.
Public property | DnsDomain | Gets or sets the DNS Domain.
Public property | DnsServers | Gets or sets the DNS servers.
Public property | Gateways | Gets or sets the gateways.
Public property | Id | Gets or sets the unique identifier of the network interface.
Public property | Index | Gets or sets the index of the network interface.
Public property | InterfaceIndex | Gets or sets the index of the network interface.
Public property | IPAddresses | Gets or sets the IP addresses on the network interface.
Public property | MacAddress | Gets or sets the MAC address.
Public property | Name | Gets or sets the friendly name of the network interface.
Public property | PnpInstanceId | Gets or sets the PNP instance id.
Public property | ServiceName | Gets or sets the service name of the network interface.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


NetworkInterfaceModel Constructor

NetworkInterfaceModel Constructor
Initializes a new instance of the NetworkInterfaceModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public NetworkInterfaceModel()
Public Sub New
public:
NetworkInterfaceModel()
new : unit -> NetworkInterfaceModel
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel Properties

NetworkInterfaceModel Properties

The NetworkInterfaceModel type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets or sets the description of the network interface.
Public property | DnsDomain | Gets or sets the DNS Domain.
Public property | DnsServers | Gets or sets the DNS servers.
Public property | Gateways | Gets or sets the gateways.
Public property | Id | Gets or sets the unique identifier of the network interface.
Public property | Index | Gets or sets the index of the network interface.
Public property | InterfaceIndex | Gets or sets the index of the network interface.
Public property | IPAddresses | Gets or sets the IP addresses on the network interface.
Public property | MacAddress | Gets or sets the MAC address.
Public property | Name | Gets or sets the friendly name of the network interface.
Public property | PnpInstanceId | Gets or sets the PNP instance id.
Public property | ServiceName | Gets or sets the service name of the network interface.
Top
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel.Description Property

NetworkInterfaceModelDescription Property
Gets or sets the description of the network interface.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}
member Description : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel.DnsDomain Property

NetworkInterfaceModelDnsDomain Property
Gets or sets the DNS Domain.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string DnsDomain { get; set; }
Public Property DnsDomain As String
    Get
    Set
public:
property String^ DnsDomain {
    String^ get ();
    void set (String^ value);
}
member DnsDomain : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel.DnsServers Property

NetworkInterfaceModelDnsServers Property
Gets or sets the DNS servers.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] DnsServers { get; set; }
Public Property DnsServers As String()
    Get
    Set
public:
property array<String^>^ DnsServers {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member DnsServers : string[] with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel.Gateways Property

NetworkInterfaceModelGateways Property
Gets or sets the gateways.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] Gateways { get; set; }
Public Property Gateways As String()
    Get
    Set
public:
property array<String^>^ Gateways {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member Gateways : string[] with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel.Id Property

NetworkInterfaceModelId Property
Gets or sets the unique identifier of the network interface.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
member Id : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel.Index Property

NetworkInterfaceModelIndex Property
Gets or sets the index of the network interface.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set
public:
property int Index {
    int get ();
    void set (int value);
}
member Index : int with get, set

Property Value

Type: Int32
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel.InterfaceIndex Property

NetworkInterfaceModelInterfaceIndex Property
Gets or sets the index of the network interface.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int InterfaceIndex { get; set; }
Public Property InterfaceIndex As Integer
    Get
    Set
public:
property int InterfaceIndex {
    int get ();
    void set (int value);
}
member InterfaceIndex : int with get, set

Property Value

Type: Int32
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel.IPAddresses Property

NetworkInterfaceModelIPAddresses Property
Gets or sets the IP addresses on the network interface.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public UnicastIPAddressModel[] IPAddresses { get; set; }
Public Property IPAddresses As UnicastIPAddressModel()
    Get
    Set
public:
property array<UnicastIPAddressModel^>^ IPAddresses {
    array<UnicastIPAddressModel^>^ get ();
    void set (array<UnicastIPAddressModel^>^ value);
}
member IPAddresses : UnicastIPAddressModel[] with get, set

Property Value

Type: UnicastIPAddressModel
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel.MacAddress Property

NetworkInterfaceModelMacAddress Property
Gets or sets the MAC address.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string MacAddress { get; set; }
Public Property MacAddress As String
    Get
    Set
public:
property String^ MacAddress {
    String^ get ();
    void set (String^ value);
}
member MacAddress : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel.Name Property

NetworkInterfaceModelName Property
Gets or sets the friendly name of the network interface.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel.PnpInstanceId Property

NetworkInterfaceModelPnpInstanceId Property
Gets or sets the PNP instance id.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string PnpInstanceId { get; set; }
Public Property PnpInstanceId As String
    Get
    Set
public:
property String^ PnpInstanceId {
    String^ get ();
    void set (String^ value);
}
member PnpInstanceId : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel.ServiceName Property

NetworkInterfaceModelServiceName Property
Gets or sets the service name of the network interface.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
member ServiceName : string with get, set

Property Value

Type: String
See Also

Reference

NetworkInterfaceModel Class


NetworkInterfaceModel Methods

NetworkInterfaceModel Methods

The NetworkInterfaceModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NetworkInterfaceModel Class


NicMappingsModel Class

NicMappingsModel Class
NIC mapping.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsNicMappingsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class NicMappingsModel
Public Class NicMappingsModel
public ref class NicMappingsModel
type NicMappingsModel =  class end

The NicMappingsModel type exposes the following members.

Constructors
 | Name | Description
Public method | NicMappingsModel | Initializes a new instance of the NicMappingsModel class
Top
Properties
 | Name | Description
Public property | FullServerNicMappings | Gets or sets the full server nic mappings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


NicMappingsModel Constructor

NicMappingsModel Constructor
Initializes a new instance of the NicMappingsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public NicMappingsModel()
Public Sub New
public:
NicMappingsModel()
new : unit -> NicMappingsModel
See Also

Reference

NicMappingsModel Class


NicMappingsModel Properties

NicMappingsModel Properties

The NicMappingsModel type exposes the following members.

Properties
 | Name | Description
Public property | FullServerNicMappings | Gets or sets the full server nic mappings.
Top
See Also

Reference

NicMappingsModel Class


NicMappingsModel.FullServerNicMappings Property

NicMappingsModelFullServerNicMappings Property
Gets or sets the full server nic mappings.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public FullServerNicMappingsModel[] FullServerNicMappings { get; set; }
Public Property FullServerNicMappings As FullServerNicMappingsModel()
    Get
    Set
public:
property array<FullServerNicMappingsModel^>^ FullServerNicMappings {
    array<FullServerNicMappingsModel^>^ get ();
    void set (array<FullServerNicMappingsModel^>^ value);
}
member FullServerNicMappings : FullServerNicMappingsModel[] with get, set

Property Value

Type: FullServerNicMappingsModel
The full server nic mappings.
See Also

Reference

NicMappingsModel Class


NicMappingsModel Methods

NicMappingsModel Methods

The NicMappingsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NicMappingsModel Class


OperatingSystemArchitecture Enumeration

OperatingSystemArchitecture Enumeration
Operating system architecture.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum OperatingSystemArchitecture
Public Enumeration OperatingSystemArchitecture
public enum class OperatingSystemArchitecture
type OperatingSystemArchitecture
Members
Member name | Value | Description
x86 | 0 | The X86
x64 | 9 | The X64
ia64 | 6 | The ia64
See Also

Reference

DoubleTake.Web.Models Namespace


OperatingSystemModel Class

OperatingSystemModel Class
Operating system model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsOperatingSystemModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public class OperatingSystemModel
Public Class OperatingSystemModel
public ref class OperatingSystemModel
type OperatingSystemModel =  class end

The OperatingSystemModel type exposes the following members.

Constructors
 | Name | Description
Public method | OperatingSystemModel | Initializes a new instance of the OperatingSystemModel class
Top
Properties
 | Name | Description
Public property | Architecture | Gets or sets the architecture of the operating system.
Public property | CsdVersion | Gets or sets the service pack number.
Public property | HasBCDTemplate | Gets or sets a value indicating whether the BCDTemplate file exists on the source machine.
Public property | ProductSuite | Gets or sets a bit mask that identifies the product suites available on the system.
Public property | ProductType | Gets or sets the product type of the operating system.
Public property | ServicePack | Gets or sets the service pack number of the operating system.
Public property | Version | Gets or sets the version of the operating system.
Public property | VersionString | Gets or sets the version of the operating system.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


OperatingSystemModel Constructor

OperatingSystemModel Constructor
Initializes a new instance of the OperatingSystemModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public OperatingSystemModel()
Public Sub New
public:
OperatingSystemModel()
new : unit -> OperatingSystemModel
See Also

Reference

OperatingSystemModel Class


OperatingSystemModel Properties

OperatingSystemModel Properties

The OperatingSystemModel type exposes the following members.

Properties
 | Name | Description
Public property | Architecture | Gets or sets the architecture of the operating system.
Public property | CsdVersion | Gets or sets the service pack number.
Public property | HasBCDTemplate | Gets or sets a value indicating whether the BCDTemplate file exists on the source machine.
Public property | ProductSuite | Gets or sets a bit mask that identifies the product suites available on the system.
Public property | ProductType | Gets or sets the product type of the operating system.
Public property | ServicePack | Gets or sets the service pack number of the operating system.
Public property | Version | Gets or sets the version of the operating system.
Public property | VersionString | Gets or sets the version of the operating system.
Top
See Also

Reference

OperatingSystemModel Class


OperatingSystemModel.Architecture Property

OperatingSystemModelArchitecture Property
Gets or sets the architecture of the operating system.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public OperatingSystemArchitecture Architecture { get; set; }
Public Property Architecture As OperatingSystemArchitecture
    Get
    Set
public:
property OperatingSystemArchitecture Architecture {
    OperatingSystemArchitecture get ();
    void set (OperatingSystemArchitecture value);
}
member Architecture : OperatingSystemArchitecture with get, set

Property Value

Type: OperatingSystemArchitecture
See Also

Reference

OperatingSystemModel Class


OperatingSystemModel.CsdVersion Property

OperatingSystemModelCsdVersion Property
Gets or sets the service pack number.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int CsdVersion { get; set; }
Public Property CsdVersion As Integer
    Get
    Set
public:
property int CsdVersion {
    int get ();
    void set (int value);
}
member CsdVersion : int with get, set

Property Value

Type: Int32
See Also

Reference

OperatingSystemModel Class


OperatingSystemModel.HasBCDTemplate Property

OperatingSystemModelHasBCDTemplate Property
Gets or sets a value indicating whether the BCDTemplate file exists on the source machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasBCDTemplate { get; set; }
Public Property HasBCDTemplate As Boolean
    Get
    Set
public:
property bool HasBCDTemplate {
    bool get ();
    void set (bool value);
}
member HasBCDTemplate : bool with get, set

Property Value

Type: Boolean
See Also

Reference

OperatingSystemModel Class


OperatingSystemModel.ProductSuite Property

OperatingSystemModelProductSuite Property
Gets or sets a bit mask that identifies the product suites available on the system.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int ProductSuite { get; set; }
Public Property ProductSuite As Integer
    Get
    Set
public:
property int ProductSuite {
    int get ();
    void set (int value);
}
member ProductSuite : int with get, set

Property Value

Type: Int32
See Also

Reference

OperatingSystemModel Class


OperatingSystemModel.ProductType Property

OperatingSystemModelProductType Property
Gets or sets the product type of the operating system.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public OperatingSystemProductType ProductType { get; set; }
Public Property ProductType As OperatingSystemProductType
    Get
    Set
public:
property OperatingSystemProductType ProductType {
    OperatingSystemProductType get ();
    void set (OperatingSystemProductType value);
}
member ProductType : OperatingSystemProductType with get, set

Property Value

Type: OperatingSystemProductType
See Also

Reference

OperatingSystemModel Class


OperatingSystemModel.ServicePack Property

OperatingSystemModelServicePack Property
Gets or sets the service pack number of the operating system.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ServicePack { get; set; }
Public Property ServicePack As String
    Get
    Set
public:
property String^ ServicePack {
    String^ get ();
    void set (String^ value);
}
member ServicePack : string with get, set

Property Value

Type: String
See Also

Reference

OperatingSystemModel Class


OperatingSystemModel.Version Property

OperatingSystemModelVersion Property
Gets or sets the version of the operating system.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public OperatingSystemVersionModel Version { get; set; }
Public Property Version As OperatingSystemVersionModel
    Get
    Set
public:
property OperatingSystemVersionModel^ Version {
    OperatingSystemVersionModel^ get ();
    void set (OperatingSystemVersionModel^ value);
}
member Version : OperatingSystemVersionModel with get, set

Property Value

Type: OperatingSystemVersionModel
See Also

Reference

OperatingSystemModel Class


OperatingSystemModel.VersionString Property

OperatingSystemModelVersionString Property
Gets or sets the version of the operating system.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string VersionString { get; set; }
Public Property VersionString As String
    Get
    Set
public:
property String^ VersionString {
    String^ get ();
    void set (String^ value);
}
member VersionString : string with get, set

Property Value

Type: String
See Also

Reference

OperatingSystemModel Class


OperatingSystemModel Methods

OperatingSystemModel Methods

The OperatingSystemModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OperatingSystemModel Class


OperatingSystemProductType Enumeration

OperatingSystemProductType Enumeration
Operating system product type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum OperatingSystemProductType
Public Enumeration OperatingSystemProductType
public enum class OperatingSystemProductType
type OperatingSystemProductType
Members
Member name | Value | Description
None | 0 | The none
Workstation | 1 | The workstation
DomainController | 2 | The domain controller
Server | 3 | The server
See Also

Reference

DoubleTake.Web.Models Namespace


OperatingSystemVersionModel Class

OperatingSystemVersionModel Class
Operating system version model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsOperatingSystemVersionModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public class OperatingSystemVersionModel
Public Class OperatingSystemVersionModel
public ref class OperatingSystemVersionModel
type OperatingSystemVersionModel =  class end

The OperatingSystemVersionModel type exposes the following members.

Constructors
 | Name | Description
Public method | OperatingSystemVersionModel | Initializes a new instance of the OperatingSystemVersionModel class
Top
Properties
 | Name | Description
Public property | Build | Gets or sets the build number of the operating system.
Public property | Major | Gets or sets the major version of the operating system.
Public property | Minor | Gets or sets the minor version of the operating system.
Public property | Revision | Gets or sets the revision number of the operating system.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


OperatingSystemVersionModel Constructor

OperatingSystemVersionModel Constructor
Initializes a new instance of the OperatingSystemVersionModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public OperatingSystemVersionModel()
Public Sub New
public:
OperatingSystemVersionModel()
new : unit -> OperatingSystemVersionModel
See Also

Reference

OperatingSystemVersionModel Class


OperatingSystemVersionModel Properties

OperatingSystemVersionModel Properties

The OperatingSystemVersionModel type exposes the following members.

Properties
 | Name | Description
Public property | Build | Gets or sets the build number of the operating system.
Public property | Major | Gets or sets the major version of the operating system.
Public property | Minor | Gets or sets the minor version of the operating system.
Public property | Revision | Gets or sets the revision number of the operating system.
Top
See Also

Reference

OperatingSystemVersionModel Class


OperatingSystemVersionModel.Build Property

OperatingSystemVersionModelBuild Property
Gets or sets the build number of the operating system.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int Build { get; set; }
Public Property Build As Integer
    Get
    Set
public:
property int Build {
    int get ();
    void set (int value);
}
member Build : int with get, set

Property Value

Type: Int32
See Also

Reference

OperatingSystemVersionModel Class


OperatingSystemVersionModel.Major Property

OperatingSystemVersionModelMajor Property
Gets or sets the major version of the operating system.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int Major { get; set; }
Public Property Major As Integer
    Get
    Set
public:
property int Major {
    int get ();
    void set (int value);
}
member Major : int with get, set

Property Value

Type: Int32
See Also

Reference

OperatingSystemVersionModel Class


OperatingSystemVersionModel.Minor Property

OperatingSystemVersionModelMinor Property
Gets or sets the minor version of the operating system.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int Minor { get; set; }
Public Property Minor As Integer
    Get
    Set
public:
property int Minor {
    int get ();
    void set (int value);
}
member Minor : int with get, set

Property Value

Type: Int32
See Also

Reference

OperatingSystemVersionModel Class


OperatingSystemVersionModel.Revision Property

OperatingSystemVersionModelRevision Property
Gets or sets the revision number of the operating system.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int Revision { get; set; }
Public Property Revision As Integer
    Get
    Set
public:
property int Revision {
    int get ();
    void set (int value);
}
member Revision : int with get, set

Property Value

Type: Int32
See Also

Reference

OperatingSystemVersionModel Class


OperatingSystemVersionModel Methods

OperatingSystemVersionModel Methods

The OperatingSystemVersionModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OperatingSystemVersionModel Class


OptionModel Class

OptionModel Class
Option model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsOptionModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class OptionModel
Public NotInheritable Class OptionModel
public ref class OptionModel sealed
[<SealedAttribute>]
type OptionModel =  class end

The OptionModel type exposes the following members.

Constructors
 | Name | Description
Public method | OptionModel | Initializes a new instance of the OptionModel class
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name.
Public property | Value | Gets or sets the value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


OptionModel Constructor

OptionModel Constructor
Initializes a new instance of the OptionModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public OptionModel()
Public Sub New
public:
OptionModel()
new : unit -> OptionModel
See Also

Reference

OptionModel Class


OptionModel Properties

OptionModel Properties

The OptionModel type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name.
Public property | Value | Gets or sets the value.
Top
See Also

Reference

OptionModel Class


OptionModel.Name Property

OptionModelName Property
Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

OptionModel Class


OptionModel.Value Property

OptionModelValue Property
Gets or sets the value.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Property Value

Type: Object
See Also

Reference

OptionModel Class


OptionModel Methods

OptionModel Methods

The OptionModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OptionModel Class


OptionRequestModel Class

OptionRequestModel Class
Options request.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsOptionRequestModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class OptionRequestModel
Public NotInheritable Class OptionRequestModel
public ref class OptionRequestModel sealed
[<SealedAttribute>]
type OptionRequestModel =  class end

The OptionRequestModel type exposes the following members.

Constructors
 | Name | Description
Public method | OptionRequestModel | Initializes a new instance of the OptionRequestModel class
Top
Properties
 | Name | Description
Public property | Options | Gets or sets the options.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


OptionRequestModel Constructor

OptionRequestModel Constructor
Initializes a new instance of the OptionRequestModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public OptionRequestModel()
Public Sub New
public:
OptionRequestModel()
new : unit -> OptionRequestModel
See Also

Reference

OptionRequestModel Class


OptionRequestModel Properties

OptionRequestModel Properties

The OptionRequestModel type exposes the following members.

Properties
 | Name | Description
Public property | Options | Gets or sets the options.
Top
See Also

Reference

OptionRequestModel Class


OptionRequestModel.Options Property

OptionRequestModelOptions Property
Gets or sets the options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public OptionModel[] Options { get; set; }
Public Property Options As OptionModel()
    Get
    Set
public:
property array<OptionModel^>^ Options {
    array<OptionModel^>^ get ();
    void set (array<OptionModel^>^ value);
}
member Options : OptionModel[] with get, set

Property Value

Type: OptionModel
The options.
See Also

Reference

OptionRequestModel Class


OptionRequestModel Methods

OptionRequestModel Methods

The OptionRequestModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OptionRequestModel Class


OptionValueModel Class

OptionValueModel Class
Options value.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsOptionValueModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class OptionValueModel
Public NotInheritable Class OptionValueModel
public ref class OptionValueModel sealed
[<SealedAttribute>]
type OptionValueModel =  class end

The OptionValueModel type exposes the following members.

Constructors
 | Name | Description
Public method | OptionValueModel | Initializes a new instance of the OptionValueModel class
Top
Properties
 | Name | Description
Public property | Value | Gets or sets the value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


OptionValueModel Constructor

OptionValueModel Constructor
Initializes a new instance of the OptionValueModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public OptionValueModel()
Public Sub New
public:
OptionValueModel()
new : unit -> OptionValueModel
See Also

Reference

OptionValueModel Class


OptionValueModel Properties

OptionValueModel Properties

The OptionValueModel type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets or sets the value.
Top
See Also

Reference

OptionValueModel Class


OptionValueModel.Value Property

OptionValueModelValue Property
Gets or sets the value.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set
public:
property Object^ Value {
    Object^ get ();
    void set (Object^ value);
}
member Value : Object with get, set

Property Value

Type: Object
The value.
See Also

Reference

OptionValueModel Class


OptionValueModel Methods

OptionValueModel Methods

The OptionValueModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OptionValueModel Class


OrphansScheduleModel Class

OrphansScheduleModel Class
Orphans schedule model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsScheduleItemModel
DoubleTake.Web.ModelsOrphansScheduleModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class OrphansScheduleModel : ScheduleItemModel
Public NotInheritable Class OrphansScheduleModel
    Inherits ScheduleItemModel
public ref class OrphansScheduleModel sealed : public ScheduleItemModel
[<SealedAttribute>]
type OrphansScheduleModel =
    class
        inherit ScheduleItemModel
    end

The OrphansScheduleModel type exposes the following members.

Constructors
 | Name | Description
Public method | OrphansScheduleModel | Initializes a new instance of the OrphansScheduleModel class
Top
Properties
 | Name | Description
Public property | IsEnabled | Gets or sets a value indicating whether or not the item is enabled. (Inherited from ScheduleItemModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


OrphansScheduleModel Constructor

OrphansScheduleModel Constructor
Initializes a new instance of the OrphansScheduleModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public OrphansScheduleModel()
Public Sub New
public:
OrphansScheduleModel()
new : unit -> OrphansScheduleModel
See Also

Reference

OrphansScheduleModel Class


OrphansScheduleModel Properties

OrphansScheduleModel Properties

The OrphansScheduleModel type exposes the following members.

Properties
 | Name | Description
Public property | IsEnabled | Gets or sets a value indicating whether or not the item is enabled. (Inherited from ScheduleItemModel.)
Top
See Also

Reference

OrphansScheduleModel Class


OrphansScheduleModel Methods

OrphansScheduleModel Methods

The OrphansScheduleModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

OrphansScheduleModel Class


PartitionModel Class

PartitionModel Class
Represents a partition info for a volume.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsPartitionModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public class PartitionModel
Public Class PartitionModel
public ref class PartitionModel
type PartitionModel =  class end

The PartitionModel type exposes the following members.

Constructors
 | Name | Description
Public method | PartitionModel | Initializes a new instance of the PartitionModel class
Top
Properties
 | Name | Description
Public property | FileSystem | Gets or sets is the file system for the partition.
Public property | Flags | Gets or sets is the flags for the partition.
Public property | PartitionEndInB | Gets or sets is the endpoint in b for the partition volume.
Public property | PartitionName | Gets or sets is the partition name created on this partition.
Public property | PartitionNumber | Gets or sets is the partition number.
Public property | PartitionStartInB | Gets or sets is the startpoint in b for the partition volume.
Public property | PartitionType | Gets or sets represents the partition type for the partition like primary, extended or logical.
Public property | Valid | Gets or sets determine whether or not this partition is a valid one.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


PartitionModel Constructor

PartitionModel Constructor
Initializes a new instance of the PartitionModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public PartitionModel()
Public Sub New
public:
PartitionModel()
new : unit -> PartitionModel
See Also

Reference

PartitionModel Class


PartitionModel Properties

PartitionModel Properties

The PartitionModel type exposes the following members.

Properties
 | Name | Description
Public property | FileSystem | Gets or sets is the file system for the partition.
Public property | Flags | Gets or sets is the flags for the partition.
Public property | PartitionEndInB | Gets or sets is the endpoint in b for the partition volume.
Public property | PartitionName | Gets or sets is the partition name created on this partition.
Public property | PartitionNumber | Gets or sets is the partition number.
Public property | PartitionStartInB | Gets or sets is the startpoint in b for the partition volume.
Public property | PartitionType | Gets or sets represents the partition type for the partition like primary, extended or logical.
Public property | Valid | Gets or sets determine whether or not this partition is a valid one.
Top
See Also

Reference

PartitionModel Class


PartitionModel.FileSystem Property

PartitionModelFileSystem Property
Gets or sets is the file system for the partition.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string FileSystem { get; set; }
Public Property FileSystem As String
    Get
    Set
public:
property String^ FileSystem {
    String^ get ();
    void set (String^ value);
}
member FileSystem : string with get, set

Property Value

Type: String
See Also

Reference

PartitionModel Class


PartitionModel.Flags Property

PartitionModelFlags Property
Gets or sets is the flags for the partition.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Flags { get; set; }
Public Property Flags As String
    Get
    Set
public:
property String^ Flags {
    String^ get ();
    void set (String^ value);
}
member Flags : string with get, set

Property Value

Type: String
See Also

Reference

PartitionModel Class


PartitionModel.PartitionEndInB Property

PartitionModelPartitionEndInB Property
Gets or sets is the endpoint in b for the partition volume.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long PartitionEndInB { get; set; }
Public Property PartitionEndInB As Long
    Get
    Set
public:
property long long PartitionEndInB {
    long long get ();
    void set (long long value);
}
member PartitionEndInB : int64 with get, set

Property Value

Type: Int64
The endpoint in b for the partition volume.
See Also

Reference

PartitionModel Class


PartitionModel.PartitionName Property

PartitionModelPartitionName Property
Gets or sets is the partition name created on this partition.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string PartitionName { get; set; }
Public Property PartitionName As String
    Get
    Set
public:
property String^ PartitionName {
    String^ get ();
    void set (String^ value);
}
member PartitionName : string with get, set

Property Value

Type: String
See Also

Reference

PartitionModel Class


PartitionModel.PartitionNumber Property

PartitionModelPartitionNumber Property
Gets or sets is the partition number.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int PartitionNumber { get; set; }
Public Property PartitionNumber As Integer
    Get
    Set
public:
property int PartitionNumber {
    int get ();
    void set (int value);
}
member PartitionNumber : int with get, set

Property Value

Type: Int32
See Also

Reference

PartitionModel Class


PartitionModel.PartitionStartInB Property

PartitionModelPartitionStartInB Property
Gets or sets is the startpoint in b for the partition volume.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long PartitionStartInB { get; set; }
Public Property PartitionStartInB As Long
    Get
    Set
public:
property long long PartitionStartInB {
    long long get ();
    void set (long long value);
}
member PartitionStartInB : int64 with get, set

Property Value

Type: Int64
The startpoint in b for the partition volume.
See Also

Reference

PartitionModel Class


PartitionModel.PartitionType Property

PartitionModelPartitionType Property
Gets or sets represents the partition type for the partition like primary, extended or logical.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string PartitionType { get; set; }
Public Property PartitionType As String
    Get
    Set
public:
property String^ PartitionType {
    String^ get ();
    void set (String^ value);
}
member PartitionType : string with get, set

Property Value

Type: String
See Also

Reference

PartitionModel Class


PartitionModel.Valid Property

PartitionModelValid Property
Gets or sets determine whether or not this partition is a valid one.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool Valid { get; set; }
Public Property Valid As Boolean
    Get
    Set
public:
property bool Valid {
    bool get ();
    void set (bool value);
}
member Valid : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PartitionModel Class


PartitionModel Methods

PartitionModel Methods

The PartitionModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PartitionModel Class


PathBlockingEntryModel Class

PathBlockingEntryModel Class
A path blocking entry.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsPathBlockingEntryModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class PathBlockingEntryModel
Public Class PathBlockingEntryModel
public ref class PathBlockingEntryModel
type PathBlockingEntryModel =  class end

The PathBlockingEntryModel type exposes the following members.

Constructors
 | Name | Description
Public method | PathBlockingEntryModel | Initializes a new instance of the PathBlockingEntryModel class
Top
Properties
 | Name | Description
Public property | BlockingMode | Gets or sets the blocking mode.
Public property | Paths | Gets or sets the paths that are blocked.
Public property | SourceAddress | Gets or sets the source address corresponding to the connection having blocked paths.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


PathBlockingEntryModel Constructor

PathBlockingEntryModel Constructor
Initializes a new instance of the PathBlockingEntryModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public PathBlockingEntryModel()
Public Sub New
public:
PathBlockingEntryModel()
new : unit -> PathBlockingEntryModel
See Also

Reference

PathBlockingEntryModel Class


PathBlockingEntryModel Properties

PathBlockingEntryModel Properties

The PathBlockingEntryModel type exposes the following members.

Properties
 | Name | Description
Public property | BlockingMode | Gets or sets the blocking mode.
Public property | Paths | Gets or sets the paths that are blocked.
Public property | SourceAddress | Gets or sets the source address corresponding to the connection having blocked paths.
Top
See Also

Reference

PathBlockingEntryModel Class


PathBlockingEntryModel.BlockingMode Property

PathBlockingEntryModelBlockingMode Property
Gets or sets the blocking mode.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public PathBlockingModeEnum BlockingMode { get; set; }
Public Property BlockingMode As PathBlockingModeEnum
    Get
    Set
public:
property PathBlockingModeEnum BlockingMode {
    PathBlockingModeEnum get ();
    void set (PathBlockingModeEnum value);
}
member BlockingMode : PathBlockingModeEnum with get, set

Property Value

Type: PathBlockingModeEnum
See Also

Reference

PathBlockingEntryModel Class


PathBlockingEntryModel.Paths Property

PathBlockingEntryModelPaths Property
Gets or sets the paths that are blocked.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string[] Paths { get; set; }
Public Property Paths As String()
    Get
    Set
public:
property array<String^>^ Paths {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member Paths : string[] with get, set

Property Value

Type: String
See Also

Reference

PathBlockingEntryModel Class


PathBlockingEntryModel.SourceAddress Property

PathBlockingEntryModelSourceAddress Property
Gets or sets the source address corresponding to the connection having blocked paths.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SourceAddress { get; set; }
Public Property SourceAddress As String
    Get
    Set
public:
property String^ SourceAddress {
    String^ get ();
    void set (String^ value);
}
member SourceAddress : string with get, set

Property Value

Type: String
See Also

Reference

PathBlockingEntryModel Class


PathBlockingEntryModel Methods

PathBlockingEntryModel Methods

The PathBlockingEntryModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PathBlockingEntryModel Class


PathBlockingModeEnum Enumeration

PathBlockingModeEnum Enumeration
This value represents if the path is blocked.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public enum PathBlockingModeEnum
Public Enumeration PathBlockingModeEnum
public enum class PathBlockingModeEnum
type PathBlockingModeEnum
Members
Member name | Value | Description
Blocked | 0 | The path is blocked for writing, except by Double-Take.
Unblocked | 1 | The path is unblocked for writing.
See Also

Reference

DoubleTake.Web.Models Namespace


PathTransformationModel Class

PathTransformationModel Class
Path transformation model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsPathTransformationModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class PathTransformationModel
Public NotInheritable Class PathTransformationModel
public ref class PathTransformationModel sealed
[<SealedAttribute>]
type PathTransformationModel =  class end

The PathTransformationModel type exposes the following members.

Constructors
 | Name | Description
Public method | PathTransformationModel | Initializes a new instance of the PathTransformationModel class
Top
Properties
 | Name | Description
Public property | SourcePath | Gets or sets the path expression used to qualify files for this rule.
Public property | TargetPath | Gets or sets the path expression used to transform file paths for the all-to-one transformations on the target.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


PathTransformationModel Constructor

PathTransformationModel Constructor
Initializes a new instance of the PathTransformationModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public PathTransformationModel()
Public Sub New
public:
PathTransformationModel()
new : unit -> PathTransformationModel
See Also

Reference

PathTransformationModel Class


PathTransformationModel Properties

PathTransformationModel Properties

The PathTransformationModel type exposes the following members.

Properties
 | Name | Description
Public property | SourcePath | Gets or sets the path expression used to qualify files for this rule.
Public property | TargetPath | Gets or sets the path expression used to transform file paths for the all-to-one transformations on the target.
Top
See Also

Reference

PathTransformationModel Class


PathTransformationModel.SourcePath Property

PathTransformationModelSourcePath Property
Gets or sets the path expression used to qualify files for this rule.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourcePath { get; set; }
Public Property SourcePath As String
    Get
    Set
public:
property String^ SourcePath {
    String^ get ();
    void set (String^ value);
}
member SourcePath : string with get, set

Property Value

Type: String
See Also

Reference

PathTransformationModel Class


PathTransformationModel.TargetPath Property

PathTransformationModelTargetPath Property
Gets or sets the path expression used to transform file paths for the all-to-one transformations on the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetPath { get; set; }
Public Property TargetPath As String
    Get
    Set
public:
property String^ TargetPath {
    String^ get ();
    void set (String^ value);
}
member TargetPath : string with get, set

Property Value

Type: String
See Also

Reference

PathTransformationModel Class


PathTransformationModel Methods

PathTransformationModel Methods

The PathTransformationModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PathTransformationModel Class


PerformanceCounterQueryInputModel Class

PerformanceCounterQueryInputModel Class
Represents the input to a performance counter query.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsPerformanceCounterQueryInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class PerformanceCounterQueryInputModel : QueryInputModel
Public Class PerformanceCounterQueryInputModel
    Inherits QueryInputModel
public ref class PerformanceCounterQueryInputModel : public QueryInputModel
type PerformanceCounterQueryInputModel =
    class
        inherit QueryInputModel
    end

The PerformanceCounterQueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | PerformanceCounterQueryInputModel | Initializes a new instance of the PerformanceCounterQueryInputModel class
Top
Properties
 | Name | Description
Public property | Category | Gets or sets the category.
Public property | ComparisonOperation | Gets or sets the comparison operation.
Public property | Counter | Gets or sets the counter.
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | Criteria | Gets or sets the criteria.
Public property | Instance | Gets or sets the instance.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


PerformanceCounterQueryInputModel Constructor

PerformanceCounterQueryInputModel Constructor
Initializes a new instance of the PerformanceCounterQueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public PerformanceCounterQueryInputModel()
Public Sub New
public:
PerformanceCounterQueryInputModel()
new : unit -> PerformanceCounterQueryInputModel
See Also

Reference

PerformanceCounterQueryInputModel Class


PerformanceCounterQueryInputModel Properties

PerformanceCounterQueryInputModel Properties

The PerformanceCounterQueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Category | Gets or sets the category.
Public property | ComparisonOperation | Gets or sets the comparison operation.
Public property | Counter | Gets or sets the counter.
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | Criteria | Gets or sets the criteria.
Public property | Instance | Gets or sets the instance.
Top
See Also

Reference

PerformanceCounterQueryInputModel Class


PerformanceCounterQueryInputModel.Category Property

PerformanceCounterQueryInputModelCategory Property
Gets or sets the category.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Category { get; set; }
Public Property Category As String
    Get
    Set
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}
member Category : string with get, set

Property Value

Type: String
The category.
See Also

Reference

PerformanceCounterQueryInputModel Class


PerformanceCounterQueryInputModel.ComparisonOperation Property

PerformanceCounterQueryInputModelComparisonOperation Property
Gets or sets the comparison operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ComparisonOperationEnum ComparisonOperation { get; set; }
Public Property ComparisonOperation As ComparisonOperationEnum
    Get
    Set
public:
property ComparisonOperationEnum ComparisonOperation {
    ComparisonOperationEnum get ();
    void set (ComparisonOperationEnum value);
}
member ComparisonOperation : ComparisonOperationEnum with get, set

Property Value

Type: ComparisonOperationEnum
The comparison operation.
See Also

Reference

PerformanceCounterQueryInputModel Class


PerformanceCounterQueryInputModel.Counter Property

PerformanceCounterQueryInputModelCounter Property
Gets or sets the counter.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Counter { get; set; }
Public Property Counter As String
    Get
    Set
public:
property String^ Counter {
    String^ get ();
    void set (String^ value);
}
member Counter : string with get, set

Property Value

Type: String
The counter.
See Also

Reference

PerformanceCounterQueryInputModel Class


PerformanceCounterQueryInputModel.Criteria Property

PerformanceCounterQueryInputModelCriteria Property
Gets or sets the criteria.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public float Criteria { get; set; }
Public Property Criteria As Single
    Get
    Set
public:
property float Criteria {
    float get ();
    void set (float value);
}
member Criteria : float32 with get, set

Property Value

Type: Single
The criteria.
See Also

Reference

PerformanceCounterQueryInputModel Class


PerformanceCounterQueryInputModel.Instance Property

PerformanceCounterQueryInputModelInstance Property
Gets or sets the instance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Instance { get; set; }
Public Property Instance As String
    Get
    Set
public:
property String^ Instance {
    String^ get ();
    void set (String^ value);
}
member Instance : string with get, set

Property Value

Type: String
The instance.
See Also

Reference

PerformanceCounterQueryInputModel Class


PerformanceCounterQueryInputModel Methods

PerformanceCounterQueryInputModel Methods

The PerformanceCounterQueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PerformanceCounterQueryInputModel Class


PerformanceCounterQueryResultModel Class

PerformanceCounterQueryResultModel Class
Represents the results of a Performance Counter Query
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultModel
DoubleTake.Web.ModelsPerformanceCounterQueryResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class PerformanceCounterQueryResultModel : QueryResultModel
Public Class PerformanceCounterQueryResultModel
    Inherits QueryResultModel
public ref class PerformanceCounterQueryResultModel : public QueryResultModel
type PerformanceCounterQueryResultModel =
    class
        inherit QueryResultModel
    end

The PerformanceCounterQueryResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | PerformanceCounterQueryResultModel | Initializes a new instance of the PerformanceCounterQueryResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryResultModel


PerformanceCounterQueryResultModel Constructor

PerformanceCounterQueryResultModel Constructor
Initializes a new instance of the PerformanceCounterQueryResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public PerformanceCounterQueryResultModel()
Public Sub New
public:
PerformanceCounterQueryResultModel()
new : unit -> PerformanceCounterQueryResultModel
See Also

Reference

PerformanceCounterQueryResultModel Class


PerformanceCounterQueryResultModel Properties

PerformanceCounterQueryResultModel Properties

The PerformanceCounterQueryResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Top
See Also

Reference

PerformanceCounterQueryResultModel Class


PerformanceCounterQueryResultModel Methods

PerformanceCounterQueryResultModel Methods

The PerformanceCounterQueryResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PerformanceCounterQueryResultModel Class


PhysicalItemFlatModel Class

PhysicalItemFlatModel Class
Represents a physical storage item such as Volume, Directory, File
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsPhysicalItemFlatModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public class PhysicalItemFlatModel
Public Class PhysicalItemFlatModel
public ref class PhysicalItemFlatModel
type PhysicalItemFlatModel =  class end

The PhysicalItemFlatModel type exposes the following members.

Constructors
 | Name | Description
Public method | PhysicalItemFlatModel | Initializes a new instance of the PhysicalItemFlatModel class
Top
Properties
 | Name | Description
Public property | Attributes | Gets or sets a value specifying the file system attributes of this item.
Public property | AvailableFreeSpace | Gets or sets the available free space on this volume.
Public property | ClassName | Gets or sets the class name.
Public property | CreationTime | Gets or sets a value specifying the time this item was created.
Public property | DriveFormat | Gets or sets the format of the drive.
Public property | DriveType | Gets or sets the type of the drive.
Public property | Id | Gets or sets the item identifier.
Public property | IsContainer | Gets or sets a value indicating whether or not the item is a container.
Public property | IsReadOnly | Gets or sets a value indicating whether or not the item is read only.
Public property | IsSupported | Gets or sets a value indicating whether this volume is supported.
Public property | IsSystemDrive | Gets or sets a value indicating whether or not this volume is the system drive.
Public property | ItemType | Gets or sets the type of the item.
Public property | Label | Gets or sets the volume label.
Public property | LastAccessTime | Gets or sets a value specifying the time this item was last accessed.
Public property | LastWriteTime | Gets or sets a value specifying the time this item was last written to.
Public property | Metadata | Gets or sets a value specifying additional meta data for this item.
Public property | Name | Gets or sets the name of the item. Typically, this name is used for display in the user interface.
Public property | Path | Gets or sets the path of the item.
Public property | Saturation | Gets or sets a value which represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface.
Public property | Size | Gets or sets a value indicating the physical size of the item.
Public property | TotalSize | Gets or sets the total size of the volume.
Public property | VolumeType | Gets or sets the volume type.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


PhysicalItemFlatModel Constructor

PhysicalItemFlatModel Constructor
Initializes a new instance of the PhysicalItemFlatModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public PhysicalItemFlatModel()
Public Sub New
public:
PhysicalItemFlatModel()
new : unit -> PhysicalItemFlatModel
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemFlatModel Properties

PhysicalItemFlatModel Properties

The PhysicalItemFlatModel type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets or sets a value specifying the file system attributes of this item.
Public property | AvailableFreeSpace | Gets or sets the available free space on this volume.
Public property | ClassName | Gets or sets the class name.
Public property | CreationTime | Gets or sets a value specifying the time this item was created.
Public property | DriveFormat | Gets or sets the format of the drive.
Public property | DriveType | Gets or sets the type of the drive.
Public property | Id | Gets or sets the item identifier.
Public property | IsContainer | Gets or sets a value indicating whether or not the item is a container.
Public property | IsReadOnly | Gets or sets a value indicating whether or not the item is read only.
Public property | IsSupported | Gets or sets a value indicating whether this volume is supported.
Public property | IsSystemDrive | Gets or sets a value indicating whether or not this volume is the system drive.
Public property | ItemType | Gets or sets the type of the item.
Public property | Label | Gets or sets the volume label.
Public property | LastAccessTime | Gets or sets a value specifying the time this item was last accessed.
Public property | LastWriteTime | Gets or sets a value specifying the time this item was last written to.
Public property | Metadata | Gets or sets a value specifying additional meta data for this item.
Public property | Name | Gets or sets the name of the item. Typically, this name is used for display in the user interface.
Public property | Path | Gets or sets the path of the item.
Public property | Saturation | Gets or sets a value which represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface.
Public property | Size | Gets or sets a value indicating the physical size of the item.
Public property | TotalSize | Gets or sets the total size of the volume.
Public property | VolumeType | Gets or sets the volume type.
Top
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemFlatModel.Attributes Property

PhysicalItemFlatModelAttributes Property
Gets or sets a value specifying the file system attributes of this item.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<FileSystemAttributes> Attributes { get; set; }
Public Property Attributes As Nullable(Of FileSystemAttributes)
    Get
    Set
public:
property Nullable<FileSystemAttributes> Attributes {
    Nullable<FileSystemAttributes> get ();
    void set (Nullable<FileSystemAttributes> value);
}
member Attributes : Nullable<FileSystemAttributes> with get, set

Property Value

Type: Nullable FileSystemAttributes
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemFlatModel.AvailableFreeSpace Property

PhysicalItemFlatModelAvailableFreeSpace Property
Gets or sets the available free space on this volume.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long AvailableFreeSpace { get; set; }
Public Property AvailableFreeSpace As Long
    Get
    Set
public:
property long long AvailableFreeSpace {
    long long get ();
    void set (long long value);
}
member AvailableFreeSpace : int64 with get, set

Property Value

Type: Int64
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemFlatModel.ClassName Property

PhysicalItemFlatModelClassName Property
Gets or sets the class name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ClassName { get; set; }
Public Property ClassName As String
    Get
    Set
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}
member ClassName : string with get, set

Property Value

Type: String
The class name.
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemFlatModel.CreationTime Property

PhysicalItemFlatModelCreationTime Property
Gets or sets a value specifying the time this item was created.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> CreationTime { get; set; }
Public Property CreationTime As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> CreationTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member CreationTime : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemFlatModel.DriveFormat Property

PhysicalItemFlatModelDriveFormat Property
Gets or sets the format of the drive.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string DriveFormat { get; set; }
Public Property DriveFormat As String
    Get
    Set
public:
property String^ DriveFormat {
    String^ get ();
    void set (String^ value);
}
member DriveFormat : string with get, set

Property Value

Type: String
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemFlatModel.DriveType Property

PhysicalItemFlatModelDriveType Property
Gets or sets the type of the drive.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DriveType DriveType { get; set; }
Public Property DriveType As DriveType
    Get
    Set
public:
property DriveType DriveType {
    DriveType get ();
    void set (DriveType value);
}
member DriveType : DriveType with get, set

Property Value

Type: DriveType
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemFlatModel.Id Property

PhysicalItemFlatModelId Property
Gets or sets the item identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
member Id : string with get, set

Property Value

Type: String
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemFlatModel.IsContainer Property

PhysicalItemFlatModelIsContainer Property
Gets or sets a value indicating whether or not the item is a container.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsContainer { get; set; }
Public Property IsContainer As Boolean
    Get
    Set
public:
property bool IsContainer {
    bool get ();
    void set (bool value);
}
member IsContainer : bool with get, set

Property Value

Type: Boolean
if this item is a container; otherwise, .
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemFlatModel.IsReadOnly Property

PhysicalItemFlatModelIsReadOnly Property
Gets or sets a value indicating whether or not the item is read only.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}
member IsReadOnly : bool with get, set

Property Value

Type: Boolean
if this item is read only; otherwise, .
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemFlatModel.IsSupported Property

PhysicalItemFlatModelIsSupported Property
Gets or sets a value indicating whether this volume is supported.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSupported { get; set; }
Public Property IsSupported As Boolean
    Get
    Set
public:
property bool IsSupported {
    bool get ();
    void set (bool value);
}
member IsSupported : bool with get, set

Property Value

Type: Boolean
if this volume is supported; otherwise, .
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemFlatModel.IsSystemDrive Property

PhysicalItemFlatModelIsSystemDrive Property
Gets or sets a value indicating whether or not this volume is the system drive.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSystemDrive { get; set; }
Public Property IsSystemDrive As Boolean
    Get
    Set
public:
property bool IsSystemDrive {
    bool get ();
    void set (bool value);
}
member IsSystemDrive : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemFlatModel.ItemType Property

PhysicalItemFlatModelItemType Property
Gets or sets the type of the item.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ItemType { get; set; }
Public Property ItemType As String
    Get
    Set
public:
property String^ ItemType {
    String^ get ();
    void set (String^ value);
}
member ItemType : string with get, set

Property Value

Type: String
The type of this item.
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemFlatModel.Label Property

PhysicalItemFlatModelLabel Property
Gets or sets the volume label.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Label { get; set; }
Public Property Label As String
    Get
    Set
public:
property String^ Label {
    String^ get ();
    void set (String^ value);
}
member Label : string with get, set

Property Value

Type: String
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemFlatModel.LastAccessTime Property

PhysicalItemFlatModelLastAccessTime Property
Gets or sets a value specifying the time this item was last accessed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> LastAccessTime { get; set; }
Public Property LastAccessTime As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> LastAccessTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member LastAccessTime : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemFlatModel.LastWriteTime Property

PhysicalItemFlatModelLastWriteTime Property
Gets or sets a value specifying the time this item was last written to.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> LastWriteTime { get; set; }
Public Property LastWriteTime As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> LastWriteTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member LastWriteTime : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemFlatModel.Metadata Property

PhysicalItemFlatModelMetadata Property
Gets or sets a value specifying additional meta data for this item.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Metadata { get; set; }
Public Property Metadata As String
    Get
    Set
public:
property String^ Metadata {
    String^ get ();
    void set (String^ value);
}
member Metadata : string with get, set

Property Value

Type: String
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemFlatModel.Name Property

PhysicalItemFlatModelName Property
Gets or sets the name of the item. Typically, this name is used for display in the user interface.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name of this item.
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemFlatModel.Path Property

PhysicalItemFlatModelPath Property
Gets or sets the path of the item.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
member Path : string with get, set

Property Value

Type: String
The path of this item.
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemFlatModel.Saturation Property

PhysicalItemFlatModelSaturation Property
Gets or sets a value which represents the saturation level of the item. Typically, this value is used to display a visual state in the user interface.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public SaturationLevel Saturation { get; set; }
Public Property Saturation As SaturationLevel
    Get
    Set
public:
property SaturationLevel Saturation {
    SaturationLevel get ();
    void set (SaturationLevel value);
}
member Saturation : SaturationLevel with get, set

Property Value

Type: SaturationLevel
The saturation level.
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemFlatModel.Size Property

PhysicalItemFlatModelSize Property
Gets or sets a value indicating the physical size of the item.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<long> Size { get; set; }
Public Property Size As Nullable(Of Long)
    Get
    Set
public:
property Nullable<long long> Size {
    Nullable<long long> get ();
    void set (Nullable<long long> value);
}
member Size : Nullable<int64> with get, set

Property Value

Type: Nullable Int64
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemFlatModel.TotalSize Property

PhysicalItemFlatModelTotalSize Property
Gets or sets the total size of the volume.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long TotalSize { get; set; }
Public Property TotalSize As Long
    Get
    Set
public:
property long long TotalSize {
    long long get ();
    void set (long long value);
}
member TotalSize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemFlatModel.VolumeType Property

PhysicalItemFlatModelVolumeType Property
Gets or sets the volume type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string VolumeType { get; set; }
Public Property VolumeType As String
    Get
    Set
public:
property String^ VolumeType {
    String^ get ();
    void set (String^ value);
}
member VolumeType : string with get, set

Property Value

Type: String
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemFlatModel Methods

PhysicalItemFlatModel Methods

The PhysicalItemFlatModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PhysicalItemFlatModel Class


PhysicalItemModel Class

PhysicalItemModel Class
Physical item model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsProtectableItemModel
DoubleTake.Web.ModelsPhysicalItemModel
DoubleTake.Web.ModelsDirectoryItemModel
DoubleTake.Web.ModelsFileItemModel
DoubleTake.Web.ModelsVolumeModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public class PhysicalItemModel : ProtectableItemModel
Public Class PhysicalItemModel
    Inherits ProtectableItemModel
public ref class PhysicalItemModel : public ProtectableItemModel
type PhysicalItemModel =
    class
        inherit ProtectableItemModel
    end

The PhysicalItemModel type exposes the following members.

Constructors
 | Name | Description
Public method | PhysicalItemModel | Initializes a new instance of the PhysicalItemModel class
Top
Properties
 | Name | Description
Public property | Attributes | Gets or sets a value specifying the file system attributes of this item.
Public property | AvailableFreeSpace | Gets or sets the available free space on this volume.
Public property | ClassName | Gets or sets the class name.
Public property | CreationTime | Gets or sets a value specifying the time this item was created.
Public property | DriveFormat | Gets or sets the format of the drive.
Public property | DriveType | Gets or sets the type of the drive.
Public property | Id | Gets or sets the item identifier. (Inherited from ProtectableItemModel.)
Public property | IsContainer | Gets or sets a value indicating whether or not this item is a container of other items. (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | Gets or sets a value indicating whether or not this item is read only; that is, its Saturation cannot be changed. (Inherited from ProtectableItemModel.)
Public property | IsSupported | Gets or sets a value indicating whether this volume is supported.
Public property | IsSystemDrive | Gets or sets a value indicating whether or not this volume is the system drive.
Public property | ItemType | Gets or sets the type of this item. (Inherited from ProtectableItemModel.)
Public property | Label | Gets or sets the volume label.
Public property | LastAccessTime | Gets or sets a value specifying the time this item was last accessed.
Public property | LastWriteTime | Gets or sets a value specifying the time this item was last written to.
Public property | Metadata | Gets or sets a value specifying additional meta data for this item.
Public property | Name | Gets or sets the name of this item. (Inherited from ProtectableItemModel.)
Public property | PartitionName | Gets or sets the partition name. (Inherited from ProtectableItemModel.)
Public property | Path | Gets or sets the path that uniquely identifies this item. (Inherited from ProtectableItemModel.)
Public property | Saturation | Gets or sets the saturation level of this item. (Inherited from ProtectableItemModel.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume.
Public property | Size | Gets or sets a value indicating the physical size of the item.
Public property | TotalSize | Gets or sets the total size of the volume.
Public property | VolumeType | Gets or sets the volume type.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


PhysicalItemModel Constructor

PhysicalItemModel Constructor
Initializes a new instance of the PhysicalItemModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public PhysicalItemModel()
Public Sub New
public:
PhysicalItemModel()
new : unit -> PhysicalItemModel
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel Properties

PhysicalItemModel Properties

The PhysicalItemModel type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets or sets a value specifying the file system attributes of this item.
Public property | AvailableFreeSpace | Gets or sets the available free space on this volume.
Public property | ClassName | Gets or sets the class name.
Public property | CreationTime | Gets or sets a value specifying the time this item was created.
Public property | DriveFormat | Gets or sets the format of the drive.
Public property | DriveType | Gets or sets the type of the drive.
Public property | Id | Gets or sets the item identifier. (Inherited from ProtectableItemModel.)
Public property | IsContainer | Gets or sets a value indicating whether or not this item is a container of other items. (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | Gets or sets a value indicating whether or not this item is read only; that is, its Saturation cannot be changed. (Inherited from ProtectableItemModel.)
Public property | IsSupported | Gets or sets a value indicating whether this volume is supported.
Public property | IsSystemDrive | Gets or sets a value indicating whether or not this volume is the system drive.
Public property | ItemType | Gets or sets the type of this item. (Inherited from ProtectableItemModel.)
Public property | Label | Gets or sets the volume label.
Public property | LastAccessTime | Gets or sets a value specifying the time this item was last accessed.
Public property | LastWriteTime | Gets or sets a value specifying the time this item was last written to.
Public property | Metadata | Gets or sets a value specifying additional meta data for this item.
Public property | Name | Gets or sets the name of this item. (Inherited from ProtectableItemModel.)
Public property | PartitionName | Gets or sets the partition name. (Inherited from ProtectableItemModel.)
Public property | Path | Gets or sets the path that uniquely identifies this item. (Inherited from ProtectableItemModel.)
Public property | Saturation | Gets or sets the saturation level of this item. (Inherited from ProtectableItemModel.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume.
Public property | Size | Gets or sets a value indicating the physical size of the item.
Public property | TotalSize | Gets or sets the total size of the volume.
Public property | VolumeType | Gets or sets the volume type.
Top
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel.Attributes Property

PhysicalItemModelAttributes Property
Gets or sets a value specifying the file system attributes of this item.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<FileSystemAttributes> Attributes { get; set; }
Public Property Attributes As Nullable(Of FileSystemAttributes)
    Get
    Set
public:
property Nullable<FileSystemAttributes> Attributes {
    Nullable<FileSystemAttributes> get ();
    void set (Nullable<FileSystemAttributes> value);
}
member Attributes : Nullable<FileSystemAttributes> with get, set

Property Value

Type: Nullable FileSystemAttributes
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel.AvailableFreeSpace Property

PhysicalItemModelAvailableFreeSpace Property
Gets or sets the available free space on this volume.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long AvailableFreeSpace { get; set; }
Public Property AvailableFreeSpace As Long
    Get
    Set
public:
property long long AvailableFreeSpace {
    long long get ();
    void set (long long value);
}
member AvailableFreeSpace : int64 with get, set

Property Value

Type: Int64
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel.ClassName Property

PhysicalItemModelClassName Property
Gets or sets the class name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ClassName { get; set; }
Public Property ClassName As String
    Get
    Set
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}
member ClassName : string with get, set

Property Value

Type: String
The class name.
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel.CreationTime Property

PhysicalItemModelCreationTime Property
Gets or sets a value specifying the time this item was created.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> CreationTime { get; set; }
Public Property CreationTime As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> CreationTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member CreationTime : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel.DriveFormat Property

PhysicalItemModelDriveFormat Property
Gets or sets the format of the drive.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string DriveFormat { get; set; }
Public Property DriveFormat As String
    Get
    Set
public:
property String^ DriveFormat {
    String^ get ();
    void set (String^ value);
}
member DriveFormat : string with get, set

Property Value

Type: String
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel.DriveType Property

PhysicalItemModelDriveType Property
Gets or sets the type of the drive.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DriveType DriveType { get; set; }
Public Property DriveType As DriveType
    Get
    Set
public:
property DriveType DriveType {
    DriveType get ();
    void set (DriveType value);
}
member DriveType : DriveType with get, set

Property Value

Type: DriveType
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel.IsSupported Property

PhysicalItemModelIsSupported Property
Gets or sets a value indicating whether this volume is supported.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSupported { get; set; }
Public Property IsSupported As Boolean
    Get
    Set
public:
property bool IsSupported {
    bool get ();
    void set (bool value);
}
member IsSupported : bool with get, set

Property Value

Type: Boolean
if this volume is supported; otherwise, .
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel.IsSystemDrive Property

PhysicalItemModelIsSystemDrive Property
Gets or sets a value indicating whether or not this volume is the system drive.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSystemDrive { get; set; }
Public Property IsSystemDrive As Boolean
    Get
    Set
public:
property bool IsSystemDrive {
    bool get ();
    void set (bool value);
}
member IsSystemDrive : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel.Label Property

PhysicalItemModelLabel Property
Gets or sets the volume label.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Label { get; set; }
Public Property Label As String
    Get
    Set
public:
property String^ Label {
    String^ get ();
    void set (String^ value);
}
member Label : string with get, set

Property Value

Type: String
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel.LastAccessTime Property

PhysicalItemModelLastAccessTime Property
Gets or sets a value specifying the time this item was last accessed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> LastAccessTime { get; set; }
Public Property LastAccessTime As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> LastAccessTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member LastAccessTime : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel.LastWriteTime Property

PhysicalItemModelLastWriteTime Property
Gets or sets a value specifying the time this item was last written to.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> LastWriteTime { get; set; }
Public Property LastWriteTime As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> LastWriteTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member LastWriteTime : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel.Metadata Property

PhysicalItemModelMetadata Property
Gets or sets a value specifying additional meta data for this item.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Metadata { get; set; }
Public Property Metadata As String
    Get
    Set
public:
property String^ Metadata {
    String^ get ();
    void set (String^ value);
}
member Metadata : string with get, set

Property Value

Type: String
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel.ShortNameBehavior Property

PhysicalItemModelShortNameBehavior Property
Gets or sets a value indicating the Short Name Behavior for this volume.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShortNameBehavior { get; set; }
Public Property ShortNameBehavior As Boolean
    Get
    Set
public:
property bool ShortNameBehavior {
    bool get ();
    void set (bool value);
}
member ShortNameBehavior : bool with get, set

Property Value

Type: Boolean
enabled = 0, disabled = 1
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel.Size Property

PhysicalItemModelSize Property
Gets or sets a value indicating the physical size of the item.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<long> Size { get; set; }
Public Property Size As Nullable(Of Long)
    Get
    Set
public:
property Nullable<long long> Size {
    Nullable<long long> get ();
    void set (Nullable<long long> value);
}
member Size : Nullable<int64> with get, set

Property Value

Type: Nullable Int64
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel.TotalSize Property

PhysicalItemModelTotalSize Property
Gets or sets the total size of the volume.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long TotalSize { get; set; }
Public Property TotalSize As Long
    Get
    Set
public:
property long long TotalSize {
    long long get ();
    void set (long long value);
}
member TotalSize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel.VolumeType Property

PhysicalItemModelVolumeType Property
Gets or sets the volume type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string VolumeType { get; set; }
Public Property VolumeType As String
    Get
    Set
public:
property String^ VolumeType {
    String^ get ();
    void set (String^ value);
}
member VolumeType : string with get, set

Property Value

Type: String
See Also

Reference

PhysicalItemModel Class


PhysicalItemModel Methods

PhysicalItemModel Methods

The PhysicalItemModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PhysicalItemModel Class


PhysicalRuleModel Class

PhysicalRuleModel Class
Physical rule model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsPhysicalRuleModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class PhysicalRuleModel
Public NotInheritable Class PhysicalRuleModel
public ref class PhysicalRuleModel sealed
[<SealedAttribute>]
type PhysicalRuleModel =  class end

The PhysicalRuleModel type exposes the following members.

Constructors
 | Name | Description
Public method | PhysicalRuleModel | Initializes a new instance of the PhysicalRuleModel class
Top
Properties
 | Name | Description
Public property | Inclusion | Gets or sets a value indicating whether the path will be included or excluded from replication.
Public property | IsReadOnly | Gets or sets a value indicating whether or not this rule is read only.
Public property | Metadata | Gets or sets the metadata for this rule.
Public property | Path | Gets or sets the path of the data to be replicated.
Public property | Recursion | Gets or sets a value indicating whether the rule will apply to this path only, or to all children of this path as well.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


PhysicalRuleModel Constructor

PhysicalRuleModel Constructor
Initializes a new instance of the PhysicalRuleModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public PhysicalRuleModel()
Public Sub New
public:
PhysicalRuleModel()
new : unit -> PhysicalRuleModel
See Also

Reference

PhysicalRuleModel Class


PhysicalRuleModel Properties

PhysicalRuleModel Properties

The PhysicalRuleModel type exposes the following members.

Properties
 | Name | Description
Public property | Inclusion | Gets or sets a value indicating whether the path will be included or excluded from replication.
Public property | IsReadOnly | Gets or sets a value indicating whether or not this rule is read only.
Public property | Metadata | Gets or sets the metadata for this rule.
Public property | Path | Gets or sets the path of the data to be replicated.
Public property | Recursion | Gets or sets a value indicating whether the rule will apply to this path only, or to all children of this path as well.
Top
See Also

Reference

PhysicalRuleModel Class


PhysicalRuleModel.Inclusion Property

PhysicalRuleModelInclusion Property
Gets or sets a value indicating whether the path will be included or excluded from replication.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public InclusionMode Inclusion { get; set; }
Public Property Inclusion As InclusionMode
    Get
    Set
public:
property InclusionMode Inclusion {
    InclusionMode get ();
    void set (InclusionMode value);
}
member Inclusion : InclusionMode with get, set

Property Value

Type: InclusionMode
See Also

Reference

PhysicalRuleModel Class


PhysicalRuleModel.IsReadOnly Property

PhysicalRuleModelIsReadOnly Property
Gets or sets a value indicating whether or not this rule is read only.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}
member IsReadOnly : bool with get, set

Property Value

Type: Boolean
See Also

Reference

PhysicalRuleModel Class


PhysicalRuleModel.Metadata Property

PhysicalRuleModelMetadata Property
Gets or sets the metadata for this rule.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Metadata { get; set; }
Public Property Metadata As String
    Get
    Set
public:
property String^ Metadata {
    String^ get ();
    void set (String^ value);
}
member Metadata : string with get, set

Property Value

Type: String
See Also

Reference

PhysicalRuleModel Class


PhysicalRuleModel.Path Property

PhysicalRuleModelPath Property
Gets or sets the path of the data to be replicated.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
member Path : string with get, set

Property Value

Type: String
See Also

Reference

PhysicalRuleModel Class


PhysicalRuleModel.Recursion Property

PhysicalRuleModelRecursion Property
Gets or sets a value indicating whether the rule will apply to this path only, or to all children of this path as well.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public RecursionMode Recursion { get; set; }
Public Property Recursion As RecursionMode
    Get
    Set
public:
property RecursionMode Recursion {
    RecursionMode get ();
    void set (RecursionMode value);
}
member Recursion : RecursionMode with get, set

Property Value

Type: RecursionMode
See Also

Reference

PhysicalRuleModel Class


PhysicalRuleModel Methods

PhysicalRuleModel Methods

The PhysicalRuleModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PhysicalRuleModel Class


PhysicalRulesModel Class

PhysicalRulesModel Class
Physical rules model
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsPhysicalRulesModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class PhysicalRulesModel
Public Class PhysicalRulesModel
public ref class PhysicalRulesModel
type PhysicalRulesModel =  class end

The PhysicalRulesModel type exposes the following members.

Constructors
 | Name | Description
Public method | PhysicalRulesModel | Initializes a new instance of the PhysicalRulesModel class
Top
Properties
 | Name | Description
Public property | PhysicalRules | Gets or sets the physical rules.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


PhysicalRulesModel Constructor

PhysicalRulesModel Constructor
Initializes a new instance of the PhysicalRulesModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public PhysicalRulesModel()
Public Sub New
public:
PhysicalRulesModel()
new : unit -> PhysicalRulesModel
See Also

Reference

PhysicalRulesModel Class


PhysicalRulesModel Properties

PhysicalRulesModel Properties

The PhysicalRulesModel type exposes the following members.

Properties
 | Name | Description
Public property | PhysicalRules | Gets or sets the physical rules.
Top
See Also

Reference

PhysicalRulesModel Class


PhysicalRulesModel.PhysicalRules Property

PhysicalRulesModelPhysicalRules Property
Gets or sets the physical rules.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public PhysicalRuleModel[] PhysicalRules { get; set; }
Public Property PhysicalRules As PhysicalRuleModel()
    Get
    Set
public:
property array<PhysicalRuleModel^>^ PhysicalRules {
    array<PhysicalRuleModel^>^ get ();
    void set (array<PhysicalRuleModel^>^ value);
}
member PhysicalRules : PhysicalRuleModel[] with get, set

Property Value

Type: PhysicalRuleModel
The physical rules.
See Also

Reference

PhysicalRulesModel Class


PhysicalRulesModel Methods

PhysicalRulesModel Methods

The PhysicalRulesModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PhysicalRulesModel Class


PhysicalVolumeModel Class

PhysicalVolumeModel Class
Physical volume model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsProtectableItemModel
DoubleTake.Web.ModelsPhysicalItemModel
DoubleTake.Web.ModelsVolumeModel
DoubleTake.Web.ModelsVolumeOptionsModel
DoubleTake.Web.ModelsPhysicalVolumeModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class PhysicalVolumeModel : VolumeOptionsModel
Public NotInheritable Class PhysicalVolumeModel
    Inherits VolumeOptionsModel
public ref class PhysicalVolumeModel sealed : public VolumeOptionsModel
[<SealedAttribute>]
type PhysicalVolumeModel =
    class
        inherit VolumeOptionsModel
    end

The PhysicalVolumeModel type exposes the following members.

Constructors
 | Name | Description
Public method | PhysicalVolumeModel | Initializes a new instance of the PhysicalVolumeModel class
Top
Properties
 | Name | Description
Public property | Attributes | Gets or sets a value specifying the file system attributes of this item. (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | Gets or sets the available free space on this volume. (Inherited from PhysicalItemModel.)
Public property | ClassName | Gets or sets the class name. (Inherited from PhysicalItemModel.)
Public property | CreationTime | Gets or sets a value specifying the time this item was created. (Inherited from PhysicalItemModel.)
Public property | DesiredSize | Gets or sets the size that the user wants the drive to be. (Inherited from VolumeOptionsModel.)
Public property | DiskControllerType | Gets or sets the type of the disk controller. (Inherited from VolumeOptionsModel.)
Public property | DiskProvisioningType | Gets or sets the type of the disk provisioning. (Inherited from VolumeOptionsModel.)
Public property | DriveFormat | Gets or sets the format of the drive. (Inherited from PhysicalItemModel.)
Public property | DriveType | Gets or sets the type of the drive. (Inherited from PhysicalItemModel.)
Public property | Id | Gets or sets the item identifier. (Inherited from ProtectableItemModel.)
Public property | IsContainer | Gets or sets a value indicating whether or not this item is a container of other items. (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | Gets or sets a value indicating whether or not this item is read only; that is, its Saturation cannot be changed. (Inherited from ProtectableItemModel.)
Public property | IsSupported | Gets or sets a value indicating whether this volume is supported. (Inherited from PhysicalItemModel.)
Public property | IsSystemDrive | Gets or sets a value indicating whether or not this volume is the system drive. (Inherited from PhysicalItemModel.)
Public property | ItemType | Gets or sets the type of this item. (Inherited from ProtectableItemModel.)
Public property | Label | Gets or sets the volume label. (Inherited from PhysicalItemModel.)
Public property | LastAccessTime | Gets or sets a value specifying the time this item was last accessed. (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | Gets or sets a value specifying the time this item was last written to. (Inherited from PhysicalItemModel.)
Public property | Metadata | Gets or sets a value specifying additional meta data for this item. (Inherited from PhysicalItemModel.)
Public property | Name | Gets or sets the name of this item. (Inherited from ProtectableItemModel.)
Public property | PartitionName | Gets or sets the partition name. (Inherited from ProtectableItemModel.)
Public property | Path | Gets or sets the path that uniquely identifies this item. (Inherited from ProtectableItemModel.)
Public property | PreexistingDiskPath | Gets or sets the path of preexisting disk. (Inherited from VolumeOptionsModel.)
Public property | Saturation | Gets or sets the saturation level of this item. (Inherited from ProtectableItemModel.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume. (Inherited from PhysicalItemModel.)
Public property | Size | Gets or sets a value indicating the physical size of the item. (Inherited from PhysicalItemModel.)
Public property | TotalSize | Gets or sets the total size of the volume. (Inherited from PhysicalItemModel.)
Public property | VirtualDiskPath | Gets or sets the path on the host where the volume should be stored. (Inherited from VolumeOptionsModel.)
Public property | VolumeSignature | Gets or sets the volume signature. (Inherited from VolumeOptionsModel.)
Public property | VolumeType | Gets or sets the volume type. (Inherited from PhysicalItemModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


PhysicalVolumeModel Constructor

PhysicalVolumeModel Constructor
Initializes a new instance of the PhysicalVolumeModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public PhysicalVolumeModel()
Public Sub New
public:
PhysicalVolumeModel()
new : unit -> PhysicalVolumeModel
See Also

Reference

PhysicalVolumeModel Class


PhysicalVolumeModel Properties

PhysicalVolumeModel Properties

The PhysicalVolumeModel type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets or sets a value specifying the file system attributes of this item. (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | Gets or sets the available free space on this volume. (Inherited from PhysicalItemModel.)
Public property | ClassName | Gets or sets the class name. (Inherited from PhysicalItemModel.)
Public property | CreationTime | Gets or sets a value specifying the time this item was created. (Inherited from PhysicalItemModel.)
Public property | DesiredSize | Gets or sets the size that the user wants the drive to be. (Inherited from VolumeOptionsModel.)
Public property | DiskControllerType | Gets or sets the type of the disk controller. (Inherited from VolumeOptionsModel.)
Public property | DiskProvisioningType | Gets or sets the type of the disk provisioning. (Inherited from VolumeOptionsModel.)
Public property | DriveFormat | Gets or sets the format of the drive. (Inherited from PhysicalItemModel.)
Public property | DriveType | Gets or sets the type of the drive. (Inherited from PhysicalItemModel.)
Public property | Id | Gets or sets the item identifier. (Inherited from ProtectableItemModel.)
Public property | IsContainer | Gets or sets a value indicating whether or not this item is a container of other items. (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | Gets or sets a value indicating whether or not this item is read only; that is, its Saturation cannot be changed. (Inherited from ProtectableItemModel.)
Public property | IsSupported | Gets or sets a value indicating whether this volume is supported. (Inherited from PhysicalItemModel.)
Public property | IsSystemDrive | Gets or sets a value indicating whether or not this volume is the system drive. (Inherited from PhysicalItemModel.)
Public property | ItemType | Gets or sets the type of this item. (Inherited from ProtectableItemModel.)
Public property | Label | Gets or sets the volume label. (Inherited from PhysicalItemModel.)
Public property | LastAccessTime | Gets or sets a value specifying the time this item was last accessed. (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | Gets or sets a value specifying the time this item was last written to. (Inherited from PhysicalItemModel.)
Public property | Metadata | Gets or sets a value specifying additional meta data for this item. (Inherited from PhysicalItemModel.)
Public property | Name | Gets or sets the name of this item. (Inherited from ProtectableItemModel.)
Public property | PartitionName | Gets or sets the partition name. (Inherited from ProtectableItemModel.)
Public property | Path | Gets or sets the path that uniquely identifies this item. (Inherited from ProtectableItemModel.)
Public property | PreexistingDiskPath | Gets or sets the path of preexisting disk. (Inherited from VolumeOptionsModel.)
Public property | Saturation | Gets or sets the saturation level of this item. (Inherited from ProtectableItemModel.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume. (Inherited from PhysicalItemModel.)
Public property | Size | Gets or sets a value indicating the physical size of the item. (Inherited from PhysicalItemModel.)
Public property | TotalSize | Gets or sets the total size of the volume. (Inherited from PhysicalItemModel.)
Public property | VirtualDiskPath | Gets or sets the path on the host where the volume should be stored. (Inherited from VolumeOptionsModel.)
Public property | VolumeSignature | Gets or sets the volume signature. (Inherited from VolumeOptionsModel.)
Public property | VolumeType | Gets or sets the volume type. (Inherited from PhysicalItemModel.)
Top
See Also

Reference

PhysicalVolumeModel Class


PhysicalVolumeModel Methods

PhysicalVolumeModel Methods

The PhysicalVolumeModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PhysicalVolumeModel Class


PingMethods Enumeration

PingMethods Enumeration
Ping methods.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum PingMethods
<FlagsAttribute>
Public Enumeration PingMethods
[FlagsAttribute]
public enum class PingMethods
[<FlagsAttribute>]
type PingMethods
Members
Member name | Value | Description
ForceUpdate | 256 | The force update
Manual | 4 | The manual
Network | 1 | The network
None | 0 | The none
Script | 8 | The script
Service | 2 | The service
See Also

Reference

DoubleTake.Web.Models Namespace


PITSnapshotRecordModel Class

PITSnapshotRecordModel Class
PIT snapshot record.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsPITSnapshotRecordModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class PITSnapshotRecordModel
Public NotInheritable Class PITSnapshotRecordModel
public ref class PITSnapshotRecordModel sealed
[<SealedAttribute>]
type PITSnapshotRecordModel =  class end

The PITSnapshotRecordModel type exposes the following members.

Constructors
 | Name | Description
Public method | PITSnapshotRecordModel | Initializes a new instance of the PITSnapshotRecordModel class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


PITSnapshotRecordModel Constructor

PITSnapshotRecordModel Constructor
Initializes a new instance of the PITSnapshotRecordModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public PITSnapshotRecordModel()
Public Sub New
public:
PITSnapshotRecordModel()
new : unit -> PITSnapshotRecordModel
See Also

Reference

PITSnapshotRecordModel Class


PITSnapshotRecordModel Methods

PITSnapshotRecordModel Methods

The PITSnapshotRecordModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PITSnapshotRecordModel Class


ProductInfoModel Class

ProductInfoModel Class
Product info model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsProductInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ProductInfoModel
Public NotInheritable Class ProductInfoModel
public ref class ProductInfoModel sealed
[<SealedAttribute>]
type ProductInfoModel =  class end

The ProductInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ProductInfoModel | Initializes a new instance of the ProductInfoModel class
Top
Properties
 | Name | Description
Public property | ActivationStatus | Gets or sets the activation status of the server.
Public property | CanPauseTarget | Gets or sets a value indicating whether or not target operations can be paused.
Public property | CanResumeTarget | Gets or sets a value indicating whether or not target operations can be resumed.
Public property | EnginePort | Gets or sets the port on which the engine is listening.
Public property | InstallationPath | Gets or sets the installation path.
Public property | LocalEndpoints | Gets or sets the local endpoints.
Public property | MachineName | Gets or sets the name of the machine.
Public property | ManagementServiceVersion | Gets or sets the version of the management service on the server.
Public property | Name | Gets or sets the name of the product on the server.
Public property | NatEndpoints | Gets or sets the NAT end points.
Public property | ReservedAddress | Gets or sets the reserved IP address for the server.
Public property | UniqueId | Gets or sets the unique id of the server.
Public property | Version | Gets or sets the version of the product on the server.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ProductInfoModel Constructor

ProductInfoModel Constructor
Initializes a new instance of the ProductInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ProductInfoModel()
Public Sub New
public:
ProductInfoModel()
new : unit -> ProductInfoModel
See Also

Reference

ProductInfoModel Class


ProductInfoModel Properties

ProductInfoModel Properties

The ProductInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | ActivationStatus | Gets or sets the activation status of the server.
Public property | CanPauseTarget | Gets or sets a value indicating whether or not target operations can be paused.
Public property | CanResumeTarget | Gets or sets a value indicating whether or not target operations can be resumed.
Public property | EnginePort | Gets or sets the port on which the engine is listening.
Public property | InstallationPath | Gets or sets the installation path.
Public property | LocalEndpoints | Gets or sets the local endpoints.
Public property | MachineName | Gets or sets the name of the machine.
Public property | ManagementServiceVersion | Gets or sets the version of the management service on the server.
Public property | Name | Gets or sets the name of the product on the server.
Public property | NatEndpoints | Gets or sets the NAT end points.
Public property | ReservedAddress | Gets or sets the reserved IP address for the server.
Public property | UniqueId | Gets or sets the unique id of the server.
Public property | Version | Gets or sets the version of the product on the server.
Top
See Also

Reference

ProductInfoModel Class


ProductInfoModel.ActivationStatus Property

ProductInfoModelActivationStatus Property
Gets or sets the activation status of the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ActivationStatusModel ActivationStatus { get; set; }
Public Property ActivationStatus As ActivationStatusModel
    Get
    Set
public:
property ActivationStatusModel^ ActivationStatus {
    ActivationStatusModel^ get ();
    void set (ActivationStatusModel^ value);
}
member ActivationStatus : ActivationStatusModel with get, set

Property Value

Type: ActivationStatusModel
See Also

Reference

ProductInfoModel Class


ProductInfoModel.CanPauseTarget Property

ProductInfoModelCanPauseTarget Property
Gets or sets a value indicating whether or not target operations can be paused.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanPauseTarget { get; set; }
Public Property CanPauseTarget As Boolean
    Get
    Set
public:
property bool CanPauseTarget {
    bool get ();
    void set (bool value);
}
member CanPauseTarget : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ProductInfoModel Class


ProductInfoModel.CanResumeTarget Property

ProductInfoModelCanResumeTarget Property
Gets or sets a value indicating whether or not target operations can be resumed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanResumeTarget { get; set; }
Public Property CanResumeTarget As Boolean
    Get
    Set
public:
property bool CanResumeTarget {
    bool get ();
    void set (bool value);
}
member CanResumeTarget : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ProductInfoModel Class


ProductInfoModel.EnginePort Property

ProductInfoModelEnginePort Property
Gets or sets the port on which the engine is listening.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int EnginePort { get; set; }
Public Property EnginePort As Integer
    Get
    Set
public:
property int EnginePort {
    int get ();
    void set (int value);
}
member EnginePort : int with get, set

Property Value

Type: Int32
See Also

Reference

ProductInfoModel Class


ProductInfoModel.InstallationPath Property

ProductInfoModelInstallationPath Property
Gets or sets the installation path.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string InstallationPath { get; set; }
Public Property InstallationPath As String
    Get
    Set
public:
property String^ InstallationPath {
    String^ get ();
    void set (String^ value);
}
member InstallationPath : string with get, set

Property Value

Type: String
See Also

Reference

ProductInfoModel Class


ProductInfoModel.LocalEndpoints Property

ProductInfoModelLocalEndpoints Property
Gets or sets the local endpoints.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> LocalEndpoints { get; set; }
Public Property LocalEndpoints As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ LocalEndpoints {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member LocalEndpoints : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
See Also

Reference

ProductInfoModel Class


ProductInfoModel.MachineName Property

ProductInfoModelMachineName Property
Gets or sets the name of the machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string MachineName { get; set; }
Public Property MachineName As String
    Get
    Set
public:
property String^ MachineName {
    String^ get ();
    void set (String^ value);
}
member MachineName : string with get, set

Property Value

Type: String
See Also

Reference

ProductInfoModel Class


ProductInfoModel.ManagementServiceVersion Property

ProductInfoModelManagementServiceVersion Property
Gets or sets the version of the management service on the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ProductVersionModel ManagementServiceVersion { get; set; }
Public Property ManagementServiceVersion As ProductVersionModel
    Get
    Set
public:
property ProductVersionModel^ ManagementServiceVersion {
    ProductVersionModel^ get ();
    void set (ProductVersionModel^ value);
}
member ManagementServiceVersion : ProductVersionModel with get, set

Property Value

Type: ProductVersionModel
See Also

Reference

ProductInfoModel Class


ProductInfoModel.Name Property

ProductInfoModelName Property
Gets or sets the name of the product on the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

ProductInfoModel Class


ProductInfoModel.NatEndpoints Property

ProductInfoModelNatEndpoints Property
Gets or sets the NAT end points.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> NatEndpoints { get; set; }
Public Property NatEndpoints As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ NatEndpoints {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member NatEndpoints : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
See Also

Reference

ProductInfoModel Class


ProductInfoModel.ReservedAddress Property

ProductInfoModelReservedAddress Property
Gets or sets the reserved IP address for the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ReservedAddress { get; set; }
Public Property ReservedAddress As String
    Get
    Set
public:
property String^ ReservedAddress {
    String^ get ();
    void set (String^ value);
}
member ReservedAddress : string with get, set

Property Value

Type: String
See Also

Reference

ProductInfoModel Class


ProductInfoModel.UniqueId Property

ProductInfoModelUniqueId Property
Gets or sets the unique id of the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string UniqueId { get; set; }
Public Property UniqueId As String
    Get
    Set
public:
property String^ UniqueId {
    String^ get ();
    void set (String^ value);
}
member UniqueId : string with get, set

Property Value

Type: String
See Also

Reference

ProductInfoModel Class


ProductInfoModel.Version Property

ProductInfoModelVersion Property
Gets or sets the version of the product on the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ProductVersionModel Version { get; set; }
Public Property Version As ProductVersionModel
    Get
    Set
public:
property ProductVersionModel^ Version {
    ProductVersionModel^ get ();
    void set (ProductVersionModel^ value);
}
member Version : ProductVersionModel with get, set

Property Value

Type: ProductVersionModel
See Also

Reference

ProductInfoModel Class


ProductInfoModel Methods

ProductInfoModel Methods

The ProductInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProductInfoModel Class


ProductVersionModel Class

ProductVersionModel Class
Product version model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsProductVersionModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ProductVersionModel
Public NotInheritable Class ProductVersionModel
public ref class ProductVersionModel sealed
[<SealedAttribute>]
type ProductVersionModel =  class end

The ProductVersionModel type exposes the following members.

Constructors
 | Name | Description
Public method | ProductVersionModel | Initializes a new instance of the ProductVersionModel class
Top
Properties
 | Name | Description
Public property | Build | Gets or sets the build (sequence) number.
Public property | Hotfix | Gets or sets the hot fix number.
Public property | Major | Gets or sets the major version number.
Public property | Minor | Gets or sets the minor version number.
Public property | ServicePack | Gets or sets the service pack number.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ProductVersionModel Constructor

ProductVersionModel Constructor
Initializes a new instance of the ProductVersionModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ProductVersionModel()
Public Sub New
public:
ProductVersionModel()
new : unit -> ProductVersionModel
See Also

Reference

ProductVersionModel Class


ProductVersionModel Properties

ProductVersionModel Properties

The ProductVersionModel type exposes the following members.

Properties
 | Name | Description
Public property | Build | Gets or sets the build (sequence) number.
Public property | Hotfix | Gets or sets the hot fix number.
Public property | Major | Gets or sets the major version number.
Public property | Minor | Gets or sets the minor version number.
Public property | ServicePack | Gets or sets the service pack number.
Top
See Also

Reference

ProductVersionModel Class


ProductVersionModel.Build Property

ProductVersionModelBuild Property
Gets or sets the build (sequence) number.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int Build { get; set; }
Public Property Build As Integer
    Get
    Set
public:
property int Build {
    int get ();
    void set (int value);
}
member Build : int with get, set

Property Value

Type: Int32
See Also

Reference

ProductVersionModel Class


ProductVersionModel.Hotfix Property

ProductVersionModelHotfix Property
Gets or sets the hot fix number.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int Hotfix { get; set; }
Public Property Hotfix As Integer
    Get
    Set
public:
property int Hotfix {
    int get ();
    void set (int value);
}
member Hotfix : int with get, set

Property Value

Type: Int32
See Also

Reference

ProductVersionModel Class


ProductVersionModel.Major Property

ProductVersionModelMajor Property
Gets or sets the major version number.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int Major { get; set; }
Public Property Major As Integer
    Get
    Set
public:
property int Major {
    int get ();
    void set (int value);
}
member Major : int with get, set

Property Value

Type: Int32
See Also

Reference

ProductVersionModel Class


ProductVersionModel.Minor Property

ProductVersionModelMinor Property
Gets or sets the minor version number.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int Minor { get; set; }
Public Property Minor As Integer
    Get
    Set
public:
property int Minor {
    int get ();
    void set (int value);
}
member Minor : int with get, set

Property Value

Type: Int32
See Also

Reference

ProductVersionModel Class


ProductVersionModel.ServicePack Property

ProductVersionModelServicePack Property
Gets or sets the service pack number.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int ServicePack { get; set; }
Public Property ServicePack As Integer
    Get
    Set
public:
property int ServicePack {
    int get ();
    void set (int value);
}
member ServicePack : int with get, set

Property Value

Type: Int32
See Also

Reference

ProductVersionModel Class


ProductVersionModel Methods

ProductVersionModel Methods

The ProductVersionModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProductVersionModel Class


PropertyModel Class

PropertyModel Class
Represents an association between a name and another string
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsPropertyModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class PropertyModel
Public NotInheritable Class PropertyModel
public ref class PropertyModel sealed
[<SealedAttribute>]
type PropertyModel =  class end

The PropertyModel type exposes the following members.

Constructors
 | Name | Description
Public method | PropertyModel | Initializes a new instance of the PropertyModel class
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name.
Public property | Value | Gets or sets the value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


PropertyModel Constructor

PropertyModel Constructor
Initializes a new instance of the PropertyModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public PropertyModel()
Public Sub New
public:
PropertyModel()
new : unit -> PropertyModel
See Also

Reference

PropertyModel Class


PropertyModel Properties

PropertyModel Properties

The PropertyModel type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name.
Public property | Value | Gets or sets the value.
Top
See Also

Reference

PropertyModel Class


PropertyModel.Name Property

PropertyModelName Property
Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

PropertyModel Class


PropertyModel.Value Property

PropertyModelValue Property
Gets or sets the value.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
The value.
See Also

Reference

PropertyModel Class


PropertyModel Methods

PropertyModel Methods

The PropertyModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PropertyModel Class


ProtectableItemModel Class

ProtectableItemModel Class
Protectable item model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsProtectableItemModel
DoubleTake.Web.ModelsLogicalItemModel
DoubleTake.Web.ModelsPhysicalItemModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ProtectableItemModel
Public MustInherit Class ProtectableItemModel
public ref class ProtectableItemModel abstract
[<AbstractClassAttribute>]
type ProtectableItemModel =  class end

The ProtectableItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | ProtectableItemModel | Initializes a new instance of the ProtectableItemModel class
Top
Properties
 | Name | Description
Public property | Id | Gets or sets the item identifier.
Public property | IsContainer | Gets or sets a value indicating whether or not this item is a container of other items.
Public property | IsReadOnly | Gets or sets a value indicating whether or not this item is read only; that is, its Saturation cannot be changed.
Public property | ItemType | Gets or sets the type of this item.
Public property | Name | Gets or sets the name of this item.
Public property | PartitionName | Gets or sets the partition name.
Public property | Path | Gets or sets the path that uniquely identifies this item.
Public property | Saturation | Gets or sets the saturation level of this item.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ProtectableItemModel Constructor

ProtectableItemModel Constructor
Initializes a new instance of the ProtectableItemModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
protected ProtectableItemModel()
Protected Sub New
protected:
ProtectableItemModel()
new : unit -> ProtectableItemModel
See Also

Reference

ProtectableItemModel Class


ProtectableItemModel Properties

ProtectableItemModel Properties

The ProtectableItemModel type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets or sets the item identifier.
Public property | IsContainer | Gets or sets a value indicating whether or not this item is a container of other items.
Public property | IsReadOnly | Gets or sets a value indicating whether or not this item is read only; that is, its Saturation cannot be changed.
Public property | ItemType | Gets or sets the type of this item.
Public property | Name | Gets or sets the name of this item.
Public property | PartitionName | Gets or sets the partition name.
Public property | Path | Gets or sets the path that uniquely identifies this item.
Public property | Saturation | Gets or sets the saturation level of this item.
Top
See Also

Reference

ProtectableItemModel Class


ProtectableItemModel.Id Property

ProtectableItemModelId Property
Gets or sets the item identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
member Id : string with get, set

Property Value

Type: String
See Also

Reference

ProtectableItemModel Class


ProtectableItemModel.IsContainer Property

ProtectableItemModelIsContainer Property
Gets or sets a value indicating whether or not this item is a container of other items.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsContainer { get; set; }
Public Property IsContainer As Boolean
    Get
    Set
public:
property bool IsContainer {
    bool get ();
    void set (bool value);
}
member IsContainer : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ProtectableItemModel Class


ProtectableItemModel.IsReadOnly Property

ProtectableItemModelIsReadOnly Property
Gets or sets a value indicating whether or not this item is read only; that is, its Saturation cannot be changed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set
public:
property bool IsReadOnly {
    bool get ();
    void set (bool value);
}
member IsReadOnly : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ProtectableItemModel Class


ProtectableItemModel.ItemType Property

ProtectableItemModelItemType Property
Gets or sets the type of this item.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ItemType { get; set; }
Public Property ItemType As String
    Get
    Set
public:
property String^ ItemType {
    String^ get ();
    void set (String^ value);
}
member ItemType : string with get, set

Property Value

Type: String
See Also

Reference

ProtectableItemModel Class


ProtectableItemModel.Name Property

ProtectableItemModelName Property
Gets or sets the name of this item.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

ProtectableItemModel Class


ProtectableItemModel.PartitionName Property

ProtectableItemModelPartitionName Property
Gets or sets the partition name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string PartitionName { get; set; }
Public Property PartitionName As String
    Get
    Set
public:
property String^ PartitionName {
    String^ get ();
    void set (String^ value);
}
member PartitionName : string with get, set

Property Value

Type: String
See Also

Reference

ProtectableItemModel Class


ProtectableItemModel.Path Property

ProtectableItemModelPath Property
Gets or sets the path that uniquely identifies this item.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
member Path : string with get, set

Property Value

Type: String
See Also

Reference

ProtectableItemModel Class


ProtectableItemModel.Saturation Property

ProtectableItemModelSaturation Property
Gets or sets the saturation level of this item.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public SaturationLevel Saturation { get; set; }
Public Property Saturation As SaturationLevel
    Get
    Set
public:
property SaturationLevel Saturation {
    SaturationLevel get ();
    void set (SaturationLevel value);
}
member Saturation : SaturationLevel with get, set

Property Value

Type: SaturationLevel
The saturation level.
See Also

Reference

ProtectableItemModel Class


ProtectableItemModel Methods

ProtectableItemModel Methods

The ProtectableItemModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ProtectableItemModel Class


QueryInputFlatModel Class

QueryInputFlatModel Class
Query input flat.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputFlatModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class QueryInputFlatModel
Public Class QueryInputFlatModel
public ref class QueryInputFlatModel
type QueryInputFlatModel =  class end

The QueryInputFlatModel type exposes the following members.

Constructors
 | Name | Description
Public method | QueryInputFlatModel | Initializes a new instance of the QueryInputFlatModel class
Top
Properties
 | Name | Description
Public property | Arguments | Gets or sets the arguments to the script or executable.
Public property | Category | Gets or sets the category.
Public property | ClassName | Gets or sets the name of the class.
Public property | ComparisonOperation | Gets or sets the comparison operation.
Public property | Counter | Gets or sets the counter.
Public property | Credentials | Gets or sets the credentials to be used by the query.
Public property | Criteria | Gets or sets the criteria.
Public property | EnginePort | Gets or sets the engine port.
Public property | ExternalDataRoot | Gets or sets the external data root.
Public property | FileName | Gets or sets the file name of the script or executable to run.
Public property | IdJob | Gets or sets the job identifier.
Public property | Instance | Gets or sets the instance.
Public property | IPAddress | Gets or sets the IP address to ping for a heartbeat.
Public property | JobId | Gets or sets the job identifier.
Public property | NetworkId | Gets or sets the server name or IP address to ping.
Public property | Operation | Gets or sets the mode of query aggregation.
Public property | ParallelExecution | Gets or sets a value indicating whether the queries are to be executed in parallel.
Public property | Queries | Gets or sets the enumerable collection of queries.
Public property | ReplicationSetName | Gets or sets the name of the replication set.
Public property | ResourceName | Gets or sets the name of the resource.
Public property | Rules | Gets or sets the rules.
Public property | RunAs | Gets or sets the key to the credentials of the user as which the process will be run.
Public property | ServiceName | Gets or sets the name of the service to monitor.
Public property | SnapshotDataRoot | Gets or sets the snapshot data root.
Public property | Target | Gets or sets the target.
Public property | TargetHostName | Gets or sets the name of the target host.
Public property | VhdPath | Gets or sets the VHD path.
Public property | VirtualSwitchInfoColl | Gets or sets the collection of virtual switch information.
Public property | VmId | Gets or sets the VM identifier.
Public property | WaitForCompletion | Gets or sets a value indicating whether to wait for completion.
Public property | WaitForCompletionTimeout | Gets or sets the wait for completion timeout.
Public property | WorkingDirectory | Gets or sets the working directory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


QueryInputFlatModel Constructor

QueryInputFlatModel Constructor
Initializes a new instance of the QueryInputFlatModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public QueryInputFlatModel()
Public Sub New
public:
QueryInputFlatModel()
new : unit -> QueryInputFlatModel
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel Properties

QueryInputFlatModel Properties

The QueryInputFlatModel type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets or sets the arguments to the script or executable.
Public property | Category | Gets or sets the category.
Public property | ClassName | Gets or sets the name of the class.
Public property | ComparisonOperation | Gets or sets the comparison operation.
Public property | Counter | Gets or sets the counter.
Public property | Credentials | Gets or sets the credentials to be used by the query.
Public property | Criteria | Gets or sets the criteria.
Public property | EnginePort | Gets or sets the engine port.
Public property | ExternalDataRoot | Gets or sets the external data root.
Public property | FileName | Gets or sets the file name of the script or executable to run.
Public property | IdJob | Gets or sets the job identifier.
Public property | Instance | Gets or sets the instance.
Public property | IPAddress | Gets or sets the IP address to ping for a heartbeat.
Public property | JobId | Gets or sets the job identifier.
Public property | NetworkId | Gets or sets the server name or IP address to ping.
Public property | Operation | Gets or sets the mode of query aggregation.
Public property | ParallelExecution | Gets or sets a value indicating whether the queries are to be executed in parallel.
Public property | Queries | Gets or sets the enumerable collection of queries.
Public property | ReplicationSetName | Gets or sets the name of the replication set.
Public property | ResourceName | Gets or sets the name of the resource.
Public property | Rules | Gets or sets the rules.
Public property | RunAs | Gets or sets the key to the credentials of the user as which the process will be run.
Public property | ServiceName | Gets or sets the name of the service to monitor.
Public property | SnapshotDataRoot | Gets or sets the snapshot data root.
Public property | Target | Gets or sets the target.
Public property | TargetHostName | Gets or sets the name of the target host.
Public property | VhdPath | Gets or sets the VHD path.
Public property | VirtualSwitchInfoColl | Gets or sets the collection of virtual switch information.
Public property | VmId | Gets or sets the VM identifier.
Public property | WaitForCompletion | Gets or sets a value indicating whether to wait for completion.
Public property | WaitForCompletionTimeout | Gets or sets the wait for completion timeout.
Public property | WorkingDirectory | Gets or sets the working directory.
Top
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.Arguments Property

QueryInputFlatModelArguments Property
Gets or sets the arguments to the script or executable.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
member Arguments : string with get, set

Property Value

Type: String
The arguments to the script or executable.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.Category Property

QueryInputFlatModelCategory Property
Gets or sets the category.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Category { get; set; }
Public Property Category As String
    Get
    Set
public:
property String^ Category {
    String^ get ();
    void set (String^ value);
}
member Category : string with get, set

Property Value

Type: String
The category.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.ClassName Property

QueryInputFlatModelClassName Property
Gets or sets the name of the class.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ClassName { get; set; }
Public Property ClassName As String
    Get
    Set
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}
member ClassName : string with get, set

Property Value

Type: String
The assembly qualified name of the class we are representing.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.ComparisonOperation Property

QueryInputFlatModelComparisonOperation Property
Gets or sets the comparison operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ComparisonOperationEnum ComparisonOperation { get; set; }
Public Property ComparisonOperation As ComparisonOperationEnum
    Get
    Set
public:
property ComparisonOperationEnum ComparisonOperation {
    ComparisonOperationEnum get ();
    void set (ComparisonOperationEnum value);
}
member ComparisonOperation : ComparisonOperationEnum with get, set

Property Value

Type: ComparisonOperationEnum
The comparison operation.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.Counter Property

QueryInputFlatModelCounter Property
Gets or sets the counter.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Counter { get; set; }
Public Property Counter As String
    Get
    Set
public:
property String^ Counter {
    String^ get ();
    void set (String^ value);
}
member Counter : string with get, set

Property Value

Type: String
The counter.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.Credentials Property

QueryInputFlatModelCredentials Property
Gets or sets the credentials to be used by the query.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, CredentialModel> Credentials { get; set; }
Public Property Credentials As IDictionary(Of String, CredentialModel)
    Get
    Set
public:
property IDictionary<String^, CredentialModel^>^ Credentials {
    IDictionary<String^, CredentialModel^>^ get ();
    void set (IDictionary<String^, CredentialModel^>^ value);
}
member Credentials : IDictionary<string, CredentialModel> with get, set

Property Value

Type: IDictionary String, CredentialModel
The credentials.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.Criteria Property

QueryInputFlatModelCriteria Property
Gets or sets the criteria.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public float Criteria { get; set; }
Public Property Criteria As Single
    Get
    Set
public:
property float Criteria {
    float get ();
    void set (float value);
}
member Criteria : float32 with get, set

Property Value

Type: Single
The criteria.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.EnginePort Property

QueryInputFlatModelEnginePort Property
Gets or sets the engine port.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> EnginePort { get; set; }
Public Property EnginePort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> EnginePort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member EnginePort : Nullable<int> with get, set

Property Value

Type: Nullable Int32
The engine port.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.ExternalDataRoot Property

QueryInputFlatModelExternalDataRoot Property
Gets or sets the external data root.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ExternalDataRoot { get; set; }
Public Property ExternalDataRoot As String
    Get
    Set
public:
property String^ ExternalDataRoot {
    String^ get ();
    void set (String^ value);
}
member ExternalDataRoot : string with get, set

Property Value

Type: String
The external data root.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.FileName Property

QueryInputFlatModelFileName Property
Gets or sets the file name of the script or executable to run.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

Property Value

Type: String
The file name of the script or executable to run.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.IdJob Property

QueryInputFlatModelIdJob Property
Gets or sets the job identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Guid IdJob { get; set; }
Public Property IdJob As Guid
    Get
    Set
public:
property Guid IdJob {
    Guid get ();
    void set (Guid value);
}
member IdJob : Guid with get, set

Property Value

Type: Guid
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.Instance Property

QueryInputFlatModelInstance Property
Gets or sets the instance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Instance { get; set; }
Public Property Instance As String
    Get
    Set
public:
property String^ Instance {
    String^ get ();
    void set (String^ value);
}
member Instance : string with get, set

Property Value

Type: String
The instance.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.IPAddress Property

QueryInputFlatModelIPAddress Property
Gets or sets the IP address to ping for a heartbeat.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string IPAddress { get; set; }
Public Property IPAddress As String
    Get
    Set
public:
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
member IPAddress : string with get, set

Property Value

Type: String
The IP address to ping for a heartbeat.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.JobId Property

QueryInputFlatModelJobId Property
Gets or sets the job identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string JobId { get; set; }
Public Property JobId As String
    Get
    Set
public:
property String^ JobId {
    String^ get ();
    void set (String^ value);
}
member JobId : string with get, set

Property Value

Type: String
The job identifier.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.NetworkId Property

QueryInputFlatModelNetworkId Property
Gets or sets the server name or IP address to ping.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string NetworkId { get; set; }
Public Property NetworkId As String
    Get
    Set
public:
property String^ NetworkId {
    String^ get ();
    void set (String^ value);
}
member NetworkId : string with get, set

Property Value

Type: String
The server name or IP address to ping.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.Operation Property

QueryInputFlatModelOperation Property
Gets or sets the mode of query aggregation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CompositeQueryOperationEnum Operation { get; set; }
Public Property Operation As CompositeQueryOperationEnum
    Get
    Set
public:
property CompositeQueryOperationEnum Operation {
    CompositeQueryOperationEnum get ();
    void set (CompositeQueryOperationEnum value);
}
member Operation : CompositeQueryOperationEnum with get, set

Property Value

Type: CompositeQueryOperationEnum
The mode.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.ParallelExecution Property

QueryInputFlatModelParallelExecution Property
Gets or sets a value indicating whether the queries are to be executed in parallel.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool ParallelExecution { get; set; }
Public Property ParallelExecution As Boolean
    Get
    Set
public:
property bool ParallelExecution {
    bool get ();
    void set (bool value);
}
member ParallelExecution : bool with get, set

Property Value

Type: Boolean
if the queries are to be executed in parallel; otherwise, .
Remarks
If this property is set to
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.Queries Property

QueryInputFlatModelQueries Property
Gets or sets the enumerable collection of queries.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public MonitorQueryFlatModel[] Queries { get; set; }
Public Property Queries As MonitorQueryFlatModel()
    Get
    Set
public:
property array<MonitorQueryFlatModel^>^ Queries {
    array<MonitorQueryFlatModel^>^ get ();
    void set (array<MonitorQueryFlatModel^>^ value);
}
member Queries : MonitorQueryFlatModel[] with get, set

Property Value

Type: MonitorQueryFlatModel
The enumerable collection of queries.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.ReplicationSetName Property

QueryInputFlatModelReplicationSetName Property
Gets or sets the name of the replication set.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ReplicationSetName { get; set; }
Public Property ReplicationSetName As String
    Get
    Set
public:
property String^ ReplicationSetName {
    String^ get ();
    void set (String^ value);
}
member ReplicationSetName : string with get, set

Property Value

Type: String
The name of the replication set.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.ResourceName Property

QueryInputFlatModelResourceName Property
Gets or sets the name of the resource.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ResourceName { get; set; }
Public Property ResourceName As String
    Get
    Set
public:
property String^ ResourceName {
    String^ get ();
    void set (String^ value);
}
member ResourceName : string with get, set

Property Value

Type: String
The name of the resource.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.Rules Property

QueryInputFlatModelRules Property
Gets or sets the rules.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<PhysicalRuleModel> Rules { get; set; }
Public Property Rules As IEnumerable(Of PhysicalRuleModel)
    Get
    Set
public:
property IEnumerable<PhysicalRuleModel^>^ Rules {
    IEnumerable<PhysicalRuleModel^>^ get ();
    void set (IEnumerable<PhysicalRuleModel^>^ value);
}
member Rules : IEnumerable<PhysicalRuleModel> with get, set

Property Value

Type: IEnumerable PhysicalRuleModel
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.RunAs Property

QueryInputFlatModelRunAs Property
Gets or sets the key to the credentials of the user as which the process will be run.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string RunAs { get; set; }
Public Property RunAs As String
    Get
    Set
public:
property String^ RunAs {
    String^ get ();
    void set (String^ value);
}
member RunAs : string with get, set

Property Value

Type: String
The key to the credentials of the user as which the process will be run.
Remarks
This value is the key into the Credentials dictionary under which the credentials are stored.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.ServiceName Property

QueryInputFlatModelServiceName Property
Gets or sets the name of the service to monitor.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
member ServiceName : string with get, set

Property Value

Type: String
The name of the service.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.SnapshotDataRoot Property

QueryInputFlatModelSnapshotDataRoot Property
Gets or sets the snapshot data root.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SnapshotDataRoot { get; set; }
Public Property SnapshotDataRoot As String
    Get
    Set
public:
property String^ SnapshotDataRoot {
    String^ get ();
    void set (String^ value);
}
member SnapshotDataRoot : string with get, set

Property Value

Type: String
The snapshot data root.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.Target Property

QueryInputFlatModelTarget Property
Gets or sets the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Uri Target { get; set; }
Public Property Target As Uri
    Get
    Set
public:
property Uri^ Target {
    Uri^ get ();
    void set (Uri^ value);
}
member Target : Uri with get, set

Property Value

Type: Uri
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.TargetHostName Property

QueryInputFlatModelTargetHostName Property
Gets or sets the name of the target host.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string TargetHostName { get; set; }
Public Property TargetHostName As String
    Get
    Set
public:
property String^ TargetHostName {
    String^ get ();
    void set (String^ value);
}
member TargetHostName : string with get, set

Property Value

Type: String
The name of the target host.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.VhdPath Property

QueryInputFlatModelVhdPath Property
Gets or sets the VHD path.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string[] VhdPath { get; set; }
Public Property VhdPath As String()
    Get
    Set
public:
property array<String^>^ VhdPath {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member VhdPath : string[] with get, set

Property Value

Type: String
The VHD path.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.VirtualSwitchInfoColl Property

QueryInputFlatModelVirtualSwitchInfoColl Property
Gets or sets the collection of virtual switch information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchInfoModel[] VirtualSwitchInfoColl { get; set; }
Public Property VirtualSwitchInfoColl As VirtualSwitchInfoModel()
    Get
    Set
public:
property array<VirtualSwitchInfoModel^>^ VirtualSwitchInfoColl {
    array<VirtualSwitchInfoModel^>^ get ();
    void set (array<VirtualSwitchInfoModel^>^ value);
}
member VirtualSwitchInfoColl : VirtualSwitchInfoModel[] with get, set

Property Value

Type: VirtualSwitchInfoModel
The virtual switch information coll.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.VmId Property

QueryInputFlatModelVmId Property
Gets or sets the VM identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string VmId { get; set; }
Public Property VmId As String
    Get
    Set
public:
property String^ VmId {
    String^ get ();
    void set (String^ value);
}
member VmId : string with get, set

Property Value

Type: String
The VM identifier.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.WaitForCompletion Property

QueryInputFlatModelWaitForCompletion Property
Gets or sets a value indicating whether to wait for completion.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool WaitForCompletion { get; set; }
Public Property WaitForCompletion As Boolean
    Get
    Set
public:
property bool WaitForCompletion {
    bool get ();
    void set (bool value);
}
member WaitForCompletion : bool with get, set

Property Value

Type: Boolean
if the query should wait for completion; otherwise, .
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.WaitForCompletionTimeout Property

QueryInputFlatModelWaitForCompletionTimeout Property
Gets or sets the wait for completion timeout.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TimeSpan> WaitForCompletionTimeout { get; set; }
Public Property WaitForCompletionTimeout As Nullable(Of TimeSpan)
    Get
    Set
public:
property Nullable<TimeSpan> WaitForCompletionTimeout {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
member WaitForCompletionTimeout : Nullable<TimeSpan> with get, set

Property Value

Type: Nullable TimeSpan
The wait for completion timeout.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel.WorkingDirectory Property

QueryInputFlatModelWorkingDirectory Property
Gets or sets the working directory.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string WorkingDirectory { get; set; }
Public Property WorkingDirectory As String
    Get
    Set
public:
property String^ WorkingDirectory {
    String^ get ();
    void set (String^ value);
}
member WorkingDirectory : string with get, set

Property Value

Type: String
The working directory.
See Also

Reference

QueryInputFlatModel Class


QueryInputFlatModel Methods

QueryInputFlatModel Methods

The QueryInputFlatModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

QueryInputFlatModel Class


QueryInputModel Class

QueryInputModel Class
Represents arguments to a monitoring query.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
More...

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class QueryInputModel
Public Class QueryInputModel
public ref class QueryInputModel
type QueryInputModel =  class end

The QueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | QueryInputModel | Initializes a new instance of the QueryInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsCompositeQueryInputModel
DoubleTake.Web.ModelsDtscStatusQueryInputModel
DoubleTake.Web.ModelsDTTargetResourceQueryInputModel
DoubleTake.Web.ModelsHeartbeatPingQueryInputModel
DoubleTake.Web.ModelsIcmpPingQueryInputModel
DoubleTake.Web.ModelsPerformanceCounterQueryInputModel
DoubleTake.Web.ModelsScriptQueryInputModel
DoubleTake.Web.ModelsServiceStatusQueryInputModel
DoubleTake.Web.ModelsShareQueryInputModel
DoubleTake.Web.ModelsVirtualSwitchConfigQueryInputModel
DoubleTake.Web.ModelsVmConfigQueryInputModel
DoubleTake.Web.ModelsVmHealthQueryInputModel


QueryInputModel Constructor

QueryInputModel Constructor
Initializes a new instance of the QueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public QueryInputModel()
Public Sub New
public:
QueryInputModel()
new : unit -> QueryInputModel
See Also

Reference

QueryInputModel Class


QueryInputModel Properties

QueryInputModel Properties

The QueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query.
Top
See Also

Reference

QueryInputModel Class


QueryInputModel.Credentials Property

QueryInputModelCredentials Property
Gets or sets the credentials to be used by the query.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public IDictionary<string, CredentialModel> Credentials { get; set; }
Public Property Credentials As IDictionary(Of String, CredentialModel)
    Get
    Set
public:
property IDictionary<String^, CredentialModel^>^ Credentials {
    IDictionary<String^, CredentialModel^>^ get ();
    void set (IDictionary<String^, CredentialModel^>^ value);
}
member Credentials : IDictionary<string, CredentialModel> with get, set

Property Value

Type: IDictionary String, CredentialModel
The credentials.
See Also

Reference

QueryInputModel Class


QueryInputModel Methods

QueryInputModel Methods

The QueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

QueryInputModel Class


QueryResultFlatModel Class

QueryResultFlatModel Class
Represents the result of a monitoring query.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultFlatModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class QueryResultFlatModel
Public Class QueryResultFlatModel
public ref class QueryResultFlatModel
type QueryResultFlatModel =  class end

The QueryResultFlatModel type exposes the following members.

Constructors
 | Name | Description
Public method | QueryResultFlatModel | Initializes a new instance of the QueryResultFlatModel class
Top
Properties
 | Name | Description
Public property | ClassName | Gets or sets the class name.
Public property | EnginePort | Gets or sets the engine port that was used to ping.
Public property | Exception | Gets or sets the query exception.
Public property | ExceptionDetail | Gets or sets the exception detail.
Public property | ExitCode | Gets or sets the exit code of the process.
Public property | ExitTime | Gets or sets the exit time.
Public property | IPAddress | Gets or sets the IP address that was pinged during this query.
Public property | NetworkId | Gets or sets the network id that was pinged.
Public property | OwningNode | Gets or sets the owning node.
Public property | QueryResults | Gets or sets the query results.
Public property | ReplyAddress | Gets or sets the IP address from which the reply was sent.
Public property | ResourceState | Gets or sets the state of the resource.
Public property | Result | Gets or sets a value indicating whether or not the query was successful.
Public property | Roundtrip | Gets or sets the duration of the ICMP ping round-trip.
Public property | ServiceName | Gets or sets the name of the service.
Public property | Shares | Gets or sets the shares.
Public property | StartTime | Gets or sets the start time.
Public property | Status | Gets or sets the IPStatus from the ping reply as a string.
Public property | VhdPath | Gets or sets the VHD paths.
Public property | VirtualSwitchInfoColl | Gets or sets the virtual switch information collection.
Public property | VmId | Gets or sets the vm identifier.
Public property | VmSnapshotDataRoot | Gets or sets the vm snapshot data root.
Public property | VmSnapshotFileNames | Gets or sets the vm snapshot file names.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


QueryResultFlatModel Constructor

QueryResultFlatModel Constructor
Initializes a new instance of the QueryResultFlatModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public QueryResultFlatModel()
Public Sub New
public:
QueryResultFlatModel()
new : unit -> QueryResultFlatModel
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel Properties

QueryResultFlatModel Properties

The QueryResultFlatModel type exposes the following members.

Properties
 | Name | Description
Public property | ClassName | Gets or sets the class name.
Public property | EnginePort | Gets or sets the engine port that was used to ping.
Public property | Exception | Gets or sets the query exception.
Public property | ExceptionDetail | Gets or sets the exception detail.
Public property | ExitCode | Gets or sets the exit code of the process.
Public property | ExitTime | Gets or sets the exit time.
Public property | IPAddress | Gets or sets the IP address that was pinged during this query.
Public property | NetworkId | Gets or sets the network id that was pinged.
Public property | OwningNode | Gets or sets the owning node.
Public property | QueryResults | Gets or sets the query results.
Public property | ReplyAddress | Gets or sets the IP address from which the reply was sent.
Public property | ResourceState | Gets or sets the state of the resource.
Public property | Result | Gets or sets a value indicating whether or not the query was successful.
Public property | Roundtrip | Gets or sets the duration of the ICMP ping round-trip.
Public property | ServiceName | Gets or sets the name of the service.
Public property | Shares | Gets or sets the shares.
Public property | StartTime | Gets or sets the start time.
Public property | Status | Gets or sets the IPStatus from the ping reply as a string.
Public property | VhdPath | Gets or sets the VHD paths.
Public property | VirtualSwitchInfoColl | Gets or sets the virtual switch information collection.
Public property | VmId | Gets or sets the vm identifier.
Public property | VmSnapshotDataRoot | Gets or sets the vm snapshot data root.
Public property | VmSnapshotFileNames | Gets or sets the vm snapshot file names.
Top
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.ClassName Property

QueryResultFlatModelClassName Property
Gets or sets the class name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ClassName { get; set; }
Public Property ClassName As String
    Get
    Set
public:
property String^ ClassName {
    String^ get ();
    void set (String^ value);
}
member ClassName : string with get, set

Property Value

Type: String
The class name.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.EnginePort Property

QueryResultFlatModelEnginePort Property
Gets or sets the engine port that was used to ping.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int EnginePort { get; set; }
Public Property EnginePort As Integer
    Get
    Set
public:
property int EnginePort {
    int get ();
    void set (int value);
}
member EnginePort : int with get, set

Property Value

Type: Int32
The engine port that was used to ping.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.Exception Property

QueryResultFlatModelException Property
Gets or sets the query exception.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ExceptionDetailModel Exception { get; set; }
Public Property Exception As ExceptionDetailModel
    Get
    Set
public:
property ExceptionDetailModel^ Exception {
    ExceptionDetailModel^ get ();
    void set (ExceptionDetailModel^ value);
}
member Exception : ExceptionDetailModel with get, set

Property Value

Type: ExceptionDetailModel
The query exception.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.ExceptionDetail Property

QueryResultFlatModelExceptionDetail Property
Gets or sets the exception detail.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ExceptionDetailModel ExceptionDetail { get; set; }
Public Property ExceptionDetail As ExceptionDetailModel
    Get
    Set
public:
property ExceptionDetailModel^ ExceptionDetail {
    ExceptionDetailModel^ get ();
    void set (ExceptionDetailModel^ value);
}
member ExceptionDetail : ExceptionDetailModel with get, set

Property Value

Type: ExceptionDetailModel
The exception detail.
Remarks
This property will only be non- if an exception was thrown by the ICMP ping operation.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.ExitCode Property

QueryResultFlatModelExitCode Property
Gets or sets the exit code of the process.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> ExitCode { get; set; }
Public Property ExitCode As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> ExitCode {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member ExitCode : Nullable<int> with get, set

Property Value

Type: Nullable Int32
The exit code.
Remarks
This value will be if the user chose not to wait for completion.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.ExitTime Property

QueryResultFlatModelExitTime Property
Gets or sets the exit time.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTimeOffset> ExitTime { get; set; }
Public Property ExitTime As Nullable(Of DateTimeOffset)
    Get
    Set
public:
property Nullable<DateTimeOffset> ExitTime {
    Nullable<DateTimeOffset> get ();
    void set (Nullable<DateTimeOffset> value);
}
member ExitTime : Nullable<DateTimeOffset> with get, set

Property Value

Type: Nullable DateTimeOffset
The exit time.
Remarks
This value will be if the user chose not to wait for completion.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.IPAddress Property

QueryResultFlatModelIPAddress Property
Gets or sets the IP address that was pinged during this query.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string IPAddress { get; set; }
Public Property IPAddress As String
    Get
    Set
public:
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
member IPAddress : string with get, set

Property Value

Type: String
The IP address that was pinged during this query.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.NetworkId Property

QueryResultFlatModelNetworkId Property
Gets or sets the network id that was pinged.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string NetworkId { get; set; }
Public Property NetworkId As String
    Get
    Set
public:
property String^ NetworkId {
    String^ get ();
    void set (String^ value);
}
member NetworkId : string with get, set

Property Value

Type: String
The network id that was pinged.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.OwningNode Property

QueryResultFlatModelOwningNode Property
Gets or sets the owning node.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string OwningNode { get; set; }
Public Property OwningNode As String
    Get
    Set
public:
property String^ OwningNode {
    String^ get ();
    void set (String^ value);
}
member OwningNode : string with get, set

Property Value

Type: String
The owning node.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.QueryResults Property

QueryResultFlatModelQueryResults Property
Gets or sets the query results.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public QueryResultFlatModel[] QueryResults { get; set; }
Public Property QueryResults As QueryResultFlatModel()
    Get
    Set
public:
property array<QueryResultFlatModel^>^ QueryResults {
    array<QueryResultFlatModel^>^ get ();
    void set (array<QueryResultFlatModel^>^ value);
}
member QueryResults : QueryResultFlatModel[] with get, set

Property Value

Type: QueryResultFlatModel
The query results.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.ReplyAddress Property

QueryResultFlatModelReplyAddress Property
Gets or sets the IP address from which the reply was sent.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ReplyAddress { get; set; }
Public Property ReplyAddress As String
    Get
    Set
public:
property String^ ReplyAddress {
    String^ get ();
    void set (String^ value);
}
member ReplyAddress : string with get, set

Property Value

Type: String
The IP address from which the reply was sent.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.ResourceState Property

QueryResultFlatModelResourceState Property
Gets or sets the state of the resource.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int ResourceState { get; set; }
Public Property ResourceState As Integer
    Get
    Set
public:
property int ResourceState {
    int get ();
    void set (int value);
}
member ResourceState : int with get, set

Property Value

Type: Int32
The state of the resource.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.Result Property

QueryResultFlatModelResult Property
Gets or sets a value indicating whether or not the query was successful.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public MonitorResultEnum Result { get; set; }
Public Property Result As MonitorResultEnum
    Get
    Set
public:
property MonitorResultEnum Result {
    MonitorResultEnum get ();
    void set (MonitorResultEnum value);
}
member Result : MonitorResultEnum with get, set

Property Value

Type: MonitorResultEnum
if query was successful; otherwise, .
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.Roundtrip Property

QueryResultFlatModelRoundtrip Property
Gets or sets the duration of the ICMP ping round-trip.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Roundtrip { get; set; }
Public Property Roundtrip As TimeSpan
    Get
    Set
public:
property TimeSpan Roundtrip {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Roundtrip : TimeSpan with get, set

Property Value

Type: TimeSpan
The duration of the ICMP ping round-trip.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.ServiceName Property

QueryResultFlatModelServiceName Property
Gets or sets the name of the service.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
member ServiceName : string with get, set

Property Value

Type: String
The name of the service.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.Shares Property

QueryResultFlatModelShares Property
Gets or sets the shares.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<ShareModel> Shares { get; set; }
Public Property Shares As IEnumerable(Of ShareModel)
    Get
    Set
public:
property IEnumerable<ShareModel^>^ Shares {
    IEnumerable<ShareModel^>^ get ();
    void set (IEnumerable<ShareModel^>^ value);
}
member Shares : IEnumerable<ShareModel> with get, set

Property Value

Type: IEnumerable ShareModel
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.StartTime Property

QueryResultFlatModelStartTime Property
Gets or sets the start time.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset StartTime { get; set; }
Public Property StartTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset StartTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member StartTime : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
The start time.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.Status Property

QueryResultFlatModelStatus Property
Gets or sets the IPStatus from the ping reply as a string.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Status { get; set; }
Public Property Status As String
    Get
    Set
public:
property String^ Status {
    String^ get ();
    void set (String^ value);
}
member Status : string with get, set

Property Value

Type: String
The IPStatus from the ping reply as a string.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.VhdPath Property

QueryResultFlatModelVhdPath Property
Gets or sets the VHD paths.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string[] VhdPath { get; set; }
Public Property VhdPath As String()
    Get
    Set
public:
property array<String^>^ VhdPath {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member VhdPath : string[] with get, set

Property Value

Type: String
The VHD path.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.VirtualSwitchInfoColl Property

QueryResultFlatModelVirtualSwitchInfoColl Property
Gets or sets the virtual switch information collection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchInfoModel[] VirtualSwitchInfoColl { get; set; }
Public Property VirtualSwitchInfoColl As VirtualSwitchInfoModel()
    Get
    Set
public:
property array<VirtualSwitchInfoModel^>^ VirtualSwitchInfoColl {
    array<VirtualSwitchInfoModel^>^ get ();
    void set (array<VirtualSwitchInfoModel^>^ value);
}
member VirtualSwitchInfoColl : VirtualSwitchInfoModel[] with get, set

Property Value

Type: VirtualSwitchInfoModel
The virtual switch information collection.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.VmId Property

QueryResultFlatModelVmId Property
Gets or sets the vm identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string VmId { get; set; }
Public Property VmId As String
    Get
    Set
public:
property String^ VmId {
    String^ get ();
    void set (String^ value);
}
member VmId : string with get, set

Property Value

Type: String
The vm identifier.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.VmSnapshotDataRoot Property

QueryResultFlatModelVmSnapshotDataRoot Property
Gets or sets the vm snapshot data root.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string VmSnapshotDataRoot { get; set; }
Public Property VmSnapshotDataRoot As String
    Get
    Set
public:
property String^ VmSnapshotDataRoot {
    String^ get ();
    void set (String^ value);
}
member VmSnapshotDataRoot : string with get, set

Property Value

Type: String
The vm snapshot data root.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel.VmSnapshotFileNames Property

QueryResultFlatModelVmSnapshotFileNames Property
Gets or sets the vm snapshot file names.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string[] VmSnapshotFileNames { get; set; }
Public Property VmSnapshotFileNames As String()
    Get
    Set
public:
property array<String^>^ VmSnapshotFileNames {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member VmSnapshotFileNames : string[] with get, set

Property Value

Type: String
The vm snapshot file names.
See Also

Reference

QueryResultFlatModel Class


QueryResultFlatModel Methods

QueryResultFlatModel Methods

The QueryResultFlatModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

QueryResultFlatModel Class


QueryResultModel Class

QueryResultModel Class
Represents the result of a monitoring query.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultModel
More...

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class QueryResultModel
Public Class QueryResultModel
public ref class QueryResultModel
type QueryResultModel =  class end

The QueryResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | QueryResultModel | Initializes a new instance of the QueryResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception.
Public property | Result | Gets or sets a value indicating whether or not the query was successful.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultModel
DoubleTake.Web.ModelsCompositeQueryResultModel
DoubleTake.Web.ModelsDtscStatusQueryResultModel
DoubleTake.Web.ModelsHeartbeatPingQueryResultModel
DoubleTake.Web.ModelsIcmpPingQueryResultModel
DoubleTake.Web.ModelsPerformanceCounterQueryResultModel
DoubleTake.Web.ModelsServiceStatusQueryResultModel
DoubleTake.Web.ModelsShareQueryResultModel
DoubleTake.Web.ModelsVirtualSwitchConfigQueryResultModel
DoubleTake.Web.ModelsVmConfigQueryResultModel
DoubleTake.Web.ModelsVmHealthQueryResultModel


QueryResultModel Constructor

QueryResultModel Constructor
Initializes a new instance of the QueryResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public QueryResultModel()
Public Sub New
public:
QueryResultModel()
new : unit -> QueryResultModel
See Also

Reference

QueryResultModel Class


QueryResultModel Properties

QueryResultModel Properties

The QueryResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception.
Public property | Result | Gets or sets a value indicating whether or not the query was successful.
Top
See Also

Reference

QueryResultModel Class


QueryResultModel.Exception Property

QueryResultModelException Property
Gets or sets the query exception.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ExceptionDetailModel Exception { get; set; }
Public Property Exception As ExceptionDetailModel
    Get
    Set
public:
property ExceptionDetailModel^ Exception {
    ExceptionDetailModel^ get ();
    void set (ExceptionDetailModel^ value);
}
member Exception : ExceptionDetailModel with get, set

Property Value

Type: ExceptionDetailModel
The query exception.
See Also

Reference

QueryResultModel Class


QueryResultModel.Result Property

QueryResultModelResult Property
Gets or sets a value indicating whether or not the query was successful.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public MonitorResultEnum Result { get; set; }
Public Property Result As MonitorResultEnum
    Get
    Set
public:
property MonitorResultEnum Result {
    MonitorResultEnum get ();
    void set (MonitorResultEnum value);
}
member Result : MonitorResultEnum with get, set

Property Value

Type: MonitorResultEnum
if query was successful; otherwise, .
See Also

Reference

QueryResultModel Class


QueryResultModel Methods

QueryResultModel Methods

The QueryResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

QueryResultModel Class


QueueStateEnum Enumeration

QueueStateEnum Enumeration
The operational state of a queue.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public enum QueueStateEnum
Public Enumeration QueueStateEnum
public enum class QueueStateEnum
type QueueStateEnum
Members
Member name | Value | Description
Pause | 0 | Queue processing is paused.
Active | 1 | The queue is being processed.
Scheduled | 2 | Queue processing is pending.
Remarks
Describes the current state of a queue, not necessarily the desired operation.
See Also

Reference

DoubleTake.Web.Models Namespace


QueueTaskParametersModel Class

QueueTaskParametersModel Class
Queue task parameters.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueueTaskParametersModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class QueueTaskParametersModel
Public NotInheritable Class QueueTaskParametersModel
public ref class QueueTaskParametersModel sealed
[<SealedAttribute>]
type QueueTaskParametersModel =  class end

The QueueTaskParametersModel type exposes the following members.

Constructors
 | Name | Description
Public method | QueueTaskParametersModel | Initializes a new instance of the QueueTaskParametersModel class
Top
Properties
 | Name | Description
Public property | DesktopInteractionMode | Gets or sets the desktop interaction mode.
Public property | OnExecute | Gets or sets the script to execute when the command is executed on the target.
Public property | OnQueue | Gets or sets the script to execute on the source when the command is queued.
Public property | OnReceive | Gets or sets the script to execute when the command is received on the target.
Public property | OnTransmit | Gets or sets the script to execute on the source when the command is transmitted to the target.
Public property | TaskName | Gets or sets the name of the task.
Public property | Timeout | Gets or sets the timeout.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


QueueTaskParametersModel Constructor

QueueTaskParametersModel Constructor
Initializes a new instance of the QueueTaskParametersModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public QueueTaskParametersModel()
Public Sub New
public:
QueueTaskParametersModel()
new : unit -> QueueTaskParametersModel
See Also

Reference

QueueTaskParametersModel Class


QueueTaskParametersModel Properties

QueueTaskParametersModel Properties

The QueueTaskParametersModel type exposes the following members.

Properties
 | Name | Description
Public property | DesktopInteractionMode | Gets or sets the desktop interaction mode.
Public property | OnExecute | Gets or sets the script to execute when the command is executed on the target.
Public property | OnQueue | Gets or sets the script to execute on the source when the command is queued.
Public property | OnReceive | Gets or sets the script to execute when the command is received on the target.
Public property | OnTransmit | Gets or sets the script to execute on the source when the command is transmitted to the target.
Public property | TaskName | Gets or sets the name of the task.
Public property | Timeout | Gets or sets the timeout.
Top
See Also

Reference

QueueTaskParametersModel Class


QueueTaskParametersModel.DesktopInteractionMode Property

QueueTaskParametersModelDesktopInteractionMode Property
Gets or sets the desktop interaction mode.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DesktopInteractionMode DesktopInteractionMode { get; set; }
Public Property DesktopInteractionMode As DesktopInteractionMode
    Get
    Set
public:
property DesktopInteractionMode DesktopInteractionMode {
    DesktopInteractionMode get ();
    void set (DesktopInteractionMode value);
}
member DesktopInteractionMode : DesktopInteractionMode with get, set

Property Value

Type: DesktopInteractionMode
The desktop interaction mode.
Remarks
Use this parameter to specify whether or not you want the script or executable to be able to interact with the desktop.
See Also

Reference

QueueTaskParametersModel Class


QueueTaskParametersModel.OnExecute Property

QueueTaskParametersModelOnExecute Property
Gets or sets the script to execute when the command is executed on the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public TaskParametersModel OnExecute { get; set; }
Public Property OnExecute As TaskParametersModel
    Get
    Set
public:
property TaskParametersModel^ OnExecute {
    TaskParametersModel^ get ();
    void set (TaskParametersModel^ value);
}
member OnExecute : TaskParametersModel with get, set

Property Value

Type: TaskParametersModel
The script to execute when the command is executed on the target.
See Also

Reference

QueueTaskParametersModel Class


QueueTaskParametersModel.OnQueue Property

QueueTaskParametersModelOnQueue Property
Gets or sets the script to execute on the source when the command is queued.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public TaskParametersModel OnQueue { get; set; }
Public Property OnQueue As TaskParametersModel
    Get
    Set
public:
property TaskParametersModel^ OnQueue {
    TaskParametersModel^ get ();
    void set (TaskParametersModel^ value);
}
member OnQueue : TaskParametersModel with get, set

Property Value

Type: TaskParametersModel
The script to execute on the source when the command is queued.
See Also

Reference

QueueTaskParametersModel Class


QueueTaskParametersModel.OnReceive Property

QueueTaskParametersModelOnReceive Property
Gets or sets the script to execute when the command is received on the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public TaskParametersModel OnReceive { get; set; }
Public Property OnReceive As TaskParametersModel
    Get
    Set
public:
property TaskParametersModel^ OnReceive {
    TaskParametersModel^ get ();
    void set (TaskParametersModel^ value);
}
member OnReceive : TaskParametersModel with get, set

Property Value

Type: TaskParametersModel
The script to execute when the command is received on the target.
See Also

Reference

QueueTaskParametersModel Class


QueueTaskParametersModel.OnTransmit Property

QueueTaskParametersModelOnTransmit Property
Gets or sets the script to execute on the source when the command is transmitted to the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public TaskParametersModel OnTransmit { get; set; }
Public Property OnTransmit As TaskParametersModel
    Get
    Set
public:
property TaskParametersModel^ OnTransmit {
    TaskParametersModel^ get ();
    void set (TaskParametersModel^ value);
}
member OnTransmit : TaskParametersModel with get, set

Property Value

Type: TaskParametersModel
The script to execute on the source when the command is transmitted to the target.
See Also

Reference

QueueTaskParametersModel Class


QueueTaskParametersModel.TaskName Property

QueueTaskParametersModelTaskName Property
Gets or sets the name of the task.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string TaskName { get; set; }
Public Property TaskName As String
    Get
    Set
public:
property String^ TaskName {
    String^ get ();
    void set (String^ value);
}
member TaskName : string with get, set

Property Value

Type: String
The name of the task.
See Also

Reference

QueueTaskParametersModel Class


QueueTaskParametersModel.Timeout Property

QueueTaskParametersModelTimeout Property
Gets or sets the timeout.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Timeout { get; set; }
Public Property Timeout As TimeSpan
    Get
    Set
public:
property TimeSpan Timeout {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Timeout : TimeSpan with get, set

Property Value

Type: TimeSpan
The timeout.
See Also

Reference

QueueTaskParametersModel Class


QueueTaskParametersModel Methods

QueueTaskParametersModel Methods

The QueueTaskParametersModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

QueueTaskParametersModel Class


RebootActionEnum Enumeration

RebootActionEnum Enumeration
An enumeration specifying the desired reboot behavior after a cutover.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public enum RebootActionEnum
Public Enumeration RebootActionEnum
public enum class RebootActionEnum
type RebootActionEnum
Members
Member name | Value | Description
RebootAfterCutover | 0 | The target should be rebooted after cutover.
DoNotRebootAfterCutover | 1 | The target should not be rebooted after cutover.
See Also

Reference

DoubleTake.Web.Models Namespace


RecommendedFailbackOptionsModel Class

RecommendedFailbackOptionsModel Class
Recommended failback options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsRecommendedFailbackOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class RecommendedFailbackOptionsModel
Public NotInheritable Class RecommendedFailbackOptionsModel
public ref class RecommendedFailbackOptionsModel sealed
[<SealedAttribute>]
type RecommendedFailbackOptionsModel =  class end

The RecommendedFailbackOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | RecommendedFailbackOptionsModel | Initializes a new instance of the RecommendedFailbackOptionsModel class
Top
Properties
 | Name | Description
Public property | FailbackOptions | Gets or sets the failback options.
Public property | IsSourceNew | Gets or sets a value indicating whether the data was restored, or is being restored, to a new source.
Public property | RestoreStatus | Gets or sets the status of the restore operation.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


RecommendedFailbackOptionsModel Constructor

RecommendedFailbackOptionsModel Constructor
Initializes a new instance of the RecommendedFailbackOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public RecommendedFailbackOptionsModel()
Public Sub New
public:
RecommendedFailbackOptionsModel()
new : unit -> RecommendedFailbackOptionsModel
See Also

Reference

RecommendedFailbackOptionsModel Class


RecommendedFailbackOptionsModel Properties

RecommendedFailbackOptionsModel Properties

The RecommendedFailbackOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | FailbackOptions | Gets or sets the failback options.
Public property | IsSourceNew | Gets or sets a value indicating whether the data was restored, or is being restored, to a new source.
Public property | RestoreStatus | Gets or sets the status of the restore operation.
Top
See Also

Reference

RecommendedFailbackOptionsModel Class


RecommendedFailbackOptionsModel.FailbackOptions Property

RecommendedFailbackOptionsModelFailbackOptions Property
Gets or sets the failback options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FailbackOptionsModel FailbackOptions { get; set; }
Public Property FailbackOptions As FailbackOptionsModel
    Get
    Set
public:
property FailbackOptionsModel^ FailbackOptions {
    FailbackOptionsModel^ get ();
    void set (FailbackOptionsModel^ value);
}
member FailbackOptions : FailbackOptionsModel with get, set

Property Value

Type: FailbackOptionsModel
See Also

Reference

RecommendedFailbackOptionsModel Class


RecommendedFailbackOptionsModel.IsSourceNew Property

RecommendedFailbackOptionsModelIsSourceNew Property
Gets or sets a value indicating whether the data was restored, or is being restored, to a new source.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSourceNew { get; set; }
Public Property IsSourceNew As Boolean
    Get
    Set
public:
property bool IsSourceNew {
    bool get ();
    void set (bool value);
}
member IsSourceNew : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RecommendedFailbackOptionsModel Class


RecommendedFailbackOptionsModel.RestoreStatus Property

RecommendedFailbackOptionsModelRestoreStatus Property
Gets or sets the status of the restore operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public RestoreStatus RestoreStatus { get; set; }
Public Property RestoreStatus As RestoreStatus
    Get
    Set
public:
property RestoreStatus RestoreStatus {
    RestoreStatus get ();
    void set (RestoreStatus value);
}
member RestoreStatus : RestoreStatus with get, set

Property Value

Type: RestoreStatus
See Also

Reference

RecommendedFailbackOptionsModel Class


RecommendedFailbackOptionsModel Methods

RecommendedFailbackOptionsModel Methods

The RecommendedFailbackOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RecommendedFailbackOptionsModel Class


RecommendedFailoverOptionsModel Class

RecommendedFailoverOptionsModel Class
Recommended failover options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsRecommendedFailoverOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class RecommendedFailoverOptionsModel
Public NotInheritable Class RecommendedFailoverOptionsModel
public ref class RecommendedFailoverOptionsModel sealed
[<SealedAttribute>]
type RecommendedFailoverOptionsModel =  class end

The RecommendedFailoverOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | RecommendedFailoverOptionsModel | Initializes a new instance of the RecommendedFailoverOptionsModel class
Top
Properties
 | Name | Description
Public property | FailoverOptions | Gets or sets the recommended failover options.
Public property | IsTestFailoverSupported | Gets or sets a value indicating whether test failover is supported.
Public property | Snapshots | Gets or sets the list of snapshots on the target server.
Public property | WarningTextTestFailover | Gets or sets a value indicating whether warning text to display if Test Failover is selected.
Public property | WarnUserOfInconsistentProtectionData | Gets or sets a value indicating whether to warn that the data on the target server may be in an inconsistent state.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


RecommendedFailoverOptionsModel Constructor

RecommendedFailoverOptionsModel Constructor
Initializes a new instance of the RecommendedFailoverOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public RecommendedFailoverOptionsModel()
Public Sub New
public:
RecommendedFailoverOptionsModel()
new : unit -> RecommendedFailoverOptionsModel
See Also

Reference

RecommendedFailoverOptionsModel Class


RecommendedFailoverOptionsModel Properties

RecommendedFailoverOptionsModel Properties

The RecommendedFailoverOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | FailoverOptions | Gets or sets the recommended failover options.
Public property | IsTestFailoverSupported | Gets or sets a value indicating whether test failover is supported.
Public property | Snapshots | Gets or sets the list of snapshots on the target server.
Public property | WarningTextTestFailover | Gets or sets a value indicating whether warning text to display if Test Failover is selected.
Public property | WarnUserOfInconsistentProtectionData | Gets or sets a value indicating whether to warn that the data on the target server may be in an inconsistent state.
Top
See Also

Reference

RecommendedFailoverOptionsModel Class


RecommendedFailoverOptionsModel.FailoverOptions Property

RecommendedFailoverOptionsModelFailoverOptions Property
Gets or sets the recommended failover options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FailoverOptionsModel FailoverOptions { get; set; }
Public Property FailoverOptions As FailoverOptionsModel
    Get
    Set
public:
property FailoverOptionsModel^ FailoverOptions {
    FailoverOptionsModel^ get ();
    void set (FailoverOptionsModel^ value);
}
member FailoverOptions : FailoverOptionsModel with get, set

Property Value

Type: FailoverOptionsModel
See Also

Reference

RecommendedFailoverOptionsModel Class


RecommendedFailoverOptionsModel.IsTestFailoverSupported Property

RecommendedFailoverOptionsModelIsTestFailoverSupported Property
Gets or sets a value indicating whether test failover is supported.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsTestFailoverSupported { get; set; }
Public Property IsTestFailoverSupported As Boolean
    Get
    Set
public:
property bool IsTestFailoverSupported {
    bool get ();
    void set (bool value);
}
member IsTestFailoverSupported : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RecommendedFailoverOptionsModel Class


RecommendedFailoverOptionsModel.Snapshots Property

RecommendedFailoverOptionsModelSnapshots Property
Gets or sets the list of snapshots on the target server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public SnapshotEntryModel[] Snapshots { get; set; }
Public Property Snapshots As SnapshotEntryModel()
    Get
    Set
public:
property array<SnapshotEntryModel^>^ Snapshots {
    array<SnapshotEntryModel^>^ get ();
    void set (array<SnapshotEntryModel^>^ value);
}
member Snapshots : SnapshotEntryModel[] with get, set

Property Value

Type: SnapshotEntryModel
See Also

Reference

RecommendedFailoverOptionsModel Class


RecommendedFailoverOptionsModel.WarningTextTestFailover Property

RecommendedFailoverOptionsModelWarningTextTestFailover Property
Gets or sets a value indicating whether warning text to display if Test Failover is selected.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool WarningTextTestFailover { get; set; }
Public Property WarningTextTestFailover As Boolean
    Get
    Set
public:
property bool WarningTextTestFailover {
    bool get ();
    void set (bool value);
}
member WarningTextTestFailover : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RecommendedFailoverOptionsModel Class


RecommendedFailoverOptionsModel.WarnUserOfInconsistentProtectionData Property

RecommendedFailoverOptionsModelWarnUserOfInconsistentProtectionData Property
Gets or sets a value indicating whether to warn that the data on the target server may be in an inconsistent state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool WarnUserOfInconsistentProtectionData { get; set; }
Public Property WarnUserOfInconsistentProtectionData As Boolean
    Get
    Set
public:
property bool WarnUserOfInconsistentProtectionData {
    bool get ();
    void set (bool value);
}
member WarnUserOfInconsistentProtectionData : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RecommendedFailoverOptionsModel Class


RecommendedFailoverOptionsModel Methods

RecommendedFailoverOptionsModel Methods

The RecommendedFailoverOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RecommendedFailoverOptionsModel Class


RecommendedJobOptionsModel Class

RecommendedJobOptionsModel Class
Recommended job options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsRecommendedJobOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class RecommendedJobOptionsModel
Public NotInheritable Class RecommendedJobOptionsModel
public ref class RecommendedJobOptionsModel sealed
[<SealedAttribute>]
type RecommendedJobOptionsModel =  class end

The RecommendedJobOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | RecommendedJobOptionsModel | Initializes a new instance of the RecommendedJobOptionsModel class
Top
Properties
 | Name | Description
Public property | JobOptions | Gets or sets the recommended job options.
Public property | JobQualificationResults | Gets or sets the job qualification results.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


RecommendedJobOptionsModel Constructor

RecommendedJobOptionsModel Constructor
Initializes a new instance of the RecommendedJobOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public RecommendedJobOptionsModel()
Public Sub New
public:
RecommendedJobOptionsModel()
new : unit -> RecommendedJobOptionsModel
See Also

Reference

RecommendedJobOptionsModel Class


RecommendedJobOptionsModel Properties

RecommendedJobOptionsModel Properties

The RecommendedJobOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | JobOptions | Gets or sets the recommended job options.
Public property | JobQualificationResults | Gets or sets the job qualification results.
Top
See Also

Reference

RecommendedJobOptionsModel Class


RecommendedJobOptionsModel.JobOptions Property

RecommendedJobOptionsModelJobOptions Property
Gets or sets the recommended job options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public JobOptionsModel JobOptions { get; set; }
Public Property JobOptions As JobOptionsModel
    Get
    Set
public:
property JobOptionsModel^ JobOptions {
    JobOptionsModel^ get ();
    void set (JobOptionsModel^ value);
}
member JobOptions : JobOptionsModel with get, set

Property Value

Type: JobOptionsModel
See Also

Reference

RecommendedJobOptionsModel Class


RecommendedJobOptionsModel.JobQualificationResults Property

RecommendedJobOptionsModelJobQualificationResults Property
Gets or sets the job qualification results.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public JobQualificationResultsModel JobQualificationResults { get; set; }
Public Property JobQualificationResults As JobQualificationResultsModel
    Get
    Set
public:
property JobQualificationResultsModel^ JobQualificationResults {
    JobQualificationResultsModel^ get ();
    void set (JobQualificationResultsModel^ value);
}
member JobQualificationResults : JobQualificationResultsModel with get, set

Property Value

Type: JobQualificationResultsModel
See Also

Reference

RecommendedJobOptionsModel Class


RecommendedJobOptionsModel Methods

RecommendedJobOptionsModel Methods

The RecommendedJobOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RecommendedJobOptionsModel Class


RecommendedJobOptionsRequestModel Class

RecommendedJobOptionsRequestModel Class
Recommended job options request model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsRecommendedJobOptionsRequestModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class RecommendedJobOptionsRequestModel
Public NotInheritable Class RecommendedJobOptionsRequestModel
public ref class RecommendedJobOptionsRequestModel sealed
[<SealedAttribute>]
type RecommendedJobOptionsRequestModel =  class end

The RecommendedJobOptionsRequestModel type exposes the following members.

Constructors
 | Name | Description
Public method | RecommendedJobOptionsRequestModel | Initializes a new instance of the RecommendedJobOptionsRequestModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the job credentials.
Public property | JobType | Gets or sets the job type.
Public property | Workload | Gets or sets the workload.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


RecommendedJobOptionsRequestModel Constructor

RecommendedJobOptionsRequestModel Constructor
Initializes a new instance of the RecommendedJobOptionsRequestModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public RecommendedJobOptionsRequestModel()
Public Sub New
public:
RecommendedJobOptionsRequestModel()
new : unit -> RecommendedJobOptionsRequestModel
See Also

Reference

RecommendedJobOptionsRequestModel Class


RecommendedJobOptionsRequestModel Properties

RecommendedJobOptionsRequestModel Properties

The RecommendedJobOptionsRequestModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the job credentials.
Public property | JobType | Gets or sets the job type.
Public property | Workload | Gets or sets the workload.
Top
See Also

Reference

RecommendedJobOptionsRequestModel Class


RecommendedJobOptionsRequestModel.Credentials Property

RecommendedJobOptionsRequestModelCredentials Property
Gets or sets the job credentials.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public JobCredentialsModel Credentials { get; set; }
Public Property Credentials As JobCredentialsModel
    Get
    Set
public:
property JobCredentialsModel^ Credentials {
    JobCredentialsModel^ get ();
    void set (JobCredentialsModel^ value);
}
member Credentials : JobCredentialsModel with get, set

Property Value

Type: JobCredentialsModel
See Also

Reference

RecommendedJobOptionsRequestModel Class


RecommendedJobOptionsRequestModel.JobType Property

RecommendedJobOptionsRequestModelJobType Property
Gets or sets the job type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string JobType { get; set; }
Public Property JobType As String
    Get
    Set
public:
property String^ JobType {
    String^ get ();
    void set (String^ value);
}
member JobType : string with get, set

Property Value

Type: String
See Also

Reference

RecommendedJobOptionsRequestModel Class


RecommendedJobOptionsRequestModel.Workload Property

RecommendedJobOptionsRequestModelWorkload Property
Gets or sets the workload.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public WorkloadModel Workload { get; set; }
Public Property Workload As WorkloadModel
    Get
    Set
public:
property WorkloadModel^ Workload {
    WorkloadModel^ get ();
    void set (WorkloadModel^ value);
}
member Workload : WorkloadModel with get, set

Property Value

Type: WorkloadModel
See Also

Reference

RecommendedJobOptionsRequestModel Class


RecommendedJobOptionsRequestModel Methods

RecommendedJobOptionsRequestModel Methods

The RecommendedJobOptionsRequestModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RecommendedJobOptionsRequestModel Class


RecommendedRestoreOptionsModel Class

RecommendedRestoreOptionsModel Class
Recommended restore options.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsRecommendedRestoreOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class RecommendedRestoreOptionsModel
Public NotInheritable Class RecommendedRestoreOptionsModel
public ref class RecommendedRestoreOptionsModel sealed
[<SealedAttribute>]
type RecommendedRestoreOptionsModel =  class end

The RecommendedRestoreOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | RecommendedRestoreOptionsModel | Initializes a new instance of the RecommendedRestoreOptionsModel class
Top
Properties
 | Name | Description
Public property | CanClearRestoreRequired | Gets or sets a value indicating whether the restore required state can be cleared.
Public property | IsNat | Gets or sets a value indicating whether this instance is NAT.
Public property | PossibleSourceAddresses | Gets or sets the possible source addresses.
Public property | RestoreOptions | Gets or sets the restore options.
Public property | SameSourceOnly | Gets or sets a value indicating whether the job only allows restoring to the same source.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


RecommendedRestoreOptionsModel Constructor

RecommendedRestoreOptionsModel Constructor
Initializes a new instance of the RecommendedRestoreOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public RecommendedRestoreOptionsModel()
Public Sub New
public:
RecommendedRestoreOptionsModel()
new : unit -> RecommendedRestoreOptionsModel
See Also

Reference

RecommendedRestoreOptionsModel Class


RecommendedRestoreOptionsModel Properties

RecommendedRestoreOptionsModel Properties

The RecommendedRestoreOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | CanClearRestoreRequired | Gets or sets a value indicating whether the restore required state can be cleared.
Public property | IsNat | Gets or sets a value indicating whether this instance is NAT.
Public property | PossibleSourceAddresses | Gets or sets the possible source addresses.
Public property | RestoreOptions | Gets or sets the restore options.
Public property | SameSourceOnly | Gets or sets a value indicating whether the job only allows restoring to the same source.
Top
See Also

Reference

RecommendedRestoreOptionsModel Class


RecommendedRestoreOptionsModel.CanClearRestoreRequired Property

RecommendedRestoreOptionsModelCanClearRestoreRequired Property
Gets or sets a value indicating whether the restore required state can be cleared.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool CanClearRestoreRequired { get; set; }
Public Property CanClearRestoreRequired As Boolean
    Get
    Set
public:
property bool CanClearRestoreRequired {
    bool get ();
    void set (bool value);
}
member CanClearRestoreRequired : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RecommendedRestoreOptionsModel Class


RecommendedRestoreOptionsModel.IsNat Property

RecommendedRestoreOptionsModelIsNat Property
Gets or sets a value indicating whether this instance is NAT.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsNat { get; set; }
Public Property IsNat As Boolean
    Get
    Set
public:
property bool IsNat {
    bool get ();
    void set (bool value);
}
member IsNat : bool with get, set

Property Value

Type: Boolean
if this instance is NAT; otherwise, .
See Also

Reference

RecommendedRestoreOptionsModel Class


RecommendedRestoreOptionsModel.PossibleSourceAddresses Property

RecommendedRestoreOptionsModelPossibleSourceAddresses Property
Gets or sets the possible source addresses.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string[] PossibleSourceAddresses { get; set; }
Public Property PossibleSourceAddresses As String()
    Get
    Set
public:
property array<String^>^ PossibleSourceAddresses {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member PossibleSourceAddresses : string[] with get, set

Property Value

Type: String
See Also

Reference

RecommendedRestoreOptionsModel Class


RecommendedRestoreOptionsModel.RestoreOptions Property

RecommendedRestoreOptionsModelRestoreOptions Property
Gets or sets the restore options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public RestoreOptionsModel RestoreOptions { get; set; }
Public Property RestoreOptions As RestoreOptionsModel
    Get
    Set
public:
property RestoreOptionsModel^ RestoreOptions {
    RestoreOptionsModel^ get ();
    void set (RestoreOptionsModel^ value);
}
member RestoreOptions : RestoreOptionsModel with get, set

Property Value

Type: RestoreOptionsModel
See Also

Reference

RecommendedRestoreOptionsModel Class


RecommendedRestoreOptionsModel.SameSourceOnly Property

RecommendedRestoreOptionsModelSameSourceOnly Property
Gets or sets a value indicating whether the job only allows restoring to the same source.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool SameSourceOnly { get; set; }
Public Property SameSourceOnly As Boolean
    Get
    Set
public:
property bool SameSourceOnly {
    bool get ();
    void set (bool value);
}
member SameSourceOnly : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RecommendedRestoreOptionsModel Class


RecommendedRestoreOptionsModel Methods

RecommendedRestoreOptionsModel Methods

The RecommendedRestoreOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RecommendedRestoreOptionsModel Class


RecursionMode Enumeration

RecursionMode Enumeration
Recursion mode.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum RecursionMode
Public Enumeration RecursionMode
public enum class RecursionMode
type RecursionMode
Members
Member name | Value | Description
Recursive | 0 | The recursive
NonRecursive | 1 | The non recursive
See Also

Reference

DoubleTake.Web.Models Namespace


ReMonitorActionEnum Enumeration

ReMonitorActionEnum Enumeration
Used to specify the action to take after a failback has completed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public enum ReMonitorActionEnum
Public Enumeration ReMonitorActionEnum
public enum class ReMonitorActionEnum
type ReMonitorActionEnum
Members
Member name | Value | Description
Remove | 0 | Indicates that we want to remove the monitor (stop monitoring).
Resume | 1 | Indicates that we want to resume monitoring.
See Also

Reference

DoubleTake.Web.Models Namespace


ReplicationSetInfoModel Class

ReplicationSetInfoModel Class
Replication set information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsReplicationSetInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class ReplicationSetInfoModel
Public NotInheritable Class ReplicationSetInfoModel
public ref class ReplicationSetInfoModel sealed
[<SealedAttribute>]
type ReplicationSetInfoModel =  class end

The ReplicationSetInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ReplicationSetInfoModel | Initializes a new instance of the ReplicationSetInfoModel class
Top
Properties
 | Name | Description
Public property | ByteCount | Gets or sets the byte count.
Public property | DirectoryCount | Gets or sets the directory count.
Public property | FileCount | Gets or sets the file count.
Public property | IsCalculating | Gets or sets a value indicating whether the replication set size is currently being calculated.
Public property | IsCaseSensitive | Gets or sets a value indicating whether this instance is case sensitive.
Public property | LastCalculated | Gets or sets the last calculated.
Public property | LastSaved | Gets or sets the last saved.
Public property | Name | Gets or sets the name.
Public property | Rules | Gets or sets the rules.
Public property | UsageType | Gets or sets the type of the usage.
Public property | VolumeCount | Gets or sets the volume count.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ReplicationSetInfoModel Constructor

ReplicationSetInfoModel Constructor
Initializes a new instance of the ReplicationSetInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ReplicationSetInfoModel()
Public Sub New
public:
ReplicationSetInfoModel()
new : unit -> ReplicationSetInfoModel
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel Properties

ReplicationSetInfoModel Properties

The ReplicationSetInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | ByteCount | Gets or sets the byte count.
Public property | DirectoryCount | Gets or sets the directory count.
Public property | FileCount | Gets or sets the file count.
Public property | IsCalculating | Gets or sets a value indicating whether the replication set size is currently being calculated.
Public property | IsCaseSensitive | Gets or sets a value indicating whether this instance is case sensitive.
Public property | LastCalculated | Gets or sets the last calculated.
Public property | LastSaved | Gets or sets the last saved.
Public property | Name | Gets or sets the name.
Public property | Rules | Gets or sets the rules.
Public property | UsageType | Gets or sets the type of the usage.
Public property | VolumeCount | Gets or sets the volume count.
Top
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel.ByteCount Property

ReplicationSetInfoModelByteCount Property
Gets or sets the byte count.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long ByteCount { get; set; }
Public Property ByteCount As Long
    Get
    Set
public:
property long long ByteCount {
    long long get ();
    void set (long long value);
}
member ByteCount : int64 with get, set

Property Value

Type: Int64
The byte count.
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel.DirectoryCount Property

ReplicationSetInfoModelDirectoryCount Property
Gets or sets the directory count.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long DirectoryCount { get; set; }
Public Property DirectoryCount As Long
    Get
    Set
public:
property long long DirectoryCount {
    long long get ();
    void set (long long value);
}
member DirectoryCount : int64 with get, set

Property Value

Type: Int64
The directory count.
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel.FileCount Property

ReplicationSetInfoModelFileCount Property
Gets or sets the file count.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long FileCount { get; set; }
Public Property FileCount As Long
    Get
    Set
public:
property long long FileCount {
    long long get ();
    void set (long long value);
}
member FileCount : int64 with get, set

Property Value

Type: Int64
The file count.
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel.IsCalculating Property

ReplicationSetInfoModelIsCalculating Property
Gets or sets a value indicating whether the replication set size is currently being calculated.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsCalculating { get; set; }
Public Property IsCalculating As Boolean
    Get
    Set
public:
property bool IsCalculating {
    bool get ();
    void set (bool value);
}
member IsCalculating : bool with get, set

Property Value

Type: Boolean
if the size is being calculated; otherwise .
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel.IsCaseSensitive Property

ReplicationSetInfoModelIsCaseSensitive Property
Gets or sets a value indicating whether this instance is case sensitive.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsCaseSensitive { get; set; }
Public Property IsCaseSensitive As Boolean
    Get
    Set
public:
property bool IsCaseSensitive {
    bool get ();
    void set (bool value);
}
member IsCaseSensitive : bool with get, set

Property Value

Type: Boolean
if this instance is case sensitive; otherwise, .
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel.LastCalculated Property

ReplicationSetInfoModelLastCalculated Property
Gets or sets the last calculated.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset LastCalculated { get; set; }
Public Property LastCalculated As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset LastCalculated {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member LastCalculated : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
The last calculated.
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel.LastSaved Property

ReplicationSetInfoModelLastSaved Property
Gets or sets the last saved.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset LastSaved { get; set; }
Public Property LastSaved As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset LastSaved {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member LastSaved : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
The last saved.
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel.Name Property

ReplicationSetInfoModelName Property
Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel.Rules Property

ReplicationSetInfoModelRules Property
Gets or sets the rules.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public PhysicalRuleModel[] Rules { get; set; }
Public Property Rules As PhysicalRuleModel()
    Get
    Set
public:
property array<PhysicalRuleModel^>^ Rules {
    array<PhysicalRuleModel^>^ get ();
    void set (array<PhysicalRuleModel^>^ value);
}
member Rules : PhysicalRuleModel[] with get, set

Property Value

Type: PhysicalRuleModel
The rules.
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel.UsageType Property

ReplicationSetInfoModelUsageType Property
Gets or sets the type of the usage.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string UsageType { get; set; }
Public Property UsageType As String
    Get
    Set
public:
property String^ UsageType {
    String^ get ();
    void set (String^ value);
}
member UsageType : string with get, set

Property Value

Type: String
The usage type.
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel.VolumeCount Property

ReplicationSetInfoModelVolumeCount Property
Gets or sets the volume count.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int VolumeCount { get; set; }
Public Property VolumeCount As Integer
    Get
    Set
public:
property int VolumeCount {
    int get ();
    void set (int value);
}
member VolumeCount : int with get, set

Property Value

Type: Int32
The volume count.
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetInfoModel Methods

ReplicationSetInfoModel Methods

The ReplicationSetInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReplicationSetInfoModel Class


ReplicationSetUsageType Enumeration

ReplicationSetUsageType Enumeration
Replication set usage type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum ReplicationSetUsageType
Public Enumeration ReplicationSetUsageType
public enum class ReplicationSetUsageType
type ReplicationSetUsageType
Members
Member name | Value | Description
Invalid | -1 | The invalid
Normal | 0 | The normal
SystemState | 1 | The system state
GeoCluster | 2 | The geo cluster
See Also

Reference

DoubleTake.Web.Models Namespace


ReplicationState Enumeration

ReplicationState Enumeration
Replication state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum ReplicationState
Public Enumeration ReplicationState
public enum class ReplicationState
type ReplicationState
Members
Member name | Value | Description
NotReplicating | 0 | The not replicating
OutOfMemory | 1 | The out of memory
Pending | 2 | The pending
Replicating | 3 | The replicating
Unknown | 4 | The unknown
Watchdog | 5 | The watchdog
Ready | 6 | The ready
See Also

Reference

DoubleTake.Web.Models Namespace


ReplicaVmInfoModel Class

ReplicaVmInfoModel Class
Replica VM info model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVmInfoModel
DoubleTake.Web.ModelsReplicaVmInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ReplicaVmInfoModel : VmInfoModel
Public NotInheritable Class ReplicaVmInfoModel
    Inherits VmInfoModel
public ref class ReplicaVmInfoModel sealed : public VmInfoModel
[<SealedAttribute>]
type ReplicaVmInfoModel =
    class
        inherit VmInfoModel
    end

The ReplicaVmInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ReplicaVmInfoModel | Initializes a new instance of the ReplicaVmInfoModel class
Top
Properties
 | Name | Description
Public property | Address | Gets or sets the virtual machine guest DNS name/IP Address. (Inherited from VmInfoModel.)
Public property | BiosGuid | Gets or sets the virtual machine BIOS Guid. (Inherited from VmInfoModel.)
Public property | BootVolumeSignature | Gets or sets the VM boot volume signature. (Inherited from VmInfoModel.)
Public property | CoresPerProcessor | Gets or sets the number of cores per processor.
Public property | Cpus | Gets or sets the number of CPUs for the replica Vm.
Public property | DisplayName | Gets or sets the virtual machine display name. (Inherited from VmInfoModel.)
Public property | GuestOS | Gets or sets the virtual machine guest OS. (Inherited from VmInfoModel.)
Public property | GuestUri | Gets or sets the guest URI. (Inherited from VmInfoModel.)
Public property | Id | Gets or sets the virtual machine Guid. (Inherited from VmInfoModel.)
Public property | Memory | Gets or sets the amount of RAM in bytes the Vm should have.
Public property | OperatingSystem | Gets or sets the ESX operating system name.
Public property | Path | Gets or sets the virtual machine location. (Inherited from VmInfoModel.)
Public property | PathTransformations | Gets or sets the path transformations. (Inherited from VmInfoModel.)
Public property | PrestageFolder | Gets or sets the prestage folder.
Public property | ReplicaVmVersion | Gets or sets the version of the Vm hardware.
Public property | RunOnceAtStartup | Gets or sets a command to run when the replica vm is first powered on.
Public property | SnapshotDataPath | Gets or sets the virtual machine snapshot location. (Inherited from VmInfoModel.)
Public property | SnapshotFileNames | Gets or sets the VM snapshot FileNames. (Inherited from VmInfoModel.)
Public property | SystemDirectory | Gets or sets the VM system directory. (Inherited from VmInfoModel.)
Public property | VirtualHardDiskPath | Gets or sets the virtual hard disk path. (Inherited from VmInfoModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ReplicaVmInfoModel Constructor

ReplicaVmInfoModel Constructor
Initializes a new instance of the ReplicaVmInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ReplicaVmInfoModel()
Public Sub New
public:
ReplicaVmInfoModel()
new : unit -> ReplicaVmInfoModel
See Also

Reference

ReplicaVmInfoModel Class


ReplicaVmInfoModel Properties

ReplicaVmInfoModel Properties

The ReplicaVmInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Address | Gets or sets the virtual machine guest DNS name/IP Address. (Inherited from VmInfoModel.)
Public property | BiosGuid | Gets or sets the virtual machine BIOS Guid. (Inherited from VmInfoModel.)
Public property | BootVolumeSignature | Gets or sets the VM boot volume signature. (Inherited from VmInfoModel.)
Public property | CoresPerProcessor | Gets or sets the number of cores per processor.
Public property | Cpus | Gets or sets the number of CPUs for the replica Vm.
Public property | DisplayName | Gets or sets the virtual machine display name. (Inherited from VmInfoModel.)
Public property | GuestOS | Gets or sets the virtual machine guest OS. (Inherited from VmInfoModel.)
Public property | GuestUri | Gets or sets the guest URI. (Inherited from VmInfoModel.)
Public property | Id | Gets or sets the virtual machine Guid. (Inherited from VmInfoModel.)
Public property | Memory | Gets or sets the amount of RAM in bytes the Vm should have.
Public property | OperatingSystem | Gets or sets the ESX operating system name.
Public property | Path | Gets or sets the virtual machine location. (Inherited from VmInfoModel.)
Public property | PathTransformations | Gets or sets the path transformations. (Inherited from VmInfoModel.)
Public property | PrestageFolder | Gets or sets the prestage folder.
Public property | ReplicaVmVersion | Gets or sets the version of the Vm hardware.
Public property | RunOnceAtStartup | Gets or sets a command to run when the replica vm is first powered on.
Public property | SnapshotDataPath | Gets or sets the virtual machine snapshot location. (Inherited from VmInfoModel.)
Public property | SnapshotFileNames | Gets or sets the VM snapshot FileNames. (Inherited from VmInfoModel.)
Public property | SystemDirectory | Gets or sets the VM system directory. (Inherited from VmInfoModel.)
Public property | VirtualHardDiskPath | Gets or sets the virtual hard disk path. (Inherited from VmInfoModel.)
Top
See Also

Reference

ReplicaVmInfoModel Class


ReplicaVmInfoModel.CoresPerProcessor Property

ReplicaVmInfoModelCoresPerProcessor Property
Gets or sets the number of cores per processor.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int CoresPerProcessor { get; set; }
Public Property CoresPerProcessor As Integer
    Get
    Set
public:
property int CoresPerProcessor {
    int get ();
    void set (int value);
}
member CoresPerProcessor : int with get, set

Property Value

Type: Int32
See Also

Reference

ReplicaVmInfoModel Class


ReplicaVmInfoModel.Cpus Property

ReplicaVmInfoModelCpus Property
Gets or sets the number of CPUs for the replica Vm.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int Cpus { get; set; }
Public Property Cpus As Integer
    Get
    Set
public:
property int Cpus {
    int get ();
    void set (int value);
}
member Cpus : int with get, set

Property Value

Type: Int32
See Also

Reference

ReplicaVmInfoModel Class


ReplicaVmInfoModel.Memory Property

ReplicaVmInfoModelMemory Property
Gets or sets the amount of RAM in bytes the Vm should have.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long Memory { get; set; }
Public Property Memory As Long
    Get
    Set
public:
property long long Memory {
    long long get ();
    void set (long long value);
}
member Memory : int64 with get, set

Property Value

Type: Int64
See Also

Reference

ReplicaVmInfoModel Class


ReplicaVmInfoModel.OperatingSystem Property

ReplicaVmInfoModelOperatingSystem Property
Gets or sets the ESX operating system name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string OperatingSystem { get; set; }
Public Property OperatingSystem As String
    Get
    Set
public:
property String^ OperatingSystem {
    String^ get ();
    void set (String^ value);
}
member OperatingSystem : string with get, set

Property Value

Type: String
See Also

Reference

ReplicaVmInfoModel Class


ReplicaVmInfoModel.PrestageFolder Property

ReplicaVmInfoModelPrestageFolder Property
Gets or sets the prestage folder.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string PrestageFolder { get; set; }
Public Property PrestageFolder As String
    Get
    Set
public:
property String^ PrestageFolder {
    String^ get ();
    void set (String^ value);
}
member PrestageFolder : string with get, set

Property Value

Type: String
See Also

Reference

ReplicaVmInfoModel Class


ReplicaVmInfoModel.ReplicaVmVersion Property

ReplicaVmInfoModelReplicaVmVersion Property
Gets or sets the version of the Vm hardware.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ReplicaVmVersion { get; set; }
Public Property ReplicaVmVersion As String
    Get
    Set
public:
property String^ ReplicaVmVersion {
    String^ get ();
    void set (String^ value);
}
member ReplicaVmVersion : string with get, set

Property Value

Type: String
See Also

Reference

ReplicaVmInfoModel Class


ReplicaVmInfoModel.RunOnceAtStartup Property

ReplicaVmInfoModelRunOnceAtStartup Property
Gets or sets a command to run when the replica vm is first powered on.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string RunOnceAtStartup { get; set; }
Public Property RunOnceAtStartup As String
    Get
    Set
public:
property String^ RunOnceAtStartup {
    String^ get ();
    void set (String^ value);
}
member RunOnceAtStartup : string with get, set

Property Value

Type: String
See Also

Reference

ReplicaVmInfoModel Class


ReplicaVmInfoModel Methods

ReplicaVmInfoModel Methods

The ReplicaVmInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ReplicaVmInfoModel Class


ResourceAndPassiveNodesModel Class

ResourceAndPassiveNodesModel Class
Resource and passive nodes.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsResourceAndPassiveNodesModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class ResourceAndPassiveNodesModel
Public Class ResourceAndPassiveNodesModel
public ref class ResourceAndPassiveNodesModel
type ResourceAndPassiveNodesModel =  class end

The ResourceAndPassiveNodesModel type exposes the following members.

Constructors
 | Name | Description
Public method | ResourceAndPassiveNodesModel | Initializes a new instance of the ResourceAndPassiveNodesModel class
Top
Properties
 | Name | Description
Public property | PassiveNodes | Gets or sets the passive nodes.
Public property | Resource | Gets or sets the resource.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ResourceAndPassiveNodesModel Constructor

ResourceAndPassiveNodesModel Constructor
Initializes a new instance of the ResourceAndPassiveNodesModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ResourceAndPassiveNodesModel()
Public Sub New
public:
ResourceAndPassiveNodesModel()
new : unit -> ResourceAndPassiveNodesModel
See Also

Reference

ResourceAndPassiveNodesModel Class


ResourceAndPassiveNodesModel Properties

ResourceAndPassiveNodesModel Properties

The ResourceAndPassiveNodesModel type exposes the following members.

Properties
 | Name | Description
Public property | PassiveNodes | Gets or sets the passive nodes.
Public property | Resource | Gets or sets the resource.
Top
See Also

Reference

ResourceAndPassiveNodesModel Class


ResourceAndPassiveNodesModel.PassiveNodes Property

ResourceAndPassiveNodesModelPassiveNodes Property
Gets or sets the passive nodes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string[] PassiveNodes { get; set; }
Public Property PassiveNodes As String()
    Get
    Set
public:
property array<String^>^ PassiveNodes {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member PassiveNodes : string[] with get, set

Property Value

Type: String
See Also

Reference

ResourceAndPassiveNodesModel Class


ResourceAndPassiveNodesModel.Resource Property

ResourceAndPassiveNodesModelResource Property
Gets or sets the resource.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Resource { get; set; }
Public Property Resource As String
    Get
    Set
public:
property String^ Resource {
    String^ get ();
    void set (String^ value);
}
member Resource : string with get, set

Property Value

Type: String
See Also

Reference

ResourceAndPassiveNodesModel Class


ResourceAndPassiveNodesModel Methods

ResourceAndPassiveNodesModel Methods

The ResourceAndPassiveNodesModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ResourceAndPassiveNodesModel Class


RestoreOptions Enumeration

RestoreOptions Enumeration
Restore options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum RestoreOptions
<FlagsAttribute>
Public Enumeration RestoreOptions
[FlagsAttribute]
public enum class RestoreOptions
[<FlagsAttribute>]
type RestoreOptions
Members
Member name | Value | Description
None | 0 | The none
UseTargetWorkload | 1 | The use target workload
RestoreWorkloadToSource | 2 | The restore workload to source
OverwriteExistingFiles | 4 | The overwrite existing files
See Also

Reference

DoubleTake.Web.Models Namespace


RestoreOptionsModel Class

RestoreOptionsModel Class
Restore options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsRestoreOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class RestoreOptionsModel
Public NotInheritable Class RestoreOptionsModel
public ref class RestoreOptionsModel sealed
[<SealedAttribute>]
type RestoreOptionsModel =  class end

The RestoreOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | RestoreOptionsModel | Initializes a new instance of the RestoreOptionsModel class
Top
Properties
 | Name | Description
Public property | ClearRestoreRequired | Gets or sets a value indicating whether to simply clear the "Restore required" state without restoring.
Public property | EnginePort | Gets or sets the engine port.
Public property | RestoreParameters | Gets or sets the parameters for the restore operation.
Public property | RestoreTargetHostUri | Gets or sets the restore target host URI.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


RestoreOptionsModel Constructor

RestoreOptionsModel Constructor
Initializes a new instance of the RestoreOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public RestoreOptionsModel()
Public Sub New
public:
RestoreOptionsModel()
new : unit -> RestoreOptionsModel
See Also

Reference

RestoreOptionsModel Class


RestoreOptionsModel Properties

RestoreOptionsModel Properties

The RestoreOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | ClearRestoreRequired | Gets or sets a value indicating whether to simply clear the "Restore required" state without restoring.
Public property | EnginePort | Gets or sets the engine port.
Public property | RestoreParameters | Gets or sets the parameters for the restore operation.
Public property | RestoreTargetHostUri | Gets or sets the restore target host URI.
Top
See Also

Reference

RestoreOptionsModel Class


RestoreOptionsModel.ClearRestoreRequired Property

RestoreOptionsModelClearRestoreRequired Property
Gets or sets a value indicating whether to simply clear the "Restore required" state without restoring.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool ClearRestoreRequired { get; set; }
Public Property ClearRestoreRequired As Boolean
    Get
    Set
public:
property bool ClearRestoreRequired {
    bool get ();
    void set (bool value);
}
member ClearRestoreRequired : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RestoreOptionsModel Class


RestoreOptionsModel.EnginePort Property

RestoreOptionsModelEnginePort Property
Gets or sets the engine port.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> EnginePort { get; set; }
Public Property EnginePort As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> EnginePort {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member EnginePort : Nullable<int> with get, set

Property Value

Type: Nullable Int32
See Also

Reference

RestoreOptionsModel Class


RestoreOptionsModel.RestoreParameters Property

RestoreOptionsModelRestoreParameters Property
Gets or sets the parameters for the restore operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public RestoreParametersModel RestoreParameters { get; set; }
Public Property RestoreParameters As RestoreParametersModel
    Get
    Set
public:
property RestoreParametersModel^ RestoreParameters {
    RestoreParametersModel^ get ();
    void set (RestoreParametersModel^ value);
}
member RestoreParameters : RestoreParametersModel with get, set

Property Value

Type: RestoreParametersModel
See Also

Reference

RestoreOptionsModel Class


RestoreOptionsModel.RestoreTargetHostUri Property

RestoreOptionsModelRestoreTargetHostUri Property
Gets or sets the restore target host URI.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Uri RestoreTargetHostUri { get; set; }
Public Property RestoreTargetHostUri As Uri
    Get
    Set
public:
property Uri^ RestoreTargetHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
member RestoreTargetHostUri : Uri with get, set

Property Value

Type: Uri
See Also

Reference

RestoreOptionsModel Class


RestoreOptionsModel Methods

RestoreOptionsModel Methods

The RestoreOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RestoreOptionsModel Class


RestoreParametersModel Class

RestoreParametersModel Class
Restore parameters model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsRestoreParametersModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class RestoreParametersModel
Public NotInheritable Class RestoreParametersModel
public ref class RestoreParametersModel sealed
[<SealedAttribute>]
type RestoreParametersModel =  class end

The RestoreParametersModel type exposes the following members.

Constructors
 | Name | Description
Public method | RestoreParametersModel | Initializes a new instance of the RestoreParametersModel class
Top
Properties
 | Name | Description
Public property | ArchiveBinLocation | Gets or sets the archive bin location.
Public property | ArchiveOption | Gets or sets the archive option.
Public property | CompressionLevel | Gets or sets the compression level.
Public property | MirrorComparisonCriteria | Gets or sets the comparison criteria.
Public property | OriginalSourceName | Gets or sets the name of the original source.
Public property | OriginalTargetRoute | Gets or sets the original target route.
Public property | PathTransformations | Gets or sets the path transformations.
Public property | ProcessOrphans | Gets or sets a value indicating whether to process orphans.
Public property | ReplicationSetName | Gets or sets the name of the replication set.
Public property | RestoreOptions | Gets or sets the options.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


RestoreParametersModel Constructor

RestoreParametersModel Constructor
Initializes a new instance of the RestoreParametersModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public RestoreParametersModel()
Public Sub New
public:
RestoreParametersModel()
new : unit -> RestoreParametersModel
See Also

Reference

RestoreParametersModel Class


RestoreParametersModel Properties

RestoreParametersModel Properties

The RestoreParametersModel type exposes the following members.

Properties
 | Name | Description
Public property | ArchiveBinLocation | Gets or sets the archive bin location.
Public property | ArchiveOption | Gets or sets the archive option.
Public property | CompressionLevel | Gets or sets the compression level.
Public property | MirrorComparisonCriteria | Gets or sets the comparison criteria.
Public property | OriginalSourceName | Gets or sets the name of the original source.
Public property | OriginalTargetRoute | Gets or sets the original target route.
Public property | PathTransformations | Gets or sets the path transformations.
Public property | ProcessOrphans | Gets or sets a value indicating whether to process orphans.
Public property | ReplicationSetName | Gets or sets the name of the replication set.
Public property | RestoreOptions | Gets or sets the options.
Top
See Also

Reference

RestoreParametersModel Class


RestoreParametersModel.ArchiveBinLocation Property

RestoreParametersModelArchiveBinLocation Property
Gets or sets the archive bin location.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ArchiveBinLocation { get; set; }
Public Property ArchiveBinLocation As String
    Get
    Set
public:
property String^ ArchiveBinLocation {
    String^ get ();
    void set (String^ value);
}
member ArchiveBinLocation : string with get, set

Property Value

Type: String
See Also

Reference

RestoreParametersModel Class


RestoreParametersModel.ArchiveOption Property

RestoreParametersModelArchiveOption Property
Gets or sets the archive option.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ArchiveRestoreOption ArchiveOption { get; set; }
Public Property ArchiveOption As ArchiveRestoreOption
    Get
    Set
public:
property ArchiveRestoreOption ArchiveOption {
    ArchiveRestoreOption get ();
    void set (ArchiveRestoreOption value);
}
member ArchiveOption : ArchiveRestoreOption with get, set

Property Value

Type: ArchiveRestoreOption
See Also

Reference

RestoreParametersModel Class


RestoreParametersModel.CompressionLevel Property

RestoreParametersModelCompressionLevel Property
Gets or sets the compression level.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CompressionLevelModel CompressionLevel { get; set; }
Public Property CompressionLevel As CompressionLevelModel
    Get
    Set
public:
property CompressionLevelModel^ CompressionLevel {
    CompressionLevelModel^ get ();
    void set (CompressionLevelModel^ value);
}
member CompressionLevel : CompressionLevelModel with get, set

Property Value

Type: CompressionLevelModel
See Also

Reference

RestoreParametersModel Class


RestoreParametersModel.MirrorComparisonCriteria Property

RestoreParametersModelMirrorComparisonCriteria Property
Gets or sets the comparison criteria.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public MirrorComparisonCriteria MirrorComparisonCriteria { get; set; }
Public Property MirrorComparisonCriteria As MirrorComparisonCriteria
    Get
    Set
public:
property MirrorComparisonCriteria MirrorComparisonCriteria {
    MirrorComparisonCriteria get ();
    void set (MirrorComparisonCriteria value);
}
member MirrorComparisonCriteria : MirrorComparisonCriteria with get, set

Property Value

Type: MirrorComparisonCriteria
See Also

Reference

RestoreParametersModel Class


RestoreParametersModel.OriginalSourceName Property

RestoreParametersModelOriginalSourceName Property
Gets or sets the name of the original source.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string OriginalSourceName { get; set; }
Public Property OriginalSourceName As String
    Get
    Set
public:
property String^ OriginalSourceName {
    String^ get ();
    void set (String^ value);
}
member OriginalSourceName : string with get, set

Property Value

Type: String
See Also

Reference

RestoreParametersModel Class


RestoreParametersModel.OriginalTargetRoute Property

RestoreParametersModelOriginalTargetRoute Property
Gets or sets the original target route.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string OriginalTargetRoute { get; set; }
Public Property OriginalTargetRoute As String
    Get
    Set
public:
property String^ OriginalTargetRoute {
    String^ get ();
    void set (String^ value);
}
member OriginalTargetRoute : string with get, set

Property Value

Type: String
See Also

Reference

RestoreParametersModel Class


RestoreParametersModel.PathTransformations Property

RestoreParametersModelPathTransformations Property
Gets or sets the path transformations.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public PathTransformationModel[] PathTransformations { get; set; }
Public Property PathTransformations As PathTransformationModel()
    Get
    Set
public:
property array<PathTransformationModel^>^ PathTransformations {
    array<PathTransformationModel^>^ get ();
    void set (array<PathTransformationModel^>^ value);
}
member PathTransformations : PathTransformationModel[] with get, set

Property Value

Type: PathTransformationModel
See Also

Reference

RestoreParametersModel Class


RestoreParametersModel.ProcessOrphans Property

RestoreParametersModelProcessOrphans Property
Gets or sets a value indicating whether to process orphans.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool ProcessOrphans { get; set; }
Public Property ProcessOrphans As Boolean
    Get
    Set
public:
property bool ProcessOrphans {
    bool get ();
    void set (bool value);
}
member ProcessOrphans : bool with get, set

Property Value

Type: Boolean
See Also

Reference

RestoreParametersModel Class


RestoreParametersModel.ReplicationSetName Property

RestoreParametersModelReplicationSetName Property
Gets or sets the name of the replication set.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ReplicationSetName { get; set; }
Public Property ReplicationSetName As String
    Get
    Set
public:
property String^ ReplicationSetName {
    String^ get ();
    void set (String^ value);
}
member ReplicationSetName : string with get, set

Property Value

Type: String
See Also

Reference

RestoreParametersModel Class


RestoreParametersModel.RestoreOptions Property

RestoreParametersModelRestoreOptions Property
Gets or sets the options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public RestoreOptions RestoreOptions { get; set; }
Public Property RestoreOptions As RestoreOptions
    Get
    Set
public:
property RestoreOptions RestoreOptions {
    RestoreOptions get ();
    void set (RestoreOptions value);
}
member RestoreOptions : RestoreOptions with get, set

Property Value

Type: RestoreOptions
See Also

Reference

RestoreParametersModel Class


RestoreParametersModel Methods

RestoreParametersModel Methods

The RestoreParametersModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RestoreParametersModel Class


RestoreStates Enumeration

RestoreStates Enumeration
Restore states.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum RestoreStates
<FlagsAttribute>
Public Enumeration RestoreStates
[FlagsAttribute]
public enum class RestoreStates
[<FlagsAttribute>]
type RestoreStates
Members
Member name | Value | Description
Connected | 4 | The connected
Mirroring | 16 | The mirroring
MirrorStopped | 32 | The mirror stopped
MultiConnect | 8 | The multi connect
None | 0 | The none
OldServer | 1 | The old server
OpDropped | 64 | The op dropped
OpRetrying | 128 | The op retrying
Required | 2 | The required
See Also

Reference

DoubleTake.Web.Models Namespace


RestoreStatus Enumeration

RestoreStatus Enumeration
Restore status.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum RestoreStatus
Public Enumeration RestoreStatus
public enum class RestoreStatus
type RestoreStatus
Members
Member name | Value | Description
NotStarted | 0 | The not started
Restoring | 1 | The restoring
Restored | 2 | The restored
See Also

Reference

DoubleTake.Web.Models Namespace


RunScriptRequestModel Class

RunScriptRequestModel Class
Run script request model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsRunScriptRequestModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class RunScriptRequestModel
Public NotInheritable Class RunScriptRequestModel
public ref class RunScriptRequestModel sealed
[<SealedAttribute>]
type RunScriptRequestModel =  class end

The RunScriptRequestModel type exposes the following members.

Constructors
 | Name | Description
Public method | RunScriptRequestModel | Initializes a new instance of the RunScriptRequestModel class
Top
Properties
 | Name | Description
Public property | Arguments | Gets or sets the arguments.
Public property | Credential | Gets or sets the credential.
Public property | ScriptPath | Gets or sets the script path.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


RunScriptRequestModel Constructor

RunScriptRequestModel Constructor
Initializes a new instance of the RunScriptRequestModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public RunScriptRequestModel()
Public Sub New
public:
RunScriptRequestModel()
new : unit -> RunScriptRequestModel
See Also

Reference

RunScriptRequestModel Class


RunScriptRequestModel Properties

RunScriptRequestModel Properties

The RunScriptRequestModel type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets or sets the arguments.
Public property | Credential | Gets or sets the credential.
Public property | ScriptPath | Gets or sets the script path.
Top
See Also

Reference

RunScriptRequestModel Class


RunScriptRequestModel.Arguments Property

RunScriptRequestModelArguments Property
Gets or sets the arguments.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
member Arguments : string with get, set

Property Value

Type: String
The arguments.
See Also

Reference

RunScriptRequestModel Class


RunScriptRequestModel.Credential Property

RunScriptRequestModelCredential Property
Gets or sets the credential.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CredentialModel Credential { get; set; }
Public Property Credential As CredentialModel
    Get
    Set
public:
property CredentialModel^ Credential {
    CredentialModel^ get ();
    void set (CredentialModel^ value);
}
member Credential : CredentialModel with get, set

Property Value

Type: CredentialModel
The credential.
See Also

Reference

RunScriptRequestModel Class


RunScriptRequestModel.ScriptPath Property

RunScriptRequestModelScriptPath Property
Gets or sets the script path.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ScriptPath { get; set; }
Public Property ScriptPath As String
    Get
    Set
public:
property String^ ScriptPath {
    String^ get ();
    void set (String^ value);
}
member ScriptPath : string with get, set

Property Value

Type: String
The script path.
See Also

Reference

RunScriptRequestModel Class


RunScriptRequestModel Methods

RunScriptRequestModel Methods

The RunScriptRequestModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RunScriptRequestModel Class


SaturationLevel Enumeration

SaturationLevel Enumeration
Saturation level.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum SaturationLevel
Public Enumeration SaturationLevel
public enum class SaturationLevel
type SaturationLevel
Members
Member name | Value | Description
Unknown | 0 | The unknown
None | 1 | The none
Partial | 2 | The partial
Full | 3 | The full
Error | 4 | The error
See Also

Reference

DoubleTake.Web.Models Namespace


ScheduleItemModel Class

ScheduleItemModel Class
Schedule item model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsScheduleItemModel
DoubleTake.Web.ModelsArchiveScheduleModel
DoubleTake.Web.ModelsOrphansScheduleModel
DoubleTake.Web.ModelsSnapshotScheduleModel
DoubleTake.Web.ModelsTransmissionScheduleModel
DoubleTake.Web.ModelsVerifyScheduleModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public abstract class ScheduleItemModel
Public MustInherit Class ScheduleItemModel
public ref class ScheduleItemModel abstract
[<AbstractClassAttribute>]
type ScheduleItemModel =  class end

The ScheduleItemModel type exposes the following members.

Constructors
 | Name | Description
Protected method | ScheduleItemModel | Initializes a new instance of the ScheduleItemModel class
Top
Properties
 | Name | Description
Public property | IsEnabled | Gets or sets a value indicating whether or not the item is enabled.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ScheduleItemModel Constructor

ScheduleItemModel Constructor
Initializes a new instance of the ScheduleItemModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
protected ScheduleItemModel()
Protected Sub New
protected:
ScheduleItemModel()
new : unit -> ScheduleItemModel
See Also

Reference

ScheduleItemModel Class


ScheduleItemModel Properties

ScheduleItemModel Properties

The ScheduleItemModel type exposes the following members.

Properties
 | Name | Description
Public property | IsEnabled | Gets or sets a value indicating whether or not the item is enabled.
Top
See Also

Reference

ScheduleItemModel Class


ScheduleItemModel.IsEnabled Property

ScheduleItemModelIsEnabled Property
Gets or sets a value indicating whether or not the item is enabled.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsEnabled { get; set; }
Public Property IsEnabled As Boolean
    Get
    Set
public:
property bool IsEnabled {
    bool get ();
    void set (bool value);
}
member IsEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ScheduleItemModel Class


ScheduleItemModel Methods

ScheduleItemModel Methods

The ScheduleItemModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScheduleItemModel Class


ScriptActionInputModel Class

ScriptActionInputModel Class
Represents the input to execute a script
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActionInputModel
DoubleTake.Web.ModelsScriptActionInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class ScriptActionInputModel : ActionInputModel
Public Class ScriptActionInputModel
    Inherits ActionInputModel
public ref class ScriptActionInputModel : public ActionInputModel
type ScriptActionInputModel =
    class
        inherit ActionInputModel
    end

The ScriptActionInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptActionInputModel | Initializes a new instance of the ScriptActionInputModel class
Top
Properties
 | Name | Description
Public property | Arguments | Gets or sets the arguments to the script or executable.
Public property | Credentials | Gets or sets the credentials to be used by the action. (Inherited from ActionInputModel.)
Public property | FileName | Gets or sets the file name of the script or executable to run.
Public property | QueryResult | Gets or sets the query result. (Inherited from ActionInputModel.)
Public property | RunAs | Gets or sets the key to the credentials of the user as which the process will be run.
Public property | WaitForCompletion | Gets or sets a value indicating whether to wait for completion.
Public property | WaitForCompletionTimeout | Gets or sets the wait for completion timeout.
Public property | WorkingDirectory | Gets or sets the working directory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsActionInputModel


ScriptActionInputModel Constructor

ScriptActionInputModel Constructor
Initializes a new instance of the ScriptActionInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ScriptActionInputModel()
Public Sub New
public:
ScriptActionInputModel()
new : unit -> ScriptActionInputModel
See Also

Reference

ScriptActionInputModel Class


ScriptActionInputModel Properties

ScriptActionInputModel Properties

The ScriptActionInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets or sets the arguments to the script or executable.
Public property | Credentials | Gets or sets the credentials to be used by the action. (Inherited from ActionInputModel.)
Public property | FileName | Gets or sets the file name of the script or executable to run.
Public property | QueryResult | Gets or sets the query result. (Inherited from ActionInputModel.)
Public property | RunAs | Gets or sets the key to the credentials of the user as which the process will be run.
Public property | WaitForCompletion | Gets or sets a value indicating whether to wait for completion.
Public property | WaitForCompletionTimeout | Gets or sets the wait for completion timeout.
Public property | WorkingDirectory | Gets or sets the working directory.
Top
See Also

Reference

ScriptActionInputModel Class


ScriptActionInputModel.Arguments Property

ScriptActionInputModelArguments Property
Gets or sets the arguments to the script or executable.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
member Arguments : string with get, set

Property Value

Type: String
The arguments to the script or executable.
See Also

Reference

ScriptActionInputModel Class


ScriptActionInputModel.FileName Property

ScriptActionInputModelFileName Property
Gets or sets the file name of the script or executable to run.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

Property Value

Type: String
The file name of the script or executable to run.
See Also

Reference

ScriptActionInputModel Class


ScriptActionInputModel.RunAs Property

ScriptActionInputModelRunAs Property
Gets or sets the key to the credentials of the user as which the process will be run.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string RunAs { get; set; }
Public Property RunAs As String
    Get
    Set
public:
property String^ RunAs {
    String^ get ();
    void set (String^ value);
}
member RunAs : string with get, set

Property Value

Type: String
The key to the credentials of the user as which the process will be run.
Remarks
This value is the key into the Credentials dictionary under which the credentials are stored.
See Also

Reference

ScriptActionInputModel Class


ScriptActionInputModel.WaitForCompletion Property

ScriptActionInputModelWaitForCompletion Property
Gets or sets a value indicating whether to wait for completion.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool WaitForCompletion { get; set; }
Public Property WaitForCompletion As Boolean
    Get
    Set
public:
property bool WaitForCompletion {
    bool get ();
    void set (bool value);
}
member WaitForCompletion : bool with get, set

Property Value

Type: Boolean
if the query should wait for completion; otherwise, .
See Also

Reference

ScriptActionInputModel Class


ScriptActionInputModel.WaitForCompletionTimeout Property

ScriptActionInputModelWaitForCompletionTimeout Property
Gets or sets the wait for completion timeout.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TimeSpan> WaitForCompletionTimeout { get; set; }
Public Property WaitForCompletionTimeout As Nullable(Of TimeSpan)
    Get
    Set
public:
property Nullable<TimeSpan> WaitForCompletionTimeout {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
member WaitForCompletionTimeout : Nullable<TimeSpan> with get, set

Property Value

Type: Nullable TimeSpan
The wait for completion timeout.
See Also

Reference

ScriptActionInputModel Class


ScriptActionInputModel.WorkingDirectory Property

ScriptActionInputModelWorkingDirectory Property
Gets or sets the working directory.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string WorkingDirectory { get; set; }
Public Property WorkingDirectory As String
    Get
    Set
public:
property String^ WorkingDirectory {
    String^ get ();
    void set (String^ value);
}
member WorkingDirectory : string with get, set

Property Value

Type: String
The working directory.
See Also

Reference

ScriptActionInputModel Class


ScriptActionInputModel Methods

ScriptActionInputModel Methods

The ScriptActionInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptActionInputModel Class


ScriptActionResultModel Class

ScriptActionResultModel Class
Represents the results of a Script action.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActionResultModel
DoubleTake.Web.ModelsScriptActionResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class ScriptActionResultModel : ActionResultModel
Public Class ScriptActionResultModel
    Inherits ActionResultModel
public ref class ScriptActionResultModel : public ActionResultModel
type ScriptActionResultModel =
    class
        inherit ActionResultModel
    end

The ScriptActionResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptActionResultModel | Initializes a new instance of the ScriptActionResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the action exception. (Inherited from ActionResultModel.)
Public property | ExitCode | Gets or sets the exit code of the process.
Public property | ExitTime | Gets or sets the exit time.
Public property | StartTime | Gets or sets the start time.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsActionResultModel


ScriptActionResultModel Constructor

ScriptActionResultModel Constructor
Initializes a new instance of the ScriptActionResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ScriptActionResultModel()
Public Sub New
public:
ScriptActionResultModel()
new : unit -> ScriptActionResultModel
See Also

Reference

ScriptActionResultModel Class


ScriptActionResultModel Properties

ScriptActionResultModel Properties

The ScriptActionResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the action exception. (Inherited from ActionResultModel.)
Public property | ExitCode | Gets or sets the exit code of the process.
Public property | ExitTime | Gets or sets the exit time.
Public property | StartTime | Gets or sets the start time.
Top
See Also

Reference

ScriptActionResultModel Class


ScriptActionResultModel.ExitCode Property

ScriptActionResultModelExitCode Property
Gets or sets the exit code of the process.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> ExitCode { get; set; }
Public Property ExitCode As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> ExitCode {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member ExitCode : Nullable<int> with get, set

Property Value

Type: Nullable Int32
The exit code.
Remarks
This value will be if the user chose not to wait for completion.
See Also

Reference

ScriptActionResultModel Class


ScriptActionResultModel.ExitTime Property

ScriptActionResultModelExitTime Property
Gets or sets the exit time.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTimeOffset> ExitTime { get; set; }
Public Property ExitTime As Nullable(Of DateTimeOffset)
    Get
    Set
public:
property Nullable<DateTimeOffset> ExitTime {
    Nullable<DateTimeOffset> get ();
    void set (Nullable<DateTimeOffset> value);
}
member ExitTime : Nullable<DateTimeOffset> with get, set

Property Value

Type: Nullable DateTimeOffset
The exit time.
Remarks
This value will be if the user chose not to wait for completion.
See Also

Reference

ScriptActionResultModel Class


ScriptActionResultModel.StartTime Property

ScriptActionResultModelStartTime Property
Gets or sets the start time.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset StartTime { get; set; }
Public Property StartTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset StartTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member StartTime : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
The start time.
See Also

Reference

ScriptActionResultModel Class


ScriptActionResultModel Methods

ScriptActionResultModel Methods

The ScriptActionResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptActionResultModel Class


ScriptExecutionMode Enumeration

ScriptExecutionMode Enumeration
Script execution mode.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum ScriptExecutionMode
Public Enumeration ScriptExecutionMode
public enum class ScriptExecutionMode
type ScriptExecutionMode
Members
Member name | Value | Description
Synchronous | 0 | The synchronous
Asynchronous | 1 | The asynchronous
See Also

Reference

DoubleTake.Web.Models Namespace


ScriptPointModel Class

ScriptPointModel Class
Script point model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsScriptPointModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ScriptPointModel
Public NotInheritable Class ScriptPointModel
public ref class ScriptPointModel sealed
[<SealedAttribute>]
type ScriptPointModel =  class end

The ScriptPointModel type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptPointModel | Initializes a new instance of the ScriptPointModel class
Top
Properties
 | Name | Description
Public property | Arguments | Gets or sets the arguments.
Public property | ExecutionMode | Gets or sets the execution mode.
Public property | InteractionMode | Gets or sets the interaction mode.
Public property | Path | Gets or sets the path.
Public property | ScriptType | Gets or sets the script point type.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ScriptPointModel Constructor

ScriptPointModel Constructor
Initializes a new instance of the ScriptPointModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptPointModel()
Public Sub New
public:
ScriptPointModel()
new : unit -> ScriptPointModel
See Also

Reference

ScriptPointModel Class


ScriptPointModel Properties

ScriptPointModel Properties

The ScriptPointModel type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets or sets the arguments.
Public property | ExecutionMode | Gets or sets the execution mode.
Public property | InteractionMode | Gets or sets the interaction mode.
Public property | Path | Gets or sets the path.
Public property | ScriptType | Gets or sets the script point type.
Top
See Also

Reference

ScriptPointModel Class


ScriptPointModel.Arguments Property

ScriptPointModelArguments Property
Gets or sets the arguments.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
member Arguments : string with get, set

Property Value

Type: String
See Also

Reference

ScriptPointModel Class


ScriptPointModel.ExecutionMode Property

ScriptPointModelExecutionMode Property
Gets or sets the execution mode.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptExecutionMode ExecutionMode { get; set; }
Public Property ExecutionMode As ScriptExecutionMode
    Get
    Set
public:
property ScriptExecutionMode ExecutionMode {
    ScriptExecutionMode get ();
    void set (ScriptExecutionMode value);
}
member ExecutionMode : ScriptExecutionMode with get, set

Property Value

Type: ScriptExecutionMode
See Also

Reference

ScriptPointModel Class


ScriptPointModel.InteractionMode Property

ScriptPointModelInteractionMode Property
Gets or sets the interaction mode.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DesktopInteractionMode InteractionMode { get; set; }
Public Property InteractionMode As DesktopInteractionMode
    Get
    Set
public:
property DesktopInteractionMode InteractionMode {
    DesktopInteractionMode get ();
    void set (DesktopInteractionMode value);
}
member InteractionMode : DesktopInteractionMode with get, set

Property Value

Type: DesktopInteractionMode
See Also

Reference

ScriptPointModel Class


ScriptPointModel.Path Property

ScriptPointModelPath Property
Gets or sets the path.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
member Path : string with get, set

Property Value

Type: String
See Also

Reference

ScriptPointModel Class


ScriptPointModel.ScriptType Property

ScriptPointModelScriptType Property
Gets or sets the script point type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ScriptPointType ScriptType { get; set; }
Public Property ScriptType As ScriptPointType
    Get
    Set
public:
property ScriptPointType ScriptType {
    ScriptPointType get ();
    void set (ScriptPointType value);
}
member ScriptType : ScriptPointType with get, set

Property Value

Type: ScriptPointType
See Also

Reference

ScriptPointModel Class


ScriptPointModel Methods

ScriptPointModel Methods

The ScriptPointModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptPointModel Class


ScriptPointType Enumeration

ScriptPointType Enumeration
Script point type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum ScriptPointType
Public Enumeration ScriptPointType
public enum class ScriptPointType
type ScriptPointType
Members
Member name | Value | Description
MirrorStart | 0 | The mirror start
MirrorComplete | 1 | The mirror complete
MirrorStop | 2 | The mirror stop
See Also

Reference

DoubleTake.Web.Models Namespace


ScriptQueryInputModel Class

ScriptQueryInputModel Class
Defines the input into the script query.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsScriptQueryInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class ScriptQueryInputModel : QueryInputModel
Public Class ScriptQueryInputModel
    Inherits QueryInputModel
public ref class ScriptQueryInputModel : public QueryInputModel
type ScriptQueryInputModel =
    class
        inherit QueryInputModel
    end

The ScriptQueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | ScriptQueryInputModel | Initializes a new instance of the ScriptQueryInputModel class
Top
Properties
 | Name | Description
Public property | Arguments | Gets or sets the arguments to the script or executable.
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | FileName | Gets or sets the file name of the script or executable to run.
Public property | RunAs | Gets or sets the key to the credentials of the user as which the process will be run.
Public property | WaitForCompletion | Gets or sets a value indicating whether to wait for completion.
Public property | WaitForCompletionTimeout | Gets or sets the wait for completion timeout.
Public property | WorkingDirectory | Gets or sets the working directory.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ScriptQueryInputModel Constructor

ScriptQueryInputModel Constructor
Initializes a new instance of the ScriptQueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ScriptQueryInputModel()
Public Sub New
public:
ScriptQueryInputModel()
new : unit -> ScriptQueryInputModel
See Also

Reference

ScriptQueryInputModel Class


ScriptQueryInputModel Properties

ScriptQueryInputModel Properties

The ScriptQueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets or sets the arguments to the script or executable.
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | FileName | Gets or sets the file name of the script or executable to run.
Public property | RunAs | Gets or sets the key to the credentials of the user as which the process will be run.
Public property | WaitForCompletion | Gets or sets a value indicating whether to wait for completion.
Public property | WaitForCompletionTimeout | Gets or sets the wait for completion timeout.
Public property | WorkingDirectory | Gets or sets the working directory.
Top
See Also

Reference

ScriptQueryInputModel Class


ScriptQueryInputModel.Arguments Property

ScriptQueryInputModelArguments Property
Gets or sets the arguments to the script or executable.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
member Arguments : string with get, set

Property Value

Type: String
The arguments to the script or executable.
See Also

Reference

ScriptQueryInputModel Class


ScriptQueryInputModel.FileName Property

ScriptQueryInputModelFileName Property
Gets or sets the file name of the script or executable to run.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}
member FileName : string with get, set

Property Value

Type: String
The file name of the script or executable to run.
See Also

Reference

ScriptQueryInputModel Class


ScriptQueryInputModel.RunAs Property

ScriptQueryInputModelRunAs Property
Gets or sets the key to the credentials of the user as which the process will be run.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string RunAs { get; set; }
Public Property RunAs As String
    Get
    Set
public:
property String^ RunAs {
    String^ get ();
    void set (String^ value);
}
member RunAs : string with get, set

Property Value

Type: String
The key to the credentials of the user as which the process will be run.
Remarks
This value is the key into the Credentials dictionary under which the credentials are stored.
See Also

Reference

ScriptQueryInputModel Class


ScriptQueryInputModel.WaitForCompletion Property

ScriptQueryInputModelWaitForCompletion Property
Gets or sets a value indicating whether to wait for completion.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool WaitForCompletion { get; set; }
Public Property WaitForCompletion As Boolean
    Get
    Set
public:
property bool WaitForCompletion {
    bool get ();
    void set (bool value);
}
member WaitForCompletion : bool with get, set

Property Value

Type: Boolean
if the query should wait for completion; otherwise, .
See Also

Reference

ScriptQueryInputModel Class


ScriptQueryInputModel.WaitForCompletionTimeout Property

ScriptQueryInputModelWaitForCompletionTimeout Property
Gets or sets the wait for completion timeout.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TimeSpan> WaitForCompletionTimeout { get; set; }
Public Property WaitForCompletionTimeout As Nullable(Of TimeSpan)
    Get
    Set
public:
property Nullable<TimeSpan> WaitForCompletionTimeout {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
member WaitForCompletionTimeout : Nullable<TimeSpan> with get, set

Property Value

Type: Nullable TimeSpan
The wait for completion timeout.
See Also

Reference

ScriptQueryInputModel Class


ScriptQueryInputModel.WorkingDirectory Property

ScriptQueryInputModelWorkingDirectory Property
Gets or sets the working directory.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string WorkingDirectory { get; set; }
Public Property WorkingDirectory As String
    Get
    Set
public:
property String^ WorkingDirectory {
    String^ get ();
    void set (String^ value);
}
member WorkingDirectory : string with get, set

Property Value

Type: String
The working directory.
See Also

Reference

ScriptQueryInputModel Class


ScriptQueryInputModel Methods

ScriptQueryInputModel Methods

The ScriptQueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ScriptQueryInputModel Class


ServerInfoModel Class

ServerInfoModel Class
Server info model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsServerInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ServerInfoModel
Public NotInheritable Class ServerInfoModel
public ref class ServerInfoModel sealed
[<SealedAttribute>]
type ServerInfoModel =  class end

The ServerInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServerInfoModel | Initializes a new instance of the ServerInfoModel class
Top
Properties
 | Name | Description
Public property | BiosGuid | Gets or sets the BIOS GUID.
Public property | BootVolume | Gets or sets the boot volume.
Public property | CoresPerProcessor | Gets or sets the number of cores per processor.
Public property | Disks | Gets or sets the disks on the server that has volume(s) on it.
Public property | Domain | Gets or sets the domain the server is a member of.
Public property | FullyQualifiedDomain | Gets or sets the fully qualified domain name of the server.
Public property | HalInternalName | Gets or sets the internal name of the hardware abstraction layer (HAL).
Public property | HalVersion | Gets or sets the version of the hardware abstraction layer (HAL).
Public property | IsClustered | Gets or sets a value indicating whether the server is part of a cluster.
Public property | IsHostedByHyperV | Gets or sets a value indicating whether or not the server is hosted by Hyper-V.
Public property | IsHostedByVMware | Gets or sets a value indicating whether or not the server is hosted by VMware.
Public property | IsHostedByXen | Gets or sets a value indicating whether or not the server is hosted by Xen.
Public property | IsHyperVHost | Gets or sets a value indicating whether or not the server is a Hyper-V host.
Public property | IsReplicationEnabled | Gets or sets a value indicating whether or not replication is enabled.
Public property | IsSbs | Gets or sets a value indicating whether or not the server is running Microsoft Windows Small Business Server.
Public property | IsSse | Gets or sets a value indicating whether or not the server is running Microsoft Windows Storage Server.
Public property | LogicalProcessorCount | Gets or sets the logical processor count. This count includes threads.
Public property | LvmOptions | Gets or sets LVM information for volumes.
Public property | ManagementPort | Gets or sets the port where the management service is listening.
Public property | MemorySize | Gets or sets the amount of memory on the server.
Public property | Name | Gets or sets the name of the server.
Public property | NetworkInterfaces | Gets or sets the network interfaces on the server.
Public property | NodeLockedServerInfo | Gets or sets the node locked server information.
Public property | OperatingSystem | Gets or sets the operating system on the server.
Public property | ProcessorCount | Gets or sets the processor count of the server.
Public property | ProgramFilesPath | Gets or sets the program files path.
Public property | SystemPath | Gets or sets the system path.
Public property | SystemRoot | Gets or sets the system root path.
Public property | SystemVolume | Gets or sets the system volume.
Public property | Volumes | Gets or sets the volumes on the server.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ServerInfoModel Constructor

ServerInfoModel Constructor
Initializes a new instance of the ServerInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ServerInfoModel()
Public Sub New
public:
ServerInfoModel()
new : unit -> ServerInfoModel
See Also

Reference

ServerInfoModel Class


ServerInfoModel Properties

ServerInfoModel Properties

The ServerInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | BiosGuid | Gets or sets the BIOS GUID.
Public property | BootVolume | Gets or sets the boot volume.
Public property | CoresPerProcessor | Gets or sets the number of cores per processor.
Public property | Disks | Gets or sets the disks on the server that has volume(s) on it.
Public property | Domain | Gets or sets the domain the server is a member of.
Public property | FullyQualifiedDomain | Gets or sets the fully qualified domain name of the server.
Public property | HalInternalName | Gets or sets the internal name of the hardware abstraction layer (HAL).
Public property | HalVersion | Gets or sets the version of the hardware abstraction layer (HAL).
Public property | IsClustered | Gets or sets a value indicating whether the server is part of a cluster.
Public property | IsHostedByHyperV | Gets or sets a value indicating whether or not the server is hosted by Hyper-V.
Public property | IsHostedByVMware | Gets or sets a value indicating whether or not the server is hosted by VMware.
Public property | IsHostedByXen | Gets or sets a value indicating whether or not the server is hosted by Xen.
Public property | IsHyperVHost | Gets or sets a value indicating whether or not the server is a Hyper-V host.
Public property | IsReplicationEnabled | Gets or sets a value indicating whether or not replication is enabled.
Public property | IsSbs | Gets or sets a value indicating whether or not the server is running Microsoft Windows Small Business Server.
Public property | IsSse | Gets or sets a value indicating whether or not the server is running Microsoft Windows Storage Server.
Public property | LogicalProcessorCount | Gets or sets the logical processor count. This count includes threads.
Public property | LvmOptions | Gets or sets LVM information for volumes.
Public property | ManagementPort | Gets or sets the port where the management service is listening.
Public property | MemorySize | Gets or sets the amount of memory on the server.
Public property | Name | Gets or sets the name of the server.
Public property | NetworkInterfaces | Gets or sets the network interfaces on the server.
Public property | NodeLockedServerInfo | Gets or sets the node locked server information.
Public property | OperatingSystem | Gets or sets the operating system on the server.
Public property | ProcessorCount | Gets or sets the processor count of the server.
Public property | ProgramFilesPath | Gets or sets the program files path.
Public property | SystemPath | Gets or sets the system path.
Public property | SystemRoot | Gets or sets the system root path.
Public property | SystemVolume | Gets or sets the system volume.
Public property | Volumes | Gets or sets the volumes on the server.
Top
See Also

Reference

ServerInfoModel Class


ServerInfoModel.BiosGuid Property

ServerInfoModelBiosGuid Property
Gets or sets the BIOS GUID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Guid BiosGuid { get; set; }
Public Property BiosGuid As Guid
    Get
    Set
public:
property Guid BiosGuid {
    Guid get ();
    void set (Guid value);
}
member BiosGuid : Guid with get, set

Property Value

Type: Guid
See Also

Reference

ServerInfoModel Class


ServerInfoModel.BootVolume Property

ServerInfoModelBootVolume Property
Gets or sets the boot volume.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string BootVolume { get; set; }
Public Property BootVolume As String
    Get
    Set
public:
property String^ BootVolume {
    String^ get ();
    void set (String^ value);
}
member BootVolume : string with get, set

Property Value

Type: String
See Also

Reference

ServerInfoModel Class


ServerInfoModel.CoresPerProcessor Property

ServerInfoModelCoresPerProcessor Property
Gets or sets the number of cores per processor.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int CoresPerProcessor { get; set; }
Public Property CoresPerProcessor As Integer
    Get
    Set
public:
property int CoresPerProcessor {
    int get ();
    void set (int value);
}
member CoresPerProcessor : int with get, set

Property Value

Type: Int32
The number of cores per processor.
See Also

Reference

ServerInfoModel Class


ServerInfoModel.Disks Property

ServerInfoModelDisks Property
Gets or sets the disks on the server that has volume(s) on it.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DiskModel[] Disks { get; set; }
Public Property Disks As DiskModel()
    Get
    Set
public:
property array<DiskModel^>^ Disks {
    array<DiskModel^>^ get ();
    void set (array<DiskModel^>^ value);
}
member Disks : DiskModel[] with get, set

Property Value

Type: DiskModel
See Also

Reference

ServerInfoModel Class


ServerInfoModel.Domain Property

ServerInfoModelDomain Property
Gets or sets the domain the server is a member of.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Domain { get; set; }
Public Property Domain As String
    Get
    Set
public:
property String^ Domain {
    String^ get ();
    void set (String^ value);
}
member Domain : string with get, set

Property Value

Type: String
See Also

Reference

ServerInfoModel Class


ServerInfoModel.FullyQualifiedDomain Property

ServerInfoModelFullyQualifiedDomain Property
Gets or sets the fully qualified domain name of the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string FullyQualifiedDomain { get; set; }
Public Property FullyQualifiedDomain As String
    Get
    Set
public:
property String^ FullyQualifiedDomain {
    String^ get ();
    void set (String^ value);
}
member FullyQualifiedDomain : string with get, set

Property Value

Type: String
See Also

Reference

ServerInfoModel Class


ServerInfoModel.HalInternalName Property

ServerInfoModelHalInternalName Property
Gets or sets the internal name of the hardware abstraction layer (HAL).

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string HalInternalName { get; set; }
Public Property HalInternalName As String
    Get
    Set
public:
property String^ HalInternalName {
    String^ get ();
    void set (String^ value);
}
member HalInternalName : string with get, set

Property Value

Type: String
See Also

Reference

ServerInfoModel Class


ServerInfoModel.HalVersion Property

ServerInfoModelHalVersion Property
Gets or sets the version of the hardware abstraction layer (HAL).

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string HalVersion { get; set; }
Public Property HalVersion As String
    Get
    Set
public:
property String^ HalVersion {
    String^ get ();
    void set (String^ value);
}
member HalVersion : string with get, set

Property Value

Type: String
See Also

Reference

ServerInfoModel Class


ServerInfoModel.IsClustered Property

ServerInfoModelIsClustered Property
Gets or sets a value indicating whether the server is part of a cluster.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsClustered { get; set; }
Public Property IsClustered As Boolean
    Get
    Set
public:
property bool IsClustered {
    bool get ();
    void set (bool value);
}
member IsClustered : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerInfoModel Class


ServerInfoModel.IsHostedByHyperV Property

ServerInfoModelIsHostedByHyperV Property
Gets or sets a value indicating whether or not the server is hosted by Hyper-V.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsHostedByHyperV { get; set; }
Public Property IsHostedByHyperV As Boolean
    Get
    Set
public:
property bool IsHostedByHyperV {
    bool get ();
    void set (bool value);
}
member IsHostedByHyperV : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerInfoModel Class


ServerInfoModel.IsHostedByVMware Property

ServerInfoModelIsHostedByVMware Property
Gets or sets a value indicating whether or not the server is hosted by VMware.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsHostedByVMware { get; set; }
Public Property IsHostedByVMware As Boolean
    Get
    Set
public:
property bool IsHostedByVMware {
    bool get ();
    void set (bool value);
}
member IsHostedByVMware : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerInfoModel Class


ServerInfoModel.IsHostedByXen Property

ServerInfoModelIsHostedByXen Property
Gets or sets a value indicating whether or not the server is hosted by Xen.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsHostedByXen { get; set; }
Public Property IsHostedByXen As Boolean
    Get
    Set
public:
property bool IsHostedByXen {
    bool get ();
    void set (bool value);
}
member IsHostedByXen : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerInfoModel Class


ServerInfoModel.IsHyperVHost Property

ServerInfoModelIsHyperVHost Property
Gets or sets a value indicating whether or not the server is a Hyper-V host.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsHyperVHost { get; set; }
Public Property IsHyperVHost As Boolean
    Get
    Set
public:
property bool IsHyperVHost {
    bool get ();
    void set (bool value);
}
member IsHyperVHost : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerInfoModel Class


ServerInfoModel.IsReplicationEnabled Property

ServerInfoModelIsReplicationEnabled Property
Gets or sets a value indicating whether or not replication is enabled.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsReplicationEnabled { get; set; }
Public Property IsReplicationEnabled As Boolean
    Get
    Set
public:
property bool IsReplicationEnabled {
    bool get ();
    void set (bool value);
}
member IsReplicationEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerInfoModel Class


ServerInfoModel.IsSbs Property

ServerInfoModelIsSbs Property
Gets or sets a value indicating whether or not the server is running Microsoft Windows Small Business Server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSbs { get; set; }
Public Property IsSbs As Boolean
    Get
    Set
public:
property bool IsSbs {
    bool get ();
    void set (bool value);
}
member IsSbs : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerInfoModel Class


ServerInfoModel.IsSse Property

ServerInfoModelIsSse Property
Gets or sets a value indicating whether or not the server is running Microsoft Windows Storage Server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSse { get; set; }
Public Property IsSse As Boolean
    Get
    Set
public:
property bool IsSse {
    bool get ();
    void set (bool value);
}
member IsSse : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServerInfoModel Class


ServerInfoModel.LogicalProcessorCount Property

ServerInfoModelLogicalProcessorCount Property
Gets or sets the logical processor count. This count includes threads.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int LogicalProcessorCount { get; set; }
Public Property LogicalProcessorCount As Integer
    Get
    Set
public:
property int LogicalProcessorCount {
    int get ();
    void set (int value);
}
member LogicalProcessorCount : int with get, set

Property Value

Type: Int32
The logical processor count.
See Also

Reference

ServerInfoModel Class


ServerInfoModel.LvmOptions Property

ServerInfoModelLvmOptions Property
Gets or sets LVM information for volumes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public LvmOptionsModel LvmOptions { get; set; }
Public Property LvmOptions As LvmOptionsModel
    Get
    Set
public:
property LvmOptionsModel^ LvmOptions {
    LvmOptionsModel^ get ();
    void set (LvmOptionsModel^ value);
}
member LvmOptions : LvmOptionsModel with get, set

Property Value

Type: LvmOptionsModel
See Also

Reference

ServerInfoModel Class


ServerInfoModel.ManagementPort Property

ServerInfoModelManagementPort Property
Gets or sets the port where the management service is listening.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int ManagementPort { get; set; }
Public Property ManagementPort As Integer
    Get
    Set
public:
property int ManagementPort {
    int get ();
    void set (int value);
}
member ManagementPort : int with get, set

Property Value

Type: Int32
See Also

Reference

ServerInfoModel Class


ServerInfoModel.MemorySize Property

ServerInfoModelMemorySize Property
Gets or sets the amount of memory on the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long MemorySize { get; set; }
Public Property MemorySize As Long
    Get
    Set
public:
property long long MemorySize {
    long long get ();
    void set (long long value);
}
member MemorySize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

ServerInfoModel Class


ServerInfoModel.Name Property

ServerInfoModelName Property
Gets or sets the name of the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

ServerInfoModel Class


ServerInfoModel.NetworkInterfaces Property

ServerInfoModelNetworkInterfaces Property
Gets or sets the network interfaces on the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public NetworkInterfaceModel[] NetworkInterfaces { get; set; }
Public Property NetworkInterfaces As NetworkInterfaceModel()
    Get
    Set
public:
property array<NetworkInterfaceModel^>^ NetworkInterfaces {
    array<NetworkInterfaceModel^>^ get ();
    void set (array<NetworkInterfaceModel^>^ value);
}
member NetworkInterfaces : NetworkInterfaceModel[] with get, set

Property Value

Type: NetworkInterfaceModel
See Also

Reference

ServerInfoModel Class


ServerInfoModel.NodeLockedServerInfo Property

ServerInfoModelNodeLockedServerInfo Property
Gets or sets the node locked server information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string NodeLockedServerInfo { get; set; }
Public Property NodeLockedServerInfo As String
    Get
    Set
public:
property String^ NodeLockedServerInfo {
    String^ get ();
    void set (String^ value);
}
member NodeLockedServerInfo : string with get, set

Property Value

Type: String
See Also

Reference

ServerInfoModel Class


ServerInfoModel.OperatingSystem Property

ServerInfoModelOperatingSystem Property
Gets or sets the operating system on the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public OperatingSystemModel OperatingSystem { get; set; }
Public Property OperatingSystem As OperatingSystemModel
    Get
    Set
public:
property OperatingSystemModel^ OperatingSystem {
    OperatingSystemModel^ get ();
    void set (OperatingSystemModel^ value);
}
member OperatingSystem : OperatingSystemModel with get, set

Property Value

Type: OperatingSystemModel
See Also

Reference

ServerInfoModel Class


ServerInfoModel.ProcessorCount Property

ServerInfoModelProcessorCount Property
Gets or sets the processor count of the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int ProcessorCount { get; set; }
Public Property ProcessorCount As Integer
    Get
    Set
public:
property int ProcessorCount {
    int get ();
    void set (int value);
}
member ProcessorCount : int with get, set

Property Value

Type: Int32
See Also

Reference

ServerInfoModel Class


ServerInfoModel.ProgramFilesPath Property

ServerInfoModelProgramFilesPath Property
Gets or sets the program files path.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ProgramFilesPath { get; set; }
Public Property ProgramFilesPath As String
    Get
    Set
public:
property String^ ProgramFilesPath {
    String^ get ();
    void set (String^ value);
}
member ProgramFilesPath : string with get, set

Property Value

Type: String
See Also

Reference

ServerInfoModel Class


ServerInfoModel.SystemPath Property

ServerInfoModelSystemPath Property
Gets or sets the system path.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SystemPath { get; set; }
Public Property SystemPath As String
    Get
    Set
public:
property String^ SystemPath {
    String^ get ();
    void set (String^ value);
}
member SystemPath : string with get, set

Property Value

Type: String
See Also

Reference

ServerInfoModel Class


ServerInfoModel.SystemRoot Property

ServerInfoModelSystemRoot Property
Gets or sets the system root path.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SystemRoot { get; set; }
Public Property SystemRoot As String
    Get
    Set
public:
property String^ SystemRoot {
    String^ get ();
    void set (String^ value);
}
member SystemRoot : string with get, set

Property Value

Type: String
See Also

Reference

ServerInfoModel Class


ServerInfoModel.SystemVolume Property

ServerInfoModelSystemVolume Property
Gets or sets the system volume.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SystemVolume { get; set; }
Public Property SystemVolume As String
    Get
    Set
public:
property String^ SystemVolume {
    String^ get ();
    void set (String^ value);
}
member SystemVolume : string with get, set

Property Value

Type: String
See Also

Reference

ServerInfoModel Class


ServerInfoModel.Volumes Property

ServerInfoModelVolumes Property
Gets or sets the volumes on the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VolumeModel[] Volumes { get; set; }
Public Property Volumes As VolumeModel()
    Get
    Set
public:
property array<VolumeModel^>^ Volumes {
    array<VolumeModel^>^ get ();
    void set (array<VolumeModel^>^ value);
}
member Volumes : VolumeModel[] with get, set

Property Value

Type: VolumeModel
See Also

Reference

ServerInfoModel Class


ServerInfoModel Methods

ServerInfoModel Methods

The ServerInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServerInfoModel Class


ServerQualificationResultsModel Class

ServerQualificationResultsModel Class
Server qualification results model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsServerQualificationResultsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ServerQualificationResultsModel
Public NotInheritable Class ServerQualificationResultsModel
public ref class ServerQualificationResultsModel sealed
[<SealedAttribute>]
type ServerQualificationResultsModel =  class end

The ServerQualificationResultsModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServerQualificationResultsModel | Initializes a new instance of the ServerQualificationResultsModel class
Top
Properties
 | Name | Description
Public property | Cpus | Gets or sets the number of CPUs.
Public property | Memory | Gets or sets the amount of RAM in bytes.
Public property | Version | Gets or sets the version.
Public property | VirtualSwitches | Gets or sets the virtual switches.
Public property | Volumes | Gets or sets the volumes.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ServerQualificationResultsModel Constructor

ServerQualificationResultsModel Constructor
Initializes a new instance of the ServerQualificationResultsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ServerQualificationResultsModel()
Public Sub New
public:
ServerQualificationResultsModel()
new : unit -> ServerQualificationResultsModel
See Also

Reference

ServerQualificationResultsModel Class


ServerQualificationResultsModel Properties

ServerQualificationResultsModel Properties

The ServerQualificationResultsModel type exposes the following members.

Properties
 | Name | Description
Public property | Cpus | Gets or sets the number of CPUs.
Public property | Memory | Gets or sets the amount of RAM in bytes.
Public property | Version | Gets or sets the version.
Public property | VirtualSwitches | Gets or sets the virtual switches.
Public property | Volumes | Gets or sets the volumes.
Top
See Also

Reference

ServerQualificationResultsModel Class


ServerQualificationResultsModel.Cpus Property

ServerQualificationResultsModelCpus Property
Gets or sets the number of CPUs.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int Cpus { get; set; }
Public Property Cpus As Integer
    Get
    Set
public:
property int Cpus {
    int get ();
    void set (int value);
}
member Cpus : int with get, set

Property Value

Type: Int32
See Also

Reference

ServerQualificationResultsModel Class


ServerQualificationResultsModel.Memory Property

ServerQualificationResultsModelMemory Property
Gets or sets the amount of RAM in bytes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long Memory { get; set; }
Public Property Memory As Long
    Get
    Set
public:
property long long Memory {
    long long get ();
    void set (long long value);
}
member Memory : int64 with get, set

Property Value

Type: Int64
See Also

Reference

ServerQualificationResultsModel Class


ServerQualificationResultsModel.Version Property

ServerQualificationResultsModelVersion Property
Gets or sets the version.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Version { get; set; }
Public Property Version As String
    Get
    Set
public:
property String^ Version {
    String^ get ();
    void set (String^ value);
}
member Version : string with get, set

Property Value

Type: String
See Also

Reference

ServerQualificationResultsModel Class


ServerQualificationResultsModel.VirtualSwitches Property

ServerQualificationResultsModelVirtualSwitches Property
Gets or sets the virtual switches.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchInfoModel[] VirtualSwitches { get; set; }
Public Property VirtualSwitches As VirtualSwitchInfoModel()
    Get
    Set
public:
property array<VirtualSwitchInfoModel^>^ VirtualSwitches {
    array<VirtualSwitchInfoModel^>^ get ();
    void set (array<VirtualSwitchInfoModel^>^ value);
}
member VirtualSwitches : VirtualSwitchInfoModel[] with get, set

Property Value

Type: VirtualSwitchInfoModel
See Also

Reference

ServerQualificationResultsModel Class


ServerQualificationResultsModel.Volumes Property

ServerQualificationResultsModelVolumes Property
Gets or sets the volumes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VolumeQualificationResultsModel[] Volumes { get; set; }
Public Property Volumes As VolumeQualificationResultsModel()
    Get
    Set
public:
property array<VolumeQualificationResultsModel^>^ Volumes {
    array<VolumeQualificationResultsModel^>^ get ();
    void set (array<VolumeQualificationResultsModel^>^ value);
}
member Volumes : VolumeQualificationResultsModel[] with get, set

Property Value

Type: VolumeQualificationResultsModel
See Also

Reference

ServerQualificationResultsModel Class


ServerQualificationResultsModel Methods

ServerQualificationResultsModel Methods

The ServerQualificationResultsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServerQualificationResultsModel Class


ServiceConnectionModel Class

ServiceConnectionModel Class
Service connection model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsServiceConnectionModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ServiceConnectionModel
Public NotInheritable Class ServiceConnectionModel
public ref class ServiceConnectionModel sealed
[<SealedAttribute>]
type ServiceConnectionModel =  class end

The ServiceConnectionModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceConnectionModel | Initializes a new instance of the ServiceConnectionModel class.
Top
Properties
 | Name | Description
Public property | Credential | Gets or sets the credential.
Public property | Host | Gets or sets the host.
Public property | Port | Gets or sets the port.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ServiceConnectionModel Constructor

ServiceConnectionModel Constructor
Initializes a new instance of the ServiceConnectionModel class.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ServiceConnectionModel()
Public Sub New
public:
ServiceConnectionModel()
new : unit -> ServiceConnectionModel
See Also

Reference

ServiceConnectionModel Class


ServiceConnectionModel Properties

ServiceConnectionModel Properties

The ServiceConnectionModel type exposes the following members.

Properties
 | Name | Description
Public property | Credential | Gets or sets the credential.
Public property | Host | Gets or sets the host.
Public property | Port | Gets or sets the port.
Top
See Also

Reference

ServiceConnectionModel Class


ServiceConnectionModel.Credential Property

ServiceConnectionModelCredential Property
Gets or sets the credential.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public CredentialModel Credential { get; set; }
Public Property Credential As CredentialModel
    Get
    Set
public:
property CredentialModel^ Credential {
    CredentialModel^ get ();
    void set (CredentialModel^ value);
}
member Credential : CredentialModel with get, set

Property Value

Type: CredentialModel
The credential.
See Also

Reference

ServiceConnectionModel Class


ServiceConnectionModel.Host Property

ServiceConnectionModelHost Property
Gets or sets the host.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Host { get; set; }
Public Property Host As String
    Get
    Set
public:
property String^ Host {
    String^ get ();
    void set (String^ value);
}
member Host : string with get, set

Property Value

Type: String
The host.
See Also

Reference

ServiceConnectionModel Class


ServiceConnectionModel.Port Property

ServiceConnectionModelPort Property
Gets or sets the port.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> Port { get; set; }
Public Property Port As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> Port {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member Port : Nullable<int> with get, set

Property Value

Type: Nullable Int32
The port.
See Also

Reference

ServiceConnectionModel Class


ServiceConnectionModel Methods

ServiceConnectionModel Methods

The ServiceConnectionModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServiceConnectionModel Class


ServiceInfoModel Class

ServiceInfoModel Class
Service information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsServiceInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class ServiceInfoModel
Public NotInheritable Class ServiceInfoModel
public ref class ServiceInfoModel sealed
[<SealedAttribute>]
type ServiceInfoModel =  class end

The ServiceInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceInfoModel | Initializes a new instance of the ServiceInfoModel class
Top
Properties
 | Name | Description
Public property | Account | Gets or sets the account under which the service runs.
Public property | Name | Gets or sets the service name.
Public property | NameDisplay | Gets or sets the service display name.
Public property | StartMode | Gets or sets the service start mode.
Public property | Status | Gets or sets the service status.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ServiceInfoModel Constructor

ServiceInfoModel Constructor
Initializes a new instance of the ServiceInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ServiceInfoModel()
Public Sub New
public:
ServiceInfoModel()
new : unit -> ServiceInfoModel
See Also

Reference

ServiceInfoModel Class


ServiceInfoModel Properties

ServiceInfoModel Properties

The ServiceInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Account | Gets or sets the account under which the service runs.
Public property | Name | Gets or sets the service name.
Public property | NameDisplay | Gets or sets the service display name.
Public property | StartMode | Gets or sets the service start mode.
Public property | Status | Gets or sets the service status.
Top
See Also

Reference

ServiceInfoModel Class


ServiceInfoModel.Account Property

ServiceInfoModelAccount Property
Gets or sets the account under which the service runs.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Account { get; set; }
Public Property Account As String
    Get
    Set
public:
property String^ Account {
    String^ get ();
    void set (String^ value);
}
member Account : string with get, set

Property Value

Type: String
See Also

Reference

ServiceInfoModel Class


ServiceInfoModel.Name Property

ServiceInfoModelName Property
Gets or sets the service name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

ServiceInfoModel Class


ServiceInfoModel.NameDisplay Property

ServiceInfoModelNameDisplay Property
Gets or sets the service display name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string NameDisplay { get; set; }
Public Property NameDisplay As String
    Get
    Set
public:
property String^ NameDisplay {
    String^ get ();
    void set (String^ value);
}
member NameDisplay : string with get, set

Property Value

Type: String
See Also

Reference

ServiceInfoModel Class


ServiceInfoModel.StartMode Property

ServiceInfoModelStartMode Property
Gets or sets the service start mode.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ServicesStartModeEnum StartMode { get; set; }
Public Property StartMode As ServicesStartModeEnum
    Get
    Set
public:
property ServicesStartModeEnum StartMode {
    ServicesStartModeEnum get ();
    void set (ServicesStartModeEnum value);
}
member StartMode : ServicesStartModeEnum with get, set

Property Value

Type: ServicesStartModeEnum
See Also

Reference

ServiceInfoModel Class


ServiceInfoModel.Status Property

ServiceInfoModelStatus Property
Gets or sets the service status.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public TargetServiceStatus Status { get; set; }
Public Property Status As TargetServiceStatus
    Get
    Set
public:
property TargetServiceStatus Status {
    TargetServiceStatus get ();
    void set (TargetServiceStatus value);
}
member Status : TargetServiceStatus with get, set

Property Value

Type: TargetServiceStatus
See Also

Reference

ServiceInfoModel Class


ServiceInfoModel Methods

ServiceInfoModel Methods

The ServiceInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServiceInfoModel Class


ServiceInformationModel Class

ServiceInformationModel Class
Service information model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsServiceInformationModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ServiceInformationModel
Public NotInheritable Class ServiceInformationModel
public ref class ServiceInformationModel sealed
[<SealedAttribute>]
type ServiceInformationModel =  class end

The ServiceInformationModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceInformationModel | Initializes a new instance of the ServiceInformationModel class
Top
Properties
 | Name | Description
Public property | DisplayName | Gets or sets the display name.
Public property | Name | Gets or sets the name.
Public property | Selected | Gets or sets a value indicating whether or not this is selected.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ServiceInformationModel Constructor

ServiceInformationModel Constructor
Initializes a new instance of the ServiceInformationModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ServiceInformationModel()
Public Sub New
public:
ServiceInformationModel()
new : unit -> ServiceInformationModel
See Also

Reference

ServiceInformationModel Class


ServiceInformationModel Properties

ServiceInformationModel Properties

The ServiceInformationModel type exposes the following members.

Properties
 | Name | Description
Public property | DisplayName | Gets or sets the display name.
Public property | Name | Gets or sets the name.
Public property | Selected | Gets or sets a value indicating whether or not this is selected.
Top
See Also

Reference

ServiceInformationModel Class


ServiceInformationModel.DisplayName Property

ServiceInformationModelDisplayName Property
Gets or sets the display name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}
member DisplayName : string with get, set

Property Value

Type: String
See Also

Reference

ServiceInformationModel Class


ServiceInformationModel.Name Property

ServiceInformationModelName Property
Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

ServiceInformationModel Class


ServiceInformationModel.Selected Property

ServiceInformationModelSelected Property
Gets or sets a value indicating whether or not this is selected.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool Selected { get; set; }
Public Property Selected As Boolean
    Get
    Set
public:
property bool Selected {
    bool get ();
    void set (bool value);
}
member Selected : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServiceInformationModel Class


ServiceInformationModel Methods

ServiceInformationModel Methods

The ServiceInformationModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServiceInformationModel Class


ServiceMetadataModel Class

ServiceMetadataModel Class
Service metadata.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsServiceMetadataModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class ServiceMetadataModel
Public NotInheritable Class ServiceMetadataModel
public ref class ServiceMetadataModel sealed
[<SealedAttribute>]
type ServiceMetadataModel =  class end

The ServiceMetadataModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceMetadataModel | Initializes a new instance of the ServiceMetadataModel class
Top
Properties
 | Name | Description
Public property | MachineId | Gets or sets the machine identifier.
Public property | ProductVersion | Gets or sets the product version.
Public property | ServerName | Gets or sets the name of the server.
Public property | ServiceTags | Gets or sets the service tags.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ServiceMetadataModel Constructor

ServiceMetadataModel Constructor
Initializes a new instance of the ServiceMetadataModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ServiceMetadataModel()
Public Sub New
public:
ServiceMetadataModel()
new : unit -> ServiceMetadataModel
See Also

Reference

ServiceMetadataModel Class


ServiceMetadataModel Properties

ServiceMetadataModel Properties

The ServiceMetadataModel type exposes the following members.

Properties
 | Name | Description
Public property | MachineId | Gets or sets the machine identifier.
Public property | ProductVersion | Gets or sets the product version.
Public property | ServerName | Gets or sets the name of the server.
Public property | ServiceTags | Gets or sets the service tags.
Top
See Also

Reference

ServiceMetadataModel Class


ServiceMetadataModel.MachineId Property

ServiceMetadataModelMachineId Property
Gets or sets the machine identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Guid MachineId { get; set; }
Public Property MachineId As Guid
    Get
    Set
public:
property Guid MachineId {
    Guid get ();
    void set (Guid value);
}
member MachineId : Guid with get, set

Property Value

Type: Guid
The machine identifier.
See Also

Reference

ServiceMetadataModel Class


ServiceMetadataModel.ProductVersion Property

ServiceMetadataModelProductVersion Property
Gets or sets the product version.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ProductVersion { get; set; }
Public Property ProductVersion As String
    Get
    Set
public:
property String^ ProductVersion {
    String^ get ();
    void set (String^ value);
}
member ProductVersion : string with get, set

Property Value

Type: String
The product version.
See Also

Reference

ServiceMetadataModel Class


ServiceMetadataModel.ServerName Property

ServiceMetadataModelServerName Property
Gets or sets the name of the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ServerName { get; set; }
Public Property ServerName As String
    Get
    Set
public:
property String^ ServerName {
    String^ get ();
    void set (String^ value);
}
member ServerName : string with get, set

Property Value

Type: String
The name of the server.
See Also

Reference

ServiceMetadataModel Class


ServiceMetadataModel.ServiceTags Property

ServiceMetadataModelServiceTags Property
Gets or sets the service tags.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> ServiceTags { get; set; }
Public Property ServiceTags As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ ServiceTags {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member ServiceTags : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
The service tags.
See Also

Reference

ServiceMetadataModel Class


ServiceMetadataModel Methods

ServiceMetadataModel Methods

The ServiceMetadataModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServiceMetadataModel Class


ServiceMonitoringOptionsModel Class

ServiceMonitoringOptionsModel Class
Service monitoring options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsServiceMonitoringOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ServiceMonitoringOptionsModel
Public NotInheritable Class ServiceMonitoringOptionsModel
public ref class ServiceMonitoringOptionsModel sealed
[<SealedAttribute>]
type ServiceMonitoringOptionsModel =  class end

The ServiceMonitoringOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceMonitoringOptionsModel | Initializes a new instance of the ServiceMonitoringOptionsModel class
Top
Properties
 | Name | Description
Public property | RepeatCount | Gets or sets the number of times to repeat the call to retrieve the service status.
Public property | Services | Gets or sets the services to be monitored.
Public property | StartService | Gets or sets a value indicating whether or not to start a monitored service if it is stopped.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ServiceMonitoringOptionsModel Constructor

ServiceMonitoringOptionsModel Constructor
Initializes a new instance of the ServiceMonitoringOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ServiceMonitoringOptionsModel()
Public Sub New
public:
ServiceMonitoringOptionsModel()
new : unit -> ServiceMonitoringOptionsModel
See Also

Reference

ServiceMonitoringOptionsModel Class


ServiceMonitoringOptionsModel Properties

ServiceMonitoringOptionsModel Properties

The ServiceMonitoringOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | RepeatCount | Gets or sets the number of times to repeat the call to retrieve the service status.
Public property | Services | Gets or sets the services to be monitored.
Public property | StartService | Gets or sets a value indicating whether or not to start a monitored service if it is stopped.
Top
See Also

Reference

ServiceMonitoringOptionsModel Class


ServiceMonitoringOptionsModel.RepeatCount Property

ServiceMonitoringOptionsModelRepeatCount Property
Gets or sets the number of times to repeat the call to retrieve the service status.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int RepeatCount { get; set; }
Public Property RepeatCount As Integer
    Get
    Set
public:
property int RepeatCount {
    int get ();
    void set (int value);
}
member RepeatCount : int with get, set

Property Value

Type: Int32
See Also

Reference

ServiceMonitoringOptionsModel Class


ServiceMonitoringOptionsModel.Services Property

ServiceMonitoringOptionsModelServices Property
Gets or sets the services to be monitored.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ServiceInformationModel[] Services { get; set; }
Public Property Services As ServiceInformationModel()
    Get
    Set
public:
property array<ServiceInformationModel^>^ Services {
    array<ServiceInformationModel^>^ get ();
    void set (array<ServiceInformationModel^>^ value);
}
member Services : ServiceInformationModel[] with get, set

Property Value

Type: ServiceInformationModel
See Also

Reference

ServiceMonitoringOptionsModel Class


ServiceMonitoringOptionsModel.StartService Property

ServiceMonitoringOptionsModelStartService Property
Gets or sets a value indicating whether or not to start a monitored service if it is stopped.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool StartService { get; set; }
Public Property StartService As Boolean
    Get
    Set
public:
property bool StartService {
    bool get ();
    void set (bool value);
}
member StartService : bool with get, set

Property Value

Type: Boolean
See Also

Reference

ServiceMonitoringOptionsModel Class


ServiceMonitoringOptionsModel Methods

ServiceMonitoringOptionsModel Methods

The ServiceMonitoringOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServiceMonitoringOptionsModel Class


ServiceOperationActionInputModel Class

ServiceOperationActionInputModel Class
The inputs for a Service operation
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActionInputModel
DoubleTake.Web.ModelsServiceOperationActionInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class ServiceOperationActionInputModel : ActionInputModel
Public Class ServiceOperationActionInputModel
    Inherits ActionInputModel
public ref class ServiceOperationActionInputModel : public ActionInputModel
type ServiceOperationActionInputModel =
    class
        inherit ActionInputModel
    end

The ServiceOperationActionInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceOperationActionInputModel | Initializes a new instance of the ServiceOperationActionInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the action. (Inherited from ActionInputModel.)
Public property | QueryResult | Gets or sets the query result. (Inherited from ActionInputModel.)
Public property | ServiceName | Gets or sets the name of the service.
Public property | ServiceOperation | Gets or sets the service operation.
Public property | StartArguments | Gets or sets the arguments for the Start operation.
Public property | Timeout | Gets or sets the timeout for the wait operation.
Public property | WaitForStatus | Gets or sets a value indicating whether to wait for the service status to change as a result of the operation performed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsActionInputModel


ServiceOperationActionInputModel Constructor

ServiceOperationActionInputModel Constructor
Initializes a new instance of the ServiceOperationActionInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ServiceOperationActionInputModel()
Public Sub New
public:
ServiceOperationActionInputModel()
new : unit -> ServiceOperationActionInputModel
See Also

Reference

ServiceOperationActionInputModel Class


ServiceOperationActionInputModel Properties

ServiceOperationActionInputModel Properties

The ServiceOperationActionInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the action. (Inherited from ActionInputModel.)
Public property | QueryResult | Gets or sets the query result. (Inherited from ActionInputModel.)
Public property | ServiceName | Gets or sets the name of the service.
Public property | ServiceOperation | Gets or sets the service operation.
Public property | StartArguments | Gets or sets the arguments for the Start operation.
Public property | Timeout | Gets or sets the timeout for the wait operation.
Public property | WaitForStatus | Gets or sets a value indicating whether to wait for the service status to change as a result of the operation performed.
Top
See Also

Reference

ServiceOperationActionInputModel Class


ServiceOperationActionInputModel.ServiceName Property

ServiceOperationActionInputModelServiceName Property
Gets or sets the name of the service.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
member ServiceName : string with get, set

Property Value

Type: String
The name of the service.
See Also

Reference

ServiceOperationActionInputModel Class


ServiceOperationActionInputModel.ServiceOperation Property

ServiceOperationActionInputModelServiceOperation Property
Gets or sets the service operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ServiceOperationEnum ServiceOperation { get; set; }
Public Property ServiceOperation As ServiceOperationEnum
    Get
    Set
public:
property ServiceOperationEnum ServiceOperation {
    ServiceOperationEnum get ();
    void set (ServiceOperationEnum value);
}
member ServiceOperation : ServiceOperationEnum with get, set

Property Value

Type: ServiceOperationEnum
The service operation.
See Also

Reference

ServiceOperationActionInputModel Class


ServiceOperationActionInputModel.StartArguments Property

ServiceOperationActionInputModelStartArguments Property
Gets or sets the arguments for the Start operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string[] StartArguments { get; set; }
Public Property StartArguments As String()
    Get
    Set
public:
property array<String^>^ StartArguments {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member StartArguments : string[] with get, set

Property Value

Type: String
The arguments for the Start operation.
Remarks
This property is ignored for all [F:ServiceOperation] values other than the Start operation.
See Also

Reference

ServiceOperationActionInputModel Class


ServiceOperationActionInputModel.Timeout Property

ServiceOperationActionInputModelTimeout Property
Gets or sets the timeout for the wait operation.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TimeSpan> Timeout { get; set; }
Public Property Timeout As Nullable(Of TimeSpan)
    Get
    Set
public:
property Nullable<TimeSpan> Timeout {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
member Timeout : Nullable<TimeSpan> with get, set

Property Value

Type: Nullable TimeSpan
The timeout for the wait operation.
Remarks
If this value is , the action agent will wait indefinitely for the status to change.
See Also

Reference

ServiceOperationActionInputModel Class


ServiceOperationActionInputModel.WaitForStatus Property

ServiceOperationActionInputModelWaitForStatus Property
Gets or sets a value indicating whether to wait for the service status to change as a result of the operation performed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool WaitForStatus { get; set; }
Public Property WaitForStatus As Boolean
    Get
    Set
public:
property bool WaitForStatus {
    bool get ();
    void set (bool value);
}
member WaitForStatus : bool with get, set

Property Value

Type: Boolean
to wait for the service status to change; otherwise, .
Remarks
There is a corresponding service status change for each operation. For instance, if you've requested the Start operation, this action will wait for the service status to change to Running.
See Also

Reference

ServiceOperationActionInputModel Class


ServiceOperationActionInputModel Methods

ServiceOperationActionInputModel Methods

The ServiceOperationActionInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServiceOperationActionInputModel Class


ServiceOperationActionResultModel Class

ServiceOperationActionResultModel Class
Represents the result of a service operation action.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActionResultModel
DoubleTake.Web.ModelsServiceOperationActionResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class ServiceOperationActionResultModel : ActionResultModel
Public Class ServiceOperationActionResultModel
    Inherits ActionResultModel
public ref class ServiceOperationActionResultModel : public ActionResultModel
type ServiceOperationActionResultModel =
    class
        inherit ActionResultModel
    end

The ServiceOperationActionResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceOperationActionResultModel | Initializes a new instance of the ServiceOperationActionResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the action exception. (Inherited from ActionResultModel.)
Public property | ServiceStatus | Gets or sets the service status after the operation has been executed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ServiceOperationActionResultModel Constructor

ServiceOperationActionResultModel Constructor
Initializes a new instance of the ServiceOperationActionResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ServiceOperationActionResultModel()
Public Sub New
public:
ServiceOperationActionResultModel()
new : unit -> ServiceOperationActionResultModel
See Also

Reference

ServiceOperationActionResultModel Class


ServiceOperationActionResultModel Properties

ServiceOperationActionResultModel Properties

The ServiceOperationActionResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the action exception. (Inherited from ActionResultModel.)
Public property | ServiceStatus | Gets or sets the service status after the operation has been executed.
Top
See Also

Reference

ServiceOperationActionResultModel Class


ServiceOperationActionResultModel.ServiceStatus Property

ServiceOperationActionResultModelServiceStatus Property
Gets or sets the service status after the operation has been executed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ServiceStatus { get; set; }
Public Property ServiceStatus As String
    Get
    Set
public:
property String^ ServiceStatus {
    String^ get ();
    void set (String^ value);
}
member ServiceStatus : string with get, set

Property Value

Type: String
The service status after the operation has been executed.
See Also

Reference

ServiceOperationActionResultModel Class


ServiceOperationActionResultModel Methods

ServiceOperationActionResultModel Methods

The ServiceOperationActionResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServiceOperationActionResultModel Class


ServiceOperationEnum Enumeration

ServiceOperationEnum Enumeration
Represents the different types of Windows service operations.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public enum ServiceOperationEnum
Public Enumeration ServiceOperationEnum
public enum class ServiceOperationEnum
type ServiceOperationEnum
Members
Member name | Value | Description
Start | 0 | Indicates to execute the 'Start' operation on the service.
Stop | 1 | Indicates to execute the 'Stop' operation on the service.
Pause | 2 | Indicates to execute the 'Pause' operation on the service.
Continue | 3 | Indicates to execute the 'Continue' operation on the service.
See Also

Reference

DoubleTake.Web.Models Namespace


ServicesStartModeEnum Enumeration

ServicesStartModeEnum Enumeration
Represents the startup mode of a Windows service.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public enum ServicesStartModeEnum
Public Enumeration ServicesStartModeEnum
public enum class ServicesStartModeEnum
type ServicesStartModeEnum
Members
Member name | Value | Description
Boot | 0 | Indicates that the device driver is started by the operating system loader.
System | 1 | Indicates that the device driver is started by the operating system initialization process.
Auto | 2 | Indicates that the service is started automatically by the Service Control Manager during system startup.
Manual | 3 | Indicates that the service is started by the Service Control Manager upon user request.
Disabled | 4 | Indicates that the service cannot be started.
Unknown | 5 | Indicates that WMI was unable to determine the start mode of the service. This is undocumented, but we have seen cases where this caused problems.
See Also

Reference

DoubleTake.Web.Models Namespace


ServiceStatusQueryInputModel Class

ServiceStatusQueryInputModel Class
Represents the input to a service query
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsServiceStatusQueryInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class ServiceStatusQueryInputModel : QueryInputModel
Public Class ServiceStatusQueryInputModel
    Inherits QueryInputModel
public ref class ServiceStatusQueryInputModel : public QueryInputModel
type ServiceStatusQueryInputModel =
    class
        inherit QueryInputModel
    end

The ServiceStatusQueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceStatusQueryInputModel | Initializes a new instance of the ServiceStatusQueryInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | ServiceName | Gets or sets the name of the service to monitor.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryInputModel


ServiceStatusQueryInputModel Constructor

ServiceStatusQueryInputModel Constructor
Initializes a new instance of the ServiceStatusQueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ServiceStatusQueryInputModel()
Public Sub New
public:
ServiceStatusQueryInputModel()
new : unit -> ServiceStatusQueryInputModel
See Also

Reference

ServiceStatusQueryInputModel Class


ServiceStatusQueryInputModel Properties

ServiceStatusQueryInputModel Properties

The ServiceStatusQueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | ServiceName | Gets or sets the name of the service to monitor.
Top
See Also

Reference

ServiceStatusQueryInputModel Class


ServiceStatusQueryInputModel.ServiceName Property

ServiceStatusQueryInputModelServiceName Property
Gets or sets the name of the service to monitor.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
member ServiceName : string with get, set

Property Value

Type: String
The name of the service.
See Also

Reference

ServiceStatusQueryInputModel Class


ServiceStatusQueryInputModel Methods

ServiceStatusQueryInputModel Methods

The ServiceStatusQueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServiceStatusQueryInputModel Class


ServiceStatusQueryResultModel Class

ServiceStatusQueryResultModel Class
Represents the results of a Service Status Query
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultModel
DoubleTake.Web.ModelsServiceStatusQueryResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class ServiceStatusQueryResultModel : QueryResultModel
Public Class ServiceStatusQueryResultModel
    Inherits QueryResultModel
public ref class ServiceStatusQueryResultModel : public QueryResultModel
type ServiceStatusQueryResultModel =
    class
        inherit QueryResultModel
    end

The ServiceStatusQueryResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceStatusQueryResultModel | Initializes a new instance of the ServiceStatusQueryResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Public property | ServiceName | Gets or sets the name of the service.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryResultModel


ServiceStatusQueryResultModel Constructor

ServiceStatusQueryResultModel Constructor
Initializes a new instance of the ServiceStatusQueryResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ServiceStatusQueryResultModel()
Public Sub New
public:
ServiceStatusQueryResultModel()
new : unit -> ServiceStatusQueryResultModel
See Also

Reference

ServiceStatusQueryResultModel Class


ServiceStatusQueryResultModel Properties

ServiceStatusQueryResultModel Properties

The ServiceStatusQueryResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Public property | ServiceName | Gets or sets the name of the service.
Top
See Also

Reference

ServiceStatusQueryResultModel Class


ServiceStatusQueryResultModel.ServiceName Property

ServiceStatusQueryResultModelServiceName Property
Gets or sets the name of the service.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
member ServiceName : string with get, set

Property Value

Type: String
The name of the service.
See Also

Reference

ServiceStatusQueryResultModel Class


ServiceStatusQueryResultModel Methods

ServiceStatusQueryResultModel Methods

The ServiceStatusQueryResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServiceStatusQueryResultModel Class


ServicesToStopModel Class

ServicesToStopModel Class
Services to stop.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsServicesToStopModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class ServicesToStopModel
Public Class ServicesToStopModel
public ref class ServicesToStopModel
type ServicesToStopModel =  class end

The ServicesToStopModel type exposes the following members.

Constructors
 | Name | Description
Public method | ServicesToStopModel | Initializes a new instance of the ServicesToStopModel class
Top
Properties
 | Name | Description
Public property | TargetServicesToStop | Gets or sets the target services to stop.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ServicesToStopModel Constructor

ServicesToStopModel Constructor
Initializes a new instance of the ServicesToStopModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ServicesToStopModel()
Public Sub New
public:
ServicesToStopModel()
new : unit -> ServicesToStopModel
See Also

Reference

ServicesToStopModel Class


ServicesToStopModel Properties

ServicesToStopModel Properties

The ServicesToStopModel type exposes the following members.

Properties
 | Name | Description
Public property | TargetServicesToStop | Gets or sets the target services to stop.
Top
See Also

Reference

ServicesToStopModel Class


ServicesToStopModel.TargetServicesToStop Property

ServicesToStopModelTargetServicesToStop Property
Gets or sets the target services to stop.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public TargetServicesToStopModel[] TargetServicesToStop { get; set; }
Public Property TargetServicesToStop As TargetServicesToStopModel()
    Get
    Set
public:
property array<TargetServicesToStopModel^>^ TargetServicesToStop {
    array<TargetServicesToStopModel^>^ get ();
    void set (array<TargetServicesToStopModel^>^ value);
}
member TargetServicesToStop : TargetServicesToStopModel[] with get, set

Property Value

Type: TargetServicesToStopModel
The target services.
See Also

Reference

ServicesToStopModel Class


ServicesToStopModel Methods

ServicesToStopModel Methods

The ServicesToStopModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ServicesToStopModel Class


ShareModel Class

ShareModel Class
Share model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsShareModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class ShareModel
Public NotInheritable Class ShareModel
public ref class ShareModel sealed
[<SealedAttribute>]
type ShareModel =  class end

The ShareModel type exposes the following members.

Constructors
 | Name | Description
Public method | ShareModel | Initializes a new instance of the ShareModel class
Top
Properties
 | Name | Description
Public property | Aces | Gets or sets the aces.
Public property | MaxUsers | Gets or sets the maximum users.
Public property | Name | Gets or sets the name.
Public property | Path | Gets or sets the path.
Public property | Type | Gets or sets the type.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


ShareModel Constructor

ShareModel Constructor
Initializes a new instance of the ShareModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ShareModel()
Public Sub New
public:
ShareModel()
new : unit -> ShareModel
See Also

Reference

ShareModel Class


ShareModel Properties

ShareModel Properties

The ShareModel type exposes the following members.

Properties
 | Name | Description
Public property | Aces | Gets or sets the aces.
Public property | MaxUsers | Gets or sets the maximum users.
Public property | Name | Gets or sets the name.
Public property | Path | Gets or sets the path.
Public property | Type | Gets or sets the type.
Top
See Also

Reference

ShareModel Class


ShareModel.Aces Property

ShareModelAces Property
Gets or sets the aces.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<AceModel> Aces { get; set; }
Public Property Aces As IEnumerable(Of AceModel)
    Get
    Set
public:
property IEnumerable<AceModel^>^ Aces {
    IEnumerable<AceModel^>^ get ();
    void set (IEnumerable<AceModel^>^ value);
}
member Aces : IEnumerable<AceModel> with get, set

Property Value

Type: IEnumerable AceModel
The aces.
See Also

Reference

ShareModel Class


ShareModel.MaxUsers Property

ShareModelMaxUsers Property
Gets or sets the maximum users.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<int> MaxUsers { get; set; }
Public Property MaxUsers As Nullable(Of Integer)
    Get
    Set
public:
property Nullable<int> MaxUsers {
    Nullable<int> get ();
    void set (Nullable<int> value);
}
member MaxUsers : Nullable<int> with get, set

Property Value

Type: Nullable Int32
The maximum users.
See Also

Reference

ShareModel Class


ShareModel.Name Property

ShareModelName Property
Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

ShareModel Class


ShareModel.Path Property

ShareModelPath Property
Gets or sets the path.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
member Path : string with get, set

Property Value

Type: String
The path.
See Also

Reference

ShareModel Class


ShareModel.Type Property

ShareModelType Property
Gets or sets the type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int Type { get; set; }
Public Property Type As Integer
    Get
    Set
public:
property int Type {
    int get ();
    void set (int value);
}
member Type : int with get, set

Property Value

Type: Int32
The type.
See Also

Reference

ShareModel Class


ShareModel Methods

ShareModel Methods

The ShareModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ShareModel Class


ShareQueryInputModel Class

ShareQueryInputModel Class
The inputs required for a share monitor
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsShareQueryInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class ShareQueryInputModel : QueryInputModel
Public Class ShareQueryInputModel
    Inherits QueryInputModel
public ref class ShareQueryInputModel : public QueryInputModel
type ShareQueryInputModel =
    class
        inherit QueryInputModel
    end

The ShareQueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | ShareQueryInputModel | Initializes a new instance of the ShareQueryInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | IdJob | Gets or sets the identifier job.
Public property | Rules | Gets or sets the rules.
Public property | Target | Gets or sets the target.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryInputModel


ShareQueryInputModel Constructor

ShareQueryInputModel Constructor
Initializes a new instance of the ShareQueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ShareQueryInputModel()
Public Sub New
public:
ShareQueryInputModel()
new : unit -> ShareQueryInputModel
See Also

Reference

ShareQueryInputModel Class


ShareQueryInputModel Properties

ShareQueryInputModel Properties

The ShareQueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | IdJob | Gets or sets the identifier job.
Public property | Rules | Gets or sets the rules.
Public property | Target | Gets or sets the target.
Top
See Also

Reference

ShareQueryInputModel Class


ShareQueryInputModel.IdJob Property

ShareQueryInputModelIdJob Property
Gets or sets the identifier job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Guid IdJob { get; set; }
Public Property IdJob As Guid
    Get
    Set
public:
property Guid IdJob {
    Guid get ();
    void set (Guid value);
}
member IdJob : Guid with get, set

Property Value

Type: Guid
See Also

Reference

ShareQueryInputModel Class


ShareQueryInputModel.Rules Property

ShareQueryInputModelRules Property
Gets or sets the rules.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<PhysicalRuleModel> Rules { get; set; }
Public Property Rules As IEnumerable(Of PhysicalRuleModel)
    Get
    Set
public:
property IEnumerable<PhysicalRuleModel^>^ Rules {
    IEnumerable<PhysicalRuleModel^>^ get ();
    void set (IEnumerable<PhysicalRuleModel^>^ value);
}
member Rules : IEnumerable<PhysicalRuleModel> with get, set

Property Value

Type: IEnumerable PhysicalRuleModel
See Also

Reference

ShareQueryInputModel Class


ShareQueryInputModel.Target Property

ShareQueryInputModelTarget Property
Gets or sets the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Uri Target { get; set; }
Public Property Target As Uri
    Get
    Set
public:
property Uri^ Target {
    Uri^ get ();
    void set (Uri^ value);
}
member Target : Uri with get, set

Property Value

Type: Uri
See Also

Reference

ShareQueryInputModel Class


ShareQueryInputModel Methods

ShareQueryInputModel Methods

The ShareQueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ShareQueryInputModel Class


ShareQueryResultModel Class

ShareQueryResultModel Class
Represents the results of a share query.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultModel
DoubleTake.Web.ModelsShareQueryResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class ShareQueryResultModel : QueryResultModel
Public Class ShareQueryResultModel
    Inherits QueryResultModel
public ref class ShareQueryResultModel : public QueryResultModel
type ShareQueryResultModel =
    class
        inherit QueryResultModel
    end

The ShareQueryResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | ShareQueryResultModel | Initializes a new instance of the ShareQueryResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Public property | Shares | Gets or sets the shares.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryResultModel


ShareQueryResultModel Constructor

ShareQueryResultModel Constructor
Initializes a new instance of the ShareQueryResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public ShareQueryResultModel()
Public Sub New
public:
ShareQueryResultModel()
new : unit -> ShareQueryResultModel
See Also

Reference

ShareQueryResultModel Class


ShareQueryResultModel Properties

ShareQueryResultModel Properties

The ShareQueryResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Public property | Shares | Gets or sets the shares.
Top
See Also

Reference

ShareQueryResultModel Class


ShareQueryResultModel.Shares Property

ShareQueryResultModelShares Property
Gets or sets the shares.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<ShareModel> Shares { get; set; }
Public Property Shares As IEnumerable(Of ShareModel)
    Get
    Set
public:
property IEnumerable<ShareModel^>^ Shares {
    IEnumerable<ShareModel^>^ get ();
    void set (IEnumerable<ShareModel^>^ value);
}
member Shares : IEnumerable<ShareModel> with get, set

Property Value

Type: IEnumerable ShareModel
See Also

Reference

ShareQueryResultModel Class


ShareQueryResultModel Methods

ShareQueryResultModel Methods

The ShareQueryResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ShareQueryResultModel Class


ShortNameBehaviorSettingEnum Enumeration

ShortNameBehaviorSettingEnum Enumeration
Defines values of the system short name behavior setting

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public enum ShortNameBehaviorSettingEnum
Public Enumeration ShortNameBehaviorSettingEnum
public enum class ShortNameBehaviorSettingEnum
type ShortNameBehaviorSettingEnum
Members
Member name | Value | Description
Enabled | 0 | Enable 8dot3 name creation on all volumes on the system.
Disabled | 1 | Disable 8dot3 name creation on all volumes on the system.
PerVolume | 2 | Set 8dot3 name creation on a per volume basis.
AllButSystem | 3 | Disable 8dot3 name creation on all volumes except the system volume.
See Also

Reference

DoubleTake.Web.Models Namespace


ShutdownOptionEnum Enumeration

ShutdownOptionEnum Enumeration
Shutdown option

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public enum ShutdownOptionEnum
Public Enumeration ShutdownOptionEnum
public enum class ShutdownOptionEnum
type ShutdownOptionEnum
Members
Member name | Value | Description
ShutdownOnly | 0 | Shutdown only
Restart | 1 | Restart
See Also

Reference

DoubleTake.Web.Models Namespace


SimpleFailoverMonitorOptionsModel Class

SimpleFailoverMonitorOptionsModel Class
Simple failover monitor options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSimpleFailoverMonitorOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class SimpleFailoverMonitorOptionsModel
Public NotInheritable Class SimpleFailoverMonitorOptionsModel
public ref class SimpleFailoverMonitorOptionsModel sealed
[<SealedAttribute>]
type SimpleFailoverMonitorOptionsModel =  class end

The SimpleFailoverMonitorOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleFailoverMonitorOptionsModel | Initializes a new instance of the SimpleFailoverMonitorOptionsModel class
Top
Properties
 | Name | Description
Public property | IsUserInterventionRequired | Gets or sets a value indicating whether or not user intervention is required before triggering a failover.
Public property | MaxPingAttempts | Gets or sets the maximum number of ping attempts before the IP address is considered to be failed.
Public property | PingInterval | Gets or sets the interval at which the source address is pinged to determine a failure condition.
Public property | TimeAllowed | Gets or sets the total time to failover.
Public property | UseTimeAllowed | Gets or sets a value indicating whether or not to use the timeAllowed property.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SimpleFailoverMonitorOptionsModel Constructor

SimpleFailoverMonitorOptionsModel Constructor
Initializes a new instance of the SimpleFailoverMonitorOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public SimpleFailoverMonitorOptionsModel()
Public Sub New
public:
SimpleFailoverMonitorOptionsModel()
new : unit -> SimpleFailoverMonitorOptionsModel
See Also

Reference

SimpleFailoverMonitorOptionsModel Class


SimpleFailoverMonitorOptionsModel Properties

SimpleFailoverMonitorOptionsModel Properties

The SimpleFailoverMonitorOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | IsUserInterventionRequired | Gets or sets a value indicating whether or not user intervention is required before triggering a failover.
Public property | MaxPingAttempts | Gets or sets the maximum number of ping attempts before the IP address is considered to be failed.
Public property | PingInterval | Gets or sets the interval at which the source address is pinged to determine a failure condition.
Public property | TimeAllowed | Gets or sets the total time to failover.
Public property | UseTimeAllowed | Gets or sets a value indicating whether or not to use the timeAllowed property.
Top
See Also

Reference

SimpleFailoverMonitorOptionsModel Class


SimpleFailoverMonitorOptionsModel.IsUserInterventionRequired Property

SimpleFailoverMonitorOptionsModelIsUserInterventionRequired Property
Gets or sets a value indicating whether or not user intervention is required before triggering a failover.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsUserInterventionRequired { get; set; }
Public Property IsUserInterventionRequired As Boolean
    Get
    Set
public:
property bool IsUserInterventionRequired {
    bool get ();
    void set (bool value);
}
member IsUserInterventionRequired : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SimpleFailoverMonitorOptionsModel Class


SimpleFailoverMonitorOptionsModel.MaxPingAttempts Property

SimpleFailoverMonitorOptionsModelMaxPingAttempts Property
Gets or sets the maximum number of ping attempts before the IP address is considered to be failed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public short MaxPingAttempts { get; set; }
Public Property MaxPingAttempts As Short
    Get
    Set
public:
property short MaxPingAttempts {
    short get ();
    void set (short value);
}
member MaxPingAttempts : int16 with get, set

Property Value

Type: Int16
See Also

Reference

SimpleFailoverMonitorOptionsModel Class


SimpleFailoverMonitorOptionsModel.PingInterval Property

SimpleFailoverMonitorOptionsModelPingInterval Property
Gets or sets the interval at which the source address is pinged to determine a failure condition.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan PingInterval { get; set; }
Public Property PingInterval As TimeSpan
    Get
    Set
public:
property TimeSpan PingInterval {
    TimeSpan get ();
    void set (TimeSpan value);
}
member PingInterval : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

SimpleFailoverMonitorOptionsModel Class


SimpleFailoverMonitorOptionsModel.TimeAllowed Property

SimpleFailoverMonitorOptionsModelTimeAllowed Property
Gets or sets the total time to failover.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan TimeAllowed { get; set; }
Public Property TimeAllowed As TimeSpan
    Get
    Set
public:
property TimeSpan TimeAllowed {
    TimeSpan get ();
    void set (TimeSpan value);
}
member TimeAllowed : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

SimpleFailoverMonitorOptionsModel Class


SimpleFailoverMonitorOptionsModel.UseTimeAllowed Property

SimpleFailoverMonitorOptionsModelUseTimeAllowed Property
Gets or sets a value indicating whether or not to use the timeAllowed property.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseTimeAllowed { get; set; }
Public Property UseTimeAllowed As Boolean
    Get
    Set
public:
property bool UseTimeAllowed {
    bool get ();
    void set (bool value);
}
member UseTimeAllowed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SimpleFailoverMonitorOptionsModel Class


SimpleFailoverMonitorOptionsModel Methods

SimpleFailoverMonitorOptionsModel Methods

The SimpleFailoverMonitorOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SimpleFailoverMonitorOptionsModel Class


SmtpConnectionSecurity Enumeration

SmtpConnectionSecurity Enumeration
SMTP connection security.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum SmtpConnectionSecurity
Public Enumeration SmtpConnectionSecurity
public enum class SmtpConnectionSecurity
type SmtpConnectionSecurity
Members
Member name | Value | Description
Plain | 0 | The plain.
Ssl | 1 | The SSL.
Tls | 2 | The TLS.
See Also

Reference

DoubleTake.Web.Models Namespace


SnapshotAge Enumeration

SnapshotAge Enumeration
Snapshot age.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum SnapshotAge
Public Enumeration SnapshotAge
public enum class SnapshotAge
type SnapshotAge
Members
Member name | Value | Description
Old | 0 | Old
All | 1 | All
See Also

Reference

DoubleTake.Web.Models Namespace


SnapshotCreationReason Enumeration

SnapshotCreationReason Enumeration
Snapshot creation reason.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum SnapshotCreationReason
Public Enumeration SnapshotCreationReason
public enum class SnapshotCreationReason
type SnapshotCreationReason
Members
Member name | Value | Description
Manual | 0 | The manual
Automatic | 1 | The automatic
Scheduled | 2 | The scheduled
Deferred | 3 | The deferred
DataTest | 4 | The data test
See Also

Reference

DoubleTake.Web.Models Namespace


SnapshotEntryModel Class

SnapshotEntryModel Class
Snapshot entry model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSnapshotEntryModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class SnapshotEntryModel
Public NotInheritable Class SnapshotEntryModel
public ref class SnapshotEntryModel sealed
[<SealedAttribute>]
type SnapshotEntryModel =  class end

The SnapshotEntryModel type exposes the following members.

Constructors
 | Name | Description
Public method | SnapshotEntryModel | Initializes a new instance of the SnapshotEntryModel class
Top
Properties
 | Name | Description
Public property | Comment | Gets or sets the comment associated with this snapshot.
Public property | ConName | Gets or sets the connection name for the snapshot.
Public property | Id | Gets or sets the unique identifier of this snapshot.
Public property | Reason | Gets or sets the reason for taking this snapshot.
Public property | States | Gets or sets the state of the target server associated with this snapshot.
Public property | Timestamp | Gets or sets the when this snapshot was taken.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SnapshotEntryModel Constructor

SnapshotEntryModel Constructor
Initializes a new instance of the SnapshotEntryModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public SnapshotEntryModel()
Public Sub New
public:
SnapshotEntryModel()
new : unit -> SnapshotEntryModel
See Also

Reference

SnapshotEntryModel Class


SnapshotEntryModel Properties

SnapshotEntryModel Properties

The SnapshotEntryModel type exposes the following members.

Properties
 | Name | Description
Public property | Comment | Gets or sets the comment associated with this snapshot.
Public property | ConName | Gets or sets the connection name for the snapshot.
Public property | Id | Gets or sets the unique identifier of this snapshot.
Public property | Reason | Gets or sets the reason for taking this snapshot.
Public property | States | Gets or sets the state of the target server associated with this snapshot.
Public property | Timestamp | Gets or sets the when this snapshot was taken.
Top
See Also

Reference

SnapshotEntryModel Class


SnapshotEntryModel.Comment Property

SnapshotEntryModelComment Property
Gets or sets the comment associated with this snapshot.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set
public:
property String^ Comment {
    String^ get ();
    void set (String^ value);
}
member Comment : string with get, set

Property Value

Type: String
See Also

Reference

SnapshotEntryModel Class


SnapshotEntryModel.ConName Property

SnapshotEntryModelConName Property
Gets or sets the connection name for the snapshot.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ConName { get; set; }
Public Property ConName As String
    Get
    Set
public:
property String^ ConName {
    String^ get ();
    void set (String^ value);
}
member ConName : string with get, set

Property Value

Type: String
See Also

Reference

SnapshotEntryModel Class


SnapshotEntryModel.Id Property

SnapshotEntryModelId Property
Gets or sets the unique identifier of this snapshot.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
member Id : Guid with get, set

Property Value

Type: Guid
See Also

Reference

SnapshotEntryModel Class


SnapshotEntryModel.Reason Property

SnapshotEntryModelReason Property
Gets or sets the reason for taking this snapshot.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public SnapshotCreationReason Reason { get; set; }
Public Property Reason As SnapshotCreationReason
    Get
    Set
public:
property SnapshotCreationReason Reason {
    SnapshotCreationReason get ();
    void set (SnapshotCreationReason value);
}
member Reason : SnapshotCreationReason with get, set

Property Value

Type: SnapshotCreationReason
See Also

Reference

SnapshotEntryModel Class


SnapshotEntryModel.States Property

SnapshotEntryModelStates Property
Gets or sets the state of the target server associated with this snapshot.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TargetStates States { get; set; }
Public Property States As TargetStates
    Get
    Set
public:
property TargetStates States {
    TargetStates get ();
    void set (TargetStates value);
}
member States : TargetStates with get, set

Property Value

Type: TargetStates
See Also

Reference

SnapshotEntryModel Class


SnapshotEntryModel.Timestamp Property

SnapshotEntryModelTimestamp Property
Gets or sets the when this snapshot was taken.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset Timestamp { get; set; }
Public Property Timestamp As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset Timestamp {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member Timestamp : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

SnapshotEntryModel Class


SnapshotEntryModel Methods

SnapshotEntryModel Methods

The SnapshotEntryModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SnapshotEntryModel Class


SnapshotQuality Enumeration

SnapshotQuality Enumeration
Snapshot quality.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum SnapshotQuality
Public Enumeration SnapshotQuality
public enum class SnapshotQuality
type SnapshotQuality
Members
Member name | Value | Description
Good | 0 | The snapshot is good.
Bad | 1 | The snapshot is bad.
See Also

Reference

DoubleTake.Web.Models Namespace


SnapshotScheduleModel Class

SnapshotScheduleModel Class
Snapshot schedule model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsScheduleItemModel
DoubleTake.Web.ModelsSnapshotScheduleModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class SnapshotScheduleModel : ScheduleItemModel
Public NotInheritable Class SnapshotScheduleModel
    Inherits ScheduleItemModel
public ref class SnapshotScheduleModel sealed : public ScheduleItemModel
[<SealedAttribute>]
type SnapshotScheduleModel =
    class
        inherit ScheduleItemModel
    end

The SnapshotScheduleModel type exposes the following members.

Constructors
 | Name | Description
Public method | SnapshotScheduleModel | Initializes a new instance of the SnapshotScheduleModel class
Top
Properties
 | Name | Description
Public property | Interval | Gets or sets the interval.
Public property | IsEnabled | Gets or sets a value indicating whether or not the item is enabled. (Inherited from ScheduleItemModel.)
Public property | MaxNumberOfSnapshots | Gets or sets the maximum number of snapshots.
Public property | StartTime | Gets or sets the start time.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SnapshotScheduleModel Constructor

SnapshotScheduleModel Constructor
Initializes a new instance of the SnapshotScheduleModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public SnapshotScheduleModel()
Public Sub New
public:
SnapshotScheduleModel()
new : unit -> SnapshotScheduleModel
See Also

Reference

SnapshotScheduleModel Class


SnapshotScheduleModel Properties

SnapshotScheduleModel Properties

The SnapshotScheduleModel type exposes the following members.

Properties
 | Name | Description
Public property | Interval | Gets or sets the interval.
Public property | IsEnabled | Gets or sets a value indicating whether or not the item is enabled. (Inherited from ScheduleItemModel.)
Public property | MaxNumberOfSnapshots | Gets or sets the maximum number of snapshots.
Public property | StartTime | Gets or sets the start time.
Top
See Also

Reference

SnapshotScheduleModel Class


SnapshotScheduleModel.Interval Property

SnapshotScheduleModelInterval Property
Gets or sets the interval.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Interval { get; set; }
Public Property Interval As TimeSpan
    Get
    Set
public:
property TimeSpan Interval {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Interval : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

SnapshotScheduleModel Class


SnapshotScheduleModel.MaxNumberOfSnapshots Property

SnapshotScheduleModelMaxNumberOfSnapshots Property
Gets or sets the maximum number of snapshots.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int MaxNumberOfSnapshots { get; set; }
Public Property MaxNumberOfSnapshots As Integer
    Get
    Set
public:
property int MaxNumberOfSnapshots {
    int get ();
    void set (int value);
}
member MaxNumberOfSnapshots : int with get, set

Property Value

Type: Int32
See Also

Reference

SnapshotScheduleModel Class


SnapshotScheduleModel.StartTime Property

SnapshotScheduleModelStartTime Property
Gets or sets the start time.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
member StartTime : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

SnapshotScheduleModel Class


SnapshotScheduleModel Methods

SnapshotScheduleModel Methods

The SnapshotScheduleModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SnapshotScheduleModel Class


SqlDatabasePersistedInfoModel Class

SqlDatabasePersistedInfoModel Class
SQL database persisted information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSqlDatabasePersistedInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class SqlDatabasePersistedInfoModel
Public NotInheritable Class SqlDatabasePersistedInfoModel
public ref class SqlDatabasePersistedInfoModel sealed
[<SealedAttribute>]
type SqlDatabasePersistedInfoModel =  class end

The SqlDatabasePersistedInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | SqlDatabasePersistedInfoModel | Initializes a new instance of the SqlDatabasePersistedInfoModel class
Top
Properties
 | Name | Description
Public property | Files | Gets or sets the files.
Public property | Name | Gets or sets the name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SqlDatabasePersistedInfoModel Constructor

SqlDatabasePersistedInfoModel Constructor
Initializes a new instance of the SqlDatabasePersistedInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public SqlDatabasePersistedInfoModel()
Public Sub New
public:
SqlDatabasePersistedInfoModel()
new : unit -> SqlDatabasePersistedInfoModel
See Also

Reference

SqlDatabasePersistedInfoModel Class


SqlDatabasePersistedInfoModel Properties

SqlDatabasePersistedInfoModel Properties

The SqlDatabasePersistedInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Files | Gets or sets the files.
Public property | Name | Gets or sets the name.
Top
See Also

Reference

SqlDatabasePersistedInfoModel Class


SqlDatabasePersistedInfoModel.Files Property

SqlDatabasePersistedInfoModelFiles Property
Gets or sets the files.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<string> Files { get; set; }
Public Property Files As IEnumerable(Of String)
    Get
    Set
public:
property IEnumerable<String^>^ Files {
    IEnumerable<String^>^ get ();
    void set (IEnumerable<String^>^ value);
}
member Files : IEnumerable<string> with get, set

Property Value

Type: IEnumerable String
The files.
See Also

Reference

SqlDatabasePersistedInfoModel Class


SqlDatabasePersistedInfoModel.Name Property

SqlDatabasePersistedInfoModelName Property
Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

SqlDatabasePersistedInfoModel Class


SqlDatabasePersistedInfoModel Methods

SqlDatabasePersistedInfoModel Methods

The SqlDatabasePersistedInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SqlDatabasePersistedInfoModel Class


SsmRecoveryType Enumeration

SsmRecoveryType Enumeration
SSM recovery type

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum SsmRecoveryType
Public Enumeration SsmRecoveryType
public enum class SsmRecoveryType
type SsmRecoveryType
Members
Member name | Value | Description
LAN | 0 | The lan
WAN | 1 | The wan
See Also

Reference

DoubleTake.Web.Models Namespace


StorageInfoModel Class

StorageInfoModel Class
Core.StorageInfo
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsStorageInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class StorageInfoModel
Public NotInheritable Class StorageInfoModel
public ref class StorageInfoModel sealed
[<SealedAttribute>]
type StorageInfoModel =  class end

The StorageInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | StorageInfoModel | Initializes a new instance of the StorageInfoModel class
Top
Properties
 | Name | Description
Public property | Disk | Gets or sets storage location.
Public property | FreeSizeInBytes | Gets or sets the free size in bytes.
Public property | Group | Gets or sets cluster group location.
Public property | IsAvailableStorageGroup | Gets or sets a value indicating whether [is available storage group].
Public property | IsQuorumResource | Gets or sets a value indicating whether this instance is quorum resource.
Public property | IsSystemVolume | Gets or sets a value indicating whether this instance is system volume.
Public property | IsVolumeCSV | Gets or sets a value indicating whether this instance is volume CSV.
Public property | Name | Gets or sets the name of the resource.
Public property | OwningNode | Gets or sets the current Owning Node.
Public property | TotalSizeInBytes | Gets or sets the total size in bytes.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


StorageInfoModel Constructor

StorageInfoModel Constructor
Initializes a new instance of the StorageInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public StorageInfoModel()
Public Sub New
public:
StorageInfoModel()
new : unit -> StorageInfoModel
See Also

Reference

StorageInfoModel Class


StorageInfoModel Properties

StorageInfoModel Properties

The StorageInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Disk | Gets or sets storage location.
Public property | FreeSizeInBytes | Gets or sets the free size in bytes.
Public property | Group | Gets or sets cluster group location.
Public property | IsAvailableStorageGroup | Gets or sets a value indicating whether [is available storage group].
Public property | IsQuorumResource | Gets or sets a value indicating whether this instance is quorum resource.
Public property | IsSystemVolume | Gets or sets a value indicating whether this instance is system volume.
Public property | IsVolumeCSV | Gets or sets a value indicating whether this instance is volume CSV.
Public property | Name | Gets or sets the name of the resource.
Public property | OwningNode | Gets or sets the current Owning Node.
Public property | TotalSizeInBytes | Gets or sets the total size in bytes.
Top
See Also

Reference

StorageInfoModel Class


StorageInfoModel.Disk Property

StorageInfoModelDisk Property
Gets or sets storage location.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Disk { get; set; }
Public Property Disk As String
    Get
    Set
public:
property String^ Disk {
    String^ get ();
    void set (String^ value);
}
member Disk : string with get, set

Property Value

Type: String
See Also

Reference

StorageInfoModel Class


StorageInfoModel.FreeSizeInBytes Property

StorageInfoModelFreeSizeInBytes Property
Gets or sets the free size in bytes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long FreeSizeInBytes { get; set; }
Public Property FreeSizeInBytes As Long
    Get
    Set
public:
property long long FreeSizeInBytes {
    long long get ();
    void set (long long value);
}
member FreeSizeInBytes : int64 with get, set

Property Value

Type: Int64
The free size in bytes.
See Also

Reference

StorageInfoModel Class


StorageInfoModel.Group Property

StorageInfoModelGroup Property
Gets or sets cluster group location.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Group { get; set; }
Public Property Group As String
    Get
    Set
public:
property String^ Group {
    String^ get ();
    void set (String^ value);
}
member Group : string with get, set

Property Value

Type: String
See Also

Reference

StorageInfoModel Class


StorageInfoModel.IsAvailableStorageGroup Property

StorageInfoModelIsAvailableStorageGroup Property
Gets or sets a value indicating whether [is available storage group].

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsAvailableStorageGroup { get; set; }
Public Property IsAvailableStorageGroup As Boolean
    Get
    Set
public:
property bool IsAvailableStorageGroup {
    bool get ();
    void set (bool value);
}
member IsAvailableStorageGroup : bool with get, set

Property Value

Type: Boolean
true if [is available storage group]; otherwise, false.
See Also

Reference

StorageInfoModel Class


StorageInfoModel.IsQuorumResource Property

StorageInfoModelIsQuorumResource Property
Gets or sets a value indicating whether this instance is quorum resource.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsQuorumResource { get; set; }
Public Property IsQuorumResource As Boolean
    Get
    Set
public:
property bool IsQuorumResource {
    bool get ();
    void set (bool value);
}
member IsQuorumResource : bool with get, set

Property Value

Type: Boolean
true if this instance is quorum resource; otherwise, false.
See Also

Reference

StorageInfoModel Class


StorageInfoModel.IsSystemVolume Property

StorageInfoModelIsSystemVolume Property
Gets or sets a value indicating whether this instance is system volume.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsSystemVolume { get; set; }
Public Property IsSystemVolume As Boolean
    Get
    Set
public:
property bool IsSystemVolume {
    bool get ();
    void set (bool value);
}
member IsSystemVolume : bool with get, set

Property Value

Type: Boolean
true if this instance is system volume; otherwise, false.
See Also

Reference

StorageInfoModel Class


StorageInfoModel.IsVolumeCSV Property

StorageInfoModelIsVolumeCSV Property
Gets or sets a value indicating whether this instance is volume CSV.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsVolumeCSV { get; set; }
Public Property IsVolumeCSV As Boolean
    Get
    Set
public:
property bool IsVolumeCSV {
    bool get ();
    void set (bool value);
}
member IsVolumeCSV : bool with get, set

Property Value

Type: Boolean
true if this instance is volume CSV; otherwise, false.
See Also

Reference

StorageInfoModel Class


StorageInfoModel.Name Property

StorageInfoModelName Property
Gets or sets the name of the resource.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

StorageInfoModel Class


StorageInfoModel.OwningNode Property

StorageInfoModelOwningNode Property
Gets or sets the current Owning Node.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string OwningNode { get; set; }
Public Property OwningNode As String
    Get
    Set
public:
property String^ OwningNode {
    String^ get ();
    void set (String^ value);
}
member OwningNode : string with get, set

Property Value

Type: String
See Also

Reference

StorageInfoModel Class


StorageInfoModel.TotalSizeInBytes Property

StorageInfoModelTotalSizeInBytes Property
Gets or sets the total size in bytes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long TotalSizeInBytes { get; set; }
Public Property TotalSizeInBytes As Long
    Get
    Set
public:
property long long TotalSizeInBytes {
    long long get ();
    void set (long long value);
}
member TotalSizeInBytes : int64 with get, set

Property Value

Type: Int64
The total size in bytes.
See Also

Reference

StorageInfoModel Class


StorageInfoModel Methods

StorageInfoModel Methods

The StorageInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StorageInfoModel Class


StringSettingModel Class

StringSettingModel Class
String setting.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsNamedSettingModel
DoubleTake.Web.ModelsStringSettingModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class StringSettingModel : NamedSettingModel
Public Class StringSettingModel
    Inherits NamedSettingModel
public ref class StringSettingModel : public NamedSettingModel
type StringSettingModel =
    class
        inherit NamedSettingModel
    end

The StringSettingModel type exposes the following members.

Constructors
 | Name | Description
Public method | StringSettingModel | Initializes a new instance of the StringSettingModel class
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name. (Inherited from NamedSettingModel.)
Public property | TypeName | Gets or sets the type name. (Inherited from NamedSettingModel.)
Public property | Value | Gets or sets the value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


StringSettingModel Constructor

StringSettingModel Constructor
Initializes a new instance of the StringSettingModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public StringSettingModel()
Public Sub New
public:
StringSettingModel()
new : unit -> StringSettingModel
See Also

Reference

StringSettingModel Class


StringSettingModel Properties

StringSettingModel Properties

The StringSettingModel type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name. (Inherited from NamedSettingModel.)
Public property | TypeName | Gets or sets the type name. (Inherited from NamedSettingModel.)
Public property | Value | Gets or sets the value.
Top
See Also

Reference

StringSettingModel Class


StringSettingModel.Value Property

StringSettingModelValue Property
Gets or sets the value.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
See Also

Reference

StringSettingModel Class


StringSettingModel Methods

StringSettingModel Methods

The StringSettingModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StringSettingModel Class


SwitchPortInfoModel Class

SwitchPortInfoModel Class
Switch port info.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSwitchPortInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class SwitchPortInfoModel
Public NotInheritable Class SwitchPortInfoModel
public ref class SwitchPortInfoModel sealed
[<SealedAttribute>]
type SwitchPortInfoModel =  class end

The SwitchPortInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | SwitchPortInfoModel | Initializes a new instance of the SwitchPortInfoModel class
Top
Properties
 | Name | Description
Public property | AccessVLanId | Gets or sets the VLan Id.
Public property | Guid | Gets or sets the switch port Guid.
Public property | Name | Gets or sets the switch port label.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SwitchPortInfoModel Constructor

SwitchPortInfoModel Constructor
Initializes a new instance of the SwitchPortInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public SwitchPortInfoModel()
Public Sub New
public:
SwitchPortInfoModel()
new : unit -> SwitchPortInfoModel
See Also

Reference

SwitchPortInfoModel Class


SwitchPortInfoModel Properties

SwitchPortInfoModel Properties

The SwitchPortInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | AccessVLanId | Gets or sets the VLan Id.
Public property | Guid | Gets or sets the switch port Guid.
Public property | Name | Gets or sets the switch port label.
Top
See Also

Reference

SwitchPortInfoModel Class


SwitchPortInfoModel.AccessVLanId Property

SwitchPortInfoModelAccessVLanId Property
Gets or sets the VLan Id.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int AccessVLanId { get; set; }
Public Property AccessVLanId As Integer
    Get
    Set
public:
property int AccessVLanId {
    int get ();
    void set (int value);
}
member AccessVLanId : int with get, set

Property Value

Type: Int32
See Also

Reference

SwitchPortInfoModel Class


SwitchPortInfoModel.Guid Property

SwitchPortInfoModelGuid Property
Gets or sets the switch port Guid.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Guid { get; set; }
Public Property Guid As String
    Get
    Set
public:
property String^ Guid {
    String^ get ();
    void set (String^ value);
}
member Guid : string with get, set

Property Value

Type: String
See Also

Reference

SwitchPortInfoModel Class


SwitchPortInfoModel.Name Property

SwitchPortInfoModelName Property
Gets or sets the switch port label.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

SwitchPortInfoModel Class


SwitchPortInfoModel Methods

SwitchPortInfoModel Methods

The SwitchPortInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SwitchPortInfoModel Class


SystemStateConfigurationModel Class

SystemStateConfigurationModel Class
Holds the system state definitions for both the source and target
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSystemStateConfigurationModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class SystemStateConfigurationModel
Public NotInheritable Class SystemStateConfigurationModel
public ref class SystemStateConfigurationModel sealed
[<SealedAttribute>]
type SystemStateConfigurationModel =  class end

The SystemStateConfigurationModel type exposes the following members.

Constructors
 | Name | Description
Public method | SystemStateConfigurationModel | Initializes a new instance of the SystemStateConfigurationModel class
Top
Properties
 | Name | Description
Public property | SourceSystemStateDefinition | Gets or sets the source system state definition.
Public property | TargetSystemStateDefinition | Gets or sets the target system state definition.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SystemStateConfigurationModel Constructor

SystemStateConfigurationModel Constructor
Initializes a new instance of the SystemStateConfigurationModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public SystemStateConfigurationModel()
Public Sub New
public:
SystemStateConfigurationModel()
new : unit -> SystemStateConfigurationModel
See Also

Reference

SystemStateConfigurationModel Class


SystemStateConfigurationModel Properties

SystemStateConfigurationModel Properties

The SystemStateConfigurationModel type exposes the following members.

Properties
 | Name | Description
Public property | SourceSystemStateDefinition | Gets or sets the source system state definition.
Public property | TargetSystemStateDefinition | Gets or sets the target system state definition.
Top
See Also

Reference

SystemStateConfigurationModel Class


SystemStateConfigurationModel.SourceSystemStateDefinition Property

SystemStateConfigurationModelSourceSystemStateDefinition Property
Gets or sets the source system state definition.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SourceSystemStateDefinition { get; set; }
Public Property SourceSystemStateDefinition As String
    Get
    Set
public:
property String^ SourceSystemStateDefinition {
    String^ get ();
    void set (String^ value);
}
member SourceSystemStateDefinition : string with get, set

Property Value

Type: String
The source system state definition.
See Also

Reference

SystemStateConfigurationModel Class


SystemStateConfigurationModel.TargetSystemStateDefinition Property

SystemStateConfigurationModelTargetSystemStateDefinition Property
Gets or sets the target system state definition.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string TargetSystemStateDefinition { get; set; }
Public Property TargetSystemStateDefinition As String
    Get
    Set
public:
property String^ TargetSystemStateDefinition {
    String^ get ();
    void set (String^ value);
}
member TargetSystemStateDefinition : string with get, set

Property Value

Type: String
The target system state definition.
See Also

Reference

SystemStateConfigurationModel Class


SystemStateConfigurationModel Methods

SystemStateConfigurationModel Methods

The SystemStateConfigurationModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SystemStateConfigurationModel Class


SystemStateCutoverStatusModel Class

SystemStateCutoverStatusModel Class
System state cutover status.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSystemStateCutoverStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class SystemStateCutoverStatusModel
Public Class SystemStateCutoverStatusModel
public ref class SystemStateCutoverStatusModel
type SystemStateCutoverStatusModel =  class end

The SystemStateCutoverStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | SystemStateCutoverStatusModel | Initializes a new instance of the SystemStateCutoverStatusModel class
Top
Properties
 | Name | Description
Public property | PercentComplete | Gets or sets the percent complete.
Public property | State | Gets or sets the state. If State > 0 SSM Cutover in progress If State = 0 No SSM Cutover activity If State is less 0 SSM Cutover failed in Phase : Math. Abs (State) If State > 0 AND PercentComplete = 100 SSM Cutover complete
Public property | TargetRebootFailed | Gets or sets a value indicating whether or not the call to reboot the target failed.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SystemStateCutoverStatusModel Constructor

SystemStateCutoverStatusModel Constructor
Initializes a new instance of the SystemStateCutoverStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public SystemStateCutoverStatusModel()
Public Sub New
public:
SystemStateCutoverStatusModel()
new : unit -> SystemStateCutoverStatusModel
See Also

Reference

SystemStateCutoverStatusModel Class


SystemStateCutoverStatusModel Properties

SystemStateCutoverStatusModel Properties

The SystemStateCutoverStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | PercentComplete | Gets or sets the percent complete.
Public property | State | Gets or sets the state. If State > 0 SSM Cutover in progress If State = 0 No SSM Cutover activity If State is less 0 SSM Cutover failed in Phase : Math. Abs (State) If State > 0 AND PercentComplete = 100 SSM Cutover complete
Public property | TargetRebootFailed | Gets or sets a value indicating whether or not the call to reboot the target failed.
Top
See Also

Reference

SystemStateCutoverStatusModel Class


SystemStateCutoverStatusModel.PercentComplete Property

SystemStateCutoverStatusModelPercentComplete Property
Gets or sets the percent complete.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int PercentComplete { get; set; }
Public Property PercentComplete As Integer
    Get
    Set
public:
property int PercentComplete {
    int get ();
    void set (int value);
}
member PercentComplete : int with get, set

Property Value

Type: Int32
The percent complete.
See Also

Reference

SystemStateCutoverStatusModel Class


SystemStateCutoverStatusModel.State Property

SystemStateCutoverStatusModelState Property
Gets or sets the state. If State > 0 SSM Cutover in progress If State = 0 No SSM Cutover activity If State is less 0 SSM Cutover failed in Phase : Math. Abs (State) If State > 0 AND PercentComplete = 100 SSM Cutover complete

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int State { get; set; }
Public Property State As Integer
    Get
    Set
public:
property int State {
    int get ();
    void set (int value);
}
member State : int with get, set

Property Value

Type: Int32
The state.
See Also

Reference

SystemStateCutoverStatusModel Class


SystemStateCutoverStatusModel.TargetRebootFailed Property

SystemStateCutoverStatusModelTargetRebootFailed Property
Gets or sets a value indicating whether or not the call to reboot the target failed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool TargetRebootFailed { get; set; }
Public Property TargetRebootFailed As Boolean
    Get
    Set
public:
property bool TargetRebootFailed {
    bool get ();
    void set (bool value);
}
member TargetRebootFailed : bool with get, set

Property Value

Type: Boolean
if the target reboot failed; otherwise, .
See Also

Reference

SystemStateCutoverStatusModel Class


SystemStateCutoverStatusModel Methods

SystemStateCutoverStatusModel Methods

The SystemStateCutoverStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SystemStateCutoverStatusModel Class


SystemStateDefinitionModel Class

SystemStateDefinitionModel Class
System state definition.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSystemStateDefinitionModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class SystemStateDefinitionModel
Public NotInheritable Class SystemStateDefinitionModel
public ref class SystemStateDefinitionModel sealed
[<SealedAttribute>]
type SystemStateDefinitionModel =  class end

The SystemStateDefinitionModel type exposes the following members.

Constructors
 | Name | Description
Public method | SystemStateDefinitionModel | Initializes a new instance of the SystemStateDefinitionModel class
Top
Properties
 | Name | Description
Public property | SystemStateDefinition | Gets or sets the system state definition.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SystemStateDefinitionModel Constructor

SystemStateDefinitionModel Constructor
Initializes a new instance of the SystemStateDefinitionModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public SystemStateDefinitionModel()
Public Sub New
public:
SystemStateDefinitionModel()
new : unit -> SystemStateDefinitionModel
See Also

Reference

SystemStateDefinitionModel Class


SystemStateDefinitionModel Properties

SystemStateDefinitionModel Properties

The SystemStateDefinitionModel type exposes the following members.

Properties
 | Name | Description
Public property | SystemStateDefinition | Gets or sets the system state definition.
Top
See Also

Reference

SystemStateDefinitionModel Class


SystemStateDefinitionModel.SystemStateDefinition Property

SystemStateDefinitionModelSystemStateDefinition Property
Gets or sets the system state definition.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SystemStateDefinition { get; set; }
Public Property SystemStateDefinition As String
    Get
    Set
public:
property String^ SystemStateDefinition {
    String^ get ();
    void set (String^ value);
}
member SystemStateDefinition : string with get, set

Property Value

Type: String
The system state definition.
See Also

Reference

SystemStateDefinitionModel Class


SystemStateDefinitionModel Methods

SystemStateDefinitionModel Methods

The SystemStateDefinitionModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SystemStateDefinitionModel Class


SystemStateDumpNonDiskSystemStateInfoStatusModel Class

SystemStateDumpNonDiskSystemStateInfoStatusModel Class
System state dump non-disk system state information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSystemStateDumpNonDiskSystemStateInfoStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class SystemStateDumpNonDiskSystemStateInfoStatusModel
Public Class SystemStateDumpNonDiskSystemStateInfoStatusModel
public ref class SystemStateDumpNonDiskSystemStateInfoStatusModel
type SystemStateDumpNonDiskSystemStateInfoStatusModel =  class end

The SystemStateDumpNonDiskSystemStateInfoStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | SystemStateDumpNonDiskSystemStateInfoStatusModel | Initializes a new instance of the SystemStateDumpNonDiskSystemStateInfoStatusModel class
Top
Properties
 | Name | Description
Public property | Complete | Gets or sets a value indicating whether this SystemStateDumpNonDiskSystemStateInfoStatusModel is complete.
Public property | Log | Gets or sets the log.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SystemStateDumpNonDiskSystemStateInfoStatusModel Constructor

SystemStateDumpNonDiskSystemStateInfoStatusModel Constructor
Initializes a new instance of the SystemStateDumpNonDiskSystemStateInfoStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public SystemStateDumpNonDiskSystemStateInfoStatusModel()
Public Sub New
public:
SystemStateDumpNonDiskSystemStateInfoStatusModel()
new : unit -> SystemStateDumpNonDiskSystemStateInfoStatusModel
See Also

Reference

SystemStateDumpNonDiskSystemStateInfoStatusModel Class


SystemStateDumpNonDiskSystemStateInfoStatusModel Properties

SystemStateDumpNonDiskSystemStateInfoStatusModel Properties

The SystemStateDumpNonDiskSystemStateInfoStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | Complete | Gets or sets a value indicating whether this SystemStateDumpNonDiskSystemStateInfoStatusModel is complete.
Public property | Log | Gets or sets the log.
Top
See Also

Reference

SystemStateDumpNonDiskSystemStateInfoStatusModel Class


SystemStateDumpNonDiskSystemStateInfoStatusModel.Complete Property

SystemStateDumpNonDiskSystemStateInfoStatusModelComplete Property
Gets or sets a value indicating whether this SystemStateDumpNonDiskSystemStateInfoStatusModel is complete.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool Complete { get; set; }
Public Property Complete As Boolean
    Get
    Set
public:
property bool Complete {
    bool get ();
    void set (bool value);
}
member Complete : bool with get, set

Property Value

Type: Boolean
true if complete; otherwise, false.
See Also

Reference

SystemStateDumpNonDiskSystemStateInfoStatusModel Class


SystemStateDumpNonDiskSystemStateInfoStatusModel.Log Property

SystemStateDumpNonDiskSystemStateInfoStatusModelLog Property
Gets or sets the log.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Log { get; set; }
Public Property Log As String
    Get
    Set
public:
property String^ Log {
    String^ get ();
    void set (String^ value);
}
member Log : string with get, set

Property Value

Type: String
The log.
See Also

Reference

SystemStateDumpNonDiskSystemStateInfoStatusModel Class


SystemStateDumpNonDiskSystemStateInfoStatusModel Methods

SystemStateDumpNonDiskSystemStateInfoStatusModel Methods

The SystemStateDumpNonDiskSystemStateInfoStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SystemStateDumpNonDiskSystemStateInfoStatusModel Class


SystemStateOptionsModel Class

SystemStateOptionsModel Class
System state options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSystemStateOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class SystemStateOptionsModel
Public NotInheritable Class SystemStateOptionsModel
public ref class SystemStateOptionsModel sealed
[<SealedAttribute>]
type SystemStateOptionsModel =  class end

The SystemStateOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | SystemStateOptionsModel | Initializes a new instance of the SystemStateOptionsModel class
Top
Properties
 | Name | Description
Public property | AlternateVolumeMapping | Gets or sets the alternate volume used for staging.
Public property | AlternateVolumeStaging | Gets or sets a value indicating whether or not the system volume staging will be done on an alternate volume.
Public property | ApplyPorts | Gets or sets a value indicating whether source engine and management service ports should be copied to the target.
Public property | ClearMonitor | Gets or sets a value indicating whether or not the failover monitor should be removed at cut over.
Public property | IsWanFailover | Gets or sets a value indicating whether or not this job uses WAN failover.
Public property | KeepTargetActivationCode | Gets or sets a value indicating whether or not the target activation code should be kept after failover.
Public property | NicMappings | Gets or sets the network interface mappings.
Public property | ServicesToStopOptions | Gets or sets the services on the target server to stop during protection.
Public property | ShouldApplyDiskSignatures | Gets or sets a value indicating whether or not disk signatures should be applied at cut over.
Public property | SourceReservedAddress | Gets or sets the reserved IP address on the source server.
Public property | StagingFolder | Gets or sets the folder where operating system files will be staged.
Public property | TargetReservedAddress | Gets or sets the reserved IP address on the target server.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SystemStateOptionsModel Constructor

SystemStateOptionsModel Constructor
Initializes a new instance of the SystemStateOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public SystemStateOptionsModel()
Public Sub New
public:
SystemStateOptionsModel()
new : unit -> SystemStateOptionsModel
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel Properties

SystemStateOptionsModel Properties

The SystemStateOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | AlternateVolumeMapping | Gets or sets the alternate volume used for staging.
Public property | AlternateVolumeStaging | Gets or sets a value indicating whether or not the system volume staging will be done on an alternate volume.
Public property | ApplyPorts | Gets or sets a value indicating whether source engine and management service ports should be copied to the target.
Public property | ClearMonitor | Gets or sets a value indicating whether or not the failover monitor should be removed at cut over.
Public property | IsWanFailover | Gets or sets a value indicating whether or not this job uses WAN failover.
Public property | KeepTargetActivationCode | Gets or sets a value indicating whether or not the target activation code should be kept after failover.
Public property | NicMappings | Gets or sets the network interface mappings.
Public property | ServicesToStopOptions | Gets or sets the services on the target server to stop during protection.
Public property | ShouldApplyDiskSignatures | Gets or sets a value indicating whether or not disk signatures should be applied at cut over.
Public property | SourceReservedAddress | Gets or sets the reserved IP address on the source server.
Public property | StagingFolder | Gets or sets the folder where operating system files will be staged.
Public property | TargetReservedAddress | Gets or sets the reserved IP address on the target server.
Top
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel.AlternateVolumeMapping Property

SystemStateOptionsModelAlternateVolumeMapping Property
Gets or sets the alternate volume used for staging.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string AlternateVolumeMapping { get; set; }
Public Property AlternateVolumeMapping As String
    Get
    Set
public:
property String^ AlternateVolumeMapping {
    String^ get ();
    void set (String^ value);
}
member AlternateVolumeMapping : string with get, set

Property Value

Type: String
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel.AlternateVolumeStaging Property

SystemStateOptionsModelAlternateVolumeStaging Property
Gets or sets a value indicating whether or not the system volume staging will be done on an alternate volume.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool AlternateVolumeStaging { get; set; }
Public Property AlternateVolumeStaging As Boolean
    Get
    Set
public:
property bool AlternateVolumeStaging {
    bool get ();
    void set (bool value);
}
member AlternateVolumeStaging : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel.ApplyPorts Property

SystemStateOptionsModelApplyPorts Property
Gets or sets a value indicating whether source engine and management service ports should be copied to the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<bool> ApplyPorts { get; set; }
Public Property ApplyPorts As Nullable(Of Boolean)
    Get
    Set
public:
property Nullable<bool> ApplyPorts {
    Nullable<bool> get ();
    void set (Nullable<bool> value);
}
member ApplyPorts : Nullable<bool> with get, set

Property Value

Type: Nullable Boolean
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel.ClearMonitor Property

SystemStateOptionsModelClearMonitor Property
Gets or sets a value indicating whether or not the failover monitor should be removed at cut over.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool ClearMonitor { get; set; }
Public Property ClearMonitor As Boolean
    Get
    Set
public:
property bool ClearMonitor {
    bool get ();
    void set (bool value);
}
member ClearMonitor : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel.IsWanFailover Property

SystemStateOptionsModelIsWanFailover Property
Gets or sets a value indicating whether or not this job uses WAN failover.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsWanFailover { get; set; }
Public Property IsWanFailover As Boolean
    Get
    Set
public:
property bool IsWanFailover {
    bool get ();
    void set (bool value);
}
member IsWanFailover : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel.KeepTargetActivationCode Property

SystemStateOptionsModelKeepTargetActivationCode Property
Gets or sets a value indicating whether or not the target activation code should be kept after failover.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool KeepTargetActivationCode { get; set; }
Public Property KeepTargetActivationCode As Boolean
    Get
    Set
public:
property bool KeepTargetActivationCode {
    bool get ();
    void set (bool value);
}
member KeepTargetActivationCode : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel.NicMappings Property

SystemStateOptionsModelNicMappings Property
Gets or sets the network interface mappings.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public FullServerNicMappingsModel[] NicMappings { get; set; }
Public Property NicMappings As FullServerNicMappingsModel()
    Get
    Set
public:
property array<FullServerNicMappingsModel^>^ NicMappings {
    array<FullServerNicMappingsModel^>^ get ();
    void set (array<FullServerNicMappingsModel^>^ value);
}
member NicMappings : FullServerNicMappingsModel[] with get, set

Property Value

Type: FullServerNicMappingsModel
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel.ServicesToStopOptions Property

SystemStateOptionsModelServicesToStopOptions Property
Gets or sets the services on the target server to stop during protection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TargetServicesToStopModel[] ServicesToStopOptions { get; set; }
Public Property ServicesToStopOptions As TargetServicesToStopModel()
    Get
    Set
public:
property array<TargetServicesToStopModel^>^ ServicesToStopOptions {
    array<TargetServicesToStopModel^>^ get ();
    void set (array<TargetServicesToStopModel^>^ value);
}
member ServicesToStopOptions : TargetServicesToStopModel[] with get, set

Property Value

Type: TargetServicesToStopModel
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel.ShouldApplyDiskSignatures Property

SystemStateOptionsModelShouldApplyDiskSignatures Property
Gets or sets a value indicating whether or not disk signatures should be applied at cut over.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldApplyDiskSignatures { get; set; }
Public Property ShouldApplyDiskSignatures As Boolean
    Get
    Set
public:
property bool ShouldApplyDiskSignatures {
    bool get ();
    void set (bool value);
}
member ShouldApplyDiskSignatures : bool with get, set

Property Value

Type: Boolean
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel.SourceReservedAddress Property

SystemStateOptionsModelSourceReservedAddress Property
Gets or sets the reserved IP address on the source server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceReservedAddress { get; set; }
Public Property SourceReservedAddress As String
    Get
    Set
public:
property String^ SourceReservedAddress {
    String^ get ();
    void set (String^ value);
}
member SourceReservedAddress : string with get, set

Property Value

Type: String
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel.StagingFolder Property

SystemStateOptionsModelStagingFolder Property
Gets or sets the folder where operating system files will be staged.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string StagingFolder { get; set; }
Public Property StagingFolder As String
    Get
    Set
public:
property String^ StagingFolder {
    String^ get ();
    void set (String^ value);
}
member StagingFolder : string with get, set

Property Value

Type: String
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel.TargetReservedAddress Property

SystemStateOptionsModelTargetReservedAddress Property
Gets or sets the reserved IP address on the target server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetReservedAddress { get; set; }
Public Property TargetReservedAddress As String
    Get
    Set
public:
property String^ TargetReservedAddress {
    String^ get ();
    void set (String^ value);
}
member TargetReservedAddress : string with get, set

Property Value

Type: String
See Also

Reference

SystemStateOptionsModel Class


SystemStateOptionsModel Methods

SystemStateOptionsModel Methods

The SystemStateOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SystemStateOptionsModel Class


SystemStatePathModel Class

SystemStatePathModel Class
System state path.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSystemStatePathModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class SystemStatePathModel
Public NotInheritable Class SystemStatePathModel
public ref class SystemStatePathModel sealed
[<SealedAttribute>]
type SystemStatePathModel =  class end

The SystemStatePathModel type exposes the following members.

Constructors
 | Name | Description
Public method | SystemStatePathModel | Initializes a new instance of the SystemStatePathModel class
Top
Properties
 | Name | Description
Public property | Path | Gets or sets the path.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SystemStatePathModel Constructor

SystemStatePathModel Constructor
Initializes a new instance of the SystemStatePathModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public SystemStatePathModel()
Public Sub New
public:
SystemStatePathModel()
new : unit -> SystemStatePathModel
See Also

Reference

SystemStatePathModel Class


SystemStatePathModel Properties

SystemStatePathModel Properties

The SystemStatePathModel type exposes the following members.

Properties
 | Name | Description
Public property | Path | Gets or sets the path.
Top
See Also

Reference

SystemStatePathModel Class


SystemStatePathModel.Path Property

SystemStatePathModelPath Property
Gets or sets the path.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
member Path : string with get, set

Property Value

Type: String
The path.
See Also

Reference

SystemStatePathModel Class


SystemStatePathModel Methods

SystemStatePathModel Methods

The SystemStatePathModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SystemStatePathModel Class


SystemStatePropertyValueModel Class

SystemStatePropertyValueModel Class
System state property.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSystemStatePropertyValueModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class SystemStatePropertyValueModel
Public NotInheritable Class SystemStatePropertyValueModel
public ref class SystemStatePropertyValueModel sealed
[<SealedAttribute>]
type SystemStatePropertyValueModel =  class end

The SystemStatePropertyValueModel type exposes the following members.

Constructors
 | Name | Description
Public method | SystemStatePropertyValueModel | Initializes a new instance of the SystemStatePropertyValueModel class
Top
Properties
 | Name | Description
Public property | Value | Gets or sets the value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SystemStatePropertyValueModel Constructor

SystemStatePropertyValueModel Constructor
Initializes a new instance of the SystemStatePropertyValueModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public SystemStatePropertyValueModel()
Public Sub New
public:
SystemStatePropertyValueModel()
new : unit -> SystemStatePropertyValueModel
See Also

Reference

SystemStatePropertyValueModel Class


SystemStatePropertyValueModel Properties

SystemStatePropertyValueModel Properties

The SystemStatePropertyValueModel type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets or sets the value.
Top
See Also

Reference

SystemStatePropertyValueModel Class


SystemStatePropertyValueModel.Value Property

SystemStatePropertyValueModelValue Property
Gets or sets the value.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}
member Value : string with get, set

Property Value

Type: String
The value.
See Also

Reference

SystemStatePropertyValueModel Class


SystemStatePropertyValueModel Methods

SystemStatePropertyValueModel Methods

The SystemStatePropertyValueModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SystemStatePropertyValueModel Class


SystemStateVerificationResultModel Class

SystemStateVerificationResultModel Class
System state verification result.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSystemStateVerificationResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class SystemStateVerificationResultModel
Public Class SystemStateVerificationResultModel
public ref class SystemStateVerificationResultModel
type SystemStateVerificationResultModel =  class end

The SystemStateVerificationResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | SystemStateVerificationResultModel | Initializes a new instance of the SystemStateVerificationResultModel class
Top
Properties
 | Name | Description
Public property | IsCompatible | Gets or sets a value indicating whether the system state is compatible.
Public property | ValidationResults | Gets or sets the validation results.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SystemStateVerificationResultModel Constructor

SystemStateVerificationResultModel Constructor
Initializes a new instance of the SystemStateVerificationResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public SystemStateVerificationResultModel()
Public Sub New
public:
SystemStateVerificationResultModel()
new : unit -> SystemStateVerificationResultModel
See Also

Reference

SystemStateVerificationResultModel Class


SystemStateVerificationResultModel Properties

SystemStateVerificationResultModel Properties

The SystemStateVerificationResultModel type exposes the following members.

Properties
 | Name | Description
Public property | IsCompatible | Gets or sets a value indicating whether the system state is compatible.
Public property | ValidationResults | Gets or sets the validation results.
Top
See Also

Reference

SystemStateVerificationResultModel Class


SystemStateVerificationResultModel.IsCompatible Property

SystemStateVerificationResultModelIsCompatible Property
Gets or sets a value indicating whether the system state is compatible.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsCompatible { get; set; }
Public Property IsCompatible As Boolean
    Get
    Set
public:
property bool IsCompatible {
    bool get ();
    void set (bool value);
}
member IsCompatible : bool with get, set

Property Value

Type: Boolean
if the system state is compatible; otherwise, .
See Also

Reference

SystemStateVerificationResultModel Class


SystemStateVerificationResultModel.ValidationResults Property

SystemStateVerificationResultModelValidationResults Property
Gets or sets the validation results.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public SystemStateVerificationStepModel[] ValidationResults { get; set; }
Public Property ValidationResults As SystemStateVerificationStepModel()
    Get
    Set
public:
property array<SystemStateVerificationStepModel^>^ ValidationResults {
    array<SystemStateVerificationStepModel^>^ get ();
    void set (array<SystemStateVerificationStepModel^>^ value);
}
member ValidationResults : SystemStateVerificationStepModel[] with get, set

Property Value

Type: SystemStateVerificationStepModel
The validation results.
See Also

Reference

SystemStateVerificationResultModel Class


SystemStateVerificationResultModel Methods

SystemStateVerificationResultModel Methods

The SystemStateVerificationResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SystemStateVerificationResultModel Class


SystemStateVerificationStepModel Class

SystemStateVerificationStepModel Class
System state verification step.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsSystemStateVerificationStepModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class SystemStateVerificationStepModel
Public Class SystemStateVerificationStepModel
public ref class SystemStateVerificationStepModel
type SystemStateVerificationStepModel =  class end

The SystemStateVerificationStepModel type exposes the following members.

Constructors
 | Name | Description
Public method | SystemStateVerificationStepModel | Initializes a new instance of the SystemStateVerificationStepModel class
Top
Properties
 | Name | Description
Public property | Message | Gets or sets the message.
Public property | Name | Gets or sets the name.
Public property | Source | Gets or sets the source.
Public property | Status | Gets or sets the state.
Public property | Target | Gets or sets the target.
Public property | Task | Gets or sets the task.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


SystemStateVerificationStepModel Constructor

SystemStateVerificationStepModel Constructor
Initializes a new instance of the SystemStateVerificationStepModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public SystemStateVerificationStepModel()
Public Sub New
public:
SystemStateVerificationStepModel()
new : unit -> SystemStateVerificationStepModel
See Also

Reference

SystemStateVerificationStepModel Class


SystemStateVerificationStepModel Properties

SystemStateVerificationStepModel Properties

The SystemStateVerificationStepModel type exposes the following members.

Properties
 | Name | Description
Public property | Message | Gets or sets the message.
Public property | Name | Gets or sets the name.
Public property | Source | Gets or sets the source.
Public property | Status | Gets or sets the state.
Public property | Target | Gets or sets the target.
Public property | Task | Gets or sets the task.
Top
See Also

Reference

SystemStateVerificationStepModel Class


SystemStateVerificationStepModel.Message Property

SystemStateVerificationStepModelMessage Property
Gets or sets the message.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}
member Message : string with get, set

Property Value

Type: String
The message.
See Also

Reference

SystemStateVerificationStepModel Class


SystemStateVerificationStepModel.Name Property

SystemStateVerificationStepModelName Property
Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

SystemStateVerificationStepModel Class


SystemStateVerificationStepModel.Source Property

SystemStateVerificationStepModelSource Property
Gets or sets the source.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Source { get; set; }
Public Property Source As String
    Get
    Set
public:
property String^ Source {
    String^ get ();
    void set (String^ value);
}
member Source : string with get, set

Property Value

Type: String
The source.
See Also

Reference

SystemStateVerificationStepModel Class


SystemStateVerificationStepModel.Status Property

SystemStateVerificationStepModelStatus Property
Gets or sets the state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VerificationStatus Status { get; set; }
Public Property Status As VerificationStatus
    Get
    Set
public:
property VerificationStatus Status {
    VerificationStatus get ();
    void set (VerificationStatus value);
}
member Status : VerificationStatus with get, set

Property Value

Type: VerificationStatus
The state.
See Also

Reference

SystemStateVerificationStepModel Class


SystemStateVerificationStepModel.Target Property

SystemStateVerificationStepModelTarget Property
Gets or sets the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Target { get; set; }
Public Property Target As String
    Get
    Set
public:
property String^ Target {
    String^ get ();
    void set (String^ value);
}
member Target : string with get, set

Property Value

Type: String
The target.
See Also

Reference

SystemStateVerificationStepModel Class


SystemStateVerificationStepModel.Task Property

SystemStateVerificationStepModelTask Property
Gets or sets the task.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long Task { get; set; }
Public Property Task As Long
    Get
    Set
public:
property long long Task {
    long long get ();
    void set (long long value);
}
member Task : int64 with get, set

Property Value

Type: Int64
The task.
See Also

Reference

SystemStateVerificationStepModel Class


SystemStateVerificationStepModel Methods

SystemStateVerificationStepModel Methods

The SystemStateVerificationStepModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SystemStateVerificationStepModel Class


TargetFileServerQualificationResultsModel Class

TargetFileServerQualificationResultsModel Class
Target file server qualification results model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsTargetFileServerQualificationResultsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class TargetFileServerQualificationResultsModel
Public NotInheritable Class TargetFileServerQualificationResultsModel
public ref class TargetFileServerQualificationResultsModel sealed
[<SealedAttribute>]
type TargetFileServerQualificationResultsModel =  class end

The TargetFileServerQualificationResultsModel type exposes the following members.

Constructors
 | Name | Description
Public method | TargetFileServerQualificationResultsModel | Initializes a new instance of the TargetFileServerQualificationResultsModel class
Top
Properties
 | Name | Description
Public property | ClusterResourceGroupAddresses | Gets or sets the cluster resource group IP addresses.
Public property | ClusterResourceGroupName | Gets or sets the name of the group that contains the resource.
Public property | CurrentOwnerNodeName | Gets or sets the name of the resource's current owner node.
Public property | DiskSize | Gets or sets the volume total disk size.
Public property | DriveLetter | Gets or sets the volume drive letter.
Public property | FreeSpace | Gets or sets the volume available free space.
Public property | IsVolumeCSV | Gets or sets a value indicating whether it is a cluster shared volume.
Public property | RecommendedGroup | Gets or sets a value indicating whether this is a recommended group.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


TargetFileServerQualificationResultsModel Constructor

TargetFileServerQualificationResultsModel Constructor
Initializes a new instance of the TargetFileServerQualificationResultsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TargetFileServerQualificationResultsModel()
Public Sub New
public:
TargetFileServerQualificationResultsModel()
new : unit -> TargetFileServerQualificationResultsModel
See Also

Reference

TargetFileServerQualificationResultsModel Class


TargetFileServerQualificationResultsModel Properties

TargetFileServerQualificationResultsModel Properties

The TargetFileServerQualificationResultsModel type exposes the following members.

Properties
 | Name | Description
Public property | ClusterResourceGroupAddresses | Gets or sets the cluster resource group IP addresses.
Public property | ClusterResourceGroupName | Gets or sets the name of the group that contains the resource.
Public property | CurrentOwnerNodeName | Gets or sets the name of the resource's current owner node.
Public property | DiskSize | Gets or sets the volume total disk size.
Public property | DriveLetter | Gets or sets the volume drive letter.
Public property | FreeSpace | Gets or sets the volume available free space.
Public property | IsVolumeCSV | Gets or sets a value indicating whether it is a cluster shared volume.
Public property | RecommendedGroup | Gets or sets a value indicating whether this is a recommended group.
Top
See Also

Reference

TargetFileServerQualificationResultsModel Class


TargetFileServerQualificationResultsModel.ClusterResourceGroupAddresses Property

TargetFileServerQualificationResultsModelClusterResourceGroupAddresses Property
Gets or sets the cluster resource group IP addresses.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public UnicastNetworkAddressInfoModel[] ClusterResourceGroupAddresses { get; set; }
Public Property ClusterResourceGroupAddresses As UnicastNetworkAddressInfoModel()
    Get
    Set
public:
property array<UnicastNetworkAddressInfoModel^>^ ClusterResourceGroupAddresses {
    array<UnicastNetworkAddressInfoModel^>^ get ();
    void set (array<UnicastNetworkAddressInfoModel^>^ value);
}
member ClusterResourceGroupAddresses : UnicastNetworkAddressInfoModel[] with get, set

Property Value

Type: UnicastNetworkAddressInfoModel
See Also

Reference

TargetFileServerQualificationResultsModel Class


TargetFileServerQualificationResultsModel.ClusterResourceGroupName Property

TargetFileServerQualificationResultsModelClusterResourceGroupName Property
Gets or sets the name of the group that contains the resource.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ClusterResourceGroupName { get; set; }
Public Property ClusterResourceGroupName As String
    Get
    Set
public:
property String^ ClusterResourceGroupName {
    String^ get ();
    void set (String^ value);
}
member ClusterResourceGroupName : string with get, set

Property Value

Type: String
See Also

Reference

TargetFileServerQualificationResultsModel Class


TargetFileServerQualificationResultsModel.CurrentOwnerNodeName Property

TargetFileServerQualificationResultsModelCurrentOwnerNodeName Property
Gets or sets the name of the resource's current owner node.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string CurrentOwnerNodeName { get; set; }
Public Property CurrentOwnerNodeName As String
    Get
    Set
public:
property String^ CurrentOwnerNodeName {
    String^ get ();
    void set (String^ value);
}
member CurrentOwnerNodeName : string with get, set

Property Value

Type: String
See Also

Reference

TargetFileServerQualificationResultsModel Class


TargetFileServerQualificationResultsModel.DiskSize Property

TargetFileServerQualificationResultsModelDiskSize Property
Gets or sets the volume total disk size.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long DiskSize { get; set; }
Public Property DiskSize As Long
    Get
    Set
public:
property long long DiskSize {
    long long get ();
    void set (long long value);
}
member DiskSize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

TargetFileServerQualificationResultsModel Class


TargetFileServerQualificationResultsModel.DriveLetter Property

TargetFileServerQualificationResultsModelDriveLetter Property
Gets or sets the volume drive letter.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string DriveLetter { get; set; }
Public Property DriveLetter As String
    Get
    Set
public:
property String^ DriveLetter {
    String^ get ();
    void set (String^ value);
}
member DriveLetter : string with get, set

Property Value

Type: String
See Also

Reference

TargetFileServerQualificationResultsModel Class


TargetFileServerQualificationResultsModel.FreeSpace Property

TargetFileServerQualificationResultsModelFreeSpace Property
Gets or sets the volume available free space.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long FreeSpace { get; set; }
Public Property FreeSpace As Long
    Get
    Set
public:
property long long FreeSpace {
    long long get ();
    void set (long long value);
}
member FreeSpace : int64 with get, set

Property Value

Type: Int64
See Also

Reference

TargetFileServerQualificationResultsModel Class


TargetFileServerQualificationResultsModel.IsVolumeCSV Property

TargetFileServerQualificationResultsModelIsVolumeCSV Property
Gets or sets a value indicating whether it is a cluster shared volume.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsVolumeCSV { get; set; }
Public Property IsVolumeCSV As Boolean
    Get
    Set
public:
property bool IsVolumeCSV {
    bool get ();
    void set (bool value);
}
member IsVolumeCSV : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TargetFileServerQualificationResultsModel Class


TargetFileServerQualificationResultsModel.RecommendedGroup Property

TargetFileServerQualificationResultsModelRecommendedGroup Property
Gets or sets a value indicating whether this is a recommended group.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool RecommendedGroup { get; set; }
Public Property RecommendedGroup As Boolean
    Get
    Set
public:
property bool RecommendedGroup {
    bool get ();
    void set (bool value);
}
member RecommendedGroup : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TargetFileServerQualificationResultsModel Class


TargetFileServerQualificationResultsModel Methods

TargetFileServerQualificationResultsModel Methods

The TargetFileServerQualificationResultsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TargetFileServerQualificationResultsModel Class


TargetServicesOptionsModel Class

TargetServicesOptionsModel Class
Target services options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsTargetServicesOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class TargetServicesOptionsModel
Public NotInheritable Class TargetServicesOptionsModel
public ref class TargetServicesOptionsModel sealed
[<SealedAttribute>]
type TargetServicesOptionsModel =  class end

The TargetServicesOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | TargetServicesOptionsModel | Initializes a new instance of the TargetServicesOptionsModel class
Top
Properties
 | Name | Description
Public property | FailoverServices | Gets or sets the failover services.
Public property | StartAndStopServices | Gets or sets a value indicating whether or not to start and stop services.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


TargetServicesOptionsModel Constructor

TargetServicesOptionsModel Constructor
Initializes a new instance of the TargetServicesOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TargetServicesOptionsModel()
Public Sub New
public:
TargetServicesOptionsModel()
new : unit -> TargetServicesOptionsModel
See Also

Reference

TargetServicesOptionsModel Class


TargetServicesOptionsModel Properties

TargetServicesOptionsModel Properties

The TargetServicesOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | FailoverServices | Gets or sets the failover services.
Public property | StartAndStopServices | Gets or sets a value indicating whether or not to start and stop services.
Top
See Also

Reference

TargetServicesOptionsModel Class


TargetServicesOptionsModel.FailoverServices Property

TargetServicesOptionsModelFailoverServices Property
Gets or sets the failover services.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ServiceInformationModel[] FailoverServices { get; set; }
Public Property FailoverServices As ServiceInformationModel()
    Get
    Set
public:
property array<ServiceInformationModel^>^ FailoverServices {
    array<ServiceInformationModel^>^ get ();
    void set (array<ServiceInformationModel^>^ value);
}
member FailoverServices : ServiceInformationModel[] with get, set

Property Value

Type: ServiceInformationModel
See Also

Reference

TargetServicesOptionsModel Class


TargetServicesOptionsModel.StartAndStopServices Property

TargetServicesOptionsModelStartAndStopServices Property
Gets or sets a value indicating whether or not to start and stop services.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool StartAndStopServices { get; set; }
Public Property StartAndStopServices As Boolean
    Get
    Set
public:
property bool StartAndStopServices {
    bool get ();
    void set (bool value);
}
member StartAndStopServices : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TargetServicesOptionsModel Class


TargetServicesOptionsModel Methods

TargetServicesOptionsModel Methods

The TargetServicesOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TargetServicesOptionsModel Class


TargetServiceStatus Enumeration

TargetServiceStatus Enumeration
Target service status.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum TargetServiceStatus
Public Enumeration TargetServiceStatus
public enum class TargetServiceStatus
type TargetServiceStatus
Members
Member name | Value | Description
Stopped | 0 | The stopped
Started | 1 | The started
StopPending | 2 | The stop pending
StartPending | 3 | The start pending
ResumePending | 4 | The resume pending
PausePending | 5 | The pause pending
Paused | 6 | The paused
Unknown | 7 | The unknown
See Also

Reference

DoubleTake.Web.Models Namespace


TargetServicesToStopModel Class

TargetServicesToStopModel Class
Target services to stop model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsTargetServicesToStopModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class TargetServicesToStopModel
Public NotInheritable Class TargetServicesToStopModel
public ref class TargetServicesToStopModel sealed
[<SealedAttribute>]
type TargetServicesToStopModel =  class end

The TargetServicesToStopModel type exposes the following members.

Constructors
 | Name | Description
Public method | TargetServicesToStopModel | Initializes a new instance of the TargetServicesToStopModel class
Top
Properties
 | Name | Description
Public property | Failover | Gets or sets a value indicating whether to start this service after failover.
Public property | IsCritical | Gets or sets a value indicating whether this service is critical.
Public property | KeepRunningNonCritical | Gets or sets a value indicating whether to keep running this non-critical service.
Public property | ServiceDescription | Gets or sets the service description.
Public property | ServiceName | Gets or sets the name of the service.
Public property | State | Gets or sets the state of this service.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


TargetServicesToStopModel Constructor

TargetServicesToStopModel Constructor
Initializes a new instance of the TargetServicesToStopModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TargetServicesToStopModel()
Public Sub New
public:
TargetServicesToStopModel()
new : unit -> TargetServicesToStopModel
See Also

Reference

TargetServicesToStopModel Class


TargetServicesToStopModel Properties

TargetServicesToStopModel Properties

The TargetServicesToStopModel type exposes the following members.

Properties
 | Name | Description
Public property | Failover | Gets or sets a value indicating whether to start this service after failover.
Public property | IsCritical | Gets or sets a value indicating whether this service is critical.
Public property | KeepRunningNonCritical | Gets or sets a value indicating whether to keep running this non-critical service.
Public property | ServiceDescription | Gets or sets the service description.
Public property | ServiceName | Gets or sets the name of the service.
Public property | State | Gets or sets the state of this service.
Top
See Also

Reference

TargetServicesToStopModel Class


TargetServicesToStopModel.Failover Property

TargetServicesToStopModelFailover Property
Gets or sets a value indicating whether to start this service after failover.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool Failover { get; set; }
Public Property Failover As Boolean
    Get
    Set
public:
property bool Failover {
    bool get ();
    void set (bool value);
}
member Failover : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TargetServicesToStopModel Class


TargetServicesToStopModel.IsCritical Property

TargetServicesToStopModelIsCritical Property
Gets or sets a value indicating whether this service is critical.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsCritical { get; set; }
Public Property IsCritical As Boolean
    Get
    Set
public:
property bool IsCritical {
    bool get ();
    void set (bool value);
}
member IsCritical : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TargetServicesToStopModel Class


TargetServicesToStopModel.KeepRunningNonCritical Property

TargetServicesToStopModelKeepRunningNonCritical Property
Gets or sets a value indicating whether to keep running this non-critical service.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool KeepRunningNonCritical { get; set; }
Public Property KeepRunningNonCritical As Boolean
    Get
    Set
public:
property bool KeepRunningNonCritical {
    bool get ();
    void set (bool value);
}
member KeepRunningNonCritical : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TargetServicesToStopModel Class


TargetServicesToStopModel.ServiceDescription Property

TargetServicesToStopModelServiceDescription Property
Gets or sets the service description.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ServiceDescription { get; set; }
Public Property ServiceDescription As String
    Get
    Set
public:
property String^ ServiceDescription {
    String^ get ();
    void set (String^ value);
}
member ServiceDescription : string with get, set

Property Value

Type: String
See Also

Reference

TargetServicesToStopModel Class


TargetServicesToStopModel.ServiceName Property

TargetServicesToStopModelServiceName Property
Gets or sets the name of the service.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ServiceName { get; set; }
Public Property ServiceName As String
    Get
    Set
public:
property String^ ServiceName {
    String^ get ();
    void set (String^ value);
}
member ServiceName : string with get, set

Property Value

Type: String
See Also

Reference

TargetServicesToStopModel Class


TargetServicesToStopModel.State Property

TargetServicesToStopModelState Property
Gets or sets the state of this service.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TargetServiceStatus State { get; set; }
Public Property State As TargetServiceStatus
    Get
    Set
public:
property TargetServiceStatus State {
    TargetServiceStatus get ();
    void set (TargetServiceStatus value);
}
member State : TargetServiceStatus with get, set

Property Value

Type: TargetServiceStatus
See Also

Reference

TargetServicesToStopModel Class


TargetServicesToStopModel Methods

TargetServicesToStopModel Methods

The TargetServicesToStopModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TargetServicesToStopModel Class


TargetStateInfoModel Class

TargetStateInfoModel Class
Target state info model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsTargetStateInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class TargetStateInfoModel
Public NotInheritable Class TargetStateInfoModel
public ref class TargetStateInfoModel sealed
[<SealedAttribute>]
type TargetStateInfoModel =  class end

The TargetStateInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | TargetStateInfoModel | Initializes a new instance of the TargetStateInfoModel class
Top
Properties
 | Name | Description
Public property | ConnectionId | Gets or sets the engine connection id.
Public property | ConnectTime | Gets or sets the time this connection was created.
Public property | EngineJobType | Gets or sets the engine job type of the connection.
Public property | Guid | Gets or sets the unique identifier of the connection.
Public property | HasSnapshotSchedule | Gets or sets a value indicating whether this connection has a snapshot schedule.
Public property | LastUpdateTime | Gets or sets the last time this target connection information was updated.
Public property | NextScheduledSnapshot | Gets or sets the time of the next scheduled snapshot.
Public property | Paths | Gets or sets the paths used on the target server.
Public property | QueueBytes | Gets or sets the target queue bytes.
Public property | ReplicationSetUsageType | Gets or sets the usage type of the replication set that is connected.
Public property | ScheduledSnapshotInterval | Gets or sets the scheduled snapshot interval.
Public property | Snapshots | Gets or sets the current list of snapshots taken for this connection.
Public property | SourceEndPoint | Gets or sets the source endpoint.
Public property | SourceEndpointFromSource | Gets or sets the default address for the source server as provided by the source server.
Public property | SourceMachineName | Gets or sets the name of the source machine.
Public property | SourceVersion | Gets or sets the product version of the source machine.
Public property | States | Gets or sets the target states.
Public property | TargetEndpoint | Gets or sets the destination endpoint of the socket connection.
Public property | WorkloadId | Gets or sets the name of the replication set.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


TargetStateInfoModel Constructor

TargetStateInfoModel Constructor
Initializes a new instance of the TargetStateInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TargetStateInfoModel()
Public Sub New
public:
TargetStateInfoModel()
new : unit -> TargetStateInfoModel
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel Properties

TargetStateInfoModel Properties

The TargetStateInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionId | Gets or sets the engine connection id.
Public property | ConnectTime | Gets or sets the time this connection was created.
Public property | EngineJobType | Gets or sets the engine job type of the connection.
Public property | Guid | Gets or sets the unique identifier of the connection.
Public property | HasSnapshotSchedule | Gets or sets a value indicating whether this connection has a snapshot schedule.
Public property | LastUpdateTime | Gets or sets the last time this target connection information was updated.
Public property | NextScheduledSnapshot | Gets or sets the time of the next scheduled snapshot.
Public property | Paths | Gets or sets the paths used on the target server.
Public property | QueueBytes | Gets or sets the target queue bytes.
Public property | ReplicationSetUsageType | Gets or sets the usage type of the replication set that is connected.
Public property | ScheduledSnapshotInterval | Gets or sets the scheduled snapshot interval.
Public property | Snapshots | Gets or sets the current list of snapshots taken for this connection.
Public property | SourceEndPoint | Gets or sets the source endpoint.
Public property | SourceEndpointFromSource | Gets or sets the default address for the source server as provided by the source server.
Public property | SourceMachineName | Gets or sets the name of the source machine.
Public property | SourceVersion | Gets or sets the product version of the source machine.
Public property | States | Gets or sets the target states.
Public property | TargetEndpoint | Gets or sets the destination endpoint of the socket connection.
Public property | WorkloadId | Gets or sets the name of the replication set.
Top
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.ConnectionId Property

TargetStateInfoModelConnectionId Property
Gets or sets the engine connection id.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int ConnectionId { get; set; }
Public Property ConnectionId As Integer
    Get
    Set
public:
property int ConnectionId {
    int get ();
    void set (int value);
}
member ConnectionId : int with get, set

Property Value

Type: Int32
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.ConnectTime Property

TargetStateInfoModelConnectTime Property
Gets or sets the time this connection was created.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset ConnectTime { get; set; }
Public Property ConnectTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset ConnectTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member ConnectTime : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.EngineJobType Property

TargetStateInfoModelEngineJobType Property
Gets or sets the engine job type of the connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public EngineJobType EngineJobType { get; set; }
Public Property EngineJobType As EngineJobType
    Get
    Set
public:
property EngineJobType EngineJobType {
    EngineJobType get ();
    void set (EngineJobType value);
}
member EngineJobType : EngineJobType with get, set

Property Value

Type: EngineJobType
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.Guid Property

TargetStateInfoModelGuid Property
Gets or sets the unique identifier of the connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Guid Guid { get; set; }
Public Property Guid As Guid
    Get
    Set
public:
property Guid Guid {
    Guid get ();
    void set (Guid value);
}
member Guid : Guid with get, set

Property Value

Type: Guid
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.HasSnapshotSchedule Property

TargetStateInfoModelHasSnapshotSchedule Property
Gets or sets a value indicating whether this connection has a snapshot schedule.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool HasSnapshotSchedule { get; set; }
Public Property HasSnapshotSchedule As Boolean
    Get
    Set
public:
property bool HasSnapshotSchedule {
    bool get ();
    void set (bool value);
}
member HasSnapshotSchedule : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.LastUpdateTime Property

TargetStateInfoModelLastUpdateTime Property
Gets or sets the last time this target connection information was updated.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset LastUpdateTime { get; set; }
Public Property LastUpdateTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset LastUpdateTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member LastUpdateTime : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.NextScheduledSnapshot Property

TargetStateInfoModelNextScheduledSnapshot Property
Gets or sets the time of the next scheduled snapshot.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset NextScheduledSnapshot { get; set; }
Public Property NextScheduledSnapshot As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset NextScheduledSnapshot {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member NextScheduledSnapshot : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.Paths Property

TargetStateInfoModelPaths Property
Gets or sets the paths used on the target server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] Paths { get; set; }
Public Property Paths As String()
    Get
    Set
public:
property array<String^>^ Paths {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member Paths : string[] with get, set

Property Value

Type: String
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.QueueBytes Property

TargetStateInfoModelQueueBytes Property
Gets or sets the target queue bytes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long QueueBytes { get; set; }
Public Property QueueBytes As Long
    Get
    Set
public:
property long long QueueBytes {
    long long get ();
    void set (long long value);
}
member QueueBytes : int64 with get, set

Property Value

Type: Int64
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.ReplicationSetUsageType Property

TargetStateInfoModelReplicationSetUsageType Property
Gets or sets the usage type of the replication set that is connected.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ReplicationSetUsageType ReplicationSetUsageType { get; set; }
Public Property ReplicationSetUsageType As ReplicationSetUsageType
    Get
    Set
public:
property ReplicationSetUsageType ReplicationSetUsageType {
    ReplicationSetUsageType get ();
    void set (ReplicationSetUsageType value);
}
member ReplicationSetUsageType : ReplicationSetUsageType with get, set

Property Value

Type: ReplicationSetUsageType
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.ScheduledSnapshotInterval Property

TargetStateInfoModelScheduledSnapshotInterval Property
Gets or sets the scheduled snapshot interval.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan ScheduledSnapshotInterval { get; set; }
Public Property ScheduledSnapshotInterval As TimeSpan
    Get
    Set
public:
property TimeSpan ScheduledSnapshotInterval {
    TimeSpan get ();
    void set (TimeSpan value);
}
member ScheduledSnapshotInterval : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.Snapshots Property

TargetStateInfoModelSnapshots Property
Gets or sets the current list of snapshots taken for this connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public SnapshotEntryModel[] Snapshots { get; set; }
Public Property Snapshots As SnapshotEntryModel()
    Get
    Set
public:
property array<SnapshotEntryModel^>^ Snapshots {
    array<SnapshotEntryModel^>^ get ();
    void set (array<SnapshotEntryModel^>^ value);
}
member Snapshots : SnapshotEntryModel[] with get, set

Property Value

Type: SnapshotEntryModel
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.SourceEndPoint Property

TargetStateInfoModelSourceEndPoint Property
Gets or sets the source endpoint.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceEndPoint { get; set; }
Public Property SourceEndPoint As String
    Get
    Set
public:
property String^ SourceEndPoint {
    String^ get ();
    void set (String^ value);
}
member SourceEndPoint : string with get, set

Property Value

Type: String
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.SourceEndpointFromSource Property

TargetStateInfoModelSourceEndpointFromSource Property
Gets or sets the default address for the source server as provided by the source server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceEndpointFromSource { get; set; }
Public Property SourceEndpointFromSource As String
    Get
    Set
public:
property String^ SourceEndpointFromSource {
    String^ get ();
    void set (String^ value);
}
member SourceEndpointFromSource : string with get, set

Property Value

Type: String
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.SourceMachineName Property

TargetStateInfoModelSourceMachineName Property
Gets or sets the name of the source machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceMachineName { get; set; }
Public Property SourceMachineName As String
    Get
    Set
public:
property String^ SourceMachineName {
    String^ get ();
    void set (String^ value);
}
member SourceMachineName : string with get, set

Property Value

Type: String
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.SourceVersion Property

TargetStateInfoModelSourceVersion Property
Gets or sets the product version of the source machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ProductVersionModel SourceVersion { get; set; }
Public Property SourceVersion As ProductVersionModel
    Get
    Set
public:
property ProductVersionModel^ SourceVersion {
    ProductVersionModel^ get ();
    void set (ProductVersionModel^ value);
}
member SourceVersion : ProductVersionModel with get, set

Property Value

Type: ProductVersionModel
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.States Property

TargetStateInfoModelStates Property
Gets or sets the target states.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TargetStates States { get; set; }
Public Property States As TargetStates
    Get
    Set
public:
property TargetStates States {
    TargetStates get ();
    void set (TargetStates value);
}
member States : TargetStates with get, set

Property Value

Type: TargetStates
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.TargetEndpoint Property

TargetStateInfoModelTargetEndpoint Property
Gets or sets the destination endpoint of the socket connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetEndpoint { get; set; }
Public Property TargetEndpoint As String
    Get
    Set
public:
property String^ TargetEndpoint {
    String^ get ();
    void set (String^ value);
}
member TargetEndpoint : string with get, set

Property Value

Type: String
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel.WorkloadId Property

TargetStateInfoModelWorkloadId Property
Gets or sets the name of the replication set.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string WorkloadId { get; set; }
Public Property WorkloadId As String
    Get
    Set
public:
property String^ WorkloadId {
    String^ get ();
    void set (String^ value);
}
member WorkloadId : string with get, set

Property Value

Type: String
See Also

Reference

TargetStateInfoModel Class


TargetStateInfoModel Methods

TargetStateInfoModel Methods

The TargetStateInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TargetStateInfoModel Class


TargetStates Enumeration

TargetStates Enumeration
Target states.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum TargetStates
<FlagsAttribute>
Public Enumeration TargetStates
[FlagsAttribute]
public enum class TargetStates
[<FlagsAttribute>]
type TargetStates
Members
Member name | Value | Description
Good | 0 | The good
Mirroring | 1 | The mirroring
MirrorStopped | 2 | The mirror stopped
OpDropped | 4 | The op dropped
Retrying | 8 | The retrying
Paused | 16 | The paused
PausePending | 32 | The pause pending
RestoreRequired | 64 | The restore required
ReplicationPending | 128 | The replication pending
SnapshotReverted | 256 | The snapshot reverted
FailoverUnblocked | 512 | The failover unblocked
Disconnected | 1024 | The disconnected
SroImage | 2048 | The SRO image
FailoverMonitoring | 4096 | The failover monitoring
TransactionsPending | 8192 | The transactions pending
GCReplicationComplete | 16384 | The GC replication complete
MarkedForDeletion | 32768 | The marked for deletion
JobNotReadyOnTarget | 65536 | The job not ready on target
TargetPathBlocked | 2147483648 | The target path blocked
Unknown | -4294967296 | The unknown
See Also

Reference

DoubleTake.Web.Models Namespace


TaskParametersModel Class

TaskParametersModel Class
Specifies a script or executable to be run along with its corresponding command-line arguments.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsTaskParametersModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class TaskParametersModel
Public NotInheritable Class TaskParametersModel
public ref class TaskParametersModel sealed
[<SealedAttribute>]
type TaskParametersModel =  class end

The TaskParametersModel type exposes the following members.

Constructors
 | Name | Description
Public method | TaskParametersModel | Initializes a new instance of the TaskParametersModel class
Top
Properties
 | Name | Description
Public property | Arguments | Gets or sets a comma-separated list of valid arguments required to execute the script.
Public property | Script | Gets or sets the full path and file name of the script.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


TaskParametersModel Constructor

TaskParametersModel Constructor
Initializes a new instance of the TaskParametersModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public TaskParametersModel()
Public Sub New
public:
TaskParametersModel()
new : unit -> TaskParametersModel
See Also

Reference

TaskParametersModel Class


TaskParametersModel Properties

TaskParametersModel Properties

The TaskParametersModel type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets or sets a comma-separated list of valid arguments required to execute the script.
Public property | Script | Gets or sets the full path and file name of the script.
Top
See Also

Reference

TaskParametersModel Class


TaskParametersModel.Arguments Property

TaskParametersModelArguments Property
Gets or sets a comma-separated list of valid arguments required to execute the script.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
member Arguments : string with get, set

Property Value

Type: String
The command-line arguments.
See Also

Reference

TaskParametersModel Class


TaskParametersModel.Script Property

TaskParametersModelScript Property
Gets or sets the full path and file name of the script.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Script { get; set; }
Public Property Script As String
    Get
    Set
public:
property String^ Script {
    String^ get ();
    void set (String^ value);
}
member Script : string with get, set

Property Value

Type: String
See Also

Reference

TaskParametersModel Class


TaskParametersModel Methods

TaskParametersModel Methods

The TaskParametersModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TaskParametersModel Class


TestFailoverOptionsModel Class

TestFailoverOptionsModel Class
Test failover options model for VRA.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsTestFailoverOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class TestFailoverOptionsModel
Public NotInheritable Class TestFailoverOptionsModel
public ref class TestFailoverOptionsModel sealed
[<SealedAttribute>]
type TestFailoverOptionsModel =  class end

The TestFailoverOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | TestFailoverOptionsModel | Initializes a new instance of the TestFailoverOptionsModel class
Top
Properties
 | Name | Description
Public property | DeleteSnapshots | Gets or sets a value indicating whether or not to delete snapshots.
Public property | DeleteVirtualDisks | Gets or sets a value indicating whether or not to delete virtual disks.
Public property | ReplicaDisplayName | Gets or sets a the test failover replica display name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


TestFailoverOptionsModel Constructor

TestFailoverOptionsModel Constructor
Initializes a new instance of the TestFailoverOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TestFailoverOptionsModel()
Public Sub New
public:
TestFailoverOptionsModel()
new : unit -> TestFailoverOptionsModel
See Also

Reference

TestFailoverOptionsModel Class


TestFailoverOptionsModel Properties

TestFailoverOptionsModel Properties

The TestFailoverOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | DeleteSnapshots | Gets or sets a value indicating whether or not to delete snapshots.
Public property | DeleteVirtualDisks | Gets or sets a value indicating whether or not to delete virtual disks.
Public property | ReplicaDisplayName | Gets or sets a the test failover replica display name.
Top
See Also

Reference

TestFailoverOptionsModel Class


TestFailoverOptionsModel.DeleteSnapshots Property

TestFailoverOptionsModelDeleteSnapshots Property
Gets or sets a value indicating whether or not to delete snapshots.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool DeleteSnapshots { get; set; }
Public Property DeleteSnapshots As Boolean
    Get
    Set
public:
property bool DeleteSnapshots {
    bool get ();
    void set (bool value);
}
member DeleteSnapshots : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TestFailoverOptionsModel Class


TestFailoverOptionsModel.DeleteVirtualDisks Property

TestFailoverOptionsModelDeleteVirtualDisks Property
Gets or sets a value indicating whether or not to delete virtual disks.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool DeleteVirtualDisks { get; set; }
Public Property DeleteVirtualDisks As Boolean
    Get
    Set
public:
property bool DeleteVirtualDisks {
    bool get ();
    void set (bool value);
}
member DeleteVirtualDisks : bool with get, set

Property Value

Type: Boolean
See Also

Reference

TestFailoverOptionsModel Class


TestFailoverOptionsModel.ReplicaDisplayName Property

TestFailoverOptionsModelReplicaDisplayName Property
Gets or sets a the test failover replica display name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ReplicaDisplayName { get; set; }
Public Property ReplicaDisplayName As String
    Get
    Set
public:
property String^ ReplicaDisplayName {
    String^ get ();
    void set (String^ value);
}
member ReplicaDisplayName : string with get, set

Property Value

Type: String
See Also

Reference

TestFailoverOptionsModel Class


TestFailoverOptionsModel Methods

TestFailoverOptionsModel Methods

The TestFailoverOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TestFailoverOptionsModel Class


TestFailoverServerCredentialModel Class

TestFailoverServerCredentialModel Class
Full server test failover options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsTestFailoverServerCredentialModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class TestFailoverServerCredentialModel
Public NotInheritable Class TestFailoverServerCredentialModel
public ref class TestFailoverServerCredentialModel sealed
[<SealedAttribute>]
type TestFailoverServerCredentialModel =  class end

The TestFailoverServerCredentialModel type exposes the following members.

Constructors
 | Name | Description
Public method | TestFailoverServerCredentialModel | Initializes a new instance of the TestFailoverServerCredentialModel class
Top
Properties
 | Name | Description
Public property | TestFailoverServerHardwareId | Gets or sets the testfailover server hardware id.
Public property | TestFailoverServerHostUri | Gets or sets the testfailover server host URI.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


TestFailoverServerCredentialModel Constructor

TestFailoverServerCredentialModel Constructor
Initializes a new instance of the TestFailoverServerCredentialModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TestFailoverServerCredentialModel()
Public Sub New
public:
TestFailoverServerCredentialModel()
new : unit -> TestFailoverServerCredentialModel
See Also

Reference

TestFailoverServerCredentialModel Class


TestFailoverServerCredentialModel Properties

TestFailoverServerCredentialModel Properties

The TestFailoverServerCredentialModel type exposes the following members.

Properties
 | Name | Description
Public property | TestFailoverServerHardwareId | Gets or sets the testfailover server hardware id.
Public property | TestFailoverServerHostUri | Gets or sets the testfailover server host URI.
Top
See Also

Reference

TestFailoverServerCredentialModel Class


TestFailoverServerCredentialModel.TestFailoverServerHardwareId Property

TestFailoverServerCredentialModelTestFailoverServerHardwareId Property
Gets or sets the testfailover server hardware id.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TestFailoverServerHardwareId { get; set; }
Public Property TestFailoverServerHardwareId As String
    Get
    Set
public:
property String^ TestFailoverServerHardwareId {
    String^ get ();
    void set (String^ value);
}
member TestFailoverServerHardwareId : string with get, set

Property Value

Type: String
The testfailover server hardware id.
See Also

Reference

TestFailoverServerCredentialModel Class


TestFailoverServerCredentialModel.TestFailoverServerHostUri Property

TestFailoverServerCredentialModelTestFailoverServerHostUri Property
Gets or sets the testfailover server host URI.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Uri TestFailoverServerHostUri { get; set; }
Public Property TestFailoverServerHostUri As Uri
    Get
    Set
public:
property Uri^ TestFailoverServerHostUri {
    Uri^ get ();
    void set (Uri^ value);
}
member TestFailoverServerHostUri : Uri with get, set

Property Value

Type: Uri
The testfailover server host URI.
Remarks
This property serves as a replacement for the deprecated SourceConnectionParameters property.
See Also

Reference

TestFailoverServerCredentialModel Class


TestFailoverServerCredentialModel Methods

TestFailoverServerCredentialModel Methods

The TestFailoverServerCredentialModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TestFailoverServerCredentialModel Class


TestScriptRequestModel Class

TestScriptRequestModel Class
Test script request model
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsTestScriptRequestModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class TestScriptRequestModel
Public NotInheritable Class TestScriptRequestModel
public ref class TestScriptRequestModel sealed
[<SealedAttribute>]
type TestScriptRequestModel =  class end

The TestScriptRequestModel type exposes the following members.

Constructors
 | Name | Description
Public method | TestScriptRequestModel | Initializes a new instance of the TestScriptRequestModel class
Top
Properties
 | Name | Description
Public property | Arguments | Gets or sets the arguments.
Public property | InteractionMode | Gets or sets the interaction mode.
Public property | ScriptPath | Gets or sets the script path.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


TestScriptRequestModel Constructor

TestScriptRequestModel Constructor
Initializes a new instance of the TestScriptRequestModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TestScriptRequestModel()
Public Sub New
public:
TestScriptRequestModel()
new : unit -> TestScriptRequestModel
See Also

Reference

TestScriptRequestModel Class


TestScriptRequestModel Properties

TestScriptRequestModel Properties

The TestScriptRequestModel type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets or sets the arguments.
Public property | InteractionMode | Gets or sets the interaction mode.
Public property | ScriptPath | Gets or sets the script path.
Top
See Also

Reference

TestScriptRequestModel Class


TestScriptRequestModel.Arguments Property

TestScriptRequestModelArguments Property
Gets or sets the arguments.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Arguments { get; set; }
Public Property Arguments As String
    Get
    Set
public:
property String^ Arguments {
    String^ get ();
    void set (String^ value);
}
member Arguments : string with get, set

Property Value

Type: String
The arguments.
See Also

Reference

TestScriptRequestModel Class


TestScriptRequestModel.InteractionMode Property

TestScriptRequestModelInteractionMode Property
Gets or sets the interaction mode.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DesktopInteractionMode InteractionMode { get; set; }
Public Property InteractionMode As DesktopInteractionMode
    Get
    Set
public:
property DesktopInteractionMode InteractionMode {
    DesktopInteractionMode get ();
    void set (DesktopInteractionMode value);
}
member InteractionMode : DesktopInteractionMode with get, set

Property Value

Type: DesktopInteractionMode
The interaction mode.
See Also

Reference

TestScriptRequestModel Class


TestScriptRequestModel.ScriptPath Property

TestScriptRequestModelScriptPath Property
Gets or sets the script path.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ScriptPath { get; set; }
Public Property ScriptPath As String
    Get
    Set
public:
property String^ ScriptPath {
    String^ get ();
    void set (String^ value);
}
member ScriptPath : string with get, set

Property Value

Type: String
The script path.
See Also

Reference

TestScriptRequestModel Class


TestScriptRequestModel Methods

TestScriptRequestModel Methods

The TestScriptRequestModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TestScriptRequestModel Class


TimesClassModel Class

TimesClassModel Class
Time at various points of the failover.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsTimesClassModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class TimesClassModel
Public NotInheritable Class TimesClassModel
public ref class TimesClassModel sealed
[<SealedAttribute>]
type TimesClassModel =  class end

The TimesClassModel type exposes the following members.

Constructors
 | Name | Description
Public method | TimesClassModel | Initializes a new instance of the TimesClassModel class
Top
Properties
 | Name | Description
Public property | completed | Time that the failover is considered complete.
Public property | startProcessing | Time the failover processing started.
Public property | startReboot | Time when the reboot started. NOTE: For data only jobs, this time will be null.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


TimesClassModel Constructor

TimesClassModel Constructor
Initializes a new instance of the TimesClassModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TimesClassModel()
Public Sub New
public:
TimesClassModel()
new : unit -> TimesClassModel
See Also

Reference

TimesClassModel Class


TimesClassModel Properties

TimesClassModel Properties

The TimesClassModel type exposes the following members.

Properties
 | Name | Description
Public property | completed | Time that the failover is considered complete.
Public property | startProcessing | Time the failover processing started.
Public property | startReboot | Time when the reboot started. NOTE: For data only jobs, this time will be null.
Top
See Also

Reference

TimesClassModel Class


TimesClassModel.completed Property

TimesClassModelcompleted Property
Time that the failover is considered complete.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> completed { get; set; }
Public Property completed As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> completed {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member completed : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

TimesClassModel Class


TimesClassModel.startProcessing Property

TimesClassModelstartProcessing Property
Time the failover processing started.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime startProcessing { get; set; }
Public Property startProcessing As DateTime
    Get
    Set
public:
property DateTime startProcessing {
    DateTime get ();
    void set (DateTime value);
}
member startProcessing : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

TimesClassModel Class


TimesClassModel.startReboot Property

TimesClassModelstartReboot Property
Time when the reboot started. NOTE: For data only jobs, this time will be null.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> startReboot { get; set; }
Public Property startReboot As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> startReboot {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member startReboot : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

TimesClassModel Class


TimesClassModel Methods

TimesClassModel Methods

The TimesClassModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TimesClassModel Class


TimeWindowModel Class

TimeWindowModel Class
Time window model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsTimeWindowModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class TimeWindowModel
Public NotInheritable Class TimeWindowModel
public ref class TimeWindowModel sealed
[<SealedAttribute>]
type TimeWindowModel =  class end

The TimeWindowModel type exposes the following members.

Constructors
 | Name | Description
Public method | TimeWindowModel | Initializes a new instance of the TimeWindowModel class
Top
Properties
 | Name | Description
Public property | Duration | Gets or sets the duration.
Public property | Start | Gets or sets the start time.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


TimeWindowModel Constructor

TimeWindowModel Constructor
Initializes a new instance of the TimeWindowModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TimeWindowModel()
Public Sub New
public:
TimeWindowModel()
new : unit -> TimeWindowModel
See Also

Reference

TimeWindowModel Class


TimeWindowModel Properties

TimeWindowModel Properties

The TimeWindowModel type exposes the following members.

Properties
 | Name | Description
Public property | Duration | Gets or sets the duration.
Public property | Start | Gets or sets the start time.
Top
See Also

Reference

TimeWindowModel Class


TimeWindowModel.Duration Property

TimeWindowModelDuration Property
Gets or sets the duration.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Duration { get; set; }
Public Property Duration As TimeSpan
    Get
    Set
public:
property TimeSpan Duration {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Duration : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

TimeWindowModel Class


TimeWindowModel.Start Property

TimeWindowModelStart Property
Gets or sets the start time.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime Start { get; set; }
Public Property Start As DateTime
    Get
    Set
public:
property DateTime Start {
    DateTime get ();
    void set (DateTime value);
}
member Start : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

TimeWindowModel Class


TimeWindowModel Methods

TimeWindowModel Methods

The TimeWindowModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TimeWindowModel Class


TransmissionMode Enumeration

TransmissionMode Enumeration
Transmission mode.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum TransmissionMode
Public Enumeration TransmissionMode
public enum class TransmissionMode
type TransmissionMode
Members
Member name | Value | Description
Error | 0 | The error
Paused | 1 | The paused
Started | 2 | The started
Scheduled | 3 | The scheduled
Stopped | 4 | The stopped
Unknown | 5 | The unknown
See Also

Reference

DoubleTake.Web.Models Namespace


TransmissionScheduleModel Class

TransmissionScheduleModel Class
Transmission schedule model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsScheduleItemModel
DoubleTake.Web.ModelsTransmissionScheduleModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class TransmissionScheduleModel : ScheduleItemModel
Public NotInheritable Class TransmissionScheduleModel
    Inherits ScheduleItemModel
public ref class TransmissionScheduleModel sealed : public ScheduleItemModel
[<SealedAttribute>]
type TransmissionScheduleModel =
    class
        inherit ScheduleItemModel
    end

The TransmissionScheduleModel type exposes the following members.

Constructors
 | Name | Description
Public method | TransmissionScheduleModel | Initializes a new instance of the TransmissionScheduleModel class
Top
Properties
 | Name | Description
Public property | Duration | Gets or sets the duration.
Public property | Interval | Gets or sets the interval.
Public property | IsEnabled | Gets or sets a value indicating whether or not the item is enabled. (Inherited from ScheduleItemModel.)
Public property | MaxBytes | Gets or sets the maximum bytes.
Public property | StartTime | Gets or sets the start time.
Public property | ThresholdBytes | Gets or sets the threshold bytes.
Public property | ThresholdPercentage | Gets or sets the threshold as a percentage.
Public property | Window | Gets or sets the time window.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


TransmissionScheduleModel Constructor

TransmissionScheduleModel Constructor
Initializes a new instance of the TransmissionScheduleModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TransmissionScheduleModel()
Public Sub New
public:
TransmissionScheduleModel()
new : unit -> TransmissionScheduleModel
See Also

Reference

TransmissionScheduleModel Class


TransmissionScheduleModel Properties

TransmissionScheduleModel Properties

The TransmissionScheduleModel type exposes the following members.

Properties
 | Name | Description
Public property | Duration | Gets or sets the duration.
Public property | Interval | Gets or sets the interval.
Public property | IsEnabled | Gets or sets a value indicating whether or not the item is enabled. (Inherited from ScheduleItemModel.)
Public property | MaxBytes | Gets or sets the maximum bytes.
Public property | StartTime | Gets or sets the start time.
Public property | ThresholdBytes | Gets or sets the threshold bytes.
Public property | ThresholdPercentage | Gets or sets the threshold as a percentage.
Public property | Window | Gets or sets the time window.
Top
See Also

Reference

TransmissionScheduleModel Class


TransmissionScheduleModel.Duration Property

TransmissionScheduleModelDuration Property
Gets or sets the duration.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TimeSpan> Duration { get; set; }
Public Property Duration As Nullable(Of TimeSpan)
    Get
    Set
public:
property Nullable<TimeSpan> Duration {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
member Duration : Nullable<TimeSpan> with get, set

Property Value

Type: Nullable TimeSpan
See Also

Reference

TransmissionScheduleModel Class


TransmissionScheduleModel.Interval Property

TransmissionScheduleModelInterval Property
Gets or sets the interval.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<TimeSpan> Interval { get; set; }
Public Property Interval As Nullable(Of TimeSpan)
    Get
    Set
public:
property Nullable<TimeSpan> Interval {
    Nullable<TimeSpan> get ();
    void set (Nullable<TimeSpan> value);
}
member Interval : Nullable<TimeSpan> with get, set

Property Value

Type: Nullable TimeSpan
See Also

Reference

TransmissionScheduleModel Class


TransmissionScheduleModel.MaxBytes Property

TransmissionScheduleModelMaxBytes Property
Gets or sets the maximum bytes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<long> MaxBytes { get; set; }
Public Property MaxBytes As Nullable(Of Long)
    Get
    Set
public:
property Nullable<long long> MaxBytes {
    Nullable<long long> get ();
    void set (Nullable<long long> value);
}
member MaxBytes : Nullable<int64> with get, set

Property Value

Type: Nullable Int64
See Also

Reference

TransmissionScheduleModel Class


TransmissionScheduleModel.StartTime Property

TransmissionScheduleModelStartTime Property
Gets or sets the start time.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<DateTime> StartTime { get; set; }
Public Property StartTime As Nullable(Of DateTime)
    Get
    Set
public:
property Nullable<DateTime> StartTime {
    Nullable<DateTime> get ();
    void set (Nullable<DateTime> value);
}
member StartTime : Nullable<DateTime> with get, set

Property Value

Type: Nullable DateTime
See Also

Reference

TransmissionScheduleModel Class


TransmissionScheduleModel.ThresholdBytes Property

TransmissionScheduleModelThresholdBytes Property
Gets or sets the threshold bytes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<long> ThresholdBytes { get; set; }
Public Property ThresholdBytes As Nullable(Of Long)
    Get
    Set
public:
property Nullable<long long> ThresholdBytes {
    Nullable<long long> get ();
    void set (Nullable<long long> value);
}
member ThresholdBytes : Nullable<int64> with get, set

Property Value

Type: Nullable Int64
See Also

Reference

TransmissionScheduleModel Class


TransmissionScheduleModel.ThresholdPercentage Property

TransmissionScheduleModelThresholdPercentage Property
Gets or sets the threshold as a percentage.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<long> ThresholdPercentage { get; set; }
Public Property ThresholdPercentage As Nullable(Of Long)
    Get
    Set
public:
property Nullable<long long> ThresholdPercentage {
    Nullable<long long> get ();
    void set (Nullable<long long> value);
}
member ThresholdPercentage : Nullable<int64> with get, set

Property Value

Type: Nullable Int64
See Also

Reference

TransmissionScheduleModel Class


TransmissionScheduleModel.Window Property

TransmissionScheduleModelWindow Property
Gets or sets the time window.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TimeWindowModel Window { get; set; }
Public Property Window As TimeWindowModel
    Get
    Set
public:
property TimeWindowModel^ Window {
    TimeWindowModel^ get ();
    void set (TimeWindowModel^ value);
}
member Window : TimeWindowModel with get, set

Property Value

Type: TimeWindowModel
See Also

Reference

TransmissionScheduleModel Class


TransmissionScheduleModel Methods

TransmissionScheduleModel Methods

The TransmissionScheduleModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TransmissionScheduleModel Class


UnicastIPAddressModel Class

UnicastIPAddressModel Class
Unicast IP address model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsUnicastIPAddressModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class UnicastIPAddressModel
Public NotInheritable Class UnicastIPAddressModel
public ref class UnicastIPAddressModel sealed
[<SealedAttribute>]
type UnicastIPAddressModel =  class end

The UnicastIPAddressModel type exposes the following members.

Constructors
 | Name | Description
Public method | UnicastIPAddressModel | Initializes a new instance of the UnicastIPAddressModel class
Top
Properties
 | Name | Description
Public property | IPAddress | Gets or sets the IP address as a string.
Public property | IsDhcp | Gets or sets a value indicating whether this address is a DHCP-assigned address or not.
Public property | IsNat | Gets or sets a value indicating whether this address is a public NAT address or not.
Public property | IsOnline | Gets or sets a value indicating whether this Virtual address is online or not.
Public property | Mask | Gets or sets the IPv4 mask.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


UnicastIPAddressModel Constructor

UnicastIPAddressModel Constructor
Initializes a new instance of the UnicastIPAddressModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public UnicastIPAddressModel()
Public Sub New
public:
UnicastIPAddressModel()
new : unit -> UnicastIPAddressModel
See Also

Reference

UnicastIPAddressModel Class


UnicastIPAddressModel Properties

UnicastIPAddressModel Properties

The UnicastIPAddressModel type exposes the following members.

Properties
 | Name | Description
Public property | IPAddress | Gets or sets the IP address as a string.
Public property | IsDhcp | Gets or sets a value indicating whether this address is a DHCP-assigned address or not.
Public property | IsNat | Gets or sets a value indicating whether this address is a public NAT address or not.
Public property | IsOnline | Gets or sets a value indicating whether this Virtual address is online or not.
Public property | Mask | Gets or sets the IPv4 mask.
Top
See Also

Reference

UnicastIPAddressModel Class


UnicastIPAddressModel.IPAddress Property

UnicastIPAddressModelIPAddress Property
Gets or sets the IP address as a string.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string IPAddress { get; set; }
Public Property IPAddress As String
    Get
    Set
public:
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
member IPAddress : string with get, set

Property Value

Type: String
See Also

Reference

UnicastIPAddressModel Class


UnicastIPAddressModel.IsDhcp Property

UnicastIPAddressModelIsDhcp Property
Gets or sets a value indicating whether this address is a DHCP-assigned address or not.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDhcp { get; set; }
Public Property IsDhcp As Boolean
    Get
    Set
public:
property bool IsDhcp {
    bool get ();
    void set (bool value);
}
member IsDhcp : bool with get, set

Property Value

Type: Boolean
See Also

Reference

UnicastIPAddressModel Class


UnicastIPAddressModel.IsNat Property

UnicastIPAddressModelIsNat Property
Gets or sets a value indicating whether this address is a public NAT address or not.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsNat { get; set; }
Public Property IsNat As Boolean
    Get
    Set
public:
property bool IsNat {
    bool get ();
    void set (bool value);
}
member IsNat : bool with get, set

Property Value

Type: Boolean
See Also

Reference

UnicastIPAddressModel Class


UnicastIPAddressModel.IsOnline Property

UnicastIPAddressModelIsOnline Property
Gets or sets a value indicating whether this Virtual address is online or not.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsOnline { get; set; }
Public Property IsOnline As Boolean
    Get
    Set
public:
property bool IsOnline {
    bool get ();
    void set (bool value);
}
member IsOnline : bool with get, set

Property Value

Type: Boolean
See Also

Reference

UnicastIPAddressModel Class


UnicastIPAddressModel.Mask Property

UnicastIPAddressModelMask Property
Gets or sets the IPv4 mask.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Mask { get; set; }
Public Property Mask As String
    Get
    Set
public:
property String^ Mask {
    String^ get ();
    void set (String^ value);
}
member Mask : string with get, set

Property Value

Type: String
See Also

Reference

UnicastIPAddressModel Class


UnicastIPAddressModel Methods

UnicastIPAddressModel Methods

The UnicastIPAddressModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UnicastIPAddressModel Class


UnicastNetworkAddressInfoModel Class

UnicastNetworkAddressInfoModel Class
Unicast network address info model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsUnicastNetworkAddressInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class UnicastNetworkAddressInfoModel
Public NotInheritable Class UnicastNetworkAddressInfoModel
public ref class UnicastNetworkAddressInfoModel sealed
[<SealedAttribute>]
type UnicastNetworkAddressInfoModel =  class end

The UnicastNetworkAddressInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | UnicastNetworkAddressInfoModel | Initializes a new instance of the UnicastNetworkAddressInfoModel class
Top
Properties
 | Name | Description
Public property | IPAddress | Gets or sets the IP address.
Public property | IPv4Mask | Gets or sets the IPv4 mask.
Public property | IsDHCP | Gets or sets a value indicating whether this address is a DHCP-assigned address.
Public property | IsNAT | Gets or sets a value indicating whether this address is a public NAT address.
Public property | IsOnline | Gets or sets a value indicating whether this Virtual address is online.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


UnicastNetworkAddressInfoModel Constructor

UnicastNetworkAddressInfoModel Constructor
Initializes a new instance of the UnicastNetworkAddressInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public UnicastNetworkAddressInfoModel()
Public Sub New
public:
UnicastNetworkAddressInfoModel()
new : unit -> UnicastNetworkAddressInfoModel
See Also

Reference

UnicastNetworkAddressInfoModel Class


UnicastNetworkAddressInfoModel Properties

UnicastNetworkAddressInfoModel Properties

The UnicastNetworkAddressInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | IPAddress | Gets or sets the IP address.
Public property | IPv4Mask | Gets or sets the IPv4 mask.
Public property | IsDHCP | Gets or sets a value indicating whether this address is a DHCP-assigned address.
Public property | IsNAT | Gets or sets a value indicating whether this address is a public NAT address.
Public property | IsOnline | Gets or sets a value indicating whether this Virtual address is online.
Top
See Also

Reference

UnicastNetworkAddressInfoModel Class


UnicastNetworkAddressInfoModel.IPAddress Property

UnicastNetworkAddressInfoModelIPAddress Property
Gets or sets the IP address.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string IPAddress { get; set; }
Public Property IPAddress As String
    Get
    Set
public:
property String^ IPAddress {
    String^ get ();
    void set (String^ value);
}
member IPAddress : string with get, set

Property Value

Type: String
See Also

Reference

UnicastNetworkAddressInfoModel Class


UnicastNetworkAddressInfoModel.IPv4Mask Property

UnicastNetworkAddressInfoModelIPv4Mask Property
Gets or sets the IPv4 mask.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string IPv4Mask { get; set; }
Public Property IPv4Mask As String
    Get
    Set
public:
property String^ IPv4Mask {
    String^ get ();
    void set (String^ value);
}
member IPv4Mask : string with get, set

Property Value

Type: String
See Also

Reference

UnicastNetworkAddressInfoModel Class


UnicastNetworkAddressInfoModel.IsDHCP Property

UnicastNetworkAddressInfoModelIsDHCP Property
Gets or sets a value indicating whether this address is a DHCP-assigned address.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsDHCP { get; set; }
Public Property IsDHCP As Boolean
    Get
    Set
public:
property bool IsDHCP {
    bool get ();
    void set (bool value);
}
member IsDHCP : bool with get, set

Property Value

Type: Boolean
See Also

Reference

UnicastNetworkAddressInfoModel Class


UnicastNetworkAddressInfoModel.IsNAT Property

UnicastNetworkAddressInfoModelIsNAT Property
Gets or sets a value indicating whether this address is a public NAT address.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsNAT { get; set; }
Public Property IsNAT As Boolean
    Get
    Set
public:
property bool IsNAT {
    bool get ();
    void set (bool value);
}
member IsNAT : bool with get, set

Property Value

Type: Boolean
See Also

Reference

UnicastNetworkAddressInfoModel Class


UnicastNetworkAddressInfoModel.IsOnline Property

UnicastNetworkAddressInfoModelIsOnline Property
Gets or sets a value indicating whether this Virtual address is online.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsOnline { get; set; }
Public Property IsOnline As Boolean
    Get
    Set
public:
property bool IsOnline {
    bool get ();
    void set (bool value);
}
member IsOnline : bool with get, set

Property Value

Type: Boolean
See Also

Reference

UnicastNetworkAddressInfoModel Class


UnicastNetworkAddressInfoModel Methods

UnicastNetworkAddressInfoModel Methods

The UnicastNetworkAddressInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UnicastNetworkAddressInfoModel Class


UnmanagedConnectionOptionsModel Class

UnmanagedConnectionOptionsModel Class
Unmanaged connection options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsUnmanagedConnectionOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class UnmanagedConnectionOptionsModel
Public NotInheritable Class UnmanagedConnectionOptionsModel
public ref class UnmanagedConnectionOptionsModel sealed
[<SealedAttribute>]
type UnmanagedConnectionOptionsModel =  class end

The UnmanagedConnectionOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | UnmanagedConnectionOptionsModel | Initializes a new instance of the UnmanagedConnectionOptionsModel class
Top
Properties
 | Name | Description
Public property | TargetStateInfo | Gets or sets the target state information for this connection.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


UnmanagedConnectionOptionsModel Constructor

UnmanagedConnectionOptionsModel Constructor
Initializes a new instance of the UnmanagedConnectionOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public UnmanagedConnectionOptionsModel()
Public Sub New
public:
UnmanagedConnectionOptionsModel()
new : unit -> UnmanagedConnectionOptionsModel
See Also

Reference

UnmanagedConnectionOptionsModel Class


UnmanagedConnectionOptionsModel Properties

UnmanagedConnectionOptionsModel Properties

The UnmanagedConnectionOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | TargetStateInfo | Gets or sets the target state information for this connection.
Top
See Also

Reference

UnmanagedConnectionOptionsModel Class


UnmanagedConnectionOptionsModel.TargetStateInfo Property

UnmanagedConnectionOptionsModelTargetStateInfo Property
Gets or sets the target state information for this connection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TargetStateInfoModel TargetStateInfo { get; set; }
Public Property TargetStateInfo As TargetStateInfoModel
    Get
    Set
public:
property TargetStateInfoModel^ TargetStateInfo {
    TargetStateInfoModel^ get ();
    void set (TargetStateInfoModel^ value);
}
member TargetStateInfo : TargetStateInfoModel with get, set

Property Value

Type: TargetStateInfoModel
See Also

Reference

UnmanagedConnectionOptionsModel Class


UnmanagedConnectionOptionsModel Methods

UnmanagedConnectionOptionsModel Methods

The UnmanagedConnectionOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UnmanagedConnectionOptionsModel Class


UpdateCredentialsModel Class

UpdateCredentialsModel Class
Information required to update the credentials for a job
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsUpdateCredentialsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class UpdateCredentialsModel
Public NotInheritable Class UpdateCredentialsModel
public ref class UpdateCredentialsModel sealed
[<SealedAttribute>]
type UpdateCredentialsModel =  class end

The UpdateCredentialsModel type exposes the following members.

Constructors
 | Name | Description
Public method | UpdateCredentialsModel | Initializes a new instance of the UpdateCredentialsModel class
Top
Properties
 | Name | Description
Public property | JobCredentials | Gets or sets the job credentials.
Public property | JobOptions | Gets or sets the job options.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


UpdateCredentialsModel Constructor

UpdateCredentialsModel Constructor
Initializes a new instance of the UpdateCredentialsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public UpdateCredentialsModel()
Public Sub New
public:
UpdateCredentialsModel()
new : unit -> UpdateCredentialsModel
See Also

Reference

UpdateCredentialsModel Class


UpdateCredentialsModel Properties

UpdateCredentialsModel Properties

The UpdateCredentialsModel type exposes the following members.

Properties
 | Name | Description
Public property | JobCredentials | Gets or sets the job credentials.
Public property | JobOptions | Gets or sets the job options.
Top
See Also

Reference

UpdateCredentialsModel Class


UpdateCredentialsModel.JobCredentials Property

UpdateCredentialsModelJobCredentials Property
Gets or sets the job credentials.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public JobCredentialsModel JobCredentials { get; set; }
Public Property JobCredentials As JobCredentialsModel
    Get
    Set
public:
property JobCredentialsModel^ JobCredentials {
    JobCredentialsModel^ get ();
    void set (JobCredentialsModel^ value);
}
member JobCredentials : JobCredentialsModel with get, set

Property Value

Type: JobCredentialsModel
The job credentials.
See Also

Reference

UpdateCredentialsModel Class


UpdateCredentialsModel.JobOptions Property

UpdateCredentialsModelJobOptions Property
Gets or sets the job options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public JobOptionsModel JobOptions { get; set; }
Public Property JobOptions As JobOptionsModel
    Get
    Set
public:
property JobOptionsModel^ JobOptions {
    JobOptionsModel^ get ();
    void set (JobOptionsModel^ value);
}
member JobOptions : JobOptionsModel with get, set

Property Value

Type: JobOptionsModel
The job options.
See Also

Reference

UpdateCredentialsModel Class


UpdateCredentialsModel Methods

UpdateCredentialsModel Methods

The UpdateCredentialsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdateCredentialsModel Class


UpdateRecommendedJobOptionsRequestModel Class

UpdateRecommendedJobOptionsRequestModel Class
Update recommended job options request model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsUpdateRecommendedJobOptionsRequestModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class UpdateRecommendedJobOptionsRequestModel
Public NotInheritable Class UpdateRecommendedJobOptionsRequestModel
public ref class UpdateRecommendedJobOptionsRequestModel sealed
[<SealedAttribute>]
type UpdateRecommendedJobOptionsRequestModel =  class end

The UpdateRecommendedJobOptionsRequestModel type exposes the following members.

Constructors
 | Name | Description
Public method | UpdateRecommendedJobOptionsRequestModel | Initializes a new instance of the UpdateRecommendedJobOptionsRequestModel class
Top
Properties
 | Name | Description
Public property | CandidateOptions | Gets or sets the candidate options.
Public property | Workload | Gets or sets the workload.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


UpdateRecommendedJobOptionsRequestModel Constructor

UpdateRecommendedJobOptionsRequestModel Constructor
Initializes a new instance of the UpdateRecommendedJobOptionsRequestModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public UpdateRecommendedJobOptionsRequestModel()
Public Sub New
public:
UpdateRecommendedJobOptionsRequestModel()
new : unit -> UpdateRecommendedJobOptionsRequestModel
See Also

Reference

UpdateRecommendedJobOptionsRequestModel Class


UpdateRecommendedJobOptionsRequestModel Properties

UpdateRecommendedJobOptionsRequestModel Properties

The UpdateRecommendedJobOptionsRequestModel type exposes the following members.

Properties
 | Name | Description
Public property | CandidateOptions | Gets or sets the candidate options.
Public property | Workload | Gets or sets the workload.
Top
See Also

Reference

UpdateRecommendedJobOptionsRequestModel Class


UpdateRecommendedJobOptionsRequestModel.CandidateOptions Property

UpdateRecommendedJobOptionsRequestModelCandidateOptions Property
Gets or sets the candidate options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public JobOptionsModel CandidateOptions { get; set; }
Public Property CandidateOptions As JobOptionsModel
    Get
    Set
public:
property JobOptionsModel^ CandidateOptions {
    JobOptionsModel^ get ();
    void set (JobOptionsModel^ value);
}
member CandidateOptions : JobOptionsModel with get, set

Property Value

Type: JobOptionsModel
The candidate options.
See Also

Reference

UpdateRecommendedJobOptionsRequestModel Class


UpdateRecommendedJobOptionsRequestModel.Workload Property

UpdateRecommendedJobOptionsRequestModelWorkload Property
Gets or sets the workload.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public WorkloadModel Workload { get; set; }
Public Property Workload As WorkloadModel
    Get
    Set
public:
property WorkloadModel^ Workload {
    WorkloadModel^ get ();
    void set (WorkloadModel^ value);
}
member Workload : WorkloadModel with get, set

Property Value

Type: WorkloadModel
The workload.
See Also

Reference

UpdateRecommendedJobOptionsRequestModel Class


UpdateRecommendedJobOptionsRequestModel Methods

UpdateRecommendedJobOptionsRequestModel Methods

The UpdateRecommendedJobOptionsRequestModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UpdateRecommendedJobOptionsRequestModel Class


UsageDataModel Class

UsageDataModel Class
Usage data.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsUsageDataModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class UsageDataModel
Public Class UsageDataModel
public ref class UsageDataModel
type UsageDataModel =  class end

The UsageDataModel type exposes the following members.

Constructors
 | Name | Description
Public method | UsageDataModel | Initializes a new instance of the UsageDataModel class
Top
Properties
 | Name | Description
Public property | Data | Gets or sets the data.
Public property | NextCollectionTime | Gets or sets the next collection time.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


UsageDataModel Constructor

UsageDataModel Constructor
Initializes a new instance of the UsageDataModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public UsageDataModel()
Public Sub New
public:
UsageDataModel()
new : unit -> UsageDataModel
See Also

Reference

UsageDataModel Class


UsageDataModel Properties

UsageDataModel Properties

The UsageDataModel type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets or sets the data.
Public property | NextCollectionTime | Gets or sets the next collection time.
Top
See Also

Reference

UsageDataModel Class


UsageDataModel.Data Property

UsageDataModelData Property
Gets or sets the data.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public List<JobUsageDataModel> Data { get; set; }
Public Property Data As List(Of JobUsageDataModel)
    Get
    Set
public:
property List<JobUsageDataModel^>^ Data {
    List<JobUsageDataModel^>^ get ();
    void set (List<JobUsageDataModel^>^ value);
}
member Data : List<JobUsageDataModel> with get, set

Property Value

Type: List JobUsageDataModel
The data.
See Also

Reference

UsageDataModel Class


UsageDataModel.NextCollectionTime Property

UsageDataModelNextCollectionTime Property
Gets or sets the next collection time.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DateTimeOffset NextCollectionTime { get; set; }
Public Property NextCollectionTime As DateTimeOffset
    Get
    Set
public:
property DateTimeOffset NextCollectionTime {
    DateTimeOffset get ();
    void set (DateTimeOffset value);
}
member NextCollectionTime : DateTimeOffset with get, set

Property Value

Type: DateTimeOffset
The next collection time.
See Also

Reference

UsageDataModel Class


UsageDataModel Methods

UsageDataModel Methods

The UsageDataModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UsageDataModel Class


UVRAPersistedStateModel Class

UVRAPersistedStateModel Class
UVRA persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsUVRAPersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class UVRAPersistedStateModel
Public NotInheritable Class UVRAPersistedStateModel
public ref class UVRAPersistedStateModel sealed
[<SealedAttribute>]
type UVRAPersistedStateModel =  class end

The UVRAPersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | UVRAPersistedStateModel | Initializes a new instance of the UVRAPersistedStateModel class
Top
Properties
 | Name | Description
Public property | FailoverTime | Gets or sets the failover time.
Public property | ReplicaNics | Gets or sets the replica nics. This info has extra fields to remember where each nic is on the replica.
Public property | SourceISCSIChapPassword | Gets or sets the iSCSI CHAP password used in mapping the source disk.
Public property | SourceISCSIChapUsername | Gets or sets the iSCSI CHAP username used in mapping the source disk.
Public property | SourceISCSITargetName | Gets or sets the iSCSI target name name used in mapping the source disk.
Public property | SourceMachineInfo | Gets or sets the machine info.
Public property | StartTime | Gets or sets the Time the job was started.
Public property | State | Gets or sets the state.
Public property | StopTime | Gets or sets the Time the job was stopped.
Public property | VolumePersistedState | Gets or sets the volume persisted state.
Public property | VRAVirtualizationConnectionInfo | Gets or sets the VRA engine connection info.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


UVRAPersistedStateModel Constructor

UVRAPersistedStateModel Constructor
Initializes a new instance of the UVRAPersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public UVRAPersistedStateModel()
Public Sub New
public:
UVRAPersistedStateModel()
new : unit -> UVRAPersistedStateModel
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel Properties

UVRAPersistedStateModel Properties

The UVRAPersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | FailoverTime | Gets or sets the failover time.
Public property | ReplicaNics | Gets or sets the replica nics. This info has extra fields to remember where each nic is on the replica.
Public property | SourceISCSIChapPassword | Gets or sets the iSCSI CHAP password used in mapping the source disk.
Public property | SourceISCSIChapUsername | Gets or sets the iSCSI CHAP username used in mapping the source disk.
Public property | SourceISCSITargetName | Gets or sets the iSCSI target name name used in mapping the source disk.
Public property | SourceMachineInfo | Gets or sets the machine info.
Public property | StartTime | Gets or sets the Time the job was started.
Public property | State | Gets or sets the state.
Public property | StopTime | Gets or sets the Time the job was stopped.
Public property | VolumePersistedState | Gets or sets the volume persisted state.
Public property | VRAVirtualizationConnectionInfo | Gets or sets the VRA engine connection info.
Top
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel.FailoverTime Property

UVRAPersistedStateModelFailoverTime Property
Gets or sets the failover time.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DateTime FailoverTime { get; set; }
Public Property FailoverTime As DateTime
    Get
    Set
public:
property DateTime FailoverTime {
    DateTime get ();
    void set (DateTime value);
}
member FailoverTime : DateTime with get, set

Property Value

Type: DateTime
The failover time.
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel.ReplicaNics Property

UVRAPersistedStateModelReplicaNics Property
Gets or sets the replica nics. This info has extra fields to remember where each nic is on the replica.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VRAInternalVirtualNetworkInterfaceInfoModel[] ReplicaNics { get; set; }
Public Property ReplicaNics As VRAInternalVirtualNetworkInterfaceInfoModel()
    Get
    Set
public:
property array<VRAInternalVirtualNetworkInterfaceInfoModel^>^ ReplicaNics {
    array<VRAInternalVirtualNetworkInterfaceInfoModel^>^ get ();
    void set (array<VRAInternalVirtualNetworkInterfaceInfoModel^>^ value);
}
member ReplicaNics : VRAInternalVirtualNetworkInterfaceInfoModel[] with get, set

Property Value

Type: VRAInternalVirtualNetworkInterfaceInfoModel
The replica nics.
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel.SourceISCSIChapPassword Property

UVRAPersistedStateModelSourceISCSIChapPassword Property
Gets or sets the iSCSI CHAP password used in mapping the source disk.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SourceISCSIChapPassword { get; set; }
Public Property SourceISCSIChapPassword As String
    Get
    Set
public:
property String^ SourceISCSIChapPassword {
    String^ get ();
    void set (String^ value);
}
member SourceISCSIChapPassword : string with get, set

Property Value

Type: String
The replica appliance SCSI bus.
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel.SourceISCSIChapUsername Property

UVRAPersistedStateModelSourceISCSIChapUsername Property
Gets or sets the iSCSI CHAP username used in mapping the source disk.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SourceISCSIChapUsername { get; set; }
Public Property SourceISCSIChapUsername As String
    Get
    Set
public:
property String^ SourceISCSIChapUsername {
    String^ get ();
    void set (String^ value);
}
member SourceISCSIChapUsername : string with get, set

Property Value

Type: String
The replica appliance SCSI bus.
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel.SourceISCSITargetName Property

UVRAPersistedStateModelSourceISCSITargetName Property
Gets or sets the iSCSI target name name used in mapping the source disk.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SourceISCSITargetName { get; set; }
Public Property SourceISCSITargetName As String
    Get
    Set
public:
property String^ SourceISCSITargetName {
    String^ get ();
    void set (String^ value);
}
member SourceISCSITargetName : string with get, set

Property Value

Type: String
The replica appliance SCSI bus.
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel.SourceMachineInfo Property

UVRAPersistedStateModelSourceMachineInfo Property
Gets or sets the machine info.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public MachineInfoModel SourceMachineInfo { get; set; }
Public Property SourceMachineInfo As MachineInfoModel
    Get
    Set
public:
property MachineInfoModel^ SourceMachineInfo {
    MachineInfoModel^ get ();
    void set (MachineInfoModel^ value);
}
member SourceMachineInfo : MachineInfoModel with get, set

Property Value

Type: MachineInfoModel
The machine info.
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel.StartTime Property

UVRAPersistedStateModelStartTime Property
Gets or sets the Time the job was started.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
member StartTime : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel.State Property

UVRAPersistedStateModelState Property
Gets or sets the state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public JobStateModel State { get; set; }
Public Property State As JobStateModel
    Get
    Set
public:
property JobStateModel^ State {
    JobStateModel^ get ();
    void set (JobStateModel^ value);
}
member State : JobStateModel with get, set

Property Value

Type: JobStateModel
The state.
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel.StopTime Property

UVRAPersistedStateModelStopTime Property
Gets or sets the Time the job was stopped.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public DateTime StopTime { get; set; }
Public Property StopTime As DateTime
    Get
    Set
public:
property DateTime StopTime {
    DateTime get ();
    void set (DateTime value);
}
member StopTime : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel.VolumePersistedState Property

UVRAPersistedStateModelVolumePersistedState Property
Gets or sets the volume persisted state.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public UVRAVolumePersistedStateModel[] VolumePersistedState { get; set; }
Public Property VolumePersistedState As UVRAVolumePersistedStateModel()
    Get
    Set
public:
property array<UVRAVolumePersistedStateModel^>^ VolumePersistedState {
    array<UVRAVolumePersistedStateModel^>^ get ();
    void set (array<UVRAVolumePersistedStateModel^>^ value);
}
member VolumePersistedState : UVRAVolumePersistedStateModel[] with get, set

Property Value

Type: UVRAVolumePersistedStateModel
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel.VRAVirtualizationConnectionInfo Property

UVRAPersistedStateModelVRAVirtualizationConnectionInfo Property
Gets or sets the VRA engine connection info.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VirtualizationConnectionInfoModel VRAVirtualizationConnectionInfo { get; set; }
Public Property VRAVirtualizationConnectionInfo As VirtualizationConnectionInfoModel
    Get
    Set
public:
property VirtualizationConnectionInfoModel^ VRAVirtualizationConnectionInfo {
    VirtualizationConnectionInfoModel^ get ();
    void set (VirtualizationConnectionInfoModel^ value);
}
member VRAVirtualizationConnectionInfo : VirtualizationConnectionInfoModel with get, set

Property Value

Type: VirtualizationConnectionInfoModel
The VRA engine connection info.
See Also

Reference

UVRAPersistedStateModel Class


UVRAPersistedStateModel Methods

UVRAPersistedStateModel Methods

The UVRAPersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UVRAPersistedStateModel Class


UVRAVolumePersistedStateModel Class

UVRAVolumePersistedStateModel Class
UVRA volume persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsProtectableItemModel
DoubleTake.Web.ModelsPhysicalItemModel
DoubleTake.Web.ModelsVolumeModel
DoubleTake.Web.ModelsVolumeOptionsModel
DoubleTake.Web.ModelsUVRAVolumePersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class UVRAVolumePersistedStateModel : VolumeOptionsModel
Public NotInheritable Class UVRAVolumePersistedStateModel
    Inherits VolumeOptionsModel
public ref class UVRAVolumePersistedStateModel sealed : public VolumeOptionsModel
[<SealedAttribute>]
type UVRAVolumePersistedStateModel =
    class
        inherit VolumeOptionsModel
    end

The UVRAVolumePersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | UVRAVolumePersistedStateModel | Initializes a new instance of the UVRAVolumePersistedStateModel class
Top
Properties
 | Name | Description
Public property | ApplianceSCSIBus | Gets or sets the SCSI bus number the volume has on the replica appliance.
Public property | ApplianceSCSIUnitNumber | Gets or sets the SCSI unit number the volume has on the replica appliance.
Public property | Attributes | Gets or sets a value specifying the file system attributes of this item. (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | Gets or sets the available free space on this volume. (Inherited from PhysicalItemModel.)
Public property | ClassName | Gets or sets the class name. (Inherited from PhysicalItemModel.)
Public property | CreationTime | Gets or sets a value specifying the time this item was created. (Inherited from PhysicalItemModel.)
Public property | DesiredSize | Gets or sets the size that the user wants the drive to be. (Inherited from VolumeOptionsModel.)
Public property | DeviceID | Gets or sets the device ID the volume has on the replica appliance
Public property | DiskControllerType | Gets or sets the type of the disk controller. (Inherited from VolumeOptionsModel.)
Public property | DiskProvisioningType | Gets or sets the type of the disk provisioning. (Inherited from VolumeOptionsModel.)
Public property | DriveFormat | Gets or sets the format of the drive. (Inherited from PhysicalItemModel.)
Public property | DriveIndex | Gets or sets the index of the drive the volume has on the replica appliance
Public property | DriveName | Gets or sets the name of the drive on the helper (\\.\PHYSICALDRIVEX)
Public property | DriveType | Gets or sets the type of the drive. (Inherited from PhysicalItemModel.)
Public property | Id | Gets or sets the item identifier. (Inherited from ProtectableItemModel.)
Public property | IsContainer | Gets or sets a value indicating whether or not this item is a container of other items. (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | Gets or sets a value indicating whether or not this item is read only; that is, its Saturation cannot be changed. (Inherited from ProtectableItemModel.)
Public property | IsSupported | Gets or sets a value indicating whether this volume is supported. (Inherited from PhysicalItemModel.)
Public property | IsSystemDrive | Gets or sets a value indicating whether or not this volume is the system drive. (Inherited from PhysicalItemModel.)
Public property | ItemType | Gets or sets the type of this item. (Inherited from ProtectableItemModel.)
Public property | Label | Gets or sets the volume label. (Inherited from PhysicalItemModel.)
Public property | LastAccessTime | Gets or sets a value specifying the time this item was last accessed. (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | Gets or sets a value specifying the time this item was last written to. (Inherited from PhysicalItemModel.)
Public property | Metadata | Gets or sets a value specifying additional meta data for this item. (Inherited from PhysicalItemModel.)
Public property | MountPoint | Gets or sets the mount point.
Public property | Name | Gets or sets the name of this item. (Inherited from ProtectableItemModel.)
Public property | OriginalPath | Gets or sets the path where the volume was stored on the source host.
Public property | PartitionName | Gets or sets the partition name. (Inherited from ProtectableItemModel.)
Public property | Path | Gets or sets the path that uniquely identifies this item. (Inherited from ProtectableItemModel.)
Public property | PNPDeviceID | Gets or sets the PNP device ID.
Public property | PreexistingDiskPath | Gets or sets the path of preexisting disk. (Inherited from VolumeOptionsModel.)
Public property | ReplicaVmSCSIBus | Gets or sets the SCSI bus number the volume has on the replica Vm.
Public property | ReplicaVmSCSIUnitNumber | Gets or sets the SCSI unit number the volume has on the replica Vm.
Public property | ReverseVolumeSignature | Gets or sets the reverse volume signature. This represents the signature of the volume on the Source.
Public property | Saturation | Gets or sets the saturation level of this item. (Inherited from ProtectableItemModel.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume. (Inherited from PhysicalItemModel.)
Public property | Size | Gets or sets a value indicating the physical size of the item. (Inherited from PhysicalItemModel.)
Public property | SourceISCSIBus | Gets or sets the iSCSI bus number used in mapping the source disk.
Public property | SourceISCSIUnitNumber | Gets or sets the iSCSI unit number used in mapping the source disk.
Public property | TotalSize | Gets or sets the total size of the volume. (Inherited from PhysicalItemModel.)
Public property | VirtualDiskFilename | Gets or sets the filename for the virtual disk.
Public property | VirtualDiskPath | Gets or sets the path on the host where the volume should be stored. (Inherited from VolumeOptionsModel.)
Public property | VolumeName | Gets or sets the name of the volume.
Public property | VolumeSignature | Gets or sets the volume signature. (Inherited from VolumeOptionsModel.)
Public property | VolumeType | Gets or sets the volume type. (Inherited from PhysicalItemModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsVolumeOptionsModel


UVRAVolumePersistedStateModel Constructor

UVRAVolumePersistedStateModel Constructor
Initializes a new instance of the UVRAVolumePersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public UVRAVolumePersistedStateModel()
Public Sub New
public:
UVRAVolumePersistedStateModel()
new : unit -> UVRAVolumePersistedStateModel
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel Properties

UVRAVolumePersistedStateModel Properties

The UVRAVolumePersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | ApplianceSCSIBus | Gets or sets the SCSI bus number the volume has on the replica appliance.
Public property | ApplianceSCSIUnitNumber | Gets or sets the SCSI unit number the volume has on the replica appliance.
Public property | Attributes | Gets or sets a value specifying the file system attributes of this item. (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | Gets or sets the available free space on this volume. (Inherited from PhysicalItemModel.)
Public property | ClassName | Gets or sets the class name. (Inherited from PhysicalItemModel.)
Public property | CreationTime | Gets or sets a value specifying the time this item was created. (Inherited from PhysicalItemModel.)
Public property | DesiredSize | Gets or sets the size that the user wants the drive to be. (Inherited from VolumeOptionsModel.)
Public property | DeviceID | Gets or sets the device ID the volume has on the replica appliance
Public property | DiskControllerType | Gets or sets the type of the disk controller. (Inherited from VolumeOptionsModel.)
Public property | DiskProvisioningType | Gets or sets the type of the disk provisioning. (Inherited from VolumeOptionsModel.)
Public property | DriveFormat | Gets or sets the format of the drive. (Inherited from PhysicalItemModel.)
Public property | DriveIndex | Gets or sets the index of the drive the volume has on the replica appliance
Public property | DriveName | Gets or sets the name of the drive on the helper (\\.\PHYSICALDRIVEX)
Public property | DriveType | Gets or sets the type of the drive. (Inherited from PhysicalItemModel.)
Public property | Id | Gets or sets the item identifier. (Inherited from ProtectableItemModel.)
Public property | IsContainer | Gets or sets a value indicating whether or not this item is a container of other items. (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | Gets or sets a value indicating whether or not this item is read only; that is, its Saturation cannot be changed. (Inherited from ProtectableItemModel.)
Public property | IsSupported | Gets or sets a value indicating whether this volume is supported. (Inherited from PhysicalItemModel.)
Public property | IsSystemDrive | Gets or sets a value indicating whether or not this volume is the system drive. (Inherited from PhysicalItemModel.)
Public property | ItemType | Gets or sets the type of this item. (Inherited from ProtectableItemModel.)
Public property | Label | Gets or sets the volume label. (Inherited from PhysicalItemModel.)
Public property | LastAccessTime | Gets or sets a value specifying the time this item was last accessed. (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | Gets or sets a value specifying the time this item was last written to. (Inherited from PhysicalItemModel.)
Public property | Metadata | Gets or sets a value specifying additional meta data for this item. (Inherited from PhysicalItemModel.)
Public property | MountPoint | Gets or sets the mount point.
Public property | Name | Gets or sets the name of this item. (Inherited from ProtectableItemModel.)
Public property | OriginalPath | Gets or sets the path where the volume was stored on the source host.
Public property | PartitionName | Gets or sets the partition name. (Inherited from ProtectableItemModel.)
Public property | Path | Gets or sets the path that uniquely identifies this item. (Inherited from ProtectableItemModel.)
Public property | PNPDeviceID | Gets or sets the PNP device ID.
Public property | PreexistingDiskPath | Gets or sets the path of preexisting disk. (Inherited from VolumeOptionsModel.)
Public property | ReplicaVmSCSIBus | Gets or sets the SCSI bus number the volume has on the replica Vm.
Public property | ReplicaVmSCSIUnitNumber | Gets or sets the SCSI unit number the volume has on the replica Vm.
Public property | ReverseVolumeSignature | Gets or sets the reverse volume signature. This represents the signature of the volume on the Source.
Public property | Saturation | Gets or sets the saturation level of this item. (Inherited from ProtectableItemModel.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume. (Inherited from PhysicalItemModel.)
Public property | Size | Gets or sets a value indicating the physical size of the item. (Inherited from PhysicalItemModel.)
Public property | SourceISCSIBus | Gets or sets the iSCSI bus number used in mapping the source disk.
Public property | SourceISCSIUnitNumber | Gets or sets the iSCSI unit number used in mapping the source disk.
Public property | TotalSize | Gets or sets the total size of the volume. (Inherited from PhysicalItemModel.)
Public property | VirtualDiskFilename | Gets or sets the filename for the virtual disk.
Public property | VirtualDiskPath | Gets or sets the path on the host where the volume should be stored. (Inherited from VolumeOptionsModel.)
Public property | VolumeName | Gets or sets the name of the volume.
Public property | VolumeSignature | Gets or sets the volume signature. (Inherited from VolumeOptionsModel.)
Public property | VolumeType | Gets or sets the volume type. (Inherited from PhysicalItemModel.)
Top
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.ApplianceSCSIBus Property

UVRAVolumePersistedStateModelApplianceSCSIBus Property
Gets or sets the SCSI bus number the volume has on the replica appliance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int ApplianceSCSIBus { get; set; }
Public Property ApplianceSCSIBus As Integer
    Get
    Set
public:
property int ApplianceSCSIBus {
    int get ();
    void set (int value);
}
member ApplianceSCSIBus : int with get, set

Property Value

Type: Int32
The replica appliance SCSI bus.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.ApplianceSCSIUnitNumber Property

UVRAVolumePersistedStateModelApplianceSCSIUnitNumber Property
Gets or sets the SCSI unit number the volume has on the replica appliance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int ApplianceSCSIUnitNumber { get; set; }
Public Property ApplianceSCSIUnitNumber As Integer
    Get
    Set
public:
property int ApplianceSCSIUnitNumber {
    int get ();
    void set (int value);
}
member ApplianceSCSIUnitNumber : int with get, set

Property Value

Type: Int32
The replica appliance SCSI unit number.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.DeviceID Property

UVRAVolumePersistedStateModelDeviceID Property
Gets or sets the device ID the volume has on the replica appliance

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string DeviceID { get; set; }
Public Property DeviceID As String
    Get
    Set
public:
property String^ DeviceID {
    String^ get ();
    void set (String^ value);
}
member DeviceID : string with get, set

Property Value

Type: String
The device ID.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.DriveIndex Property

UVRAVolumePersistedStateModelDriveIndex Property
Gets or sets the index of the drive the volume has on the replica appliance

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int DriveIndex { get; set; }
Public Property DriveIndex As Integer
    Get
    Set
public:
property int DriveIndex {
    int get ();
    void set (int value);
}
member DriveIndex : int with get, set

Property Value

Type: Int32
The index of the drive.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.DriveName Property

UVRAVolumePersistedStateModelDriveName Property
Gets or sets the name of the drive on the helper (\\.\PHYSICALDRIVEX)

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string DriveName { get; set; }
Public Property DriveName As String
    Get
    Set
public:
property String^ DriveName {
    String^ get ();
    void set (String^ value);
}
member DriveName : string with get, set

Property Value

Type: String
The index of the drive.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.MountPoint Property

UVRAVolumePersistedStateModelMountPoint Property
Gets or sets the mount point.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string MountPoint { get; set; }
Public Property MountPoint As String
    Get
    Set
public:
property String^ MountPoint {
    String^ get ();
    void set (String^ value);
}
member MountPoint : string with get, set

Property Value

Type: String
The mount point.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.OriginalPath Property

UVRAVolumePersistedStateModelOriginalPath Property
Gets or sets the path where the volume was stored on the source host.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string OriginalPath { get; set; }
Public Property OriginalPath As String
    Get
    Set
public:
property String^ OriginalPath {
    String^ get ();
    void set (String^ value);
}
member OriginalPath : string with get, set

Property Value

Type: String
The original path.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.PNPDeviceID Property

UVRAVolumePersistedStateModelPNPDeviceID Property
Gets or sets the PNP device ID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string PNPDeviceID { get; set; }
Public Property PNPDeviceID As String
    Get
    Set
public:
property String^ PNPDeviceID {
    String^ get ();
    void set (String^ value);
}
member PNPDeviceID : string with get, set

Property Value

Type: String
The PNP device ID.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.ReplicaVmSCSIBus Property

UVRAVolumePersistedStateModelReplicaVmSCSIBus Property
Gets or sets the SCSI bus number the volume has on the replica Vm.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int ReplicaVmSCSIBus { get; set; }
Public Property ReplicaVmSCSIBus As Integer
    Get
    Set
public:
property int ReplicaVmSCSIBus {
    int get ();
    void set (int value);
}
member ReplicaVmSCSIBus : int with get, set

Property Value

Type: Int32
The replica vm SCSI bus.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.ReplicaVmSCSIUnitNumber Property

UVRAVolumePersistedStateModelReplicaVmSCSIUnitNumber Property
Gets or sets the SCSI unit number the volume has on the replica Vm.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int ReplicaVmSCSIUnitNumber { get; set; }
Public Property ReplicaVmSCSIUnitNumber As Integer
    Get
    Set
public:
property int ReplicaVmSCSIUnitNumber {
    int get ();
    void set (int value);
}
member ReplicaVmSCSIUnitNumber : int with get, set

Property Value

Type: Int32
The replica vm SCSI unit number.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.ReverseVolumeSignature Property

UVRAVolumePersistedStateModelReverseVolumeSignature Property
Gets or sets the reverse volume signature. This represents the signature of the volume on the Source.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public byte[] ReverseVolumeSignature { get; set; }
Public Property ReverseVolumeSignature As Byte()
    Get
    Set
public:
property array<unsigned char>^ ReverseVolumeSignature {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member ReverseVolumeSignature : byte[] with get, set

Property Value

Type: Byte
The reverse volume signature.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.SourceISCSIBus Property

UVRAVolumePersistedStateModelSourceISCSIBus Property
Gets or sets the iSCSI bus number used in mapping the source disk.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int SourceISCSIBus { get; set; }
Public Property SourceISCSIBus As Integer
    Get
    Set
public:
property int SourceISCSIBus {
    int get ();
    void set (int value);
}
member SourceISCSIBus : int with get, set

Property Value

Type: Int32
The replica appliance SCSI bus.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.SourceISCSIUnitNumber Property

UVRAVolumePersistedStateModelSourceISCSIUnitNumber Property
Gets or sets the iSCSI unit number used in mapping the source disk.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int SourceISCSIUnitNumber { get; set; }
Public Property SourceISCSIUnitNumber As Integer
    Get
    Set
public:
property int SourceISCSIUnitNumber {
    int get ();
    void set (int value);
}
member SourceISCSIUnitNumber : int with get, set

Property Value

Type: Int32
The replica appliance SCSI unit number.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.VirtualDiskFilename Property

UVRAVolumePersistedStateModelVirtualDiskFilename Property
Gets or sets the filename for the virtual disk.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string VirtualDiskFilename { get; set; }
Public Property VirtualDiskFilename As String
    Get
    Set
public:
property String^ VirtualDiskFilename {
    String^ get ();
    void set (String^ value);
}
member VirtualDiskFilename : string with get, set

Property Value

Type: String
The virtual disk filename.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel.VolumeName Property

UVRAVolumePersistedStateModelVolumeName Property
Gets or sets the name of the volume.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string VolumeName { get; set; }
Public Property VolumeName As String
    Get
    Set
public:
property String^ VolumeName {
    String^ get ();
    void set (String^ value);
}
member VolumeName : string with get, set

Property Value

Type: String
The name of the volume.
See Also

Reference

UVRAVolumePersistedStateModel Class


UVRAVolumePersistedStateModel Methods

UVRAVolumePersistedStateModel Methods

The UVRAVolumePersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

UVRAVolumePersistedStateModel Class


V2VVirtualMachineModel Class

V2VVirtualMachineModel Class
Describes a virtual machine to be protected by the V2V feature.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsV2VVirtualMachineModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class V2VVirtualMachineModel
Public NotInheritable Class V2VVirtualMachineModel
public ref class V2VVirtualMachineModel sealed
[<SealedAttribute>]
type V2VVirtualMachineModel =  class end

The V2VVirtualMachineModel type exposes the following members.

Constructors
 | Name | Description
Public method | V2VVirtualMachineModel | Initializes a new instance of the V2VVirtualMachineModel class
Top
Properties
 | Name | Description
Public property | ActivationCode | Gets or sets the license key on the virtual machine.
Public property | BiosGuid | Gets or sets the BIOS unique ID for the virtual machine.
Public property | CPUs | Gets or sets the number of processors on the virtual machine.
Public property | Credentials | Gets or sets the credentials used to access the virtual machine.
Public property | DiskFormat | Gets or sets the disk format.
Public property | DisplayName | Gets or sets the virtual machine display name.
Public property | GuestOS | Gets or sets the guest operating system.
Public property | Guid | Gets or sets the unique ID of the virtual machine.
Public property | Memory | Gets or sets the amount of memory, in bytes, on the virtual machine.
Public property | NetworkId | Gets or sets the unique ID of the virtual machine network.
Public property | NetworkInterfaceInfo | Gets or sets the desired NIC configuration on the replica virtual machine.
Public property | Path | Gets or sets the path of the original source virtual machine.
Public property | SnapshotPath | Gets or sets the location of the virtual machine's snapshot files.
Public property | SystemDirectory | Gets or sets the location of the system directory.
Public property | TargetPath | Gets or sets the target path. Do not use this property. Double-Take uses it internally.
Public property | Volumes | Gets or sets a volume to protect and any changes to its base configuration.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


V2VVirtualMachineModel Constructor

V2VVirtualMachineModel Constructor
Initializes a new instance of the V2VVirtualMachineModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public V2VVirtualMachineModel()
Public Sub New
public:
V2VVirtualMachineModel()
new : unit -> V2VVirtualMachineModel
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel Properties

V2VVirtualMachineModel Properties

The V2VVirtualMachineModel type exposes the following members.

Properties
 | Name | Description
Public property | ActivationCode | Gets or sets the license key on the virtual machine.
Public property | BiosGuid | Gets or sets the BIOS unique ID for the virtual machine.
Public property | CPUs | Gets or sets the number of processors on the virtual machine.
Public property | Credentials | Gets or sets the credentials used to access the virtual machine.
Public property | DiskFormat | Gets or sets the disk format.
Public property | DisplayName | Gets or sets the virtual machine display name.
Public property | GuestOS | Gets or sets the guest operating system.
Public property | Guid | Gets or sets the unique ID of the virtual machine.
Public property | Memory | Gets or sets the amount of memory, in bytes, on the virtual machine.
Public property | NetworkId | Gets or sets the unique ID of the virtual machine network.
Public property | NetworkInterfaceInfo | Gets or sets the desired NIC configuration on the replica virtual machine.
Public property | Path | Gets or sets the path of the original source virtual machine.
Public property | SnapshotPath | Gets or sets the location of the virtual machine's snapshot files.
Public property | SystemDirectory | Gets or sets the location of the system directory.
Public property | TargetPath | Gets or sets the target path. Do not use this property. Double-Take uses it internally.
Public property | Volumes | Gets or sets a volume to protect and any changes to its base configuration.
Top
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.ActivationCode Property

V2VVirtualMachineModelActivationCode Property
Gets or sets the license key on the virtual machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ActivationCode { get; set; }
Public Property ActivationCode As String
    Get
    Set
public:
property String^ ActivationCode {
    String^ get ();
    void set (String^ value);
}
member ActivationCode : string with get, set

Property Value

Type: String
The activation code.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.BiosGuid Property

V2VVirtualMachineModelBiosGuid Property
Gets or sets the BIOS unique ID for the virtual machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Guid BiosGuid { get; set; }
Public Property BiosGuid As Guid
    Get
    Set
public:
property Guid BiosGuid {
    Guid get ();
    void set (Guid value);
}
member BiosGuid : Guid with get, set

Property Value

Type: Guid
The BIOS GUID.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.CPUs Property

V2VVirtualMachineModelCPUs Property
Gets or sets the number of processors on the virtual machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int CPUs { get; set; }
Public Property CPUs As Integer
    Get
    Set
public:
property int CPUs {
    int get ();
    void set (int value);
}
member CPUs : int with get, set

Property Value

Type: Int32
The CP us.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.Credentials Property

V2VVirtualMachineModelCredentials Property
Gets or sets the credentials used to access the virtual machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public CredentialModel Credentials { get; set; }
Public Property Credentials As CredentialModel
    Get
    Set
public:
property CredentialModel^ Credentials {
    CredentialModel^ get ();
    void set (CredentialModel^ value);
}
member Credentials : CredentialModel with get, set

Property Value

Type: CredentialModel
The credentials.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.DiskFormat Property

V2VVirtualMachineModelDiskFormat Property
Gets or sets the disk format.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string DiskFormat { get; set; }
Public Property DiskFormat As String
    Get
    Set
public:
property String^ DiskFormat {
    String^ get ();
    void set (String^ value);
}
member DiskFormat : string with get, set

Property Value

Type: String
The disk format.
Remarks
Dynamic—Use this value for ESX thin disks and for Hyper-V dynamic disks. Fixed—Use this value for ESX thick disks and for Hyper-V fixed disks. Flat Disk—Use this value for ESX flat disks. This type is not supported on Hyper-V.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.DisplayName Property

V2VVirtualMachineModelDisplayName Property
Gets or sets the virtual machine display name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}
member DisplayName : string with get, set

Property Value

Type: String
The display name.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.GuestOS Property

V2VVirtualMachineModelGuestOS Property
Gets or sets the guest operating system.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string GuestOS { get; set; }
Public Property GuestOS As String
    Get
    Set
public:
property String^ GuestOS {
    String^ get ();
    void set (String^ value);
}
member GuestOS : string with get, set

Property Value

Type: String
The guest OS.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.Guid Property

V2VVirtualMachineModelGuid Property
Gets or sets the unique ID of the virtual machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Guid Guid { get; set; }
Public Property Guid As Guid
    Get
    Set
public:
property Guid Guid {
    Guid get ();
    void set (Guid value);
}
member Guid : Guid with get, set

Property Value

Type: Guid
The GUID.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.Memory Property

V2VVirtualMachineModelMemory Property
Gets or sets the amount of memory, in bytes, on the virtual machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long Memory { get; set; }
Public Property Memory As Long
    Get
    Set
public:
property long long Memory {
    long long get ();
    void set (long long value);
}
member Memory : int64 with get, set

Property Value

Type: Int64
The memory.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.NetworkId Property

V2VVirtualMachineModelNetworkId Property
Gets or sets the unique ID of the virtual machine network.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string NetworkId { get; set; }
Public Property NetworkId As String
    Get
    Set
public:
property String^ NetworkId {
    String^ get ();
    void set (String^ value);
}
member NetworkId : string with get, set

Property Value

Type: String
The network id.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.NetworkInterfaceInfo Property

V2VVirtualMachineModelNetworkInterfaceInfo Property
Gets or sets the desired NIC configuration on the replica virtual machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VirtualNetworkInterfaceInfoModel[] NetworkInterfaceInfo { get; set; }
Public Property NetworkInterfaceInfo As VirtualNetworkInterfaceInfoModel()
    Get
    Set
public:
property array<VirtualNetworkInterfaceInfoModel^>^ NetworkInterfaceInfo {
    array<VirtualNetworkInterfaceInfoModel^>^ get ();
    void set (array<VirtualNetworkInterfaceInfoModel^>^ value);
}
member NetworkInterfaceInfo : VirtualNetworkInterfaceInfoModel[] with get, set

Property Value

Type: VirtualNetworkInterfaceInfoModel
The network interface info.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.Path Property

V2VVirtualMachineModelPath Property
Gets or sets the path of the original source virtual machine.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
member Path : string with get, set

Property Value

Type: String
The path.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.SnapshotPath Property

V2VVirtualMachineModelSnapshotPath Property
Gets or sets the location of the virtual machine's snapshot files.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SnapshotPath { get; set; }
Public Property SnapshotPath As String
    Get
    Set
public:
property String^ SnapshotPath {
    String^ get ();
    void set (String^ value);
}
member SnapshotPath : string with get, set

Property Value

Type: String
The snapshot path.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.SystemDirectory Property

V2VVirtualMachineModelSystemDirectory Property
Gets or sets the location of the system directory.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SystemDirectory { get; set; }
Public Property SystemDirectory As String
    Get
    Set
public:
property String^ SystemDirectory {
    String^ get ();
    void set (String^ value);
}
member SystemDirectory : string with get, set

Property Value

Type: String
The system directory.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.TargetPath Property

V2VVirtualMachineModelTargetPath Property
Gets or sets the target path. Do not use this property. Double-Take uses it internally.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string TargetPath { get; set; }
Public Property TargetPath As String
    Get
    Set
public:
property String^ TargetPath {
    String^ get ();
    void set (String^ value);
}
member TargetPath : string with get, set

Property Value

Type: String
The target path.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel.Volumes Property

V2VVirtualMachineModelVolumes Property
Gets or sets a volume to protect and any changes to its base configuration.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VolumeOptionsModel[] Volumes { get; set; }
Public Property Volumes As VolumeOptionsModel()
    Get
    Set
public:
property array<VolumeOptionsModel^>^ Volumes {
    array<VolumeOptionsModel^>^ get ();
    void set (array<VolumeOptionsModel^>^ value);
}
member Volumes : VolumeOptionsModel[] with get, set

Property Value

Type: VolumeOptionsModel
The volumes.
See Also

Reference

V2VVirtualMachineModel Class


V2VVirtualMachineModel Methods

V2VVirtualMachineModel Methods

The V2VVirtualMachineModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

V2VVirtualMachineModel Class


VcdVappOptionsModel Class

VcdVappOptionsModel Class
Vcd vapp options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVcdVappOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VcdVappOptionsModel
Public NotInheritable Class VcdVappOptionsModel
public ref class VcdVappOptionsModel sealed
[<SealedAttribute>]
type VcdVappOptionsModel =  class end

The VcdVappOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | VcdVappOptionsModel | Initializes a new instance of the VcdVappOptionsModel class
Top
Properties
 | Name | Description
Public property | DoDiskDataEncryption | Gets or sets a value indicating whether or not to do disk encryption.
Public property | IsSnapshotQuiescenceEnabled | Gets or sets a value indicating whether or not snapshot quiescence is enabled.
Public property | ReplicationIntervalSeconds | Gets or sets the replication interval in seconds.
Public property | SourceOrgName | Gets or sets the source organization name.
Public property | SourceVappDisplayName | Gets or sets the source Vapp display name.
Public property | SourceVappGuid | Gets or sets the source Vapp Guid.
Public property | TargetOrgName | Gets or sets the target organization name.
Public property | TargetOrgVdcName | Gets or sets the target Org Vdc name.
Public property | TargetVappDisplayName | Gets or sets the target Vapp display name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VcdVappOptionsModel Constructor

VcdVappOptionsModel Constructor
Initializes a new instance of the VcdVappOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VcdVappOptionsModel()
Public Sub New
public:
VcdVappOptionsModel()
new : unit -> VcdVappOptionsModel
See Also

Reference

VcdVappOptionsModel Class


VcdVappOptionsModel Properties

VcdVappOptionsModel Properties

The VcdVappOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | DoDiskDataEncryption | Gets or sets a value indicating whether or not to do disk encryption.
Public property | IsSnapshotQuiescenceEnabled | Gets or sets a value indicating whether or not snapshot quiescence is enabled.
Public property | ReplicationIntervalSeconds | Gets or sets the replication interval in seconds.
Public property | SourceOrgName | Gets or sets the source organization name.
Public property | SourceVappDisplayName | Gets or sets the source Vapp display name.
Public property | SourceVappGuid | Gets or sets the source Vapp Guid.
Public property | TargetOrgName | Gets or sets the target organization name.
Public property | TargetOrgVdcName | Gets or sets the target Org Vdc name.
Public property | TargetVappDisplayName | Gets or sets the target Vapp display name.
Top
See Also

Reference

VcdVappOptionsModel Class


VcdVappOptionsModel.DoDiskDataEncryption Property

VcdVappOptionsModelDoDiskDataEncryption Property
Gets or sets a value indicating whether or not to do disk encryption.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool DoDiskDataEncryption { get; set; }
Public Property DoDiskDataEncryption As Boolean
    Get
    Set
public:
property bool DoDiskDataEncryption {
    bool get ();
    void set (bool value);
}
member DoDiskDataEncryption : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VcdVappOptionsModel Class


VcdVappOptionsModel.IsSnapshotQuiescenceEnabled Property

VcdVappOptionsModelIsSnapshotQuiescenceEnabled Property
Gets or sets a value indicating whether or not snapshot quiescence is enabled.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSnapshotQuiescenceEnabled { get; set; }
Public Property IsSnapshotQuiescenceEnabled As Boolean
    Get
    Set
public:
property bool IsSnapshotQuiescenceEnabled {
    bool get ();
    void set (bool value);
}
member IsSnapshotQuiescenceEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VcdVappOptionsModel Class


VcdVappOptionsModel.ReplicationIntervalSeconds Property

VcdVappOptionsModelReplicationIntervalSeconds Property
Gets or sets the replication interval in seconds.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int ReplicationIntervalSeconds { get; set; }
Public Property ReplicationIntervalSeconds As Integer
    Get
    Set
public:
property int ReplicationIntervalSeconds {
    int get ();
    void set (int value);
}
member ReplicationIntervalSeconds : int with get, set

Property Value

Type: Int32
See Also

Reference

VcdVappOptionsModel Class


VcdVappOptionsModel.SourceOrgName Property

VcdVappOptionsModelSourceOrgName Property
Gets or sets the source organization name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceOrgName { get; set; }
Public Property SourceOrgName As String
    Get
    Set
public:
property String^ SourceOrgName {
    String^ get ();
    void set (String^ value);
}
member SourceOrgName : string with get, set

Property Value

Type: String
See Also

Reference

VcdVappOptionsModel Class


VcdVappOptionsModel.SourceVappDisplayName Property

VcdVappOptionsModelSourceVappDisplayName Property
Gets or sets the source Vapp display name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceVappDisplayName { get; set; }
Public Property SourceVappDisplayName As String
    Get
    Set
public:
property String^ SourceVappDisplayName {
    String^ get ();
    void set (String^ value);
}
member SourceVappDisplayName : string with get, set

Property Value

Type: String
See Also

Reference

VcdVappOptionsModel Class


VcdVappOptionsModel.SourceVappGuid Property

VcdVappOptionsModelSourceVappGuid Property
Gets or sets the source Vapp Guid.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceVappGuid { get; set; }
Public Property SourceVappGuid As String
    Get
    Set
public:
property String^ SourceVappGuid {
    String^ get ();
    void set (String^ value);
}
member SourceVappGuid : string with get, set

Property Value

Type: String
See Also

Reference

VcdVappOptionsModel Class


VcdVappOptionsModel.TargetOrgName Property

VcdVappOptionsModelTargetOrgName Property
Gets or sets the target organization name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetOrgName { get; set; }
Public Property TargetOrgName As String
    Get
    Set
public:
property String^ TargetOrgName {
    String^ get ();
    void set (String^ value);
}
member TargetOrgName : string with get, set

Property Value

Type: String
See Also

Reference

VcdVappOptionsModel Class


VcdVappOptionsModel.TargetOrgVdcName Property

VcdVappOptionsModelTargetOrgVdcName Property
Gets or sets the target Org Vdc name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetOrgVdcName { get; set; }
Public Property TargetOrgVdcName As String
    Get
    Set
public:
property String^ TargetOrgVdcName {
    String^ get ();
    void set (String^ value);
}
member TargetOrgVdcName : string with get, set

Property Value

Type: String
See Also

Reference

VcdVappOptionsModel Class


VcdVappOptionsModel.TargetVappDisplayName Property

VcdVappOptionsModelTargetVappDisplayName Property
Gets or sets the target Vapp display name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TargetVappDisplayName { get; set; }
Public Property TargetVappDisplayName As String
    Get
    Set
public:
property String^ TargetVappDisplayName {
    String^ get ();
    void set (String^ value);
}
member TargetVappDisplayName : string with get, set

Property Value

Type: String
See Also

Reference

VcdVappOptionsModel Class


VcdVappOptionsModel Methods

VcdVappOptionsModel Methods

The VcdVappOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VcdVappOptionsModel Class


VerificationStatus Enumeration

VerificationStatus Enumeration
Verification status.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum VerificationStatus
Public Enumeration VerificationStatus
public enum class VerificationStatus
type VerificationStatus
Members
Member name | Value | Description
InProgress | 0 | The in progress
Success | 1 | The success
Warning | 2 | The warning
Error | 3 | The error
See Also

Reference

DoubleTake.Web.Models Namespace


VerificationStatusModel Class

VerificationStatusModel Class
Verification status model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsActivityStatusModel
DoubleTake.Web.ModelsVerificationStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VerificationStatusModel : ActivityStatusModel
Public NotInheritable Class VerificationStatusModel
    Inherits ActivityStatusModel
public ref class VerificationStatusModel sealed : public ActivityStatusModel
[<SealedAttribute>]
type VerificationStatusModel =
    class
        inherit ActivityStatusModel
    end

The VerificationStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | VerificationStatusModel | Initializes a new instance of the VerificationStatusModel class
Top
Properties
 | Name | Description
Public property | Duration | Gets or sets a value the duration of the activity at the time this status was yielded. (Inherited from ActivityStatusModel.)
Public property | MessageFormatParameters | Gets or sets the message format parameters. (Inherited from ActivityStatusModel.)
Public property | MessageId | Gets or sets a value representing a message identifier. (Inherited from ActivityStatusModel.)
Public property | RequesterUserName | Gets or sets the user that initiated the activity. (Inherited from ActivityStatusModel.)
Public property | Status | Gets or sets the current status of the activity. (Inherited from ActivityStatusModel.)
Public property | StatusUri | Gets or sets the URI to call to obtain further status information - missing if the status is 'completed', 'canceled' or 'faulted'. (Inherited from ActivityStatusModel.)
Public property | Steps | Gets or sets the steps in the verification task.
Public property | TimeStamp | Gets or sets the server time when the activity yielded this status. (Inherited from ActivityStatusModel.)
Public property | Token | Gets or sets a token that identifies the request that initiated the activity. (Inherited from ActivityStatusModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VerificationStatusModel Constructor

VerificationStatusModel Constructor
Initializes a new instance of the VerificationStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VerificationStatusModel()
Public Sub New
public:
VerificationStatusModel()
new : unit -> VerificationStatusModel
See Also

Reference

VerificationStatusModel Class


VerificationStatusModel Properties

VerificationStatusModel Properties

The VerificationStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | Duration | Gets or sets a value the duration of the activity at the time this status was yielded. (Inherited from ActivityStatusModel.)
Public property | MessageFormatParameters | Gets or sets the message format parameters. (Inherited from ActivityStatusModel.)
Public property | MessageId | Gets or sets a value representing a message identifier. (Inherited from ActivityStatusModel.)
Public property | RequesterUserName | Gets or sets the user that initiated the activity. (Inherited from ActivityStatusModel.)
Public property | Status | Gets or sets the current status of the activity. (Inherited from ActivityStatusModel.)
Public property | StatusUri | Gets or sets the URI to call to obtain further status information - missing if the status is 'completed', 'canceled' or 'faulted'. (Inherited from ActivityStatusModel.)
Public property | Steps | Gets or sets the steps in the verification task.
Public property | TimeStamp | Gets or sets the server time when the activity yielded this status. (Inherited from ActivityStatusModel.)
Public property | Token | Gets or sets a token that identifies the request that initiated the activity. (Inherited from ActivityStatusModel.)
Top
See Also

Reference

VerificationStatusModel Class


VerificationStatusModel.Steps Property

VerificationStatusModelSteps Property
Gets or sets the steps in the verification task.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public IEnumerable<VerificationStepModel> Steps { get; set; }
Public Property Steps As IEnumerable(Of VerificationStepModel)
    Get
    Set
public:
property IEnumerable<VerificationStepModel^>^ Steps {
    IEnumerable<VerificationStepModel^>^ get ();
    void set (IEnumerable<VerificationStepModel^>^ value);
}
member Steps : IEnumerable<VerificationStepModel> with get, set

Property Value

Type: IEnumerable VerificationStepModel
See Also

Reference

VerificationStatusModel Class


VerificationStatusModel Methods

VerificationStatusModel Methods

The VerificationStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VerificationStatusModel Class


VerificationStepModel Class

VerificationStepModel Class
Verification step model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVerificationStepModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VerificationStepModel
Public NotInheritable Class VerificationStepModel
public ref class VerificationStepModel sealed
[<SealedAttribute>]
type VerificationStepModel =  class end

The VerificationStepModel type exposes the following members.

Constructors
 | Name | Description
Public method | VerificationStepModel | Initializes a new instance of the VerificationStepModel class
Top
Properties
 | Name | Description
Public property | CanFix | Gets or sets a value indicating whether this step can be fixed.
Public property | Id | Gets or sets a value representing the identifier of this verification step.
Public property | Index | Gets or sets the index of this verification step
Public property | MessageFormatParameters | Gets or sets the message format parameters for this step.
Public property | MessageKey | Gets or sets a value representing a message key for this verification step.
Public property | Progress | Gets or sets value that indicates the completion progress of this verification step.
Public property | Status | Gets or sets the status of this verification step.
Public property | TitleFormatParameters | Gets or sets the title format parameters for this step.
Public property | TitleKey | Gets or sets a value representing a title key for this verification step.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VerificationStepModel Constructor

VerificationStepModel Constructor
Initializes a new instance of the VerificationStepModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VerificationStepModel()
Public Sub New
public:
VerificationStepModel()
new : unit -> VerificationStepModel
See Also

Reference

VerificationStepModel Class


VerificationStepModel Properties

VerificationStepModel Properties

The VerificationStepModel type exposes the following members.

Properties
 | Name | Description
Public property | CanFix | Gets or sets a value indicating whether this step can be fixed.
Public property | Id | Gets or sets a value representing the identifier of this verification step.
Public property | Index | Gets or sets the index of this verification step
Public property | MessageFormatParameters | Gets or sets the message format parameters for this step.
Public property | MessageKey | Gets or sets a value representing a message key for this verification step.
Public property | Progress | Gets or sets value that indicates the completion progress of this verification step.
Public property | Status | Gets or sets the status of this verification step.
Public property | TitleFormatParameters | Gets or sets the title format parameters for this step.
Public property | TitleKey | Gets or sets a value representing a title key for this verification step.
Top
See Also

Reference

VerificationStepModel Class


VerificationStepModel.CanFix Property

VerificationStepModelCanFix Property
Gets or sets a value indicating whether this step can be fixed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool CanFix { get; set; }
Public Property CanFix As Boolean
    Get
    Set
public:
property bool CanFix {
    bool get ();
    void set (bool value);
}
member CanFix : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VerificationStepModel Class


VerificationStepModel.Id Property

VerificationStepModelId Property
Gets or sets a value representing the identifier of this verification step.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Id { get; set; }
Public Property Id As String
    Get
    Set
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}
member Id : string with get, set

Property Value

Type: String
See Also

Reference

VerificationStepModel Class


VerificationStepModel.Index Property

VerificationStepModelIndex Property
Gets or sets the index of this verification step

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set
public:
property int Index {
    int get ();
    void set (int value);
}
member Index : int with get, set

Property Value

Type: Int32
See Also

Reference

VerificationStepModel Class


VerificationStepModel.MessageFormatParameters Property

VerificationStepModelMessageFormatParameters Property
Gets or sets the message format parameters for this step.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] MessageFormatParameters { get; set; }
Public Property MessageFormatParameters As String()
    Get
    Set
public:
property array<String^>^ MessageFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member MessageFormatParameters : string[] with get, set

Property Value

Type: String
See Also

Reference

VerificationStepModel Class


VerificationStepModel.MessageKey Property

VerificationStepModelMessageKey Property
Gets or sets a value representing a message key for this verification step.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string MessageKey { get; set; }
Public Property MessageKey As String
    Get
    Set
public:
property String^ MessageKey {
    String^ get ();
    void set (String^ value);
}
member MessageKey : string with get, set

Property Value

Type: String
See Also

Reference

VerificationStepModel Class


VerificationStepModel.Progress Property

VerificationStepModelProgress Property
Gets or sets value that indicates the completion progress of this verification step.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int Progress { get; set; }
Public Property Progress As Integer
    Get
    Set
public:
property int Progress {
    int get ();
    void set (int value);
}
member Progress : int with get, set

Property Value

Type: Int32
See Also

Reference

VerificationStepModel Class


VerificationStepModel.Status Property

VerificationStepModelStatus Property
Gets or sets the status of this verification step.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VerificationStatus Status { get; set; }
Public Property Status As VerificationStatus
    Get
    Set
public:
property VerificationStatus Status {
    VerificationStatus get ();
    void set (VerificationStatus value);
}
member Status : VerificationStatus with get, set

Property Value

Type: VerificationStatus
See Also

Reference

VerificationStepModel Class


VerificationStepModel.TitleFormatParameters Property

VerificationStepModelTitleFormatParameters Property
Gets or sets the title format parameters for this step.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] TitleFormatParameters { get; set; }
Public Property TitleFormatParameters As String()
    Get
    Set
public:
property array<String^>^ TitleFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member TitleFormatParameters : string[] with get, set

Property Value

Type: String
See Also

Reference

VerificationStepModel Class


VerificationStepModel.TitleKey Property

VerificationStepModelTitleKey Property
Gets or sets a value representing a title key for this verification step.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string TitleKey { get; set; }
Public Property TitleKey As String
    Get
    Set
public:
property String^ TitleKey {
    String^ get ();
    void set (String^ value);
}
member TitleKey : string with get, set

Property Value

Type: String
See Also

Reference

VerificationStepModel Class


VerificationStepModel Methods

VerificationStepModel Methods

The VerificationStepModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VerificationStepModel Class


VerifyJobOptionsRequestModel Class

VerifyJobOptionsRequestModel Class
Verify job options request model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVerifyJobOptionsRequestModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VerifyJobOptionsRequestModel
Public NotInheritable Class VerifyJobOptionsRequestModel
public ref class VerifyJobOptionsRequestModel sealed
[<SealedAttribute>]
type VerifyJobOptionsRequestModel =  class end

The VerifyJobOptionsRequestModel type exposes the following members.

Constructors
 | Name | Description
Public method | VerifyJobOptionsRequestModel | Initializes a new instance of the VerifyJobOptionsRequestModel class
Top
Properties
 | Name | Description
Public property | JobCredentials | Gets or sets the job credentials.
Public property | JobOptions | Gets or sets the job options.
Public property | JobType | Gets or sets the type of the job.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VerifyJobOptionsRequestModel Constructor

VerifyJobOptionsRequestModel Constructor
Initializes a new instance of the VerifyJobOptionsRequestModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VerifyJobOptionsRequestModel()
Public Sub New
public:
VerifyJobOptionsRequestModel()
new : unit -> VerifyJobOptionsRequestModel
See Also

Reference

VerifyJobOptionsRequestModel Class


VerifyJobOptionsRequestModel Properties

VerifyJobOptionsRequestModel Properties

The VerifyJobOptionsRequestModel type exposes the following members.

Properties
 | Name | Description
Public property | JobCredentials | Gets or sets the job credentials.
Public property | JobOptions | Gets or sets the job options.
Public property | JobType | Gets or sets the type of the job.
Top
See Also

Reference

VerifyJobOptionsRequestModel Class


VerifyJobOptionsRequestModel.JobCredentials Property

VerifyJobOptionsRequestModelJobCredentials Property
Gets or sets the job credentials.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public JobCredentialsModel JobCredentials { get; set; }
Public Property JobCredentials As JobCredentialsModel
    Get
    Set
public:
property JobCredentialsModel^ JobCredentials {
    JobCredentialsModel^ get ();
    void set (JobCredentialsModel^ value);
}
member JobCredentials : JobCredentialsModel with get, set

Property Value

Type: JobCredentialsModel
The job credentials.
See Also

Reference

VerifyJobOptionsRequestModel Class


VerifyJobOptionsRequestModel.JobOptions Property

VerifyJobOptionsRequestModelJobOptions Property
Gets or sets the job options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public JobOptionsModel JobOptions { get; set; }
Public Property JobOptions As JobOptionsModel
    Get
    Set
public:
property JobOptionsModel^ JobOptions {
    JobOptionsModel^ get ();
    void set (JobOptionsModel^ value);
}
member JobOptions : JobOptionsModel with get, set

Property Value

Type: JobOptionsModel
The job options.
See Also

Reference

VerifyJobOptionsRequestModel Class


VerifyJobOptionsRequestModel.JobType Property

VerifyJobOptionsRequestModelJobType Property
Gets or sets the type of the job.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string JobType { get; set; }
Public Property JobType As String
    Get
    Set
public:
property String^ JobType {
    String^ get ();
    void set (String^ value);
}
member JobType : string with get, set

Property Value

Type: String
The type of the job.
See Also

Reference

VerifyJobOptionsRequestModel Class


VerifyJobOptionsRequestModel Methods

VerifyJobOptionsRequestModel Methods

The VerifyJobOptionsRequestModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VerifyJobOptionsRequestModel Class


VerifyScheduleModel Class

VerifyScheduleModel Class
Verify schedule model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsScheduleItemModel
DoubleTake.Web.ModelsVerifyScheduleModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VerifyScheduleModel : ScheduleItemModel
Public NotInheritable Class VerifyScheduleModel
    Inherits ScheduleItemModel
public ref class VerifyScheduleModel sealed : public ScheduleItemModel
[<SealedAttribute>]
type VerifyScheduleModel =
    class
        inherit ScheduleItemModel
    end

The VerifyScheduleModel type exposes the following members.

Constructors
 | Name | Description
Public method | VerifyScheduleModel | Initializes a new instance of the VerifyScheduleModel class
Top
Properties
 | Name | Description
Public property | Criteria | Gets or sets how to compare files when creating the verification report.
Public property | Interval | Gets or sets how often a verification is to be run.
Public property | IsEnabled | Gets or sets a value indicating whether or not the item is enabled. (Inherited from ScheduleItemModel.)
Public property | Options | Gets or sets a value indicating whether or not to synchronize the data while creating the verification report.
Public property | StartTime | Gets or sets the time that the first scheduled verification report will be run.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VerifyScheduleModel Constructor

VerifyScheduleModel Constructor
Initializes a new instance of the VerifyScheduleModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VerifyScheduleModel()
Public Sub New
public:
VerifyScheduleModel()
new : unit -> VerifyScheduleModel
See Also

Reference

VerifyScheduleModel Class


VerifyScheduleModel Properties

VerifyScheduleModel Properties

The VerifyScheduleModel type exposes the following members.

Properties
 | Name | Description
Public property | Criteria | Gets or sets how to compare files when creating the verification report.
Public property | Interval | Gets or sets how often a verification is to be run.
Public property | IsEnabled | Gets or sets a value indicating whether or not the item is enabled. (Inherited from ScheduleItemModel.)
Public property | Options | Gets or sets a value indicating whether or not to synchronize the data while creating the verification report.
Public property | StartTime | Gets or sets the time that the first scheduled verification report will be run.
Top
See Also

Reference

VerifyScheduleModel Class


VerifyScheduleModel.Criteria Property

VerifyScheduleModelCriteria Property
Gets or sets how to compare files when creating the verification report.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public MirrorComparisonCriteria Criteria { get; set; }
Public Property Criteria As MirrorComparisonCriteria
    Get
    Set
public:
property MirrorComparisonCriteria Criteria {
    MirrorComparisonCriteria get ();
    void set (MirrorComparisonCriteria value);
}
member Criteria : MirrorComparisonCriteria with get, set

Property Value

Type: MirrorComparisonCriteria
See Also

Reference

VerifyScheduleModel Class


VerifyScheduleModel.Interval Property

VerifyScheduleModelInterval Property
Gets or sets how often a verification is to be run.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TimeSpan Interval { get; set; }
Public Property Interval As TimeSpan
    Get
    Set
public:
property TimeSpan Interval {
    TimeSpan get ();
    void set (TimeSpan value);
}
member Interval : TimeSpan with get, set

Property Value

Type: TimeSpan
See Also

Reference

VerifyScheduleModel Class


VerifyScheduleModel.Options Property

VerifyScheduleModelOptions Property
Gets or sets a value indicating whether or not to synchronize the data while creating the verification report.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public MirrorOperationOptions Options { get; set; }
Public Property Options As MirrorOperationOptions
    Get
    Set
public:
property MirrorOperationOptions Options {
    MirrorOperationOptions get ();
    void set (MirrorOperationOptions value);
}
member Options : MirrorOperationOptions with get, set

Property Value

Type: MirrorOperationOptions
See Also

Reference

VerifyScheduleModel Class


VerifyScheduleModel.StartTime Property

VerifyScheduleModelStartTime Property
Gets or sets the time that the first scheduled verification report will be run.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}
member StartTime : DateTime with get, set

Property Value

Type: DateTime
See Also

Reference

VerifyScheduleModel Class


VerifyScheduleModel Methods

VerifyScheduleModel Methods

The VerifyScheduleModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VerifyScheduleModel Class


VhdDeleteActionType Enumeration

VhdDeleteActionType Enumeration
VHD delete action type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public enum VhdDeleteActionType
Public Enumeration VhdDeleteActionType
public enum class VhdDeleteActionType
type VhdDeleteActionType
Members
Member name | Value | Description
KeepAll | 0 | The keep all
DeleteAll | 1 | The delete all
UseVhdsToDelete | 2 | The use VHDS to delete
See Also

Reference

DoubleTake.Web.Models Namespace


VHDMappingModel Class

VHDMappingModel Class
Represents source and target VHD mappings
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVHDMappingModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class VHDMappingModel
Public NotInheritable Class VHDMappingModel
public ref class VHDMappingModel sealed
[<SealedAttribute>]
type VHDMappingModel =  class end

The VHDMappingModel type exposes the following members.

Constructors
 | Name | Description
Public method | VHDMappingModel | Initializes a new instance of the VHDMappingModel class
Top
Properties
 | Name | Description
Public property | SourceVHD | Gets or sets the source .vhd file.
Public property | TargetVHD | Gets or sets the target .vhd file.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VHDMappingModel Constructor

VHDMappingModel Constructor
Initializes a new instance of the VHDMappingModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VHDMappingModel()
Public Sub New
public:
VHDMappingModel()
new : unit -> VHDMappingModel
See Also

Reference

VHDMappingModel Class


VHDMappingModel Properties

VHDMappingModel Properties

The VHDMappingModel type exposes the following members.

Properties
 | Name | Description
Public property | SourceVHD | Gets or sets the source .vhd file.
Public property | TargetVHD | Gets or sets the target .vhd file.
Top
See Also

Reference

VHDMappingModel Class


VHDMappingModel.SourceVHD Property

VHDMappingModelSourceVHD Property
Gets or sets the source .vhd file.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SourceVHD { get; set; }
Public Property SourceVHD As String
    Get
    Set
public:
property String^ SourceVHD {
    String^ get ();
    void set (String^ value);
}
member SourceVHD : string with get, set

Property Value

Type: String
See Also

Reference

VHDMappingModel Class


VHDMappingModel.TargetVHD Property

VHDMappingModelTargetVHD Property
Gets or sets the target .vhd file.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string TargetVHD { get; set; }
Public Property TargetVHD As String
    Get
    Set
public:
property String^ TargetVHD {
    String^ get ();
    void set (String^ value);
}
member TargetVHD : string with get, set

Property Value

Type: String
See Also

Reference

VHDMappingModel Class


VHDMappingModel Methods

VHDMappingModel Methods

The VHDMappingModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VHDMappingModel Class


VirtualizationConnectionInfoModel Class

VirtualizationConnectionInfoModel Class
Virtualization connection information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVirtualizationConnectionInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class VirtualizationConnectionInfoModel
Public NotInheritable Class VirtualizationConnectionInfoModel
public ref class VirtualizationConnectionInfoModel sealed
[<SealedAttribute>]
type VirtualizationConnectionInfoModel =  class end

The VirtualizationConnectionInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualizationConnectionInfoModel | Initializes a new instance of the VirtualizationConnectionInfoModel class
Top
Properties
 | Name | Description
Public property | Attach | Gets or sets a value indicating whether this VirtualizationConnectionInfoModel is attach.
Public property | MonitorId | Gets or sets the monitor id.
Public property | PathTransformations | Gets or sets the path transformations.
Public property | ProcessHardlinks | Gets or sets a value indicating whether Double-Take should process hardlinks.
Public property | RepsetName | Gets or sets the name of the repset.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VirtualizationConnectionInfoModel Constructor

VirtualizationConnectionInfoModel Constructor
Initializes a new instance of the VirtualizationConnectionInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VirtualizationConnectionInfoModel()
Public Sub New
public:
VirtualizationConnectionInfoModel()
new : unit -> VirtualizationConnectionInfoModel
See Also

Reference

VirtualizationConnectionInfoModel Class


VirtualizationConnectionInfoModel Properties

VirtualizationConnectionInfoModel Properties

The VirtualizationConnectionInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Attach | Gets or sets a value indicating whether this VirtualizationConnectionInfoModel is attach.
Public property | MonitorId | Gets or sets the monitor id.
Public property | PathTransformations | Gets or sets the path transformations.
Public property | ProcessHardlinks | Gets or sets a value indicating whether Double-Take should process hardlinks.
Public property | RepsetName | Gets or sets the name of the repset.
Top
See Also

Reference

VirtualizationConnectionInfoModel Class


VirtualizationConnectionInfoModel.Attach Property

VirtualizationConnectionInfoModelAttach Property
Gets or sets a value indicating whether this VirtualizationConnectionInfoModel is attach.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool Attach { get; set; }
Public Property Attach As Boolean
    Get
    Set
public:
property bool Attach {
    bool get ();
    void set (bool value);
}
member Attach : bool with get, set

Property Value

Type: Boolean
if attach; otherwise, .
See Also

Reference

VirtualizationConnectionInfoModel Class


VirtualizationConnectionInfoModel.MonitorId Property

VirtualizationConnectionInfoModelMonitorId Property
Gets or sets the monitor id.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public Guid MonitorId { get; set; }
Public Property MonitorId As Guid
    Get
    Set
public:
property Guid MonitorId {
    Guid get ();
    void set (Guid value);
}
member MonitorId : Guid with get, set

Property Value

Type: Guid
The monitor id.
See Also

Reference

VirtualizationConnectionInfoModel Class


VirtualizationConnectionInfoModel.PathTransformations Property

VirtualizationConnectionInfoModelPathTransformations Property
Gets or sets the path transformations.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public PathTransformationModel[] PathTransformations { get; set; }
Public Property PathTransformations As PathTransformationModel()
    Get
    Set
public:
property array<PathTransformationModel^>^ PathTransformations {
    array<PathTransformationModel^>^ get ();
    void set (array<PathTransformationModel^>^ value);
}
member PathTransformations : PathTransformationModel[] with get, set

Property Value

Type: PathTransformationModel
The path transformations.
See Also

Reference

VirtualizationConnectionInfoModel Class


VirtualizationConnectionInfoModel.ProcessHardlinks Property

VirtualizationConnectionInfoModelProcessHardlinks Property
Gets or sets a value indicating whether Double-Take should process hardlinks.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool ProcessHardlinks { get; set; }
Public Property ProcessHardlinks As Boolean
    Get
    Set
public:
property bool ProcessHardlinks {
    bool get ();
    void set (bool value);
}
member ProcessHardlinks : bool with get, set

Property Value

Type: Boolean
true if Double-Take should process hardlinks; otherwise, false.
See Also

Reference

VirtualizationConnectionInfoModel Class


VirtualizationConnectionInfoModel.RepsetName Property

VirtualizationConnectionInfoModelRepsetName Property
Gets or sets the name of the repset.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string RepsetName { get; set; }
Public Property RepsetName As String
    Get
    Set
public:
property String^ RepsetName {
    String^ get ();
    void set (String^ value);
}
member RepsetName : string with get, set

Property Value

Type: String
The name of the repset.
See Also

Reference

VirtualizationConnectionInfoModel Class


VirtualizationConnectionInfoModel Methods

VirtualizationConnectionInfoModel Methods

The VirtualizationConnectionInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualizationConnectionInfoModel Class


VirtualMachineResourceInfoModel Class

VirtualMachineResourceInfoModel Class
Virtual machine resource information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVirtualMachineResourceInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class VirtualMachineResourceInfoModel
Public NotInheritable Class VirtualMachineResourceInfoModel
public ref class VirtualMachineResourceInfoModel sealed
[<SealedAttribute>]
type VirtualMachineResourceInfoModel =  class end

The VirtualMachineResourceInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualMachineResourceInfoModel | Initializes a new instance of the VirtualMachineResourceInfoModel class
Top
Properties
 | Name | Description
Public property | VmCfgResourceName | Gets or sets cluster VM configuration resource name.
Public property | VmGuid | Gets or sets cluster VM GUID.
Public property | VmResourceName | Gets or sets cluster VM resource name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VirtualMachineResourceInfoModel Constructor

VirtualMachineResourceInfoModel Constructor
Initializes a new instance of the VirtualMachineResourceInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VirtualMachineResourceInfoModel()
Public Sub New
public:
VirtualMachineResourceInfoModel()
new : unit -> VirtualMachineResourceInfoModel
See Also

Reference

VirtualMachineResourceInfoModel Class


VirtualMachineResourceInfoModel Properties

VirtualMachineResourceInfoModel Properties

The VirtualMachineResourceInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | VmCfgResourceName | Gets or sets cluster VM configuration resource name.
Public property | VmGuid | Gets or sets cluster VM GUID.
Public property | VmResourceName | Gets or sets cluster VM resource name.
Top
See Also

Reference

VirtualMachineResourceInfoModel Class


VirtualMachineResourceInfoModel.VmCfgResourceName Property

VirtualMachineResourceInfoModelVmCfgResourceName Property
Gets or sets cluster VM configuration resource name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string VmCfgResourceName { get; set; }
Public Property VmCfgResourceName As String
    Get
    Set
public:
property String^ VmCfgResourceName {
    String^ get ();
    void set (String^ value);
}
member VmCfgResourceName : string with get, set

Property Value

Type: String
See Also

Reference

VirtualMachineResourceInfoModel Class


VirtualMachineResourceInfoModel.VmGuid Property

VirtualMachineResourceInfoModelVmGuid Property
Gets or sets cluster VM GUID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string VmGuid { get; set; }
Public Property VmGuid As String
    Get
    Set
public:
property String^ VmGuid {
    String^ get ();
    void set (String^ value);
}
member VmGuid : string with get, set

Property Value

Type: String
See Also

Reference

VirtualMachineResourceInfoModel Class


VirtualMachineResourceInfoModel.VmResourceName Property

VirtualMachineResourceInfoModelVmResourceName Property
Gets or sets cluster VM resource name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string VmResourceName { get; set; }
Public Property VmResourceName As String
    Get
    Set
public:
property String^ VmResourceName {
    String^ get ();
    void set (String^ value);
}
member VmResourceName : string with get, set

Property Value

Type: String
See Also

Reference

VirtualMachineResourceInfoModel Class


VirtualMachineResourceInfoModel Methods

VirtualMachineResourceInfoModel Methods

The VirtualMachineResourceInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualMachineResourceInfoModel Class


VirtualNetworkInterfaceInfoModel Class

VirtualNetworkInterfaceInfoModel Class
Virtual network interface info model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsNetworkInterfaceModel
DoubleTake.Web.ModelsVirtualNetworkInterfaceInfoModel
DoubleTake.Web.ModelsVRAInternalVirtualNetworkInterfaceInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public class VirtualNetworkInterfaceInfoModel : NetworkInterfaceModel
Public Class VirtualNetworkInterfaceInfoModel
    Inherits NetworkInterfaceModel
public ref class VirtualNetworkInterfaceInfoModel : public NetworkInterfaceModel
type VirtualNetworkInterfaceInfoModel =
    class
        inherit NetworkInterfaceModel
    end

The VirtualNetworkInterfaceInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualNetworkInterfaceInfoModel | Initializes a new instance of the VirtualNetworkInterfaceInfoModel class
Top
Properties
 | Name | Description
Public property | Description | Gets or sets the description of the network interface. (Inherited from NetworkInterfaceModel.)
Public property | DnsDomain | Gets or sets the DNS Domain. (Inherited from NetworkInterfaceModel.)
Public property | DnsServers | Gets or sets the DNS servers. (Inherited from NetworkInterfaceModel.)
Public property | Gateways | Gets or sets the gateways. (Inherited from NetworkInterfaceModel.)
Public property | Id | Gets or sets the unique identifier of the network interface. (Inherited from NetworkInterfaceModel.)
Public property | Index | Gets or sets the index of the network interface. (Inherited from NetworkInterfaceModel.)
Public property | InterfaceIndex | Gets or sets the index of the network interface. (Inherited from NetworkInterfaceModel.)
Public property | IPAddresses | Gets or sets the IP addresses on the network interface. (Inherited from NetworkInterfaceModel.)
Public property | MacAddress | Gets or sets the MAC address. (Inherited from NetworkInterfaceModel.)
Public property | Name | Gets or sets the friendly name of the network interface. (Inherited from NetworkInterfaceModel.)
Public property | PnpInstanceId | Gets or sets the PNP instance id. (Inherited from NetworkInterfaceModel.)
Public property | ServiceName | Gets or sets the service name of the network interface. (Inherited from NetworkInterfaceModel.)
Public property | VirtualNetwork | Gets or sets the virtual network.
Public property | VirtualNicType | Gets or sets the type of the virtual NIC.
Public property | VLAN_ID | Gets or sets the replica's VLan ID.
Public property | VLAN_ID_TestFailover | Gets or sets the replica's test failover VLan ID.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VirtualNetworkInterfaceInfoModel Constructor

VirtualNetworkInterfaceInfoModel Constructor
Initializes a new instance of the VirtualNetworkInterfaceInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VirtualNetworkInterfaceInfoModel()
Public Sub New
public:
VirtualNetworkInterfaceInfoModel()
new : unit -> VirtualNetworkInterfaceInfoModel
See Also

Reference

VirtualNetworkInterfaceInfoModel Class


VirtualNetworkInterfaceInfoModel Properties

VirtualNetworkInterfaceInfoModel Properties

The VirtualNetworkInterfaceInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Description | Gets or sets the description of the network interface. (Inherited from NetworkInterfaceModel.)
Public property | DnsDomain | Gets or sets the DNS Domain. (Inherited from NetworkInterfaceModel.)
Public property | DnsServers | Gets or sets the DNS servers. (Inherited from NetworkInterfaceModel.)
Public property | Gateways | Gets or sets the gateways. (Inherited from NetworkInterfaceModel.)
Public property | Id | Gets or sets the unique identifier of the network interface. (Inherited from NetworkInterfaceModel.)
Public property | Index | Gets or sets the index of the network interface. (Inherited from NetworkInterfaceModel.)
Public property | InterfaceIndex | Gets or sets the index of the network interface. (Inherited from NetworkInterfaceModel.)
Public property | IPAddresses | Gets or sets the IP addresses on the network interface. (Inherited from NetworkInterfaceModel.)
Public property | MacAddress | Gets or sets the MAC address. (Inherited from NetworkInterfaceModel.)
Public property | Name | Gets or sets the friendly name of the network interface. (Inherited from NetworkInterfaceModel.)
Public property | PnpInstanceId | Gets or sets the PNP instance id. (Inherited from NetworkInterfaceModel.)
Public property | ServiceName | Gets or sets the service name of the network interface. (Inherited from NetworkInterfaceModel.)
Public property | VirtualNetwork | Gets or sets the virtual network.
Public property | VirtualNicType | Gets or sets the type of the virtual NIC.
Public property | VLAN_ID | Gets or sets the replica's VLan ID.
Public property | VLAN_ID_TestFailover | Gets or sets the replica's test failover VLan ID.
Top
See Also

Reference

VirtualNetworkInterfaceInfoModel Class


VirtualNetworkInterfaceInfoModel.VirtualNetwork Property

VirtualNetworkInterfaceInfoModelVirtualNetwork Property
Gets or sets the virtual network.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string VirtualNetwork { get; set; }
Public Property VirtualNetwork As String
    Get
    Set
public:
property String^ VirtualNetwork {
    String^ get ();
    void set (String^ value);
}
member VirtualNetwork : string with get, set

Property Value

Type: String
See Also

Reference

VirtualNetworkInterfaceInfoModel Class


VirtualNetworkInterfaceInfoModel.VirtualNicType Property

VirtualNetworkInterfaceInfoModelVirtualNicType Property
Gets or sets the type of the virtual NIC.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string VirtualNicType { get; set; }
Public Property VirtualNicType As String
    Get
    Set
public:
property String^ VirtualNicType {
    String^ get ();
    void set (String^ value);
}
member VirtualNicType : string with get, set

Property Value

Type: String
See Also

Reference

VirtualNetworkInterfaceInfoModel Class


VirtualNetworkInterfaceInfoModel.VLAN_ID Property

VirtualNetworkInterfaceInfoModelVLAN_ID Property
Gets or sets the replica's VLan ID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int VLAN_ID { get; set; }
Public Property VLAN_ID As Integer
    Get
    Set
public:
property int VLAN_ID {
    int get ();
    void set (int value);
}
member VLAN_ID : int with get, set

Property Value

Type: Int32
See Also

Reference

VirtualNetworkInterfaceInfoModel Class


VirtualNetworkInterfaceInfoModel.VLAN_ID_TestFailover Property

VirtualNetworkInterfaceInfoModelVLAN_ID_TestFailover Property
Gets or sets the replica's test failover VLan ID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int VLAN_ID_TestFailover { get; set; }
Public Property VLAN_ID_TestFailover As Integer
    Get
    Set
public:
property int VLAN_ID_TestFailover {
    int get ();
    void set (int value);
}
member VLAN_ID_TestFailover : int with get, set

Property Value

Type: Int32
See Also

Reference

VirtualNetworkInterfaceInfoModel Class


VirtualNetworkInterfaceInfoModel Methods

VirtualNetworkInterfaceInfoModel Methods

The VirtualNetworkInterfaceInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualNetworkInterfaceInfoModel Class


VirtualSwitchConfigQueryInputModel Class

VirtualSwitchConfigQueryInputModel Class
Inputs for a Virtual Switch monitor
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsVirtualSwitchConfigQueryInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class VirtualSwitchConfigQueryInputModel : QueryInputModel
Public Class VirtualSwitchConfigQueryInputModel
    Inherits QueryInputModel
public ref class VirtualSwitchConfigQueryInputModel : public QueryInputModel
type VirtualSwitchConfigQueryInputModel =
    class
        inherit QueryInputModel
    end

The VirtualSwitchConfigQueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualSwitchConfigQueryInputModel | Initializes a new instance of the VirtualSwitchConfigQueryInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | VirtualSwitchInfoColl | Gets or sets the collection of virtual switch information.
Public property | VmId | Gets or sets the vm identifier.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryInputModel


VirtualSwitchConfigQueryInputModel Constructor

VirtualSwitchConfigQueryInputModel Constructor
Initializes a new instance of the VirtualSwitchConfigQueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchConfigQueryInputModel()
Public Sub New
public:
VirtualSwitchConfigQueryInputModel()
new : unit -> VirtualSwitchConfigQueryInputModel
See Also

Reference

VirtualSwitchConfigQueryInputModel Class


VirtualSwitchConfigQueryInputModel Properties

VirtualSwitchConfigQueryInputModel Properties

The VirtualSwitchConfigQueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | VirtualSwitchInfoColl | Gets or sets the collection of virtual switch information.
Public property | VmId | Gets or sets the vm identifier.
Top
See Also

Reference

VirtualSwitchConfigQueryInputModel Class


VirtualSwitchConfigQueryInputModel.VirtualSwitchInfoColl Property

VirtualSwitchConfigQueryInputModelVirtualSwitchInfoColl Property
Gets or sets the collection of virtual switch information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchInfoModel[] VirtualSwitchInfoColl { get; set; }
Public Property VirtualSwitchInfoColl As VirtualSwitchInfoModel()
    Get
    Set
public:
property array<VirtualSwitchInfoModel^>^ VirtualSwitchInfoColl {
    array<VirtualSwitchInfoModel^>^ get ();
    void set (array<VirtualSwitchInfoModel^>^ value);
}
member VirtualSwitchInfoColl : VirtualSwitchInfoModel[] with get, set

Property Value

Type: VirtualSwitchInfoModel
The virtual switch information coll.
See Also

Reference

VirtualSwitchConfigQueryInputModel Class


VirtualSwitchConfigQueryInputModel.VmId Property

VirtualSwitchConfigQueryInputModelVmId Property
Gets or sets the vm identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string VmId { get; set; }
Public Property VmId As String
    Get
    Set
public:
property String^ VmId {
    String^ get ();
    void set (String^ value);
}
member VmId : string with get, set

Property Value

Type: String
The vm identifier.
See Also

Reference

VirtualSwitchConfigQueryInputModel Class


VirtualSwitchConfigQueryInputModel Methods

VirtualSwitchConfigQueryInputModel Methods

The VirtualSwitchConfigQueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualSwitchConfigQueryInputModel Class


VirtualSwitchConfigQueryResultModel Class

VirtualSwitchConfigQueryResultModel Class
Represents the results of a Virtual Switch config query.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultModel
DoubleTake.Web.ModelsVirtualSwitchConfigQueryResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class VirtualSwitchConfigQueryResultModel : QueryResultModel
Public Class VirtualSwitchConfigQueryResultModel
    Inherits QueryResultModel
public ref class VirtualSwitchConfigQueryResultModel : public QueryResultModel
type VirtualSwitchConfigQueryResultModel =
    class
        inherit QueryResultModel
    end

The VirtualSwitchConfigQueryResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualSwitchConfigQueryResultModel | Initializes a new instance of the VirtualSwitchConfigQueryResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Public property | VirtualSwitchInfoColl | Gets or sets the virtual switch information collection.
Public property | VmId | Gets or sets the vm identifier.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryResultModel


VirtualSwitchConfigQueryResultModel Constructor

VirtualSwitchConfigQueryResultModel Constructor
Initializes a new instance of the VirtualSwitchConfigQueryResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchConfigQueryResultModel()
Public Sub New
public:
VirtualSwitchConfigQueryResultModel()
new : unit -> VirtualSwitchConfigQueryResultModel
See Also

Reference

VirtualSwitchConfigQueryResultModel Class


VirtualSwitchConfigQueryResultModel Properties

VirtualSwitchConfigQueryResultModel Properties

The VirtualSwitchConfigQueryResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Public property | VirtualSwitchInfoColl | Gets or sets the virtual switch information collection.
Public property | VmId | Gets or sets the vm identifier.
Top
See Also

Reference

VirtualSwitchConfigQueryResultModel Class


VirtualSwitchConfigQueryResultModel.VirtualSwitchInfoColl Property

VirtualSwitchConfigQueryResultModelVirtualSwitchInfoColl Property
Gets or sets the virtual switch information collection.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchInfoModel[] VirtualSwitchInfoColl { get; set; }
Public Property VirtualSwitchInfoColl As VirtualSwitchInfoModel()
    Get
    Set
public:
property array<VirtualSwitchInfoModel^>^ VirtualSwitchInfoColl {
    array<VirtualSwitchInfoModel^>^ get ();
    void set (array<VirtualSwitchInfoModel^>^ value);
}
member VirtualSwitchInfoColl : VirtualSwitchInfoModel[] with get, set

Property Value

Type: VirtualSwitchInfoModel
The virtual switch information collection.
See Also

Reference

VirtualSwitchConfigQueryResultModel Class


VirtualSwitchConfigQueryResultModel.VmId Property

VirtualSwitchConfigQueryResultModelVmId Property
Gets or sets the vm identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string VmId { get; set; }
Public Property VmId As String
    Get
    Set
public:
property String^ VmId {
    String^ get ();
    void set (String^ value);
}
member VmId : string with get, set

Property Value

Type: String
The vm identifier.
See Also

Reference

VirtualSwitchConfigQueryResultModel Class


VirtualSwitchConfigQueryResultModel Methods

VirtualSwitchConfigQueryResultModel Methods

The VirtualSwitchConfigQueryResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualSwitchConfigQueryResultModel Class


VirtualSwitchInfoModel Class

VirtualSwitchInfoModel Class
Virtual switch info model
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVirtualSwitchInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VirtualSwitchInfoModel
Public NotInheritable Class VirtualSwitchInfoModel
public ref class VirtualSwitchInfoModel sealed
[<SealedAttribute>]
type VirtualSwitchInfoModel =  class end

The VirtualSwitchInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualSwitchInfoModel | Initializes a new instance of the VirtualSwitchInfoModel class
Top
Properties
 | Name | Description
Public property | Label | Gets or sets a value indicating virtual switch label.
Public property | SwitchUuid | Gets or sets a value indicating virtual switch Guid.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VirtualSwitchInfoModel Constructor

VirtualSwitchInfoModel Constructor
Initializes a new instance of the VirtualSwitchInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchInfoModel()
Public Sub New
public:
VirtualSwitchInfoModel()
new : unit -> VirtualSwitchInfoModel
See Also

Reference

VirtualSwitchInfoModel Class


VirtualSwitchInfoModel Properties

VirtualSwitchInfoModel Properties

The VirtualSwitchInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Label | Gets or sets a value indicating virtual switch label.
Public property | SwitchUuid | Gets or sets a value indicating virtual switch Guid.
Top
See Also

Reference

VirtualSwitchInfoModel Class


VirtualSwitchInfoModel.Label Property

VirtualSwitchInfoModelLabel Property
Gets or sets a value indicating virtual switch label.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Label { get; set; }
Public Property Label As String
    Get
    Set
public:
property String^ Label {
    String^ get ();
    void set (String^ value);
}
member Label : string with get, set

Property Value

Type: String
See Also

Reference

VirtualSwitchInfoModel Class


VirtualSwitchInfoModel.SwitchUuid Property

VirtualSwitchInfoModelSwitchUuid Property
Gets or sets a value indicating virtual switch Guid.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SwitchUuid { get; set; }
Public Property SwitchUuid As String
    Get
    Set
public:
property String^ SwitchUuid {
    String^ get ();
    void set (String^ value);
}
member SwitchUuid : string with get, set

Property Value

Type: String
See Also

Reference

VirtualSwitchInfoModel Class


VirtualSwitchInfoModel Methods

VirtualSwitchInfoModel Methods

The VirtualSwitchInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualSwitchInfoModel Class


VirtualSwitchMappingModel Class

VirtualSwitchMappingModel Class
Virtual switch mapping model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVirtualSwitchMappingModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VirtualSwitchMappingModel
Public NotInheritable Class VirtualSwitchMappingModel
public ref class VirtualSwitchMappingModel sealed
[<SealedAttribute>]
type VirtualSwitchMappingModel =  class end

The VirtualSwitchMappingModel type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualSwitchMappingModel | Initializes a new instance of the VirtualSwitchMappingModel class
Top
Properties
 | Name | Description
Public property | SourceVirtualSwitch | Gets or sets a value indicating source virtual switch.
Public property | TargetVirtualSwitch | Gets or sets a value indicating target virtual switch.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VirtualSwitchMappingModel Constructor

VirtualSwitchMappingModel Constructor
Initializes a new instance of the VirtualSwitchMappingModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchMappingModel()
Public Sub New
public:
VirtualSwitchMappingModel()
new : unit -> VirtualSwitchMappingModel
See Also

Reference

VirtualSwitchMappingModel Class


VirtualSwitchMappingModel Properties

VirtualSwitchMappingModel Properties

The VirtualSwitchMappingModel type exposes the following members.

Properties
 | Name | Description
Public property | SourceVirtualSwitch | Gets or sets a value indicating source virtual switch.
Public property | TargetVirtualSwitch | Gets or sets a value indicating target virtual switch.
Top
See Also

Reference

VirtualSwitchMappingModel Class


VirtualSwitchMappingModel.SourceVirtualSwitch Property

VirtualSwitchMappingModelSourceVirtualSwitch Property
Gets or sets a value indicating source virtual switch.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchInfoModel SourceVirtualSwitch { get; set; }
Public Property SourceVirtualSwitch As VirtualSwitchInfoModel
    Get
    Set
public:
property VirtualSwitchInfoModel^ SourceVirtualSwitch {
    VirtualSwitchInfoModel^ get ();
    void set (VirtualSwitchInfoModel^ value);
}
member SourceVirtualSwitch : VirtualSwitchInfoModel with get, set

Property Value

Type: VirtualSwitchInfoModel
See Also

Reference

VirtualSwitchMappingModel Class


VirtualSwitchMappingModel.TargetVirtualSwitch Property

VirtualSwitchMappingModelTargetVirtualSwitch Property
Gets or sets a value indicating target virtual switch.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchInfoModel TargetVirtualSwitch { get; set; }
Public Property TargetVirtualSwitch As VirtualSwitchInfoModel
    Get
    Set
public:
property VirtualSwitchInfoModel^ TargetVirtualSwitch {
    VirtualSwitchInfoModel^ get ();
    void set (VirtualSwitchInfoModel^ value);
}
member TargetVirtualSwitch : VirtualSwitchInfoModel with get, set

Property Value

Type: VirtualSwitchInfoModel
See Also

Reference

VirtualSwitchMappingModel Class


VirtualSwitchMappingModel Methods

VirtualSwitchMappingModel Methods

The VirtualSwitchMappingModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VirtualSwitchMappingModel Class


VmCfgSimpleInfoModel Class

VmCfgSimpleInfoModel Class
VM configuration simple information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVmCfgSimpleInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class VmCfgSimpleInfoModel
Public Class VmCfgSimpleInfoModel
public ref class VmCfgSimpleInfoModel
type VmCfgSimpleInfoModel =  class end

The VmCfgSimpleInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | VmCfgSimpleInfoModel | Initializes a new instance of the VmCfgSimpleInfoModel class
Top
Properties
 | Name | Description
Public property | BiosGuid | Gets or sets the bios unique identifier.
Public property | ExternalDataRoot | Gets or sets the external data root.
Public property | GuestDNSName | Gets or sets the name of the guest DNS.
Public property | GuestOS | Gets or sets the guest os.
Public property | Name | Gets or sets the name.
Public property | SnapshotDataRoot | Gets or sets the snapshot data root.
Public property | Uuid | Gets or sets the UUID.
Public property | VmHealth | Gets or sets the vm health.
Public property | VmState | Gets or sets the state of the vm.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VmCfgSimpleInfoModel Constructor

VmCfgSimpleInfoModel Constructor
Initializes a new instance of the VmCfgSimpleInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VmCfgSimpleInfoModel()
Public Sub New
public:
VmCfgSimpleInfoModel()
new : unit -> VmCfgSimpleInfoModel
See Also

Reference

VmCfgSimpleInfoModel Class


VmCfgSimpleInfoModel Properties

VmCfgSimpleInfoModel Properties

The VmCfgSimpleInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | BiosGuid | Gets or sets the bios unique identifier.
Public property | ExternalDataRoot | Gets or sets the external data root.
Public property | GuestDNSName | Gets or sets the name of the guest DNS.
Public property | GuestOS | Gets or sets the guest os.
Public property | Name | Gets or sets the name.
Public property | SnapshotDataRoot | Gets or sets the snapshot data root.
Public property | Uuid | Gets or sets the UUID.
Public property | VmHealth | Gets or sets the vm health.
Public property | VmState | Gets or sets the state of the vm.
Top
See Also

Reference

VmCfgSimpleInfoModel Class


VmCfgSimpleInfoModel.BiosGuid Property

VmCfgSimpleInfoModelBiosGuid Property
Gets or sets the bios unique identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string BiosGuid { get; set; }
Public Property BiosGuid As String
    Get
    Set
public:
property String^ BiosGuid {
    String^ get ();
    void set (String^ value);
}
member BiosGuid : string with get, set

Property Value

Type: String
The bios unique identifier.
See Also

Reference

VmCfgSimpleInfoModel Class


VmCfgSimpleInfoModel.ExternalDataRoot Property

VmCfgSimpleInfoModelExternalDataRoot Property
Gets or sets the external data root.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ExternalDataRoot { get; set; }
Public Property ExternalDataRoot As String
    Get
    Set
public:
property String^ ExternalDataRoot {
    String^ get ();
    void set (String^ value);
}
member ExternalDataRoot : string with get, set

Property Value

Type: String
The external data root.
See Also

Reference

VmCfgSimpleInfoModel Class


VmCfgSimpleInfoModel.GuestDNSName Property

VmCfgSimpleInfoModelGuestDNSName Property
Gets or sets the name of the guest DNS.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string GuestDNSName { get; set; }
Public Property GuestDNSName As String
    Get
    Set
public:
property String^ GuestDNSName {
    String^ get ();
    void set (String^ value);
}
member GuestDNSName : string with get, set

Property Value

Type: String
The name of the guest DNS.
See Also

Reference

VmCfgSimpleInfoModel Class


VmCfgSimpleInfoModel.GuestOS Property

VmCfgSimpleInfoModelGuestOS Property
Gets or sets the guest os.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string GuestOS { get; set; }
Public Property GuestOS As String
    Get
    Set
public:
property String^ GuestOS {
    String^ get ();
    void set (String^ value);
}
member GuestOS : string with get, set

Property Value

Type: String
The guest os.
See Also

Reference

VmCfgSimpleInfoModel Class


VmCfgSimpleInfoModel.Name Property

VmCfgSimpleInfoModelName Property
Gets or sets the name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
The name.
See Also

Reference

VmCfgSimpleInfoModel Class


VmCfgSimpleInfoModel.SnapshotDataRoot Property

VmCfgSimpleInfoModelSnapshotDataRoot Property
Gets or sets the snapshot data root.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SnapshotDataRoot { get; set; }
Public Property SnapshotDataRoot As String
    Get
    Set
public:
property String^ SnapshotDataRoot {
    String^ get ();
    void set (String^ value);
}
member SnapshotDataRoot : string with get, set

Property Value

Type: String
The snapshot data root.
See Also

Reference

VmCfgSimpleInfoModel Class


VmCfgSimpleInfoModel.Uuid Property

VmCfgSimpleInfoModelUuid Property
Gets or sets the UUID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string Uuid { get; set; }
Public Property Uuid As String
    Get
    Set
public:
property String^ Uuid {
    String^ get ();
    void set (String^ value);
}
member Uuid : string with get, set

Property Value

Type: String
The UUID.
See Also

Reference

VmCfgSimpleInfoModel Class


VmCfgSimpleInfoModel.VmHealth Property

VmCfgSimpleInfoModelVmHealth Property
Gets or sets the vm health.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VmHealthEnum VmHealth { get; set; }
Public Property VmHealth As VmHealthEnum
    Get
    Set
public:
property VmHealthEnum VmHealth {
    VmHealthEnum get ();
    void set (VmHealthEnum value);
}
member VmHealth : VmHealthEnum with get, set

Property Value

Type: VmHealthEnum
The vm health.
See Also

Reference

VmCfgSimpleInfoModel Class


VmCfgSimpleInfoModel.VmState Property

VmCfgSimpleInfoModelVmState Property
Gets or sets the state of the vm.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int VmState { get; set; }
Public Property VmState As Integer
    Get
    Set
public:
property int VmState {
    int get ();
    void set (int value);
}
member VmState : int with get, set

Property Value

Type: Int32
The state of the vm.
See Also

Reference

VmCfgSimpleInfoModel Class


VmCfgSimpleInfoModel Methods

VmCfgSimpleInfoModel Methods

The VmCfgSimpleInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VmCfgSimpleInfoModel Class


VmConfigQueryInputModel Class

VmConfigQueryInputModel Class
Query inputs for monitoring a VmConfig
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsVmConfigQueryInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class VmConfigQueryInputModel : QueryInputModel
Public Class VmConfigQueryInputModel
    Inherits QueryInputModel
public ref class VmConfigQueryInputModel : public QueryInputModel
type VmConfigQueryInputModel =
    class
        inherit QueryInputModel
    end

The VmConfigQueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | VmConfigQueryInputModel | Initializes a new instance of the VmConfigQueryInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | ExternalDataRoot | Gets or sets the external data root.
Public property | SnapshotDataRoot | Gets or sets the snapshot data root.
Public property | VhdPath | Gets or sets the VHD path.
Public property | VmId | Gets or sets the VM identifier.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryInputModel


VmConfigQueryInputModel Constructor

VmConfigQueryInputModel Constructor
Initializes a new instance of the VmConfigQueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VmConfigQueryInputModel()
Public Sub New
public:
VmConfigQueryInputModel()
new : unit -> VmConfigQueryInputModel
See Also

Reference

VmConfigQueryInputModel Class


VmConfigQueryInputModel Properties

VmConfigQueryInputModel Properties

The VmConfigQueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | ExternalDataRoot | Gets or sets the external data root.
Public property | SnapshotDataRoot | Gets or sets the snapshot data root.
Public property | VhdPath | Gets or sets the VHD path.
Public property | VmId | Gets or sets the VM identifier.
Top
See Also

Reference

VmConfigQueryInputModel Class


VmConfigQueryInputModel.ExternalDataRoot Property

VmConfigQueryInputModelExternalDataRoot Property
Gets or sets the external data root.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string ExternalDataRoot { get; set; }
Public Property ExternalDataRoot As String
    Get
    Set
public:
property String^ ExternalDataRoot {
    String^ get ();
    void set (String^ value);
}
member ExternalDataRoot : string with get, set

Property Value

Type: String
The external data root.
See Also

Reference

VmConfigQueryInputModel Class


VmConfigQueryInputModel.SnapshotDataRoot Property

VmConfigQueryInputModelSnapshotDataRoot Property
Gets or sets the snapshot data root.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SnapshotDataRoot { get; set; }
Public Property SnapshotDataRoot As String
    Get
    Set
public:
property String^ SnapshotDataRoot {
    String^ get ();
    void set (String^ value);
}
member SnapshotDataRoot : string with get, set

Property Value

Type: String
The snapshot data root.
See Also

Reference

VmConfigQueryInputModel Class


VmConfigQueryInputModel.VhdPath Property

VmConfigQueryInputModelVhdPath Property
Gets or sets the VHD path.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string[] VhdPath { get; set; }
Public Property VhdPath As String()
    Get
    Set
public:
property array<String^>^ VhdPath {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member VhdPath : string[] with get, set

Property Value

Type: String
The VHD path.
See Also

Reference

VmConfigQueryInputModel Class


VmConfigQueryInputModel.VmId Property

VmConfigQueryInputModelVmId Property
Gets or sets the VM identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string VmId { get; set; }
Public Property VmId As String
    Get
    Set
public:
property String^ VmId {
    String^ get ();
    void set (String^ value);
}
member VmId : string with get, set

Property Value

Type: String
The VM identifier.
See Also

Reference

VmConfigQueryInputModel Class


VmConfigQueryInputModel Methods

VmConfigQueryInputModel Methods

The VmConfigQueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VmConfigQueryInputModel Class


VmConfigQueryResultModel Class

VmConfigQueryResultModel Class
Represents the results of a Vm config query
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultModel
DoubleTake.Web.ModelsVmConfigQueryResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class VmConfigQueryResultModel : QueryResultModel
Public Class VmConfigQueryResultModel
    Inherits QueryResultModel
public ref class VmConfigQueryResultModel : public QueryResultModel
type VmConfigQueryResultModel =
    class
        inherit QueryResultModel
    end

The VmConfigQueryResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | VmConfigQueryResultModel | Initializes a new instance of the VmConfigQueryResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Public property | VhdPath | Gets or sets the VHD path.
Public property | VirtualSwitchInfoColl | Gets or sets the collection of virtual switch information.
Public property | VmId | Gets or sets the vm identifier.
Public property | VmSnapshotDataRoot | Gets or sets the vm snapshot data root.
Public property | VmSnapshotFileNames | Gets or sets the vm snapshot file names.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryResultModel


VmConfigQueryResultModel Constructor

VmConfigQueryResultModel Constructor
Initializes a new instance of the VmConfigQueryResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VmConfigQueryResultModel()
Public Sub New
public:
VmConfigQueryResultModel()
new : unit -> VmConfigQueryResultModel
See Also

Reference

VmConfigQueryResultModel Class


VmConfigQueryResultModel Properties

VmConfigQueryResultModel Properties

The VmConfigQueryResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Public property | VhdPath | Gets or sets the VHD path.
Public property | VirtualSwitchInfoColl | Gets or sets the collection of virtual switch information.
Public property | VmId | Gets or sets the vm identifier.
Public property | VmSnapshotDataRoot | Gets or sets the vm snapshot data root.
Public property | VmSnapshotFileNames | Gets or sets the vm snapshot file names.
Top
See Also

Reference

VmConfigQueryResultModel Class


VmConfigQueryResultModel.VhdPath Property

VmConfigQueryResultModelVhdPath Property
Gets or sets the VHD path.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string[] VhdPath { get; set; }
Public Property VhdPath As String()
    Get
    Set
public:
property array<String^>^ VhdPath {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member VhdPath : string[] with get, set

Property Value

Type: String
The VHD path.
See Also

Reference

VmConfigQueryResultModel Class


VmConfigQueryResultModel.VirtualSwitchInfoColl Property

VmConfigQueryResultModelVirtualSwitchInfoColl Property
Gets or sets the collection of virtual switch information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchInfoModel[] VirtualSwitchInfoColl { get; set; }
Public Property VirtualSwitchInfoColl As VirtualSwitchInfoModel()
    Get
    Set
public:
property array<VirtualSwitchInfoModel^>^ VirtualSwitchInfoColl {
    array<VirtualSwitchInfoModel^>^ get ();
    void set (array<VirtualSwitchInfoModel^>^ value);
}
member VirtualSwitchInfoColl : VirtualSwitchInfoModel[] with get, set

Property Value

Type: VirtualSwitchInfoModel
The virtual switch information coll.
See Also

Reference

VmConfigQueryResultModel Class


VmConfigQueryResultModel.VmId Property

VmConfigQueryResultModelVmId Property
Gets or sets the vm identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string VmId { get; set; }
Public Property VmId As String
    Get
    Set
public:
property String^ VmId {
    String^ get ();
    void set (String^ value);
}
member VmId : string with get, set

Property Value

Type: String
The vm identifier.
See Also

Reference

VmConfigQueryResultModel Class


VmConfigQueryResultModel.VmSnapshotDataRoot Property

VmConfigQueryResultModelVmSnapshotDataRoot Property
Gets or sets the vm snapshot data root.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string VmSnapshotDataRoot { get; set; }
Public Property VmSnapshotDataRoot As String
    Get
    Set
public:
property String^ VmSnapshotDataRoot {
    String^ get ();
    void set (String^ value);
}
member VmSnapshotDataRoot : string with get, set

Property Value

Type: String
The vm snapshot data root.
See Also

Reference

VmConfigQueryResultModel Class


VmConfigQueryResultModel.VmSnapshotFileNames Property

VmConfigQueryResultModelVmSnapshotFileNames Property
Gets or sets the vm snapshot file names.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string[] VmSnapshotFileNames { get; set; }
Public Property VmSnapshotFileNames As String()
    Get
    Set
public:
property array<String^>^ VmSnapshotFileNames {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member VmSnapshotFileNames : string[] with get, set

Property Value

Type: String
The vm snapshot file names.
See Also

Reference

VmConfigQueryResultModel Class


VmConfigQueryResultModel Methods

VmConfigQueryResultModel Methods

The VmConfigQueryResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VmConfigQueryResultModel Class


VmdkInfoModel Class

VmdkInfoModel Class
VMDK information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVmdkInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class VmdkInfoModel
Public NotInheritable Class VmdkInfoModel
public ref class VmdkInfoModel sealed
[<SealedAttribute>]
type VmdkInfoModel =  class end

The VmdkInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | VmdkInfoModel | Initializes a new instance of the VmdkInfoModel class
Top
Properties
 | Name | Description
Public property | DoDifferenceMirror | Gets or sets a value indicating whether [do difference mirror].
Public property | SourceVmdkUuid | Gets or sets the source VMDK UUID.
Public property | SourceVmUuid | Gets or sets the source VM UUID.
Public property | TargetChangeId | Gets or sets the target change identifier.
Public property | TargetDeviceKey | Gets or sets the target device key.
Public property | TargetDiskOffset | Gets or sets the target disk offset.
Public property | TargetVmdkPath | Gets or sets the target VMDK path.
Public property | TargetVmdkUuid | Gets or sets the target VMDK UUID.
Public property | TargetVmUuid | Gets or sets the target VM UUID.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VmdkInfoModel Constructor

VmdkInfoModel Constructor
Initializes a new instance of the VmdkInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VmdkInfoModel()
Public Sub New
public:
VmdkInfoModel()
new : unit -> VmdkInfoModel
See Also

Reference

VmdkInfoModel Class


VmdkInfoModel Properties

VmdkInfoModel Properties

The VmdkInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | DoDifferenceMirror | Gets or sets a value indicating whether [do difference mirror].
Public property | SourceVmdkUuid | Gets or sets the source VMDK UUID.
Public property | SourceVmUuid | Gets or sets the source VM UUID.
Public property | TargetChangeId | Gets or sets the target change identifier.
Public property | TargetDeviceKey | Gets or sets the target device key.
Public property | TargetDiskOffset | Gets or sets the target disk offset.
Public property | TargetVmdkPath | Gets or sets the target VMDK path.
Public property | TargetVmdkUuid | Gets or sets the target VMDK UUID.
Public property | TargetVmUuid | Gets or sets the target VM UUID.
Top
See Also

Reference

VmdkInfoModel Class


VmdkInfoModel.DoDifferenceMirror Property

VmdkInfoModelDoDifferenceMirror Property
Gets or sets a value indicating whether [do difference mirror].

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool DoDifferenceMirror { get; set; }
Public Property DoDifferenceMirror As Boolean
    Get
    Set
public:
property bool DoDifferenceMirror {
    bool get ();
    void set (bool value);
}
member DoDifferenceMirror : bool with get, set

Property Value

Type: Boolean
true if [do difference mirror]; otherwise, false.
See Also

Reference

VmdkInfoModel Class


VmdkInfoModel.SourceVmdkUuid Property

VmdkInfoModelSourceVmdkUuid Property
Gets or sets the source VMDK UUID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SourceVmdkUuid { get; set; }
Public Property SourceVmdkUuid As String
    Get
    Set
public:
property String^ SourceVmdkUuid {
    String^ get ();
    void set (String^ value);
}
member SourceVmdkUuid : string with get, set

Property Value

Type: String
The source VMDK UUID.
See Also

Reference

VmdkInfoModel Class


VmdkInfoModel.SourceVmUuid Property

VmdkInfoModelSourceVmUuid Property
Gets or sets the source VM UUID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string SourceVmUuid { get; set; }
Public Property SourceVmUuid As String
    Get
    Set
public:
property String^ SourceVmUuid {
    String^ get ();
    void set (String^ value);
}
member SourceVmUuid : string with get, set

Property Value

Type: String
The source VM UUID.
See Also

Reference

VmdkInfoModel Class


VmdkInfoModel.TargetChangeId Property

VmdkInfoModelTargetChangeId Property
Gets or sets the target change identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string TargetChangeId { get; set; }
Public Property TargetChangeId As String
    Get
    Set
public:
property String^ TargetChangeId {
    String^ get ();
    void set (String^ value);
}
member TargetChangeId : string with get, set

Property Value

Type: String
The target change identifier.
See Also

Reference

VmdkInfoModel Class


VmdkInfoModel.TargetDeviceKey Property

VmdkInfoModelTargetDeviceKey Property
Gets or sets the target device key.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int TargetDeviceKey { get; set; }
Public Property TargetDeviceKey As Integer
    Get
    Set
public:
property int TargetDeviceKey {
    int get ();
    void set (int value);
}
member TargetDeviceKey : int with get, set

Property Value

Type: Int32
The target device key.
See Also

Reference

VmdkInfoModel Class


VmdkInfoModel.TargetDiskOffset Property

VmdkInfoModelTargetDiskOffset Property
Gets or sets the target disk offset.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public long TargetDiskOffset { get; set; }
Public Property TargetDiskOffset As Long
    Get
    Set
public:
property long long TargetDiskOffset {
    long long get ();
    void set (long long value);
}
member TargetDiskOffset : int64 with get, set

Property Value

Type: Int64
The target disk offset.
See Also

Reference

VmdkInfoModel Class


VmdkInfoModel.TargetVmdkPath Property

VmdkInfoModelTargetVmdkPath Property
Gets or sets the target VMDK path.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string TargetVmdkPath { get; set; }
Public Property TargetVmdkPath As String
    Get
    Set
public:
property String^ TargetVmdkPath {
    String^ get ();
    void set (String^ value);
}
member TargetVmdkPath : string with get, set

Property Value

Type: String
The target VMDK path.
See Also

Reference

VmdkInfoModel Class


VmdkInfoModel.TargetVmdkUuid Property

VmdkInfoModelTargetVmdkUuid Property
Gets or sets the target VMDK UUID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string TargetVmdkUuid { get; set; }
Public Property TargetVmdkUuid As String
    Get
    Set
public:
property String^ TargetVmdkUuid {
    String^ get ();
    void set (String^ value);
}
member TargetVmdkUuid : string with get, set

Property Value

Type: String
The target VMDK UUID.
See Also

Reference

VmdkInfoModel Class


VmdkInfoModel.TargetVmUuid Property

VmdkInfoModelTargetVmUuid Property
Gets or sets the target VM UUID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string TargetVmUuid { get; set; }
Public Property TargetVmUuid As String
    Get
    Set
public:
property String^ TargetVmUuid {
    String^ get ();
    void set (String^ value);
}
member TargetVmUuid : string with get, set

Property Value

Type: String
The target VM UUID.
See Also

Reference

VmdkInfoModel Class


VmdkInfoModel Methods

VmdkInfoModel Methods

The VmdkInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VmdkInfoModel Class


VmHealthEnum Enumeration

VmHealthEnum Enumeration
VM health

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public enum VmHealthEnum
Public Enumeration VmHealthEnum
public enum class VmHealthEnum
type VmHealthEnum
Members
Member name | Value | Description
Good | 0 | The good
Bad | 1 | The bad
Dormant | 2 | The dormant
See Also

Reference

DoubleTake.Web.Models Namespace


VmHealthQueryInputModel Class

VmHealthQueryInputModel Class
Query input for monitoring the health of a vm
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryInputModel
DoubleTake.Web.ModelsVmHealthQueryInputModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class VmHealthQueryInputModel : QueryInputModel
Public Class VmHealthQueryInputModel
    Inherits QueryInputModel
public ref class VmHealthQueryInputModel : public QueryInputModel
type VmHealthQueryInputModel =
    class
        inherit QueryInputModel
    end

The VmHealthQueryInputModel type exposes the following members.

Constructors
 | Name | Description
Public method | VmHealthQueryInputModel | Initializes a new instance of the VmHealthQueryInputModel class
Top
Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | VmId | Gets or sets the vm identifier.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryInputModel


VmHealthQueryInputModel Constructor

VmHealthQueryInputModel Constructor
Initializes a new instance of the VmHealthQueryInputModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VmHealthQueryInputModel()
Public Sub New
public:
VmHealthQueryInputModel()
new : unit -> VmHealthQueryInputModel
See Also

Reference

VmHealthQueryInputModel Class


VmHealthQueryInputModel Properties

VmHealthQueryInputModel Properties

The VmHealthQueryInputModel type exposes the following members.

Properties
 | Name | Description
Public property | Credentials | Gets or sets the credentials to be used by the query. (Inherited from QueryInputModel.)
Public property | VmId | Gets or sets the vm identifier.
Top
See Also

Reference

VmHealthQueryInputModel Class


VmHealthQueryInputModel.VmId Property

VmHealthQueryInputModelVmId Property
Gets or sets the vm identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string VmId { get; set; }
Public Property VmId As String
    Get
    Set
public:
property String^ VmId {
    String^ get ();
    void set (String^ value);
}
member VmId : string with get, set

Property Value

Type: String
The vm identifier.
See Also

Reference

VmHealthQueryInputModel Class


VmHealthQueryInputModel Methods

VmHealthQueryInputModel Methods

The VmHealthQueryInputModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VmHealthQueryInputModel Class


VmHealthQueryResultModel Class

VmHealthQueryResultModel Class
Represents the results of a Vm health query
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsQueryResultModel
DoubleTake.Web.ModelsVmHealthQueryResultModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class VmHealthQueryResultModel : QueryResultModel
Public Class VmHealthQueryResultModel
    Inherits QueryResultModel
public ref class VmHealthQueryResultModel : public QueryResultModel
type VmHealthQueryResultModel =
    class
        inherit QueryResultModel
    end

The VmHealthQueryResultModel type exposes the following members.

Constructors
 | Name | Description
Public method | VmHealthQueryResultModel | Initializes a new instance of the VmHealthQueryResultModel class
Top
Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Public property | VmId | Gets or sets the vm identifier.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsQueryResultModel


VmHealthQueryResultModel Constructor

VmHealthQueryResultModel Constructor
Initializes a new instance of the VmHealthQueryResultModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VmHealthQueryResultModel()
Public Sub New
public:
VmHealthQueryResultModel()
new : unit -> VmHealthQueryResultModel
See Also

Reference

VmHealthQueryResultModel Class


VmHealthQueryResultModel Properties

VmHealthQueryResultModel Properties

The VmHealthQueryResultModel type exposes the following members.

Properties
 | Name | Description
Public property | Exception | Gets or sets the query exception. (Inherited from QueryResultModel.)
Public property | Result | Gets or sets a value indicating whether or not the query was successful. (Inherited from QueryResultModel.)
Public property | VmId | Gets or sets the vm identifier.
Top
See Also

Reference

VmHealthQueryResultModel Class


VmHealthQueryResultModel.VmId Property

VmHealthQueryResultModelVmId Property
Gets or sets the vm identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string VmId { get; set; }
Public Property VmId As String
    Get
    Set
public:
property String^ VmId {
    String^ get ();
    void set (String^ value);
}
member VmId : string with get, set

Property Value

Type: String
The vm identifier.
See Also

Reference

VmHealthQueryResultModel Class


VmHealthQueryResultModel Methods

VmHealthQueryResultModel Methods

The VmHealthQueryResultModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VmHealthQueryResultModel Class


VmInfoModel Class

VmInfoModel Class
Vm info model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVmInfoModel
DoubleTake.Web.ModelsReplicaVmInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public class VmInfoModel
Public Class VmInfoModel
public ref class VmInfoModel
type VmInfoModel =  class end

The VmInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | VmInfoModel | Initializes a new instance of the VmInfoModel class
Top
Properties
 | Name | Description
Public property | Address | Gets or sets the virtual machine guest DNS name/IP Address.
Public property | BiosGuid | Gets or sets the virtual machine BIOS Guid.
Public property | BootVolumeSignature | Gets or sets the VM boot volume signature.
Public property | DisplayName | Gets or sets the virtual machine display name.
Public property | GuestOS | Gets or sets the virtual machine guest OS.
Public property | GuestUri | Gets or sets the guest URI.
Public property | Id | Gets or sets the virtual machine Guid.
Public property | Path | Gets or sets the virtual machine location.
Public property | PathTransformations | Gets or sets the path transformations.
Public property | SnapshotDataPath | Gets or sets the virtual machine snapshot location.
Public property | SnapshotFileNames | Gets or sets the VM snapshot FileNames.
Public property | SystemDirectory | Gets or sets the VM system directory.
Public property | VirtualHardDiskPath | Gets or sets the virtual hard disk path.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VmInfoModel Constructor

VmInfoModel Constructor
Initializes a new instance of the VmInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VmInfoModel()
Public Sub New
public:
VmInfoModel()
new : unit -> VmInfoModel
See Also

Reference

VmInfoModel Class


VmInfoModel Properties

VmInfoModel Properties

The VmInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | Address | Gets or sets the virtual machine guest DNS name/IP Address.
Public property | BiosGuid | Gets or sets the virtual machine BIOS Guid.
Public property | BootVolumeSignature | Gets or sets the VM boot volume signature.
Public property | DisplayName | Gets or sets the virtual machine display name.
Public property | GuestOS | Gets or sets the virtual machine guest OS.
Public property | GuestUri | Gets or sets the guest URI.
Public property | Id | Gets or sets the virtual machine Guid.
Public property | Path | Gets or sets the virtual machine location.
Public property | PathTransformations | Gets or sets the path transformations.
Public property | SnapshotDataPath | Gets or sets the virtual machine snapshot location.
Public property | SnapshotFileNames | Gets or sets the VM snapshot FileNames.
Public property | SystemDirectory | Gets or sets the VM system directory.
Public property | VirtualHardDiskPath | Gets or sets the virtual hard disk path.
Top
See Also

Reference

VmInfoModel Class


VmInfoModel.Address Property

VmInfoModelAddress Property
Gets or sets the virtual machine guest DNS name/IP Address.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Address { get; set; }
Public Property Address As String
    Get
    Set
public:
property String^ Address {
    String^ get ();
    void set (String^ value);
}
member Address : string with get, set

Property Value

Type: String
See Also

Reference

VmInfoModel Class


VmInfoModel.BiosGuid Property

VmInfoModelBiosGuid Property
Gets or sets the virtual machine BIOS Guid.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Guid BiosGuid { get; set; }
Public Property BiosGuid As Guid
    Get
    Set
public:
property Guid BiosGuid {
    Guid get ();
    void set (Guid value);
}
member BiosGuid : Guid with get, set

Property Value

Type: Guid
See Also

Reference

VmInfoModel Class


VmInfoModel.BootVolumeSignature Property

VmInfoModelBootVolumeSignature Property
Gets or sets the VM boot volume signature.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] BootVolumeSignature { get; set; }
Public Property BootVolumeSignature As Byte()
    Get
    Set
public:
property array<unsigned char>^ BootVolumeSignature {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member BootVolumeSignature : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

VmInfoModel Class


VmInfoModel.DisplayName Property

VmInfoModelDisplayName Property
Gets or sets the virtual machine display name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string DisplayName { get; set; }
Public Property DisplayName As String
    Get
    Set
public:
property String^ DisplayName {
    String^ get ();
    void set (String^ value);
}
member DisplayName : string with get, set

Property Value

Type: String
See Also

Reference

VmInfoModel Class


VmInfoModel.GuestOS Property

VmInfoModelGuestOS Property
Gets or sets the virtual machine guest OS.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string GuestOS { get; set; }
Public Property GuestOS As String
    Get
    Set
public:
property String^ GuestOS {
    String^ get ();
    void set (String^ value);
}
member GuestOS : string with get, set

Property Value

Type: String
See Also

Reference

VmInfoModel Class


VmInfoModel.GuestUri Property

VmInfoModelGuestUri Property
Gets or sets the guest URI.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Uri GuestUri { get; set; }
Public Property GuestUri As Uri
    Get
    Set
public:
property Uri^ GuestUri {
    Uri^ get ();
    void set (Uri^ value);
}
member GuestUri : Uri with get, set

Property Value

Type: Uri
See Also

Reference

VmInfoModel Class


VmInfoModel.Id Property

VmInfoModelId Property
Gets or sets the virtual machine Guid.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
member Id : Guid with get, set

Property Value

Type: Guid
See Also

Reference

VmInfoModel Class


VmInfoModel.Path Property

VmInfoModelPath Property
Gets or sets the virtual machine location.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}
member Path : string with get, set

Property Value

Type: String
See Also

Reference

VmInfoModel Class


VmInfoModel.PathTransformations Property

VmInfoModelPathTransformations Property
Gets or sets the path transformations.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public PathTransformationModel[] PathTransformations { get; set; }
Public Property PathTransformations As PathTransformationModel()
    Get
    Set
public:
property array<PathTransformationModel^>^ PathTransformations {
    array<PathTransformationModel^>^ get ();
    void set (array<PathTransformationModel^>^ value);
}
member PathTransformations : PathTransformationModel[] with get, set

Property Value

Type: PathTransformationModel
See Also

Reference

VmInfoModel Class


VmInfoModel.SnapshotDataPath Property

VmInfoModelSnapshotDataPath Property
Gets or sets the virtual machine snapshot location.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SnapshotDataPath { get; set; }
Public Property SnapshotDataPath As String
    Get
    Set
public:
property String^ SnapshotDataPath {
    String^ get ();
    void set (String^ value);
}
member SnapshotDataPath : string with get, set

Property Value

Type: String
See Also

Reference

VmInfoModel Class


VmInfoModel.SnapshotFileNames Property

VmInfoModelSnapshotFileNames Property
Gets or sets the VM snapshot FileNames.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] SnapshotFileNames { get; set; }
Public Property SnapshotFileNames As String()
    Get
    Set
public:
property array<String^>^ SnapshotFileNames {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member SnapshotFileNames : string[] with get, set

Property Value

Type: String
See Also

Reference

VmInfoModel Class


VmInfoModel.SystemDirectory Property

VmInfoModelSystemDirectory Property
Gets or sets the VM system directory.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SystemDirectory { get; set; }
Public Property SystemDirectory As String
    Get
    Set
public:
property String^ SystemDirectory {
    String^ get ();
    void set (String^ value);
}
member SystemDirectory : string with get, set

Property Value

Type: String
See Also

Reference

VmInfoModel Class


VmInfoModel.VirtualHardDiskPath Property

VmInfoModelVirtualHardDiskPath Property
Gets or sets the virtual hard disk path.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] VirtualHardDiskPath { get; set; }
Public Property VirtualHardDiskPath As String()
    Get
    Set
public:
property array<String^>^ VirtualHardDiskPath {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member VirtualHardDiskPath : string[] with get, set

Property Value

Type: String
See Also

Reference

VmInfoModel Class


VmInfoModel Methods

VmInfoModel Methods

The VmInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VmInfoModel Class


VolumeGroupModel Class

VolumeGroupModel Class
Volume group model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVolumeGroupModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VolumeGroupModel
Public NotInheritable Class VolumeGroupModel
public ref class VolumeGroupModel sealed
[<SealedAttribute>]
type VolumeGroupModel =  class end

The VolumeGroupModel type exposes the following members.

Constructors
 | Name | Description
Public method | VolumeGroupModel | Initializes a new instance of the VolumeGroupModel class
Top
Properties
 | Name | Description
Public property | LogicalVolumes | Gets or sets the list of logical volumes.
Public property | MaxPhysicalVolumeSize | Gets or sets the maximum size of the physical volume
Public property | Name | Gets or sets the volume group name.
Public property | PhysicalVolumes | Gets or sets the list of physical volumes.
Public property | PreexistingDiskPaths | Gets or sets the preexisting disk paths.
Public property | SourceVolumeGroupSize | Gets or sets the size of the source volume group.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VolumeGroupModel Constructor

VolumeGroupModel Constructor
Initializes a new instance of the VolumeGroupModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VolumeGroupModel()
Public Sub New
public:
VolumeGroupModel()
new : unit -> VolumeGroupModel
See Also

Reference

VolumeGroupModel Class


VolumeGroupModel Properties

VolumeGroupModel Properties

The VolumeGroupModel type exposes the following members.

Properties
 | Name | Description
Public property | LogicalVolumes | Gets or sets the list of logical volumes.
Public property | MaxPhysicalVolumeSize | Gets or sets the maximum size of the physical volume
Public property | Name | Gets or sets the volume group name.
Public property | PhysicalVolumes | Gets or sets the list of physical volumes.
Public property | PreexistingDiskPaths | Gets or sets the preexisting disk paths.
Public property | SourceVolumeGroupSize | Gets or sets the size of the source volume group.
Top
See Also

Reference

VolumeGroupModel Class


VolumeGroupModel.LogicalVolumes Property

VolumeGroupModelLogicalVolumes Property
Gets or sets the list of logical volumes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public LogicalVolumeModel[] LogicalVolumes { get; set; }
Public Property LogicalVolumes As LogicalVolumeModel()
    Get
    Set
public:
property array<LogicalVolumeModel^>^ LogicalVolumes {
    array<LogicalVolumeModel^>^ get ();
    void set (array<LogicalVolumeModel^>^ value);
}
member LogicalVolumes : LogicalVolumeModel[] with get, set

Property Value

Type: LogicalVolumeModel
See Also

Reference

VolumeGroupModel Class


VolumeGroupModel.MaxPhysicalVolumeSize Property

VolumeGroupModelMaxPhysicalVolumeSize Property
Gets or sets the maximum size of the physical volume

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long MaxPhysicalVolumeSize { get; set; }
Public Property MaxPhysicalVolumeSize As Long
    Get
    Set
public:
property long long MaxPhysicalVolumeSize {
    long long get ();
    void set (long long value);
}
member MaxPhysicalVolumeSize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

VolumeGroupModel Class


VolumeGroupModel.Name Property

VolumeGroupModelName Property
Gets or sets the volume group name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

VolumeGroupModel Class


VolumeGroupModel.PhysicalVolumes Property

VolumeGroupModelPhysicalVolumes Property
Gets or sets the list of physical volumes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public PhysicalVolumeModel[] PhysicalVolumes { get; set; }
Public Property PhysicalVolumes As PhysicalVolumeModel()
    Get
    Set
public:
property array<PhysicalVolumeModel^>^ PhysicalVolumes {
    array<PhysicalVolumeModel^>^ get ();
    void set (array<PhysicalVolumeModel^>^ value);
}
member PhysicalVolumes : PhysicalVolumeModel[] with get, set

Property Value

Type: PhysicalVolumeModel
See Also

Reference

VolumeGroupModel Class


VolumeGroupModel.PreexistingDiskPaths Property

VolumeGroupModelPreexistingDiskPaths Property
Gets or sets the preexisting disk paths.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] PreexistingDiskPaths { get; set; }
Public Property PreexistingDiskPaths As String()
    Get
    Set
public:
property array<String^>^ PreexistingDiskPaths {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member PreexistingDiskPaths : string[] with get, set

Property Value

Type: String
See Also

Reference

VolumeGroupModel Class


VolumeGroupModel.SourceVolumeGroupSize Property

VolumeGroupModelSourceVolumeGroupSize Property
Gets or sets the size of the source volume group.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long SourceVolumeGroupSize { get; set; }
Public Property SourceVolumeGroupSize As Long
    Get
    Set
public:
property long long SourceVolumeGroupSize {
    long long get ();
    void set (long long value);
}
member SourceVolumeGroupSize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

VolumeGroupModel Class


VolumeGroupModel Methods

VolumeGroupModel Methods

The VolumeGroupModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VolumeGroupModel Class


VolumeModel Class

VolumeModel Class
Volume model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsProtectableItemModel
DoubleTake.Web.ModelsPhysicalItemModel
DoubleTake.Web.ModelsVolumeModel
DoubleTake.Web.ModelsVolumeOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public class VolumeModel : PhysicalItemModel
Public Class VolumeModel
    Inherits PhysicalItemModel
public ref class VolumeModel : public PhysicalItemModel
type VolumeModel =
    class
        inherit PhysicalItemModel
    end

The VolumeModel type exposes the following members.

Constructors
 | Name | Description
Public method | VolumeModel | Initializes a new instance of the VolumeModel class
Top
Properties
 | Name | Description
Public property | Attributes | Gets or sets a value specifying the file system attributes of this item. (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | Gets or sets the available free space on this volume. (Inherited from PhysicalItemModel.)
Public property | ClassName | Gets or sets the class name. (Inherited from PhysicalItemModel.)
Public property | CreationTime | Gets or sets a value specifying the time this item was created. (Inherited from PhysicalItemModel.)
Public property | DriveFormat | Gets or sets the format of the drive. (Inherited from PhysicalItemModel.)
Public property | DriveType | Gets or sets the type of the drive. (Inherited from PhysicalItemModel.)
Public property | Id | Gets or sets the item identifier. (Inherited from ProtectableItemModel.)
Public property | IsContainer | Gets or sets a value indicating whether or not this item is a container of other items. (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | Gets or sets a value indicating whether or not this item is read only; that is, its Saturation cannot be changed. (Inherited from ProtectableItemModel.)
Public property | IsSupported | Gets or sets a value indicating whether this volume is supported. (Inherited from PhysicalItemModel.)
Public property | IsSystemDrive | Gets or sets a value indicating whether or not this volume is the system drive. (Inherited from PhysicalItemModel.)
Public property | ItemType | Gets or sets the type of this item. (Inherited from ProtectableItemModel.)
Public property | Label | Gets or sets the volume label. (Inherited from PhysicalItemModel.)
Public property | LastAccessTime | Gets or sets a value specifying the time this item was last accessed. (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | Gets or sets a value specifying the time this item was last written to. (Inherited from PhysicalItemModel.)
Public property | Metadata | Gets or sets a value specifying additional meta data for this item. (Inherited from PhysicalItemModel.)
Public property | Name | Gets or sets the name of this item. (Inherited from ProtectableItemModel.)
Public property | PartitionName | Gets or sets the partition name. (Inherited from ProtectableItemModel.)
Public property | Path | Gets or sets the path that uniquely identifies this item. (Inherited from ProtectableItemModel.)
Public property | Saturation | Gets or sets the saturation level of this item. (Inherited from ProtectableItemModel.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume. (Inherited from PhysicalItemModel.)
Public property | Size | Gets or sets a value indicating the physical size of the item. (Inherited from PhysicalItemModel.)
Public property | TotalSize | Gets or sets the total size of the volume. (Inherited from PhysicalItemModel.)
Public property | VolumeType | Gets or sets the volume type. (Inherited from PhysicalItemModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VolumeModel Constructor

VolumeModel Constructor
Initializes a new instance of the VolumeModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VolumeModel()
Public Sub New
public:
VolumeModel()
new : unit -> VolumeModel
See Also

Reference

VolumeModel Class


VolumeModel Properties

VolumeModel Properties

The VolumeModel type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets or sets a value specifying the file system attributes of this item. (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | Gets or sets the available free space on this volume. (Inherited from PhysicalItemModel.)
Public property | ClassName | Gets or sets the class name. (Inherited from PhysicalItemModel.)
Public property | CreationTime | Gets or sets a value specifying the time this item was created. (Inherited from PhysicalItemModel.)
Public property | DriveFormat | Gets or sets the format of the drive. (Inherited from PhysicalItemModel.)
Public property | DriveType | Gets or sets the type of the drive. (Inherited from PhysicalItemModel.)
Public property | Id | Gets or sets the item identifier. (Inherited from ProtectableItemModel.)
Public property | IsContainer | Gets or sets a value indicating whether or not this item is a container of other items. (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | Gets or sets a value indicating whether or not this item is read only; that is, its Saturation cannot be changed. (Inherited from ProtectableItemModel.)
Public property | IsSupported | Gets or sets a value indicating whether this volume is supported. (Inherited from PhysicalItemModel.)
Public property | IsSystemDrive | Gets or sets a value indicating whether or not this volume is the system drive. (Inherited from PhysicalItemModel.)
Public property | ItemType | Gets or sets the type of this item. (Inherited from ProtectableItemModel.)
Public property | Label | Gets or sets the volume label. (Inherited from PhysicalItemModel.)
Public property | LastAccessTime | Gets or sets a value specifying the time this item was last accessed. (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | Gets or sets a value specifying the time this item was last written to. (Inherited from PhysicalItemModel.)
Public property | Metadata | Gets or sets a value specifying additional meta data for this item. (Inherited from PhysicalItemModel.)
Public property | Name | Gets or sets the name of this item. (Inherited from ProtectableItemModel.)
Public property | PartitionName | Gets or sets the partition name. (Inherited from ProtectableItemModel.)
Public property | Path | Gets or sets the path that uniquely identifies this item. (Inherited from ProtectableItemModel.)
Public property | Saturation | Gets or sets the saturation level of this item. (Inherited from ProtectableItemModel.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume. (Inherited from PhysicalItemModel.)
Public property | Size | Gets or sets a value indicating the physical size of the item. (Inherited from PhysicalItemModel.)
Public property | TotalSize | Gets or sets the total size of the volume. (Inherited from PhysicalItemModel.)
Public property | VolumeType | Gets or sets the volume type. (Inherited from PhysicalItemModel.)
Top
See Also

Reference

VolumeModel Class


VolumeModel Methods

VolumeModel Methods

The VolumeModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VolumeModel Class


VolumeOptionsModel Class

VolumeOptionsModel Class
Volume options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsProtectableItemModel
DoubleTake.Web.ModelsPhysicalItemModel
DoubleTake.Web.ModelsVolumeModel
DoubleTake.Web.ModelsVolumeOptionsModel
DoubleTake.Web.ModelsLogicalVolumeModel
DoubleTake.Web.ModelsPhysicalVolumeModel
DoubleTake.Web.ModelsUVRAVolumePersistedStateModel
DoubleTake.Web.ModelsVRAVolumePersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public class VolumeOptionsModel : VolumeModel
Public Class VolumeOptionsModel
    Inherits VolumeModel
public ref class VolumeOptionsModel : public VolumeModel
type VolumeOptionsModel =
    class
        inherit VolumeModel
    end

The VolumeOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | VolumeOptionsModel | Initializes a new instance of the VolumeOptionsModel class
Top
Properties
 | Name | Description
Public property | Attributes | Gets or sets a value specifying the file system attributes of this item. (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | Gets or sets the available free space on this volume. (Inherited from PhysicalItemModel.)
Public property | ClassName | Gets or sets the class name. (Inherited from PhysicalItemModel.)
Public property | CreationTime | Gets or sets a value specifying the time this item was created. (Inherited from PhysicalItemModel.)
Public property | DesiredSize | Gets or sets the size that the user wants the drive to be.
Public property | DiskControllerType | Gets or sets the type of the disk controller.
Public property | DiskProvisioningType | Gets or sets the type of the disk provisioning.
Public property | DriveFormat | Gets or sets the format of the drive. (Inherited from PhysicalItemModel.)
Public property | DriveType | Gets or sets the type of the drive. (Inherited from PhysicalItemModel.)
Public property | Id | Gets or sets the item identifier. (Inherited from ProtectableItemModel.)
Public property | IsContainer | Gets or sets a value indicating whether or not this item is a container of other items. (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | Gets or sets a value indicating whether or not this item is read only; that is, its Saturation cannot be changed. (Inherited from ProtectableItemModel.)
Public property | IsSupported | Gets or sets a value indicating whether this volume is supported. (Inherited from PhysicalItemModel.)
Public property | IsSystemDrive | Gets or sets a value indicating whether or not this volume is the system drive. (Inherited from PhysicalItemModel.)
Public property | ItemType | Gets or sets the type of this item. (Inherited from ProtectableItemModel.)
Public property | Label | Gets or sets the volume label. (Inherited from PhysicalItemModel.)
Public property | LastAccessTime | Gets or sets a value specifying the time this item was last accessed. (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | Gets or sets a value specifying the time this item was last written to. (Inherited from PhysicalItemModel.)
Public property | Metadata | Gets or sets a value specifying additional meta data for this item. (Inherited from PhysicalItemModel.)
Public property | Name | Gets or sets the name of this item. (Inherited from ProtectableItemModel.)
Public property | PartitionName | Gets or sets the partition name. (Inherited from ProtectableItemModel.)
Public property | Path | Gets or sets the path that uniquely identifies this item. (Inherited from ProtectableItemModel.)
Public property | PreexistingDiskPath | Gets or sets the path of preexisting disk.
Public property | Saturation | Gets or sets the saturation level of this item. (Inherited from ProtectableItemModel.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume. (Inherited from PhysicalItemModel.)
Public property | Size | Gets or sets a value indicating the physical size of the item. (Inherited from PhysicalItemModel.)
Public property | TotalSize | Gets or sets the total size of the volume. (Inherited from PhysicalItemModel.)
Public property | VirtualDiskPath | Gets or sets the path on the host where the volume should be stored.
Public property | VolumeSignature | Gets or sets the volume signature.
Public property | VolumeType | Gets or sets the volume type. (Inherited from PhysicalItemModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VolumeOptionsModel Constructor

VolumeOptionsModel Constructor
Initializes a new instance of the VolumeOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VolumeOptionsModel()
Public Sub New
public:
VolumeOptionsModel()
new : unit -> VolumeOptionsModel
See Also

Reference

VolumeOptionsModel Class


VolumeOptionsModel Properties

VolumeOptionsModel Properties

The VolumeOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets or sets a value specifying the file system attributes of this item. (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | Gets or sets the available free space on this volume. (Inherited from PhysicalItemModel.)
Public property | ClassName | Gets or sets the class name. (Inherited from PhysicalItemModel.)
Public property | CreationTime | Gets or sets a value specifying the time this item was created. (Inherited from PhysicalItemModel.)
Public property | DesiredSize | Gets or sets the size that the user wants the drive to be.
Public property | DiskControllerType | Gets or sets the type of the disk controller.
Public property | DiskProvisioningType | Gets or sets the type of the disk provisioning.
Public property | DriveFormat | Gets or sets the format of the drive. (Inherited from PhysicalItemModel.)
Public property | DriveType | Gets or sets the type of the drive. (Inherited from PhysicalItemModel.)
Public property | Id | Gets or sets the item identifier. (Inherited from ProtectableItemModel.)
Public property | IsContainer | Gets or sets a value indicating whether or not this item is a container of other items. (Inherited from ProtectableItemModel.)
Public property | IsReadOnly | Gets or sets a value indicating whether or not this item is read only; that is, its Saturation cannot be changed. (Inherited from ProtectableItemModel.)
Public property | IsSupported | Gets or sets a value indicating whether this volume is supported. (Inherited from PhysicalItemModel.)
Public property | IsSystemDrive | Gets or sets a value indicating whether or not this volume is the system drive. (Inherited from PhysicalItemModel.)
Public property | ItemType | Gets or sets the type of this item. (Inherited from ProtectableItemModel.)
Public property | Label | Gets or sets the volume label. (Inherited from PhysicalItemModel.)
Public property | LastAccessTime | Gets or sets a value specifying the time this item was last accessed. (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | Gets or sets a value specifying the time this item was last written to. (Inherited from PhysicalItemModel.)
Public property | Metadata | Gets or sets a value specifying additional meta data for this item. (Inherited from PhysicalItemModel.)
Public property | Name | Gets or sets the name of this item. (Inherited from ProtectableItemModel.)
Public property | PartitionName | Gets or sets the partition name. (Inherited from ProtectableItemModel.)
Public property | Path | Gets or sets the path that uniquely identifies this item. (Inherited from ProtectableItemModel.)
Public property | PreexistingDiskPath | Gets or sets the path of preexisting disk.
Public property | Saturation | Gets or sets the saturation level of this item. (Inherited from ProtectableItemModel.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume. (Inherited from PhysicalItemModel.)
Public property | Size | Gets or sets a value indicating the physical size of the item. (Inherited from PhysicalItemModel.)
Public property | TotalSize | Gets or sets the total size of the volume. (Inherited from PhysicalItemModel.)
Public property | VirtualDiskPath | Gets or sets the path on the host where the volume should be stored.
Public property | VolumeSignature | Gets or sets the volume signature.
Public property | VolumeType | Gets or sets the volume type. (Inherited from PhysicalItemModel.)
Top
See Also

Reference

VolumeOptionsModel Class


VolumeOptionsModel.DesiredSize Property

VolumeOptionsModelDesiredSize Property
Gets or sets the size that the user wants the drive to be.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long DesiredSize { get; set; }
Public Property DesiredSize As Long
    Get
    Set
public:
property long long DesiredSize {
    long long get ();
    void set (long long value);
}
member DesiredSize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

VolumeOptionsModel Class


VolumeOptionsModel.DiskControllerType Property

VolumeOptionsModelDiskControllerType Property
Gets or sets the type of the disk controller.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string DiskControllerType { get; set; }
Public Property DiskControllerType As String
    Get
    Set
public:
property String^ DiskControllerType {
    String^ get ();
    void set (String^ value);
}
member DiskControllerType : string with get, set

Property Value

Type: String
See Also

Reference

VolumeOptionsModel Class


VolumeOptionsModel.DiskProvisioningType Property

VolumeOptionsModelDiskProvisioningType Property
Gets or sets the type of the disk provisioning.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string DiskProvisioningType { get; set; }
Public Property DiskProvisioningType As String
    Get
    Set
public:
property String^ DiskProvisioningType {
    String^ get ();
    void set (String^ value);
}
member DiskProvisioningType : string with get, set

Property Value

Type: String
See Also

Reference

VolumeOptionsModel Class


VolumeOptionsModel.PreexistingDiskPath Property

VolumeOptionsModelPreexistingDiskPath Property
Gets or sets the path of preexisting disk.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string PreexistingDiskPath { get; set; }
Public Property PreexistingDiskPath As String
    Get
    Set
public:
property String^ PreexistingDiskPath {
    String^ get ();
    void set (String^ value);
}
member PreexistingDiskPath : string with get, set

Property Value

Type: String
See Also

Reference

VolumeOptionsModel Class


VolumeOptionsModel.VirtualDiskPath Property

VolumeOptionsModelVirtualDiskPath Property
Gets or sets the path on the host where the volume should be stored.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string VirtualDiskPath { get; set; }
Public Property VirtualDiskPath As String
    Get
    Set
public:
property String^ VirtualDiskPath {
    String^ get ();
    void set (String^ value);
}
member VirtualDiskPath : string with get, set

Property Value

Type: String
See Also

Reference

VolumeOptionsModel Class


VolumeOptionsModel.VolumeSignature Property

VolumeOptionsModelVolumeSignature Property
Gets or sets the volume signature.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public byte[] VolumeSignature { get; set; }
Public Property VolumeSignature As Byte()
    Get
    Set
public:
property array<unsigned char>^ VolumeSignature {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member VolumeSignature : byte[] with get, set

Property Value

Type: Byte
See Also

Reference

VolumeOptionsModel Class


VolumeOptionsModel Methods

VolumeOptionsModel Methods

The VolumeOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VolumeOptionsModel Class


VolumeQualificationResultsModel Class

VolumeQualificationResultsModel Class
Volume qualification results model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVolumeQualificationResultsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VolumeQualificationResultsModel
Public NotInheritable Class VolumeQualificationResultsModel
public ref class VolumeQualificationResultsModel sealed
[<SealedAttribute>]
type VolumeQualificationResultsModel =  class end

The VolumeQualificationResultsModel type exposes the following members.

Constructors
 | Name | Description
Public method | VolumeQualificationResultsModel | Initializes a new instance of the VolumeQualificationResultsModel class
Top
Properties
 | Name | Description
Public property | ClusterResourceGroupName | Gets or sets the name of the group that contains the resource.
Public property | CurrentOwnerNodeName | Gets or sets the name of the resource's current owner node.
Public property | DiskSize | Gets or sets the volume total disk size.
Public property | DriveLetter | Gets or sets the volume drive letter.
Public property | FreeSpace | Gets or sets the volume available free space.
Public property | IsSystemVolume | Gets or sets a value indicating whether it is a system volume.
Public property | IsVolumeCSV | Gets or sets a value indicating whether it is a cluster shared volume.
Public property | MaxFileSize | Gets or sets the max file size.
Public property | ProvisionedSpace | Gets or sets the volume provisioned space.
Public property | Url | Gets or sets the url of a datastore.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VolumeQualificationResultsModel Constructor

VolumeQualificationResultsModel Constructor
Initializes a new instance of the VolumeQualificationResultsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VolumeQualificationResultsModel()
Public Sub New
public:
VolumeQualificationResultsModel()
new : unit -> VolumeQualificationResultsModel
See Also

Reference

VolumeQualificationResultsModel Class


VolumeQualificationResultsModel Properties

VolumeQualificationResultsModel Properties

The VolumeQualificationResultsModel type exposes the following members.

Properties
 | Name | Description
Public property | ClusterResourceGroupName | Gets or sets the name of the group that contains the resource.
Public property | CurrentOwnerNodeName | Gets or sets the name of the resource's current owner node.
Public property | DiskSize | Gets or sets the volume total disk size.
Public property | DriveLetter | Gets or sets the volume drive letter.
Public property | FreeSpace | Gets or sets the volume available free space.
Public property | IsSystemVolume | Gets or sets a value indicating whether it is a system volume.
Public property | IsVolumeCSV | Gets or sets a value indicating whether it is a cluster shared volume.
Public property | MaxFileSize | Gets or sets the max file size.
Public property | ProvisionedSpace | Gets or sets the volume provisioned space.
Public property | Url | Gets or sets the url of a datastore.
Top
See Also

Reference

VolumeQualificationResultsModel Class


VolumeQualificationResultsModel.ClusterResourceGroupName Property

VolumeQualificationResultsModelClusterResourceGroupName Property
Gets or sets the name of the group that contains the resource.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ClusterResourceGroupName { get; set; }
Public Property ClusterResourceGroupName As String
    Get
    Set
public:
property String^ ClusterResourceGroupName {
    String^ get ();
    void set (String^ value);
}
member ClusterResourceGroupName : string with get, set

Property Value

Type: String
See Also

Reference

VolumeQualificationResultsModel Class


VolumeQualificationResultsModel.CurrentOwnerNodeName Property

VolumeQualificationResultsModelCurrentOwnerNodeName Property
Gets or sets the name of the resource's current owner node.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string CurrentOwnerNodeName { get; set; }
Public Property CurrentOwnerNodeName As String
    Get
    Set
public:
property String^ CurrentOwnerNodeName {
    String^ get ();
    void set (String^ value);
}
member CurrentOwnerNodeName : string with get, set

Property Value

Type: String
See Also

Reference

VolumeQualificationResultsModel Class


VolumeQualificationResultsModel.DiskSize Property

VolumeQualificationResultsModelDiskSize Property
Gets or sets the volume total disk size.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long DiskSize { get; set; }
Public Property DiskSize As Long
    Get
    Set
public:
property long long DiskSize {
    long long get ();
    void set (long long value);
}
member DiskSize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

VolumeQualificationResultsModel Class


VolumeQualificationResultsModel.DriveLetter Property

VolumeQualificationResultsModelDriveLetter Property
Gets or sets the volume drive letter.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string DriveLetter { get; set; }
Public Property DriveLetter As String
    Get
    Set
public:
property String^ DriveLetter {
    String^ get ();
    void set (String^ value);
}
member DriveLetter : string with get, set

Property Value

Type: String
See Also

Reference

VolumeQualificationResultsModel Class


VolumeQualificationResultsModel.FreeSpace Property

VolumeQualificationResultsModelFreeSpace Property
Gets or sets the volume available free space.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long FreeSpace { get; set; }
Public Property FreeSpace As Long
    Get
    Set
public:
property long long FreeSpace {
    long long get ();
    void set (long long value);
}
member FreeSpace : int64 with get, set

Property Value

Type: Int64
See Also

Reference

VolumeQualificationResultsModel Class


VolumeQualificationResultsModel.IsSystemVolume Property

VolumeQualificationResultsModelIsSystemVolume Property
Gets or sets a value indicating whether it is a system volume.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSystemVolume { get; set; }
Public Property IsSystemVolume As Boolean
    Get
    Set
public:
property bool IsSystemVolume {
    bool get ();
    void set (bool value);
}
member IsSystemVolume : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VolumeQualificationResultsModel Class


VolumeQualificationResultsModel.IsVolumeCSV Property

VolumeQualificationResultsModelIsVolumeCSV Property
Gets or sets a value indicating whether it is a cluster shared volume.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsVolumeCSV { get; set; }
Public Property IsVolumeCSV As Boolean
    Get
    Set
public:
property bool IsVolumeCSV {
    bool get ();
    void set (bool value);
}
member IsVolumeCSV : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VolumeQualificationResultsModel Class


VolumeQualificationResultsModel.MaxFileSize Property

VolumeQualificationResultsModelMaxFileSize Property
Gets or sets the max file size.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long MaxFileSize { get; set; }
Public Property MaxFileSize As Long
    Get
    Set
public:
property long long MaxFileSize {
    long long get ();
    void set (long long value);
}
member MaxFileSize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

VolumeQualificationResultsModel Class


VolumeQualificationResultsModel.ProvisionedSpace Property

VolumeQualificationResultsModelProvisionedSpace Property
Gets or sets the volume provisioned space.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long ProvisionedSpace { get; set; }
Public Property ProvisionedSpace As Long
    Get
    Set
public:
property long long ProvisionedSpace {
    long long get ();
    void set (long long value);
}
member ProvisionedSpace : int64 with get, set

Property Value

Type: Int64
See Also

Reference

VolumeQualificationResultsModel Class


VolumeQualificationResultsModel.Url Property

VolumeQualificationResultsModelUrl Property
Gets or sets the url of a datastore.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Url { get; set; }
Public Property Url As String
    Get
    Set
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}
member Url : string with get, set

Property Value

Type: String
See Also

Reference

VolumeQualificationResultsModel Class


VolumeQualificationResultsModel Methods

VolumeQualificationResultsModel Methods

The VolumeQualificationResultsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VolumeQualificationResultsModel Class


VRAInternalVirtualNetworkInterfaceInfoModel Class

VRAInternalVirtualNetworkInterfaceInfoModel Class
VRA internal virtual network interface information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsNetworkInterfaceModel
DoubleTake.Web.ModelsVirtualNetworkInterfaceInfoModel
DoubleTake.Web.ModelsVRAInternalVirtualNetworkInterfaceInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class VRAInternalVirtualNetworkInterfaceInfoModel : VirtualNetworkInterfaceInfoModel
Public NotInheritable Class VRAInternalVirtualNetworkInterfaceInfoModel
    Inherits VirtualNetworkInterfaceInfoModel
public ref class VRAInternalVirtualNetworkInterfaceInfoModel sealed : public VirtualNetworkInterfaceInfoModel
[<SealedAttribute>]
type VRAInternalVirtualNetworkInterfaceInfoModel =
    class
        inherit VirtualNetworkInterfaceInfoModel
    end

The VRAInternalVirtualNetworkInterfaceInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | VRAInternalVirtualNetworkInterfaceInfoModel | Initializes a new instance of the VRAInternalVirtualNetworkInterfaceInfoModel class
Top
Properties
 | Name | Description
Public property | BusNumber | Gets or sets the bus number to be used on the replica.
Public property | Description | Gets or sets the description of the network interface. (Inherited from NetworkInterfaceModel.)
Public property | DeviceNumber | Gets or sets the device number to be used on the replica.
Public property | DnsDomain | Gets or sets the DNS Domain. (Inherited from NetworkInterfaceModel.)
Public property | DnsServers | Gets or sets the DNS servers. (Inherited from NetworkInterfaceModel.)
Public property | Gateways | Gets or sets the gateways. (Inherited from NetworkInterfaceModel.)
Public property | Id | Gets or sets the unique identifier of the network interface. (Inherited from NetworkInterfaceModel.)
Public property | Index | Gets or sets the index of the network interface. (Inherited from NetworkInterfaceModel.)
Public property | InterfaceIndex | Gets or sets the index of the network interface. (Inherited from NetworkInterfaceModel.)
Public property | IPAddresses | Gets or sets the IP addresses on the network interface. (Inherited from NetworkInterfaceModel.)
Public property | MacAddress | Gets or sets the MAC address. (Inherited from NetworkInterfaceModel.)
Public property | Name | Gets or sets the friendly name of the network interface. (Inherited from NetworkInterfaceModel.)
Public property | PnpInstanceId | Gets or sets the PNP instance id. (Inherited from NetworkInterfaceModel.)
Public property | ServiceName | Gets or sets the service name of the network interface. (Inherited from NetworkInterfaceModel.)
Public property | VirtualNetwork | Gets or sets the virtual network. (Inherited from VirtualNetworkInterfaceInfoModel.)
Public property | VirtualNicType | Gets or sets the type of the virtual NIC. (Inherited from VirtualNetworkInterfaceInfoModel.)
Public property | VLAN_ID | Gets or sets the replica's VLan ID. (Inherited from VirtualNetworkInterfaceInfoModel.)
Public property | VLAN_ID_TestFailover | Gets or sets the replica's test failover VLan ID. (Inherited from VirtualNetworkInterfaceInfoModel.)
Public property | VRANicId | Gets or sets the VRA nic id.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsVirtualNetworkInterfaceInfoModel


VRAInternalVirtualNetworkInterfaceInfoModel Constructor

VRAInternalVirtualNetworkInterfaceInfoModel Constructor
Initializes a new instance of the VRAInternalVirtualNetworkInterfaceInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VRAInternalVirtualNetworkInterfaceInfoModel()
Public Sub New
public:
VRAInternalVirtualNetworkInterfaceInfoModel()
new : unit -> VRAInternalVirtualNetworkInterfaceInfoModel
See Also

Reference

VRAInternalVirtualNetworkInterfaceInfoModel Class


VRAInternalVirtualNetworkInterfaceInfoModel Properties

VRAInternalVirtualNetworkInterfaceInfoModel Properties

The VRAInternalVirtualNetworkInterfaceInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | BusNumber | Gets or sets the bus number to be used on the replica.
Public property | Description | Gets or sets the description of the network interface. (Inherited from NetworkInterfaceModel.)
Public property | DeviceNumber | Gets or sets the device number to be used on the replica.
Public property | DnsDomain | Gets or sets the DNS Domain. (Inherited from NetworkInterfaceModel.)
Public property | DnsServers | Gets or sets the DNS servers. (Inherited from NetworkInterfaceModel.)
Public property | Gateways | Gets or sets the gateways. (Inherited from NetworkInterfaceModel.)
Public property | Id | Gets or sets the unique identifier of the network interface. (Inherited from NetworkInterfaceModel.)
Public property | Index | Gets or sets the index of the network interface. (Inherited from NetworkInterfaceModel.)
Public property | InterfaceIndex | Gets or sets the index of the network interface. (Inherited from NetworkInterfaceModel.)
Public property | IPAddresses | Gets or sets the IP addresses on the network interface. (Inherited from NetworkInterfaceModel.)
Public property | MacAddress | Gets or sets the MAC address. (Inherited from NetworkInterfaceModel.)
Public property | Name | Gets or sets the friendly name of the network interface. (Inherited from NetworkInterfaceModel.)
Public property | PnpInstanceId | Gets or sets the PNP instance id. (Inherited from NetworkInterfaceModel.)
Public property | ServiceName | Gets or sets the service name of the network interface. (Inherited from NetworkInterfaceModel.)
Public property | VirtualNetwork | Gets or sets the virtual network. (Inherited from VirtualNetworkInterfaceInfoModel.)
Public property | VirtualNicType | Gets or sets the type of the virtual NIC. (Inherited from VirtualNetworkInterfaceInfoModel.)
Public property | VLAN_ID | Gets or sets the replica's VLan ID. (Inherited from VirtualNetworkInterfaceInfoModel.)
Public property | VLAN_ID_TestFailover | Gets or sets the replica's test failover VLan ID. (Inherited from VirtualNetworkInterfaceInfoModel.)
Public property | VRANicId | Gets or sets the VRA nic id.
Top
See Also

Reference

VRAInternalVirtualNetworkInterfaceInfoModel Class


VRAInternalVirtualNetworkInterfaceInfoModel.BusNumber Property

VRAInternalVirtualNetworkInterfaceInfoModelBusNumber Property
Gets or sets the bus number to be used on the replica.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int BusNumber { get; set; }
Public Property BusNumber As Integer
    Get
    Set
public:
property int BusNumber {
    int get ();
    void set (int value);
}
member BusNumber : int with get, set

Property Value

Type: Int32
The bus number.
See Also

Reference

VRAInternalVirtualNetworkInterfaceInfoModel Class


VRAInternalVirtualNetworkInterfaceInfoModel.DeviceNumber Property

VRAInternalVirtualNetworkInterfaceInfoModelDeviceNumber Property
Gets or sets the device number to be used on the replica.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int DeviceNumber { get; set; }
Public Property DeviceNumber As Integer
    Get
    Set
public:
property int DeviceNumber {
    int get ();
    void set (int value);
}
member DeviceNumber : int with get, set

Property Value

Type: Int32
The device number.
See Also

Reference

VRAInternalVirtualNetworkInterfaceInfoModel Class


VRAInternalVirtualNetworkInterfaceInfoModel.VRANicId Property

VRAInternalVirtualNetworkInterfaceInfoModelVRANicId Property
Gets or sets the VRA nic id.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string VRANicId { get; set; }
Public Property VRANicId As String
    Get
    Set
public:
property String^ VRANicId {
    String^ get ();
    void set (String^ value);
}
member VRANicId : string with get, set

Property Value

Type: String
The VRA nic id.
See Also

Reference

VRAInternalVirtualNetworkInterfaceInfoModel Class


VRAInternalVirtualNetworkInterfaceInfoModel Methods

VRAInternalVirtualNetworkInterfaceInfoModel Methods

The VRAInternalVirtualNetworkInterfaceInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VRAInternalVirtualNetworkInterfaceInfoModel Class


VraOptionsModel Class

VraOptionsModel Class
Vra options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVraOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VraOptionsModel
Public NotInheritable Class VraOptionsModel
public ref class VraOptionsModel sealed
[<SealedAttribute>]
type VraOptionsModel =  class end

The VraOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | VraOptionsModel | Initializes a new instance of the VraOptionsModel class
Top
Properties
 | Name | Description
Public property | DiskConfigStrategy | Gets or sets the disk layout strategy.
Public property | DisksOptions | Gets or sets the disks for a Linux server.
Public property | Hypervisor | Gets or sets the hypervisor.
Public property | IsSourceHostCluster | Gets or sets a value indicating whether source host is cluster or not.
Public property | IsWANFailoverEnabled | Gets or sets a value indicating whether or not this instance is WAN failover enabled.
Public property | LvmOptions | Gets or sets LVM information for volumes.
Public property | ReplicaApplianceInfo | Gets or sets the Replica Appliance information.
Public property | ReplicaESXHostName | Gets or sets the target vim host information.
Public property | ReplicaNetworkInterfaceInfo | Gets or sets the replica network interface info.
Public property | ReplicaVmInfo | Gets or sets the replica VM information.
Public property | ReverseCount | Gets or sets the reverse count.
Public property | ReverseRoute | Gets or sets the reverse route.
Public property | SourceApplianceInfo | Gets or sets the source appliance information.
Public property | SourceESXHostName | Gets or sets the source vim host info.
Public property | SourceNetworkInterfaceInfo | Gets or sets the source network interface info.
Public property | SourceProductLicense | Gets or sets the source product license.
Public property | SourceVmInfo | Gets or sets the source information.
Public property | TestFailoverOptions | Gets or sets the test failover options for VRA.
Public property | VirtualSwitchMapping | Gets or sets the source and target virtual switch mappings.
Public property | VirtualSwitchMappingTestFailover | Gets or sets the source and target virtual switch mappings for test failover.
Public property | Volumes | Gets or sets the volumes to create and protect.
Public property | WorkloadCustomizationOptions | Gets or sets the workload customization options.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VraOptionsModel Constructor

VraOptionsModel Constructor
Initializes a new instance of the VraOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VraOptionsModel()
Public Sub New
public:
VraOptionsModel()
new : unit -> VraOptionsModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel Properties

VraOptionsModel Properties

The VraOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | DiskConfigStrategy | Gets or sets the disk layout strategy.
Public property | DisksOptions | Gets or sets the disks for a Linux server.
Public property | Hypervisor | Gets or sets the hypervisor.
Public property | IsSourceHostCluster | Gets or sets a value indicating whether source host is cluster or not.
Public property | IsWANFailoverEnabled | Gets or sets a value indicating whether or not this instance is WAN failover enabled.
Public property | LvmOptions | Gets or sets LVM information for volumes.
Public property | ReplicaApplianceInfo | Gets or sets the Replica Appliance information.
Public property | ReplicaESXHostName | Gets or sets the target vim host information.
Public property | ReplicaNetworkInterfaceInfo | Gets or sets the replica network interface info.
Public property | ReplicaVmInfo | Gets or sets the replica VM information.
Public property | ReverseCount | Gets or sets the reverse count.
Public property | ReverseRoute | Gets or sets the reverse route.
Public property | SourceApplianceInfo | Gets or sets the source appliance information.
Public property | SourceESXHostName | Gets or sets the source vim host info.
Public property | SourceNetworkInterfaceInfo | Gets or sets the source network interface info.
Public property | SourceProductLicense | Gets or sets the source product license.
Public property | SourceVmInfo | Gets or sets the source information.
Public property | TestFailoverOptions | Gets or sets the test failover options for VRA.
Public property | VirtualSwitchMapping | Gets or sets the source and target virtual switch mappings.
Public property | VirtualSwitchMappingTestFailover | Gets or sets the source and target virtual switch mappings for test failover.
Public property | Volumes | Gets or sets the volumes to create and protect.
Public property | WorkloadCustomizationOptions | Gets or sets the workload customization options.
Top
See Also

Reference

VraOptionsModel Class


VraOptionsModel.DiskConfigStrategy Property

VraOptionsModelDiskConfigStrategy Property
Gets or sets the disk layout strategy.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DiskConfigStrategy DiskConfigStrategy { get; set; }
Public Property DiskConfigStrategy As DiskConfigStrategy
    Get
    Set
public:
property DiskConfigStrategy DiskConfigStrategy {
    DiskConfigStrategy get ();
    void set (DiskConfigStrategy value);
}
member DiskConfigStrategy : DiskConfigStrategy with get, set

Property Value

Type: DiskConfigStrategy
See Also

Reference

VraOptionsModel Class


VraOptionsModel.DisksOptions Property

VraOptionsModelDisksOptions Property
Gets or sets the disks for a Linux server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public DiskOptionsModel[] DisksOptions { get; set; }
Public Property DisksOptions As DiskOptionsModel()
    Get
    Set
public:
property array<DiskOptionsModel^>^ DisksOptions {
    array<DiskOptionsModel^>^ get ();
    void set (array<DiskOptionsModel^>^ value);
}
member DisksOptions : DiskOptionsModel[] with get, set

Property Value

Type: DiskOptionsModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel.Hypervisor Property

VraOptionsModelHypervisor Property
Gets or sets the hypervisor.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Hypervisor { get; set; }
Public Property Hypervisor As String
    Get
    Set
public:
property String^ Hypervisor {
    String^ get ();
    void set (String^ value);
}
member Hypervisor : string with get, set

Property Value

Type: String
See Also

Reference

VraOptionsModel Class


VraOptionsModel.IsSourceHostCluster Property

VraOptionsModelIsSourceHostCluster Property
Gets or sets a value indicating whether source host is cluster or not.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsSourceHostCluster { get; set; }
Public Property IsSourceHostCluster As Boolean
    Get
    Set
public:
property bool IsSourceHostCluster {
    bool get ();
    void set (bool value);
}
member IsSourceHostCluster : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VraOptionsModel Class


VraOptionsModel.IsWANFailoverEnabled Property

VraOptionsModelIsWANFailoverEnabled Property
Gets or sets a value indicating whether or not this instance is WAN failover enabled.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsWANFailoverEnabled { get; set; }
Public Property IsWANFailoverEnabled As Boolean
    Get
    Set
public:
property bool IsWANFailoverEnabled {
    bool get ();
    void set (bool value);
}
member IsWANFailoverEnabled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VraOptionsModel Class


VraOptionsModel.LvmOptions Property

VraOptionsModelLvmOptions Property
Gets or sets LVM information for volumes.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public LvmOptionsModel LvmOptions { get; set; }
Public Property LvmOptions As LvmOptionsModel
    Get
    Set
public:
property LvmOptionsModel^ LvmOptions {
    LvmOptionsModel^ get ();
    void set (LvmOptionsModel^ value);
}
member LvmOptions : LvmOptionsModel with get, set

Property Value

Type: LvmOptionsModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel.ReplicaApplianceInfo Property

VraOptionsModelReplicaApplianceInfo Property
Gets or sets the Replica Appliance information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VmInfoModel ReplicaApplianceInfo { get; set; }
Public Property ReplicaApplianceInfo As VmInfoModel
    Get
    Set
public:
property VmInfoModel^ ReplicaApplianceInfo {
    VmInfoModel^ get ();
    void set (VmInfoModel^ value);
}
member ReplicaApplianceInfo : VmInfoModel with get, set

Property Value

Type: VmInfoModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel.ReplicaESXHostName Property

VraOptionsModelReplicaESXHostName Property
Gets or sets the target vim host information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ReplicaESXHostName { get; set; }
Public Property ReplicaESXHostName As String
    Get
    Set
public:
property String^ ReplicaESXHostName {
    String^ get ();
    void set (String^ value);
}
member ReplicaESXHostName : string with get, set

Property Value

Type: String
See Also

Reference

VraOptionsModel Class


VraOptionsModel.ReplicaNetworkInterfaceInfo Property

VraOptionsModelReplicaNetworkInterfaceInfo Property
Gets or sets the replica network interface info.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VirtualNetworkInterfaceInfoModel[] ReplicaNetworkInterfaceInfo { get; set; }
Public Property ReplicaNetworkInterfaceInfo As VirtualNetworkInterfaceInfoModel()
    Get
    Set
public:
property array<VirtualNetworkInterfaceInfoModel^>^ ReplicaNetworkInterfaceInfo {
    array<VirtualNetworkInterfaceInfoModel^>^ get ();
    void set (array<VirtualNetworkInterfaceInfoModel^>^ value);
}
member ReplicaNetworkInterfaceInfo : VirtualNetworkInterfaceInfoModel[] with get, set

Property Value

Type: VirtualNetworkInterfaceInfoModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel.ReplicaVmInfo Property

VraOptionsModelReplicaVmInfo Property
Gets or sets the replica VM information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ReplicaVmInfoModel ReplicaVmInfo { get; set; }
Public Property ReplicaVmInfo As ReplicaVmInfoModel
    Get
    Set
public:
property ReplicaVmInfoModel^ ReplicaVmInfo {
    ReplicaVmInfoModel^ get ();
    void set (ReplicaVmInfoModel^ value);
}
member ReplicaVmInfo : ReplicaVmInfoModel with get, set

Property Value

Type: ReplicaVmInfoModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel.ReverseCount Property

VraOptionsModelReverseCount Property
Gets or sets the reverse count.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int ReverseCount { get; set; }
Public Property ReverseCount As Integer
    Get
    Set
public:
property int ReverseCount {
    int get ();
    void set (int value);
}
member ReverseCount : int with get, set

Property Value

Type: Int32
See Also

Reference

VraOptionsModel Class


VraOptionsModel.ReverseRoute Property

VraOptionsModelReverseRoute Property
Gets or sets the reverse route.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string ReverseRoute { get; set; }
Public Property ReverseRoute As String
    Get
    Set
public:
property String^ ReverseRoute {
    String^ get ();
    void set (String^ value);
}
member ReverseRoute : string with get, set

Property Value

Type: String
See Also

Reference

VraOptionsModel Class


VraOptionsModel.SourceApplianceInfo Property

VraOptionsModelSourceApplianceInfo Property
Gets or sets the source appliance information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VmInfoModel SourceApplianceInfo { get; set; }
Public Property SourceApplianceInfo As VmInfoModel
    Get
    Set
public:
property VmInfoModel^ SourceApplianceInfo {
    VmInfoModel^ get ();
    void set (VmInfoModel^ value);
}
member SourceApplianceInfo : VmInfoModel with get, set

Property Value

Type: VmInfoModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel.SourceESXHostName Property

VraOptionsModelSourceESXHostName Property
Gets or sets the source vim host info.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceESXHostName { get; set; }
Public Property SourceESXHostName As String
    Get
    Set
public:
property String^ SourceESXHostName {
    String^ get ();
    void set (String^ value);
}
member SourceESXHostName : string with get, set

Property Value

Type: String
See Also

Reference

VraOptionsModel Class


VraOptionsModel.SourceNetworkInterfaceInfo Property

VraOptionsModelSourceNetworkInterfaceInfo Property
Gets or sets the source network interface info.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VirtualNetworkInterfaceInfoModel[] SourceNetworkInterfaceInfo { get; set; }
Public Property SourceNetworkInterfaceInfo As VirtualNetworkInterfaceInfoModel()
    Get
    Set
public:
property array<VirtualNetworkInterfaceInfoModel^>^ SourceNetworkInterfaceInfo {
    array<VirtualNetworkInterfaceInfoModel^>^ get ();
    void set (array<VirtualNetworkInterfaceInfoModel^>^ value);
}
member SourceNetworkInterfaceInfo : VirtualNetworkInterfaceInfoModel[] with get, set

Property Value

Type: VirtualNetworkInterfaceInfoModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel.SourceProductLicense Property

VraOptionsModelSourceProductLicense Property
Gets or sets the source product license.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string SourceProductLicense { get; set; }
Public Property SourceProductLicense As String
    Get
    Set
public:
property String^ SourceProductLicense {
    String^ get ();
    void set (String^ value);
}
member SourceProductLicense : string with get, set

Property Value

Type: String
See Also

Reference

VraOptionsModel Class


VraOptionsModel.SourceVmInfo Property

VraOptionsModelSourceVmInfo Property
Gets or sets the source information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VmInfoModel SourceVmInfo { get; set; }
Public Property SourceVmInfo As VmInfoModel
    Get
    Set
public:
property VmInfoModel^ SourceVmInfo {
    VmInfoModel^ get ();
    void set (VmInfoModel^ value);
}
member SourceVmInfo : VmInfoModel with get, set

Property Value

Type: VmInfoModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel.TestFailoverOptions Property

VraOptionsModelTestFailoverOptions Property
Gets or sets the test failover options for VRA.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public TestFailoverOptionsModel TestFailoverOptions { get; set; }
Public Property TestFailoverOptions As TestFailoverOptionsModel
    Get
    Set
public:
property TestFailoverOptionsModel^ TestFailoverOptions {
    TestFailoverOptionsModel^ get ();
    void set (TestFailoverOptionsModel^ value);
}
member TestFailoverOptions : TestFailoverOptionsModel with get, set

Property Value

Type: TestFailoverOptionsModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel.VirtualSwitchMapping Property

VraOptionsModelVirtualSwitchMapping Property
Gets or sets the source and target virtual switch mappings.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchMappingModel[] VirtualSwitchMapping { get; set; }
Public Property VirtualSwitchMapping As VirtualSwitchMappingModel()
    Get
    Set
public:
property array<VirtualSwitchMappingModel^>^ VirtualSwitchMapping {
    array<VirtualSwitchMappingModel^>^ get ();
    void set (array<VirtualSwitchMappingModel^>^ value);
}
member VirtualSwitchMapping : VirtualSwitchMappingModel[] with get, set

Property Value

Type: VirtualSwitchMappingModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel.VirtualSwitchMappingTestFailover Property

VraOptionsModelVirtualSwitchMappingTestFailover Property
Gets or sets the source and target virtual switch mappings for test failover.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VirtualSwitchMappingModel[] VirtualSwitchMappingTestFailover { get; set; }
Public Property VirtualSwitchMappingTestFailover As VirtualSwitchMappingModel()
    Get
    Set
public:
property array<VirtualSwitchMappingModel^>^ VirtualSwitchMappingTestFailover {
    array<VirtualSwitchMappingModel^>^ get ();
    void set (array<VirtualSwitchMappingModel^>^ value);
}
member VirtualSwitchMappingTestFailover : VirtualSwitchMappingModel[] with get, set

Property Value

Type: VirtualSwitchMappingModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel.Volumes Property

VraOptionsModelVolumes Property
Gets or sets the volumes to create and protect.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VolumeOptionsModel[] Volumes { get; set; }
Public Property Volumes As VolumeOptionsModel()
    Get
    Set
public:
property array<VolumeOptionsModel^>^ Volumes {
    array<VolumeOptionsModel^>^ get ();
    void set (array<VolumeOptionsModel^>^ value);
}
member Volumes : VolumeOptionsModel[] with get, set

Property Value

Type: VolumeOptionsModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel.WorkloadCustomizationOptions Property

VraOptionsModelWorkloadCustomizationOptions Property
Gets or sets the workload customization options.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VraWorkloadCustomizationOptionsModel WorkloadCustomizationOptions { get; set; }
Public Property WorkloadCustomizationOptions As VraWorkloadCustomizationOptionsModel
    Get
    Set
public:
property VraWorkloadCustomizationOptionsModel^ WorkloadCustomizationOptions {
    VraWorkloadCustomizationOptionsModel^ get ();
    void set (VraWorkloadCustomizationOptionsModel^ value);
}
member WorkloadCustomizationOptions : VraWorkloadCustomizationOptionsModel with get, set

Property Value

Type: VraWorkloadCustomizationOptionsModel
See Also

Reference

VraOptionsModel Class


VraOptionsModel Methods

VraOptionsModel Methods

The VraOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VraOptionsModel Class


VraQualificationResultsModel Class

VraQualificationResultsModel Class
Vra qualification results model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVraQualificationResultsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VraQualificationResultsModel
Public NotInheritable Class VraQualificationResultsModel
public ref class VraQualificationResultsModel sealed
[<SealedAttribute>]
type VraQualificationResultsModel =  class end

The VraQualificationResultsModel type exposes the following members.

Constructors
 | Name | Description
Public method | VraQualificationResultsModel | Initializes a new instance of the VraQualificationResultsModel class
Top
Properties
 | Name | Description
Public property | PreexistingDisksFileName | Gets or sets we have a special format for the replica disks, so to use pre-existing disk that disk must have the same name which we expect.
Public property | SourceServerMemorySize | Gets or sets the amount of memory on the server.
Public property | SourceServerProcessorCount | Gets or sets the processor count of the server.
Public property | TargetHost | Gets or sets the target server information.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VraQualificationResultsModel Constructor

VraQualificationResultsModel Constructor
Initializes a new instance of the VraQualificationResultsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VraQualificationResultsModel()
Public Sub New
public:
VraQualificationResultsModel()
new : unit -> VraQualificationResultsModel
See Also

Reference

VraQualificationResultsModel Class


VraQualificationResultsModel Properties

VraQualificationResultsModel Properties

The VraQualificationResultsModel type exposes the following members.

Properties
 | Name | Description
Public property | PreexistingDisksFileName | Gets or sets we have a special format for the replica disks, so to use pre-existing disk that disk must have the same name which we expect.
Public property | SourceServerMemorySize | Gets or sets the amount of memory on the server.
Public property | SourceServerProcessorCount | Gets or sets the processor count of the server.
Public property | TargetHost | Gets or sets the target server information.
Top
See Also

Reference

VraQualificationResultsModel Class


VraQualificationResultsModel.PreexistingDisksFileName Property

VraQualificationResultsModelPreexistingDisksFileName Property
Gets or sets we have a special format for the replica disks, so to use pre-existing disk that disk must have the same name which we expect.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] PreexistingDisksFileName { get; set; }
Public Property PreexistingDisksFileName As String()
    Get
    Set
public:
property array<String^>^ PreexistingDisksFileName {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member PreexistingDisksFileName : string[] with get, set

Property Value

Type: String
See Also

Reference

VraQualificationResultsModel Class


VraQualificationResultsModel.SourceServerMemorySize Property

VraQualificationResultsModelSourceServerMemorySize Property
Gets or sets the amount of memory on the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public long SourceServerMemorySize { get; set; }
Public Property SourceServerMemorySize As Long
    Get
    Set
public:
property long long SourceServerMemorySize {
    long long get ();
    void set (long long value);
}
member SourceServerMemorySize : int64 with get, set

Property Value

Type: Int64
See Also

Reference

VraQualificationResultsModel Class


VraQualificationResultsModel.SourceServerProcessorCount Property

VraQualificationResultsModelSourceServerProcessorCount Property
Gets or sets the processor count of the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public int SourceServerProcessorCount { get; set; }
Public Property SourceServerProcessorCount As Integer
    Get
    Set
public:
property int SourceServerProcessorCount {
    int get ();
    void set (int value);
}
member SourceServerProcessorCount : int with get, set

Property Value

Type: Int32
See Also

Reference

VraQualificationResultsModel Class


VraQualificationResultsModel.TargetHost Property

VraQualificationResultsModelTargetHost Property
Gets or sets the target server information.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ServerQualificationResultsModel TargetHost { get; set; }
Public Property TargetHost As ServerQualificationResultsModel
    Get
    Set
public:
property ServerQualificationResultsModel^ TargetHost {
    ServerQualificationResultsModel^ get ();
    void set (ServerQualificationResultsModel^ value);
}
member TargetHost : ServerQualificationResultsModel with get, set

Property Value

Type: ServerQualificationResultsModel
See Also

Reference

VraQualificationResultsModel Class


VraQualificationResultsModel Methods

VraQualificationResultsModel Methods

The VraQualificationResultsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VraQualificationResultsModel Class


VRAVolumePersistedStateModel Class

VRAVolumePersistedStateModel Class
VRA volume persisted state.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsProtectableItemModel
DoubleTake.Web.ModelsPhysicalItemModel
DoubleTake.Web.ModelsVolumeModel
DoubleTake.Web.ModelsVolumeOptionsModel
DoubleTake.Web.ModelsVRAVolumePersistedStateModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public sealed class VRAVolumePersistedStateModel : VolumeOptionsModel
Public NotInheritable Class VRAVolumePersistedStateModel
    Inherits VolumeOptionsModel
public ref class VRAVolumePersistedStateModel sealed : public VolumeOptionsModel
[<SealedAttribute>]
type VRAVolumePersistedStateModel =
    class
        inherit VolumeOptionsModel
    end

The VRAVolumePersistedStateModel type exposes the following members.

Constructors
 | Name | Description
Public method | VRAVolumePersistedStateModel | Initializes a new instance of the VRAVolumePersistedStateModel class
Top
Properties
 | Name | Description
Public property | ApplianceSCSIBus | Gets or sets the SCSI bus number the volume has on the replica appliance.
Public property | ApplianceSCSIUnitNumber | Gets or sets the SCSI unit number the volume has on the replica appliance.
Public property | Attributes | Gets or sets a value specifying the file system attributes of this item. (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | Gets or sets the available free space on this volume. (Inherited from PhysicalItemModel.)
Public property | ClassName | Gets or sets the class name. (Inherited from PhysicalItemModel.)
Public property | CreationTime | Gets or sets a value specifying the time this item was created. (Inherited from PhysicalItemModel.)
Public property | DesiredSize | Gets or sets the size that the user wants the drive to be. (Inherited from VolumeOptionsModel.)
Public property | DeviceID | Gets or sets the device ID the volume has on the replica appliance
Public property | DiskControllerType | Gets or sets the type of the disk controller. (Inherited from VolumeOptionsModel.)
Public property | DiskProvisioningType | Gets or sets the type of the disk provisioning. (Inherited from VolumeOptionsModel.)
Public property | DriveFormat | Gets or sets the format of the drive. (Inherited from PhysicalItemModel.)
Public property | DriveIndex | Gets or sets the index of the drive the volume has on the replica appliance
Public property | DriveName | Gets or sets the name of the drive on the helper (\\.\PHYSICALDRIVEX)
Public property | DriveType | Gets or sets the type of the drive. (Inherited from PhysicalItemModel.)
Public property | Id | Gets or sets the item identifier. (Inherited from ProtectableItemModel.)
Public property | IsContainer | Gets or sets a value indicating whether or not this item is a container of other items. (Inherited from ProtectableItemModel.)
Public property | IsGpt | Gets or sets a value indicating whether this instance is a GPT disk.
Public property | IsReadOnly | Gets or sets a value indicating whether or not this item is read only; that is, its Saturation cannot be changed. (Inherited from ProtectableItemModel.)
Public property | IsSupported | Gets or sets a value indicating whether this volume is supported. (Inherited from PhysicalItemModel.)
Public property | IsSystemDrive | Gets or sets a value indicating whether or not this volume is the system drive. (Inherited from PhysicalItemModel.)
Public property | ItemType | Gets or sets the type of this item. (Inherited from ProtectableItemModel.)
Public property | Label | Gets or sets the volume label. (Inherited from PhysicalItemModel.)
Public property | LastAccessTime | Gets or sets a value specifying the time this item was last accessed. (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | Gets or sets a value specifying the time this item was last written to. (Inherited from PhysicalItemModel.)
Public property | Metadata | Gets or sets a value specifying additional meta data for this item. (Inherited from PhysicalItemModel.)
Public property | MountPoint | Gets or sets the mount point.
Public property | Name | Gets or sets the name of this item. (Inherited from ProtectableItemModel.)
Public property | OriginalPath | Gets or sets the path where the volume was stored on the source host.
Public property | PartitionName | Gets or sets the partition name. (Inherited from ProtectableItemModel.)
Public property | Path | Gets or sets the path that uniquely identifies this item. (Inherited from ProtectableItemModel.)
Public property | PNPDeviceID | Gets or sets the PNP device ID.
Public property | PreexistingDiskPath | Gets or sets the path of preexisting disk. (Inherited from VolumeOptionsModel.)
Public property | ReplicaVmSCSIBus | Gets or sets the SCSI bus number the volume has on the replica Vm.
Public property | ReplicaVmSCSIUnitNumber | Gets or sets the SCSI unit number the volume has on the replica Vm.
Public property | ReverseVolumeSignature | Gets or sets the reverse volume signature. This represents the signature of the volume on the Source.
Public property | Saturation | Gets or sets the saturation level of this item. (Inherited from ProtectableItemModel.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume. (Inherited from PhysicalItemModel.)
Public property | Size | Gets or sets a value indicating the physical size of the item. (Inherited from PhysicalItemModel.)
Public property | TotalSize | Gets or sets the total size of the volume. (Inherited from PhysicalItemModel.)
Public property | VirtualDiskFilename | Gets or sets the filename for the virtual disk.
Public property | VirtualDiskPath | Gets or sets the path on the host where the volume should be stored. (Inherited from VolumeOptionsModel.)
Public property | VolumeName | Gets or sets the name of the volume.
Public property | VolumeSignature | Gets or sets the volume signature. (Inherited from VolumeOptionsModel.)
Public property | VolumeType | Gets or sets the volume type. (Inherited from PhysicalItemModel.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace
DoubleTake.Web.ModelsVolumeOptionsModel


VRAVolumePersistedStateModel Constructor

VRAVolumePersistedStateModel Constructor
Initializes a new instance of the VRAVolumePersistedStateModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public VRAVolumePersistedStateModel()
Public Sub New
public:
VRAVolumePersistedStateModel()
new : unit -> VRAVolumePersistedStateModel
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel Properties

VRAVolumePersistedStateModel Properties

The VRAVolumePersistedStateModel type exposes the following members.

Properties
 | Name | Description
Public property | ApplianceSCSIBus | Gets or sets the SCSI bus number the volume has on the replica appliance.
Public property | ApplianceSCSIUnitNumber | Gets or sets the SCSI unit number the volume has on the replica appliance.
Public property | Attributes | Gets or sets a value specifying the file system attributes of this item. (Inherited from PhysicalItemModel.)
Public property | AvailableFreeSpace | Gets or sets the available free space on this volume. (Inherited from PhysicalItemModel.)
Public property | ClassName | Gets or sets the class name. (Inherited from PhysicalItemModel.)
Public property | CreationTime | Gets or sets a value specifying the time this item was created. (Inherited from PhysicalItemModel.)
Public property | DesiredSize | Gets or sets the size that the user wants the drive to be. (Inherited from VolumeOptionsModel.)
Public property | DeviceID | Gets or sets the device ID the volume has on the replica appliance
Public property | DiskControllerType | Gets or sets the type of the disk controller. (Inherited from VolumeOptionsModel.)
Public property | DiskProvisioningType | Gets or sets the type of the disk provisioning. (Inherited from VolumeOptionsModel.)
Public property | DriveFormat | Gets or sets the format of the drive. (Inherited from PhysicalItemModel.)
Public property | DriveIndex | Gets or sets the index of the drive the volume has on the replica appliance
Public property | DriveName | Gets or sets the name of the drive on the helper (\\.\PHYSICALDRIVEX)
Public property | DriveType | Gets or sets the type of the drive. (Inherited from PhysicalItemModel.)
Public property | Id | Gets or sets the item identifier. (Inherited from ProtectableItemModel.)
Public property | IsContainer | Gets or sets a value indicating whether or not this item is a container of other items. (Inherited from ProtectableItemModel.)
Public property | IsGpt | Gets or sets a value indicating whether this instance is a GPT disk.
Public property | IsReadOnly | Gets or sets a value indicating whether or not this item is read only; that is, its Saturation cannot be changed. (Inherited from ProtectableItemModel.)
Public property | IsSupported | Gets or sets a value indicating whether this volume is supported. (Inherited from PhysicalItemModel.)
Public property | IsSystemDrive | Gets or sets a value indicating whether or not this volume is the system drive. (Inherited from PhysicalItemModel.)
Public property | ItemType | Gets or sets the type of this item. (Inherited from ProtectableItemModel.)
Public property | Label | Gets or sets the volume label. (Inherited from PhysicalItemModel.)
Public property | LastAccessTime | Gets or sets a value specifying the time this item was last accessed. (Inherited from PhysicalItemModel.)
Public property | LastWriteTime | Gets or sets a value specifying the time this item was last written to. (Inherited from PhysicalItemModel.)
Public property | Metadata | Gets or sets a value specifying additional meta data for this item. (Inherited from PhysicalItemModel.)
Public property | MountPoint | Gets or sets the mount point.
Public property | Name | Gets or sets the name of this item. (Inherited from ProtectableItemModel.)
Public property | OriginalPath | Gets or sets the path where the volume was stored on the source host.
Public property | PartitionName | Gets or sets the partition name. (Inherited from ProtectableItemModel.)
Public property | Path | Gets or sets the path that uniquely identifies this item. (Inherited from ProtectableItemModel.)
Public property | PNPDeviceID | Gets or sets the PNP device ID.
Public property | PreexistingDiskPath | Gets or sets the path of preexisting disk. (Inherited from VolumeOptionsModel.)
Public property | ReplicaVmSCSIBus | Gets or sets the SCSI bus number the volume has on the replica Vm.
Public property | ReplicaVmSCSIUnitNumber | Gets or sets the SCSI unit number the volume has on the replica Vm.
Public property | ReverseVolumeSignature | Gets or sets the reverse volume signature. This represents the signature of the volume on the Source.
Public property | Saturation | Gets or sets the saturation level of this item. (Inherited from ProtectableItemModel.)
Public property | ShortNameBehavior | Gets or sets a value indicating the Short Name Behavior for this volume. (Inherited from PhysicalItemModel.)
Public property | Size | Gets or sets a value indicating the physical size of the item. (Inherited from PhysicalItemModel.)
Public property | TotalSize | Gets or sets the total size of the volume. (Inherited from PhysicalItemModel.)
Public property | VirtualDiskFilename | Gets or sets the filename for the virtual disk.
Public property | VirtualDiskPath | Gets or sets the path on the host where the volume should be stored. (Inherited from VolumeOptionsModel.)
Public property | VolumeName | Gets or sets the name of the volume.
Public property | VolumeSignature | Gets or sets the volume signature. (Inherited from VolumeOptionsModel.)
Public property | VolumeType | Gets or sets the volume type. (Inherited from PhysicalItemModel.)
Top
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.ApplianceSCSIBus Property

VRAVolumePersistedStateModelApplianceSCSIBus Property
Gets or sets the SCSI bus number the volume has on the replica appliance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int ApplianceSCSIBus { get; set; }
Public Property ApplianceSCSIBus As Integer
    Get
    Set
public:
property int ApplianceSCSIBus {
    int get ();
    void set (int value);
}
member ApplianceSCSIBus : int with get, set

Property Value

Type: Int32
The replica appliance SCSI bus.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.ApplianceSCSIUnitNumber Property

VRAVolumePersistedStateModelApplianceSCSIUnitNumber Property
Gets or sets the SCSI unit number the volume has on the replica appliance.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int ApplianceSCSIUnitNumber { get; set; }
Public Property ApplianceSCSIUnitNumber As Integer
    Get
    Set
public:
property int ApplianceSCSIUnitNumber {
    int get ();
    void set (int value);
}
member ApplianceSCSIUnitNumber : int with get, set

Property Value

Type: Int32
The replica appliance SCSI unit number.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.DeviceID Property

VRAVolumePersistedStateModelDeviceID Property
Gets or sets the device ID the volume has on the replica appliance

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string DeviceID { get; set; }
Public Property DeviceID As String
    Get
    Set
public:
property String^ DeviceID {
    String^ get ();
    void set (String^ value);
}
member DeviceID : string with get, set

Property Value

Type: String
The device ID.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.DriveIndex Property

VRAVolumePersistedStateModelDriveIndex Property
Gets or sets the index of the drive the volume has on the replica appliance

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int DriveIndex { get; set; }
Public Property DriveIndex As Integer
    Get
    Set
public:
property int DriveIndex {
    int get ();
    void set (int value);
}
member DriveIndex : int with get, set

Property Value

Type: Int32
The index of the drive.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.DriveName Property

VRAVolumePersistedStateModelDriveName Property
Gets or sets the name of the drive on the helper (\\.\PHYSICALDRIVEX)

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string DriveName { get; set; }
Public Property DriveName As String
    Get
    Set
public:
property String^ DriveName {
    String^ get ();
    void set (String^ value);
}
member DriveName : string with get, set

Property Value

Type: String
The index of the drive.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.IsGpt Property

VRAVolumePersistedStateModelIsGpt Property
Gets or sets a value indicating whether this instance is a GPT disk.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsGpt { get; set; }
Public Property IsGpt As Boolean
    Get
    Set
public:
property bool IsGpt {
    bool get ();
    void set (bool value);
}
member IsGpt : bool with get, set

Property Value

Type: Boolean
true if this instance is GPT; otherwise, false.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.MountPoint Property

VRAVolumePersistedStateModelMountPoint Property
Gets or sets the mount point.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string MountPoint { get; set; }
Public Property MountPoint As String
    Get
    Set
public:
property String^ MountPoint {
    String^ get ();
    void set (String^ value);
}
member MountPoint : string with get, set

Property Value

Type: String
The mount point.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.OriginalPath Property

VRAVolumePersistedStateModelOriginalPath Property
Gets or sets the path where the volume was stored on the source host.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string OriginalPath { get; set; }
Public Property OriginalPath As String
    Get
    Set
public:
property String^ OriginalPath {
    String^ get ();
    void set (String^ value);
}
member OriginalPath : string with get, set

Property Value

Type: String
The original path.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.PNPDeviceID Property

VRAVolumePersistedStateModelPNPDeviceID Property
Gets or sets the PNP device ID.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string PNPDeviceID { get; set; }
Public Property PNPDeviceID As String
    Get
    Set
public:
property String^ PNPDeviceID {
    String^ get ();
    void set (String^ value);
}
member PNPDeviceID : string with get, set

Property Value

Type: String
The PNP device ID.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.ReplicaVmSCSIBus Property

VRAVolumePersistedStateModelReplicaVmSCSIBus Property
Gets or sets the SCSI bus number the volume has on the replica Vm.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int ReplicaVmSCSIBus { get; set; }
Public Property ReplicaVmSCSIBus As Integer
    Get
    Set
public:
property int ReplicaVmSCSIBus {
    int get ();
    void set (int value);
}
member ReplicaVmSCSIBus : int with get, set

Property Value

Type: Int32
The replica vm SCSI bus.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.ReplicaVmSCSIUnitNumber Property

VRAVolumePersistedStateModelReplicaVmSCSIUnitNumber Property
Gets or sets the SCSI unit number the volume has on the replica Vm.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public int ReplicaVmSCSIUnitNumber { get; set; }
Public Property ReplicaVmSCSIUnitNumber As Integer
    Get
    Set
public:
property int ReplicaVmSCSIUnitNumber {
    int get ();
    void set (int value);
}
member ReplicaVmSCSIUnitNumber : int with get, set

Property Value

Type: Int32
The replica vm SCSI unit number.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.ReverseVolumeSignature Property

VRAVolumePersistedStateModelReverseVolumeSignature Property
Gets or sets the reverse volume signature. This represents the signature of the volume on the Source.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public byte[] ReverseVolumeSignature { get; set; }
Public Property ReverseVolumeSignature As Byte()
    Get
    Set
public:
property array<unsigned char>^ ReverseVolumeSignature {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}
member ReverseVolumeSignature : byte[] with get, set

Property Value

Type: Byte
The reverse volume signature.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.VirtualDiskFilename Property

VRAVolumePersistedStateModelVirtualDiskFilename Property
Gets or sets the filename for the virtual disk.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string VirtualDiskFilename { get; set; }
Public Property VirtualDiskFilename As String
    Get
    Set
public:
property String^ VirtualDiskFilename {
    String^ get ();
    void set (String^ value);
}
member VirtualDiskFilename : string with get, set

Property Value

Type: String
The virtual disk filename.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel.VolumeName Property

VRAVolumePersistedStateModelVolumeName Property
Gets or sets the name of the volume.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public string VolumeName { get; set; }
Public Property VolumeName As String
    Get
    Set
public:
property String^ VolumeName {
    String^ get ();
    void set (String^ value);
}
member VolumeName : string with get, set

Property Value

Type: String
The name of the volume.
See Also

Reference

VRAVolumePersistedStateModel Class


VRAVolumePersistedStateModel Methods

VRAVolumePersistedStateModel Methods

The VRAVolumePersistedStateModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VRAVolumePersistedStateModel Class


VraWorkloadCustomizationOptionsModel Class

VraWorkloadCustomizationOptionsModel Class
Vra workload customization options model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsVraWorkloadCustomizationOptionsModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class VraWorkloadCustomizationOptionsModel
Public NotInheritable Class VraWorkloadCustomizationOptionsModel
public ref class VraWorkloadCustomizationOptionsModel sealed
[<SealedAttribute>]
type VraWorkloadCustomizationOptionsModel =  class end

The VraWorkloadCustomizationOptionsModel type exposes the following members.

Constructors
 | Name | Description
Public method | VraWorkloadCustomizationOptionsModel | Initializes a new instance of the VraWorkloadCustomizationOptionsModel class
Top
Properties
 | Name | Description
Public property | NoReplication | Gets or sets a value indicating whether or not to replicate data.
Public property | PowerupReplicaAfterFailover | Gets or sets a value indicating whether or not we should power up the replica after failover.
Public property | ShouldShutdownSource | Gets or sets a value indicating whether or not the source machine should be shutdown during failover.
Public property | UseWin32 | Gets or sets a value indicating whether or not we should include a USEWIN32 in our connect line.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


VraWorkloadCustomizationOptionsModel Constructor

VraWorkloadCustomizationOptionsModel Constructor
Initializes a new instance of the VraWorkloadCustomizationOptionsModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public VraWorkloadCustomizationOptionsModel()
Public Sub New
public:
VraWorkloadCustomizationOptionsModel()
new : unit -> VraWorkloadCustomizationOptionsModel
See Also

Reference

VraWorkloadCustomizationOptionsModel Class


VraWorkloadCustomizationOptionsModel Properties

VraWorkloadCustomizationOptionsModel Properties

The VraWorkloadCustomizationOptionsModel type exposes the following members.

Properties
 | Name | Description
Public property | NoReplication | Gets or sets a value indicating whether or not to replicate data.
Public property | PowerupReplicaAfterFailover | Gets or sets a value indicating whether or not we should power up the replica after failover.
Public property | ShouldShutdownSource | Gets or sets a value indicating whether or not the source machine should be shutdown during failover.
Public property | UseWin32 | Gets or sets a value indicating whether or not we should include a USEWIN32 in our connect line.
Top
See Also

Reference

VraWorkloadCustomizationOptionsModel Class


VraWorkloadCustomizationOptionsModel.NoReplication Property

VraWorkloadCustomizationOptionsModelNoReplication Property
Gets or sets a value indicating whether or not to replicate data.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool NoReplication { get; set; }
Public Property NoReplication As Boolean
    Get
    Set
public:
property bool NoReplication {
    bool get ();
    void set (bool value);
}
member NoReplication : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VraWorkloadCustomizationOptionsModel Class


VraWorkloadCustomizationOptionsModel.PowerupReplicaAfterFailover Property

VraWorkloadCustomizationOptionsModelPowerupReplicaAfterFailover Property
Gets or sets a value indicating whether or not we should power up the replica after failover.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool PowerupReplicaAfterFailover { get; set; }
Public Property PowerupReplicaAfterFailover As Boolean
    Get
    Set
public:
property bool PowerupReplicaAfterFailover {
    bool get ();
    void set (bool value);
}
member PowerupReplicaAfterFailover : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VraWorkloadCustomizationOptionsModel Class


VraWorkloadCustomizationOptionsModel.ShouldShutdownSource Property

VraWorkloadCustomizationOptionsModelShouldShutdownSource Property
Gets or sets a value indicating whether or not the source machine should be shutdown during failover.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool ShouldShutdownSource { get; set; }
Public Property ShouldShutdownSource As Boolean
    Get
    Set
public:
property bool ShouldShutdownSource {
    bool get ();
    void set (bool value);
}
member ShouldShutdownSource : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VraWorkloadCustomizationOptionsModel Class


VraWorkloadCustomizationOptionsModel.UseWin32 Property

VraWorkloadCustomizationOptionsModelUseWin32 Property
Gets or sets a value indicating whether or not we should include a USEWIN32 in our connect line.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool UseWin32 { get; set; }
Public Property UseWin32 As Boolean
    Get
    Set
public:
property bool UseWin32 {
    bool get ();
    void set (bool value);
}
member UseWin32 : bool with get, set

Property Value

Type: Boolean
See Also

Reference

VraWorkloadCustomizationOptionsModel Class


VraWorkloadCustomizationOptionsModel Methods

VraWorkloadCustomizationOptionsModel Methods

The VraWorkloadCustomizationOptionsModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

VraWorkloadCustomizationOptionsModel Class


Weekdays Enumeration

Weekdays Enumeration
The Weekdays.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
[FlagsAttribute]
public enum Weekdays
<FlagsAttribute>
Public Enumeration Weekdays
[FlagsAttribute]
public enum class Weekdays
[<FlagsAttribute>]
type Weekdays
Members
Member name | Value | Description
None | 0 | The none
Sunday | 1 | The Sunday
Monday | 2 | The Monday
Tuesday | 4 | The Tuesday
Wednesday | 8 | The Wednesday
Thursday | 16 | The Thursday
Friday | 32 | The Friday
Saturday | 64 | The Saturday
Weekends | 65 | The weekends
Workdays | 62 | The workdays
All | 127 | All
See Also

Reference

DoubleTake.Web.Models Namespace


WinServiceInfoModel Class

WinServiceInfoModel Class
Service information.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsWinServiceInfoModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public class WinServiceInfoModel
Public Class WinServiceInfoModel
public ref class WinServiceInfoModel
type WinServiceInfoModel =  class end

The WinServiceInfoModel type exposes the following members.

Constructors
 | Name | Description
Public method | WinServiceInfoModel | Initializes a new instance of the WinServiceInfoModel class
Top
Properties
 | Name | Description
Public property | IsInstalled | Gets or sets a value indicating whether or not the service is installed.
Public property | IsRunning | Gets or sets a value indicating whether or not the service is running.
Public property | StartMode | Gets or sets the start mode.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


WinServiceInfoModel Constructor

WinServiceInfoModel Constructor
Initializes a new instance of the WinServiceInfoModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public WinServiceInfoModel()
Public Sub New
public:
WinServiceInfoModel()
new : unit -> WinServiceInfoModel
See Also

Reference

WinServiceInfoModel Class


WinServiceInfoModel Properties

WinServiceInfoModel Properties

The WinServiceInfoModel type exposes the following members.

Properties
 | Name | Description
Public property | IsInstalled | Gets or sets a value indicating whether or not the service is installed.
Public property | IsRunning | Gets or sets a value indicating whether or not the service is running.
Public property | StartMode | Gets or sets the start mode.
Top
See Also

Reference

WinServiceInfoModel Class


WinServiceInfoModel.IsInstalled Property

WinServiceInfoModelIsInstalled Property
Gets or sets a value indicating whether or not the service is installed.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsInstalled { get; set; }
Public Property IsInstalled As Boolean
    Get
    Set
public:
property bool IsInstalled {
    bool get ();
    void set (bool value);
}
member IsInstalled : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WinServiceInfoModel Class


WinServiceInfoModel.IsRunning Property

WinServiceInfoModelIsRunning Property
Gets or sets a value indicating whether or not the service is running.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public bool IsRunning { get; set; }
Public Property IsRunning As Boolean
    Get
    Set
public:
property bool IsRunning {
    bool get ();
    void set (bool value);
}
member IsRunning : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WinServiceInfoModel Class


WinServiceInfoModel.StartMode Property

WinServiceInfoModelStartMode Property
Gets or sets the start mode.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public WinServiceStartModeEnum StartMode { get; set; }
Public Property StartMode As WinServiceStartModeEnum
    Get
    Set
public:
property WinServiceStartModeEnum StartMode {
    WinServiceStartModeEnum get ();
    void set (WinServiceStartModeEnum value);
}
member StartMode : WinServiceStartModeEnum with get, set

Property Value

Type: WinServiceStartModeEnum
See Also

Reference

WinServiceInfoModel Class


WinServiceInfoModel Methods

WinServiceInfoModel Methods

The WinServiceInfoModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WinServiceInfoModel Class


WinServiceStartModeEnum Enumeration

WinServiceStartModeEnum Enumeration
Service start mode

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Management.Web.Client (in DoubleTake.Management.Web.Client.dll) Version: 8.1.0.599 (8.1.0.599)
Syntax
C#
VB
C++
F#
Copy
public enum WinServiceStartModeEnum
Public Enumeration WinServiceStartModeEnum
public enum class WinServiceStartModeEnum
type WinServiceStartModeEnum
Members
Member name | Value | Description
Auto | 0 | Auto
Manual | 1 | Manual
Disabled | 2 | Disabled
DelayedAuto | 3 | Delayed auto
See Also

Reference

DoubleTake.Web.Models Namespace


WorkloadModel Class

WorkloadModel Class
Workload model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsWorkloadModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class WorkloadModel
Public NotInheritable Class WorkloadModel
public ref class WorkloadModel sealed
[<SealedAttribute>]
type WorkloadModel =  class end

The WorkloadModel type exposes the following members.

Constructors
 | Name | Description
Public method | WorkloadModel | Initializes a new instance of the WorkloadModel class
Top
Properties
 | Name | Description
Public property | Id | Gets or sets the workload identifier.
Public property | LogicalRules | Gets or sets the logical replication rules that compose this workload.
Public property | PhysicalRules | Gets or sets the physical replication rules that compose this workload.
Public property | RecoveryImageDataPath | Gets or sets the path to the recovery image data for an image based recovery.
Public property | RecoveryImageId | Gets or sets the image id for an image based recovery.
Public property | RecoverySnapshotSetId | Gets or sets the snapshot set id for an image based recovery.
Public property | Server | Gets or sets the server the workload is hosted on.
Public property | WorkloadTypeName | Gets or sets the name of the workload type.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


WorkloadModel Constructor

WorkloadModel Constructor
Initializes a new instance of the WorkloadModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public WorkloadModel()
Public Sub New
public:
WorkloadModel()
new : unit -> WorkloadModel
See Also

Reference

WorkloadModel Class


WorkloadModel Properties

WorkloadModel Properties

The WorkloadModel type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets or sets the workload identifier.
Public property | LogicalRules | Gets or sets the logical replication rules that compose this workload.
Public property | PhysicalRules | Gets or sets the physical replication rules that compose this workload.
Public property | RecoveryImageDataPath | Gets or sets the path to the recovery image data for an image based recovery.
Public property | RecoveryImageId | Gets or sets the image id for an image based recovery.
Public property | RecoverySnapshotSetId | Gets or sets the snapshot set id for an image based recovery.
Public property | Server | Gets or sets the server the workload is hosted on.
Public property | WorkloadTypeName | Gets or sets the name of the workload type.
Top
See Also

Reference

WorkloadModel Class


WorkloadModel.Id Property

WorkloadModelId Property
Gets or sets the workload identifier.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Guid Id { get; set; }
Public Property Id As Guid
    Get
    Set
public:
property Guid Id {
    Guid get ();
    void set (Guid value);
}
member Id : Guid with get, set

Property Value

Type: Guid
See Also

Reference

WorkloadModel Class


WorkloadModel.LogicalRules Property

WorkloadModelLogicalRules Property
Gets or sets the logical replication rules that compose this workload.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] LogicalRules { get; set; }
Public Property LogicalRules As String()
    Get
    Set
public:
property array<String^>^ LogicalRules {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member LogicalRules : string[] with get, set

Property Value

Type: String
See Also

Reference

WorkloadModel Class


WorkloadModel.PhysicalRules Property

WorkloadModelPhysicalRules Property
Gets or sets the physical replication rules that compose this workload.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public PhysicalRuleModel[] PhysicalRules { get; set; }
Public Property PhysicalRules As PhysicalRuleModel()
    Get
    Set
public:
property array<PhysicalRuleModel^>^ PhysicalRules {
    array<PhysicalRuleModel^>^ get ();
    void set (array<PhysicalRuleModel^>^ value);
}
member PhysicalRules : PhysicalRuleModel[] with get, set

Property Value

Type: PhysicalRuleModel
See Also

Reference

WorkloadModel Class


WorkloadModel.RecoveryImageDataPath Property

WorkloadModelRecoveryImageDataPath Property
Gets or sets the path to the recovery image data for an image based recovery.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string RecoveryImageDataPath { get; set; }
Public Property RecoveryImageDataPath As String
    Get
    Set
public:
property String^ RecoveryImageDataPath {
    String^ get ();
    void set (String^ value);
}
member RecoveryImageDataPath : string with get, set

Property Value

Type: String
See Also

Reference

WorkloadModel Class


WorkloadModel.RecoveryImageId Property

WorkloadModelRecoveryImageId Property
Gets or sets the image id for an image based recovery.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<Guid> RecoveryImageId { get; set; }
Public Property RecoveryImageId As Nullable(Of Guid)
    Get
    Set
public:
property Nullable<Guid> RecoveryImageId {
    Nullable<Guid> get ();
    void set (Nullable<Guid> value);
}
member RecoveryImageId : Nullable<Guid> with get, set

Property Value

Type: Nullable Guid
See Also

Reference

WorkloadModel Class


WorkloadModel.RecoverySnapshotSetId Property

WorkloadModelRecoverySnapshotSetId Property
Gets or sets the snapshot set id for an image based recovery.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public Nullable<Guid> RecoverySnapshotSetId { get; set; }
Public Property RecoverySnapshotSetId As Nullable(Of Guid)
    Get
    Set
public:
property Nullable<Guid> RecoverySnapshotSetId {
    Nullable<Guid> get ();
    void set (Nullable<Guid> value);
}
member RecoverySnapshotSetId : Nullable<Guid> with get, set

Property Value

Type: Nullable Guid
See Also

Reference

WorkloadModel Class


WorkloadModel.Server Property

WorkloadModelServer Property
Gets or sets the server the workload is hosted on.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Server { get; set; }
Public Property Server As String
    Get
    Set
public:
property String^ Server {
    String^ get ();
    void set (String^ value);
}
member Server : string with get, set

Property Value

Type: String
See Also

Reference

WorkloadModel Class


WorkloadModel.WorkloadTypeName Property

WorkloadModelWorkloadTypeName Property
Gets or sets the name of the workload type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string WorkloadTypeName { get; set; }
Public Property WorkloadTypeName As String
    Get
    Set
public:
property String^ WorkloadTypeName {
    String^ get ();
    void set (String^ value);
}
member WorkloadTypeName : string with get, set

Property Value

Type: String
See Also

Reference

WorkloadModel Class


WorkloadModel Methods

WorkloadModel Methods

The WorkloadModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WorkloadModel Class


WorkloadSupportSummaryModel Class

WorkloadSupportSummaryModel Class
Workload support summary model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsWorkloadSupportSummaryModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class WorkloadSupportSummaryModel
Public NotInheritable Class WorkloadSupportSummaryModel
public ref class WorkloadSupportSummaryModel sealed
[<SealedAttribute>]
type WorkloadSupportSummaryModel =  class end

The WorkloadSupportSummaryModel type exposes the following members.

Constructors
 | Name | Description
Public method | WorkloadSupportSummaryModel | Initializes a new instance of the WorkloadSupportSummaryModel class
Top
Properties
 | Name | Description
Public property | Reason | Gets or sets the reason why the workload type is licensed or not.
Public property | ReasonFormatParameters | Gets or sets the reason format parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


WorkloadSupportSummaryModel Constructor

WorkloadSupportSummaryModel Constructor
Initializes a new instance of the WorkloadSupportSummaryModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public WorkloadSupportSummaryModel()
Public Sub New
public:
WorkloadSupportSummaryModel()
new : unit -> WorkloadSupportSummaryModel
See Also

Reference

WorkloadSupportSummaryModel Class


WorkloadSupportSummaryModel Properties

WorkloadSupportSummaryModel Properties

The WorkloadSupportSummaryModel type exposes the following members.

Properties
 | Name | Description
Public property | Reason | Gets or sets the reason why the workload type is licensed or not.
Public property | ReasonFormatParameters | Gets or sets the reason format parameters.
Top
See Also

Reference

WorkloadSupportSummaryModel Class


WorkloadSupportSummaryModel.Reason Property

WorkloadSupportSummaryModelReason Property
Gets or sets the reason why the workload type is licensed or not.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Reason { get; set; }
Public Property Reason As String
    Get
    Set
public:
property String^ Reason {
    String^ get ();
    void set (String^ value);
}
member Reason : string with get, set

Property Value

Type: String
See Also

Reference

WorkloadSupportSummaryModel Class


WorkloadSupportSummaryModel.ReasonFormatParameters Property

WorkloadSupportSummaryModelReasonFormatParameters Property
Gets or sets the reason format parameters.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string[] ReasonFormatParameters { get; set; }
Public Property ReasonFormatParameters As String()
    Get
    Set
public:
property array<String^>^ ReasonFormatParameters {
    array<String^>^ get ();
    void set (array<String^>^ value);
}
member ReasonFormatParameters : string[] with get, set

Property Value

Type: String
See Also

Reference

WorkloadSupportSummaryModel Class


WorkloadSupportSummaryModel Methods

WorkloadSupportSummaryModel Methods

The WorkloadSupportSummaryModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WorkloadSupportSummaryModel Class


WorkloadTypeModel Class

WorkloadTypeModel Class
Workload type model.
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsWorkloadTypeModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class WorkloadTypeModel
Public NotInheritable Class WorkloadTypeModel
public ref class WorkloadTypeModel sealed
[<SealedAttribute>]
type WorkloadTypeModel =  class end

The WorkloadTypeModel type exposes the following members.

Constructors
 | Name | Description
Public method | WorkloadTypeModel | Initializes a new instance of the WorkloadTypeModel class
Top
Properties
 | Name | Description
Public property | IsLicensed | Gets or sets a value indicating whether or not this type of workload is licensed for the server.
Public property | IsPresent | Gets or sets a value indicating whether or not this type of workload is present on the server.
Public property | Name | Gets or sets the workload type name.
Public property | SupportSummary | Gets or sets the summary of the licensing for this workload type.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


WorkloadTypeModel Constructor

WorkloadTypeModel Constructor
Initializes a new instance of the WorkloadTypeModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public WorkloadTypeModel()
Public Sub New
public:
WorkloadTypeModel()
new : unit -> WorkloadTypeModel
See Also

Reference

WorkloadTypeModel Class


WorkloadTypeModel Properties

WorkloadTypeModel Properties

The WorkloadTypeModel type exposes the following members.

Properties
 | Name | Description
Public property | IsLicensed | Gets or sets a value indicating whether or not this type of workload is licensed for the server.
Public property | IsPresent | Gets or sets a value indicating whether or not this type of workload is present on the server.
Public property | Name | Gets or sets the workload type name.
Public property | SupportSummary | Gets or sets the summary of the licensing for this workload type.
Top
See Also

Reference

WorkloadTypeModel Class


WorkloadTypeModel.IsLicensed Property

WorkloadTypeModelIsLicensed Property
Gets or sets a value indicating whether or not this type of workload is licensed for the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsLicensed { get; set; }
Public Property IsLicensed As Boolean
    Get
    Set
public:
property bool IsLicensed {
    bool get ();
    void set (bool value);
}
member IsLicensed : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WorkloadTypeModel Class


WorkloadTypeModel.IsPresent Property

WorkloadTypeModelIsPresent Property
Gets or sets a value indicating whether or not this type of workload is present on the server.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public bool IsPresent { get; set; }
Public Property IsPresent As Boolean
    Get
    Set
public:
property bool IsPresent {
    bool get ();
    void set (bool value);
}
member IsPresent : bool with get, set

Property Value

Type: Boolean
See Also

Reference

WorkloadTypeModel Class


WorkloadTypeModel.Name Property

WorkloadTypeModelName Property
Gets or sets the workload type name.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}
member Name : string with get, set

Property Value

Type: String
See Also

Reference

WorkloadTypeModel Class


WorkloadTypeModel.SupportSummary Property

WorkloadTypeModelSupportSummary Property
Gets or sets the summary of the licensing for this workload type.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public WorkloadSupportSummaryModel SupportSummary { get; set; }
Public Property SupportSummary As WorkloadSupportSummaryModel
    Get
    Set
public:
property WorkloadSupportSummaryModel^ SupportSummary {
    WorkloadSupportSummaryModel^ get ();
    void set (WorkloadSupportSummaryModel^ value);
}
member SupportSummary : WorkloadSupportSummaryModel with get, set

Property Value

Type: WorkloadSupportSummaryModel
See Also

Reference

WorkloadTypeModel Class


WorkloadTypeModel Methods

WorkloadTypeModel Methods

The WorkloadTypeModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WorkloadTypeModel Class


WorkloadTypesActivationStatusModel Class

WorkloadTypesActivationStatusModel Class
Contains information required to get the available workload types by using the activation status of the source and target
Inheritance Hierarchy
SystemObject
DoubleTake.Web.ModelsWorkloadTypesActivationStatusModel

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public sealed class WorkloadTypesActivationStatusModel
Public NotInheritable Class WorkloadTypesActivationStatusModel
public ref class WorkloadTypesActivationStatusModel sealed
[<SealedAttribute>]
type WorkloadTypesActivationStatusModel =  class end

The WorkloadTypesActivationStatusModel type exposes the following members.

Constructors
 | Name | Description
Public method | WorkloadTypesActivationStatusModel | Initializes a new instance of the WorkloadTypesActivationStatusModel class
Top
Properties
 | Name | Description
Public property | Source | Gets or sets the activation status information for the source.
Public property | Target | Gets or sets the activation status information for the target.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DoubleTake.Web.Models Namespace


WorkloadTypesActivationStatusModel Constructor

WorkloadTypesActivationStatusModel Constructor
Initializes a new instance of the WorkloadTypesActivationStatusModel class

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public WorkloadTypesActivationStatusModel()
Public Sub New
public:
WorkloadTypesActivationStatusModel()
new : unit -> WorkloadTypesActivationStatusModel
See Also

Reference

WorkloadTypesActivationStatusModel Class


WorkloadTypesActivationStatusModel Properties

WorkloadTypesActivationStatusModel Properties

The WorkloadTypesActivationStatusModel type exposes the following members.

Properties
 | Name | Description
Public property | Source | Gets or sets the activation status information for the source.
Public property | Target | Gets or sets the activation status information for the target.
Top
See Also

Reference

WorkloadTypesActivationStatusModel Class


WorkloadTypesActivationStatusModel.Source Property

WorkloadTypesActivationStatusModelSource Property
Gets or sets the activation status information for the source.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ActivationStatusModel Source { get; set; }
Public Property Source As ActivationStatusModel
    Get
    Set
public:
property ActivationStatusModel^ Source {
    ActivationStatusModel^ get ();
    void set (ActivationStatusModel^ value);
}
member Source : ActivationStatusModel with get, set

Property Value

Type: ActivationStatusModel
The source.
See Also

Reference

WorkloadTypesActivationStatusModel Class


WorkloadTypesActivationStatusModel.Target Property

WorkloadTypesActivationStatusModelTarget Property
Gets or sets the activation status information for the target.

Namespace: DoubleTake.Web.Models
Assembly: DoubleTake.Web.Client.Management (in DoubleTake.Web.Client.Management.dll) Version: 0.5.41.0 (0.5.41.0)
Syntax
C#
VB
C++
F#
Copy
public ActivationStatusModel Target { get; set; }
Public Property Target As ActivationStatusModel
    Get
    Set
public:
property ActivationStatusModel^ Target {
    ActivationStatusModel^ get ();
    void set (ActivationStatusModel^ value);
}
member Target : ActivationStatusModel with get, set

Property Value

Type: ActivationStatusModel
The target.
See Also

Reference

WorkloadTypesActivationStatusModel Class


WorkloadTypesActivationStatusModel Methods

WorkloadTypesActivationStatusModel Methods

The WorkloadTypesActivationStatusModel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

WorkloadTypesActivationStatusModel Class